Вы находитесь на странице: 1из 406
User Manual - March 2010 - AutoGrid5™ v8 Automated Grid Generator for Turbomachinery NUMERICAL MECHANICS
User Manual - March 2010 - AutoGrid5™ v8 Automated Grid Generator for Turbomachinery NUMERICAL MECHANICS

User Manual

- March 2010 -

AutoGrid5™ v8

Automated Grid Generator for Turbomachinery

User Manual

AutoGrid5™ v8 Documentation v8d

NUMECA International 5, Avenue Franklin Roosevelt 1050 Brussels Belgium

Tel: +32 2 647.83.11 Fax: +32 2 647.93.98 Web: http://www.numeca.com

Contents

CHAPTER 1:

Getting Started

1-1

1-1 Overview

1-1

1-2 Introduction

1-1

What is AutoGrid5™

1-1

Features

1-1

Structured vs. Unstructured

1-2

Approach

1-2

Project Management

1-3

Mesh files

1-3

Template files

1-3

1-3 How To Use This Manual

1-4

Outline

1-4

Conventions

1-4

1-4 First Time Use

1-5

Basic Installation

1-5

Expert Graphics Options

1-5

Graphics Driver

1-5

Background & Foreground Colors

1-6

1-5 How to Start AutoGrid5™ Interface

1-6

1-6 Required Licenses

1-7

Standard AutoGrid5™ License

1-7

Additional Licenses

1-7

CHAPTER 2:

Graphical User Interface

2-1

2-1 Overview

2-1

2-2 Project Selection

2-2

Create New Template/Project

2-2

Open Existing Template/Project

2-3

2-3 Main Menu Bar

2-4

File Menu

2-4

Open Project

2-4

New Project

2-4

Save Project / Save Project As

2-5

Save Template / Save Template As

2-5

Save Grid -> Save Grid As

2-6

Save Grid -> Save Grid As Fine 7.4

2-6

Save Grid -> Save Grid As Fine 8.6

2-6

Save Grid -> Merge Project Grid

2-6

Save Grid -> Save Fluid Domain(s)

2-6

Project List -> Transfer File List

2-6

Project List -> Open File List

2-6

Scripts -> Edit

2-6

Scripts -> Save All

2-7

Scripts -> Execute

2-7

Scripts -> Re-execute Last

2-7

Print -> As PostScript

2-7

Contents

Print -> As Bitmap PostScript

2-7

Print -> As PNG

2-7

Export -> IGES

2-8

Export -> Geometry Selection

2-8

Export -> Geometry Control Points

2-8

Export -> Block Coor

2-8

Export -> Face Coor

2-8

Export -> Patch Coor

2-9

Export -> Plot3D

2-9

Import -> IGG Project

2-9

Prefix

2-10

Importation operations

2-10

Import -> IGG Data

2-10

Import -> External Grid

2-11

Import -> Face Grid

2-11

Import -> Topology

2-12

Import -> CATIA V5

2-12

Import -> Parasolid

2-12

Import -> IGES

2-13

Import -> PLOT3D

2-14

Import -> CGNS

2-15

Import -> GridPro

2-16

Preferences

2-16

Saving Page

2-16

Graphics Page

2-17

Layout Page

2-18

Quit

2-18

Geometry Menu

2-18

View Menu

2-19

Patch Viewer

2-19

Sweep Surfaces

2-20

Coarse Grid

2-21

Repetition

2-22

Face Displacement

2-22

View Depth

2-22

Toggle 3D Solid View

2-23

View/Hide 3D Solid Mesh

2-23

View 3D Solid Block

2-24

Toggle Throughflow Mesh

2-24

Toggle Tool Bar / Symbolic View / Configuration/IGG Panel

2-24

Grid Menu

2-25

Periodicity

2-25

Boundary Conditions

2-26

Patch Browser

2-26

Filters

2-27

Patch Type Specification

2-27

Patch Definition & Editing

2-28

Automatic Connectivity Search

2-28

Manual Connectivity Settings

2-30

Contents

Full Non Matching Connections

2-31

Rotor/Stator Connections

2-33

Grid Quality

2-34

Quality Criterion Definitions (Block Page)

2-36

Quality Criterion Definitions (Boundaries Page)

2-38

Quality Criterion Definitions (FNMB Page)

2-39

Grid Quality Report

2-41

Grid Quality Report (HTML)

2-41

Negative Cells

2-43

Compute All Fnmbs

2-44

Create Face / Create Block

2-44

2-4 Toolbar

2-44

User Mode

2-45

Project Management Icons

2-45

Mesh Generation Buttons

2-45

View & Mesh Quality Management Icons

2-46

Mesh Control Icons

2-46

Contextual Icons

2-47

Row Management Icons

2-47

Blade Management Icons

2-47

Shroud & Hub Gap Management Icons

2-48

2-5 Quick Access Pad

2-48

Rows Definition Subpad

2-50

Project Management Buttons

2-50

Configuration Tree

2-50

Contextual Popup Menu of Tree Items

2-51

Geometry Definition Subpad

2-52

Mesh Control Subpad

2-53

Grid Level Page

2-53

Row Mesh Control Page

2-54

Active B2B Layer Page

2-54

View Subpad

2-55

Geometry Groups Page

2-55

Block Groups Page

2-57

Grid Configuration Page

2-58

Main Project Management

2-59

Duplicate Main Project

2-59

Merge Main Project

2-60

SubProject Management

2-60

Rename SubProject

2-60

Duplicate SubProject

2-61

Save SubProject

2-61

Load SubProject

2-61

Merge SubProject

2-62

Delete SubProject

2-62

Domain Management

2-62

Domain Properties

2-63

Rename Domain

2-63

Contents

Group Domain

2-63

Delete Domain

2-64

Domain Interface Management

2-64

Domain Boundary Properties

2-65

Rename Domain Boundary

2-65

Group Domain Boundaries

2-65

Ungroup Domain Boundaries

2-66

Connect Domain Boundaries

2-66

Interface Viewer

2-68

Export Surfaces

2-68

Grid Page

2-68

2-6 Control Area

2-69

Message Area

2-70

Keyboard Input Area

2-70

Mouse Coordinates

2-70

Information Area

2-70

Grid Parameters Area

2-70

Generation Status Area

2-71

Viewing Buttons

2-72

X, Y & Z Projection Buttons

2-72

Coordinate Axis

2-72

Scrolling

2-72

3D Viewing Button

2-73

Rotate Around X, Y or Z axis

2-73

Zoom In/Out

2-73

Region Zoom

2-73

Fit Button

2-74

Original Button

2-74

Cutting Plane

2-74

2-7 Graphics Area & Views

2-74

Symbolic View

2-75

Meridional View

2-75

Blade to Blade View

2-76

3D View

2-76

View & User Interaction

2-77

2-8 File Chooser

2-77

CHAPTER 3: Meshing Fundamentals

3-1

3-1 Overview

3-1

3-2 Mesh Domain Definition

3-2

Hub & Shroud Definition

3-2

Blade Definition

3-3

Inlet & Outlet Limits

3-3

Technological Effects

3-3

Meridional Technological Effects

3-3

3D Technological Effects

3-3

Cooling & Conjugate Heat Transfer

3-3

Contents

3-3 Geometry Definition

3-4

The ".geomTurbo" File Format

3-4

Channel Format

3-4

Basic Curves

3-5

Channel Curves

3-6

Row(s) Definition Format.

3-6

Row Type

3-7

Row Periodicity

3-7

Blade Definition

3-7

External CAD Format

3-9

3-4 Mesh Generation Steps

3-10

Project Initialization

3-10

Project Setup

3-11

Row Properties

3-12

Periodicity

3-12

Number of Geometry Periodicity

3-12

Row Information

3-12

Hub/Shroud/Shroud Gap Non-Axisymmetric

3-12

Tandem Row

3-13

Full Mesh Generation

3-13

Low Memory Use

3-13

Number of Repetition

3-13

Hub/Shroud Gap (Expert Mode)

3-13

Cell Width

3-13

Mesh Control

3-13

Flow Paths Control

3-14

Blade to Blade Control

3-14

Conformal Mapping

3-15

Blade to Blade Mesh Initialization

3-15

Default (O4H) Blade to Blade Topology

3-15

Grid Points Clustering

3-17

Initial Mesh

3-17

Blade to Blade Mesh Optimization

3-18

Blade to Blade View Control

3-18

Display Update

3-18

Active Layer

3-18

3D Mesh Generation

3-20

Project Persistency

3-20

Create New Project

3-21

Overwrite Existing Project

3-21

Project Library

3-21

Project Info

3-21

Project Files

3-21

Mesh files

3-21

Template files

3-22

Open Project File

3-22

Select Project File

3-22

Project File Library

3-23

Contents

Project Information Area

3-23

3-5 Meshing Similar Geometry & Batch Mode

3-23

CHAPTER 4: Wizard Mode

4-1

4-1 Overview

4-1

4-2 Wizard Mode GUI

4-2

Main Menu Bar

4-2

Toolbar

4-3

User Mode

4-3

Project Management Icons

4-3

Mesh Generation Buttons

4-4

View & Mesh Quality Management Icons

4-4

View Management Icons

4-5

Copy/Paste Row Topology Icons

4-5

Quick Access Pad

4-5

Rows Definition Subpad

4-7

Geometry Definition Subpad

4-7

Mesh Control Subpad

4-7

View Subpad

4-8

4-3 Row Wizard

4-8

Geometry Check

4-9

Machine Characteristics Definition

4-9

Gap/Fillet Definition

4-10

Flow Path Definition

4-10

Blade-to-Blade Mesh Definition

4-11

Initialization End

4-13

MultiStage Management

4-13

Automatic Blade-to-Blade Settings

4-14

Global Settings

4-14

Upstream & Downstream H blocks Definition

4-14

Blade-to-Blade Topology

4-15

High Staggered Topology

4-15

Blade-to-Blade Grid Points

4-15

Throat Control

4-16

Sharp & Rounded Treatment

4-16

B2B Mesh Parameters

4-16

Optimization Parameters

4-16

Machine Dedicated Settings

4-17

Wind Turbine Settings

4-17

Axial Turbine Settings

4-20

Francis Turbine Settings

4-20

Kaplan Turbine Settings

4-21

Inducer Settings

4-21

Axial Compressor Settings

4-22

Centrifugal Impeller Settings

4-22

Radial Diffuser Settings

4-22

Return Channel Settings

4-23

Contents

 

Counter Rotative Fan Settings

4-23

SHF Pump Settings

4-23

Axial Fan Settings

4-24

CHAPTER 5: Geometry Definition

5-1

5-1 Overview

5-1

5-2 Import ".geomTurbo" File

5-1

5-3 Import CAD

5-2

Menu Bar

5-3

File Menu

5-3

Open

5-3

Open IGES

5-4

Export

5-5

Close

5-6

Exit

5-6

Geometry Menu

5-6

Edit Menu

5-6

Geometry Axis

5-6

View Menu

5-6

View Solid

5-6

Select Menu

5-7

Surfaces

5-7

Curves

5-7

Surface List

5-8

Curve List

5-8

Invert Selection

5-9

Hide Selection

5-9

Viewing Buttons

5-9

Quick Access Pad

5-9

Graphics Area Interaction

5-10

Overview

5-10

"Link to

"

Description

5-10

Link to Hub

5-11

Link to Shroud

5-11

Link Non Axi to Hub

5-11

Link Non Axi to Shroud

5-11

Link Non Axi to Shroud Gap

5-11

Link to Nozzle

5-11

Link to Fin Up/Down

5-11

Import Meridional

5-12

Link to 3D Effect

5-12

Link to Blade

5-12

Link to Pressure/Suction Side

5-12

Link to Leading Edge

5-12

Link to Trailing Edge

5-12

Link to Hub Gap

5-12

Link to Shroud Gap

5-12

Contents

Link to Inlet

5-13

Link to Outlet

5-13

Link to Outlet Up

5-13

5-4 Hub/Shroud Edition

5-13

Edit Hub/Shroud

5-13

Non-Axisymmetric Hub/Shroud

5-14

From ".geomTurbo" File

5-15

From Import CAD

5-16

Mesh Generation Control

5-16

5-5 Blade Edition

5-18

Blade Expansion

5-18

Force Blunt at Leading Edge

5-18

Force Blunt at Trailing Edge

5-18

Stick Leading/Trailing Edge

5-18

Apply a Rotation

5-18

Sewing Tolerance

5-19

Expansion at Hub

5-19

Unchanged

5-19

Expand

5-19

Treat blend

5-20

Treat blend with offset

5-20

Expansion at Shroud

5-20

Unchanged

5-20

Expand

5-20

Treat blend

5-20

Treat blend with offset

5-21

Blade Fillet

5-21

Leading/Trailing Edge Wizard

5-23

Control Layers Definition

5-23

Control Layer Limits

5-24

Control Layer Clustering

5-24

Global Layer Control

5-24

Expert Layer Control

5-25

Leading/Trailing Edge Location Definition

5-25

Active Layer

5-26

Edge Location Control.

5-26

Edge Expansion Control

5-27

View B2B & Solid Body

5-27

Sheet on Blade

5-28

Non-Axisymmetric Shroud Gap

5-30

From ".geomTurbo" File

5-31

From Import CAD

5-31

Mesh Generation Control

5-32

5-6 Cascade Configuration

5-33

5-7 Blade Geometry Check

5-34

Check Geometry

5-34

Blade Definition Check

5-34

Streamwise Orientation Check

5-35

Contents

 

Loop Detection - Distance Check

5-35

Loop Detection - Angle Check

5-35

Adapt Geometry

5-36

Data Reduction

5-36

Blade Sections Interpolation Loops

5-36

Blade Rotation

5-37

5-8 Blade Geometry Export

5-37

CHAPTER 6:

Meridional Control

6-1

6-1 Overview

6-1

6-2 Geometry Control

6-1

Basic Curves

6-1

Creation

6-1

Discretization

6-2

Deletion

6-2

Check Geometry

6-2

Hub - Shroud - Nozzle

6-3

Rotor/Stator

6-4

Properties

6-5

Control Points Editing

6-6

Meridional Control Lines

6-6

Creation

6-7

Deletion

6-7

Edition

6-7

Properties

6-7

Specific Cases: Bypass, Fin & Bulb

6-9

Channel Control

6-11

Meridional Curve Checks

6-11

6-3 Mesh Control

6-12

Flow Paths Control

6-13

Flow Paths Manual Editing

6-14

Hub/Shroud Gaps Control

6-16

Blade Fillet

6-16

Bulb Control

6-17

Bypass Control

6-18

Fin Control

6-20

Copy - Merge Distributions

6-20

Conditions of Use

6-21

Representation

6-21

Mesh Quality Checks

6-22

CHAPTER 7:

Blade to Blade Control

7-1

7-1 Overview

7-1

7-2 Blade to Blade Topology Management

7-3

Overview

7-3

Topology Selection

7-3

Contents

Copy/Paste Topology

7-6

7-3 Default Topology (O4H Topology)

7-7

Default Topology Control

7-7

Control Number of Grid Points

7-7

Control Periodic Boundary Condition Type

7-9

Control Skin Mesh Clustering around the Blade

7-9

Grid Point Number Control

7-10

Leading Edge & Trailing Edge Clustering Control

7-10

Move Leading Edge & Trailing Edge Location

7-11

Control Boundary Layer in the Skin Mesh.

7-12

Control Hub/Shroud Gap Mesh

7-13

Blend/Sharp/Rounded Treatment at Leading/Trailing Edge

7-14

Grid Points in Throat

7-15

Wake Control

7-17

Inlet & Outlet Boundary Control

7-18

Relax Inlet & Outlet Clustering

7-18

Blunt at Leading/Trailing Edge

7-20

Topology for High Staggered Blades

7-21

Overview

7-21

High Staggered Blade Topology Optimization

7-22

Grid Points - Periodic Boundary - Gap Control

7-23

Tandem Row

7-24

Main Blade/Splitter Configuration

7-25

Multi-Rows Configuration

7-26

Control Lines & Blade to Blade Mesh.

7-27

Upstream & Downstream Control Lines.

7-28

Control Line on Blade

7-29

Cell Width around Control Line

7-29

Mesh Quality Improvement with Control Line

7-29

Intersection Control Options

7-30

7-4 HOH Topology

7-32

Overview

7-32

HOH Blade to Blade Mesh Control

7-32

Upstream & Downstream Extension Control

7-33

Number of Points Control

7-34

Blade Clustering Control

7-35

Butterfly Mesh Topology for Hub/Shroud Gap

7-36

Hub to Shroud Mesh Control

7-37

Intersection Control Options

7-37

7-5 H&I Topology

7-38

Overview

7-38

H&I Topology Control

7-39

Control Number of Grid Points

7-43

Control Skin Mesh Clustering around the Blade

7-43

Control Hub/Shroud Gap Mesh

7-44

Blend/Sharp/Rounded Treatment at Leading/Trailing Edge

7-44

Inlet & Outlet Boundary Control

7-44

Control Clustering at Projection Points

7-44

Contents

Topology for High Staggered Blades

7-45

Intersection Control Options

7-46

7-6 User Defined Topology

7-47

Geometry Control

7-48

Mesh Control

7-49

Control Layer Page

7-51

Create - Connect Pages

7-51

View Control

7-54

7-7 Blade to Blade Optimization

7-55

Introduction

7-55

Optimization Control

7-55

Optimization Steps

7-56

Skewness Control

7-56

Orthogonality Control

7-57

Wake Control Level

7-58

Multigrid Acceleration

7-59

Non-Matching Control

7-59

Periodic Boundary Optimization

7-59

Multisplitter Control

7-60

Skin Mesh Control

7-60

Advice to Users

7-60

Theoretical Aspect

7-60

CHAPTER 8: 3D Generation

8-1

8-1 Overview

8-1

8-2 Application Field

8-2

8-3 3D Mesh - Interpolation

8-2

3D Blocks Naming

8-3

Row Mesh

8-3

Default Topology - H&I Topology - HOH Topology

8-3

User Defined Topology

8-4

Mesh in Bulb

8-4

Mesh around Nozzle (Bypass)

8-4

Mesh in Meridional Technological Effect

8-4

Mesh in 3D Technological Effect

8-4

3D Boundary Condition Patches

8-4

Generation

8-4

Patch Naming

8-4

Block Order

8-5

Generate Full Mesh

8-5

Number of Mesh Points.

8-5

8-4 Mesh Quality

8-6

8-5 Template & Mesh Files

8-6

Mesh Files

8-7

Template Files

8-7

8-6 B2B Cut

8-7

Edit B2B Cut

8-8

Contents

Delete B2B Cut

8-9

Create B2B Cut

8-9

CHAPTER 9: Meridional Technological Effect

9-1

9-1 Overview

9-1

9-2 Configuration Management

9-2

9-3 Geometry Definition

9-2

The ".geomTurbo" File

9-3

CAD Import

9-3

User Defined

9-3

9-4 Definition of Meridional Mesh

9-4

Start Edition Mode

9-4

Edition Mode

9-5

Geometry Control

9-5

Topology Control

9-6

Create & Modify New Block

9-7

Delete Existing Blocks

9-8

Insert New Control Vertices

9-8

Grid Points Clustering

9-8

Grid Point Number Control

9-8

Automatic Default Topology

9-9

Optimization Steps

9-10

Radial Expansion

9-10

Automatic Detection Tools

9-10

9-5 Connection with Main Blade Channel

9-12

Connection Types

9-12

Multiple Connections

9-13

9-6 3D Generation

9-14

CHAPTER 10:3D Technological Effect

10-1

10-1 Overview

10-1

10-2 Configuration Management

10-1

10-3 Geometry Definition

10-2

External Data File

10-2

CAD Import

10-2

10-4 Edition Mode

10-3

10-5 Topology Management

10-4

3D effect library

10-4

Copy/Paste Feature

10-5

10-6 3D Generation & Persistency

10-6

CHAPTER 11:Cooling & Conjugate Heat Transfer Modules

11-1

11-1 Overview

11-1

11-2 Conjugate Heat Transfer

11-1

Contents

Mesh of Blade Solid Body

11-1

Solid Body Configuration

11-3

Solid Body Configuration (Default)

11-3

Solid Body + Spanwise Holes Configuration

11-3

Solid Body + Cooling Channel Configuration

11-4

Solid Body + Basin Configuration

11-4

Solid Body + Basin + Cooling Channel Configuration

11-4

Solid Body + Cooling Channel Configuration

11-5

Solid Body + Penny Configuration

11-5

Solid Body + Squiller Tip Configuration

11-5

Internal Offset Shape Control

11-6

Parametric Mode

11-6

External ".geomTurbo" File

11-7

External CAD Data File

11-7

Leading/Trailing Edge Wizard

11-8

Basin / Tip Wall / Basin Bottom Wall Definition

11-8

Mesh Generation Control

11-8

Blade to Blade Control

11-9

Internal Cooling Wall Streamwise Distribution.

11-9

Number of Points in O-Mesh (Solid Blade Area)

11-10

Special Configuration: Inserted Cooling Tube

11-10

3D Control

11-12

Mesh of End Wall Solid Body

11-12

Geometry Definition

11-13

Topology Definition

11-13

3D Mesh Generation

11-14

11-3 Cooling - Blade Holes

11-14

Blade Holes Methodology

11-14

Blade Holes Properties

11-16

Geometry Control

11-17

Holes Number Control

11-17

Holes Shape Control

11-17

Holes Location Control

11-18

Parametric Mode

11-18

XYZ Mode (Px,Py,Pz)

11-18

RTHZ Mode (Pr,Pth,Pz)

11-18

Holes Axis Control

11-19

Parametric Mode

11-19

XYZ Mode (Vx,Vy,Vz)

11-19

RTHZ Mode (Pr,Pth,Pz)

11-19

Holes Dimension Control

11-19

Circular Shape

11-19

Rectangular & Oval Shapes

11-19

Trailing Edge Groove Shape

11-20

4-Sided Shape

11-20

Holes Orientation Control

11-20

External Holes Definition File

11-20

Data File for Circular Shape Holes Line

11-20

Contents

Data File for Rectangular Shape Holes Line

11-21

Data File for Oval Shape Holes Line

11-21

Data File for Trailing Edge Groove Holes Line

11-21

Data File for Trailing Edge Circular Holes File

11-22

Data File for 4-Sided Shape Holes Line

11-22

Mesh Control

11-23

Grid Points Distribution

11-23

Optimization Control

11-24

Wake Control

11-25

Mesh Shape Control

11-25

Global Control

11-25

Blade Holes Mesh Generation

11-26

Blade Holes Project Management

11-27

11-4 Cooling - Basin Holes/Separator

11-27

Basin Holes/Separator Methodology

11-28

Basin Holes Properties

11-29

Geometry Control

11-30

Parametric Mode

11-30

XYZ Mode

11-30

External Holes Definition File

11-31

Mesh Control

11-32

Basin Separator Properties

11-33

Basin Holes/Separator Mesh Generation

11-34

11-5 Cooling - End Wall Holes

11-34

End Wall Holes Methodology

11-35

End Wall Holes Properties

11-35

·End Wall Holes Mesh Generation

11-36

11-6 Cooling - Pin Fins

11-37

Pin Fins Properties

11-38

Pin Fins Box Definition

11-38

From IGG™ Edit Mode

11-38

From External Block File

11-38

Pin Fins Lines Definition

11-38

Pin Fins Mesh Generation

11-40

11-7 Cooling - Ribs

11-41

Ribs Properties

11-41

Ribs Box Definition

11-41

From IGG™ Edit Mode

11-42

From 3D View

11-42

Ribs Geometry Control

11-42

Ribs Mesh Control

11-44

Ribs Mesh Generation

11-45

CHAPTER 12:Python Script

12-1

12-1 Overview

12-1

12-2 Running a Script File

12-1

12-3 Commands Description

12-2

Contents

Configuration Commands

12-2

Geometry Import Commands

12-4

Viewing Commands

12-5

NIConfigurationEntities Class Commands

12-6

RowWizard Class Commands

12-6

WindTurbine Class Commands

12-7

B2B Cut Class Commands

12-8

Row Class Commands

12-8

Topology Management

12-9

Row Boundaries Access

12-9

Row Technological Effects 3D Access

12-9

Row Blades Properties

12-9

Row Properties

12-9

Row Hub/Shroud Non-Axisymmetric

12-11

Row Shroud Gap Non-Axisymmetric

12-11

Row Hub/Shroud Solid Mesh

12-11

Flow Paths Control

12-12

Optimization

12-12

Blade Class Commands

12-13

Blade Expansion & Rotation Parameters

12-14

Blunt & Sharp Blade Parameters

12-14

Default Topology Parameters

12-15

Topology Control

12-15

Grid Points Control

12-15

Mesh Control

12-16

Intersection Control

12-17

HOH Topology Parameters

12-17

Topology Control

12-17

Grid Points Control

12-18

Leading Edge Grid Points Distribution Control

12-19

Trailing Edge Grid Points Distribution Control

12-19

Mesh Control

12-20

H&I Topology Parameters

12-20

Topology Control

12-20

Grid Points Control

12-20

Mesh Control

12-21

Cooling - Conjugate Heat Transfer Parameters

12-21

Blade Cooling Holes Control

12-21

Cooling Channel & Basin Control

12-21

Basin Holes & Separator Control

12-22

Pin Fins & Ribs Control

12-22

Gap Class Commands

12-23

Fillet Class Commands

12-23

WizardLETE Class Commands

12-24

Blade Sheet Class Commands

12-25

RSInterface Class Commands

12-26

BasicCurve Class Commands

12-27

StagnationPoint Class Commands

12-27

TechnologicalEffectZR Class Commands

12-27

Contents

TechnologicalEffect3D Class Commands

12-28

Cooling Channel Class Commands

12-28

Hole Class Commands

12-28

Hole Location Control

12-29

Parametric Mode (all hole type excepted grooves)

12-29

XYZ Mode

12-29

RTHZ Mode

12-29

Hole Axis Control

12-30

Parametric Mode (all hole type excepted grooves)

12-30

XYZ Mode (all hole type excepted grooves)

12-30

RTHZ Mode (all hole type excepted grooves)

12-30

Hole Dimension Control

12-30

Circular Shape

12-30

Rectangular/Oval Shape

12-30

Grooves (Parametric Mode)

12-30

Quadrilateral Shape (4-Sided)

12-31

Hole Orientation Control

12-31

HolesLine Class Commands

12-31

External File Control

12-31

Hole Line Geometry Control

12-32

Holes Number

12-32

Hole Shape

12-32

Hole Location

12-32

Hole Axis

12-33

Hole Dimension

12-34

Hole Orientation

12-35

Hole Line Mesh Control

12-35

Grid Points Number

12-35

Optimization

12-35

Wake Control

12-36

Holes Line Mesh Shape Control

12-36

Global Mesh Control

12-36

Basin Class Commands

12-36

Global Parameters

12-36

Hole Parameters

12-36

Basin Hole

12-37

Separator

12-37

Penny

12-37

PinFinsChannel Class Commands

12-37

PinFinsLine Class Commands

12-38

External File Control

12-38

Pin Fins Line Geometry Control

12-38

Pin Fins Number

12-38

Pin Fin Shape

12-38

Pin Fin Location

12-39

Pin Fin Axis Control

12-39

Pin Fin Dimension Control

12-40

Pin Fin Orientation Control

12-40

Pin Fin Mesh Control

12-41

Contents

Grid Points Number

12-41

Optimization

12-41

Wake Control

12-41

Holes Line Mesh Shape Control

12-41

Global Mesh Control

12-42

PinFin Class Commands

12-42

Pin Fin Location

12-42

Parametric Mode

12-42

XYZ Mode

12-42

UV Mode

12-42

Pin Fin Axis Control

12-43

Parametric Mode

12-43

XYZ Mode

12-43

Pin Fin Dimension Control

12-43

Circular Shape

12-43

Rectangular/Oval Shape

12-43

Quadrilateral Shape (4-Sided)

12-43

Pin Fin Orientation Control

12-44

EndWall Class Commands

12-44

End Wall Generation Control

12-44

End Wall Parameters Control

12-44

EndWallHole Class Commands

12-44

Hole Location Control

12-45

XYZ Mode

12-45

MTheta Mode

12-45

Hole Axis Control

12-45

Parametric Mode

12-45

XYZ Mode

12-45

Hole Dimension Control

12-45

Circular Shape

12-45

Rectangular/Oval Shape

12-46

Quadrilateral Shape (4-Sided)

12-46

Hole Dimension Control

12-46

EndWallHolesLine Class Commands

12-46

External File Control

12-46

Hole Line Geometry Control

12-47

Holes Number

12-47

Hole Shape

12-47

Hole Location

12-47

Hole Axis

12-48

Hole Dimension

12-48

Hole Orientation

12-49

Hole Line Mesh Control

12-49

Grid Points Number

12-49

Optimization

12-49

Wake Control

12-50

Holes Line Mesh Shape Control

12-50

Global Mesh Control

12-50

Contents

CHAPTER 1: Getting Started

1-1

Overview

Welcome to the AutoGrid5™ User’s Guide, a presentation of NUMECA’s fully automatic grid gen- erator for turbomachines. This chapter presents the basic concepts of AutoGrid5™ and shows how to get started with the program by describing:

what is AutoGrid5™,

how to use this guide,

how to start AutoGrid5™.

1-2

1-2.1

Introduction

What is AutoGrid5™

AutoGrid5™ is an automatic meshing system for turbomachinery configurations developed to ease pre-processing for numerical computations on such configurations. Pre-processing consists of defining the geometrical description of the to-be-studied model and the discretization (mesh gener- ation) of the to-be-studied domain. The number of computational nodes needed increases rapidly with the detail in the model. For 3D geometries, this easily reaches from 100,000 to 1,000,000 nodes and even higher. This vast number of nodes, along with the description of the complex geometries, necessitates the use of a powerful mesh generator that allows providing a computa- tional mesh with sufficient quality in an automatic way. AutoGrid5™ enables to deal with complex geometries resulting in a structured mesh of high quality.

1-2.2

Features

The advanced tools of AutoGrid5™ enable to create mesh for a large range of gas turbines, fans and compressors:

turbofan, turboprop, turboshaft,

Getting Started

Introduction

turbojet and after burning turbojet,

axial or centrifugal,

single or multistage,

including or not bulbs on the hub,

with one or multiple splitter blades (centrifugal),

with hub or shroud clearances,

with bypass,

with seal leakages,

with meridional or 3D technological effects.

1-2.3

Structured vs. Unstructured

Depending on the geometry complexity, the user should define the requested mesh type: structured or unstructured. Structured meshes are to be preferred for reasons of accuracy in cases of aligned flow even if their generation can sometimes be difficult and cumbersome. Unstructured meshes can be easily generated independently of the geometrical complexity and owing to their nature gener- ally tend to generate less points than in the structured case. For turbomachinery design, because of a request of high accuracy, it is recommended to use AutoGrid5™ which enables to provide adapted structured meshes.

Users requiring an unstructured mesh may consider the use of the NUMECA automatic hexahedral mesh generation software Hexpress™.

1-2.4

Approach

To obtain fully automatic or semi-automatic grids with an optimal quality control, AutoGrid5™ takes advantage of the characteristics of turbomachinery configurations by creating blade to blade grids onto surfaces of revolution. The generation based on a conformal mapping between the 3D Cartesian space (XYZ coordinates) and the cylindrical surfaces of the 2D blade to blade space (dm/ r-θ plane) follows 4 main steps:

1. Definition of the geometry:

The blade surface description.

The curves for the definition of the hub and shroud surfaces of revolution.

The additional data needed to handle special features such as splitters, meridional or 3D technological effects.

2. Generation of meridional flow paths. These flow paths define the meridional trace of the sur- faces of revolution on which the 3D mesh will be built.

3. Generation and control of 2D meshes on spanwise surfaces. This 2D generation enables the user to control the mesh topology, the grid clustering and the mesh orthogonality along the solid walls.

4. Generation of the final 3D mesh. This generation combines the meridional flow paths and the 2D blade to blade meshes to create the mesh on surfaces of revolution. The use of the conformal mapping between the 3D Cartesian space and the 2D blade to blade space ensures conservation of quality in terms of orthogonality and clustering for each axisymmetric surface mesh.

The settings used to create a mesh are controlled interactively through dialog boxes. At the end of the grid generation process, all the parameters can be saved in a template file (".trb"). Meshes for similar geometries can be created automatically using this file.

Introduction

Getting Started

1-2.5

Project Management

To manage complete mesh generation, AutoGrid5™ integrates the concept of project. An AutoGrid5™ project involves template files and mesh files:

a) Mesh files

The mesh files contains the multiblock mesh topology, geometry, grid points, patch grouping and the boundary condition types:

new_prefix.bcs: boundary conditions files

new_prefix.cgns: grid points files (CGNS format)

new_prefix.geom and new_prefix.xmt_txt (.X_T): geometry files

new_prefix.igg: topology file

new_prefix.qualityReport: mesh quality report file

new_prefix.config: mesh configuration file used for the grouping in FINEGUI and for the subProject (more details in FINEUser Manual)

These files can be loaded into the structured multiblock grid generation system IGGand by the CFD integrated environment FINE/Turbo.

The mesh quality file is saved at the end of the grid generation. If the new project has not yet been saved before launching the 3D generation, no grid quality report file will be saved because the system is not able to determine automatically the file location.

b) Template files

The template files contain the parameters and the geometry needed to reproduced the mesh with

AutoGrid5:

new_prefix.geomTurbo and new_prefix.geomTurbo.xmt_txt (.geomTurbo.X_T): the geometry files (geomTurbo format)

new_prefix.trb: the template file containing the grid generation parameters.

new_prefix.info: the information file

new_prefix_b2b.png: a picture of the blade to blade view

new_prefix_merid.png: a picture of the meridional view

• new_prefix_merid.png: a picture of the meridional view FIGURE 1.2.5-1 Example of file management for an

FIGURE 1.2.5-1 Example of file management for an AutoGrid5™ project

Getting Started

How To Use This Manual

1-3

1-3.1

How To Use This Manual

Outline

This manual consists of four distinct parts:

Chapters 1and 2: Introduction and description of the interface,

Chapter 3: Mesh fundamentals,

Chapter 4: Mesh generation wizard,

Chapters 5 to 8: Mesh generation and parameters,

Chapters 9 and 10: Meridional and 3D technological effects.

Chapter 11: Cooling & Conjugate Heat Transfer Modules.

Chapter 12: Script within AutoGrid5™.

At first time use of AutoGrid5™ it is recommended to read this first chapter carefully and certainly section 1-4 to section 1-6. Chapters 2, 3 and 4 give a general overview of the AutoGrid5™ interface and the way to manage a project. For every mesh generation, the input parameters can be defined as described in the Chapters 5 to 8. Chapters 9 and 10 give an overview of how to add technological effects in the Meridional or in the 3D view. Chapter 11 is describing how to define cooling holes, basin, cooling channel with pin fins/ribs and to mesh the solid body (blade and end walls). Chapter 12 is presenting python commands available within AutoGrid5™.

1-3.2

Conventions

Some conventions are used to ease information access throughout this guide:

Commands to type in are in italic.

Keys to press are in italic and surrounded by <> (e.g.: press <Ctrl>).

Names of menu or sub-menu items are in bold.

Names of buttons that appear in dialog boxes are in italic.

Numbered sentences are steps to follow to complete a task. Sentences that follow a step and are preceded with a dot (•) are substeps; they describe in detail how to accomplish the step.

The hand indicates an important note.

The pair of scissors indicates a keyboard shortcut.

The pair of scissors indicates a keyboard shortcut. A light bulb in the margin indicates a

A light bulb in the margin indicates a section with a description of expert parameters.

First Time Use

Getting Started

1-4

1-4.1

First Time Use

Basic Installation

When using AutoGrid5™ for first time it is necessary that AutoGrid5™ is properly installed according to the installation note. The installation note provided with the installation software should be read carefully and the following points are specifically important:

Hardware and operating system requirements should be verified to see whether the chosen machine is supported.

Installation of AutoGrid5™ according to the described procedure in a directory chosen by the user and referenced in the installation note as ‘NUMECA_INSTALLATION_DIRECTORY’.

A license should be requested that allows for the use of AutoGrid5™ and the desired compo- nent and modules (see section 1-6 for all available licenses). The license should be installed according to the described procedure in the installation note.

Each user willing to use AutoGrid5™ or any other NUMECA software must perform a user configuration as described in the installation note.

When these points are checked the software can be started as described in the installation note or section 1-5 of this users guide.

in the installation note or section 1-5 of this users guide. 1-4.2 Expert Graphics Options a)

1-4.2

Expert Graphics Options

a) Graphics Driver

The graphics area of AutoGrid5™ interface uses by default an OPENGL driver that takes advan- tage of the available graphics card. When the activation of OPENGL is causing problems, AutoGrid5™ uses an X11 driver (on UNIX) or MSW driver (for Windows) instead.

It is possible to explicitly change the driver used by FINE™ in the following ways:

On UNIX:

in csh, tcsh or bash shell:

setenv NI_DRIVER X11 in korn shell:

NI_DRIVER=X11

export NI_DRIVER

The selection will take effect at the next session.

On Windows:

Log in as Administrator.

Launch regedit from the Start/Run menu.

Go to the HKEY_LOCAL_MACHINE/SOFTWARE/NUMECA International/Fine# or autog- rid# register.

Modify the DRIVER entry to either OPENGL or MSW.

The selection will take effect at the next session.

Getting Started

How to Start AutoGrid5™ Interface

b) Background & Foreground Colors

The background color of the graphics area can be changed by setting the environment variable NI_IGG_REVERSEVIDEO on UNIX/LINUX platforms or IGG_REVERSEVIDEO on Windows platforms. Set the variable to ’ON’ to have a black background (white axis) and set it to ’OFF’ to have a white background (black axis). The variable can be manually specified through the follow- ing commands:

On UNIX:

in csh, tcsh or bash shell:

setenv NI_IGG_REVERSEVIDEO ON

in korn shell:

NI_IGG_REVERSEVIDEO=ON export NI_IGG_REVERSEVIDEO

The selection will take effect at the next session.

On Windows:

Log in as Administrator.

Launch System Properties from the Start/Settings/Control Panel/System menu.

Go in the Environment Variables.

Modify or add the IGG_REVERSEVIDEO entry to either ON or OFF.

The selection will take effect at the next session.

Furthermore, the background and foreground colors of the graphics area can be adapted through File/Preferences menu available within IGGin the Colors page.

1-5

How to Start AutoGrid5™ Interface

In order to run AutoGrid5™, the following command should be executed:

On UNIX and LINUX platforms type: igg -niversion # -autogrid5 <Enter>

On Windows platforms:

1. click on the IGG icon in Start/Programs/NUMECA software/Fine# or in Start/Programs/ NUMECA software/autogrid#. Then AutoGrid5™ is accessible through the menu Modules/

AutoGrid5.

2. alternatively AutoGrid™ can be launched from a dos shell by typing:

<NUMECA_INSTALLATION_DIRECTORY>\Fine#\bin\igg.exe <Enter> or

<NUMECA_INSTALLATION_DIRECTORY>\autogrid#\bin\igg.exe <Enter>

where NUMECA_INSTALLATION_DIRECTORY is the directory indicated in section 1-4.1. Then AutoGrid5™ is accessible through the menu Modules/AutoGrid5.

Required Licenses

Getting Started

1-6

1-6.1

Required Licenses

Standard AutoGrid5™ License

The standard license for AutoGrid5™ allows for the use of all basic features of AutoGrid5™ including:

CAD importation and geometry management (except CATIA v5),

single row and multistage management,

skin, HOH and H&I blade-to-blade topology management,

wind turbine mesh wizard,

introduction of blade to blade cut,

no meridional technological effect,

no 3D technological effect,

no solid mesh, cooling channel, holes, pin fins and ribs.

1-6.2

Additional Licenses

Within AutoGrid5™ the following features are available that require a separate license:

CATIA v5 importation,

introduction of bypass configuration,

introduction of meridional technological effect,

user-defined blade-to-blade topology management,

introduction of 3D technological effect,

introduction of solid mesh, cooling channel, holes, pin fins and ribs.

Next to AutoGrid5™ other products are available that require a separate license:

FINE™/Turbo (structured mesh generator - solver - visualization software),

FINE™/Design 3D (3D inverse design),

Hexpress™ (unstructured mesh generator),

FINE™/Hexa (unstructured mesh generator - solver - visualization software),

FINE™/Marine (unstructured mesh generator - solver - visualization software).

Getting Started

Required Licenses

CHAPTER 2: Graphical User Interface

2-1

Overview

When launching AutoGrid5™ as described in Chapter 1 the interface appears in its default layout as shown in Figure 2.1.0-1. An overview of the complete layout of the AutoGrid5™ Expert Mode interface (see Chapter 4 for AutoGrid5™ Wizard Mode interface) is shown on the next page in Figure 2.1.0-2. In the next sections the items in this interface are described in more detail.

the items in this interface are described in more detail. FIGURE 2.1.0-1 AutoGrid5 ™ Expert Mode

FIGURE 2.1.0-1 AutoGrid5Expert Mode Interface.

Together with the AutoGrid5interface, a Open Turbo Project Wizard window is opened, which allows to open an existing project. See section 2-2.2 for description of this window.

Graphical User Interface

Project Selection

A File Chooser window is available for browsing through the file system and to select a file. More detail on the File Chooser window is given in section 2-8.

Menu bar

(section 2-3) Toolbar (section 2-4) Graphics area (section 2-7) Quick Access Pad (section 2-5) Viewing
(section 2-3)
Toolbar
(section 2-4)
Graphics area
(section 2-7)
Quick Access Pad
(section 2-5)
Viewing Buttons
Message area
KeyBoard Input Area
Mouse coordinates
Information area
Generation Status
Control area

Grid parameters area

(section 2-6)

FIGURE 2.1.0-2 AutoGrid5Graphical User Interface (Expert Mode)

2-2

Project Selection

Together with the AutoGrid5interface, a Open Turbo Project Wizard window is opened, which allows to open an existing template with or without the corresponding mesh. See section 2-2.2 for description of this window. After use of this window it is closed. To create or open a template or a project is also possible using the File menu.

2-2.1

Create New Template/Project

To create a new template or project when launching the AutoGrid5™ interface:

1. close the Open Turbo Project Wizard window.

Project Selection

Graphical User Interface

2. select File/New Project or click on the New Project icon ( which allows to confirm. Click yes to confirm.

icon ( which allows to confirm. Click yes to confirm. ). A new window will appear,
icon ( which allows to confirm. Click yes to confirm. ). A new window will appear,

). A new window will appear,

3. A project initialization window appears to assign a geometry to the new project. There are five possibilities:

to start a new project presenting a bypass (if license key) from scratch.

to start a new project presenting a bypass and a fin on fan (if license key) from scratch.

to start a new project presenting no bypass and no fin on fan from scratch.

to start a new project presenting a cascade configuration from scratch.

to initialize a new project from an existing ".geomTurbo" file. Then a File Chooser window is available for browsing through the file system and to select a file. When clicking on OK (Open) the geometry is loaded in AutoGrid5™.

on OK ( Open ) the geometry is loaded in AutoGrid5™. 2-2.2 Open Existing Template/Project If

2-2.2

Open Existing Template/Project

If the Open Turbo Project Wizard window is closed, select File/Open Project. A new window will appear, which allows to confirm. Click yes to confirm.

appear, which allows to confirm. Click yes to confirm. To open an existing project the following

To open an existing project the following possibilities are available in the Open Turbo Project Wiz- ard window:

Click on the icon Select a Project File. A File Chooser will appear that allows to browse to the location of the existing template. Automatically the filter in the File Chooser is set to display only the files with extension ".trb", the default extension for a template file. If the option Load Mesh is active, the corresponding mesh will also be loaded.

Select a Project in the List by left clicking on it, this list contains all projects available in the local AutoGrid5™ library. To view all information on the selected template, click on Info>>. To remove the selected template from the list, click on Hide. To open the selected template click on Open Template or double-click on the selected template. To open the selected project (the template with the corresponding mesh) click on Open Project.