Вы находитесь на странице: 1из 67
Cisco Expo 2010 Cisco IOS XR Обзор операционной системы Китаев Алексан др,

Cisco Expo

2010

Cisco Expo 2010 Cisco IOS XR Обзор операционной системы Китаев Алексан др,

Cisco IOS XR Обзор операционной системы

Китаев Александр, системный инженер Cisco alkitaev@cisco.com

Программа

Обзор Cisco IOS XR

Краткий экскурс в историю Требования к современным NOS Аппаратные платформы

Архитектурные особенности IOS XR

Интерфейсы управления IOS XR Обзор методов управления Использование CLI в IOS XR Примеры конфигураций IOS XR

Расширенные функции IOS XR Local Packet Transport Service (LPTS) Routing Policy Language (RPL)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

2

Введение Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights reserved. Cisco Public

Введение

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

3

Историческая справка

Историческая справка Декабрь1984 года Двое ученых из Стенфордского

Декабрь1984 года

Двое ученых из

Стенфордского университета

Len Bosack и Sandy Lerner

создают компанию – Cisco Systems

Cisco Systems Corporate Timeline http://newsroom.cisco.com/dlls/timeline/

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

4

Историческая справка

Июль 1986 года

Компания Cisco Systems выпускает на рынок устройство под

названием Advanced Gateway Server (AGS), которое работает под управлением программного обеспечения версии 5.0, которое в

последствие назовут Cisco IOS

в последствие назовут Cisco IOS Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

5

Историческая справка

Реализация IOS выполнена примерно для

80 аппаратных платформ!

Поддерживаемые сетевые протоколы:

DECnet, AppleTalk, Apollo Domain, Novell IPX, Banyan VINES, IBM SNA, TCP/IP и т.д.

Успешно работает уже более 20 лет и продолжает развиваться!

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

http://www.cisco.com/go/ios Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights reserved. Cisco Public 6

Cisco Public

6

Тенденции в развитии сетей

Появление новых приложений и сервисов

Рост трафика и количества пользователей

Увеличение скоростей передачи

Рост производительности процессоров и

объемов оперативной памяти

Повсеместный переход на использование протоколов IPv4/IPv6

Переход от эксплуатации нескольких

специализированных сетей к одной

мультисервисной

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

7

Требования к операторским NOS

Время сходимости

Масштабируемость

Доступность

Отказоустойчивость оборудования Обнаружение сбоев Восстановление после сбоев

Микроядерная архитектура

Обновление программного обеспечения

Безопасность

Внедрение новых сервисов

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

8

Аппаратные платформы IOS XR

92 Tbps / 322 Tbps

6,4 Tbps CRS-1/CRS-3 4/8/16 слотов MSS до 72 LCC
6,4 Tbps
CRS-1/CRS-3
4/8/16 слотов
MSS до 72 LCC

ASR 9006, ASR 9010

40 Gbps
40 Gbps

XR 12404/12406/12410/12416 GSR 12006/12010/12016/12810/12816

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

9

Архитектурные особенности IOS XR Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights

Архитектурные особенности IOS XR

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

10

Сравнение архитектур NOS

IOS

Control Plane Applications Forwarding Plane Applications Network Stack System Forward Infrastructure Infrastructure
Control Plane Applications
Forwarding Plane Applications
Network Stack
System
Forward
Infrastructure
Infrastructure
OS Scheduler
Management Plane Applications
HA Infrastructure

IOS XR

Control Plane Data Plane Management Plane Control Plane Data Plane Management Plane Control Plane Data
Control Plane
Data Plane
Management Plane
Control Plane
Data Plane
Management Plane
Control Plane
Data Plane
Management Plane
Checkpoint DB
Multicast IPC
System DB
Distributed Infrastructure
Scheduler
Synch. Services
IPC Mech
Memory Mgmt
BGB
RIP
ISIS
OSPF
Routing
PIM
IGMP
RIB
L2 Drivers
ACL
FIB
QoS
LPTS
Host Service
PFI
Interface
CLI
SNMP
XML
Netflow
Alarm
Per.fMgmt
SSH
SSH
SSH

Kernel System Services

Монолитное ядро

Централизованная инфраструктура

Интегрированный сетевой стэк

Приложения централизованы

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

XR © 2010 Cisco and/or its affiliates. All rights reserved.  Микроядро  Распределенная

Микроядро

Распределенная инфраструктура

Независимый сетевой стэк

Распределенные приложения

Cisco Public

11

Ключевые особенности IOS XR

Модульность обновление ПО без перезагрузки устройства

Масштабируемость поддержка мульти-шасси (CRS)

Платформо-независимость POSIX совместимость

Высокая доступность резервирование и перезапуск процессов

Безопасность разделение информационных потоков (planes)

Логические маршрутизаторы (SDR) разделение ресурсов

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

12

Архитектура IOS XR

IOS XR состоит из:

ОС на базе микроядра (ОСРВ - QNX Neutrino):

защита памяти, взаимодействие между процессами, вытесняющая многозадачность

Вся базовая функциональность ОС и функции

маршрутизатора реализованы в виде «процессов»

Каждый процесс выполняется в своем защищенном адресном пространстве

Сервисы P Microkernel C Threads O S I X Scheduling I Debug S Timers C
Сервисы
P
Microkernel
C Threads
O
S I X
Scheduling
I
Debug
S Timers
C
O

Распределенная обработка

Файловая система

Обмен сообщениями

Обработка событий

Очереди сообщений

Синхронизация процессов

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

13

Управление процессами

Процесс (Process)

Исполняемая часть кода, выполняемая в отдельном адресном пространстве

Поток (Thread)

Один процесс может состоять из одного или более потоков Поток является дочерней сущностью, которая управляется и контролируется родительским процессом

Например, OSPF имеет поток, который обрабатывает ‘hello’

пакеты (обеспечивает прием и передачу)

Поток может выполняться только тогда, когда родительский процесс получил квант времени для выполнения от системного диспетчера (system scheduler).

Процесс с несколькими потоками называется многопоточным

(multi-threaded)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

14

Управление процессами

Job ID# (JID)

Каждый процесс при первом запуске получает свой номер – JID, который не меняется при перезапуске или остановке процесса

Process ID# (PID)

Каждому процессу при первом запуске также присваивается PID. PID будет изменяться при остановке или перезапуске процесса

Thread ID# (TID)

Если процесс создает потоки, то каждому потоку присваивается свой идентификатор (TID)

Dynamic Link Libraries (DLL)

Процессы могут использовать в своей работе динамические библиотеки (DLL) – позволяя более эффективно использовать код. Процессы будут динамический загружать библиотеки в процессе работы по мере необходимости

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

15

Управление процессами

Посмотреть информацию о процессах

show process

Перезапустить процесс

process restart <process name | number> <option>

Мониторинг процессов и потоков

monitor processes monitor threads (top)

Поиск неисправностей

show exception dumpcore show context, clear context

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

16

IOS XR Взаимодействие процессов

Обмен сообщениями с помощью механизма Inter-Process Communication (IPC)

SysDB ISIS NetIO OSPF BGP RIB IF mgr FIB… микроядро
SysDB
ISIS
NetIO
OSPF
BGP
RIB
IF mgr
FIB…
микроядро
NetIO OSPF BGP RIB IF mgr FIB… микроядро Изолированные, перезапускаемые

Изолированные, перезапускаемые процессы

перезапускаемые процессы ―ОС‖ управление процессами Cisco

―ОС‖

перезапускаемые процессы ―ОС‖ управление процессами Cisco IOS XR ©

управление процессами

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

17

Распределенная обработка (control plane)

BGP BGP MPLS Multicast IS-IS RESILIENT SYSTEM PROCESS DISTRIBUTION RP1 RP2 RP3 RP4 RPn
BGP
BGP
MPLS
Multicast
IS-IS
RESILIENT
SYSTEM PROCESS
DISTRIBUTION
RP1
RP2
RP3
RP4
RPn

Протоколы маршрутизации и сигнальные протоколы

могут быть запущены на одном или нескольких (D)RP

Каждый активный (D)RP может резервироваться запасным (standby (D)RP)

Распределение процессов по D(RP)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

18

Архитектура маршрутизации

RP

Policy

Repository

Routing Protocols

BGP

OSPF

ISIS

Static

Route/Label Databases

Connected

LSD

RIB

Infra Intf. RSI Mgmt Config Check Mgr/ point IP Addr SysDB Mgmt
Infra
Intf.
RSI
Mgmt
Config
Check
Mgr/
point
IP Addr
SysDB
Mgmt
Инфраструктура BCDL (GSP)
Инфраструктура BCDL (GSP)

LC

FIB

LC

FIB

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

19

Распределенная обработка (forwarding plane)

RP IP IM Netflow Stack Drivers VLAN PPP ARP FIB Global IDB & AIB CPU
RP
IP
IM
Netflow
Stack
Drivers
VLAN
PPP
ARP
FIB
Global
IDB & AIB
CPU
Switching Fabric
CPU
LC
LC
LC-CPU RP IM VLAN PPP Global Int. Mgr. ARP HDLC Netflow CPU Ingress FIB Ingress
LC-CPU
RP
IM
VLAN
PPP
Global
Int. Mgr.
ARP
HDLC Netflow
CPU
Ingress
FIB
Ingress
Egress
AIB &
IDB
FIB
Switching Fabric
CPU
Egress
AIB & IDB
LC
LC

Одноэтапная передача пакета:

Одна глобальная Adjacency Information Base (AIB), распределена по всем LC

Одна глобальная Interface Management

DB распределена по всем LC

Используется только FIB входящей LC - решение на передачу принимает RP

Двухэтапная передача пакета:

У каждой LC есть своя AIB только для своих интерфейсов

У каждой LC своя Interface DB для своих интерфейсов

Использование FIB таблиц входящей и выходящей LC позволяют картам выполнять передачу пакетов самостоятельно

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

21

Высокая доступность в IOS XR

ISSU
ISSU
Non-Stop Forwarding (NSF)
Non-Stop Forwarding
(NSF)
Раздельные плоскости управления и коммутации
Раздельные плоскости
управления и коммутации
Резервирование RP/DRP Переключение Active/Standby
Резервирование RP/DRP
Переключение Active/Standby
Перезапускаемость процессов: Сохранение конфигурации
Перезапускаемость процессов: Сохранение конфигурации

Все подсистемы: Изолированные адресные пространства

Сбой памяти – отказ только 1 процесса, восстановление перезапуском

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

22

Отказоустойчивость на уровне процессов

Hot Process A Process A Check Check Point Point Warm Process B Process B Server
Hot
Process A
Process A
Check
Check
Point
Point
Warm
Process B
Process B
Server
Server
Cold
Process C
Process C
ACTIVE RP
STANDBY RP

Выбор типа отказоустойчивости (hot/warm/cold) зависит от реализации того или иного процесса

Process A: HOT standby: данные о состоянии постоянно синхронизируются через сервер с резервным процессом

Process B: Warm standby: данные о состоянии получаются от сервера в момент перехода процесса в рабочее состояние (GoActive)

Process C: Cold standby: процессу ничего не надо от сервера

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

23

Модульность IOS XR

MPLS

MPLS, UCP

Multicast

PIM, MFIB, IGMP

Security

IPSec, Encryption, Decryption

Manageability

ORB, XML, Alarms management

Routing:

RIB, BGP, ISIS, OSPF, RPL

Forwarding

Platform independent FIB, ARP, QoS, ACL, etc

Base

Interface manager, System database, checkpoint services Configuration management, etc.

Line Card

Platform Dependent LC ucode & drivers

Admin

Fabric, Chassis, etc. Administrative tasks

OS:

Kernel, file system, memory management, and other slow changing core

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

24

Модульность IOS-XR

Возможность независимо обновить

MPLS, Multicast или протоколы

маршрутизации

Возможность выполнять разные версии ПО на разных узлах

Возможность собрать из модулей свой набор ПО

Не использовать на устройстве не требующуюся в данный момент функциональность (Multicast, MPLS, IPSEC)

MPLS
MPLS
Multi- cast
Multi-
cast
RPL BGP Routing Composite OSPF ISIS
RPL
BGP
Routing
Composite
OSPF
ISIS
Manageability Security Host Forwarding Composite Base IOX Admin OS
Manageability
Security
Host Forwarding
Composite Base
IOX Admin
OS
Line card

Line card

Line card
Line card

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

25

Логические маршрутизаторы (SDR)

Система логически разделяется

на части (на уровне слотов)

Каждый SDR должен иметь в своем составе как минимум один RP

Каждый SDR имеет свои собственные RIB и FIB

Каждый SDR имеет свой собственный интерфейс управления

Ресурсы коммутационной матрицы

разделяются между всеми SDR

Поддержка Multi Chassis

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

Поддержка Multi Chassis Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights reserved. Cisco

26

Интерфейсы управления в IOS XR Cisco IOS XR © 2010 Cisco and/or its affiliates. All

Интерфейсы управления в IOS XR

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

27

Интерфейсы управления в IOS XR

Архитектура управления IOS XR

Различия в конфигурировании IOS и IOS XR

Именование устройств в IOS XR

Основные особенности CLI в IOS XR

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

28

Архитектура управления в IOS XR

―Industry Standard‖ Object Model External EMS Fault Configuration Accounting Performance Security XML
―Industry Standard‖ Object Model
External EMS
Fault
Configuration
Accounting
Performance
Security
XML
―Standards Derived‖ Object Model
Craft Works
RP
Interface
CLI
SNMP
XML
XML
Agent
Agent
Agent
Object Request Broker
ACL, QoS,
Alarm and
Perf and
Test/
Inventory
Routing
IF
MPLS
Log
Accounting
Diagnostic
Agent
Agent
Agent
Agent
Agent
Agent
Agent
Common APIs to the rest of HFR S/W
DRP
RP/Shelf Control
Shelf Control
Line Card
Fabric Card
Netflow

Модель представления данных не зависит от способа доступа CLI, SNMP или XML

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

29

Craft Works Interface (CWI)

Craft Works Interface (CWI)  Графический интерфейс Настройка интерфейсов

Графический интерфейс

Настройка интерфейсов

Протоколы: BGP, ISIS, OSPF, TE

Проверка конфигурации перед активацией

Редактор конфигураций

Поддержка SSH/Telnet

Вид лицевой панели

Просмотр информации об авариях (alarms)

информации об авариях (alarms) Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

30

30

Различия в настройке IOS XR и IOS

IOS XR

IOS

Изменения конфигурации НЕ вступают в действие после нажатия <CR>

Изменение конфигурации немедленно вступают в действие после нажатия <CR>

Изменения конфигурации должны быть

 

подтверждены ‘committed’ до того как они

Ничего подтверждать не нужно

вступят в действие (активируются)

Выполняется базовая проверка изменений до их активации

Никаких проверок не выполняется

2х этапная модель конфигурирования

Не доступно

Откат выполненных изменений

Не доступно

Функционально-ориентированное конфигурирование (feature centric)

Интерфейсо-ориентированное конфигурирование (interface centric)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

31

IOS XR CLI: Именование устройств

Новый CLI отражает расположение оборудования в

системе

Применяется иерархический подход при именовании

Каждая линейная карта имеет следующий идентификатор:

Shelf/Slot/cpu #

Интерфейсы именуются так: Shelf/Slot/Bay/Interface

При настройке протоколов указывается тип адресного пространства (address family type) v4/v6

пространства (address family type) – v4/v6 RP/0/0/CPU0:Router-1#show ipv4 interface brief Interface
RP/0/0/CPU0:Router-1#show ipv4 interface brief Interface Protocol MgmtEth0/0/CPU0/0 MgmtEth0/0/CPU0/1 MgmtEth0/0/CPU0/2

RP/0/0/CPU0:Router-1#show ipv4 interface brief

Interface Protocol

MgmtEth0/0/CPU0/0

MgmtEth0/0/CPU0/1

MgmtEth0/0/CPU0/2

MgmtEth0/0/CPU0/0 MgmtEth0/0/CPU0/1 MgmtEth0/0/CPU0/2 GigabitEthernet0/2/0/0 IP-Address Status 10.23.1.69

GigabitEthernet0/2/0/0

IP-Address

Status

10.23.1.69

Up

Up

unassigned

Shutdown

Down

unassigned

Shutdown

Down

100.12.1.1

Up

Up

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

32

IOS XR CLI: Именование устройств

Обозначение физических устройств в системе

Используется при выполнении эксплуатационных операций.

Обычно указывается в параметре location

RP/0/RP0/CPU0:R1(admin)#show platform Node Type PLIM State Config State
RP/0/RP0/CPU0:R1(admin)#show platform
Node
Type
PLIM
State
Config State
-----------------------------------------------------------------------------
0/1/SP
MSC(SP)
0/1/CPU0
N/A
Jacket Card
PWR,NSHUT,MON
MSC
PWR,NSHUT,MON
0/1/0
MSC(SPA)
1x10GE
IOS XR RUN
IOS XR RUN
OK
PWR,NSHUT,MON
0/1/1
MSC(SPA)
1x10GE
OK
PWR,NSHUT,MON
0/1/2
MSC(SPA)
1x10GE
PWR,NSHUT,MON
0/RP0/CPU0
RP(Active)
N/A
PWR,NSHUT,MON
0/RP1/CPU0
RP(Standby)
N/A
PWR,NSHUT,MON
0/SM0/SP
FC/S(SP)
N/A
PWR,NSHUT,MON
0/SM1/SP
FC/S(SP)
N/A
OK
IOS XR RUN
IOS XR RUN
IOS XR RUN
IOS XR RUN
PWR,NSHUT,MON
0/SM2/SP
FC/S(SP)
N/A
IOS XR RUN
PWR,NSHUT,MON
0/SM3/SP
FC/S(SP)
N/A
IOS XR RUN
PWR,NSHUT,MON
Cisco IOS XR
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
33

IOS XR CLI: Основные особенности

Новый формат CLI

2-х этапная модель конфигурирования

Возможность отменять изменения

Предварительная настройка интерфейсов

Новый режим конфигурирования – Admin mode

Просмотр конфигурации

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

34

IOS XR CLI: Новый формат CLI

Конфигурационные режимы:

Privileged exec mode

Global config mode Config sub-mode Admin mode

В IOS XR появляется новый режим - Admin mode

Admin mode позволяет работать и настраивать разделяемые ресурсы, такие как:

Фабрика коммутации Логические маршрутизаторы Пакеты программного обеспечения (packages)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

35

IOS XR CLI: Режимы конфигурации

RP/0/0/CPU0:ios#config t RP/0/0/CPU0:ios(config)#interface MgmtEth 0/0/CPU0/0

RP/0/0/CPU0:ios(config-if)#

RP/0/0/CPU0:ios#

RP/0/0/CPU0:ios#admin

RP/0/0/CPU0:ios(admin)#

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

36

IOS XR CLI: 2-х этапная модель 1 этап 2 этап БД конфигураций CLI
IOS XR CLI: 2-х этапная модель
1 этап
2 этап
БД
конфигураций
CLI
оператор
Commit
Изменения
Активная
конфигурация
Изменения
Результирующая
Активация
=
+
конфигурации
конфигурация
конфигурации

Оператор подключается к маршрутизатору

Добавление/удаление/

модификация конфигурации:

Вводятся в «буферной» зоне

Проверка синтаксиса и прав доступа

Можно смотреть и редактировать

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

Изменения переносятся из

«буферной» зоны в активную конфигурацию:

Семантическая проверка

Создание точки возврата в БД конфигураций

37

IOS XR CLI: Режим конфигурирования

RP/0/0/CPU0:ios#show run int gi0/2/0/0 % No such configuration item(s)

RP/0/0/CPU0:iosxr1#conf t

RP/0/0/CPU0:iosxr1(config)#interface gig0/2/0/0 RP/0/0/CPU0:iosxr1(config-if)#ipv4 address 100.12.1.1/24

RP/0/0/CPU0:iosxr1(config-if)#ipv4 address 100.12.1.1/24 RP/0/0/CPU0:iosxr1(config-if)#commit RP/0/0/CPU0:Apr 24

RP/0/0/CPU0:iosxr1(config-if)#commit

RP/0/0/CPU0:Apr 24 00:49:28.119 : config[65691]: %MGBL-CONFIG-6- DB_COMMIT : Configuration committed by user 'root'. Use 'show

configuration commit changes 1000000036' to view the changes.

RP/0/0/CPU0:iosxr1(config-if)#end

RP/0/0/CPU0:Apr 24 00:49:30.701 : config[65691]: %MGBL-SYS-5- CONFIG_I : Configured from console by root

RP/0/0/CPU0:iosxr1#

: Configured from console by root RP/0/0/CPU0:iosxr1# RP/0/0/CPU0:iosxr1#show run int gigabitEthernet 0/2/0/0

RP/0/0/CPU0:iosxr1#show run int gigabitEthernet 0/2/0/0

interface GigabitEthernet0/2/0/0 ipv4 address 100.12.1.1 255.255.255.0

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

38

IOS XR CLI: Активация изменений (2 этап)

Каждая команда «commit» генерирует уникальный ID для

сделанного изменения

commit ID используется для отмены сделанных изменений (rollback points)

Commit Database хранит до 100 таких

Config Database Running Config
Config
Database
Running
Config

rollback points

таких Config Database Running Config rollback points Target Config Commit Config Log: Commit ID# 100 Commit

Target Config

Commit

Running Config rollback points Target Config Commit Config Log: Commit ID# 100 Commit ID# 099 Commit

Config Log:

Commit ID# 100

Commit ID# 099

Commit ID# 098

Commit ID #001

100 Commit ID# 099 Commit ID# 098 … Commit ID #001 Cisco IOS XR © 2010

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

39

IOS XR CLI: Команда ‗commit‘

Команда Commit сохраняет сделанные

изменения и делает их активными

Присваивает уникальный идентификатор каждому изменению

Список изменений можно посмотреть

История изменений сохраняется

К сделанным изменениям можно написать

понятный комментарий (label)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

40

IOS XR CLI: Отмена изменений (rollback)

RP/0/0/CPU0:iosxr1#conf t RP/0/0/CPU0:iosxr1(config)#hostname iox-nw06

t RP/0/0/CPU0:iosxr1(config)#hostname iox-nw06 RP/0/0/CPU0:iosxr1(config)# commit RP/0/0/CPU0:Apr 24

RP/0/0/CPU0:iosxr1(config)#commit

RP/0/0/CPU0:Apr 24 01:00:55.302 : config[65691]: %MGBL-CONFIG-6-DB_COMMIT

: Configuration committed by user 'root'. Use 'show configuration commit

changes 1000000034' to view the changes.

RP/0/0/CPU0:iox-nw06(config)#end

RP/0/0/CPU0:iox-nw06#

RP/0/0/CPU0:iox-nw06(config)#end RP/0/0/CPU0:iox-nw06# RP/0/0/CPU0:iox-nw06# rollback configuration to 1000000033

RP/0/0/CPU0:iox-nw06#rollback configuration to 1000000033 Loading Rollback Changes. Loaded Rollback Changes in 1 sec Committing. 3 items committed in 1 sec (2)items/sec Updating.RP/0/0/CPU0:Apr 24 01:01:07.143 : config_rollback[65691]: %MGBL- CONFIG-6-DB_COMMIT : Configuration committed by user 'root'. Use 'show configuration commit changes 1000000035' to view the changes.

commit changes 1000000035' to view the changes. Updated Commit database in 1 sec Configuration successfully

Updated Commit database in 1 sec

Configuration successfully rolled back to '1000000033'.

RP/0/0/CPU0:iosxr1#

RP/0/0/CPU0:iosxr1#

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

41

IOS XR CLI: Предварительная настройка

Возможность предварительной настройки позволяет задать параметры для интерфейса, до того как модуль будет установлен в маршрутизатор

Предварительно настроенные интерфейсы не

проверяются и не работают, до момента установки модуля в соответствующий слот

Позволяет уменьшить время простоя

RP/0/0/CPU0:IOX-4(config)# interface preconfigure POS 0/4/1/0 RP/0/0/CPU0:IOX-4(config-if-pre)# ip address 1.1.1.1

RP/0/0/CPU0:IOX-4(config)#interface preconfigure POS 0/4/1/0

RP/0/0/CPU0:IOX-4(config-if-pre)#ip address 1.1.1.1 255.255.255.0

RP/0/0/CPU0:IOX-4(config-if-pre)#encapsulation ppp RP/0/0/CPU0:IOX-4(config)#controller preconfigure sonet 0/4/0/0 RP/0/0/CPU0:IOX-4(config-sonet)#clock source line

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

42

IOS XR CLI: Работа над ошибками

Два уровня обработки ошибок

Синтаксические ошибки

Распознаются синтаксическим анализатором после нажатия клавиши <return>

Ошибки активации конфигурации

Синтаксически правильные но не корректные с точки

зрения активации изменений

Подробную информацию об ошибке можно получить с помощью команды ―show configuration failed

Типичные причины возникновения:

Отсутствие необходимых команд в конфигурации Не поддерживаемая на платформе функциональность

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

43

IOS XR CLI: Работа над ошибками

Сообщение об ошибке при настройке QoS

RP/0/0/CPU0:ios#conf t RP/0/0/CPU0:ios(config)#policy p1 RP/0/0/CPU0:ios(config-pmap)#class c0

p1 RP/0/0/CPU0:ios(config-pmap)#class c0 RP/0/0/CPU0:ios(config-pmap-c)#set precedence 0

RP/0/0/CPU0:ios(config-pmap-c)#set precedence 0

RP/0/0/CPU0:ios(config-pmap-c)#commit

% Failed to commit one or more configuration items during an

atomic operation, no changes have been made. Please use 'show configuration failed' to view the errors

RP/0/0/CPU0:ios(config-pmap-c)#show configuration failed !! CONFIGURATION FAILED DUE TO SEMANTIC ERRORS policy-map p1 class c0 set precedence routine

FAILED DUE TO SEMANTIC ERRORS policy-map p1 class c0 set precedence routine !!% Class-map not configured:

!!% Class-map not configured: c0

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

44

Просмотр конфигурации

в режиме конфигурации (config mode)

show Показать текущие изменения для текущего режима (sub- mode)

show config Показать все изменения для всех режимов

show config merge Показать текущие изменения вместе с активной конфигурацией

show config running Показать активную конфигурацию

show config failed Показать части конфигурации, которые не были активированы из-за ошибок

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

45

Просмотр конфигурации

в режиме SDR Exec

RP/0/RP0/CPU0:CRS#show running-config

Building configuration

!! Last configuration change at 12:17:03 UTC Wed Jun 28 2006 by ww

!

hostname CRS line default exec-timeout 1440 0

RP/0/RP0/CPU0:CRS#show config commit list

SNo. Label/ID

User

Line

Client

Time Stamp

~~~~ ~~~~~~~~

~~~~

~~~~~~

~~~~~~~~~~

1 1000000296 ww

~~~~ con0_RP0_C CLI

12:17:03 UTC Wed Jun 28 2006

2 1000000295 ww

con0_RP0_C CLI

12:16:47 UTC Wed Jun 28 2006

3 1000000294 ww

vty0

CLI

12:09:03 UTC Wed Jun 28 2006

4 1000000293 admin

vty0

CLI

06:47:51 UTC Wed Jun 28 2006

5 1000000292 admin

vty0

CLI

06:47:18 UTC Wed Jun 28 2006

RP/0/RP0/CPU0:CRS#show config commit changes last 5

Building configuration hostname CRS policy-map edge class prec_5 bandwidth remaining percent 50

RP/0/RP0/CPU0:CRS#show config sessions

Session

Line

User

Date

Lock

00000201-0014e0da-00000000 vty0

ww

Wed Jun 28 12:58:14 2006

*

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

46

Примеры конфигураций IOS XR Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights

Примеры конфигураций IOS XR

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

47

Примеры конфигураций IOS XR

OSPF

ISIS

Static

BGP

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

48

OSPF

Включается добавлением интерфейсов в область

Вся конфигурация в режиме router ospf

router ospf 100

в режиме router ospf router ospf 100 area 0 area 1 interface gig 0/4/0/0 interface gig
в режиме router ospf router ospf 100 area 0 area 1 interface gig 0/4/0/0 interface gig
в режиме router ospf router ospf 100 area 0 area 1 interface gig 0/4/0/0 interface gig

area 0

area 1

interface gig 0/4/0/0

interface gig 0/5/0/4

interface gig 0/5/0/5

interface gig 0/3/0/0

interface gig 0/3/0/1

gig 0/5/0/5 interface gig 0/3/0/0 interface gig 0/3/0/1 passive enable interface gig 0/3/0/2 cost 40 Cisco

passive enable

interface gig 0/3/0/2

interface gig 0/3/0/1 passive enable interface gig 0/3/0/2 cost 40 Cisco IOS XR © 2010 Cisco

cost 40

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

49

Пример конфигурации OSPF

router ospfv3 32 area 0 interface GigabitEthernet0/5/0/0

!

interface GigabitEthernet0/5/0/1 cost 30

!

!

area 1 interface GigabitEthernet0/5/0/2

cost 40

passive

!

router ospf 101 area 0

interface GigabitEthernet0/5/0/0

!

interface GigabitEthernet0/5/0/1

!

interface GigabitEthernet0/5/0/2

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

50

ISIS

Включается добавлением интерфейсов в ISIS

Вся конфигурация в режиме router isis

Cisco IOS XR

router isis <label> net 49.0001.0000.0000.000c.00 interface gig 0/4/0/0 address-family ipv4 unicast interface
router isis <label>
net 49.0001.0000.0000.000c.00
interface gig 0/4/0/0
address-family ipv4 unicast
interface gig 0/4/0/1
address-family ipv4 unicast
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public

51

Пример конфигурации ISIS

router isis 100

net 49.0001.0000.0000.000c.00

interface Loopback0

address-family ipv4 unicast

!

!

interface GigabitEthernet0/4/0/1

address-family ipv4 unicast

!

!

interface GigabitEthernet0/4/0/2

address-family ipv4 unicast

!

!

interface GigabitEthernet0/4/0/3 address-family ipv4 unicast

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

52

Статическая маршрутизация

router static

address-family ipv4 unicast

0.0.0.0/0 7.1.9.1 7.7.7.77/32 7.1.9.1 8.8.8.1/32 GigabitEthernet0/5/0/1.101 8.8.8.1/32 GigabitEthernet0/5/0/1.102

8.8.8.2/32 5.1.1.2

8.8.8.2/32 5.2.1.2

!

router static address-family ipv6 unicast

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

53

BGP

Задать номер AS

Инициализировать address family ipv4 unicast

Сконфигурировать адрес BGP соседа

Задать номер удаленной AS

Разрешить address-family ipv4 unicast

Определить политику импорта/экспорта

router bgp 100 address-family ipv4 unicast

!

neighbor 1.1.1.1 remote-as 200 address-family ipv4 unicast route-policy filter-in in

route-policy filter-out out

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

54

Расширенные функции IOS XR Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights

Расширенные функции IOS XR

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

55

Расширенные функции IOS XR

Local Packet Transport Service (LPTS)

Routing Policy Language (RPL)

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

56

Local Packet Transport Protocol (LPTS)

Обеспечивает передачу данных к распределѐнным

процессам плоскости управления, которые выполняются

на RPs, DRPs

Передача пакета (forwarding) выполняется аппаратными средствами без использования ресурсов CPU линейной карты

LPTS используется также для ограничения и фильтрации трафика управления:

Аппаратный policer на LC ограничивает трафик в сторону RP/DRPs. Лимиты определяются исходя из типа трафика.

Тип трафика определяется приложением от которого он

поступил (OSPF, BGP, …), а также текущим состоянием удаленного узла (established, configured или unknown peer) от которого данный трафик был получен

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

57

LPTS: Dynamic Control Plane Protection

router bgp neighbor 202.4.48.99

ttl_security

!

mpls ldp

!

DCoPP – это автоматический firewall для

трафика плоскости управления

Каждый пакет трафика управления, полученный от линейной карты будет аппаратно ограничиваться для

обеспечения защиты RP от перегрузки

LC 1 IFIB TCAM HW Entries Local port Remote port Rate Priority Any ICMP ANY
LC 1 IFIB TCAM HW Entries
Local
port
Remote
port
Rate
Priority
Any
ICMP
ANY
ANY
1000
low
any
179
any
any
100
medium
any
179
202.4.48.99
any
1000
medium
ttl
255
202.4.48.1
179
202.4.48.99
2223
10000
medium
200.200.0.2
13232
200.200.0.1
646
100
medium
LC 2 IFIB TCAM HW Entries …

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

Cisco and/or its affiliates. All rights reserved. Cisco Public LPTS Socket BGP LDP SSH TCP Handshake

LPTS

Socket

LPTS Socket BGP LDP SSH
LPTS Socket BGP LDP SSH

BGPLPTS Socket LDP SSH

LPTS Socket BGP LDP SSH

LDPLPTS Socket BGP SSH

SSH

Cisco and/or its affiliates. All rights reserved. Cisco Public LPTS Socket BGP LDP SSH TCP Handshake

TCP Handshake

58

Cisco and/or its affiliates. All rights reserved. Cisco Public LPTS Socket BGP LDP SSH TCP Handshake
Cisco and/or its affiliates. All rights reserved. Cisco Public LPTS Socket BGP LDP SSH TCP Handshake

RPL — Предпосылки возникновения

Масштабируемость

Использование route-maps приводило к

конфигурациям в 100k 1M строк (для 1000 BGP соседей)

Модульность

Переиспользование общих частей уже написанного

кода

Использование параметров

Вводится понятие переменной, значение которой

можно передавать из одной части кода в другую

Улучшение ясности кода

Все выполняемые правила задаются явно

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

59

RPL синтаксис

Привычные выражения: if, then, elseif и else

Логические (Boolean) операции для

объединения нескольких выражений

Определение процедур и функций с

параметрами

Нет необходимости в нумерации порядка выполнения операций

Возможность обработки множества атрибутов:

as-path, community, med, tag, metric etc.

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

60

RPL — Примеры использования

if med eq 150 then

set local-preference 10

elseif med eq 200 then set local-preference 60

else

set local-preference 0 endif

if med eq 42 and next-hop in (1.1.1.1) then if med eq 10 and not destination in (10.1.3.0/24) or community is (56:78) if med eq 10 and (not destination in (10.1.3.0/24)) or community is (56:78 )

in (10.1.3.0/24) or community is (56:78) if med eq 10 and (not destination in (10.1.3.0/24)) or
in (10.1.3.0/24) or community is (56:78) if med eq 10 and (not destination in (10.1.3.0/24)) or

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

61

RPL — Примеры использования

RP/0/RP0/CPU0:IOS XR#sh run route-policy Inner route-policy Inner($med) set med $med end-policy

!
!

route-policy Outer apply Inner(10) end-policy

RP/0/RP0/CPU0:IOS XR#sh run route-policy Outer

!

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

62

RPL Sets (наборы данных)

Совокупность элементов одного типа

RPL работает с наборами в условных (if then)

выражениях

Элементы в наборе разделяются запятыми

5 типов наборов:

prefix-set ten

10.0.3.0/24,

10.0.4.0/24,

10.0.5.0/24 ge 26 le 30

end-set

prefix-set

as-path-set

community-set

extcommunity-set

rd-set

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

63

Литература

Литература http://www.ciscopress.com/bookstore/product.asp?isbn=9781587052712 Cisco IOS XR © 2010 Cisco and/or

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

XR © 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

64

Полезные ссылки

Cisco IOS XR документация

Маршрутизаторы Cisco XR 12000

Маршрутизаторы Cisco ASR 9000

Cisco Carrier Routing System

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

65

Вопросы и Ответы

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

Вопросы и Ответы Cisco IOS XR © 2010 Cisco and/or its affiliates. All rights reserved. Cisco

66

Мы хотели бы узнать Ваше мнение

Пожалуйста,

заполните анкету

Пожалуйста , заполните анкету

Cisco IOS XR

© 2010 Cisco and/or its affiliates. All rights reserved.

Cisco Public

67