Вы находитесь на странице: 1из 22

LAB 1:

5.1 Cu hnh 5.1.1 Cu hnh router A1:

hostname A1 ! ip cef ip audit po max-events 100 ! interface Loopback0 ip address 10.10.10.10 255.255.255.0 ! interface Serial1/0 ip address 192.168.1.2 255.255.255.0 serial restart-delay 0

! router rip version 2 network 10.0.0.0 network 192.168.1.0 no auto-summary ! End


5.1.2 Cu hnh router B1:

hostname B1 ! ip cef ip audit po max-events 100 ! interface Loopback0 ip address 20.20.20.20 255.255.255.0 ! interface Serial1/0 ip address 192.168.2.2 255.255.255.0 serial restart-delay 0 !

router rip version 2 network 20.0.0.0 network 192.168.2.0 no auto-summary ! End


5.1.3 Cu hnh router PE01:

hostname PE01 ! ip vrf A1 rd 1:100 route-target export 1:100 route-target import 1:100 ! ip vrf B1 rd 1:200 route-target export 1:200 route-target import 1:200 ! ip cef

ip audit po max-events 100 ! interface Loopback0 ip address 1.1.1.1 255.255.255.0 ! interface Serial1/0 ip vrf forwarding A1 ip address 192.168.1.1 255.255.255.0 serial restart-delay 0 ! interface Serial1/1 ip vrf forwarding B1 ip address 192.168.2.1 255.255.255.0 serial restart-delay 0 ! interface Serial1/2 ip address 192.168.3.1 255.255.255. mpls label protocol ldp tag-switching ip serial restart-delay 0 !

router eigrp 100 network 1.0.0.0 network 192.168.3.0 no auto-summary ! router rip version 2 ! address-family ipv4 vrf B1 redistribute bgp 1 metric transparent network 192.168.2.0 no auto-summary exit-address-family ! address-family ipv4 vrf A1 redistribute bgp 1 metric transparent network 192.168.1.0 no auto-summary exit-address-family ! router bgp 1

no synchronization bgp log-neighbor-changes neighbor 2.2.2.2 remote-as 1 neighbor 2.2.2.2 update-source Loopback0 no auto-summary ! address-family vpnv4 neighbor 2.2.2.2 activate neighbor 2.2.2.2 next-hop-self neighbor 2.2.2.2 send-community both exit-address-family ! address-family ipv4 vrf B1 redistribute rip no auto-summary no synchronization exit-address-family ! address-family ipv4 vrf A1 redistribute rip no auto-summary

no synchronization exit-address-family ! End


5.1.4 Cu hnh router P:

hostname P ! ip cef ip audit po max-events 100 ! interface Loopback0 ip address 3.3.3.3 255.255.255.0 ! interface Serial1/0 ip address 192.168.3.2 255.255.255.0 mpls label protocol ldp tag-switching ip serial restart-delay 0 ! interface Serial1/1 ip address 192.168.4.1 255.255.255.0

mpls label protocol ldp tag-switching ip serial restart-delay 0 ! router eigrp 100 network 3.0.0.0 network 192.168.3.0 network 192.168.4.0 no auto-summary ! End
5.1.5 Cu hnh router PE02:

hostname PE02 ! ip vrf A2 rd 1:100 route-target export 1:100 route-target import 1:100 ! ip vrf B2 rd 1:200

route-target export 1:200 route-target import 1:200 ! ip cef ip audit po max-events 100 ! interface Loopback0 ip address 2.2.2.2 255.255.255.0 ! interface Serial1/0 ip address 192.168.4.2 255.255.255.0 mpls label protocol ldp tag-switching ip serial restart-delay 0 ! interface Serial1/1 ip vrf forwarding A2 ip address 192.168.5.1 255.255.255.0 serial restart-delay 0 ! interface Serial1/2

ip vrf forwarding B2 ip address 192.168.6.1 255.255.255.0 serial restart-delay 0 ! router eigrp 100 network 2.0.0.0 network 192.168.4.0 no auto-summary ! router rip version 2 ! address-family ipv4 vrf B2 redistribute bgp 1 metric transparent network 192.168.6.0 no auto-summary exit-address-family ! address-family ipv4 vrf A2 redistribute bgp 1 metric transparent network 192.168.5.0

no auto-summary exit-address-family ! router bgp 1 no synchronization bgp log-neighbor-changes neighbor 1.1.1.1 remote-as 1 neighbor 1.1.1.1 update-source Loopback0 no auto-summary ! address-family vpnv4 neighbor 1.1.1.1 activate neighbor 1.1.1.1 next-hop-self neighbor 1.1.1.1 send-community both exit-address-family ! address-family ipv4 vrf B2 redistribute rip no auto-summary no synchronization exit-address-family

! address-family ipv4 vrf A2 redistribute rip no auto-summary no synchronization exit-address-family ! End


5.1.6 Cu hnh router A2:

hostname A2 ! ip cef ip audit po max-events 100 ! interface Loopback0 ip address 30.30.30.30 255.255.255.0 ! interface Serial1/0 ip address 192.168.5.2 255.255.255.0 serial restart-delay 0 !

router rip version 2 network 30.0.0.0 network 192.168.5.0 no auto-summary ! End


5.1.7 Cu hnh router B2:

hostname B2 ! ip cef ip audit po max-events 100 ! interface Loopback0 ip address 40.40.40.40 255.255.255.0 ! interface Serial1/0 ip address 192.168.6.2 255.255.255.0 serial restart-delay 0 ! router rip

version 2 network 40.0.0.0 network 192.168.6.0 no auto-summary ! End

LAB 2:

1.Cc lnh cu hnh. a)Cu hnh router A1. hostname A1 ip cef ip audit po max-events 100 interface Loopback0 ip address 10.10.10.10 255.255.255.0 interface Serial1/0 ip address 192.168.1.2 255.255.255.0 serial restart-delay 0 router rip version 2

network 10.0.0.0 network 192.168.1.0 no auto-summary End

b)Cu hnh router PE01. hostname PE01 ip vrf A1 rd 1:100 route-target export 1:100 route-target import 1:100 ip cef ip audit po max-events 100 interface Loopback0 ip address 1.1.1.1 255.255.255.0 interface Serial1/0 ip vrf forwarding A1 ip address 192.168.1.1 255.255.255.0 interface Serial1/1 ip address 192.168.3.1 255.255.255.0 mpls label protocol ldp tag-switching ip serial restart-delay 0

router eigrp 100 network 1.0.0.0 network 192.168.3.0 no auto-summary router rip version 2

address-family ipv4 vrf A1 redistribute bgp 1 metric transparent network 192.168.1.0 no auto-summary exit-address-family router bgp 1 no synchronization bgp log-neighbor-changes neighbor 2.2.2.2 remote-as 1 neighbor 2.2.2.2 update-source Loopback0 no auto-summary address-family vpnv4 neighbor 2.2.2.2 activate neighbor 2.2.2.2 next-hop-self neighbor 2.2.2.2 send-community both exit-address-family

address-family ipv4 vrf A1 redistribute rip no auto-summary no synchronization exit-address-family End

c)Cu hnh router P. hostname P ip cef ip audit po max-events 100 interface Loopback0 ip address 3.3.3.3 255.255.255.0 interface Serial1/0 ip address 192.168.3.2 255.255.255.0 mpls label protocol ldp tag-switching ip serial restart-delay 0 interface Serial1/1 ip address 192.168.4.1 255.255.255.0 mpls label protocol ldp tag-switching ip serial restart-delay 0

router eigrp 100 network 3.0.0.0 network 192.168.3.0 network 192.168.4.0 no auto-summary End

d)Cu hnh router PE02. hostname PE02 ip vrf A2 rd 1:100 route-target export 1:100 route-target import 1:100 ip cef ip audit po max-events 100 interface Loopback0 ip address 2.2.2.2 255.255.255.0 interface Serial1/0 ip address 192.168.4.2 255.255.255.0 mpls label protocol ldp tag-switching ip serial restart-delay 0 nterface Serial1/1

ip vrf forwarding A2 ip address 192.168.5.1 255.255.255.0 serial restart-delay 0 router eigrp 100 network 2.0.0.0 network 192.168.4.0 no auto-summary router rip version 2 address-family ipv4 vrf A2 redistribute bgp 1 metric transparent network 192.168.5.0 no auto-summary exit-address-family router bgp 1 no synchronization bgp log-neighbor-changes neighbor 1.1.1.1 remote-as 1 neighbor 1.1.1.1 update-source Loopback0 no auto-summary address-family vpnv4 neighbor 1.1.1.1 activate neighbor 1.1.1.1 next-hop-self

neighbor 1.1.1.1 send-community both exit-address-family address-family ipv4 vrf A2 redistribute rip no auto-summary no synchronization exit-address-family End e)Cu hnh router A2. hostname A2 ip cef ip audit po max-events 100 interface Loopback0 ip address 30.30.30.30 255.255.255.0 interface Serial1/0 ip address 192.168.5.2 255.255.255.0 serial restart-delay 0 router rip version 2 network 30.0.0.0 network 192.168.5.0 no auto-summary End