Вы находитесь на странице: 1из 10

CCNP Route: EIGRP 1

Posted by on Friday, August 31, 2012Leave a comment (10)Go to comments

No rest for the wicked. NCDA


, , . -
, , , , EIGRP, OSPF, BGP
.
EIGRP CCNA , .

EIGRP:

(routing summarization)
;

(topology table) (feasible successor)


, RIP,
OSPF,

;

OSPF;

, OSPF,

, ,

EIGRP

neighbor table - directly connected , ,


RIP, Multicast .

topology table - ,
(successor), (feasible successor);

routing table , EIGRP


;

feasible distance (FD) ,


;

advertised distance (AD) reported distance (RD) ,


, ;

successor ;

feasible successor (FS) - , ;

feasible ondition (FC) .


feasible successor : reported distance
, feasible distance ;

active DUAL , , ;

passive - DUAL

EIGRP

hello (-> 224.0.0.10)

update (RTP)

ack (update, query, reply) (RTP)

query (RTP)

reply (RTP)

, /
, R1 R2 ( AS k-values):
1. R1 hello 224.0.0.10;
2. R2 ack RTP - Reliable Transport Protocol;
3. R1 update , ;
4. R2, ack R1 update,
R2 ;
5. R1, , ack, ;
,
update ack.
R2 - , R1 ,
( query) , ,
R2. R1 (reply) ,
-, , ,
(, 4.2 - ), . 3 ,
stuck in active, .


5 , :

bandwidth (k1)

delay (k3)

reliablitiy (k4 k5)

load (k2)

:
metric = k1 * bw ((k2 * bw)/(256 load)) + k3*delay) * (k5/reliablitiy + k4)
, k2, k4 k5 0, :
metric (default) = 256 * (slowest bw + summ of all links delays)

, MTU
. . ,
ospf, mtu mismatch .

branch

.
CoreRouter:
CoreRouter(config)#router eigrp 100
! EIGRP
CoreRouter(config-router)#no auto-summary
! CoreRouter

EIGRP

CoreRouter(config-router)#network 192.168.0.0 0.0.7.255


CoreRouter(config-router)#network 10.0.0.0
CoreRouter(config-router)#^Z
! EIGRP
! show ip protocols
CoreRouter#sh ip protocols
--- --Routing for Networks:
10.0.0.0
192.168.0.0/21
--- ---

network network wildcard_mask ?


Hello c , ,
. Brnch1:
Brnch1(config)#router eigrp 100
Brnch1(config-router)#no auto-summary
Brnch1(config-router)#network 10.1.1.0 0.0.0.3
Brnch1(config-router)#network 172.16.0.0 0.0.0.255
Brnch1(config-router)#network 172.17.0.0 0.0.0.31

brnch2 hack.
wildcard mask /15 , . EIGRP
,
.
Brnch2(config)#router eigrp 100
Brnch2(config-router)#network 10.2.2.2 0.0.0.0
Brnch2(config-router)#network 172.16.0.0 0.0.0.255

, :
Brnch2#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H

Address

Interface

Hold Uptime

SRTT

(sec)

(ms)

RTO

Seq

Cnt Num

172.16.0.1

Fa0/0

12 00:00:48 2634

10.2.2.1

Se1/0

11 00:19:37

101

5000

18

606

29

H , ;

Address ;

Interface , ;

Hold ,
. hello 5
hello 3;

SRTT source round trip timer ,


RTO retransmit timeout , ;

Q , .
, ;

Seq ;

, eigrp:
CoreRouter#sh ip route eigrp
172.16.0.0/24 is subnetted, 1 subnets
D

172.16.0.0 [90/2172416] via 10.2.2.2, 00:06:49, Serial1/0


172.17.0.0/27 is subnetted, 1 subnets

172.17.0.0 [90/2174976] via 10.2.2.2, 00:06:49, Serial1/0

, 172.17.0.0/27 Brnch1 (1 hop) CoreRouter


Brnch2 - (bandwidth & delay).
CoreRouter#sh ip eigrp topology
--- --P 172.17.0.0/27, 1 successors, FD is 2174976
via 10.2.2.2 (2174976/30720), Serial1/0
via 10.1.1.2 (5514496/28160), Serial1/1
--- ---

Brnch1 FS .
? RD FS Brnch1 (28160) , FD Successor (2174976) Brnch2.

, .


4-

ip route network/mask redistribute static (external route)

ip route 0.0.0.0/0 network 0.0.0.0 (internal route)

ip default-network network network network (internal route)

ip summary-address eigrp AS 0.0.0.0 0.0.0.0

, , 0.0.0.0/0.
branch-
.
BrnchX#sh ip route
--- --Gateway of last resort is 10.2.2.1 to network 0.0.0.0
D*EX

0.0.0.0/0 [170/2681856] via 10.2.2.1, 00:00:07, Serial1/0

-- ---

(, , you name it) eigrp


- redistribute static.
.
Brnch2#sh ip route
--- --Gateway of last resort is not set
D*

192.168.0.0/24 [90/2681856] via 10.2.2.1, 00:10:33, Serial1/0

--- ---

, candidate
default. , default-network .
, candidate
default, :

No default-information allowed in

Passive-Interface
, , EIGRP. , 172.17.0.0/27
,
, GNS3, . ,
, , - ,
- passive interface.
network hello
. Passive-interface
hello .
Brnch1(config-if)#router eigr 100
Brnch1(config-router)#passive-interface fastEthernet 0/1
Brnch1(config-router)#do sh ip proto
--- --Routing for Networks:
10.1.1.2/32
10.1.1.0/30
172.16.0.0/24
172.17.0.0/27
Passive Interface(s):
FastEthernet0/1
--- ---

Cool, eh? @ .
, ?
, :
CoreRouter(config)#router eigrp 100
CoreRouter(config-router)#passive-interface default
! -,

*Aug 31 17:48:42.243: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.1.1.2 (Serial1/1)


is down: interface passive *Aug 31 17:48:42.279: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100:
Neighbor 10.2.2.2 (Serial1/0) is down: interface passive
CoreRouter(config-router)#no passive-interface serial 1/0
CoreRouter(config-router)#no passive-interface serial 1/1
*Aug 31 17:48:48.723: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.2.2.2 (Serial1/0)
is up: new adjacency *Aug 31 17:48:49.899: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor
10.1.1.2 (Serial1/1) is up: new adjacency

Summarization
,
192.168.1.0/24-192.168.3.0/24 192.168.0.0/22.
CoreRouter(config)#int s1/0
CoreRouter(config-if)#ip summary-address eigrp 100 192.168.0.0 255.255.252.0
Brnch2#sh ip route eigrp
--- --D

192.168.0.0/22 [90/2172416] via 10.2.2.1, 00:06:39, Serial1/0

D
D
D
D

192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
192.168.4.0/24

[90/5517056]
[90/5517056]
[90/5517056]
[90/2172416]

via
via
via
via

172.16.0.1, 00:06:39, FastEthernet0/0


172.16.0.1, 00:06:39, FastEthernet0/0
172.16.0.1, 00:06:39, FastEthernet0/0
10.2.2.1, 00:18:31, Serial1/0

?! . Brnch2 192.168.1.0/24-192.168.3.0/24
, Brnch1. , longest prefix match,
.
serial- CoreRouter, Brnch1,
:
Brnch2(config-router)#do sh ip route
--- --D

192.168.0.0/22 [90/2172416] via 10.2.2.1, 00:14:31, Serial1/0

192.168.4.0/24 [90/2172416] via 10.2.2.1, 00:26:23, Serial1/0

.
:
, .
:

query-

, , ,
,

Variance
variance , feasible
successor, .
CoreRouter(config)#do sh ip eig topo
--- --P 172.16.0.0/24, 1 successors, FD is 2172416
via 10.2.2.2 (2172416/28160), Serial1/0
via 10.1.1.2 (5514496/28160), Serial1/1
--- ---

CoreRouter Brnch1 2.5 (5514496/2172416), CoreRouter


Brnch2. variance 1
. , :
CoreRouter(config)#router eigrp 100
CoreRouter(config-router)#variance 3
CoreRouter(config-router)#do sh ip route
--- --D

172.16.0.0 [90/2172416] via 10.2.2.2, 00:00:04, Serial1/0


[90/5514496] via 10.1.1.2, 00:00:04, Serial1/1
172.17.0.0/27 is subnetted, 1 subnets

172.17.0.0 [90/2174976] via 10.2.2.2, 00:00:04, Serial1/0

[90/5514496] via 10.1.1.2, 00:00:04, Serial1/1


--- ---

. 3
CoreRouter Brnch2 , 1 CoreRouter Brnch1.
. 2.
@

Techccnp route, cisco, eigrp


vSphere 5.1 ?
CCNP Route: EIGRP 2