Вы находитесь на странице: 1из 71

..

Cisco IOS

.......
router> enable
router# conf t
router# interface fastethernet 0/0
................

!
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
clock rate 2000000
!
interface Serial0/0.1 point-to-point
ip address 10.0.0.1 255.255.255.252
snmp trap link-status
frame-relay interface-dlci 101
!
!


))) 2012

-
. . . . - ( )
()

. .



Cisco IOS
()
, Cisco ,
.
. ,
, ,
.

,
200900 .

- 2012.

1.
1.1. Cisco IOS
1.2.
1.3. IOS . . . . . . . . . . . . . . . . . . . . . . . . .
1.4. . . . . . . . . . . . . . . . . . .
1.5. . . . . . . . . . . . . . .

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

5
6
8
11
13
15

2.
17
2.1. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
2.2. . . . . . . . . . . . . . . . . . . . . . . 20
3.
3.1. . . . . . . .
3.2. . . . . . . .
3.3. . . . . . . . . . . . . .
3.4. . . . . . . . . . . . . . . . .
3.5. . . . . . . . . . . . . . . . .
3.6. . . . . . . . . . . .
3.7. DNS . . . . . . . . . . . . .
3.8. CDP . . . . .

.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

4.
4.1. . . . . . .
4.2. . .
4.3. . . . . . . . . . . . . .
4.4. . .
4.5. . . . . . . . . . .

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

5.
5.1. . . . . . . . . . . . .
5.1.1. . . . . . . . . . . .
5.1.2. . . . . . . . .
5.2. . . . . . . . . . . . .
5.2.1. Null- . . . . . . . . . . . . . . . . . .
5.2.2. Loopback- . . . . . . . . . . . . . . .
5.3.
5.3.1. . . . . . . . . . . . . . .
5.3.2. . . . . . . . . . . . . . .
5.3.3. IP- . . . . . . . . .

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

.
.
.
.
.

.
.
.
.
.
.
.
.
.
.

.
.
.
.
.
.
.
.

23
23
23
24
24
25
25
26
27

.
.
.
.
.

29
29
30
30
31
32

.
.
.
.
.
.
.
.
.
.

33
33
33
34
34
35
36
36
36
37
37

. .

5.4.
5.5.
5.6.
5.7.
5.8.

5.3.4. show
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Ethernet . . . . . . . . . . . . . . . . . . . .
Serial . . . . . . . . . . .
Frame-Relay . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
ATM . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

6.
6.1. .
6.2.
6.2.1. RIP . . . . . . . . . . .
6.2.2. EIGRP . . . . . . . . . .
6.2.3. BGP . . . . . . . . . . .

. . . . . . . . . . .
. . . . . . . . . . .
. . . . . . . . . . .
. . . . . . . . . . .
. . . . . . . . . . .

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

38
38
39
40
44
51
52
52
53
54
62
68

7.

69

70

8.

70

PC

Frame Relay

Ethernet

ATM

- .
- .

. .

1.
,
, ,

. , , .. ,
,
(IP, PPP, HDLC ..) (Ethernet, , Frame Relay, ATM ..).
, (DNS, NTP, CDP .),
(RIP, EIGRP).

1.1. Cisco IOS


ISO/OSI
. (,
.) , .
-
IP- . ,
.
, OSI , . , (PC) , .
, ,
- . Cisco ,
. ,
:
-
- .
Cisco . ( standalone-) .
, .1 .2 Cisco 2800.
1 (,
,
, ..). 2 Compact Flash .
3 USB, , ,
, . 4 (Console)
(, AUX) .
5.

. .

1
2

. 1. -

. 2. -
.2 . - NM (Network Module),
NME (Network Module Enhanced) ( 8); WIC (Wan Interface
Card), HWIC, VIC (Voice Interface Card), VWIC ( 7); (PVDM-DSP, Packet Voice Data Modules) .. 6 LAN
FEthernet.
AIM (Advanced Intergration Modules).
- (,
Double-Wide). , ( standalone ) ,
.
, , , .
() Cisco IOS.
.
(,
, ..) -
.
, PC ( ), (-

, , .). ,
PC .
, (DRAM)
ECC (Error Correction Coding), RAM (
). , , ,
, .
, ( Cisco)
, . .., ,
- Cisco, , ,
.

1.2.
(serial) PC (, .)
, Console. (
). Cisco ,
DB-9 F
PC (DB-9 M), RJ-45,
Console. .3.
!
.
PC
VT100. , PuTTY, minicom.
. -, Console 9600 ,
8 , 1 .
,
.
POST . ,
. ,
(PC) .

10

. .
GND
GND
DSR
CTS

TxD
DTR
RTS

DTR
RxD
TxD
DCD
GND

4
9

RI

3
8

CTS

2
7

1
6

RTS
DSR

PC RS232

Cisco Console

. 3.
, , ,
.1 .2. .1
, . ,
.2 , ()
.
1.
Router con0 is now available
Press RETURN to get started .
2.
--- System Configuration Dialog --At any point you may enter a question mark ? for help .
Use ctrl - c to abort confguration dialog at any prompt .
Default settings are in square brackets [] .
Would you like to enter the initial config dialog ? [ yes / no ]:

11

(CLI), Enter no
Enter .
, show version show diag
: IOS, ,
DRAM, . .3 .4.
3. show version
Cisco IOS Software , 3600 Software ( C3640 - IK9S - M ) , Ver . 12.4(16)
...
Cisco 3640 ( R4700 ) processor with 124928 K /6144 K bytes of mem .
Processor board ID FF1045C5
R4700 CPU at 100 MHz , Implementation 33 , Rev 1.2
16 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled .
125 K bytes of NVRAM .
8192 K bytes of processor board System flash ( Read / Write )
...
Configuration register is 0 x2142
4. show diag
Slot 0:
FastEthernet Port adapter , 16 ports
Port adapter is analyzed
Port adapter insertion time unknown
EEPROM contents at hardware discovery :
Hardware Revision
: 1.0
Top Assy . Part Number
: 800 -15156 -01
Board Revision
: E0
Deviation Number
: 0 -0
Fab Version
: 03
PCB Serial Number
: 00000000000
RMA Test History
: 00
RMA Number
: 0 -0 -0 -0
RMA History
: 00
Base MAC Address
: cc00 .2 fc7 . f000
MAC Address block size
: 17
Product ( FRU ) Number
: NM -16 ESW =
EEPROM format version 4
EEPROM contents ( hex ):

12

. .

0 x00 :
0 x10 :
0 x20 :
0 x30 :
0 x40 :
0 x50 :

04
42
30
CF
FF
FF

FF
45
30
06
FF
FF

40
30
30
CC
FF
FF

02
80
30
00
FF
FF

A9
00
30
2F
FF
FF

41
00
30
C7
FF
FF

01
00
30
F0
FF
FF

00
00
03
00
FF
FF

C0
02
00
43
FF
FF

46
03
81
00
FF
FF

03
C1
00
11
FF
FF

20
8B
00
FF
FF
FF

00
30
00
FF
FF
FF

3B
30
00
FF
FF
FF

34
30
04
FF
FF
FF

01
30
00
FF
FF
FF

,

, telnet, SSH rlogin.
3 4.

1.3. IOS
IOS ,
- () . , , , ..
. , startup-config ( NVRAM),
, -, .
(IP Base),
. ,
, , , . ,
, IOS
show flash.
.4
IOS.
, ,
, c2600-ipbasek9-mz.124-17.bin:
c2600 - , Cisco 2600;
ipbasek9 - .4,
(IP Base);
mz - , ()
- ;
124-17 - (12.4) (17);

IP Base

13

Advanced
Security

Advanced
IP Services

IP Voice

SP
Services

Enterprise
Base

Enterprise
Services

Advanced
Enterprise
Services

. 4. IOS
bin - .
, ( m), (l),
- (f ), PCMCIA (c) PC Card, , , ROM (r). (z,x,w), .
, c2691-advipservicesk9-mz.124-15.T6.bin:
2691 c , .. Advanced IP Services;
- ; IOS
124-15.6.
, , , :
, ;
;
, -, ;
, , show version, show diag, show registry.
. , ( -

14

. .

) IOS TFTP copy flash


tftp. , , IP- TFTP-, ()
. copy , .. copy tftp flash,
TFTP - .
, , (SSH). , , - copy (.5), , (user),
, IP- SSH
(172.16.100.17), , (c2691-124.bin), (flash).
5. SSH
router # copy scp :// user@172 .16.100.17/ c2691 -124. bin flash :
, (. 2.2)
TFTP SSH.

1.4.
,
, ,
.
, ?. :
6.
router >?
Exec commands :
access - enable
access - profile
clear
connect
credential
crypto
disable
disconnect
enable

Create a temporary Access - List entry


Apply user - profile to interface
Reset functions
Open a terminal connection
load the credential info from file system
Encryption related commands .
Turn off privileged commands
Disconnect an existing network connection
Turn on privileged commands


exit
help
lock

15

Exit from the EXEC


Description of the interactive help system
Lock the terminal

...
, ,
:
7.
router > enable ?
0 -15 Enable level
view
Set into the existing view
, show:
8. show
router > show ?
aaa
aal2
appfw
arp
auto
backup
bcm560x
bgp
call
cca
ccm - manager
cdapi
cef
...

Show AAA values


Show commands for AAL2
Application Firewall information
ARP table
Show Automation Template
Backup status
BCM560x HW Table
BGP information
Show call
CCA information
Call Manager Application information
CDAPI information
Cisco Express Forwarding

? .
:
9. lo
router # lo ?
* lo = logout lock

login

logout

? , ,
, (.
2.1).

16

. .

Ctrl-F
Ctrl-B
Ctrl-A
Ctrl-E
Ctrl-D
Ctrl-W
Ctrl-K
Ctrl-X
Ctrl-Y
Ctrl-T
Ctrl-U
Ctrl-P
Ctrl-N




1.

1.5.
. .. , ..
( alias UNIX) .
, configure terminal Tab
:
10.
router # conf ^ Tab
router # configure term ^ Tab
router # configure terminal
conf t. ,
show sh. sh int s0/0
show interface serial0/0.
Tab.
,
(shortcuts). .1. , Ctrl-Z -
, Ctrl-Shift-6, X -

17

, , ping, traceroute .

18

. .

2.
! , .

2.1.

(), -
. IOS 16 . , ,
(.).
. , 1 ,
15 .

. :
11.
router >
.
?.

. enable. :
12.
router #

. :
router > enable 15
router #
router # enable 1
router >
enable 15 15( .. ), enable 1 .

19

,
UNIX, Windows, Mac . (root)
UNIX Windows
..
, ,
.
4 , .
configure terminal,
.
, :
13.
router # configure terminal
router ( config )#
CtrlZ. disable. .
conf t ( )
:
:
conf t.
,
.
, DNS, ..
. .13.
Ctrl-Z end.
, 3.
:
, (, Ethernet). interface,
(, serial0
fastethernet0). IP, , -

20

. .
, IP- ..
, ,
. .14.
14.
router > enable
router # configure terminal
router ( config )# interface serial0 /0
router ( config - if )#
,
5.
:
, vty, tty,
console, async .. line
. , line console 0.
:
.
router , router rip. , , . , , RIP :
15.
router > enable
router # configure terminal
router ( config )# router rip
router ( config - router )# version 2
router ( config - router )# no auto - summary
router ( config - router )# network 10.10.11.0
router ( config - router )# network 10.10.12.0
router ( config - router )# exit
router ( config )# ^ Ctrl - Z
,
6.

, . -

21

, .
. .5
.
enable

Router>

conf t

Router#

disable

end

interface

end

exit

Router(cong-if)#

Router(cong)#

Router(cong-line)#

Router(cong-router)#

line

router

. 5.

2.2.
(plain text), . ,
,
,
.
. -
( ) startup-config.

(NVRAM)
startup-config. - running-config. , (startup-config)
, . ..
running-config.

22

. .


.
, startup-config ,
running-config , .
,
startup-config , . (
) running-config RAM- .
. , copy, :
16.
router # copy running - config startup - config
copy
startup-config , running-config. ..
,
() .
show . (
):
17.
router # show startup - config
!
version 12.4
!
hostname Default
!
...
!
interface Serial0 /0
no ip address
shutdown
...
!
line con 0
line aux 0
line vty 0 4

23

login
!
end
( ):
18.
router # show running - config
!
version 12.4
!
hostname router
!
...
!
interface Serial0 /0
no ip address
encapsulation frame - relay IETF
clock rate 2000000
!
interface Serial0 /0.1 point - to - point
ip address 10.0.0.1 255.255.255.252
snmp trap link - status
frame - relay interface - dlci 101
!
...
!
line con 0
line aux 0
line vty 0 4
login
!
end
erase, (startup-config).
!
. , telnet, ssh ..

24

. .

%s
%t
%n
%p
%h
%%

TTY-,
. : >, : #

%

2.

3.
3.1.
( ) hostname, :
19.
Router ( config )# hostname darkstar
darkstar ( config )#
254 . () (_). , . -, DNS.
, Moscow-FRAME-RTR
msc-fr-rtr.

3.2.
prompt. . ,
, TTY- , :
20.
router ( config )# prompt % h :% n % p % s
router :1#
.2. - no prompt.

25

3.3.
,
, .
! , , ,
. :
21.
! main serial frame relay intf .
!
interface Serial0 /0
no ip address
encapsulation frame - relay IETF
clock rate 2000000
!
!
,
.

3.4.
- ,
. , .
banner motd, banner login,
banner exec .. .
22.
darkstar ( config )# banner motd # Message of the day ! #
darkstar ( config )# banner login # Login succesfull ! #
darkstar ( config )# banner exec # Done ! #
darkstar ( config )# banner motd $
Enter TEXT message . End with the character $ .
Today this router will be down untill 20:00:00\ $
($), .. .
no exec-banner no motd-banner. no banner,
.

26

. .

3.5.
enable password.
.
23.
router ( config )# enable password tuxonice
( )
, .
enable secret
. .
24.
router ( config )# enable secret nicepass
service
password-encryption.

3.6.
clock set,
24 . ,
.
25.
darkstar # clock set 17:25:00 23 dec 2011
show clock detail.

clock timezone. , .
4 (UTC+4) :
26.
darkstar ( config )# clock timezone MSK +4
,
.
( ) calendar

27

set. , . .. . :
27.
darkstar # calendar set 17:25:00 23 dec 2011
darkstar # clock read - calendar

.
, calendar set
, .

NTP.
NTP.
28. NTP
darkstar # clock timezone MSK +4
darkstar ( config )# ntp server 10.10.11.1
NTP, ntp clock-period.
clock update-calendar, NTP.
NTP. ,
, ()
.
29. NTP
darkstar # clock timezone MSK +4
darkstar # clock calendar - valid
darkstar # ntp master
! ntp master
NTP .
, ntp master
(stratum),
NTP.

3.7. DNS
,
(IP) -

28

. .

DNS.
ip host.
IP-. , 8 IP- . :
30. IP-
router ( config )# ip host ap . local 10.10.11.2
router ( config )# ip host sw . local 10.10.11.3
router ( config )# ip host ds . local 10.10.11.4 10.10.11.5
no ip host:
31.
router ( config )# no ip host ap . local 10.10.11.2
router ( config )# no ip host sw . local 10.10.11.3
.
DNS ip domain-lookup. , DNS:
32. DNS-
darkstar ( config )# ip name - server 10.10.11.1
darkstar ( config )# ip name - server 89.110.21.39
darkstar ( config )# ip domain - name local
() ( ). .. IP-
jarnsax, jarnsax.local.
, DNS
, , , DNS . no ip
domain-lookup.
show hosts:
33. DNS-
darkstar ( config )# ip name - server 10.10.11.1
darkstar ( config )# ip name - server 89.110.21.39
darkstar ( config )# ip domain - name local

3.8. CDP
Cisco Cisco, , -

29

(, ). CDP
. CDP cdp run no cdp run.
, CDP - .
CDP no cdp enable .
.. CDP, . show cdp
neighbors :
34. CDP
darkstar # show cdp neighbors
Capability Codes :
R - Router , T - Trans Bridge , B - Source Route Bridge
S - Switch , H - Host , I - IGMP , r - Repeater
Device ID
moonlight

Local Intrfce Capability


Ser 0/0.1
R S I

Platform
2691

Port ID
Ser 0/0.1

show cdp neighbors


detail.
, CDP , -
, .

30

. .

4.
4.1.
IOS
- :

- (CTY), (TTY),
(AUX);
() (VTY) Telnet SSH.
, line,
( ). IOS 4 , ,
: console, tty, aux, vty.
35.
darkstar # conf t
darkstar ( config }# line tty 1 10
darkstar ( config - line )#
. , 0, ..,
, vty 0 .., n- c vty(n-1). , ..
.
, ,
, . (CTY, console 0),
0. , ,
(TTY, tty 1), 1 (CTY+1). 2 (TTYn+1), (AUX, aux 0).
, , (VTY, 0)
3 (AUX+1).
,
show users all, .3.
, console 0
0; 4 tty1-tty4 1 4; aux 0, 5; 5 vty0-vty4
6 10.

show line.



0
1
2
3
4
5
6
7
8
9
10


0
1
2
3
4
0
0
1
2
3
4

31

console 0
tty 1
tty 2
tty 3
tty 4
aux 0
vty 0
vty 1
vty 2
vty 3
vty 4

3.

4.2.

1.2.
line, console 0. . ,
:
36.
darkstar ( config )# username admin password nicepass
darkstar ( config )# line console 0
darkstar ( config - line )# login local
exec-timeout. .37 10 ,
.
37.
darkstar ( config - line )# exec - timeout 10
,
, ,
, .

4.3.
, , , -

32

. .

. TTY- ( )
(async) . .6 R1 (). TTY, TTY
async.
R1
""

MD1

TTY1
MD2

MD3

TTY4

TTY2

MD4

TTY3

. 6.

4.4.
, AUX- . ,
(console) .
.7
Frame Relay. ,

.
R1
""
FR1

FR2

AUX

R2
""

AUX
MD1

MD1

. 7.
R1 () , .7 .38.
38.
R1 ( config )#
R1 ( config )#
R1 ( config )#
R1 # conf t
R1 ( config )#

dialer - list 1 protocol ip permit


chat - script scr " " " atdt 233 -17 -82" timeout 60 " connect "
^ Ctrl - Z
line aux 0

33

R1 ( config - line ) modem chat - script scr


R1 ( config - line ) modem inout
dialer-list chat-script scr,
(
AT). modem chat-script
aux 0.
[1] [2].

4.5.

telnet SSH . , telnet SSH
, VTY-.
, , ..
.
.
.39 vty 0.
39.
darkstar ( config )# line
darkstar ( config - line )#
darkstar ( config - line )#
darkstar ( config - line )#

vty 0
login local
transport preffered ssh
^ Ctrl - Z

.39 login local


, transport preffered ssh SSH.

34

. .

5.
5.1.
ISO/OSI
, (), , , , MAC OSI.
, , - ethernet (fastethernet, gigabitethernet),
LAN, vlan VLAN, serial Serial, , ,
CSU/DSU (Channel Service Unit/Digital Service Unit), async
, atm, ATM-,
, ,
( loopback-) ..
, , , . , , , , IP.
5.1.1.
2.1,
interface,
. , 0- FastEthernet,
:
40. fastethernet
darkstar > enable
darkstar # conf t
darkstar ( config )# interface fastethernet 0
darkstar ( config - if )# ip address ...
, , :
41.
darkstar ( config )# interface serial 0
darkstar ( config - if )# encapsulation ...
SOHO (
). , -

35

,
,
. ,
( 16- Ethernet) , .. /, / 0.
.8
0

Ethernet 0-7

Ethernet 0-7

. 8. ,
, 5 ,
interface ethernet 1/4 ..
5.1.2.
, () . . (.)
. , , (.. ). ..
interface fastethernet 0/0.0 interface fastethernet 0/0.
. ,
fastethernet 1/2, :
42. fastethernet
darkstar ( config )# interface fastethernet 1/2.1
darkstar ( config - if )# ...
, , , ATM, Frame Relay .. .5.6.

5.2.
! , . ..
.

36

. .

5.2.1. Null-
,
. , , , .
UNIX, null
/dev.
, . , , , , . ,
.9.
, , 192.168.1.0/24
( 192.168.2.0/24, 192.168.3.0/24, 192.168.5.5/30),
R1 :
43. null0
R1 ( config )# ip route 192.168.1.0 255.255.255.0 null0
192.168.2.0/24

192.168.1.0/24

SW2
R1
SW1

SW3

192.168.5.5/30

192.168.3.0/24

. 9.
, , . ,

null0.

37

5.2.2. Loopback-
! IP- 127.0.0.1.
.
.
, , .
IP- :
44.
darkstar ( config )# interface loopback 0
darkstar ( config - if )# ip address 172.17.117.1 255.255.255.248
darkstar ( config - if )# ^ Ctrl - Z
, ,
. . , OSPF,
BGP . ,
, , , loopback0.

5.3.
5.3.1. . .
-
(.). , no shutdown.
! ,
( IP-, .), , ..
.
45. .
darkstar > enable
darkstar # conf t
darkstar ( config )# interface fastethernet 0/1
darkstar ( config - if )# no shutdown
darkstar ( config - if )# ^ Ctrl - Z
, .
, (
show interfaces line
protocol is down.
.

38

. .

5.3.2.
, description,
240 . , ,
.
46.
darkstar ( config )# interface fastethernet 0/1
darkstar ( config - if )# description Main LAN intf
5.3.3. IP-
IP- . , IP- 172.16.0.1
255.255.255.252 fastethernet 0/0 :
47. IP-
darkstar > enable
darkstar # conf t
darkstar ( config )# interface fastethernet 0/0
darkstar ( config - if )# ip address 172.16.0.1 255.255.255.252
darkstar ( config - if )# ^ Ctrl - Z
IP-. ..
(secondary) IP- . , IP , .47 secondary
IP-:
48. IP-
darkstar ( config )# interface fastethernet 0/0
darkstar ( config - if )# ip address 172.16.0.1/30
darkstar ( config - if )# ip address 172.16.0.5/30 secondary
.. fastethernet 0/0 (172.16.0.0/30 172.16.0.4/30).
IP-, secondary.
! , IP-
. . IP- OSPF. " (split
horizont), , ..

39

IP-. ,
.
5.3.4. show
show
.
,
show interfaces.
. show ip interface , IP. show interface ,
.
show version show hardware .

5.4. Ethernet
Ethernet . , Ethernet
, , ,
xDSL- CSU/DSU, (Bridges) Ethernet ATM .. ,
Ethernet
ISO/OSI.
, Ethernet , . ,
Ethernet 10Mbit/s ethernet (.5.1.1). Ethernet 10/100Mbit/s fastethernet
fe , Gigabit Ethernet (1Gbit/s)
gigabitethernet ..
,
show (.5.3.4).
duplex, (full duplex, half duplex ..) speed,
, .
, FastEthernet IP, . .49.

40

. .
FastEthernet 0/0
IP: 78.91.115.41
R1
""

R2
""

Ethernet 0/1
IP: 192.168.56.1/29
SW1

Ethernet 0/1
IP: 10.10.11.1/30
FastEthernet 0/0
IP: 192.44.12.128

SW2

. 10. FEthernet
49. FEthernet
darkstar > enable
darkstar # conf t
darkstar ( config )# interface fastethernet 0/1
darkstar ( config - if )# description Inner eth intrfs
darkstar ( config - if )# ip address 10.10.11.1 255.255.255.252
darkstar ( config - if )# speed 100
darkstar ( config - if )# duplex full
darkstar ( config - if )# no shutdown
darkstar ( config - if )# ^ Ctrl - Z

Ethernet.

5.5. Serial

, , (DSU).
,
(, E1), ,
. , .
, , ,
.
, Frame Relay (X.36), X.25, ATM, PPP, HDLC, SDLC, STUN .

41

PPP
R1
""

Serial 0/0
IP: 192.168.0.1/30

R2
""

Serial 0/0
IP: 192.168.0.2/30

. 11.
. , PPP
serial 0/0 :
50. PPP
darkstar > enable
darkstar # conf t
darkstar ( config )# interface serial 0/0
darkstar ( config - if )# description E1 - full channel
darkstar ( config - if )# ip address 192.168.0.1 255.255.255.252
darkstar ( config - if )# encapsulation ppp
darkstar ( config - if )# no keepalives
darkstar ( config - if )# no shutdown
darkstar ( config - if )# ^ Ctrl - Z
.50, encapsulation,
. PPP - .
no keepalives.
HDLC encapsulation hdlc Frame Relay encapsulation
frame-relay ( Frame Relay . 5.6).

5.6. Frame-Relay
Frame
Relay. , .
,
, E. .. Frame Relay,

Frame Relay, . C Frame Relay ()

42

. .

(serial-), .
, Frame Relay.
, Frame Relay , ,
(frame-relay) LMI ( ).
(-
), IP- ( ),
(DLCI).
FR SWITCH
DLCI 100 < > DLCI 200
FR1

R1
""

R2
""

IP Serial 0/0.1: 10.10.10.1/30


FR DLCI 100

IP Serial 0/0.1: 10.10.10.2/30


FR DLCI 200

. 12. Frame Relay


, serial 0/0 R1
() .12 :
51. FR
R1 > enable
R1 # conf t
R1 ( config )# interface serial 0/0
R1 ( config - if )# no ip address
R1 ( config - if )# encapsulation frame - relay ietf
R1 ( config - if )# frame - relay lmi - type ansi
R1 ( config - if )# no shutdown
R1 ( config - if )# ^ Ctrl - Z
serial 0/0 IP- (no ip address), .. IP-
serial 0/0.1. framerelay ( IETF), encapsulation frame-relay ietf.
frame-relay lmi-type ansi ,
ANSI. ,
, ,
.
:

43

52.
R1 ( config )# interface serial 0/0.1 point - to - point
R1 ( config - if )# ip address 10.10.10.1 255.255.255.252
R1 ( config - if )# frame - relay interface - dlci 100
R1 ( config - if )# ^ Ctrl - Z
point-to-point -. Frame Relay, . IP frame-relay interface-dlci 100
100. , DLCI ( , ) Frame Relay
. DLCI
, , , Frame Relay DLCI,
, R1 FR1. FR1
() PVC DLCI=100 c
DLCI=200. R2 () R1, IP- serial 0/0.1 DLCI 200.
-, . .13
Frame Relay. (PVC) DLCI.
R2
""

FR SWITCH
DLCI 100 <=> DLCI 200
DLCI 101 <=> DLCI 300

Serial 0/0.1 IP:10.10.10.2/29


FR DLCI 200

FR1
R1
""

Serial 0/0.1 IP:10.10.10.1/29


FR DLCI 100
DLCI 101

R3
""

Serial 0/0.1 IP:10.10.10.3/29


FR DLCI 300

. 13. Frame Relay

44

. .

. point-to-point,
. , , .13 R1 ()
2 DLCI. , multipoint
.
. ,
R1 () :
53.
R1 ( config )# interface serial 0/0
R1 ( config - if )# no ip address
R1 ( config - if )# encapsulation frame - relay ietf
R1 ( config - if )# frame - relay lmi - type ansi
R1 ( config - if )# no shutdown
R1 ( config - if )# exit
R1 ( config )# interface serial 0/0.1 multipoint
R1 ( config - if )# ip address 10.10.10.1 255.255.255.248
R1 ( config - if )# frame - relay interface - dlci 100
R1 ( config - fr - dlci )# frame - relay interface - dlci 101
.53
DLCI (100 101) , .
R2 () R3 () .51-52
DLCI IP-. FR1 PVC DLCI=100 DLCI=200, DLCI=101
DLCI=300.
Frame Relay, IP- DLCI. - DLCI Frame Relay
inARP, frame-relay map ip, IP-
DLCI-. :
54. IP-DLCI
R1 ( config )# interface serial 0/0
R1 ( config - if )# encapsulation frame - relay ietf
R1 ( config - if )# frame - relay lmi - type ansi
R1 ( config - if )# frame - relay map ip 10.10.0.2 200
R1 ( config - if )# no frame - relay inverse - arp

45

R1 ( config - if )# no shutdown
R1 ( config - if )# exit
.54 frame-relay map ip 10.10.0.2 200, serial 0/0, IP- 10.10.0.2 DLCI- 200,
no frame-relay inverse-arp inARP.
, Frame Relay inARP,
, . inARP
.
IP-DLCI, inARP clear frame-relay inarp (enable):
55. IP-DLCI inARP
R1 > enable
R1 # clear frame - relay inarp

5.7. ATM
ATM.
,
.
ATM , . ATM,
CSU/DSU, . ATM DSU (serial) . ATM (ATM Bridges).
, () atm . ,
ATM- , atm, ATM .14. R1 () R2
() ATM- (BR1 BR2, ) FastEthernet. ATM-, (
) , Ethernet
ATM ( )
( , VC),
VPI VCI.
ATM .

46

. .
R2
""

R1
""
ATM1

ATM4

BR1

BR2
ATM2

ATM3

. 14. ATM
(fastethernet, serial ..)
. ATM , .. atm (atm0, atm1 atm1.1 ..).
ATM : (,
PVC) (SVC). , , , PVC-
, , ( ), .
, . VPI ,
VCI
.
, .15 ATM. R1 () BR1 FastEthernet
(fastethernet 0/0) IP- 10.10.0.1/30. ATM- BR1 , Ethernet, R1 (), ATM, ATM1 VPI/VCI
0/100. , R2 (), BR2. fastethernet 0/0 IP- 10.10.0.2/30. BR2
ATM1, VPI/VCI 1/200. ATM1 VPI/VCI VPI/VCI
.
, Ethernet, IP-
VPI/VCI ATM-.
, , ATM
.
aal5snap aal5mux. : aal5snap
(IP ..) , -

47
ATM SWITCH
0/100 < > 1/200
ATM1

R1
""

R2
""

IP: 10.10.0.1/30

IP: 10.10.0.2/30

VPI 0
VCI 100

BR1

BR2

VPI 1
VCI 200

. 15. ATM
aal5mux ().
, ATM DSU- , atm dxi. , ATM, , ATM DSU-,
. DSU, , ATM .
.56
56. ATM DXI DSU-
darkstar ( config )# interface serial 0/0
darkstar ( config - if )# ip address 10.10.10.1 255.255.255.248
darkstar ( config - if )# encapsulation atm - dxi
darkstar ( config - if )# dxi pvc 1 2 mux
darkstar ( config - if )# dxi map ip 10.10.10.2 1 2 broadcast
darkstar ( config - if )# no shutdown
darkstar ( config - if )# ^ Ctrl - Z
encapsulation atm-dxi ATM DXI
DSU, dxi pvc 1 2 mux PVC VPI/VCI 1/2. mux ,
IP. dxi
map ip 10.10.10.2 1 2 broadcast IP- ( ) VPI/VCI=1/2.
broadcast , (, ).
ATM PVC,
IP- .

48

. .

IP-- . inARP. .

R1
""

atm 0.1
IP: 10.10.0.1/30

PVC 10
VPI 1
VCI 21

R2
""

atm 0.1
IP: 10.10.0.2/30

. 16. ATM
. map-list, ,
IP-- .
atm0 R1 (), .16 :
57. ATM

R1 ( config )# interface atm 0


R1 ( config - if )# no shutdown
R1 ( config - if )# exit
R1 ( config )# map - list atm - map10
R1 ( config - map - list )# ip 10.0.0.2 atm - vc 10 broadcast
R1 ( config - map - list )# exit
R1 ( config )# interface atm 0.1
R1 ( config - if )# ip address 10.0.0.1 255.255.255.252
R1 ( config - if )# atm pvc 10 1 21 aal5snap
R1 ( config - if )# map - group atm - map10
R1 ( config - if )# ^ Ctrl - Z
map-list atm-map10 atm-map10, IP- 10.0.0.2 ( )
PVC 10 ( ip 10.0.0.2 atm-vc 10 broadcast).
(PVC 10), , ,
, , IP--
. atm pvc 10 1 21 aal5snap 10 ( ) VPI/VCI 1/21 aal5snap. map-group atm-map10 ,
atm-map10, .

49

ATM PVC . inARP, - inARP . ..


atm inARP.
58. ATM

R1 ( config )# interface atm 0


R1 ( config - if )# no shutdown
R1 ( config - if )# exit
R1 ( config )# interface atm 0.1
R1 ( config - if )# ip address 10.0.0.1 255.255.255.252 inarp 3
R1 ( config - if )# atm pvc 10 1 21 aal5snap
R1 ( config - if )# ^ Ctrl - Z
, ATM .58 .57.
inARP atm 0.1 inarp c 3, 3 . .57, IP-- .
ATM,
.
SVC. SVC NSAP-
ATM.
NSAP-, . ATM , NSAP () . NSAP- 160
. 4 , 160/4=40 .., NSAP-
40 , :
AA.BBBB.CC.ABCDEF.ABCD.AAAA.BBBB.CCCC.DDDD.EEEE.FF.
NSAP- atm nsap-address, . , NSAP- atm 0.1 :
59. NSAP-
R1 ( config )# interface atm 0.1
R1 ( config - if )# ip address 10.0.0.1 255.255.255.252

50

. .

R1 ( config - if )# atm nsap - address AA ... FF


R1 ( config - if )# ^ Ctrl - Z
NSAP- .
ATM NSAP- (
IP). (. .57) map-list.
.
, SVC ,
, .
, PVC- atm.
PVC VPI/VCI=0/5,
PVC VPI/VCI=0/16.
. qsaal, ilmi.
, .17 SVC NSAP- .
, R1 (),
:
60. SVC
R1 # conf t
R1 ( config )# interface atm 0
R1 ( config - if )# atm pvc 1 0 5 qsaal
R1 ( config - if )# atm pvc 2 0 16 ilmi
R1 ( config - if )# exit
R1 ( config )# map - list atm - map - static
R1 ( config - map - list )# ip 10.10.11.1 atm - nsap AA ... FF broadcast
R1 ( config - map - list )# ip 10.10.11.2 atm - nsap BB ... FF broadcast
R1 ( config - map - list )# exit
R1 ( config ) interface atm 0.1
R1 ( config - if )# ip address 10.10.11.3 255.255.255.248
R1 ( config - if )# atm nsap - address CC ... FF
R1 ( config - if )# map - group atm - map - static
R1 ( config - if )# ^ Ctrl - Z
atm pvc 0 0 5 qsaal atm pvc 0 0 16 ilmi atm0
, . , map-list atm-map-static (atmmap-static) (IP--NSAP) ip 10.10.11.1 atm-nsap AA...FF broadcast .., .57. atm 0.1 IP- 10.10.11.3/29 NSAP-

51

ATM ...FF. map-group atm-map-static , (atm-map static).


.. R3 () R2 () .
R2
""

IP: 10.10.11.1/29
NSAP: AA...FF
BR1

ATM2
R1
""

BR1

IP: 10.10.11.3/29
NSAP: CC...FF
ATM1
BR1

IP: 10.10.11.2/29
R3
NSAP: BB...FF
""

. 17. ATM
ATM ARP-, IP- NSAP, ATM .

SVC. , ,
atm arp-server nsap, NSAP- ARP-,
. , .60, ARP-,
R1 ():
61. SVC

R1 # conf t
R1 ( config )# interface atm 0
R1 ( config - if )# atm pvc 1 0 5 qsaal
R1 ( config - if )# atm pvc 2 0 16 ilmi
R1 ( config - if )# exit
R1 ( config ) interface atm 0.1
R1 ( config - if )# ip address 10.10.11.3 255.255.255.248

52

. .

R1 ( config - if )# atm nsap - address CC ... FF


R1 ( config - if )# atm arp - server nsap 11... FF
R1 ( config - if )# ^ Ctrl - Z
, ARP-,
, IP-
ARP. ARP-
atm arp-server self. .62 :
62. ARP
R1 # conf t
R1 ( config )# interface atm 0
R1 ( config - if )# ip address 10.10.11.3 255.255.255.248
R1 ( config - if )# atm nsap - address CC ... FF
R1 ( config - if )# atm arp - server self
R1 ( config - if )# ^ Ctrl - Z

5.8.

53

6.
IP-. (BGP)
(RIP, OSPF, EIGRP ..). ,
, .

(router) (.2.1).
, , router,
, router rip. ,
,
. . 6.2.

(configure terminal).
, .

6.1.
. ,
,

.
IP (.2.1). ip route,
, , . , 10.10.11.0/28 R2
() .18, :
63.
R2 # conf t
R2 ( config )# ip route 10.10.11.0 255.255.255.240 172.17.117.1
R2 ( config )# ^ Ctrl - Z
.. .63 172.17.117.1, , 10.10.11.0/28.
, -, ,

54

. .
R1
""

172.17.117.1/30

R2
""

172.17.117.2/30

192.168.10.0/30
10.10.11.0/28

. 18.
.
- .64.
64. -
darkstar # conf t
darkstar ( config )# ip route 0.0.0.0 0.0.0.0 10.1.1.1
darkstar ( config )# ^ Ctrl - Z
, () , 10.1.1.1. .
,
.19 (R1), IP- - , , ,
Internet.
65. -
darkstar # conf t
darkstar ( config )# ip route 0.0.0.0 0.0.0.0 serial 0/0
darkstar ( config )# ^ Ctrl - Z
. null0 .
.
5.2.1.

6.2.
. ,

55
R1

R2

Serial 0/0
ISP

10.0.0.0/24

. 19.
, ,
. ,
.
,
(router). router,
. :
66.
darkstar > enable
darkstar # configure terminal
darkstar ( config )# router rip
darkstar ( config - router )#
2.1.
6.2.1. RIP
, RIP, ,
,
. ,
,
() , .
(RIPv2) .
. , ,
RIPv2 16 . , RIP -

56

. .

,
, . , RIP .
, ,
, .
SW1

R1
""

10.10.11.1/30

R2
""

SW1

10.10.11.5/30
10.10.11.2/30

10.10.11.10/30

R3
""

10.10.11.6/30

10.10.11.9/30

192.168.1.0/28
192.168.2.0/28
192.168.3.0/28

. 20. RIPv2
RIP
RIPv2, (router).
router rip RIP,
, , R1(config-router)#.
(
RIP)
.
- RIP.
, RIPv2
version 2.
67. R1 ()
R1 > enable
R1 # conf t
R1 ( config )# interface ethernet 0/0
R1 ( config - if )# no shutdown
R1 ( config - if )# ip address 10.10.11.1 255.255.255.252
R1 ( config - if )# exit
R1 ( config )# interface ethernet 0/1
R1 ( config - if )# no shutdown
R1 ( config - if )# ip address 10.10.11.5 255.255.255.252

57

R1 ( config - if )# exit
R1 ( config )# interface ethernet 0/2
R1 ( config - if )# no shutdown
R1 ( config - if )# ip address 192.168.1.1 255.255.255.240
R1 ( config - if )# ^ Ctrl - Z
(.67), RIP
. .20 IP- , . R1
() : 192.168.1.0/28 (
), 10.10.11.0/30 ( R1-R2) 10.10.11.4/30 ( R1-R3).
:
, ,
. IP-, .
RIPv2 R1 ()
:
68. RIPv2 R1 ()
R1 > enable
R1 # conf t
R1 ( config )# router
R1 ( config - router )#
R1 ( config - router )#
R1 ( config - router )#
R1 ( config - router )#
R1 ( config - router )#

rip
version 2
no auto - summary
network 10.10.11.0
network 10.10.11.4
network 192.168.1.0

, version 2 RIPv2. network 10.10.11.0, network 10.10.11.4 network


192.168.1.0 , . no auto-summary
.
- RIP , .
no auto-summary, RIP
10.10.11.0/30 10.10.11.4/30 , .. 10.0.0.0/8,
, - () . , , RIP ,
.

58

. .

( no auto-summary), -. , - auto-summary.
R2 () R3 () .69 70
69. R2 ()
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password - encryption
!
hostname R2
!
boot - start - marker
boot - end - marker
!
no logging console
!
no aaa new - model
memory - size iomem 5
!
!
ip cef
no ip domain lookup
!
!
interface Ethernet0 /0
ip address 10.10.11.2 255.255.255.252
full - duplex
!
interface Ethernet0 /1
ip address 10.10.11.10 255.255.255.252
full - duplex
!
interface Ethernet0 /2
ip address 192.168.2.1 255.255.255.240
half - duplex
!


interface Ethernet0 /3
no ip address
shutdown
half - duplex
!
router rip
version 2
network 10.0.0.0
network 192.168.2.0
no auto - summary
!
ip http server
no ip http secure - server
!
control - plane
!
line con 0
line aux 0
line vty 0 4
login
!
end
70. R3 ()
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password - encryption
!
hostname R3
!
boot - start - marker
boot - end - marker
!
no logging console
!
no aaa new - model
memory - size iomem 5
!

59

60
!
ip cef
no ip domain lookup
!
!
interface Ethernet0 /0
ip address 10.10.11.9 255.255.255.252
full - duplex
!
interface Ethernet0 /1
ip address 10.10.11.6 255.255.255.252
full - duplex
!
interface Ethernet0 /2
ip address 192.168.3.1 255.255.255.240
half - duplex
!
interface Ethernet0 /3
no ip address
shutdown
half - duplex
!
router rip
version 2
network 10.0.0.0
network 192.168.3.0
no auto - summary
!
ip http server
no ip http secure - server
!
!
control - plane
!
line con 0
line aux 0
line vty 0 4
login
!
end

. .

61

( () ), ,
show ip route. R1 (), RIP, ( -
):
71. R1 ()
R1 # show ip route
Gateway of last resort is not set

R
C
C
C
R
R

10.0.0.0/30 is subnetted , 3 subnets


10.10.11.8 [120/1] via 10.10.11.6 , 00:00:03 , Ethernet0 /1
[120/1] via 10.10.11.2 , 00:00:19 , Ethernet0 /0
10.10.11.0 is directly connected , Ethernet0 /0
10.10.11.4 is directly connected , Ethernet0 /1
192.168.1.0/28 is subnetted , 1 subnets
192.168.1.0 is directly connected , Ethernet0 /2
192.168.2.0/28 is subnetted , 1 subnets
192.168.2.0 [120/1] via 10.10.11.2 , 00:00:19 , Ethernet0 /0
192.168.3.0/28 is subnetted , 1 subnets
192.168.3.0 [120/1] via 10.10.11.6 , 00:00:04 , Ethernet0 /1

R2 () R3 (),
R1 () . R , , RIP. ,
, ()
. , .
Gateway of last resort is not set , ,
-.
-, , , 6.1.
show ip route
. , (show ip
route rip show ip route ospf ..) ,
, , .
, show ip route static show ip route connected,

62

. .

, , , .
,
RIP. , -
, RIP ,
. - , - , .
IP-,
() . IP-, IP- , TTL .
, TTL , IP, (packet drop).
, (
) .
, (split horizon). ,
. , , R1 ()
(.20) R3 () 192.168.3.0/28
ethernet 0/1 (IP- 10.10.11.5), R3 (),
, 192.168.3.0/28 R1 (). , ,
, ethernet 0/2 (IP- 192.168.3.1) R3 (), , ,
192.168.3.0/28 R1 (). R1
() 192.168.3.0/28,
R3 (),
. .
, ,
- (, serial 0/0), ( ,
serial 0/0).
, .
.

63


,
. - . , no ip split-horizon
.
72.
darkstar > enable
darkstar # conf t
darkstar ( config )# interface ethernet 0/0
darkstar ( config - if )# no shutdown
darkstar ( config - if )# ip address 10.10.11.1 255.255.255.252
darkstar ( config - if )# no ip split - horizon
darkstar ( config - if )# exit

. ,
( .
5.6).
6.2.2. EIGRP
, EIGRP, ,
. , , ,
() ,
.
EIGRP, ,
RIP. , .
, .20 . . , .73
R1("").
73. R1("")
R1 > enable
R1 # conf t
R1 ( config )# ip classless
R1 ( config )# interface ethernet 0/0
R1 ( config - if )# no shutdown

64

. .

R1 ( config - if )# ip address 10.10.11.1 255.255.255.252


R1 ( config - if )# exit
R1 ( config )# interface ethernet 0/1
R1 ( config - if )# no shutdown
R1 ( config - if )# ip address 10.10.11.5 255.255.255.252
R1 ( config - if )# exit
R1 ( config )# interface ethernet 0/2
R1 ( config - if )# no shutdown
R1 ( config - if )# ip address 192.168.1.1 255.255.255.240
R1 ( config - if )# ^ Ctrl - Z
R1("")
.67, ip
classless, . , , EIGRP
(bandwidth) , /. , (ethernet, fastethernet, serial, atm ..)
, . EIGRP . ethernet,
-, 10 000 / (10 /). , ,
,
, . bandwidth,
, /. ,

serial 0/0, 115 /, :
74.
R1 > enable
R1 # conf t
R1 ( config )# interface serial 0/0
R1 ( config - if )# no shutdown
R1 ( config - if )# ip address 10.10.10.1 255.255.255.252
R1 ( config - if )# bandwidth 115
R1 ( config - if )# ^ Ctrl - Z
, EIGRP.

router, (eigrp) , 1-65535. EIGRP, ..
(AS) BGP.

65

,
. .. EIGRP .
EIGRP , ,
. .. EIGRP .
EIGRP, . , 10.10.0.0 100, 172.16.10.0
101 :
75. EIGRP
darkstar > enable
darkstar # conf t
darkstar ( config )# router
darkstar ( config - router )#
darkstar ( config - router )#
darkstar ( config )# router
darkstar ( config - router )#
darkstar ( config - router )#

eigrp 100
network 10.10.0.0
exit
eigrp 101
network 172.16.10.0
^ Ctrl - Z

, .20, , .
.76 EIGRP R1(""):
76. EIGRP R1("")
R1 # conf t
R1 ( config )# router
R1 ( config - router )#
R1 ( config - router )#
R1 ( config - router )#
R1 ( config - router )#

eigrp 100
no auto - summary
network 10.10.11.0
network 10.10.11.4
network 192.168.1.0

RIP (.68),
network 10.10.11.0, network 10.10.11.4 network 192.168.1.0, . no auto-summary
.
router eigrp 100 EIGRP 100. R2("") R3("") .77
78
77. R2("")
!

66
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password - encryption
!
hostname R2
!
boot - start - marker
boot - end - marker
!
no logging console
!
no aaa new - model
memory - size iomem 5
!
!
ip cef
!
ip classless
!
no ip domain lookup
!
!
interface Ethernet0 /0
ip address 10.10.11.2 255.255.255.252
full - duplex
!
interface Ethernet0 /1
ip address 10.10.11.10 255.255.255.252
full - duplex
!
interface Ethernet0 /2
ip address 192.168.2.1 255.255.255.240
half - duplex
!
interface Ethernet0 /3
no ip address
shutdown
half - duplex
!

. .


router eigrp 100
network 10.0.0.0
network 192.168.2.0
no auto - summary
!
ip http server
no ip http secure - server
!
control - plane
!
line con 0
line aux 0
line vty 0 4
login
!
end
78. R3("")
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password - encryption
!
hostname R3
!
boot - start - marker
boot - end - marker
!
no logging console
!
no aaa new - model
memory - size iomem 5
!
!
ip cef
!
ip classless
!
no ip domain lookup

67

68

. .

!
!
interface Ethernet0 /0
ip address 10.10.11.9 255.255.255.252
full - duplex
!
interface Ethernet0 /1
ip address 10.10.11.6 255.255.255.252
full - duplex
!
interface Ethernet0 /2
ip address 192.168.3.1 255.255.255.240
half - duplex
!
interface Ethernet0 /3
no ip address
shutdown
half - duplex
!
router eigrp 100
network 10.0.0.0
network 192.168.3.0
no auto - summary
!
ip http server
no ip http secure - server
!
!
control - plane
!
line con 0
line aux 0
line vty 0 4
login
!
end
show ip route show ip route eigrp,
c , EIGRP, , . , show ip eigrp neighbors EIGRP . eigrp

69

log-neighbor-changes EIGRP
. show ip eigrp topology EIGRP- . , show ip eigrp traffic
, ,
EIGRP .
6.2.3. BGP

70

7.

. .

71

8.
[1] . Cisco IOS. .: , .: , 2008.
[2] . Cisco. .: , 2008.
[3] . Cisco. .: , 2003.
[4] ., . . .: , 2003.
[5] . TCP/IP. , 3- . .: -, 2004.
[6] . ., . . . , , :
. 3- . .: , 2008.