Вы находитесь на странице: 1из 64

MPLS

MPLS Inter-AS
MPLS CSC

dmishilo@cisco.com

2013
1

1. MPLS.
MPLS L3VPN.

2. Inter-AS A,B,C

3. CSC

4. Inter-AS L2 VPNs

1.
MPLS.
MPLS
L3VPN.


AS
10.1.1.0/24

10.2.2.0/24

Border A

10.3.3.0/24
AS 200

10 - NH - B

AS 100
10 - NH - A

20.1.1.0/24

iBGP

20.2.2.0/24
10 - NH - B

20.3.3.0/24

10 - NH - B

10 - NH - C

30.1.1.0/24
D

30.2.2.0/24
30.3.3.0/24

AS 300

IP-:
-



AS

BGP AS
(
BGP IGP, AS)

,
,
300 000

ISP2
ISP1

EBGP
IBGP
Border1

RR
Core1

Transit AS
IBGP

EBGP
RR

Border2

Core2

EBGP
IBGP
Border3
ISP3

10 - NH - A

IP-:

20 - NH - A
30 - NH - A
40 - NH - Y

10

50 - NH - Y

20

60 - NH - Y

30

70 - NH - C

40

80 - NH - C

50

40

90 - NH - C

A Int E0/0

40

E0/0

40
E0/1

A
10 - NH - X
20 - NH - X
30 - NH - X
40 - NH - B
50 - NH - B
60 - NH - B
70 - NH - C
80 - NH - C
90 - NH - C
X Int E0/0
B Int E0/1
C Int E0/1

E0/0

Transit AS
E0/1

40

Int E0/0

40

Y Int E0/1
E0/1

E0/0

Core1

Core2

10 - NH - A

10 - NH - A

20 - NH - A

20 - NH - A

30 - NH - A

30 - NH - A

40 - NH - B

40 - NH - B

50 - NH - B

50 - NH - B

60 - NH - B

60 - NH - B

70 - NH - C

70 - NH - C

80 - NH - C

80 - NH - C

90 - NH - C

90 - NH - C

A Int E0/0

A Int E0/0

B Int E0/1

B Int E0/1

C Int E0/1

C Int E0/2

E0/0

E0/1

60

E0/2

E0/0

E0/1

10 - NH - A

20 - NH - A

30 - NH - A

70

40 - NH - B

80

50 - NH - B

90

60 - NH - B
70 - NH - Z
80 - NH - Z
90 - NH - Z
A Int E0/0

B Int E0/0
Z Int E0/1
6

Cisco Express Forwarding (CEF)

BGP Table

IP Routing
Table

(RIB)

FIB Table
(CEF Cache)

Adjacency
Table

Address
40.0.0.0
...
Protocol
BGP
OSPF
conn.

Address
40.0.0.0
...

IP Address
1.1.1.1
...

Prefix
/8
...
Address
40.0.0.0
10.1.1.16
1.1.1.0

Prefix
/8
...

AS-Path
100
...
Prefix
/8
/30
/24

Next-Hop Communities Other Attributes


10.1.1.17
36:12
...
...
...
Next-Hop Outgoing Interface
10.1.1.17
--1.1.1.1
Ethernet 0/1
--Ethernet 0/1

Adjacency Pointer
1.1.1.1
...

Layer 2 Header
MAC Header
...

ARP Cache
IP Address
MAC Address
1.1.1.1
0c.00.11.22.33.44
...
...
8

, ,
,
.
,
, .
AS
.

10 - NH - A

L1

20 - NH - A

L1

30 - NH - A

L1

40 - NH - Y
50 - NH - Y

10

LDP - Lable Distribution Protocol

20

60 - NH - Y

30

PHP - Penultimate Hop Popping


X
40 L2

E0/0

40 L2
E0/1

E0/0

Transit AS 40
E0/1

L2

70 - NH - C

L3

40

80 - NH - C

L3

50

90 - NH - C

L3

A Int E0/0

A L1

B Int E0/0

B L2

Y Int E0/1
E0/1

E0/0

E0/0

IGP

E0/1

60

C L3

B
40 L2

Core1

Core2

20 - NH - X

A Int E0/0

A Int E0/0

30 - NH - X

B Int E0/1

B Int E0/1

10 - NH - A

L1

40 - NH - B

L2

C Int E0/1

C Int E0/2

20 - NH - A

L1

50 - NH - B

L2

A L1

A L1

30 - NH - A

L1

70

60 - NH - B

L2

B L2

B L2

40 - NH - B

L2

80

70 - NH - C

L3

C L3

C L3

50 - NH - B

L2

90

80 - NH - C

L3

L1 Int E0/0

L1 Int E0/0

60 - NH - B

L2

90 - NH - C

L3

L2 Int E0/1

L2 Int E0/1

X Int E0/0

A L1

L3 Int E0/1

L3 Int E0/2

B Int E0/1

B L2

C Int E0/1

C L3

E0/2

10 - NH - X

BGP

40

E0/0

E0/1

70 - NH - Z
80 - NH - Z
90 - NH - Z
A Int E0/0

A L1

B Int E0/0

B L2

Z Int E0/1

C L3
10

BGP
MPLS-
ISP2

ISP1

IBGP

EBGP

Border1

Core1

EBGP

Core2

Border2

Transit AS


BGP.

IGP ( OSPF,ISIS, EIGRP,RIP)
LDP
next-hop.
11


Label Distribution Protocol (LDP)
.
Label Switch Path (LSP)
MPLS.
IP routing
protocol
updates

A
D
G
B
H
LSP:
AB D G I

IGP .
12

MPLS - 1
1.

IP- (IP routing table).

2.

,
, LIB

3.


LFIB.

IP routing table , IP, LFIB.

Edge LSR

(IGP,BGP)

Control Plane
Routing Protocol (OSPF, BGP .)
1

(LDP)

Label Distribution Protocol (LIB)

CEF

IP Routing Table (RIB)

ip-

Data Plane
IP Forwarding Table (FIB)

Label Forwarding Table (LFIB)

Ip-

13

LSP
Loopback
10.1.1.1
23

A
D
LFIB:
push77
LIB:
10 77
10 57

G
B
H
LFIB:
7716

LFIB:
1634

LIB:
10 16
10 51

LIB:
10 23
10 34
10 51

LFIB:
34pop
LIB:
10 pop

LDP LSP-.
14

MPLS BGP
IP Routing
Table

Protocol
BGP
OSPF
conn.

Address
20.0.0.0
20.1.1.16
10.1.1.0

Prefix
/30
/24

Next-Hop Outgoing Interface


20.1.1.17
--10.1.1.1
Ethernet 0/1
--Ethernet 0/1

IGP.

BGP-
BGP next-hop . BGP
next-hop

15

MPLS-Based Transit AS
FIB LFIB
AS

ISP1

ISP2
1.2.3.5

10.0.0.0 next-hop 1.2.3.4

Border1
FIB:
1.2.3.4 23
10.0.0.0 23
LFIB:
push 23

Core1

Border2

Core2

1.2.3.4/32

1.2.3.4/32

1.2.3.4/32

1.2.3.4/32
L=23

1.2.3.4/32
L=35

1.2.3.4/32
L=pop

1.2.3.4

FIB:
1.2.3.4 loopback0
10.0.0.0
1.2.3.5
1.2.3.4 loopback0
LFIB:

FIB:
1.2.3.4 35

FIB:
1.2.3.4 pop

LFIB:
23 35

LFIB:
35 pop

16

MPLS-Based Transit AS

ISP2

ISP1

1.2.3.5

23

Border1

10.1.1.1

35

Core1

10.1.1.1

10.1.1.1

Core2

1.2.3.4

Border2

FIB:
1.2.3.4 23
10.0.0.0 1.2.3.4

FIB:
1.2.3.4 35

FIB:
1.2.3.4 pop

FIB:
1.2.3.4 serial0/0
10.0.0.0
1.2.3.5
1.2.3.4loopback 0

LFIB:
push 23

LFIB:
23 35

LFIB:
35 pop

LFIB:

17

MPLS L3VPN

18


Provider (P) device: P

Customer A
Site #1
Remote
Office

Remote
Office

P-Network

Site #1
CE router

Customer A
Site #2

Customer A
Site #3

Customer B
Site #1

PE Router
POP-X

P Router

Customer A
Site #4

PE Router
POP-Y

P Router

Provider network (P-network):


Provider edge (PE) device:
P-

CE-
VPN-

Customer B
Site #2

Customer B
Site #3

Customer B
Site #4

Customer edge (CE) device: C-


Customer network (C-network):
P-;

customer premises equipment (CPE)

VPN
19

PE-
PE Router

E0/1
Customer A
Site #1

IP Router

P Router
E0/5

E0/2

Customer A
Site #2

Customer A
Site #3

Customer B
Site #1

Virtual IP Routing
Table A

Global IP
Routing Table

E0/3

E0/4

Virtual IP Routing
Table B

20

Customer A

Customer B

PE Router X

IGP for Customer A

IGP for Customer A

IGP for Customer B

IGP for Customer B

IGP for Customer C

IGP for Customer C

P Router

Customer B

PE Router Y

Customer C

P-Network
Customer C

Customer A

Q: PE-
?
A1: Interior Gateway Protocol (IGP)
P-.
.
P- .
21





PE-
Customer A

Customer B

Customer B

PE Router X

P Router

PE Router Y

Customer C

P-Network
Customer C

Customer A


PE- BGP.
64-
(route distinguisherRD) .
96-
22

MPLS VPN P
MPLS VPN Backbone
MP-BGP

CE Router

CE Router

VPN Routing

VPN Routing

PE Router

P Router
IGP

PE Router
IGP

CE Router

CE Router

PE-CE: (VPN Routing)

PE-P-PE: IGP

PE-PE: MP- BGP VPNv4 PE

23

Route Distinguisher
MPLS VPN
A 64-bit Route Distinguisher

IPv4-
96-bit VPNv4

P-Network

96-bit VPNv4-
BGP
PE-.

Customer A

Customer A

PE 1

PE 2
Customer B

Customer B

CE- IPv4
PE.
24

Route Distinguisher
Route Targets MPLS VPN
RD VPNv4 prefix,
32-bit IPv4
prefix.

VRF RT ,
,
RT VRF

Customer VRF

BGP Table

P-Network
Customer A

Customer A

PE 1
Customer B

PE 2
Customer B

PE
IPv4 CE
.
25

MP-BGP Update
8 Bytes

4 Bytes

8 Bytes

100:1

10.1.1.0

100:5

RD

IPv4

Route-Target

3 Bytes

286

Label

VPNv4

MP-IBGP update : RD, RT, Label


- VPNv4 address (RD+IP address)
- Extended communities - route targets

-
VPN
- BGP (AS path, local
preference, MED, standard community )
26

10,20,30
10
20
30

CE1-1

40,50,60
40
50
60

40

E0/0

40

L21/L2

CE2-1

40
50
60

E0/2

VRFs RIB

E0/1
E0/0

Core1

E0/0

E0/1

Core2

E0/0

E0/2

IGP

A conn-loop0
B Core1-E0/1

A A-E0/0
B Core2-E0/1

A Core1-E0/0
B B-E0/1

A Core2-E0/0
C
B conn-loop0

LDP

A pop
B L7

A L8
B L2

A L3
B L5

A L9
Pop - B

A
B L2

pop L8
L2 L5

L8 L3
L5 pop

A L3
B

10
20
30
10
20
30

40 NHB
50 NHB
60 NHB
40 NHB
50 NHB
60 NHB

(IP CEF)

40 L21

E0/0

LFIB

FIB

40
L21

E0/1
E0/1

10
20
30

40

L21/L5

100:10
100:20
100:30
200:10
200:20
200:30

NHA
NHA
NHA
NHA
NHA
NHA

L11
L12
L13
L14
L15
L16

100:40
100:50
100:60
200:40
200:50
200:60

NHB
NHB
NHB
NHB
NHB
NHB

L21
L22
L23
L24
L25
L26

10 CE1-1 E0/0
20 CE1-1 E0/0
30 CE1-1 E0/0
40 L21/L2 E0/1
50 L22/L2 E0/1
60 L23/L2 E0/1

MP-BGP VPNv4

10 CE1-2 E0/1
20 CE1-2 E0/1
30 CE1-2 E0/1
40 L24/L2 E0/1
50 L25/L2 E0/1
60 L26/L2 E0/1

1: VPN- VPN PE
2: VPN- PE MP-BGP update.
3: VRF

40
50
60
40
50
60

10
20
CE2-1
30
10
20
30

CE2-2

100:40
100:50
100:60
200:40
200:50
200:60

NHB
NHB
NHB
NHB
NHB
NHB

L21
L22
L23
L24
L25
L26

40
50
60

100:10
100:20
100:30
200:10
200:20
200:30

NHA
NHA
NHA
NHA
NHA
NHA

L11
L12
L13
L14
L15
L16

10 NHA
20 NHA
30 NHA

10 L11/L3 E0/0
20 L12/L3 E0/0
30 L13/L3 E0/0
40 CE2-1 E0/1
50 CE2-1 E0/1
60 CE2-1 E0/1

40
50
60

10 NHA
20 NHA
30 NHA

10 L14/L3 E0/0
20 L15/L3 E0/0
30 L16/L3 E0/0
40 CE2-2 E0/2
50 CE2-2 E0/2
60 CE2-2 E0/2

27

MPLS VPN

LSP-
PE
PE BGP- BGP next
hops IGP.
..
LSP- .
, BGP next hop,
MP-BGP
.

28

QoS MPLS
Frame
Header

IP

Payload

IP Precedence

MPLS Experimental

Frame
Header

LABEL

IP

Payload

MPLS 3 - experimental bits.


Cisco 3
IP Precedence 3 MPLS experimental.

MPLS
experimental bits.
29

2.
Inter-AS MPLS

30

MPLS-
1

AS1

1
AS2

AS3

MPLS-

MPLS VPN- ,
,
..

:
1. (Inter-AS)
2. (CSC)
31


ASBR-A ASBR-B
A

MPLS
A
1

A
2

Inter-AS -

()

-



VPN MPLS

-

VPN-

A
1

A
2

CSC -




. A



VPN-

32

Inter-AS VPN
A: Back-to-back VRFs

B:MP-eBGP for VPNv4

AS #1

ASBR_1

ASBR_2

AS #2

C:Multihop MP-eBGP

PE-1
VPN-A

CE-1

Client-A

RR

RR

PE-2
VPN-A
CE-2

Client-A

VPNv4
(A, B, C)
33

Inter-AS VPN A

ASBRs Back-to-Back VRFs


ASBR
ASBR CE

BGP VPN-IPv4
Net=RD:17.1/16

NH=ASBR1
Route Target 100:1

BGP VPN-IPv4
Net=RD:17.1/16
NH=PE2
Route Target 200:1

Unlabeled
IP Packets

VPN Label=40

PE1

VPN Label=80

PE2

P1
P1

AS1
IP

IP

40 ASBR1

VRF-Lite
Configuration

PE-ASBR1
IP

40

P2

PE-ASBR2

IP

IP

AS2

80 PE2

IP

80

IP

MPLS
ASBR- VPN/VRF

ASBR- IP
PE-CE
IP QoS ASBR

A
VPN
34
34

Inter-AS VPN B
ASBRs MP-eBGP VPNv4 VPN- c
MP-BGP VPNv4
10/8

20

20

CE1

L23/L1

PE1

20

ASBR1

L28

20

L21/L3

ASBR2

20

20/8
CE2

PE2

AS 2

AS 1
IGP

FIB

PE1
ASBR1

PE1
ASBR1

PE2
ASBR2

PE2
C
ASBR2

LDP

LFIB

ASBR1 L1

PE1 L2

PE2 L3

ASBR2 L4

MP-BGP VPNv4
10/8 NH:CE1

20/8 NH-PE1

100:10/8 NH:PE1 L11

100:10/8 NH:ASBR1 L17

100:20/8 NH-ASBR1 L23

100:20/8 NH-ASBR2 L28

100:10/8 NH:ASBR2 L13

100:20/8 NH-PE2 L21

LFIB

20/8 NH:CE2

10 ASBR2 E0/0 L13/L4


20 CE2 E0/1 unlabeled

10 CE1 E0/0 - unlabeled


20 ASBR1 E0/1 L23/L1

FIB

10/8 NH:PE2

L17 L11/L2 E0/0


L23 L28 E0/1

L13 L17 E0/0


L28 L21/L3 E0/1

VPNv4 PEs ASBR

VPNv4 Next Hop labels


ASBR. ASBR VPNv4 BGP .
35

Inter-AS VPNOption B

ASBR-
1. ASBR next hop VPNv4
Next Hop
AS2

ASBR1

Next Hop
AS1

ASBR2
AS #2

AS #1
PE1

PE2

2. eBGP IGP AS
ASBR1
AS #1
IGP1

PE1

ASBR2
AS #2
IGP2

PE2
36

36

Inter-AS VPN B

VRF ASBR
IOS, ASBR /32
ASBR
IGP next-hop-self
LSP

IOS XR Next
Hop ASBR B C address families
(IPv4, IPv6, VPNv4, VPNv6).
IOS XR eBGP route-policy

. address
families (IPv4, IPv6, VPNv4, VPNv6).
ASBR-ASBR
. GRE-.

37

Inter-AS VPNOption B

eBGP ASBR Cisco IOS


eBGP for
VPNv4

ASBR1

ASBR2

E1/0

AS #1
PE1

AS #2
PE2

Interface E1/0
CE2
mpls bgp forwarding
!
VPN-R1 router bgp 1
VPN-R2
neighbor <ASBR2> remote-as 2
neighbor <PE1> remote-as 1
neighbor <PE1> update-source loopback0
no bgp default route-target filter
!
address-family vpnv4
neighbor <PE1> remote-as 1 activate
neighbor <PE1> remote-as 1 next-hop-self
neighbor <ASBR2> remote-as 2 activate
neighbor <ASBR2> remote-as 2 send-comm extended
ASBR no bgp default route-target filter
VPNv4 ASBR VRF, .. PE
VPNv4 VRF.
CE1

38

Inter-AS VPNOption B

eBGP ASBR Cisco IOS XR


eBGP for VPNv4
ASBR1
PE1

AS #1

Int gig0/0/1

Int gig0/0/1

50.0.0.1

50.0.0.2

router bgp 1
mpls activate (Enables MPLS forwarding on
ASBR)
interface <type & #> (Specify ASBR-ASBR link)
address-family vpnv4 unicast
!
neighbor <ASBR2>
remote-as 2
address-family vpnv4 unicast (Initialize VPNv4
address family for ASBR)
route-policy pass-all in
route-policy pass-all out
(Allow forwarding of VPNv4 routes to other AS)
!
route-policy pass-all
pass
end-policy
!

ASBR2
PE2
AS #2

!
neighbor <PE1>
remote-as 1
update-source loopback0
address-family vpnv4 unicast
next-hop-self
(!Set ASBR1 as next-hop-self!)
!
router static
50.0.0.2/32 interface gig0/0/1
!
(!Static Route for ASBR-ASBR link must
be configured. It is not installed
automatically like in IOS!)

: Static route route-policy addressfamilies Option B C

39

Inter-AS VPN
RRs MP-eBGP VPNv4 VPN- c

RR1

10/8

20

20

CE1

RR2

MP-BGP VPNv4
L21/L3

PE1

20

ASBR1

L21/L3

20

L21/L3

ASBR2

20

20/8
CE2

PE2

AS 2

AS 1

eBGP IPv4 + Labels IGP + LDP

ASBRs


PE loopbacks
PE1
PE1
PE2
PE2
RIB

ASBR1

ASBR1

ASBR2

ASBR2

ASBR1 L1

PE1 L2

PE2 L3

ASBR2 L4

PE2 L3

PE2 L3

PE1 L2

PE1 L2

RRs PE2

VPNv4PE1

PE2
PE1
ASBR2
ASBR1
ASBR1
ASBR2
LIB

100:10/8 NH:PE1 L11

100:10/8 NH:PE1 L11

MP-BGP VPNv4
10/8 NH:CE1

20/8 NH-PE1

FIB
LFIB

100:10/8 NH:PE1 L11

100:10/8 NH:PE1 L11

100:20/8 NH-PE2 L21

100:20/8 NH-PE2 L21

10 CE1 E0/0 - unlabeled


L3
20 PE2 E0/1 L21/L?

L2 E0/0
L3 E0/1

L2 E0/0
L3 E0/1

10/8 NH:PE2

20/8 NH:CE2

L2
10 PE1 E0/0 L11/L?
20 CE2 E0/1 unlabeled
40

Inter-AS VPN
Multihop eBGP VPNv4 RRs
eBGP for VPNv4
RR1
PE1

AS #1

RR2
1.eBGP IPv4 + Labels

ASBR1

2.IGP + LDP

AS #2

PE2

ASBR2

Route Reflectors VPNv4


ASBRs loopbacks PE (IPv4) .. BGP
NH
ASBRs VPNv4 .
BGP NH PEs :

1. BGP IPv4 + Labels (RFC3107)


2. IGP + LDP
RFC3107: BGP exchange Label Advertisement Capability
end-end LSP
Subsequent Address Family Identifier (SAFI 4)
NLRI
Next-hop-self eBGP RRs

41

I-AS VPNOption C
IPv4+Label, Cisco IOS Configuration
router bgp 1
address-family ipv4
network 1.1.1.1 mask 255.255.255.255 (loop0 PE1)
neighbor <RR1> activate
neighbor <RR1> send-label
RR1

AS #1

ASBR1

PE1
Interface e1/0
mpls bgp forwarding

!
router bgp 1
neighbor <RR2> remote-as 2
neighbor <RR2> ebgp-multihop 255
neighbor <RR2> update-source loop0
RR2
!
address-family ipv4
neighbor <PE1> activate
neighbor <PE1> send-label
neighbor <ASBR1> activate
neighbor <ASBR1> send-label
! ASBR2
address-family vpnv4
PE2
neighbor <RR2> activate
neighbor <RR2> send-comm extend
neighbor <RR2> next-hop-unchanged

router bgp 1
address-family ipv4
neighbor <ASBR2> activate
neighbor <ASBR2> send-label
neighbor <RR1> activate
neighbor <RR1> next-hop-self
neighbor <RR1> send-label

42

I-AS VPNOption C
IPv4+Label, Cisco IOS XR Configuration
router bgp 1
neighbor <RR1>
remote-as 1
address-family ipv4 labeled-unicast
RR1

AS #1

router bgp 1
neighbor <RR1>
remote-as 1
address-family ipv4 labeled-unicast
neighbor <ASBR2>
remote-as 2
address-family ipv4 labeled-unicast
route-policy <RPL> in
route-policy <RPL> out

ASBR1

RR2

PE1

!
router bgp 1
address-family vpnv4 unicast
!
neighbor <RR2>
remote-as 2
address-family vpnv4 unicast
ebgp-multihop 255
next-hop-unchanged
!

PE2

AS #2
ASBR2

43

Inter-AS
MD5 LDP/BGP

max prefix
Static Labels
TTL DoS
BGP ASPATH, ext
communities, RDs .. route-maps

RT ( RT Constraint )
Route Targets, RT (RT Rewrite)

44

Route Target Rewrite Example


VPN-A
Export RT 100:1
Import RT 100:1

VPNv4

Rewrite RT:

Exchange

100:1->200:1

VPN-A
Export RT 200:1
Import RT 200:1

PE-ASBR1
AS #1
PE-1

AS #2
PE-ASBR2

PE2
CE2

CE-1
VPN-A-1

Rewrite RT:

Replace Incoming Update on ASBR2:

200:1->100:1

ip extcommunity-list 1 permit rt 100:1


!
route-map extmap permit 10
match extcommunity-list 1
set extcommunity-list 1 delete
set extcommunity rt 200:1 additive
!
route-map extmap permit 20
!
neighbor X.X.X.X route-map extmap in

VPN-A-2

45

Inter-AS L3VPN Summary

: A, B, C

A ,
QoS.
B, A VRF

C, A
A VRFs
eBGP ASBR
ASBRs VPNv4
C, ,
, SP

ASBR- IPv4 loopback
PE-
Route Reflector- VPNv4
46

3.
CSC

47

CSC VPN

CSC-PE1

CSC-PE2

MPLS

MSK-CSC-CE1
MSK-RR1

NS-CSC-CE2

NS-RR1
MSK-PE1

NS-PE2

MSK-PE2

A
VPN-A1

VPN-E1 VPN-C1

NS-PE1

VPN-B1

VPN-A2
C

VPN-B2

VPN-C2

VPN-E2

-
: CSC-PE, CSC-CE, RR, PE, CE, External Routes,
Internal Routes

48

CSC Model III Routing Exchange

ISP1
PE

ISP1

Backbone
RR1

CSC-CE1

CSC-PE1

Service Provider

CSC-PE2 CSC-CE2

eBGP + Label

CE1-red

CE1-green

PE

MPLS

MPLS

PE1

RR2

MPLS
Backbone

MP-iBGP VPNv4

eBGP + Label

PE2

CE2green

CE2-red

RR1 RR2 VPNv4

49

Customer Carrier Supports MPLS VPNs


Establishing peers and forwarding VPN
traffic
MP-iBGP Peering

VPN-v4 Update:
RD:1:27:149.27.2.0/24,
NH=PE2
RT=1:231, Label=(28)

MP-iBGP
MPLS
PE1
Site A
VPNA

IP/MPLS

VRF
CSC-CE1

VRF

CSC-PE1

AS2

VRF

CSC-PE2

MPLS
CSC-CE2

AS1

149.27.2.0/24
VRF

CE2

Swap

Swap

Site B
VPN A

AS1

CE1

Push

PE2

Pop

Swap

Push

Pop

Push

Label
CE2-VPN-Label

Payload

Label
Label=28

Label=120

Payload

Label=100

Label

Label=28

Label=50
Label=28

Label=28

Label=28

Payload

Payload

Payload

Payload

Payload

50

Best Practice

Static default routes CSC-CE

End-End LSP VPN MPLS VPN


CSC-CE CSC-PE ,
eBGP+IPv4 Labels
RRs customer carrier
next-hop-unchanged RRs

51

CSC Summary
CSC VPN
VPNs customer carriers backbone
MPLS VPN Service Provider
QoS CSC-CE CSC-PE MPLS EXP

CSC
MPLS IPV6 VPNs
Multicast VPNs
MPLS L2 VPNs
MPLS TE

52

4.
Inter-AS L2 VPNs

53

L2VPNs
Pseudowire

Targetted-LDP Peers
VC types & Labels
exchanged

PE1

CE1

PW1

PE2

CE3

PW2

CE2

IP/MPLS

AC

AC

CE4

AS1

L2VPN L2-

PW IP MPLS
Virtual Circuit(VC) Attachment Circuit (AC)

L2-
L2VPN PE
VC T-LDP
54

Any Transport over MPLS


3. PE1
VC
VC
ID

4. PE1
PE2
,
VC
VC

2. PE1
LDP- PE2

1. L2-

PE1

PE1

PSN
P1

P2

5. PE2
VC VC,


VC
PE2
1-5,

/VCID
PE2

CE

CE

L2PDU 21 50

L2PDU 21 90 L2PDU 21

L2PDU

PE LDP
VC ID . VC
.
HDLC, PPP, Ethernet, ATM
Frame Relay

55

Virtual Private LAN Service (VPLS)


VPLS :
VSI: Virtual Switching Instance ( VFI-Virtual Forwarding Instance)
VPN.
VPLS
(PW) PE. PW
LDP.
L2- (
VLAN).
CE

PE3

PW

LSP

CE

PW

CE

PE4
CE

PW
PW
CE

CE
VSI
VSI
VSI

LDP PE

PE2

PW
VSI

VSI
VSI
VSI

CE

CE
56

L2VPN Inter-AS
:



AS

Option B

PE1

Option A

Option A


AS
ASBR S-PEs
(multi-segment PWs)
eBGP (IPv4 prefix + label)

AS

Option C

AS
PW
AS

IP/MPLS
AS X ASBR1

LDP/RSVP-TE

Targeted-LDP

IP/MPLS
ASBR2 AS Y

PE2

LDP/RSVP-TE

PW AC
Native Ethernet

Targeted-LDP

Option B

PE1

IP/MPLS
AS X ASBR1

IP/MPLS
ASBR2 AS Y

PE2

LDP/RSVP-TE

eBGP (IPv4+Label)

LDP/RSVP-TE

Targeted-LDP

Targeted-LDP

Targeted-LDP

Option C

PE1

IP/MPLS
AS X ASBR1

LDP/RSVP-TE

IP/MPLS
ASBR2 AS Y

eBGP (IPv4+Label)

PE2

LDP/RSVP-TE

Targeted-LDP

57

L2VPN Inter-AS Option A


CE-1

PE1

ASBR1

MPLS

ASBR2

Pseudowire 1

RSVP-TE / LDP
Targeted-LDP
VC and
Tunnel label
imposition

Push

PE2

MPLS

CE-2

Pseudowire 2

RSVP-TE / LDP
Targeted-LDP
Penultimate
Hop

Native Ethernet
on NNI

PW 1 VC
label
No MPLS
disposition
enabled
Pop
Pop

Push

Push

Popping (PHP)
Pop
Pop

PW 2VC
label
disposition

Push

Tunnel Label
VC Label

Label = 34
Label = 28

Label = 28

Payload

Payload

Payload

Label = 19

Payload

Label = 88

Label = 88

Payload

Payload

Payload

Traffic direction
58

L2VPN Inter-AS Option B


CE-1

PE1

ASBR1

MPLS

Pseudowire 1

Push

Pop

RSVP-TE / LDP
Targeted-LDP

BGP on NNI used to


exchange tunnel label

VC labels swapped
Swap

No LDP on NNI

Push

CE-2

Pseudowire 3

eBGP IPv4+Label
Targeted-LDP

PW switching point

PE2

MPLS

Pseudowire 2

RSVP-TE / LDP
Targeted-LDP

VC and Tunnel
label imposition

ASBR2

Swap

Penultimate Hop
Popping (PHP)
Pop

VC label
disposition

Pop

Push

Tunnel Label
VC Label

Label = 34
Label = 28

Label = 28

Label = 45

Label = 88

Label = 88

Payload

Payload

Payload

Payload

Payload

Payload

Label = 19

Payload

Traffic direction
59

Inter-AS L2VPN Option B IOS


Configuration
PE2
!
interface giga1/0
xconnect <ASBR2> 20 encapsulation mpls
!

PE1
!
interface giga1/0
xconnect <ASBR1> 10 encapsulation mpls
!

PE1

ASBR1

ASBR2

PW1

IP/MPLS

PE2
PW3

E1/0 PW2

AS1

E1/0

IP/MPLS
AS2

ASBR1
!
pseudowire-class Pw-switch
encapsulation mpls
!
l2 vfi Pw-switch point-to-point
neighbor <ASBR2> 100 pw-class pw-switch
neighbor <PE1> 10 pw-class pw-switch
!
Interface E1/0
mpls bgp forwarding
!
router bgp 1
neighbor <ASBR2-E1/0> remote-as 2

ASBR2
!
pseudowire-class pw-switch
encapsulation mpls
!
L2 vfi pw-switch point-to-point
neighbor <ASBR1> 100 pw-class pw-switch
neighbor <PE2> 20 pw-class pw-switch
!
Interface E1/0
mpls bgp forwarding
!
router bgp 2
neighbor <ASBR1-E1/0> remote-as1

* loop0
(xconnect ID) ASBR1 IGP(AS1) eBGP

* loop0
(xconnect ID) ASBR2 IGP(AS2) eBGP
60

L2VPN Inter-AS Option C


CE-1

PE1

ASBR1

MPLS

ASBR2

MPLS

PE2

CE-2

Pseudowire 1

eBGP IPv4+Label
Targeted-LDP

RSVP-TE / LDP/iBGP

BGP on NNI used to


exchange tunnel label

PW switching point
VC and Tunnel
label imposition

VC labels swapped
Push

Pop

Push

RSVP-TE / LDP/iBGP

Swap

No LDP on NNI

Push

Swap

Penultimate Hop
Popping (PHP)
Pop

VC label
disposition

Pop

Push

Tunnel Label
VC Label

Label = 34

Label = 35

Label = 36

Label = 19

Label = 28

Label = 28

Label = 28

Label = 28

Label = 28

Payload

Payload

Payload

Payload

Payload

Payload

Payload

Traffic direction
61

Inter-AS AToM Option CConfiguration


HOSTNAME PE1
!
interface Gig1/1/1
xconnect <PE2> 100 encapsulation
mpls
!
! Activate IPv4 label capability !
router bgp 1
!
address-family ipv4
neighbor <ASBR-1> send-label

Notice PW
configuration remains
the same as in intraAS network

HOSTNAME PE2
!
interface Gig1/1/1
xconnect <PE1> 100 encapsulation
mpls
!
! Activate IPv4 label capability !
router bgp 2
!
address-family ipv4
neighbor <ASBR-2> send-label

T-LDP Peers
ASBR1

PE1
Int
Gig1/1/1

ASBR2

PE2

IP/MPLS

IP/MPLS

AS1

AS2

ASBR1
! Activate IPv4 label capability !
router bgp 1
!
address-family ipv4
neighbor <PE1> send-label
neighbor <ASBR-2> send-label

Int
Gig1/1/1

ASBR2
! Activate IPv4 label capability !
router bgp 2
!
address-family ipv4
neighbor <PE2> send-label
neighbor <ASBR-1> send-label
62

Inter-AS L2VPNs
I-AS VPWS VPLS
PWs
PWs
IOS LDP , BGP
Autodiscovery( VPLS)
IOS XR LDP BGP
B BGP PWs
Per-PW Quality of Service (QoS) .
Attachment circuit inter-working IOS XR
L2VPN virtual circuit Traffic
Engineering (TE) (tunnel selection) GRE.

63

L2VPN service support over a CSC


network
Single-Hop PW

PE1

Pseudowire

Customer
Carrier A ASBR1

MPLS Backbone
Carrier
ASBR3

(CsC)

ASBR4

Customer
Carrier A
ASBR2

PE2

PW1

Multi-Hop PW

PE1

Pseudowire

PW1
Customer
Carrier A

ASBR1

ASBR3

ASBR4

MPLS Backbone
Carrier

ASBR2

PE2

Customer
Carrier A

(CsC)

64


1. www.cisco.com - BGP Case Studies
2. MPLS and VPN Architectures

3. MPLS Fundamentals

Ivan Pepelnjak

Luc De Ghein

65

Оценить