Вы находитесь на странице: 1из 8

PMANTASAN NG LUNGSOD NG MAYNILA

University of the City of Manila


Intramuros, Manila

COLLEGE OF ENGINEERING AND TECHNOLOGY


ECE/EE DEPARTMENT

Experiment No.6

Submitted by:
Alicaya, Abigail C.
Guiang, Emmanuel E.
Lumabi, Benedict Junien A.

Submitted to:
Engr. Joan del Espiritu

March 19, 2015

OPEN SHORTES PATH FIRST(OSPF)

OSPF is a link-state routing protocol. It is designed to be run internal to a


single Autonomous System. Each OSPF router maintains an identical database
describing the Autonomous System's topology. From this database, a routing table is
calculated by constructing a shortest-path tree.
OSPF recalculates routes quickly in the face of topological changes, utilizing a
minimum of routing protocol traffic. OSPF provides support for equal-cost multipath.
An area routing capability is provided, enabling an additional level of routing
protection and a reduction in routing protocol traffic. In addition, all OSPF routing
protocol exchanges are authenticated.
Using OSPF, a host that obtains a change to a routing table or detects a change in
the network immediately multicasts the information to all other hosts in the network
so that all will have the same routing table information. Unlike the RIP in which the
entire routing table is sent, the host using OSPF sends only the part that has
changed. With RIP, the routing table is sent to a neighbour host every 30 seconds.
OSPF multicasts the updated information only when a change has taken place.

Use IP block 192.168.0.0/16


All WAN interface connected to s0/0/0 will use the first UIP
All LAN interface will use first UIP
Clock rate 64 000
Use dhcp pool name
Enable secret password cisco
Hostname: RA, RB, RC, RD

No. of

2n

SNM

NA

BA

UIP

LAN D

Hosts
100

2^7

/25

192.168.0.0

192.168.0.127

LAN B

90

2^7

/25

192.168.0.255

LAN F

50

2^6

/26

192.168.0.12
8
192.168.1.0

LAN E

42

2^6

/26

192.168.1.64

192.168.1.127

LAN C

40

2^6

/26

192.168.1.191

LAN A

20

2^5

/27

WAN A

2^2

/30

WAN B

2^2

/30

WAN C

2^2

/30

WAN D

2^2

/30

192.168.1.12
8
192.168.1.19
2
192.168.1.22
4
192.168.1.22
8
192.168.1.23
2
192.168.1.23
6
192.168.1.24
0

192.168.0.1192.168.0.126
192.168.0.129192.168.0.254
192.168.1.1192.168.1.62
192.168.1.65192.168.1.126
192.168.1.129192.168.1.190
192.168.1.193192.168.1.222
192.168.1.225192.168.1.226
192.168.1.229192.168.1.230
192.168.1.233192.168.1.234
192.168.1.237192.168.1.238

192.168.1.63

192.168.1.223
192.168.1.227
192.168.1.231
192.168.1.235
192.168.1.239

RA
LAN A fa0/0
LAN B fa0/1
WAN A s0/0/0
WAN D s0/0/1

192.168.1.193
RD
192.168.0.129
LAN F fa0/0
192.168.1.225
WAN C
192.168.1.238

192.168.1.234

s0/0/1
WAN D

RB

192.168.1.1

s0/0/0

LAN C fa0/0

192.168.1.129

WAN A s0/0/1

192.168.1.226

WAN B s0/0/0

192.168.1.229

192.168.1.237

RC
LAN D fa0/0

192.168.0.1

LAN E fa0/1

192.168.1.65

WAN B s0/0/1

192.168.1.230

WAN C s0/0/0

192.168.1.233

CODES

For OSPF

ROUTER A

RA(config)#ip dhcp pool LANA


RA(dhcp-config)#network 192.168.1.192 255.255.255.224
RA(dhcp-config)#default-router 192.168.1.193
RA(dhcp-config)#exit
RA(config)#ip dhcp pool LANB
RA(dhcp-config)#network 192.168.0.128 255.255.255.128
RA(dhcp-config)#default-router 192.168.0.129
RA(dhcp-config)#exit
RA(config)#exit
RA#
%SYS-5-CONFIG_I: Configured from console by console
%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 192.168.0.129.
%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 192.168.1.193.

RA#en
RA#config t
Enter configuration commands, one per line. End with CNTL/Z.

RA(config)#router ospf 2
RA(config-router)#network 192.168.1.192 255.255.255.224 Area 0
RA(config-router)#network 192.168.0.128 255.255.255.128 Area 0
RA(config-router)#network 192.168.1.224 255.255.255.252 Area 0
RA(config-router)#network 192.168.1.238 255.255.255.252 Area 0
RA(config-router)#exit
RA(config)#exit

ROUTER B

RB(dhcp-config)#ip dhcp pool LANC


RB(dhcp-config)#network 192.168.1.128 255.255.255.192
RB(dhcp-config)#default-router 192.168.1.129
RB(dhcp-config)#exit
RB(config)#%DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged
192.168.1.129.

RB(config)#
RB(config)#router ospf 2
RB(config-router)#network 192.168.1.128 255.255.255.192 Area 0
RB(config-router)#network 192.168.1.224 255.255.255.252 Area 0
RB(config-router)#network 192.168.1.228 255.255.255.252 Area 0
00:04:43: %OSPF-5-ADJCHG: Process 2, Nbr 192.168.1.238 on Serial0/0/1 from
LOADING to FULL, Loading Done

ROUTER C

RC#en

RC#config t
Enter configuration commands, one per line. End with CNTL/Z.
RC(config)#ip dhcp pool LAND
RC(dhcp-config)#network 192.168.0.0 255.255.255.128
RC(dhcp-config)#default-router 192.168.0.1
RC(dhcp-config)#exit
RC(config)#ip dhcp pool LANE
RC(dhcp-config)#network 192.168.1.64 255.255.255.192
RC(dhcp-config)#default-router 192.168.1.65
RC(dhcp-config)#exit
RC(config)#router ospf 2
RC(config-router)#network 192.168.0.0 255.255.255.128 Area 0
RC(config-router)#network 192.168.1.64 255.255.255.224 Area 0
RC(config-router)#network 192.168.1.228 255.255.255.252 Area 0
RC(config-router)#network 192.168.1.232 255.255.255.252 Area 0
RC(config-router)#
00:22:42: %OSPF-5-ADJCHG: Process 2, Nbr 192.168.1.229 on Serial0/0/1 from
LOADING to FULL, Loading Done

RC(config-router)#exit
RC(config)#exit

ROUTER D

RD#en
RD#config t
Enter configuration commands, one per line. End with CNTL/Z.
RD(config)#ip dhcp pool LANf

RD(dhcp-config)#network 192.168.1.0 255.255.255.192


RD(dhcp-config)#default-router 192.168.1.1
RD(dhcp-config)#exit
RD(config)#router ospf 2
RD(config-router)#network 192.168.1.0 255.255.255.192 Area 0
RD(config-router)#network 192.168.1.232 255.255.255.252 Area 0
RD(config-router)#
00:23:22: %OSPF-5-ADJCHG: Process 2, Nbr 192.168.1.233 on Serial0/0/1 from
LOADING to FULL, Loading Done

RD(config-router)#network 192.168.1.236 255.255.255.252 Area 0


RD(config-router)#
RD(config-router)#exit
RD(config)#exit