Вы находитесь на странице: 1из 2

DMVPN

Cisco DMVPN allows branch locations to communicate directly with


each other over the public WAN or Internet, such as when using
voice over IP (VOIP) between two branch offices, but doesn't require
a permanent VPN connection between sites. It enables zero-touch
deployment of IPsec VPNs and improves network performance by
reducing latency and jitter, while optimizing head office bandwidth
utilization.

Page 1 of 1

CCNP_DMVPN and GRE

Why DMVPN
1. Multicast traffic can pass through GRE
tunnels
2. Allows VPN to be treated as a private
network

! R1 HUB

conf t

int fa 0/0
ip address 10.1.1.1 255.255.255.0
no shutdown
exit

int ethernet 3/1


ip address 14.0.0.1 255.255.255.0
no shutdown
exit

ip route 0.0.0.0 0.0.0.0 14.0.0.4

int tunnel 0
tunnel source ethernet 3/1
tunnel mode gre multipoint
tunnel key 6783

ip nhrp network-id 1
ip nhrp authentication cisco123
ip nhrp map multicast dynamic

ip address 172.16.0.1 255.255.255.0


ip mtu 1400
ip tcp adjust-mss 1360
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
exit

router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
end

! Spoke R2:
conf t

int fa 0/0
ip address 10.2.2.2 255.255.255.0
no shutdown
exit

int ethernet 3/2


ip address 24.0.0.2 255.255.255.0
no shutdown
exit

ip route 0.0.0.0 0.0.0.0 24.0.0.4

interface tunnel 0
tunnel mode gre multipoint
tunnel source ethernet 3/2
tunnel key 6783

ip nhrp network-id 1
ip nhrp authentication cisco123
ip nhrp map multicast 14.0.0.1
ip nhrp map 172.16.0.1 14.0.0.1
ip nhrp nhs 172.16.0.1

ip address 172.16.0.2 255.255.255.0


ip mtu 1400
ip tcp adjust-mss 1360
exit

router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
end

! R4 Internet Cloud Router


conf t

int ethernet 3/1


description ISP to R1
ip address 14.0.0.4 255.255.255.0
no shutdown
exit

int ethernet 3/2


description ISP to R2
ip address 24.0.0.4 255.255.255.0
no shutdown
exit

int ethernet 3/3


description ISP to R3
ip address 34.0.0.4 255.255.255.0
no shutdown
end

Page 2 of 2

! R3
conf t

int fa 0/0
ip address 10.3.3.3 255.255.255.0
no shutdown
exit

int ethernet 3/3


ip address 34.0.0.3 255.255.255.0
no shutdown
exit

ip route 0.0.0.0 0.0.0.0 34.0.0.4

interface tunnel 0
tunnel mode gre multipoint
tunnel source ethernet 3/3
tunnel key 6783

ip nhrp network-id 1
ip nhrp authentication cisco123
ip nhrp map multicast 14.0.0.1
ip nhrp map 172.16.0.1 14.0.0.1
ip nhrp nhs 172.16.0.1

ip address 172.16.0.3 255.255.255.0


ip mtu 1400
ip tcp adjust-mss 1360
exit

router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
end

Вам также может понравиться