Вы находитесь на странице: 1из 23

Module 3 - Functions

Introduction
In this module, how to make fluid models (PVT), saturation functions
(relative permeability and capillary pressure), and rock compaction
functions in Petrel, will be covered.
Prerequisites
No prerequisites are required for this module.
Learning Objectives
In this module you will learn:
How to create a correlation based black oil fluid model
How to define the initial contact depths and pressure
How to create correlation based saturation functions
How to create rock compaction functions based on correlations
How to import fluid models and rock physics functions from
keyword files
How to edit and visualize the functions in Petrel

Reservoir Engineering

Functions 65

Lesson 1 - Make fluid model

Make fluid model

The Make fluid model process allows you to create black oil models
from correlations and to create compositional and thermal models. In
this course, we will only use black oil models, but we will briefly
explained how to create compositional models.
Correlation library
The correlation library we use incorporates many published
correlations, some of which use the separator conditions as input. All of
the correlations have been tested against an extensive database of
actual PVT (pressure-volume-temperature) experiments at the
Schlumberger Reservoir Fluids Center in Edmonton, Canada. Petrel
selects which correlation to use based on the input data you provide
the API gravity, the reservoir pressure, etc.
The library contains about 70 black-oil correlations - including the ones
most commonly used in the industry.
66 Functions

Reservoir Engineering

Black Oil and Compositional Models


ECLIPSE Blackoil and FrontSim
Black oil simulators
One component of gas and one
of oil in both vapor and liquid
phase

ECLIPSE Compositional
Compositional simulator
Both the vapor and the liquid
phase consists of several
components

Rv

Rs

There will always be two, or frequently three, phases present in the


reservoir during its producing life (oil, gas, water). The proportions, the
composition and the physical properties of the phases may change as
production proceeds, and pressures change. All of the phases are
considered compressible, although to different degrees.
In a black oil model, the temperature is assumed to be constant.
Typical temperatures at reservoir conditions are 350K~77C~171F. Also,
since both the liquid hydrocarbon phase and the vapor phase are
assumed to consist of mainly one component, it is customary to name
them the oil and gas phase, respectively. The compositional behavior is
modeled by allowing some of the gas component to be dissolved in oil
and some of the oil component to be vaporized in gas.
A compositional fluid model represents the hydrocarbon fluid by a
set of components (typically 6-12 for reservoir simulation). An equation
of state is then used to determine the physical properties of mixtures of
these components as a function of pressure and temperature and the
properties of the individual components.

Reservoir Engineering

Functions 67

Appropriate Black Oil Models


Fits the Black Oil model.

Pressure

Unsuited for black oil simulation


(use Compositional simulation).

G: Near Critical
Fluid

F: Wet Gas,
Retrograde

A: Dead Oil
C: Live Oil,
Saturated

Approximated by Black Oil


varying gas/oil and oil/gas ratios
to mimic small compositional
changes.
B: Live Oil,
Initially
Undersaturated

D: Dry Gas

E: Wet Gas

Temperature

Phase diagrams
The hydrocarbon behavior in a reservoir is often described in terms of a
phase diagram as showed in the illustration above. The phase diagram
relates the fluid state to pressure and temperature in the reservoir. The
upper line of the phase envelope represents the lowest pressure and
temperature limit for the existence of a liquid phase. This line is called
the bubble point line. The lower line represents the upper limit for
pressure and temperature for the existence of a vapor phase. This line
is called the dew point line. The area between the two lines is pressure
and temperature conditions where both a liquid and a vapor phase is
present simultaneously. The point where the bubble point line and the
dew point line meet, is called the critical point. At this pressure and
temperature condition, the vapor and the liquid properties are equal.
Pressure-temperature conditions close to the critical point cannot be
modelled using a black-oil model.

68 Functions

Reservoir Engineering

Make a Fluid Model


1. Select Create new
to define a new fluid
model.

1
2

2. Specify Model type.

Note : All fluid models


will be stored in the
Input pane.

In the process dialog, you need to specify whether to make a black oil,
compositional or thermal fluid model.

Reservoir Engineering

Functions 69

Compositional Model
1. Select equation of state
from the General tab.

Note: There is no
support for tuning an
equation of state to
match laboratory
measurements.

2. Append a row for each


component.

You can select pre-defined


components from the drop-down
menu.
2

3. Go to the Interactions tab


to give interactions and to the
Samples tab to give samples.
3

When you make a compositional model, you must first select an


equation of state at the General tab. Note that there is no support for
tuning the equation of state to laboratory measurements. For that, you
will have to use PVTi and import the resulting matched equation of
state.
When you add a new component on the Components tab, you need to
type in the molecular weight and then click the Fill table button to fill
in the rest of the table according to the equation of state. Note that if
you later change the equation of state, you must return to the
Components tab and click the Fill table button again.

70 Functions

Reservoir Engineering

Make a default Compositional Model


1. Select model type
Compositional.
2

2. Use the drop-down


menu to specify
default model.
All sub-tabs are filled
with preset values.

Make a default Black Oil Model

1
3
2

1. Select Black oil as Model type.


2. On the General tab, specify which
phases are required (enter required
properties in the following tabs).
3. Or use one of the defaults.
4. Specify an initial condition.

Reservoir Engineering

Functions 71

There are four default black oil models to select from:


Dead oil. Two phases, oil and water. Bubble point pressure lower
than minimum reservoir pressure, hence no gas will boil out of
the oil.
Heavy oil+gas. Three fluid phases, oil, gas, and water. The oil has
API gravity of 26.
Light oil+gas. Three phases, oil, gas, and water. A lighter oil with
API gravity of 45.
Dry gas. Two fluid phases, gas and water.
To make a default model, select one of the models from the drop-down
list and go to the Initial conditions tab to specify the initial fluid
contacts.

Make a model using the settings


General tab
Select phases.
Enter pressure and temperature
in the reservoir.

In addition to the four default fluid models, you can make black oil
models by filling in the settings in the process dialog. Based on the
settings, Petrel will select a model based on correlations.
The General tab
In the General tab, you specify which fluid phases that are present and
also the reservoir pressure and temperature.
Reservoir conditions. This is where the minimum and the maximum
pressure in the reservoir is specified. In addition, you must enter the
temperature in the reservoir.
Separator conditions. Here you can specify the pressure and the
temperature at separator conditions. Some of the correlations need
information on separator conditions.
72 Functions

Reservoir Engineering

The Gas tab


Gas
Information on the gas phase
composition entered here is
used to select correlations.

Correlations
Leave as Default to allow Petrel
to select correlations based on
your input.

Gas properties. Enter the density or the gravity of the gas phase. If
you are defining a dry gas, you must type in the vaporized gas/oil ratio.
You can also select which correlations to use or you can make Petrel
select, based on the input you give.
If you have information on the concentration of each component of the
gas phase, this can be entered here. Note that this option is only used
to select which correlations to use, it does not mean that you are
defining a compositional model.

Reservoir Engineering

Functions 73

The Oil tab


Specify gravity and bubble
point pressure.
Correlations are reported on the Statistics
tab of the fluid model

Oil properties. Here, you need to specify the oil density or the oil
gravity (API gravity: The usual range starts with water density at 10
degrees and rises to volatile oils and straw colored condensate liquids
around 60-70 degrees). In addition, you must enter the Bubble point
pressure or the Solution gas/oil ratio at the oil/gas contact. Note
that if the bubble point pressure you supply is lower than the minimum
reservoir pressure, then no gas will boil out of the oil. Consequently,
you get dead oil. Also, notice that unless you plan to give a depth
dependent Solution gas/oil ratio, the bubble point pressure must be
equal to the pressure at the gas/oil contact as specified in the Initial
conditions tab.
You can either select correlations, or leave it to Petrel to select based
on the input you give. Notice that the correlations that are used to make
the fluid model are listed on the Statistics tab of the settings dialog
for the fluid model.

74 Functions

Reservoir Engineering

Initial conditions tab

1
1. From contact set.

2. Define in the table.


3. Add columns to the
table to add initial
condition regions.

Initial conditions tab


In the Initial conditions tab, you can give the initial fluid contacts as
well as the pressure and the capillary pressure at those contacts. This
information is used in the simulator to calculate the initial pressure and
phase saturations in every grid block.
For each fluid region, you must specify a reference depth (datum) and a
corresponding pressure, gas-oil contact depth, and water contact depth
(depending on which phases you have). In the Define simulation case
process you will have the opportunity to associate each of these initial
condition regions with a region of the grid.
There are two ways you can define your initial conditions:
Contact set: If you have an existing contact set, you can select the
Use contact set option and drop in the contact set from the
Petrel explorer. The option Target number of initial
conditions will control how many regions to make from a
contact set (for example, if a tilted surface is made in the
Reservoir Engineering

Functions 75

To keep the fluids


in a stair step condition, you
will need to define the model
as such (with an active
aquifer, capillary pressure,
etc). If you just put a tilted
surface for the contact, and
then run the simulator, the
fluid will gradually slump
down to a flat contact.

Make contacts process). This algorithm is iterative and


cannot guarantee to get exactly the number of targets
specified. For example, if you enter 10, but there are only two
distinct values in the surface, you will only get two regions.
Table: If you not using contact set, you can enter the details of
each initial condition in a table. The table consists of a column
for each initial condition region; columns can be added or
removed using the usual Petrel table manipulation buttons.
By default, the gas-oil contact is set as Datum. Also, the pressure at
Datum is defaulted using a pressure gradient of 0.0981 bar/m over the
depth given by (surface elevation - datum depth). To enter a specific
pressure or datum depth, select the check box.
Note that unless you plan to give a depth table for solution gas/oil ratio
and bubble point pressure, the pressure at the gas-oil contact must be
equal to the bubble point pressure input, specified on the General tab.

Make contacts
Make contacts is the process
where the contacts to be used in
the Volume calculation and
Simulation processes are made

76 Functions

Reservoir Engineering

To use contacts as input to the Make fluid model processes, you must
define them in a separate process in Petrel, called Make contacts.
The purpose of this is to be able to enter different types of contacts,
such as constant values, dipping contacts and surfaces, and you can
choose to use different contacts for each zone and each segment or the
same contacts for the entire 3D model.
Another purpose of contacts is to visualize them together with one of
the horizons. This will show the contact contour on the surface together
with colored intervals for each hydrocarbon interval. This is useful when
displaying the aerial extent of the hydrocarbon intervals.

Make contacts

Define fluid contacts

1. Append the number of contacts.

2. Define the contact type and name.


3. Define the contact level.

Can be a different value/surface for


each segment and zone.

Make contacts - Procedure


1. Open the Make contact process.
2. Choose to Create new contact set.
3. Enter the type of contacts to be created, and change the name
(if other than default).
4. Enter the contact level.

Reservoir Engineering

Functions 77

Contact level
Can be a constant value or a surface. To enter a constant
value, type the value directly into the cell. If it is a surface,
select the little check box and use the blue arrow to copy the
surface that represents the contact into the cell.
To use different contacts for each segment and zone, clear the
options Same for all zones and Same for all segments.

Fluid variations with depth


Vertical variations in PVT must be given in a
spreadsheet.
Right-click an Initial condition and select
Spreadsheet to enter a depth table.

Specify the bubble point or the Rs value at


each depth. If you specify one, then the
other is calculated using the correlations.

Composition of oil is frequently a function of depth


Solution gas/oil ratio (Rs) or Bubble point pressure (Pb
Vaporized oil/gas ratio (Rv) or dew point (Pd)
(No correlations available to create vaporized oil PVT input
manually or import)
To model the variation with depth, you have to fill in the Spreadsheet
located under the Initial condition sub-folder of the fluid model folder.
You can specify the bubble point or the Rs value at each depth. If you
specify Pb, then Rs will automatically be calculated and vice-versa,
using the correlations the fluid model is based on.
78 Functions

Reservoir Engineering

Entering a depth table is optional. If a table is not entered, the


dissolved gas concentration in under-saturated oil is set equal to the
saturated Rs value at the gas-oil contact everywhere. This is the Rs
value that you specified on the General tab when you made the fluid
model.
If the bubble point pressure (specified on the General tab of the Make
fluid model process) is not equal to the pressure at the gas-oil contact
(as specified on the Initial conditions tab), a depth table is required.
At any position in the reservoir, the Rs value derived from an Rs or Pb
versus depth table, is subject to an upper limit equal to the saturated
value at the local pressure, since the Rs value cannot exceed this.

Spreadsheets
You can view/edit a fluid model
in spreadsheet format.
You can copy and paste to/from
existing tables.

By right-clicking the oil or gas phase of the fluid model, you can access
the data in a spreadsheet format. Data can be copied/pasted from/to
those spreadsheets from Excel.

Reservoir Engineering

Functions 79

Plotting
Fluids data can be
plotted in a
function window.

Import
Black oil models exported
from PVTi can be imported.
The status of the import is
reported in the message log.

80 Functions

Reservoir Engineering

You can import fluid models generated in PVTi, or you can import Eclipse
keyword files.

Exercises Make fluid model


There are several ways to create a fluid model in Petrel. You can use
the Make fluid model process to generate a fluid model from
correlations, you can import data or you can define a fluid model by
using spreadsheets.
Exercise Workflow
Make a black oil fluid model
Reviewing fluid model settings
Import a keyword fluid model
Plot the fluid model
Exercise Data
In this exercise, we will continue to use the project from the previous
exercise.

Make a black oil model from correlations


In this exercise, we will create a black oil fluid model based on
correlations using the Make fluid model process in Petrel. The output
from the process is a fluid model that can be used by the simulator.
Exercise steps
1. From the Processes pane, open the Simulation folder and
open the Make fluid model process.
2. Select Create new fluid model.
3. Click on the Use presets button and select Light oil + gas
from the drop-down menu. Observe that the process window is
filled with default values.
4. On the General tab, change the Maximum pressure to 460
bar.

Reservoir Engineering

Functions 81

5. Inspect the Gas tab, accept the default settings.


6. Select the Oil tab. Change the Bubble point pressure to 200
bar.
7. Go to the Initial conditions tab. To specify the initial
reservoir conditions for the model, you can either drop in a
contact set or you can enter a table of contact depths and
pressures. In this exercise, we will use the table and enter a
value for the gas-oil contact to -1600m and the water contact
to -2600 m.
8. Enter a pressure at datum (the gas-oil contact) of 200 bar.

If the datum depth


lies above the gas-oil
contact, the pressure refers
to the gas phase.
If the datum depth lies below
the water-oil contact, the
pressure refers to the water
phase. Otherwise, the
pressure refers to the oil
phase.

9. Click OK in the Make fluid model process dialog.


82 Functions

Reservoir Engineering

Reviewing fluid model settings


In this exercise, we will inspect the settings for the fluid model we just
created to see how we can edit and change the model.
Exercise steps
1. In the Input pane you can now see that a Fluids folder has
been added. This is where the fluid models are stored.
2. Expand your fluid model inside the Fluids folder and then
right-click on Oil and select Spreadsheet from the context
menu. This opens a spreadsheet view of the oil properties that
vary with pressure.

Import a keyword fluid model


In this exercise, we will import a fluid model from a keyword file. This
file can be an included file to the simulation deck, or the main .DATA file
of the simulation deck.
Exercise steps
1. Right-click on the Fluids folder and select Import (on
selection). Navigate to the ImportData > Functions >
FLUID.INC file, and click Open to do the import.
2. On import, you may get a message that some keywords were
not imported. You can find those keywords in the Message
log. These keywords do not contain PVT data.
3. After importing, a new fluid model is added to the Fluids
folder in the Input pane. Check the imported data by using the
Settings panel and the spreadsheets.
4. The fluid you imported does not have an initial condition,
hence, an initial condition must be added before the fluid can
be used in a simulation model.

Plotting the fluid model


In this exercise, we will plot the fluid model in a function window.
Exercise steps
1. Insert a New function window from the Window menu,
and select the check box next to Oil formation volume
factor in the Oil folder of the imported Black oil model 1.
2. Use the Select/pick mode tool
Reservoir Engineering

and click anywhere on


Functions 83

any of the curves. The property name and value appear in the
status bar. If you cannot see the status bar, enable it with the
View > Status bar command.
3. Deselect to view the Oil formation volume factor and select
the check box next to Oil viscosity instead.
4. Any changes made in any of the settings panels and
spreadsheets will be reflected in what you see in the function
window.

84 Functions

Reservoir Engineering

Create multiple viewports Optional


In this exercise, we will set up a new plot window with four function
viewports so we can make a report of the fluid model and inspect more
data in one view.
Exercise steps
1. Insert a New plot window from the Window menu.
2. There are two ways to create multiple viewports in the plot
window:
a. Go to the Windows pane and find the inserted plot
window. Open the settings for Plot window 1 [Any] and
go to the Setup multiple viewports tab.
Or,
b. From the toolbar, click on the New object in window
button on the toolbar and select Create/align multiple
viewports.

Reservoir Engineering

Functions 85

3. In the settings for Plot window 1 [Any] dialog, select


Function viewport(s) from the New viewport type dropdown menu. Define Number of rows: 2 and Number of
columns: 2. Then click the Setup viewports button
and close the settings window by
clicking OK.
4. You should now have four function viewports ready to use for
plotting the line data. The active viewport is shown with a red
border. Click inside a function viewport to make it active.
5. As an example, select the following data to plot from the Light
oil + gas fluid model:
a. Top left viewport: Oil formation volume factor.
b. Top right viewport: Oil viscosity.
c. Bottom left viewport: Pressure and the fluid contacts from
Initial condition 1.
d. Bottom right viewport: Gas formation volume factor.
6. You should have a plot window similar to the one shown
below:
86 Functions

Reservoir Engineering

Reservoir Engineering

Functions 87