Вы находитесь на странице: 1из 103

BY CHRISTOPHER F.

SIKORA

Copyright 2015 Christopher Sikora

This manual is for educational purposes only. It may be printed, but not resold for profit for its content.
Inventor is a registered trademark of Autodesk Corporation.
Inventor 2016 is a product name of Autodesk Corporation.
ACIS is a registered trademark of Spatial Technology Inc.
IGES Access Library is a trademark of IGES Data Analysis, Inc.

Other brand or product names are trademarks or registered trademarks of their respective holders.

The information discussed in this document is subject to change without notice and should not be considered commitments by
Christopher F. Sikora.
The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms
of the manufactures license.

Introduction to Inventor - IMT 110


Course Description:
Intro to CIM
3 credit hours
Exploration of the theory and application of Computer Integrated Manufacturing,
beginning with CAD - solid modeling techniques for product design, CNC, and Computer
Aided Manufacturing. Prerequisite: Intro to Engineering Drawings 101 or consent of
instructor.
(1 lecture hours, 2 lab hours)
Course Objectives:
Provide the student with the knowledge and practical experience in the areas of 3D CAD
modeling of parts, assemblies, and the creation of mechanical drawings from the
models.
Textbook & Software
Inventor Basics (pdf. provided)
Instructional videos of lectures are available on YouTube channel:
YouTube Link: Vertanux1
Web Page Link: www.vertanux1.com
Software Page Link: Inventor Professional 2016 Software
NOTE: When setting up an account to download software you must use your student .edu email address.

Evaluation Scale:
A

90% to 100%

80% to 89%

70% to 79%

60% to 69%

Below 60%

Points:
Labs

300 pts

Mid Term

300 pts

Final

300 pts

Participation/Attendance

100 pts

Total

1000 pts

General Course Outline


Date

Week Topic

8/20

1.

E1 - Introduction to CIM and Inventor CAD Interface Lecture


CAD/CAE/CAM Theory

2.

E2 - Revolved Features and Mirroring

3.

E3 - Part Modeling
Secondary Features. Fillets, Chamfers, Draft, Patterns, Mirroring.

4.

E4 - Sweeps, and Circular Patterns (Review for Quiz 1)

5.

Q1 - Modeling Quiz and CIM Administration

6.

E5 - Building Assemblies (Bottom-Up method BU)

7.

E6 - Creating Drawings. Review for Mid Term

8.

Mid Term Exam

9.

E7 - Computer Aided Engineering (CAE)

10.

E8 Lofts (Boat)

11.

E9 - Computer Aided Manufacturing (CAM)

12.

E10 - Advanced Freeform (G2) bottle

13.

Design Project, Sketching, Modeling, & Rapid Prototyping

14.

Design Project, Intro to PowerPoint

15.

Lab time to complete Design project, Presentations

16.

Presentations/Design projects and Exercises 1 thru 10 due

10/8

12/10

Chapters
1.

Introduction to the Interface


Modeling Theory - Sketching and Base Feature Geometry Creation.

2.

Part Modeling
Revolved Method

3.

Secondary Feature Modeling (Draft, Offsetting Entities, Filleting)

4.

Advanced part Modeling (Sweeps, and Circular Patterns)

5.

Bottom-Up Assembly Modeling

6.

Creating Drawings

7.

CAE (Computer Aided Engineering)

8.

Lofting

9.

Inventor to Mastercam

10. Advanced Freeform Modeling

Introduction to Inventor Professional

2016 Interface

Icons
Quick Launch
Options

Browser/Feature
Manager

View port

Mouse Buttons
Left Button - Most commonly used for selecting objects on the screen or sketching.
Right Button Used for activating pop-up menu items, typically used when editing.
Center Button (option) Used for model Pan, Rotate when holding Shift key.
Center Scroll Wheel (option) same as Center Button when depressed, only it activates
Zoom feature when scrolling wheel.

Options menu The hearts of Inventor


Selecting the Grid Icon opens the Options Menu or the Tools/Options pull down can
be used.

Application Options (Global Settings) are setting that affect all documents.
Location: Upper Left corner icon with the big yellow I, then find Options at the
bottom center of the list or Tools>Application Options.
Screen Background Color
Performance Settings
Interface Preferences

Document Settings (Individual Document Settings) are setting that adjust only
the currently active document.
Location: While in a part (.ipt) or an assembly (.iam) document got to Tools>Document
Settings.
Part Color
Units
Standards

Sketching (2D tools)

Where do you start a sketch?


Sketches can be created on any Plane or Planar Face or Surface. Inventor provides you
with three planes centralized at the Origin (your zero marker in space)
NOTE: Planes can also be created and will be discussed in more detail in the future.

To start a sketch Pre-select the plane or face you desire to sketch on and then select the quick
launch Sketch Icon that appears automatically. NOTE: You can select the planes from the
Browser - Feature Manager.

Controlling your geometry

Inventor uses two methods for constraining geometric entities.


Relations and Dimensions
Relations can be referred to as common elements of geometry such as Tangency,
Parallelism, and Concentricity. These elements can be added to geometric entities
automatically or manually during the design process.

Here is an example of
adding a relationship
between two geometric
entities.

By selecting both entities


Inventor will automatically
activate the properties
menu on the right side of
the screen enabling the
user to input the desired
relation.

10

Cautious sketching can save time.


Here are some tips to avoid modeling errors.

This is acceptable because it is a closed contour.


Use the Trim tool to cut and extend.

This is unacceptable because it has untrimmed geometry.

This is unacceptable because it has multiple contours share a common entity.

There are 3 primary file types in Inventor, which include


1. Part (.ipt)
Single part or volume.
2. Assembly (.iam)
Multiple parts in one file assembled.
3. Drawing (.idw)
The 2D layout containing views, dimensions, and annotations.

11

Controlling your geometry with dimensions

Dimensioning this way will


enable the length of the
bracket to change but the
holes will always remain
positioned to 1.5 off each
side.

Dimensioning this way will


enable the length of the
bracket to change but the
holes will always remain
positioned to the left side.

Features (3D tools)

12

Solid Modeling Basics


Layer Cake method
Extruded Boss/Base (Creates/Adds material)
Extruded Cut (Removes material)
Ingredients:
Profile

Revolve method
Revolve Boss/Base (Creates/Adds material)
Revolve Cut (Removes material)
Ingredients:
Profile
Center Line (Note: The profile cannot cross over the center line!)

13

EXERCISE 1
Introduction to basic part modeling
Base Extrude Features create a 3D solid representation by extruding a 2 dimensional
profile of the entity.
Objective:
Create a
solid
model.

This will create a hole.

This will fail to extrude.

1. Start a new part


file.

5. Select to add
the dimensions.

3. Select the
Rectangle tool.
2. Select the
Sketch icon.

5. Select Finish
Sketch.

4. Click and drag


across.

14

7. Select Extrude

9. Hit OK to
apply.

8. Set to Blind
@ .5.

10. To sketch the next feature


select the front face of the model
and then select the Create
Sketch quick launch icon.

15

11. Use the rectangle tool to


sketch from the lower left corner,
approximately 1.5 inches to the
right edge, when you see the
little constraint symbol appear hit
tab to edit the vertical
dimension and insert 1.5. Hit
Finish Sketch.

12. Go to the
Model tab, and
then select
Extrude.
13. Insert .5
depth.
Hit the green
check mark to
apply.

16

Adding the hole

1. Select this face


and start a sketch.

2. Select the circle


icon, and begin by
locating the center
of the circle, LMB
(left mouse
button) click, and
drag out the circle
by LMB clicking
again.

17

3. Using
Dimension
add the shown
dimensions.

4. Select the
Extrude icon.

5. Select the
Cut option.

5. Select the
All option.

18

Go to the

icon and save-as E1

FINISHED
Now try LAB1
NOTE: Patterns/Arrays and Mirroring will be covered in the next three chapters. Please
try to model LAB 1 without using them. Its good practice to just dimension and sketch all
geometry when first starting out learning this software.

Please understand that I dont want to overwhelm you with too much information the
first day. It is my goal to help you succeed, not to fail.

19

20

21

EXERCISE 2
Revolved Features
Revolved Feature - creates features that add or remove material by revolving
one or more profiles around a centerline. The feature can be a solid, a thin
feature, or a surface.
Tips
Profile
Centerline, Edge, or
Axis of Revolution

The profile should never cross over the centerline, nor should there be profiles on
both sides of the centerline.

22

1. Create a new part file (E2) and then start to sketch horizontal and vertical
centerlines.

2. Sketch the following. Ctrl select the profile and the horizontal centerline,
then using the Mirror tool to create a of the geometry and then mirror it
to the other side. Make sure you finish adding the dimensions.

23

3. Select the Revolve feature icon.

Then select the axis/centerline.

4. Select the top and bottom edges and add a .100 fillets.

24

25

26

27

EXERCISE 3
Secondary Feature Modeling
1.

Start a new part file and sketch the geometry as show below.

2.

Extrude. Select Mid-Plane, 1 and add 7 of draft located in the More tab.

7 degrees

Mid-Plane

28

3.

Select the front face of the model and start a sketch on it.

4.

Use the Offset icon to offset sketch geometry .125 from the outside
edges..

5.

Cut Extrude at .125 deep.

29

6.

Select the base of the pocket and start a sketch on it.

7. Go normal to and sketch the following. Draw two circles on the center points
of the outside arcs. Use the trim tool to remove intersections.

9. Extrude cut .75 deep.

30

1. Select the base of the new pocket and start a sketch on it.

11.

Sketch the following, and extrude cut Through-all.

12.

Go to the Plane icon and select Offset from XZ plane in the feature tree,
then click on the dimension to change it to -4.00.

31

13.

Start a sketch on Work Plane 1 and draw a .5 dia. circle centered on


the origin.

14.

Extrude and use the To next option.

32

15.

16.

Start a sketch on the Front plane and sketch the following rectangle.
Use a centerline with a midpoint relationship to center the rectangle to
the origin.

Extrude boss using the mid-plane option and .750 thick with 7 draft.

33

17. Using the fillet tool select the following edges and put a .125 radius on them.

18. Add additional fillets of .06 on the following edges.

34

35

36

EXERCISE 4
Sweeps, Circular Arrays and Secondary Feature Modeling
1.

Sketch the geometry as show below on the Front plane.

2. Select Revolve.

37

3. Select the XY aka: Front plane and start a sketch on it. Rebuild after completion.

4. Create a plane using the Plane tool located under Parallel to Plane through Point
Select Finish Sketch. Note: The 2 ingredients for creating a Parallel plane to a curve are the
YZ plane and the end Point of the curve you just completed in the last section.

38

5. In the Left view orientation select the new plane and RMB click on the end of
the curve, select Project Geometry.

6. Sketch the following using center point arc and lines, and insert relations and
dimensions as shown.

39

7. Creating a Sweep: Select the Sweep Icon. Then select the Path and Profile.

8. Add .188 Fillets on the bottom edges of the spoke.

40

9. Add .25 fillets to the intersection of the Spoke and Center.

Creating the Circular Pattern/Array

10. Select the spoke feature then select the Circular Pattern Icon. Then select the
Rotation Axis icon and the actual cylinder face located at the center and the
Spoke. Enter 3 for the number of spokes. Note: be sure to select the fillets as well, or they
will not show up on the instances.

41

2. Select the XY plane and start a sketch on it. Draw the following and dont
forget the Centerline.

3. Select the Boss-Revolve Icon, and revolve 360 One-Direction.

42

4. Add .25 fillets around the intersections of the handle and spokes.

5. You are finished.

43

Using the Hole Wizard

1.
2.
3.
4.

Select the Hole icon


Select the Concentric option if on a circular face.
Select the face where the hole is to be placed
Specify the size and type

44

45

46

EXERCISE 5
Bottom-Up Assembly Creation
1.

2.

Go to File/New and select the Standard.iam (Assembly) template.

Assemblies Toolbar.

47

3.

To insert a part into the assembly go to Place.

4.

Search for the Sheet Metal Bracket in the Exercise 5 folder provided. Then
move the pointer to the viewport and click the LMB to insert. Parts available
on www.vertanux1.com

48

5.

Go thru the insert steps again to bring in the Yoke Male, drop it to the left of
the Sheet Metal Bracket.

6.

Select the Constraint icon and then select Insert option. Next, select the
side face of the boss sticking out at the top of the Yoke. Then select the inside
face of the hole on the bracket. Select Apply.

49

7.

8.

Select the concentric option and apply. The part should now move into place.

Insert the Spider part next and mate it between the legs on the yoke, you may
need to select mate alignment or Flush in order to rotate the part 180 degrees.

50

9.

Use a concentric mate to align the center hole with the holes on the yoke.

51

10.

Attach the remainder of the components.

11.

After completion you should be able to LMB click on the handle to


dynamically rotate the assembly.

52

53

54

EXERCISE 6
Fundamental 2D Drawing Creation
1.

Open the E6 part file.

2.

IPro/New/Drawing

55

3.

One method of inserting a part (E6) into a drawing is to first open the desired
part file.

4.

Selecting a different Template: Notice the options for Sheet Format/Size will
pop up. Select A- Landscape and hit New Sheet.

56

5.

6.

Inserting a View: You should now see the paper border and the front view
image. Double click on the image to access the Drawing View options.
Change Scale to 1:2.

Select Projection, then select the Front view, move your pointer up and click to
drop a top view, then right and click, and corner right and click. Right Mouse Button
click to create.

57

7.

Section Views: Select the Section View icon and then locate the left side
quadrant edge of the top view and click on the edge. While a short distance
away from contacting the edge LMB click and drag a line horizontally
through the entire view. (Dont stop in the middle).

8.

Once through release the LMB and you should be able to now drag off a
section view and drop it just above the Top view by LMB clicking again.

58

9.

Detail Views: Select the Detail View icon. The circle tool is automatically
activated so then you can draw a circle surrounding the region you wish to
create a detail view from.

10.

Move the view to the desired location and LMB click to release/drop it.

Note: the view scale can be changed by simply double clicking on the scale text and typing in a new
value, and the position and diameter of the circle can be changed dynamically by LMB clicking and
dragging its center or diameter.

59

Auxiliary Views: Can be created by selecting an edge of the part and then select the
Auxiliary view icon.

11.

Then drag out the view and LMB click to drop it into position.

60

12.

Editing the Sheet and Sheet Format: The Sheet is the transparent top
level containing the model views, dimension and notes. The Sheet Format
is the lower level that contains the border, title block, and notes.

13.

RMB click on the SHEET1 tab located at the bottom left corner of the
screen, and select edit sheet format.

61

14.

Dimensions and Annotations: To add independent and non-parametric


dimensions you can select the Dimension icon. Then just add dimensions
the way you would in the sketcher. Otherwise you can use the Retrieve
option in the Annotate tab.

15.

The Retrieve tool gives you access to dimensions and annotations added to
the model during its construction by the designer. These annotations can be
inserted automatically into the drawing. These are true, editable, parametric
dimensions.
Try using some of the other annotations like Note, Surface Finish, Welds, and
GD&T.

16.

62

63

IMT 110 Mid-Term Exam


1. Model the BOTTLE drawing A. (50 Points)

2. Model the CAP drawing B. (50 Points)

3. Create the BOTTLE assembly and attach the cap to the


bottle. (100 Points)

4. Recreate the MEDICINE BOTTLE assembly drawing C. (100


Points)
Note: Do not forget to insert your name on the drawing.
Print out the drawing and turn in.

64

65

66

67

EXERCISE 7
Introduction to Computer Aided Engineering (CAE)
Stess Analysis FEA can be very useful for testing failure of a part.
1.

Go to file new and select part from the options.

1000
psi

2.

Objective:
Create bottle
opener.
Perform FEA
analysis to test
for failure.

FIXED
FACE

Select the Material option on the top options bar next to the beach
ball icon, Locate and select ABS Plastic from the list.

68

3.

Select the front plane and use the line tool to sketch the geometry
called out on the attached drawings.

4. Extrude .400 depth. Add .3 and .1 fillets. Select ABS Plastic (top options bar)

69

5. Go to Environments/Stress Analysis, Create Simulation.

6. Select OK.

70

5. Select Fixed.

6. Select the underside face of the bottle opener, where the bottle cap would
contact the opener. This is considered the fixed face because it rests on
the cap. Select OK.

71

7. Select Force, elect the underside face of the model. Enter 40 lbs.

8. Select Simulate, and select Run.

72

9. At the next screen hit Next and Run to begin the simulation.

10. Select Animate Hit the play icon.

73

EXERCISE 7b
Computer Aided Engineering Case Study
PROJECT: Monitor Wall Mounting Bracket

InLite, a major manufacturer of Video and Television mounting components has


commissioned the analysis of their latest polymer (Plastic) based LED Television
mounting bracket. Because LED (Light Emitting Diode) technology enables televisions
and monitors to be nearly half the weight of traditional LCD (liquid crystal) or Plasma
displays.

Your task is to analyze the design to accommodate the weight of a typical 37 LED
display. Write a minimum two page report on your findings with visuals (FOS2 & Stress
plot).

70lbs
PSI

FIXED
SURFACE
PSI

74

Creating an Analysis Report

Its important to include relevant data extracted from the analysis. And also be able to
explain the purpose and noted critical regions with logic behind their selection.
Here is a partial sample of a report.

Items to include in a report:

Cover page

Name

Project name

Date

Purpose Page

Define the purpose

Images with highlighted regions analyzed Explain you decisioning.

Material

Each analyis should have its own page or pages with images and coplete descriptions of
the results.

Bad reports typically lack explainations, and have little content.


Good report is to the point with clearly labeled explainations.
Images play a large role in analyis thus you should try and include all relavent and
descriptive image results.

Liability
When writing a report be careful to avoid putting yourself in a difficult situation. FEA
analysis is not an insurance policy and its results can be flawed.

75

PHONE BEZEL STUDY


March 8, 2010
HEALY CORPORATION
BY: CHRISTPHER F. SIKORA

76

Purpose
The purpose of this study was to evaluate the structural integrity of the engineered
design, as well as to determine the elements of a controlled failure.
Preliminary studies indicated there are two assemblies (Handset and Phone Bezel) with
a total of 3 regions, which required advanced analysis. FEA-Finite Element Analysis
software was used to identify undesirable feature characteristics through computer
simulation. This document presents chronologically the process of identification,
correction and optimization of engineered features.
Material: Nylon 101 (MPa Threshold 45 < or =)
ANALYIS B
TOP BEZEL
CORNER
RISK OF
FAILURE

ANALYSIS A
BEZEL CORNER
RISK OF
FAILURE

ANALYIS C
HANDSET CORNER

77

ANALYSIS A
BEZEL 5ft. Drop Test
March 10, 2010
Purpose: The Phone Bezel lower left corner may require additional reinforcement to
prevent failure or cracking.
During analysis we discovered the corner endures an MPa of 46.8 which exceeds the
given threshold just slightly. We suggest that reinforcement of the interior corner ribs
be adjusted and thickened from .06 to .100. (see Fig.1)

FLOOR

ANALYIS A

IMPACT

78

Reinforcement Region 1
By increasing the rib thickness to .100 the phone should be able to endure the projected
forces.

Figure 1: Questionable region

79

EXERCISE 8
Lofting
Lofting creates a feature by making transitions between profiles. A loft can be a base,
boss, cut, or surface.
Objective: Create
a boat hull by
lofting multiple
section profiles.

1.

Create four (4) planes beginning from the XY Front plane and offset from
each other as shown.
Plane 1 6.00
Plane 2 8.00
Plane 3 1.00

2.

Sketch 1 on the XY Front plane should look like this use the Spline tool.

80

3.

Sketch 2 on Plane 1 should look like this

4.

Sketch 3 on Plane 2 should look like this

5.

Sketch 4 on Plane 3 should point at the origin.

81

7.

Loft: Exit any sketches and select Loft.

8.

Profiles: Select the four profiles in order from back to front of boat.

82

9.

Use the Mirror feature and select the flat side face as the plane to mirror from.

10.

Select the hull as the feature and hit OK to apply.

83

11.

You are finished with the boat Hull.

12.

(Optional) Now dress it up for the contest

84

EXERCISE 9
Basic Machined part modeling for Mastercam

85

1. Draw on the XY plane and extrude the following 1 thick.

2. Sketch the circles and extrude them.

86

3. Sketch the following and extrude cut it.

4. Extrue cut .5 deep.

87

5. Add .25 fillets in the corners of the square cutout.

6. Save the part as E9.


7. Start Matercam and import the Autodesk Inventor E9.ipt. be sure to set your Files of
type filter to Autodesk Inventor files.

88

8. Once the file is impoted turn on shaded mode.

9. Select stock setup from the feature tree.

89

10. Select all solids.

11. Selecting Material: Go to the Tool Settings tab and select Mill Library at the bottom and
find Aluminum 6061.

90

12. Select Properties and Mill Default in the Feature tree, and select Drill. Note: you can
select under Machine Type your specific Postprocessor for the CNC you currently are
using.

13. Select the bottom floor surfaces for the drill. Select the green checkbox.

91

14. Select the Tool option, and then select the Library Tool

15. Select a 1/2 (#6) DIA. Drill. Hit the two green check boxes.

92

16. Repeat the same steps to add a DIA (#5) drill for the second hole. Hit the two green
check boxes.

17. Pockets: Select the Pocket tool

93

18. Select solids, and then select the floor of each pocket. Select the green check box.

19. Select Tool, Select Tool. Select the FLA (FLAT) (#239). Select the green check box.

94

20. Select Roughing, and Constant overlap Spiral. Hit the green check box.

21. Select Machine Group 1 from the top of the feature tree, then select the Backplot
icon.

95

22. Adjust the setting as seen below and select the Machine icon to begin the toolpath
simulation.

23. Watch the simulation.

96

24. G-Code Program Output Select Post to have Mastercam generate the program.

Finished

97

EXERCISE 10
Lofting with Guide Curves
1.
Sketch the geometry as show below on the XY-front plane. Rebuild. (5 spline
points) Use ordinate dimensions for simplicity.

2.

Select Offset plane and offset a datum plane 8 from the XY-front plane.

98

3.

Sketch the following on Plane 1. (5 spline points)

4.

Start a sketch on the top plane, and draw the following. (3 spline points)

99

5.

Start a new sketch on the top plane and draw the following. (5 spline points)

6.

Loft

100

7.

Loft completed.

8.

Creating G2 Curvature Continuous Fillets. Select the bottom edge of


the bottle. Select the fillets icon. Input .250 radius and check Smooth G2.

101

What are G2 Curvature Continuous fillets?


Use Smooth G2 fillets to resolve discontinuity
problems and create a smoother curvature
between adjacent surfaces. To verify the effect of
the curvature continuity, you can display Zebra
Stripes. You can also analyze the curvature using
the curvature tool.
Curvature continuous fillets differ from standard
fillets in the following ways. They have a spline
cross-section as opposed to a circular crosssection. Curvature continuous fillets are smoother
than standard fillets because there is no jump in
curvature at the boundary. Standard fillets include
a jump at the boundary because they are tangent
continuous at the boundary. (Source: SolidWorks
help)

9.

Select the back flat face and go to Insert/Mirror all.

102

10.

Insert the neck of the bottle as shown below.

11.

Creating a Thread - Select the side face of the neck and go to the thread
tool to add a cosmetic thread to the neck.

12.

Complete the other side the same way. Add additional features to finish
bottle. Shell at .050.

103

Оценить