Вы находитесь на странице: 1из 7

Router on a Stick

S1#show run
!
hostname S1
!
!
enable secret 5 $1$WFwJ$AFYWzdaVlJztdeClb3r61/
!
username user privilege 15 secret 5 $1$LAcK$q5OgPkrWWBj9.Wv51KAl00
!
no ip domain-lookup
ip domain-name ccna.com
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1,10,20 priority 24576
!
vlan internal allocation policy ascending
!
ip ssh time-out 5
!
!
interface Port-channel1
switchport trunk native vlan 10
switchport mode trunk
!
interface FastEthernet0/1

switchport trunk native vlan 10


switchport mode trunk
channel-group 1 mode active
!
interface FastEthernet0/2
switchport trunk native vlan 10
switchport mode trunk
channel-group 1 mode active
!
!
interface FastEthernet0/5
switchport trunk native vlan 10
switchport mode trunk
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
switchport port-security maximum 2
spanning-tree portfast
spanning-tree bpduguard enable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.10.10 255.255.255.0
!

ip default-gateway 192.168.10.1
banner motd ^C Authorized Access Only ^C
!
line con 0
password ccna
login
line vty 0 4
password ccna
login local
transport input ssh
line vty 5 15
password ccna
login local
transport input ssh
!
end

S1#

S2#show run
!
hostname S2
!
username user privilege 15 secret 5 $1$WYBZ$zp.8k84gMe5UrAew3mura/
!
!
ip domain-name ccna.com
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh time-out 30
!
interface Port-channel1
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport mode trunk
channel-group 1 mode passive
!
interface FastEthernet0/2

switchport trunk native vlan 10


switchport trunk allowed vlan 10,20
switchport mode trunk
channel-group 1 mode passive
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
switchport port-security maximum 2
spanning-tree portfast
spanning-tree bpduguard enable
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.12 255.255.255.0
!
ip default-gateway 192.168.10.1
!
banner motd ^C Authorized Access Only ^C
!
line con 0
line vty 0 4
login local
transport input ssh
line vty 5 15
login local

transport input ssh


!
end

S2#

R1#show run
!
hostname R1
!
!
logging message-counter syslog
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.10
encapsulation dot1Q 10 native
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/1.20

encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
banner motd ^C Authorized Access Only ^C
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

R1#