You are on page 1of 12

Algoritmo VigasTyL

Escribir Anlisis
Escribir Diseo
Escribir Elija una opcion
Leer opcion

Si opcion=analisis Entonces
Escribir Ingrese b
Leer b

Escribir Ingrese bw
Leer bw

Escribir Ingrese h
Leer h

Escribir Ingrese hf
Leer hf

Escribir Ingrese fc
Leer fc

Escribir Ingrese fy
Leer fy

Escribir Ingrese viga


Leer viga

Escribir Ingrese recub


Leer recub

Repetir
Escribir Ingrese el tipo de barra
Leer tp

Si tp=3/8 Entonces
a1=0.71
d1=0.95
Sino
Si tp=1/2 Entonces
a1=1.27
d1=1.27
Sino
Si tp=5/8 Entonces
a1=1.98
d1=1.59
Sino
Si tp=3/4 Entonces
a1=2.85
d1=1.91
Sino
Si tp=7/8 Entonces
a1=3.88
d1=2.2
Sino
Si tp=1 Entonces
a1=5.07
d1=2.54
Sino
Si tp=11/8 Entonces
a1=6.41
d1=2.86

Sino
Si tb=11/4 Entonces
a1=7.92
d1=3.18
Sino
a1=11.4
d1=3.81
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si

Escribir Ingrese el nivel de capa


Leer nc

Si nc=1 Entonces
momen=momen+nb*a1*(h-recub-dimest-(d1)/2)
area=area+nb*a1
Sino
barra inferior

Escribir Ingresar Separacion de Capas y Diametro de


Leer sc
Leer dbi

momen=momen+nb*a1*(h-recub-dimest-(d1)/2-dbi-sc)
area=area+nb*a1

Fin Si

Escribir Preguntar Desea Continuar


Leer respuesta
Hasta Que respuesta=0
Peralef=momen/area

Si fc>280 Entonces
b1=0.85-0.05*(fc-280)/70
Si b1<=0.65 Entonces
b1=0.65
Sino
Fin Si

Sino

b1=0.85
Fin Si
cb1=0.85*(fc/fy)*b1*(6000/(6000+fy))
as2=0.85*fc*(b-bw)*hf/fy
cb2=as2/(bw*peralef)
cmin1=0.8*fc^0.5/fy
cmin2=14/fy

Escribir Elija una opcion


Escribir 1 p=As/b*d
Escribir 2 p=As/bw*d
Leer respuesta

Si respuesta=1 Entonces
cb=(cb1+cb2)*(bw/b);
cs=area/(b*peralef);
Sino

cb=(cb1+cb2);
cs=area/(bw*peralef);

Fin Si
Escribir Elija una opcion
Escribir 1 Moderado Riesgo Sismico
Escribir 2 Alto Riesgo Sismico
Leer respuesta

Si respuesta=1 Entonces
Cmax=0.75*cb

Sino

Cmax=0.50*cb
Fin Si
Si cmin1<cmin2 Entonces
cmi=cmin2
Sino
cmi=cmin1
Fin Si

Si cmi<cs & cs<cmax Entonces


a=area*fy/(0.85*fc*b)

Si a<hf Entonces
Mn=area*(fy/1000)*(peralef-a/2)/100
Mu=0.9*Mn
Sino

a=(area-as2)*fy/(0.85*fc*bw)

Mn=(area-as2)*(fy/1000)*((peralefa/2)/100)+as2*(fy/1000)*(peralef-hf/2)/100
Mu=0.9*Mn

Escribir RESULTADOS
Fin Si

Sino

Escribir No se cumple requisitos de cuantia


Fin Si
Sino

Escribir Ingrese bw
Leer bw

Escribir Ingrese h
Leer h

Escribir Ingrese hf
Leer hf

Escribir Ingrese fc
Leer fc

Escribir Ingrese fy
Leer fy

Escribir Ingrese luz libre


Leer lnn

Escribir Ingrese separacion entre vigas


Leer sn

Escribir Ingrese recub


Leer recub

Escribir Ingrese Mu
Leer Mu

Escribir Elija una opcion


Escribir 1 Vigas T
Escribir 2 Vigas L
Leer respuesta

Si respuesta=1 Entonces
b1=(lnn/4);
b2=((bw/100)+Sn);
b3=(16*(hf/100)+(bw/100));

Sino

b1=(Lnn/12);
b2=((bw/100)+Sn/2);
b3=(6*(hf/100)+(bw/100))
Fin Si
Si b1<b2 Entonces
b=b1
Si b1<b3 Entonces
b=b1
Sino
b=b3
Fin Si

Sino

b=b2
Si b2<b3 Entonces
b=b2
Sino
b=b3
Fin Si
Fin Si

Escribir Ingrese el tipo de barra


Leer tp

Si tp=3/8 Entonces
a1=0.71
d1=0.95
Sino
Si tp=1/2 Entonces
a1=1.27
d1=1.27
Sino
Si tp=5/8 Entonces

a1=1.98
d1=1.59
Sino
Si tp=3/4 Entonces
a1=2.85
d1=1.91
Sino
Si tp=7/8 Entonces
a1=3.88
d1=2.2
Sino
Si tp=1 Entonces
a1=5.07
d1=2.54
Sino
Si tp=11/8 Entonces
a1=6.41
d1=2.86
Sino
Si tb=11/4 Entonces
a1=7.92
d1=3.18
Sino
a1=11.4
d1=3.81
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si

Fin Si
Fin Si

Escribir Elija consideraciones


Escribir 1 Una Capa
Escribir 2 Dos Capas
Leer respuesta

Si respuesta=1 Entonces
d=h-(recub+dimest+(d1)/2)

Sino

Escribir Ingrese Separacion de Capas


Leer sc
d=h-(recub+dimest+(d1)+sc/2);
Fin Si
a=d/5

Mientras i<5 Hacer


area=(Mu*10^5)/(0.9*fy*(d-a/2));
a=area*fy/(0.85*fc*b*100);
i=i+1;
Fin Mientras
Si a>hf Entonces
as2=0.85*(fc/1000)*(b*100-bw)*hf/(fy/1000)
Mu2=0.9*as2*(fy/1000)*(d-hf/2)/100;
Mu1=Mu-Mu2;
a=d/5

Mientras i<5 Hacer


as1=(Mu1*10^5)/(0.9*fy*(d-a/2));
a=as1*fy/(0.85*fc*bw);

i=i+1;;
Fin Mientras

area=as1+as2

Si fc>280 Entonces
b1=0.85-0.05*(fc-280)/70
Si b1<=0.65 Entonces
b1=0.65
Sino

Fin Si
Sino
b1=0.85
Fin Si

cb1=0.85*(fc/fy)*b1*(6000/(6000+fy))
as2=0.85*fc*(b-bw)*hf/fy
cb2=as2/(bw*peralef)
cmin1=0.8*fc^0.5/fy
cmin2=14/fy
cb=(cb1+cb2)*(bw/b);
cs=area/(b*peralef)

Escribir Elija una opcion


Escribir 1 Moderado Riesgo Sismico
Escribir 2 Alto Riesgo Sismico
Leer respuesta

Si respuesta=1 Entonces

Cmax=0.75*cb
Sino
Cmax=0.50*cb
Fin Si

Si cmin1<cmin2 Entonces
cmi=cmin2
Sino
cmi=cmin1
Fin Si

Escribir RESULTADOS
Sino

Si fc>280 Entonces
b1=0.85-0.05*(fc-280)/70
Si b1<=0.65 Entonces
b1=0.65
Sino

Fin Si
Sino
b1=0.85
Fin Si

cb1=0.85*(fc/fy)*b1*(6000/(6000+fy))
as2=0.85*fc*(b-bw)*hf/fy
cb2=as2/(bw*peralef)
cmin1=0.8*fc^0.5/fy
cmin2=14/fy
cb=(cb1+cb2)*(bw/b);
cs=area/(b*peralef)

Escribir Elija una opcion


Escribir 1 Moderado Riesgo Sismico
Escribir 2 Alto Riesgo Sismico
Leer respuesta

Si respuesta=1 Entonces
Cmax=0.75*cb
Sino
Cmax=0.50*cb
Fin Si

Si cmin1<cmin2 Entonces
cmi=cmin2
Sino
cmi=cmin1
Fin Si

Escribir RESULTADOS
Fin Si
Fin Si
FinAlgoritmo