Вы находитесь на странице: 1из 11

Интегрированная среда Турбо Паскаля 1

Интегрированная среда Турбо Паскаля


Содержание раздела
ИНТЕГРИРОВАННАЯ СРЕДА ТУРБО ПАСКАЛЯ................................................................................................1
К содержаниюзадачника
ИНТЕГРИРОВАННАЯ СРЕДА ТУРБО ПАСКАЛЯ 10...........................................................................................1
Упражнения...............................................................................................................................................................2
Справочные материалы............................................................................................................................................3
Историческая справка. .........................................................................................................................................................3
Запуск интегрированной среды.............................................................................................................................................3
Окно редактора.......................................................................................................................................................................3
Новая программа....................................................................................................................................................................4
Работа с меню.........................................................................................................................................................................5
Сохранение программы на диске..........................................................................................................................................5
Запуск программы на исполнение.........................................................................................................................................5
Чтение файла с диска.............................................................................................................................................................6
Редактирование и отладка программы..................................................................................................................................6
Выход из интегрированной среды........................................................................................................................................6
Система окон среды. .............................................................................................................................................................6
Справочная служба Турбо Паскаля......................................................................................................................................7
Команды меню File................................................................................................................................................................7
Команды меню Help:..............................................................................................................................................................8
Команды меню Window.........................................................................................................................................................8
Функциональные клавиши....................................................................................................................................................9
Комбинации клавиш для работы со встроенной справочной службой............................................................................10
Быстрое передвижение по тексту .......................................................................................................................................10
Вставка и удаление в режиме редактирования...................................................................................................................10
Комбинации клавиш для работы с окнами.........................................................................................................................11
Запуск программы на выполнение — Ctrl+F9....................................................................................................................11

Цель занятия.
Получить опыт работы в интегрированной среде Turbo Pascal. Уметь выполнять следующие
действия:
1. Запускать интегрированную среду Turbo Pascal в оконном режиме.
2. Набирать текст программы с клавиатуры
3. Сохранять программу (исходный текст на Паскале) на диске.
4. Запускать программу на выполнение.
5. Просматривать результаты работы программы в окне User Screen и Output.
6. Редактировать программу.
7. Сохранять выполняемую программу на диске.
8. Запускать программу на выполнение из-под Windows.
9. Открывать ранее сохраненную программу и создавать новую программу.
10. Работать с несколькими окнами.
11. Выходить из среды Turbo Pascal.
Интегрированная среда Турбо Паскаля 2

Упражнения
1. Запустите интегрированную среду Turbo Pascal. Наберите, сохраните и
выполните программу
Begin {начать и}
End. {закончить}
Конечно, эта программа не выполняет никаких действий, поскольку содержит только
пустой оператор. Однако исходный файл, содержащий эту программу, занимает 34 байта (11
байт без комментариев, заключенных в фигурные скобки). Сколько байт занимает
программный файл? Узнать это можно, сохранив программный файл на диске.
2. Комментарии (тексты, заключенные в фигурные скобки) в программный файл
не входят, т.е. программный файл будет иметь одинаковый размер независимо от того, есть в
исходном файле комментарии или нет. Комментарии в программе нужны человеку для
лучшего понимания текста программы. Убедитесь в справедливости сказанного, удалив
комментарии из текста программы, сохраненной при выполнении предыдущего упражнения.
Сохраните программу без комментариев в файле с другим именем и получите для нее
программный файл на диске.
3. Вот еще одна простая программа на Паскале. Она выводит текст, заключенный
в апострофы, в окно программы.
Begin
writeln ( 'Вот текст, который выводит программа' )
End.
Вставьте в первоначальную программу строку, содержащуюся в этом примере, и
запустите программу на исполнение. Как просмотреть в окне программы результаты работы
программы?
4. Для организации простейшего диалога кроме оператора вызова процедуры
вывода writeln, потребуется оператор вызова процедуры ввода readln. Воспользуйтесь ниже
приведенным текстом программы для организации диалога с компьютером.
var s: string;
Begin
writeln( 'Как тебя зовут?' );
readln(s);
writeln( 'Привет, ', s);
End.
Интегрированная среда Турбо Паскаля 3

Справочные материалы
Историческая справка.
Язык программирования Паскаль был создан Никласом Виртом в целях обучения
студентов программированию и назван в честь французского ученого Блеза Паскаля (1623 –
1662), который первым в мире изобрел автоматическое устройство, позволяющее
складывать числа. В 1971 г. Никлас Вирт опубликовал описание языка, в 1973 г. был
разработан первый транслятор. С тех пор Паскаль получил широкое распространение в мире
и не только в целях обучения. В 1992 г. фирма Borland International выпустила два пакета
программирования, основанные на использовании языка Паскаль. Это Borland Pascal 7.0 и
Turbo Pascal 7.0.В Турбо Паскале можно подготовить программы, работающие под DOS, а в
Борланд Паскале – работающие как под DOS, так и под Windows.

Пакет программирования Turbo Pascal состоит из компилятора с языка Паскаль и


инструментальной программной оболочки, повышающей эффективность создания
программ. Реализуемый компилятором язык программирования называется языком Турбо
Паскаля, а разнообразные сервисные услуги, предоставляемые программной оболочкой, –
средой Турбо Паскаля.
Запуск интегрированной среды.
Запустить интегрированную среду можно разными способами. Самый плохой – найти
и запустить файл turbo.exe. Гораздо лучше создать папку, в которой будут храниться ваши
файлы (программы) и вызывать Turbo Pascal из этого каталога. Самый надежный способ при
запуске из-под Windows – создать ярлык для запуска Turbo Pascal и настроить его для
работы в оконном режиме.
Для нормальной работы в пакете Turbo Pascal 7.0 должны быть каталоги: BIN
(содержит программные файлы turbo.exe, turbo.tpl, turbo.tph, turbo.tp, tpc.exe), UNITS
(содержит файлы стандартных модулей с расширением .tpu) и BGI (содержит графические
драйверы и шрифты).
Окно редактора
Сразу после запуска Турбо Паскаля среда должна автоматически перейти в режим
редактирования текста, в котором можно подготовить новую программу или исправить
существующую. Признаком того, что среда находится в режиме редактирования, является
наличие в окне редактора курсора – мигающей полоски. Если по какой-то причине,
например, были изменены настройки интегрированной среды, среда не вышла в режим
редактирования текста, установите новое окно редактора, используя команду меню File|New.
Интегрированная среда Турбо Паскаля 4

Окно редактора изображается в виде синего прямоугольника в белой двойной рамке с


именем программы – NONAME00.PAS. С его помощью имитируется просмотр длинного и
достаточно широкого листа бумаги, лишь часть которого видна на экране. Если курсор
достиг нижнего края окна, осуществляется сдвиг содержимого окна редактора вверх и снизу
появляется новая строка. Если курсор достиг правого края окна, содержимое окна
сдвигается влево, а справа появляется продолжение строки. Максимальная длина строки, как
и максимальное количество строк, ограничивается только общим количеством символов в
программе (не больше 64535), однако компилятор Турбо Паскаля воспринимает строки
программы длиной не более 126 символов. Всегда можно узнать местоположение курсора на
этом «листе бумаги», посмотрев на числа, разделенные двоеточием, в левом нижнем углу
окна редактора. Первое число означает номер строки текста, второе – номер позиции в
строке. Наличие значка слева от этих чисел означает, что текст в окне не сохранен на диске.
Новая программа
Файл, содержащий программу, написанную на языке Турбо Паскаль, называют
исходным файлом. Стандартное расширение имени исходного файла – .pas. Например,
файлу, содержащему программу из упражнения 1, можно дать имя prog1.pas.
Исходный файл можно подготовить в любом текстовом редакторе, но лучше делать
это в интегрированной среде Turbo Pascal, позволяющей редактировать (набирать и
исправлять) текст программы, запускать программу на исполнение и предоставляющей
программисту много дополнительных удобств.
Набор текста программы не представляет сложностей. Для переключения режима
набора текста латинскими или русскими буквами (LAT/RUS) обычно используется
совместное нажатие левой и правой клавиш Shift или левый Shift+Ctrl – латынь, правый
Shift+Ctrl – русский.
Клавиша Shift используется для набора прописных букв. Чтобы перейти к новой
строке, нажмите клавишу Enter. Используйте клавишу Enter и для вставки новой строки
между существующими. Чтобы стереть символ перед курсором, используйте клавишу забоя
(над клавишей Enter), а для удаления символа, на который указывает курсор, нажмите
клавишу Delete.
Стрелки и мышь помогут вам быстро перемещаться по тексту. Этой же цели служат
клавиши Home, End, Page Up и Page Down и их совместное нажатие с клавишей Ctrl. Справа
и снизу окна редактора имеются полосы прокрутки. Они удобны для перемещения по тексту
Интегрированная среда Турбо Паскаля 5

с помощью мыши. Для получения дополнительной информации читайте Help| Using Help|
The Editor.
Важно! Интегрированная среда Турбо Паскаль – многооконная среда. Возьмите за
правило: новая программа – новое окно File| New.
Работа с меню
Из режима редактирования можно перейти к любому другому режиму работы Turbo
Pascal, используя функциональные клавиши или выбрав нужный режим из главного меню.
Пункты главного меню размещены в верхней строке экрана над окном редактора: File, Edit,
Search, Run, Compile, Debug, Tools, Options, Window, Help.
Подведите курсор мыши к нужному пункту и щелкните левой кнопкой мыши. Если
мыши нет, нажмите совместно с клавишей Alt выделенную букву из названия пункта меню.
После того как меню откроется, выберите нужную команду, действуя или мышью (двойной
щелчок на нужной команде), или стрелками на клавиатуре и клавишей Enter. Многие
действия можно выполнить с помощью «горячих клавиш» - акселераторов.
Сохранение программы на диске
Для сохранения программы выберите в меню команду File| Save или File| Save As,
если вы хотите изменить имя файла. Убедитесь, что ваша программа будет записана именно
туда, где вы хотите ее видеть. Переопределите путь, если по какой-то причине путь
назначения указан неверно. Для переопределения пути можно использовать команду меню
File| Change dir .
Важно! Сохранить файл на диске можно нажатием клавиши F2. Делайте это
регулярно. Почему это важно, вы поймете, потеряв 20 - 30 строк программы, если вдруг
произойдет перебой с питанием компьютера.
Запуск программы на исполнение
Чтобы запустить программу, написанную на языке Турбо Паскаль, на исполнение,
нужно выбрать в меню интегрированной среды команду Run|Run. По этой команде
происходит компиляция (создается объектный файл с расширением obj, например,
prog1.obj), компоновка (создается программный файл с расширением .exe, например,
prog1.exe) и исполнение программы. В зависимости от настроек интегрированной среды эти
файлы хранятся либо в оперативной памяти, либо на диске. По умолчанию местом хранения
программного файла (исполняемого модуля) является оперативная память.
Для сохранения программного файла на диске используйте команду меню Compile|
Destination (если в этой опции установлено Memory, то программный файл сохраняется в
Интегрированная среда Турбо Паскаля 6

оперативной памяти, а если Disk, то программный файл сохраняется на диске).


Программный файл с расширением .exe можно запустить на исполнение непосредственно из
операционной системы.
Чтение файла с диска
Имеющийся на диске файл можно прочитать, выбрав в меню команду File| Open и
установив имя нужного файла. В программе на языке Турбо Паскаль, сохраненной в файле с
расширением .pas, будут выделены зарезервированные слова.
Редактирование и отладка программы
В процессе работы с программой программист подготавливает исходный текст
программы. Компьютер компилирует программу, создает программный файл и исполняет
его. Если результаты работы программы удовлетворяют программиста, то его работа с
программой заканчивается. В противном случае программист вносит в программу
изменения (редактирует ее) и процесс повторяется (отладка).
Если в программе, написанной на языке Турбо Паскаль, нет синтаксических ошибок,
то после запуска ее на исполнение на экране появляется сообщение о количестве строк
откомпилированной программы и объеме доступной оперативной памяти.
Затем интегрированная среда Турбо Паскаля выводит на экран окно программы и
передает управление программе. После завершения работы программы, интегрированная
среда вновь берет на себя управление работой компьютера и восстанавливает на экране окно
редактора. Просмотреть окно программы можно командой Debug| User screen.
Если на каком-либо этапе среда обнаружила ошибку, она прекращает дальнейшие
действия, восстанавливает окно редактора и помещает курсор на ту строку программы, при
компиляции или исполнении которой была обнаружена ошибка. При этом в верхней строке
редактора появляется диагностическое сообщение о причине ошибки.
Выход из интегрированной среды
Выберите в меню команду File|Exit. Если в окне редактора есть не сохраненный
текст, на запрос, сохранять ли его, ответьте Yes, если вы хотите его сохранить на диске, No -
в противном случае и Cancel, если вы вообще передумали выходить из среды Турбо
Паскаль.
Система окон среды.
Интегрированная среда Турбо Паскаль является многооконной. Можно открыть
столько окон, сколько позволяет наличие свободной оперативной памяти. Однако активным
– доступным для выполнения в нем каких-либо операций – может быть только одно из них.
Интегрированная среда Турбо Паскаля 7

Активное окно выделяется двойной рамкой и располагается поверх других окон, если они
перекрываются. Имеются следующие окна: окна редактирования; окна меню; окна диалога;
информационные окна.
Окна редактирования открываются из меню File командой File| New (новая
программа) или File| Open (сохраненная на диске программа). Из окна редактирования
можно получить доступ к окнам меню.
Окна диалога широко используются в системе меню для задания различных режимов
работы или необходимых параметров. Таковы, например, окна диалога при сохранении
файла на диске или открытии файла.
Информационные окна служат для размещения в них данных о текущем
вычислительном процессе и данных, получаемых программой. Это, например, окно отладки,
окно просмотра результатов работы программы, окно справочной службы (Help).
При необходимости окна можно закрывать. Размеры и положение окон (не всех)
можно изменять. Соответствующие команды содержатся в меню Window. Удобным для
работы (отладки программы) в среде Турбо Паскаль может быть такое расположение окон,
при котором на экране одновременно видны окно редактора с отлаживаемой программой,
окно отладки (Watch) и окно просмотра результатов работы программы (Output).
Справочная служба Турбо Паскаля
Используйте справочную службу Турбо Паскаля (Help), чтобы получить
информацию о языке Турбо Паскаль и о возможностях интегрированной среды. В
сообщениях справочной службы все перекрестные ссылки выделяются цветом. Любую из
перекрестных ссылок можно получить, используя указатель мыши или действуя стрелками и
клавишей ввода.
Во многих случаях достаточно нажать клавишу F1 (возможно, совместно с клавишей
Ctrl), чтобы получить помощь в затруднительной ситуации.
Команды меню File
 Open — открыть новое окно редактора и поместить в него указанный
дисковый файл.
 New — открыть новое окно редактора с именем NONAME.
 Save — сохранить содержимое активного окна редактора в файл на диске.
 Save as — сохранить содержимое активного окна редактора в файл на диске с
другим именем.
Интегрированная среда Турбо Паскаля 8

 Save all — сохранить содержимое всех окон редактора в соответствующие


файлы на диске.
 Change dir — изменить текущий каталог, в котором сохраняются программы.
 Print — печатать содержимое активного окна редактора на принтере.
 Printer setup — изменить настройки принтера.
 DOS shell — обеспечить временный выход в ДОС. Турбо Паскаль остается
резидентным в памяти. Для возвращения в среду Турбо Паскаля нужно в командной строке
ДОС напечатать слово EXIT и нажать клавишу ввода.
 Exit — завершить работу с Турбо Паскалем.
Команды меню Help:
 Contents — дать содержание справочной службы.
 Index — вывести алфавитный список всех ссылок справочной службы.
 Topic search — осуществить поиск в окрестности курсора зарезервированного
слова или стандартной процедуры (функции) и дать соответствующую справку. Вызывается
из редактора командой Ctrl+F1.
 Previous topic — вывести предыдущее справочное сообщение.
 Using help — дать справку о том, как пользоваться справочной службой.
 Files — использовать дополнительные файлы справок.
 Compiler directives — дать описание директив компилятора.
 Procedures and functions — вывести справки о всех процедурах и функциях
Турбо Паскаля в алфавитном порядке.
 Reserved words — вывести список зарезервированных слов.
 Standard units — дать справки о содержании стандартных модулей Турбо
Паскаля.
 Turbo Pascal Language — вывести справочник языка Турбо Паскаль.
 Error messages — вывести список ошибок компиляции и исполнения
программы.
 About — дать информацию о системе программирования.
Команды меню Window
 Tile — расположить окна без перекрытий, «черепицей».
 Cascade — расположить окна одно над другим, каскадом.
 Close All — закрыть все окна.
Интегрированная среда Турбо Паскаля 9

 Refresh Display — обновить экран, если программа случайно изменила его


состояние.
 Size/Move — изменить размеры окна, переместить его.
 Zoom — увеличить размеры окна до размеров экрана.
 Next — сделать активным следующее окно.
 Previous — сделать активным предыдущее окно.
 Close — закрыть активное окно.
 List ... — представить список открытых окон.
Наиболее сложной из перечисленных команд является команда Size/Move. Изменение
местоположения окна на экране осуществляется нажатием клавиш со стрелками. Изменение
размеров окна осуществляется нажатием клавиш со стрелками совместно с клавишей Shift.
Гораздо удобнее изменять размеры окна с помощью мыши. Правый нижний угол окна
выделен цветом. Надо установить на него указатель мыши и при нажатой левой кнопке
мыши протянуть указатель к желаемому положению правого нижнего угла. Левый верхний
угол при этом не изменяет своего положения. Для перемещения окна по экрану указатель
мыши устанавливается на заголовок окна и, при нажатой левой кнопке мыши, окно
перемещают по экрану. Альтернативой команде Zoom является щелчок кнопкой мыши по
стрелке в правом верхнем углу. Чтобы закрыть окно (команда Close), надо выполнить
щелчок по прямоугольному элементу в левом верхнем углу окна.
Функциональные клавиши
С функциональными клавишами F1, F2, … , F10, а также с некоторыми
комбинациями с клавишами Alt (от ALTernativ — дополнительный), Ctrl (ConTRoL —
управление) и Shift (SHIFT — сдвиг) связаны команды, управляющие средой. Под
комбинацией клавиш понимается их совместное нажатие, обозначаемое знаком +.
 F1 — обратиться за справкой к справочной службе.
 F2 — сохранить содержимое активного окна редактора в файле на диске.
 F3 — прочитать содержимое файла на диске в окно редактора.
 F4 — в режиме отладки программы: начать пошаговое выполнение программы
со строки, на которой находится курсор.
 F5 — активное окно увеличить до размера окна редактора.
 F6 — сделать активным следующее окно.
Интегрированная среда Турбо Паскаля 10

 F7 — в режиме отладки программы: команда выполнить следующую строку


программы. Если в строке есть обращение к процедуре или функции, то войти в эту
процедуру (функцию).
 F8 — в режиме отладки программы: команда выполнить следующую строку
программы. Если в строке есть обращение к процедуре или функции, то выполнить эту
процедуру (функцию), но не прослеживать ее работу.
 F9 — компилировать программу, но не выполнять ее.
 F10 — перейти к диалоговому режиму работы с помощью меню.
Комбинации клавиш для работы со встроенной справочной службой

 Alt+F1 — вывести на экран предыдущее справочное сообщение.


 Ctrl+F1 — осуществить поиск в окрестности курсора зарезервированного
слова или стандартной процедуры (функции) и дать соответствующую справку.
 Shift+F1 — вывести на экран алфавитный список всех ссылок справочной
службы.
Быстрое передвижение по тексту
 Page Up — на страницу вверх.
 Page Down — на страницу вниз.
 Ctrl+Page Up — в начало текста.
 Ctrl+Page Down — в конец текста.
 Ctrl+\leftarrow — в начало слова левее курсора.
 Ctrl+\rightarrow — в начало слова правее курсора.
 Home — в начало строки.
 End — в конец строки.
Вставка и удаление в режиме редактирования
 Insert — переключатель режима вставка/замена.
 Ctrl+N — вставить строку.
 Ctrl+Y — удалить строку.
 Ctrl+Q Y — удалить часть строки от курсора до конца.
 Backspace — это клавиша \leftarrow над клавишей ввода. Удалить символ слева от
курсора.
 Delete — удалить символ, на который указывает курсор.
Интегрированная среда Турбо Паскаля 11

 Ctrl+T — удалить слово.


Комбинации клавиш для работы с окнами
 Ctrl+F5 — изменить размеры окна, переместить окно.
 Shift+F6 — активизировать предыдущее окно.
 Alt+F3 — закрыть окно.
 Alt+0 — представить список окон.
Запуск программы на выполнение — Ctrl+F9