Вы находитесь на странице: 1из 3

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
neighbor 2.2.2.2 remote-as 234
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

ip classless
ip route 2.2.2.0 255.255.255.0 192.168.12.2
R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255

interface Loopback1
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.0

router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0

router bgp 234


no synchronization
bgp log-neighbor-changes
network 192.168.2.0
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 234
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 4.4.4.4 remote-as 234
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
no auto-summary

ip route 1.1.1.0 255.255.255.0 192.168.12.1


Page 1 of 3
R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.3 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.23.3 255.255.255.0

router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.23.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 0
!
router bgp 234
no synchronization
bgp log-neighbor-changes
network 192.168.3.0
neighbor 2.2.2.2 remote-as 234
neighbor 2.2.2.2 update-source Loopback0
neighbor 4.4.4.4 remote-as 234
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.4 255.255.255.0

interface FastEthernet0/1
ip address 192.168.45.4 255.255.255.0
!

router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 192.168.34.0 0.0.0.255 area 0

router bgp 234


no synchronization
bgp log-neighbor-changes
network 192.168.4.0
Page 2 of 3
neighbor 2.2.2.2 remote-as 234
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 3.3.3.3 remote-as 234
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 5.5.5.5 remote-as 5
neighbor 5.5.5.5 ebgp-multihop 2
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
ip route 5.5.5.0 255.255.255.0 192.168.45.5
!
R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.45.5 255.255.255.0
!
router bgp 5
no synchronization
bgp log-neighbor-changes
network 192.168.5.0
neighbor 4.4.4.4 remote-as 234
neighbor 4.4.4.4 ebgp-multihop 2
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
ip route 4.4.4.0 255.255.255.0 192.168.45.4

Page 3 of 3

Вам также может понравиться