Вы находитесь на странице: 1из 17

UNIVERSIDAD IBEROAMERICANA

LABORATORIO
FISICA UNIVERSITARIA 2

PROYECTO
SIMULACION DE CIRCUITOS MEDIANTE
SOFTWARE
“LIVEWIRE”

FECHA: 8 /11/2010
UNIVERSIDAD IBEROAMERICANA
LABORATORIO FISICA UNIVERSITARIA 2
PROYECTO
SIMULACION DE CIRCUITOS MEDIANTE SOFTWARE “LIVEWIRE”
SERGIO ADRIAN HERNANDEZ RUIZ 170961-8
FERNANDO ALBERTO ESCUDERO GUZMAN 170889-3
GRUPO: G

OBJETIVOS:
El objetivo del siguiente proyecto se enfoca en dar una visión mas completa y real de cómo funcionan
los circuitos eléctricos y sus propiedades como son la corriente y voltaje en sus diferentes conexiones,
(serie y paralelo), de una manera fácil y didáctica, por lo cual este documento pretende ser un tutorial
del software y a su vez una guía para los ejercicios realizados en el laboratorio.

INTRODUCCION:
El siguiente programa de simulación es un ejemplo mas de toda la cantidad de programas para
simulación que existen hoy en día en la industria, este entorno integrado de desarrollo (IDE) esta
considerado de bajo rendimiento ya que no pose cualidades muy avanzadas a comparación de otros
como Multisim de National Instruments, Proteus de Labcenter y recientemente Circuit Applet que es un
programa con licencia GLP (publica) que se encuentra en la red, por otra parte nuestro programa cuenta
con características que lo hace muy flexible para la introducción y trabajo con circuitos no complejos,
estas son, facilidad de manejo y entorno amigable además de poseer una cualidad muy importante que
es la que nos interesa.

Este software cuenta con una opción llamada Current Flow que es la cualidad a la que nos referíamos,
esto opción de simulación nos muestra el flujo de corriente y su magnitud de una manera animada y
fácil de comprender dentro de un circuito eléctrico, lo que nos permite entender las diferentes
propiedades como el voltaje la corriente y sus diferentes configuraciones.

DESARROLLO:
Ahora bien, comencemos a introducirnos en el entorno, primero haremos una explicación general del
software nombrando sus partes y opciones para posteriormente pasar a ejemplos concretos.

INSTALACION DEL SOFTWARE

El paquete completo del software viene dentro de un carpeta que lleva el mismo nombre que el
programa (Livewire), dentro de esta carpeta están todos los archivos necesarios para su buen
funcionamiento. Ahora bien, para su instalación lo único que se requiere es, copiar la carpeta llamada
LIVEWIRE dentro de un lugar donde estemos seguros de no borrarlo, como puede ser dentro de
C:/Archivos de Programas/… y posteriormente crear un acceso directo al archivo ejecutable
“Livewire.exe” y colocarlo en el escritorio. Una vez que tengamos el acceso directo listo, podremos
acceder al programa como

cualquier otro.
PANTALLA INICIAL
Una vez instalado el software, podemos iniciarlo desde su acceso directo el cual nos presenta la
siguiente imagen.

Figura 1 – Entorno de desarrollo de Livewire

A continuación explicaremos cada una de las partes y herramientas del mismo, primero tenemos lo que
es la barra de menús.

BARRA DE MENUS

Figura 2 – Barra de menús


File – en este menú tenemos las opciones de Nuevo, Cerrar, Guardar, Imprimir, etc, como se muestra en
la figura.

Figura 3 – Menu File


Edit – En este menú tenemos las opciones de Copiar, Pegar, Borrar, Deshacer, etc.

Figura 4 – Menu Edit

View – En el menú View tenemos algunas opciones propias del programa como es la de mostrar la reja
de puntos, mostrar las barras de herramientas y propiedades de la hoja.

Figura 5 – Menu View

Insert – En especial este menú es importante por que desde aquí podemos insertar los componente que
queramos en caso de haber cerrado la ventana emergente que se abre automáticamente cuando inicia
el programa, tanto la ventana emergente como este menú sirven para lo mismo, insertar los
componentes, la única diferencia es que en la ventana emergente podemos observar la imagen del
dispositivo.

Figura 6 – Menu Insert Figura 7 – Ventana emergente o


Galeria de dispositivos
Tools – Dentro del menú tolos tenemos las opciones de funcionalidad del programa, estas herramientas
son las de poder simular el circuito, pararlo y ortografía. Esta opciones también puden ser controladas
desde otra barra de herramienta estándar que posteriormente de describirá.

Figura 8- Menu Tools

Dentro de este menú tenemos modos de simulación en general para todos los tipos de simulaciones
existentes, con esto me refiero a que tenemos la opción de simulación Mute, Explosions, Faults y
Bounce. Las opciones de simulación que a nosotros nos interesan son Mute y Explosions, Mute nos
permite simular los circuitos sin tomar en cuenta los factores reales de los componentes como la
potencia disipada y calentamiento, al contrario, la opción de Explosions nos permite tener en cuenta
estas consideraciones y nos permite tener una simulación mas apegada a la realidad mediante una
animación de la sobrecarga del dispositivo debido al flujo de corriente.

Windows y Help – Dentro de menú Windows tenemos las opciones de visualización de la pantalla,
modo horizontal , vertical, cascada, etc. y dentro del menú Help esta la ayuda e información del
programa, como versión, diseñadores , etc.

Figura 9 – Menu Window Figura 10 – Menu Help

La opción de ayuda del programa, muchas veces es muy útil ya que nos presetna un pequeño tutorial de
cómo funcionan las cosas, como podemos ver en la imagen, a modo de prueba se selecciono la ayuda de
cómo funciona el osciloscopio. Para realizar una búsqueda se da clic en el botón Search y se escribe la
palabra o dispositivo que se busca en nuestro caso en particular el Osciloscopio.

Figura 11 – Busqueda con la herramienta Search Figura 12 – Livewire Help para encontrar
como funciona el Osciloscopio
BARRAS DE HERRAMIENTAS

Figura 13 – Barra de herramientas

Al iniciar el programa muestra dos barras de herramientas principales, la barra de la izquierda


es la barra estándar la cual contiene las herramientas básicas como es copiar, guardar,
imprimir, abrir, etc y la la barra de la derecha es la barra llamada Toolbox la cual contiene
herramientas como:

Cursor - que nos sirve para seleccionar objetos.


La manita (Pan) - nos sirve para mover el circuito completo.
Zoom
Delete
Grahp - muy importante por que nos permite insertar las graficas de los componentes como el
osciloscopio.
Rotar – nos permite rotar a la izquierda o derecha algún componente.
Gallery - nos permite visualizar la galería de componentes (ventana emergente de
componentes).

BARRA DE HERRAMIENTA STYLE


Esta barra en particular es muy importante por que nos permite visualizar las diferentes
opciones de simulación que tiene el programa, esta barra se encuentra del lado izquierdo de la
pantalla y de forma vertical.

Figura 14 – Barra de herramientas Style

Para observar su funcionamiento veremos un ejemplo de cada una de las opciones de


simulación de esta barra en diferentes imágenes.

Simulacion Normal – Esta simulación es la mas básica, muestra al circuito tal como lo
diseñamos, sin ningún cambio, pero se observa el funcionamiento del mismo.

Figura 15 – Simulacion modo Normal


Simulacion Voltage Levels – En esta simulación se pueden apreciar tanto el sentido de la
corriente con un flechitas azules como el nivel alto de voltaje mediante cuadritos rojos, esto es
útil cuando se tienen circuitos lógicos, como es el caso de compuertas lógicas o dispositivos
lógicos.

Figura 16 – Simulacion modo Voltage Levels

Simulacion Current Flow – Esta simulación es la mas importante para nuestro propósito ya que
permite ver el sentido de la corriente, como fluye a través del circuito y como cambia su
magnitud debido a la oposición de algún dispositivo.
Esta simulación nos permite ver perfectamente como es la corriente y como pasa por los
diferentes componentes.

Figura 17 – Simulacion modo Current Flow

Simulacion Logic Level – Esta simulación es indispensable para los circuitos puramente lógicos
donde se requiere ver en donde y en que salidas tenemos un 1 o un 0 lógico.
Figura 18 – Simulacion modo Logic Levels

Una vez terminada la explicación de los diferentes tipos de simulaciones que tenemos pasemos
la ver como crear un circuito nuevo y como simularlo

CREACION DE UN CIRCUITO Y SIMULACION


Para la realización de un circuito, como en cualquier programa debemos ir al menú File, New o
simplemente al abrir el programa tenemos una hoja en blanco.
Para crear nuestro circuito debemos de buscar los dispositivos que lo forman dentro de la
galería de componentes, una vez que los encontramos damos un clic sobre el para seleccionarlo
y luego otro clic dentro de la hoja para colocarlo.
Otro proceso es el de dar clic sobre el objeto, sostener en botón y arrastrarlo a la hoja.

Figura 19 – Métodos para colocación de componentes

Continuamos con el mismo procedimiento hasta colocar todos los componentes dentro de la
hoja, para posterior mente proceder editarlos y conectarlos.

Una vez colocados los componentes dentro de la hoja y si se requiere editar algunas de sus
propiedades como su valor o nombre se siguen los siguiente pasos.
BUSQUEDA DE ELEMENTOS
Para buscar un dispositivo e insertarlo en la hoja de trabajo podemos ir a la galería de
componentes y buscarlo mediante las categorías existentes, en la siguiente imagen se puede
ver en el menú desplegable los nombres de todas las categorías existentes.

Figura 20 – Menú desplegable con todos los componentes posibles

Como se puede observar dentro de cada categoría podemos ver los diferentes componentes
como fuentes de Voltaje, Conectores, Componentes Pasivos, Lógicos, Discretos, etc. Como
ejemplo veamos la categoría de Componentes Pasivos y de Medición.

Componentes Pasivos
Dentro de los pasivos encontramos las resistencias, capacitores e inductores

Figura 21 – Categorías de los componentes Pasivos


Instrumentos de Medición
Aquí tenemos dos tipos de instrumentos los de medición (amperímetro, voltímetro, test point)
y los virtuales. Dentro de estos encontramos lo que es el multimetro análogo, digital, el
watometro, osciloscopio y un analizador lógico.

Figura 22 – Instrumentos de medición

Dentro de las demás categorías podemos encontrar compuertas lógicas, conectores, circuitos
integrados, terminales etc, todo lo necesario para simular circuitos digitales y analógicos, en la
siguiente imagen podemos ver la categoría de compuertas lógicas de la familia 74.

Figura 23 – Familia lógica 74


EDICION DE COMPONENTES
Para editar algún componente lo que se hace, es dar doble clic sobre la imagen del mismo y
aparece una ventana con sus propiedades, donde se editan sus valores directamente, como
ejemplo una resistencia.

Figura 24 – Edición de propiedades de una resistencia

Como se aprecia dentro de la ventana tenemos varias opcinaes a editar, Number, que es el
numero del componente dentro del circuito, Caption, que es el nombre del componente dentro
de nuestro circuito y Value, que es el valor de nuestro componente.
Tambien dentro de la ventana podemos observar el botón de Help, este botón es para mostrar
la ayuda del programa para cada componente en especial, nos explica como funciona y para
que son cada uno de los campos de sus propiedades.

Figura 25 – Ayuda de una resistencia


PROCESO DE CONEXIÓN
Para conectar los componentes entre si:
Paso 1 - se pone el cursor sobre una de las terminales del componente hasta que aparezca una
cruz que indica la conexión.

Paso 2 – se sostiene el clic y se arrastra hasta la otra terminal del componente que se quiere
unir

Paso 3 – si se requiere hacer vueltas o dobleces con el cable, lo que se hace es dar un clic donde
se requiera el doblez

Una vez que se tiene unido y listo el circuito se pasa a simularlo

Figura 22 – Circuito completo, listo para simulación

Terminado el circuito se procede a la simulación del mismo, esto se hace mediante el botón
Run dentro de la barra estándar o dentro del menú Tools/Simulation/Run, aun lado también
podemos encontrar los botones de Pausa y Stop de la simulación, como se observa en la
siguientes imágenes.

Figura 26 – Botones para iniciar la simulación


Teniendo lista la simulación del circuito podemos pasar a ver las diferentes opciones de
simulación que anteriormente mencionamos, Voltage Level, Current Flow, Logic Level, etc.
Una vez dentro de la simulación que queramos existen dos formas para analizar el circuito con
respecto a los diferentes parámetros que deseemos, estos parámetros pueden ser corriente y
voltaje, para esto existen dos formas, poniendo el cursor sobre el punto que queramos medir o
insertando un componente de medición como podemos ver en seguida.

Una cosa importante que tenemos que mencionar es la de que una vez iniciada la simulación
no se puede modificar el circuito, así es que para hacer cualquier cambio primero se tiene que
parar la simulación

MEDICION DE PARAMETROS
Como ya mencionamos existen dos formas para medir los valores de corriente y voltaje, la
primera es, posicionando el cursor sobre el punto a medir.

Figura 27 – Medición de corriente y voltaje en un punto

Como podemos observar sale un recuadro con la medición de voltaje y corriente en ese punto,
en este caso 9 Volts y 9 mili ampers.
Para medir los watts sobre un dispositivo se pone el cursor sobre tal componente y en un
recuadro en la parte de abajo se aprecia el valor de la corriente y los watts disipador en ese
momento en el elemento, como se muestra a continuación.

Figura 28 –Medición de corriente y potencia

La segunda forma es la de poner instrumentos de medición dentro del circuito, como podemos
observar, esto es muy útil por que también nos permite ver y entender como se conectan los
diferentes dispositivos para medir voltaje y corriente, y como fluye la corriente por los mismos.
Figura 29 – Medicion de parámetros mediante instrumentos de medición

Aparte de los instrumentos mas comunes como el Voltímetro o el Amperímetro existen otros
instrumentos que nos pueden ser útiles, con esto me refiero al osciloscopio, milímetro digital,
analógico y watometro. Es importante mencionarlo por que en especifico el osciloscopio
necesita de una grafica donde se puedan mostrar las señales que están presentes en sus
entradas.
El proceso para introducir y conectar un elemento de medición es igual al de los componentes.
Veamos como es agrega una osciloscopio a un circuito, como ejemplo tenemos un circuito de la
primera etapa de una fuente de voltaje directo, como se ve en la siguiente ilustración.

Figura 30 – Circuito de la etapa 1 de una fuente de voltaje directo

Teniendo listo nuestro circuito anexamos un osciloscopio y lo conectamos a las terminales


adecuadas.

Figura 31 – Conexión de un osciloscopio de dos canales

Ahora bien para que podamos ver el resultado de las señales en observación tenemos que
generarle una grafica para que podamos ver el resultado de la señal. Para lograr esto tenemos
que ir al menú del elemento y dar clic en la opción de Add Graph como se observa en la
siguiente ilustración.
Figura 32 – Menú del elemento Osciloscopio mostrando la opción de Add Graph

Al dar clic sobre esta opción formamos un recuadro dentro de la hoja, tal recuadro es la grafica
donde se van a mostrar los resultados.

Figura 33 – Grafica del osciloscopio lista para iniciar el muestreo de la senal

Por ultimo, ya teniendo la grafica de salida solo basta con iniciar la simulación y obtener las
señales en la grafica, la grafica también puede ser editada de sus propiedades dentro de su
menú secundario, los parámetros que pueden ser modificados son el tamaño del voltaje
máximo y mínimo, tiempo de muestreo y color de las señales.

Figura 34 – Grafica de salida de un osciloscopio

Una ves teniendo todos los conceptos necesarios para utilizar este IDE de simulación y sus
herramientas podemos ver un ejemplo de dos circuitos sencillos donde se muestra la medición
y conexión en serie y paralelo de resistencias, circuito útil para los temas que se ven en
laboratorio. Claro esta que mediante la utilización de este software se pueden diseñar circuitos
mas complejos facilitando su entendimiento.
CIRCUITO EJEMPLO (SERIE-PARALELO)
Como ejemplo, tenemos el siguiente circuito modelado en el simulador, tal circuito nos permite
ver como se conectan los instrumentos de medición además de poder monitorear sus voltajes y
corrientes en cada una de las resistencias que lo forman. Un circuito esta en paralelo y el otro
esta en serie como se puede observar.

Figura 35 – Circuito ejemplo de conexiones serie paralelo

Dentro de la carpeta Ejemplos circuitos podemos encontrar tres ejercicios que modelan
ampliamente las funciones más importantes de este simulador, estos circuitos fueron
realizados para mostrar el funcionamiento del programa. Para aprender y ver distintas
funcionalidades del software, este cuenta con dos carpetas llamadas Electricity y Electronics,
ubicadas dentro del submenú Abrir del menú Archivo.
La carpeta Electricity cuenta con circuitos eléctricos y la carpeta Electronics cuenta con circuitos
Electronicos, a continuación se muestra una imagen con los ejemplos de Electricity.

\
Figura 36 – Carpeta Electricity con ejemplos
Dentro de esta carpeta se encuentra un ejemplo de la ley de Ohm que puede ser my útil para la
enseñanza en el laboratorio.

Figura 37 – Ejemplo Ley de Ohm

CONCLUSIONES
Como pudimos observar, este programa es muy útil para la simulación de circuitos eléctricos y
electrónicos de manera fácil y didáctica, que permita a los estudiantes una mejor comprensión
de los ejercicios realizados en la clase.

SERGIO ADRIAN HERNANDEZ RUIZ


170961-8
serjames@hotmail.com
Si tiene alguna duda o quiere saber mas sobre algún tema de electrónica le dejo mi mail para que
me contacte.

FERNANDO ALBERTO ESCUDERO GUZMAN


170889-3
escguzman@hotmail.com