Вы находитесь на странице: 1из 40

Технический Университет Молдовы

Факультет Градостроительства и Архитектуры


Кафедра Железных, автомобильных дорог и
мостов

МАШИННАЯ ГРАФИКА

Auto CAD. 3D моделирование

Учебное пособие

Кишинэу
ТУМ
2007
Кратко изложены основные команды трехмерного
моделирования графической системы AutoCAD.
Предназначено для студентов специальностей
«Архитектура» и «Дизайн интерьера», изучающих дисциплину
курса «Grafica asistată de calculator».

Составитель: старшии преподаватель, Шаргородская Т.А

Ответственный редактор: кандидат технических наук,


доцент Шаргородский М.Т

Рецензент: кандидат технических наук, доцент Грозаву Н.Т

____________________________________________________________
Bun de tipar 28.06.07 Formatul hărtiei 60x84 1/16
Hărtie ofset. Tipar ofset Tirajul 100 ex.
Coli de tipar 2,5 Comanda nr.106
––––––––––––––––––––––––––––––––––––––––––––––––––––––––––––
U.T.M., 2004, Chişinău, bd.Ştefan cel Mare, 168.
Secţia Redactare şi Editare a U.T.M.
MD-2068, Chişinău, str.Studenţilor, 9/9

© ТУМ,2007
ТРЕХМЕРНАЯ ГРАФИКА
Использование компьютерных технологий при
проектировании и разработке архитектурных объектов
дизайна интерьера помогает увидеть конечный вариант
задолго до того, как объект будет создан. Трехмерная
графика позволяет создавать трехмерные макеты различных
объектов, повторяя их геометрическую форму и имитируя
материал, из которого они созданы. Чтобы получить полное
представление об определенном объекте, необходимо
осмотреть его со всех сторон, с разных точек. 3D-
презентации — популярное средство для привлечения
внимания к своим разработкам в сфере образования и науки.
AutoCAD широко используется для создания трехмерных
моделей, но не обладает средствами создания убедительной
фотореалистичной визуализации. Все чаще AutoCAD
используется в связке с другими пакетами визуализации
объектов проектирования. Например, связь «моделирование
— AutoCAD , рендеринг — 3ds Max» можно очень часто
встретить на интерьерных и экстерьерных
визуализациях.Форма — это геометрия объекта, которая в
простейшем случае описывается серией взаимосвязанных в
трехмерном пространстве точек (вершин) и многоугольников
(граней — замкнутых двумерных фигур с тремя или более
сторонами). Например, куб имеет восемь вершин и шесть
граней. Раньше для простоты в качестве базовых
многоугольников выбирались треугольники. Несколько
сотен или даже тысяч таких треугольников соединялись друг
с другом и образовывали сложные трехмерные сетки. Теперь
же в трехмерных пакетах все больше используется
моделирование гладких поверхностей в форме сплайнов, или
так называемое твердотельное моделирование (solid), что и
будет основным предметом рассмотрения в данной работе. В
системе AutoCAD существует большой набор
пространственных примитивов, которые позволяют

3
выполнять построения трехмерных моделей зданий,
сооружений и различных машиностроительных изделий.

1. РАБОТА С СИСТЕМАМИ КООРДИНАТ В


ТРЕХМЕРНЫХ МОДЕЛЯХ
1.1.Двумерные и трехмерные системы координат
Любая точка чертежа выполняемого в AutoCAD может
быть представлена двумя координатами Х (абсциссой) и У
(ординатой). То есть система координат на плоскости
состоит из двух взаимно перпендикулярных осей. О
направлении этих осей нам указывает пиктограмма,
расположенная в левом нижнем углу рабочего пространства
при открытии нового чертежа (рис.1.1). В процессе работы в
пространстве эта пиктограмма может быть в различных
положениях относительно экрана

Рис. 1. 1. Пиктограмма мировой системы координат. Стиль 2D

Ось абсцисс расположена горизонтально и ее


положительное направление - слева направо. Ось ординат
расположена вертикально и ее положительное направление –
снизу вверх.
Для того чтобы перейти в пространство нам нужно
добавить еще одну ось - ось аппликат (Z). Эта ось
перпендикулярна как оси абсцисс, так и оси ординат (т.е.
перпендикулярно плоскости ХУ). Например, если плоскость
ХУ совпадает с плоскостью экрана нашего монитора, то
положительное направление оси аппликат – от экрана к нам.
Итак, каждая точка в пространстве представляется тремя
координатами Х, У и Z.
Многие команды трехмерного построения
предполагают ввод точек в трехмерных координатах.
Существует несколько видов записи трехмерных координат.

4
Абсолютные X,Y,Z Точка находится в координатах
координаты (22,57,114) X=22, Y=57, Z=114
Относительные @∆X,∆Y,∆Z Точка смещена относительно
декартовые (@35,118,20) предыдущей по оси X на 35, по
координаты оси Y на 18, по оси Z на 35
единиц
Относительные @L<α,Z Проекция отрезка соединяющего
полярные @47<30, 12 предыдущую точку с
координаты последующей на плоскость XY –
47. Угол между проекцией
отрезка на плоскость XY и
положительным направлением
оси X – 30о. Смещение точки по
оси Z - 12
Относительные @L<α1< α2 Отрезок, соединяющий
cферические @83<30<45 предыдущую точку с
координаты последующей – 83. Угол между
проекцией отрезка на плоскость
XY и положительным
направлением оси X - 30о. Угол
между отрезком и плоскостью
XY – 45о,

Пиктограмму, указывающую направление осей координат в


двухмерном пространстве, можно заметить пиктограммой,
указывающую направление осей координат в трехмерном
пространстве (Рис. 1.2). Для наглядности перейдите в вид
SW_Isometrc. Меню View>3DView> SW_Isometrc

Рис. 1.2 Пиктограмма мировой системы координат. Стиль 3D

5
1.2. Настройка пиктограммы UCS
Для выбора стиля отображения пиктограммы в падающем
меню выберите:
View>Display>UCS_Icon>Properties
В раскрывающемся диалоговом окне установите стиль 2D
или 3D. В этом же окне можно установить другие параметры
пиктограммы:
• параметр Cone выводит на конце осей замкнутую
(или незамкнутую) стрелку;
• параметр Line Width управляет шириной линии
пиктограммы;
• UCS icon size устанавливает величину знака в % от
размера экрана (от 5 до 95%);
• UCS icon сolor устанавливает цвет знака.
В AutoCAD рисовать можно только на плоскости ХУ, но эту
плоскость в пространстве можно расположить как угодно.
Плоскость XY основной системы координат, с которой мы
до сих пор работали совпадает с плоскостью графического
экрана. Третья ось (ось Z) МСК расположена
перпендикулярно экрану и направлена от экрана к нам. Такая
система координат называется мировой системой
координат (МСК).
Признаком того, что вы работаете в мировой системе
координат, является наличие буквы «W» (World) в
пиктограмме 2D, или квадрата на пересечении осей ХУ в
пиктограмме 3D. Любые другие системы координат
называются пользовательскими, о которых мы будем
говорить отдельно.

6
1.3. Пользовательские системы координат
ПСК (UCS)
Для задания любых других плоскостей построений, которые
не параллельны плоскости XY МСК, используется команда
UCS. Аббревиатура команды образована от слов
"пользовательская система координат" ("user coordinate
system"). Все системы координат, отличные от мировой,
называются пользовательскими.
Пользовательские системы координат могут именоваться.
Команда ПСК (UCS) позволяет задать начало новой системы
координат и положение новых осей Х и Y, а положение
новой оси Z зависит от положения соответствующих осей Х
и Y и поэтому определяется автоматически.
Для того, чтобы рассмотреть другие системы координат
необходимо произвести некоторые построения.
Построим параллелепипед с параметрами: length(длина) -
200; width (ширина) - 100; height(высота) - 100
Воспользуемся меню Draw>Solids>Box для построения
стандартной фигуры Box или соответствующей
пиктограммой на панели инструментов Solids (Рис.1.3)

Рис.1.3. Панель инструментов Solids

Command: _box
Specify corner of box or [CEnter] <0,0,0>: 0,0
Введите значение координат левого ближнего угла нижней
грани параллелепипеда
Specify corner or [Cube/Length]: l
Введите опцию L(длина) для указания размера по оси Х
Specify length: 200
Введите значение длины 200
Specify width: 100
Введите значение ширины (размер по оси Y) 100
Specify height: 100

7
Введите значение высоты (размер по оси Z) 100
Перейдите в вид SW_Isometrc. Меню View>3DView>
SW_Isometrc
Для наглядности расположения осей X, Y, Z перейдем к виду
3D пиктограммы осей координат (рис 1.4).

Рис. 1.4. Параллелепипед

Заметим, что все двухмерные построения в АutoCAD


осуществляются в плоскости XY.
Чтобы осуществить построения, например, на грани
параллелепипеда, которая на рис.1.4 находится в плоскости
XZ, необходимо, переместить плоскость XY на указанную
грань. Для этого мы должны установить пользовательскую
систему координат, воспользовавшись меню:Tools
>NewUCS или соответствующей пиктограммой на панели
инструментов UCS (рис.1.5).

Рис. 1.5. Панель инструментов UCS

Возможны следующие опции создания новой


пользовательской системы координат:
• Origin of new UCS (начало новой ПСК) - перенос
начала ПСК в новую точку с сохранением направлений
осей Х и У.
Зададим команду расположения новой (пользовательской)
системы координат Tools>NewUCS>Origin.
На запрос команды укажите новую точку начала координат.
Например точку с координатами 0,-100,0. Можно
воспользоваться привязкой Endpoint и указать
соответствующую вершину параллелепипеда.

8
Рис. 1.6. Установка новой системы
координат
Origin of new UCS

Внимание! При переносе начала координат в новую точку,


отсчет координат будет производиться от новой точки (0,0).
• 3 point (3 точки) - указание нового начала координат и
точек, определяющих положительное направление осей Х
и У. Направление оси Z определяется автоматически
(рис.1.7).
Выберите в меню команду Tools - NewUCS – 3 Рoint.
Specify new origin point <0,0,0>: 0,100,0
Укажите точку начала координат (1) или с помощью
привязки укажите соответствующую вершину
параллелограмма.
Specify point on positive portion of X-axis <0,0,0>:
Укажите точку, указывающую положительное направление
оси Х (2).
Specify point on positive-Y portion of the UCS XY plane
<0,0,0>:
Укажите точку, указывающую положительное направление
оси Y (3)

Рис. 1.7. Установка системы координат с помощью опции 3 point

• ZAxiz (Zось) - указание нового начала координат и


точки, лежащей на положительном направлении оси Z..

9
• Object (Объект) - установка ПСК по плоскости
двумерного объекта.
На запрос укажите ребро, на котором предполагается
положительное направление оси Х. Начало координат будет
находится в той вершине, ближе к которой указана точка на
грани.
• Face (Грань) - установка ПСК по плоскости грани
трехмерного объекта.
Укажите ребро, на котором предполагается положительного
направления оси Х. Плоскость ХУ расположится строго но
грани параллелепипеда. Однако к указанному ребру
прилегает две грани. Если вас не устраивает данная грань,
задайте опцию N (Next). Плоскость ХУ перейдет на
следующую грань.
• Vew (Вид) - установка ПСК перпендикулярно
направлению взгляда (в плоскости вида), с сохранением
начала координат.
• X - поворот ПСК вокруг текущей оси Х.
• Y - поворот ПСК вокруг текущей оси Y.
• Z - поворот ПСК вокруг текущей оси Z.
Чтобы вернуться в мировую систему координат необходимо
воспользоваться меню Tools<NewUCS>World

1.4. Плоскости построения


Плоскость, в которой строятся двумерные объекты,
называется плоскостью построений. Ее положение
определяется действующей системой координат и уровнем,
т. е. ее смещением вдоль оси Z относительно плоскости XY
текущей системы координат. Удобно анализировать
трехмерные построения в изометрических видах, которые
вполне могут заменить известную нам аксонометрию.
Установим стандартный вид, называемый юго-западная
изометрия. Меню View>3DView> SW_Isometrc
Установите мировую систему координат. Используем
параллелепипед из предыдущего примера. Далее построим
окружность (с помощью команды CIRCLE (КРУГ)) с

10
центром в точке 0,0 и радиусом 50 мм. В результате чего
получим вид, изображенный на рис.1.8.

Рис. 1.8. Определение плоскости построения

В изометрическом виде окружность изображается эллипсом.


Ось Z при этом идет вертикально вверх от точки начала
координат. Изменим уровень окружности.. В меню Modify
выберем пункт Properties . Появится диалоговое окно
Properties (Свойства) (рис.1.9). Отметим окружность.
Выберем характеристику Center Z. В ячейке появится
вертикальный текстовый курсор и значок устройства
указания (его можно использовать, если вы хотите указать
новое значение Z для центра с помощью мыши). Исправьте с
помощью клавиатуры старое значение 0 на 100 и закройте
диалоговое окно Properties. В результате этого изменения
окружность переместилась вверх на 100 мм (рис.1.9).

Рис. 1.9. Изменение плоскости построения

11
Если бы было нужно опустить окружность на 100 мм вниз,
то мы бы задали -100.
Таким образом, в нашем примере плоскостью построений
сначала была основная плоскость XY с уровнем Z=0, а затем
объект был перенесен в новую плоскость (на 100 мм выше по
оси Z).
Для построения объекта на заданном уровне обычно
используют привязку к соответствующей точке уже
существующего объекта. При указании первой точки начала
построения и будет определять уровень построения по оси Z.
Перемещение примитивов можно выполнить, не только
изменяя уровень объекта (для окружности это координата Z
ее центра), но и с помощью известной команды Move.
Для закрепления вышесказанного выполните упражнение.
Установите плоскость XY на передней грани. Меню
Tools>NewUCS>3 point. Постройте диагональ на этой грани.
Используя привязку Midpoint и команду Cilinder на панели
инструментов Soilids постройте стандартный цилиндр
радиусом 50 и высотой 20 с указанием точки центра
цилиндра в центре диагонали (рис.1.10).

Рис. 1.10. Пример построения тел в пользовательских системах


координат

Вывод: Для того, чтобы приступить к построению объекта,


необходимо определить плоскость основания объекта,
перейти необходимую систему координат, определить
уровень построения.
Ниже будут перечислены наиболее часто употребляемые
способы построения тел. Выбор того или иного способа
зависит от формы и сложности объекта.

12
2. ВИДЫ ПРЕДСТАВЛЕНИЯ ОБЪЕКТОВ
НА ЭКРАНЕ
2.1. Управление видами
Мы можем посмотреть на объекты из различных точек
пространства: Сверху (Top ), Снизу (Botton ), Слева (Left ),
Справа (Right) и т.д.. Для этого в меню View выберите
строку 3D Views, а в этой строке соответствующий пункт,
например, SW-Isometrc (Юго-Западная изометрия). Или
указать необходимую пиктограмму на панели инструментов
View (рис.2.1).

Рис. 2.1. Вид панели инструментов View

Управление видом также можно осуществлять командой


3DORBIT, которой соответствуют кнопка 3D Orbit
одноименной панели инструментов и пункт меню View (рис
2.2).

Рис. 2.2. Вид панели инструментов 3D Orbit

Команда позволяет динамически изменять вид


трехмерных объектов с помощью устройства указания. Если
в момент вызова команды в рисунке были выбраны какие-то
объекты, то в дальнейших манипуляциях участвуют только
они. При отсутствии выбранных объектов динамическое
изменение показывает новое положение всех видимых
объектов рисунка (хотя при большом объеме рисунка это
может происходить медленно).

13
Рис. 2.3. Орбитальное кольцо команды 3D
Orbit

В зависимости от места нахождения


курсора относительно орбитального кольца
(внутри, снаружи, на малых кругах), объект
поворачивается вокруг соответствующей оси
(рис.2.3).
Если у вас заданы лимиты чертежа и включен режим
Grid, то вы увидите прямоугольник лимитов в
соответствующей проекции.

2.2. Системная переменная ISOLINES


На криволинейной части цилиндра имеется некоторое
количество образующих. По умолчанию переменная имеет
значение 4, т.е. на цилиндре имеется 4 образующих. При
необходимости это значение регулируется пользователем.
Системная переменная 1SOLINES. вводится в командной
строке
Command: isolines
Enter new value for ISOLINES <4>: 20

Рис. 2.4. Результат изменения системной переменной ISOLINES

На рис.2.4 представлены тела с различными значениями


системной переменной

14
После введения нового значения переменной необходимо
обязательно выполнить пункт Regen (Регенерировать) или
Regen All (Регенерировать все) падающего меню View (Вид).
Пункт Regen All (Регенерировать все) отличается от пункта
Regen (Регенерировать) тем, что если графический экран
разделен на видовые экраны, то регенерируются все экраны,
а не только активный.
В рабочем режиме все стенки цилиндра доступны для
редактирования и прозрачны, чтобы видеть объект
полностью.

2.3. Вид Hide


Теперь воспользуйтесь пунктом Hide (Скрыть) падающего
меню View (Вид) для того, чтобы скрыть невидимые части
цилиндра и убедиться, что стенка цилиндра и оба дна
(основания) являются непрозрачными.

Рис. 2.5. Вид объекта в режиме Hide

На рис.2.5 видно, что верхнее и нижнее основания цилиндра


являются непрозрачными.
Изображение, образовавшееся на графическом экране в
результате скрытия невидимых линий, является нерабочим -
для продолжения редактирования обязательно выполнить
пункт Regen (Регенерировать) или Regen All
(Регенерировать все) меню View (Вид).

2.4. Виды раскрашивания объектов


Для того, чтобы более наглядно рассмотреть объект в
трехмерном пространстве существуют несколько
стандартных представлений раскрашивания объекта.
- Wireframe (Каркас) - изображение объектов в виде
совокупности отрезков и линий, раскрашивание
отсутствует;

15
- Hidden - то же, но линии невидимых граней не
отображаются;
- Flat Shaded - грани раскрашиваются цветом с низкой
плавностью раскраски;
- Gouraud Shaded - то же, но переходы граней
сглаживаются;
- Flat Shaded, Edges On - комбинируются виды Wireframe
и Flat Shaded - линии каркасов просвечиваются.

Рис. 2.5. Изображения объекта в различных видах раскрашивания


соответственно (слева направо) 2DWireframe 3DWireframe Hidden
Flat Shaded Gouraud Shaded Flat Shaded,Edges On

3. ПОСТРОЕНИЕ ТЕЛ
Объекты, которые будут рассмотрены в данном разделе,
называются телами. Эти объекты имеют внутренность и
объем, их можно объединять, вычитать и пересекать как
трехмерные множества.
Тела получаются в результате использования команд
построения стандартных тел (ящиков, конусов, шаров и т.
п.), а также как результат вращения, выдавливания областей.
Тела можно разрезать на части и получать сечения
плоскостями. Над телами возможны операции специального
редактирования.
Для создания в системе AutoCAD твердотельной модели
изделия в начале необходимо мысленно разложить его на
простые стандартные составляющие. Затем путем
логических операций (объединения, вычитания и

16
пересечения) а также операций редактирования создать
объект нужной формы.

3.1. Формирование типовых объемных тел


В панели инструментов Solids (Тела) (рис. 3.1)) собраны
кнопки операций построения тел.

Рис. 3.1. Вид панели инструментов Solids

Первые шесть кнопок этой панели предназначены для


построения твердотельных объектов стандартной формы,
таких как BOX (ПАРАЛЛЕЛЕПИПЕЛ), SPHERE (ШАР),
CYLINDER (ЦИЛИНДР), CONE (КОНУС), WEDGE
(КЛИН) и TORUS (ТОР). Им соответствуют
одноименные команды.
Построение параллелепипеда и цилиндра было
рассмотрено ранее.
При построении сферы необходимо задать точку
центра (center) и для конуса – центр (center),
радиус(radius) и высоту (height). Для клина -
длину и ширину основания и высоту клина. Для
торуса – центр (center), большой радиус
торуса (radius of torus), малый радиус трубы
(radius of tube).
Отвечая на соответствующие вопросы команд
производим построения стандартных тел.

3.2. Построение тела методом выдавливания


Команда EXTRUDE (Выдавить)
Наиболее часто применяемый способ построения тел –
использование команды EXTRUDE, которая находится на
панели инструментов Solids и в меню Draw>Solids>
Extrude.

17
Перед тем как воспользоваться командой, необходимо
построить на предполагаемой плоскости основание будущего
тела. Основание должно быть построено замкнутой
полилинией. В данном примере это будет шестиугольник
(рис.3.2).

Рис. 3.2. Построение замкнутого многоугольника


В случае, если основание получилось в процессе построения
и не образует замкнутую полилинию его необходимо
превратить в замкнутый контур, для этого необходимо
использовать команду BOUNDARY, которая находиться в
меню Draw> Boundary или на панели инструментов Draw.
После выбора команды появляется диалоговое окно

Рис. 3.3. Диалоговое окно команды Boundary

Выберите кнопку Pick Point , после закрытия окна укажите


курсором точку внутри области, вокруг которой необходимо
образовать замкнутую полилинию.
Обозначенный контур выделиться тонкой пунктирной
линией. Нажмите Enter. В результате образуется замкнутая
полилиния на текущем слое.
Основание имеется, переходим к построению тела.
Выбираем комаду EXTRUDE

18
Command: _extrude
Select objects:
Выделить построенный в плоскости объект (Объект должен
быть построен замкнутой полилинией).
Specify height of extrusion or [Path]: 40
Указать высоту (Толшину), на которую должен быть
выдавлен объект.
Specify angle of taper for extrusion <0>:
Указать угол наклона относительно положительного
направления оси Z.
В данном примере угол наклона равен 0.

Рис. 3.4. Пример применения команды


EXTRUDE

В результате получился шестигранник определенной высоты


(рис.3.4).
В основании цилиндра должен быть построен круг,
параллелепипеда – прямоуголник и т.д.

3.3. Построение тел выдавливания


по направляющей
При построении тела путем выдавливания по пути
необходимо иметь два элемента: контур сечения тела и
линию, вдоль которой буде происходить выдавливание
(путь).
Существует ряд правил, по которым выполняется эта
команда
• линия сечения должна быть замкнутым контуром
• путь может быть как замкнутым так и не замкнутым
• линия пути не должна иметь собственное пересечение

19
• линия пути и линия сечения не должны быть
построены в одной плоскости
Для примера создадим параллелепипед, на верхней грани
которого командой PLINE вычертим прямоугольник
(рис.3.5 а)
Перейдем в пользовательскую систему координат, в которой
плоскость XY находится на передней правой грани
параллелепипеда (рис.3.5 б).
В качестве сечения построим окружность и расположим ее
так как указано на рисунке (рис.3.5 в)..

а) б) в)
Рис. 3.5. Построения пути и профиля при выполнении команды
EXTRUDE

Выбираем комаду EXTRUDE


Command: _extrude
Select objects:
Выделить окружность
Specify height of extrusion or [Path]: Р
Вместо указания высоты выдавливания ввести опцию . Р
[Path]
Select extrusion path or [Taper angle]:
Указать линию пути
Просмотреть тело в затененном виде (рис.3.6).

20
Рис. 3.6. Результат построения тела выдавливанием вдоль пути

Конфигурация сечения и пути может быть самой различной


для моделирования архитектурных форм и предметов
интерьера .
Для формирования пути также может быть использована
трехмерная полилиния, которая состоит из связанных
прямолинейных сегментов, вершины которых могут иметь
любые координаты трехмерного пространства.
Команда 3DPOLY находится в меню Draw>3D Polyline

3.4. Построение тел методом вращения Команда


REVOLVE (Вращать)
Команду REVOLVE будем изучать на классическом
примере рисования кувшина
Для построения тела вращения необходимо вычертить
профиль фигуры. Так как и в предыдущей команде профиль
должен быть отрисован замкнутой полилинией.
Для примера используем классический пример построения
кувшина.
Командой Polyline рисуем предполагаемый профиль
кувшина (рис.3.7.а). Так как кувшин имеет сглаженные
формы, применяем команду Fillet для сглаживания
необходимых углов (рис.3.7.б).
Стенки имеют определенную толщину, поэтому командой
Offset строим подобную линию на заданном расстоянии
(рис.3.7.в).

21
Командой Line замыкаем верхнюю и нижнюю часть
параллельных полилиний и командой Boundary создаем
замкнутую полилинию, которая будет определять профиль
заданной толщины (рис.3.7).

а) б) в)
Рис. 3.7. Пример построения профиля тела вращения
Для построения тела вращения используем команду
RVOLVE, которая находится на панели инструментов Solids
или в меню Draw>Solids>Revolve.
Command: _revolve
Select objects:
Выделить контур профиля
Specify start point for axis of revolution or
define axis by [Object/X (axis)/Y (axis)]:
Указать первую точку на оси вращения , в даном случае это
левая нижняя точка
Specify endpoint of axis:
Указать вторую точку на оси. В нашем примере включить
режим ORTO и указать точку в пространстве, находящуюся
выше первой на условной вертикальной оси вращения.
Specify angle of revolution <360>:
Нажать Enter, так как наше тело образовано вращением на
360 градусов (рис.3.8).

22
Рис. 3.8. Результат применения команды Revolve

Просмотреть фигуру в виде SW Isomrtric в затененном


режиме.
Повернуть фигуру так, чтобы основание находилось на
плоскости XY. Используем команду Rotate 3D, которая
находится в меню Modify>3D Operation>Rotate3D.
Вернуться в режим ТОР.
Command: _rotate3d
Select objects: Выделить объект
Specify first point on axis or define axis
by[Object/Last/View/Xaxis/Yaxis/Zaxis/2points]: x
Указать ось, вокруг которой будет вращение
Specify a point on the X axis <0,0,0>:
Указать точку, через которую проходит ось
Specify rotation angle or [Reference]: 90
Вести угол поворота.
Снова посмотреть в в виде SW Isomrtric (рис.3.9)

Рис. 3.9. Поворот тела вокруг оси

23
3.5.Создание сложных тел с помощью
булевых операций
3.5.1.Объединение тел
Операцию объединения можно найти в меню
Modify>Solids Editing>Union или на панели
инструментов Solids Editing
Command: _union
Select objects: 1 found
Выделить первый объект для объединения
Select objects: 1 found, 2 total
Выделить второй объект
Select objects:
Выделить третий объект если это необходимо или нажать
Enter для завершения команды ( рис.3.10).

Рис. 3.10 Тела до и после объединения

3.5.2.Вычитание тел
Операцию вычитания можно найти в меню
Modify>Solids Editing>Subtract или на панели
инструментов Solids Editing
Command: _subtract Select solids and regions to subtract
from ..
Select objects:
Выделить объект, из которого происходит вычитание.
Select objects:
Выделить второй объект из которого происходит вычитание
если имеется второй объект участвующий в операции или
нажать Enter для продолжения операции
Select solids and regions to subtract ..
Select objects:

24
Выделить объект, который необходимо вычесть из первого
Select objects:
Выделить второй вычитаемый объект если имеется второй
объект участвующий в операции или нажать Enter для
окончания команды (рис.3.11)

Рис. 3.11. Тела до и после вычитания

3.5.3. Пересечение тел


Операцию вычитания можно найти в меню
Modify>Solids Editing>Intersect или на панели
инструментов Solids Editing
Операция позволяет создать тело, занимающее общий объем
двух или более тел.
На запросы команды Select Object: последовательно
выделить два или несколько объектов и нажать Enter для
завершения команды (рис.3.12).

Рис. 3.12. Тела до и после выполнения команды пересечения

25
3.6. Разрез. Команда Slice
Рассмотрим эту команду на примере тела полученного в
результате вычитания (рис.3.13а). С помощью команды UCS
перейдите в мировую систему координат World. Щелкните
мышью по кнопке Slice на панели инструментов Solids и
на запрос об объектах выберите данное тело. Следующий
запрос:
Specify first point on slicing plane by
[Objecl/Zaxis/View/XY/YZ/ZX/3points] <3points>:): YZ
Нам необходимо разрезать тело плоскостью YZ, проходящей
через среднюю точку левой передней грани. Для этого в
командной строке введем опцию YZ.
Нажмите клавишу <Enter>, подтверждая выбор плоскости
Specify a point on the YZ-plane <0,0,0>:
С привязкой Midpoint укажите среднюю точку на нижнем
ребре передней грани
Specify a point on desired side of the plane or [keep Both
sides]:
Укажите точку на той части объекта, которую необходимо
оставить (рис.3.13. б)

а) б) в)
Рис. 3.13. Пример применения команды Slice

Если выберите опцию [keep Both sides] (Обе стороны), труба


разделится на два тела. Отодвиньте одно тело влево.
Результат проделанных операций приведен на рис.3.13 в.

26
3.7. Сечение. Команда Section
Команда SECTION которой соответствует кнопка Section
панели инструментов Solids, строит сечение тела,
образуя в результате линии сечения, которые можно затем
вынести и использовать в чертеже.
Рассмотрим сечение на примере построения
сечения конуса на определенной высоте.
Построим конус радиусом 50 , высотой 70.
Наша задача состоит в том, чтобы определить
радиус конуса на высоте 40
В основании конуса построим диаметр, и
командой Move передвинем его на высоту 40
для того, чтобы определить точку, через
которую будет проходить плоскость сечения.
Выбираем команду кнопка Section панели
инструментов Solids,
Команда выполняется аналогично команде SLICE
(см.выше). При этом образуется линия сечения
на указанном уровне. Далее определяем радиус
полученного сечения. Сечение может
использоваться для дальнейших построений
(рис.3.12).

Рис. 3.12. Пример применения команды Section

27
4.МОДИФИЦИРОВАНИЕ ОБЪЕКТОВ В
ТРЕХМЕРНОМ ПРОСТРАНСТВЕ
3.1.Команды редактирования
твердотельных моделей
Для операций специального редактирования тел есть
еще одна панель инструментов - Редактирование тел (Solids
Editing) (рис.4.1)

Рис. 4.1. Панель Solids Editing (Редактирование тел)


Первые три кнопки соответствуют операциям объединения,
вычитания и пересечения тел и уже были рассмотрены выше.
Далее кратко перечислим функции остальных кнопок:
• Extrude Faces (Выдавить грани) - выдавливание граней
тела на заданную глубину или вдоль траектории;
• Move Faces (Перенести грани) - перенос граней тела на
заданное расстояние;
• Offset Faces (Сместить грани) - равномерное смещение
граней на заданное расстояние или до указанной
точки;
• Delete Faces (Удалить грани) - удаление граней тела
вместе с сопряжениями и фасками;
• Rotate Faces (Повернуть грани) - поворот граней вокруг
заданной оси;
• Taper Faces (Свести грани на конус) - сведение граней на
конус под заданным углом;
• Copy Faces (Копировать грани) - создание копий граней
тела в виде областей или твердотельных оболочек;
• Color Faces (Изменить цвет граней) - изменение цвета
отдельных граней;
• Copy Edges (Копировать ребра) - создание копий ребер
тела;

28
• Color Edges (Изменить цвет ребер) - изменение цвета
ребер;
• Imprint (Клеймить) - создание клейма на грани;
• Clean (Упростить) - удаление лишних ребер и вершин;
• Separate (Разделить) - разделение многосвязных тел
(занимающих несколько замкнутых объемов в
пространстве) на отдельные тела;
• Shell (Оболочка) - создание полой тонкостенной оболочки
заданной толщины;
• Check (Проверить) - проверка, является ли объект
допустимым телом.
Все эти кнопки потребуют значительных вычислительных
ресурсов вашего компьютера и в первую очередь,
оперативной памяти.
Рассмотрим работу команды SOLIDEDIT с
использований некоторых опций.

4.1.1. Extrude Faces (Выдавить грани)


Построим параллелепипед размером 50х30х30.
Применим операцию для увеличения высоты
параллелепипеда.
Выбрать пиктограмму Extrude Faces на панели инструментов.
Command: _solidedit
Select faces or [Undo/Remove]:
Указать на грань, которую необходимо выдавить. Укажите
верхнюю грань на ребре (рис.4.2 а). Так как указанное ребро
примыкает к двум граням, выделится сразу две. необходимо
снять выделение со второй грани, которая не редактируется.
Select faces or [Undo/Remove/ALL]: r
Необходимо снять выделение со второй грани, которая не
редактируется. Введите опцию Remove.
Remove faces or [Undo/Add/ALL]:
Указать вторую грань для снятия выделения (рис.4.2 б)
Remove faces or [Undo/Add/ALL]:

29
Команда предлагает другие опции для снятия или
добавления выделения. Если не желаете их использовать,
нажать Enter
Specify height of extrusion or [Path]: 20
Указать высоту выдавливания верхней грани 20
Specify angle of taper for extrusion <0>:
Указать угол среза. При отсутствии – нажать Enter
Enter a face editing option
[Eхtrude/Move/Rotate/Offset/Taper/Delete/Copy/coLor/
Undo/eXit] <eXit>:
При отсутствии дальнейшего редактирования грани нажать
еще раз ENTER для выхода из команды (рис.4.2 в).

а) б) в)
Рис. 4.2. Пример выполнения опции Extrude Faces команды
SOLIDEDIT

4.1.2.Rotate Faces (Повернуть грани)


Построить параллелепипед аналогичный
предыдущему примеру. Выбрать опцию Rotate
Faces
Command: _solidedit
Select faces or [Undo/Remove]:
Выбрать необходимую грань с использованием
опции Remove (см. предыдущий пример).
На вопрос команды
Specify an axis point or [Axis by
object/View/Xaxis/Yaxis/Zaxis] <2points>:
Выбрать первую точку на оси, вокруг которой
предполагается вращение
Specify the second point on the rotation axis:

30
Выбрать вторую точку на оси, вокруг которой
предполагается вращение
Specify a rotation angle or [Reference]: 25
Ввести угол вращения грани

Рис. 4.2. Пример выполнения опции Rotate Faces команды


SOLIDEDIT

4.1.3. Separate (Разделить)


Предположим, что в результате вычитания или
других операций получилось два замкнутых
тела связанных друг с другом. Для дальнейшего
построения необходимо, чтобы эти тела стали
независимы друг от друга. В этом случае
применяется операция Separate.
На рисунке 4.3а представлено тело получившееся в
результате вычитания цилиндра из параллелепипеда.
Визуально объект состоит из двух частей. Однако при
преобразовании и редактировании он имеет свойства
единого целого. Для разделения его на две части необходимо
применить операцию SEPARATE.

а) б)

31
Рис. 4.3. Применение опции SEPARATE команды SOLIDEDIT

Выбрать опцию SEPARATE в меню или на панели


инструментов. После запроса команды
Select a 3D solid:
Выбрать редактируемый объект и нажать ENTER. Тело
разделится на два независимых, которые можно двигать,
поворачивать и т.д. (рис.4.3)

4.2. Скругление граней, снятие фасок


Скругление граней и снятие фасок выполняется командами
FILLET, CHAMFER , аналогично тем, которые
применяются в двухмерном черчении.
Команды находятся на панели инструментов Modify или в
одноименном меню.
Для примера используем две стандартные фигуры куб и
цилиндр.
Для куба (рис.4.4а) применим команду CHAMFER
Command: _chamfer
(TRIM mode) Current chamfer Dist1 = 0.0000,
Dist2 = 0.0000
Select first line or
[Undo/Polyline/Distance/Angle/Trim/
mEthod/Multiple]:
Выделить редактируемую грань (указать ребро
грани)
Base surface selection...
Enter surface selection option [Next/OK
(current)] <OK>: n
Если выделилась не та гранъ, которую
необходимо редактировать (так как к
выделенному ребру примыкают две грани)
необходимо воспользоваться опцией Next
Enter surface selection option [Next/OK
(current)] <OK>:
Нажать ENTER
Specify base surface chamfer distance: 10

32
Ввести число, определяющую глубину среза на
базовой поверхности
Specify other surface chamfer distance
<10.0000>:
Ввести число, определяющую глубину среза на
примыкающей поверхности
Если эти значения совпадают нажать ENTER
Select an edge or [Loop]: l
Выделить отдельно ребра для среза. Или
применить опцию Loop для одновременного
среза всех ребер базовой поверхности.
Select an edge loop or [Edge]: Select an edge
loop or [Edge]:

Рис. 4.4. Применение команды CHAMFER

Для цилиндра применим команду FILLET


Command: _fillet
Current settings: Mode = TRIM, Radius =
0.0000
Select first object or
[Undo/Polyline/Radius/Trim/Multiple]:
Выделить верхнюю грань цилиндра.
Enter fillet radius: 20
Ввести радиус скругления
Select an edge or [Chain/Radius]:
Так как выделение грани уже существует можно
нажать ENTER

33
Рис. 4.5. Применение команды FILLET

4.3. Зеркальное отображение объектов


MIRROR3d
Команда находиться в меню Modify>3D
Operation>Mirror 3D
Применим команду для зеркального отражения
половины цилиндра относительно плоскости ZX
Command: _mirror3d
Select objects: 1 found
Select objects:
Выделить исходный объект (4.6 а)
Specify first point of mirror plane (3 points)
or
[Object/Last/Zaxis/View/XY/YZ/ZX/3points]
<3points>: yz
Ввести плоскость, через которую будет
зеркально отражен объект
Specify point on YZ plane <0,0,0>:
Указать точку, через которую будет проходить
эта плоскость
Delete source objects? [Yes/No] <N>:
Если необходимо удалить исходный объект,
ввести опцию Yes, если нет – No (рис.4.6 б).

34
а) б)
Рис. 4.6. Применение команды MIRROR3d

4.4. Трехмерный массив 3D Array


Команда находиться в меню Modify>3D
Operation>Mirror 3D
Построим конус радиусом 30 и высотой 50

Рис. 4.7. Построение исходного объекта Конус

Построим массив из данного элемента


Command: _3darray
Select objects:
Выделить объект
Enter the type of array [Rectangular/Polar]
<R>:r
Вести тип массива прямоугольный (Rectangular)
или круговой (Polar)
Enter the number of rows (---) <1>: 5
Вести количество строк
Enter the number of columns (|||) <1>: 3
Ввести количество столбцов
Enter the number of levels (...) <1>: 2
Ввести количество уровней (отличие от
двухмерного массива)
Specify the distance between rows (---): 100
Ввести расстояние между строчками

35
Specify the distance between columns (|||):
200
Ввести расстояние между столбцами
Specify the distance between levels (...): 100
Ввести расстояние между уровнями
На рисунке 4.8 представлены виды сверху и
спереди трехмерного массива

Рис. 4.8. Применение команды 3D Array

4.5. Поворот объектов. Rotate 3D


Команда находиться в меню Modify>3D
Operation> Rotate 3D
Поворот объекта был рассмотрен в разделе 3.4.

4.6.Выравнивание объектов Align


Команда находиться в меню Modify>3D
Operation> Align
Допустим, что имеется два куба со сторонами
100 и 50 произвольно повернутых относительно
друг друга. Необходимо расположить меньший
куб в левом нижнем углу верхней грани.
Command: _align
Select objects: 1 found
Select objects:
Выделить объект, который необходимо
переместить. В данном примере это меньший
куб.
Specify first source point:
Указать точку 1 на меньшем кубе.
Specify first destination point:

36
Указать точку 1 на большем к кубе
Specify second source point:
Указать точку 2 на меньшем кубе.
Specify second destination point:
Указать точку 2 на большем к кубе.
Specify third source point or <continue>:
Указать точку 3 на меньшем кубе.
Specify third destination point:
Указать точку 3 на большем к кубе.
Последовательность и результат
преобразований указан на рис.4.9.

Рис. 4.9. Пример выполнения команды ALIGN


Команды Move (Перемещение), Copy
(Копирование), Erase (Удаление), Scale
(Масштабирование) выполняются аналогично
командам в двухмерном черчении

37
Содержание
1. РАБОТА С СИСТЕМАМИ КООРДИНАТ В
ТРЕХМЕРНЫХ МОДЕЛЯХ....................................................4
1.1.Двумерные и трехмерные системы координат........................4
1.2. Настройка пиктограммы UCS.................................................6
1.3. Пользовательские системы координат ...................................7
1.4. Плоскости построения ..........................................................10
2. ВИДЫ ПРЕДСТАВЛЕНИЯ ОБЪЕКТОВ.......................13
НА ЭКРАНЕ.............................................................................13
2.1. Управление видами................................................................13
2.2. Системная переменная ISOLINES........................................14
2.4. Виды раскрашивания объектов............................................15
3. ПОСТРОЕНИЕ ТЕЛ...........................................................16
3.1. Формирование типовых объемных тел.................................17
3.2. Построение тела методом выдавливания.............................17
3.3. Построение тел выдавливания .............................................19
3.4. Построение тел методом вращения Команда ......................21
REVOLVE (Вращать)...................................................................21
3.5.Создание сложных тел с помощью .......................................24
булевых операций.........................................................................24
3.5.1.Объединение тел............................................................................24
3.5.2.Вычитание тел................................................................................24
3.5.3. Пересечение тел............................................................................25
3.6. Разрез. Команда Slice.............................................................26
3.7. Сечение. Команда Section......................................................27
4.МОДИФИЦИРОВАНИЕ ОБЪЕКТОВ В
ТРЕХМЕРНОМ ПРОСТРАНСТВЕ.....................................28
3.1. Команды редактирования ......................................................28
твердотельных моделей................................................................28
4.1.1. Extrude Faces (Выдавить грани)...................................................29
4.1.2.Rotate Faces (Повернуть грани)....................................................30
4.1.3. Separate (Разделить)......................................................................31
4.2. Скругление граней, снятие фасок.........................................32
4.4. Трехмерный массив 3D Array...............................................35
4.5. Поворот объектов. Rotate 3D.................................................36
4.6.Выравнивание объектов Align................................................36

Технический Университет Молдовы

38
МАШИННАЯ ГРАФИКА

Auto CAD. 3D моделирование

Учебное пособие

Кишинэу
2007

39