Вы находитесь на странице: 1из 6

Рехтер Александр Дантонович, ТОО “Альбион”, тел.(0852) 27-45-51 E-mail rad@ymz.yaroslavl.

ru

Оптимизация упрощенной конструкции шатуна с помощью ANSYS 5.4

1. ЦЕЛЬ РАСЧЕТА.
Подбор оптимального соотношения размеров упрощенной
модели шатуна, обеспечивающих снижение
эквивалентных напряжений при минимальном весе
конструкции.

2. ОПИСАНИЕ КОНЕЧНО-ЭЛЕМЕНТНОЙ МОДЕЛИ


(КЭМ).
Вследствие симметрии рассматривается только половина
конструкции. С точки зрения геометрии модель включает
нижнюю и верхнюю головку в виде полуколец,
соединенных ребром толщиной T3 и стенкой толщиной
T4. Кроме параметров толщин T3 и T4 модель шатуна (см.
рис.1) включает еще 6 конструкторских параметров (DS1,
DS2, AL11, DAL1, AL21, DAL2), которые в процессе
оптимизации варьируются в пределах заданных
ограничений.
Моделируется нагружение от действия на шатун газовой
силы. Для упрощения принимается, что на нижнюю и
верхнюю головку действует равномерное давление в
пределах дуги 60°. Давления подобраны так чтобы
суммарная нагрузка, действующая на верхнюю головку,
была равна суммарной силе, действующей на нижнюю
головку. Закрепление узлов в направлении оси X
обеспечивает условие симметрии. Один из узлов
закрепляется в направлении оси Y для компенсации
небольшой разницы в суммарных нагрузках, действующих
на нижнюю и верхнюю головку.
КЭМ рассчитывает плоско-напряженное состояние
модели шатуна. Она состоит из 280 элементов типа
PLANE42. Использовалась регулярная схема разбиения.
Материал модели сталь с коэффициентом Юнга 20 000
кг/кв.мм и коэффициентом Пуассона – 0,28. Ниже все
размеры определены в мм. Давление в кг/кв.мм.

3. ОПИСАНИЕ МЕТОДА ОПТИМИЗАЦИИ.


Основным вопросом оптимизации является ориентация
ребра жесткости и толщина перемычки между ребрами Не
все методы оптимизации дают одинаково хорошие
результаты. В данном случае наилучшие результаты дал метод первого порядка FIRST. В тексте пакетного
файла заданы ограничения на параметры конструкции и переменную состояния. В качестве переменной
состояния использовалось эквивалентное напряжение, соответствующее критерию Мизеса. Минимизируемой
объектной переменной являлся вес конструкции. Расчет проводился с помощью Ansys 5.4/ED.

Представительство CAD FEM GmbH в СНГ: 107497 Москва, Щелковское шоссе, 77, офис 1703 1
Тел.: (095) 468-8175 Тел.\факс: (095) 913-2300 e-mail: cadfem@online.ru http://www.cadfem.ru
Рехтер Александр Дантонович, ТОО “Альбион”, тел.(0852) 27-45-51 E-mail rad@ymz.yaroslavl.ru

4. ЭТАПЫ РЕШЕНИЯ ЗАДАЧИ. AL21=105


Подготовка модели DAL2=10
1. Заголовок задачи Для упрощения последующей записи далее
2. Инициализация параметров для построения вводятся соотношения.
геометрии модели. AL12=AL11+DAL1
3. Выбор типа расчета AL22=AL21+DAL2
4. Выбор типа и параметров элементов. 2.2 Close
5. Определение свойств материала. 3. Выбор типа расчета: M_M:Preprocessor ⇒
6. Задание констант. Loads ⇒ New Analysis. Включаем кнопку
7. Построение верхней головки шатуна. Static и затем OK.
8. Построение нижней головки. 4. Выбор типа и параметров элементов:
9. Построение ребра. M_M:Preprocessor ⇒ Element Type ⇒
10. Формирование областей. Add/Edit/Delete.
11. Определение параметров разбиения. 4.1. Add (добавить новый тип элемента)
12. Разбиение модели. 4.2. Выберите Quad 4 node 42 (PLANE 42)
13. Закрепление узлов. 4.3. OK
14. Приложение давления к нижней головке. 4.4. Options (параметры элемента)
15. Приложение давления к верхней головке 4.5. В списке K3 смените тип анализа с Plane
stress на Plane stress w/thk
Расчет. (плосконапряженное состояние с учетом
16. Решение модели с заданными граничными толщины элемента)
условиями. 4.6. OK
Постпроцессор 4.7. Нажмите Close в предыдущем окне.
17. Определение суммарного объема модели; 5. Определение свойств материала:
18. Определение максимального эквивалентного M_M:Preprocessor ⇒ Material Props ⇒
напряжения. Isotropic.
Оптимизация модели 5.1. Ввести номер набора свойств материала 1
19. Задание геометрических параметров. и нажмите OK
20. Задание переменной состояния. 5.2. Задайте модуль Юнга в поле EX 20 000
21. Задание целевой функции. 5.3. Задать коэффициент Пуассона в поле
22. Задание метода оптимизации. NUXY 0.28. Нажмите OK
23. Назначение рабочего файла . 6. Задание констант:
24. Запуск процесса оптимизации. M_M:Preprocessor ⇒ Real Constant ⇒
25. Анализ полученных результатов. Add/Edit/Delete.
Далее в тексте кнопки, клавиши, пункты меню 6.1. Add (добавить набор констант)
и выбираемые строки в списках Ansys показаны 6.2. OK (в окне выбора типа
жирным шрифтом, вводимые с клавиатуры элемента)Выберите PLANE 42
величины даны курсивом 6.3. Вводим номер набора свойств 1 и
толщину элементов 30 для данного набора
7. ПРОТОКОЛ РЕШЕНИЯ. 6.4. Apply
Подготовка модели. 6.5. Соответственно вводим номер набора 2 и
толщину 30
1. Заголовок задачи. U_M: File ⇒ Change Title 6.6 Apply
1.1. Наберите заголовок «Piston rod 6.7 Вводим номер набора 3 и толщину T3
optimization.» 6.8 Apply
1.2. ОК 6.9 Вводим номер набора 4 и толщину T4
2. Инициализация параметров для построения 6.10 OK
геометрии модели. 6.11 Close
U_M: Parameters ⇒ Scalar Parameters
2.1. В появившемся окне ввести имена и 7. Построение верхней головки шатуна:
значения переменных (после набора одной 7.1. Создание точки в центре головки:
переменной – Enter). M_M:Preprocessor ⇒ Create ⇒ Keypoints
DS1=10 ⇒ In Active CS
DS2=10 7.2. Ввести в поле NPT номер точки 1, в поле
T3=30 X, Y, Z координаты 0,0,0.
T4=7 7.3. OK
AL11=235 7.4.Перейти к цилиндрической системе
DAL1=10 координат с центром в точке 0,0,0:

Представительство CAD FEM GmbH в СНГ: 107497 Москва, Щелковское шоссе, 77, офис 1703 2
Тел.: (095) 468-8175 Тел.\факс: (095) 913-2300 e-mail: cadfem@online.ru http://www.cadfem.ru
Рехтер Александр Дантонович, ТОО “Альбион”, тел.(0852) 27-45-51 E-mail rad@ymz.yaroslavl.ru
U_M:Work Plane ⇒ Change Active CS to ⇒
Global Cylindrical Первая координата – радиус точки, вторая
7.5 Ввод координат опорных точек: – угол. После каждого ввода нажмите
M_M:Preprocessor ⇒ Create ⇒ Keypoints Apply, после последнего ОК.
⇒ In Active CS.Последовательно ввести в 10 0,0; Apply
диалоговом окне номер точки и ее 11 45,90; Apply
координаты в текущей цилиндрической 12 45,180; Apply
системе координат. Первая координата – 13 45,270; Apply
радиус точки, вторая – угол. После каждого 14 45+DS2,90; Apply
ввода нажмите Apply, после последнего 15 45+DS2,AL21; Apply
ОК. 16 45+DS2,AL22; Apply
2 25,90; Apply 17 45+DS2,180; Apply
3 25,180; Apply 18 45+DS2,270. OK
4 25,270; Apply 8.4 Формирование дуг: M_M:Preprocessor ⇒
5 25+DS1,90; Apply Create ⇒ Arcs ⇒ By End KPs & Rad
6 25+DS1,180; Apply Укажите курсором конечные точки дуги и
7 25+DS1,AL11; Apply нажмите OK, затем точку центра дуги и
8 25+DS1,AL12; Apply ОК, в последнем окне ввести радиус дуги и
9 25+DS1,270. OK Apply. Последовательно для каждой дуги
7.6 Формирование дуг:: M_M:Preprocessor ⇒ укажите:
Create ⇒ Arcs ⇒ By End KPs & Rad 11,12 (кон. т.) 10 (т. ц.) 45 (рад.) Apply
Укажите курсором конечные точки дуги и 12,13 10 45 Apply
нажмите OK, затем точку центра дуги и 14,15 10 45+DS2 Apply
ОК, в последнем окне ввести радиус дуги и 15,16 10 45+DS2 Apply
Apply. Последовательно для каждой дуги 16,17 10 45+DS2 Apply
укажите: 17,18 10 45+DS2 OK
3,2 (кон. т.) 1 (т. центра) 25 (радиус) 8.5 Формирование прямых линий:
3,4 1 25 M_M:Preprocessor ⇒ Create ⇒ Lines
6,5 1 25+DS1 ⇒Straight Line. Последовательно для
6,7 1 25+DS1 каждой линии укажите курсором
7,8 1 25+DS1 начальную и конечную точки.
8,9 1 25+DS1 11 (нач. т.), 14 (кон. т.)
OK 13, 18 OK
7.7 Формирование прямых линий: 9. Построение ребра:
M_M:Preprocessor ⇒ Create ⇒ Lines M_M:Preprocessor ⇒ Create ⇒ Lines
⇒Straight Line. Последовательно для ⇒Straight Line. Последовательно для каждой
каждой линии укажите курсором линии укажите курсором начальную и
начальную и конечную точки. конечную точки.
2 (нач. т.), 5 (кон. т.) 7 (нач. т.), 16 (кон. т.)
4, 9 OK 8, 15
8. Построение нижней головки шатуна: 9, 14 OK
8.1 Перейти к новой цилиндрической системе 10. Формирование областей:
координат с началом в центре нижней M_M:Preprocessor ⇒ Create ⇒ Arbitrary ⇒
головки:: U_M:Work Plane ⇒ Local By Lines. Последовательно укажите курсором
Coordinate Systems ⇒ Create Local CS. ⇒ для каждой области образующие ее линии. :
At Specified Loc. В окне ANSYS Input L1, L2, L8, L6, L5, L4, L3, L7 Apply
ввести координаты начала новой системы в L9, L10, L16, L14, L13, L12, L11, L15 Apply
глобальной системе 0,-250,0. OK. В L5, L17, L12, L18 Apply
следующем диалоговом окне ввести в поле L11, L18, L6, L19 OK.
KCN (номер системы) - 11, а в поле KCS 11. Определение параметров разбиения.:
(тип системы) выбрать Cylindrical. OK. M_M:Preprocessor ⇒ Size Cntrls ⇒ Picked
8.2. Устанавливаем новую систему координат Lines. Последовательно указывайте на экране
текущей:: U_M:Work Plane ⇒ Change по одной линии и затем OK. В следующем
Active CS to ⇒ Specified Coord Sys. В поле диалоговом окне задайте параметры NDIV
KCN вводим 11. OK. (число делений) и SPACE ( сгущение) . Знак
8.3. Ввод координат опорных точек: минус для SPACE указывает на сгущение к
M_M:Preprocessor ⇒ Create ⇒ Keypoints концу линии, плюс – к началу.
⇒ In Active CS. Последовательно ввести в L5 NDIV = 3 SPACE = 1 Apply
диалоговом окне номер точки и ее L6 NDIV = 3 SPACE = 1 Apply
координаты в текущей цилиндрической
системе координат.

Представительство CAD FEM GmbH в СНГ: 107497 Москва, Щелковское шоссе, 77, офис 1703 3
Тел.: (095) 468-8175 Тел.\факс: (095) 913-2300 e-mail: cadfem@online.ru http://www.cadfem.ru
Рехтер Александр Дантонович, ТОО “Альбион”, тел.(0852) 27-45-51 E-mail rad@ymz.yaroslavl.ru
13.1 Выбор линий для закрепления узлов в
L15 NDIV = 4 SPACE = 1 Apply направлении оси X. U_M:Select ⇒ Entities
L8 NDIV = 4 SPACE = 1 Apply В верхнем списке диалогового окна
L18 NDIV = 12 SPACE = 1 Apply выберите тип примитива Lines, в нижнем
L4 NDIV = 8, SPACE = -2 Apply списке укажите способ выбора By
L3 NDIV = 8, SPACE = 2 Apply Num/Pick и нажмите OK. Укажите
L13 NDIV = 12, SPACE = 2 Apply курсором L7, L8, L15, L16, L19 и нажмите
L14 NDIV = 12, SPACE = 2 Apply OK.
L9 NDIV = 18, SPACE = 2 Apply 13.2 Привязка узлов к выбранным линиям.
L10 NDIV = 12, SPACE = 2 OK U_M:Select ⇒ Entities . В верхнем списке
12. Разбиение модели. диалогового окна выберите тип примитива
12.1 Для генерации регулярной элементной Nodes, в нижнем – Attached to и включите
сетки разбиваемые области должны переключатель Lines, all. Нажмите OK.
включать не более 4 линий. Поскольку 13.3. Задание направления закрепления для
(см. п. 10) первая и вторая область выбранных узлов. M_M: Preprocessor ⇒
включали более 4 линий необходимо Loads ⇒ Apply ⇒ Displacement ⇒ On
провести их слияние (конкатенацию). Nodes. Нажмите Pick All, в следующем
M_M: Preprocessor ⇒ Concatenate ⇒ окне выберите направление закрепления
Lines. Последовательно укажите курсором UX и нажмите OK
объединяемые линии и нажимайте 13.4. Возврат в набор всех линий модели..
клавишу Apply, для последней линии ОК. U_M:Select ⇒ Entities . В верхнем списке
L3, L4, L5, L6 Apply выберите тип примитива Lines, в нижнем
L1, L2 Apply способ выбора By Num/Pick, кнопка Full
L11, L12, L13, L14 Apply должна быть включена и затем OK. В
L9, L10 OK. следующем окне нажмите Pick All.
12.2. Задание признака регулярного разбиения. 13.5. Возврат в набор всех узлов модели..
M_M: Preprocessor ⇒ Mesher Opts U_M:Select ⇒ Entities . В верхнем списке
В диалоговом окне включите выберите тип примитива Nodes, в нижнем
переключатель Mapped и нажмите OK. В способ выбора By Num/Pick, кнопка Full
следующем диалоговом окне выберите из должна быть включена и затем OK. В
списка 2D Shape строку Quad следующем окне нажмите Pick All.
(четырехугольный элемент) и нажмите OK. 13.6. Закрепление одного из узлов в
12.3. Задание набора констант для первой направлении оси Y.. M_M: Preprocessor ⇒
области.
Loads ⇒ Apply ⇒ Displacement ⇒ On
. M_M: Preprocessor ⇒ Create ⇒ Elements Nodes. Выберите курсором один из узлов
⇒ Elem Atributes на стержне шатуна и затем OK. В
В диалоговом окне из списка REAL следующем окне задайте направление
выберите 1 и нажмите OK. закрепления UY и нажмите OK
12.4. Разбиение первой области. 14. Приложение давления к нижней головке .
M_M: Preprocessor ⇒ Mesh ⇒ Mapped ⇒ 14.1 Выбор узлов лежащих на дуге радиуса 45
3 or 4 sided. Затем укажите курсором
мм в пределах изменения угла от 90° до
первую область и нажмите OK.
12.5. Задание набора констант для второй 150°. U_M:Select ⇒ Entities. В верхнем
области.Aналогично п.12.3 с указанием списке выберите тип примитива Nodes , в
параметра REAL = 2. нижнем способ выбора By Location.
12.6. Разбиение второй области. Включите кнопку From Full.и X. В поле
Аналогично п. 12.4 c указанием второй ввода MIN, MAX введите радиус
области. размещения узлов 45 и нажмите Apply.
12.7. Задание набора констант для третьей Включите кнопку Reselect и Y. В поле
области.Aналогично п.12.3 с указанием MIN, MAX введите 90, 150 и нажмите OK.
параметра REAL = 3. 14.2. Задание величины давления. M_M:
12.8. Разбиение третьей области. Preprocessor ⇒ Loads ⇒ Apply ⇒
Аналогично п. 12.4 c указанием третьей Pressure ⇒ On Nodes. Нажмите Pick All и
области. в следующем окне введите в поле Value
12.9. Задание набора констант для четвертой 4.95 и нажмите OK
области.Aналогично п.12.3 с указанием 14.3. .Возврат в набор всех узлов модели..
параметра REAL = 4. U_M:Select ⇒ Entities . В верхнем списке
12.10. Разбиение четвертой области. выберите тип примитива Nodes, в нижнем
Аналогично п. 12.4 c указанием четвертой By Num/Pick, кнопка Full должна быть
области. включена, и нажмите OK. В следующем
13. Закрепление узлов. окне нажмите Pick All.

Представительство CAD FEM GmbH в СНГ: 107497 Москва, Щелковское шоссе, 77, офис 1703 4
Тел.: (095) 468-8175 Тел.\факс: (095) 913-2300 e-mail: cadfem@online.ru http://www.cadfem.ru
Рехтер Александр Дантонович, ТОО “Альбион”, тел.(0852) 27-45-51 E-mail rad@ymz.yaroslavl.ru
SEQV и нажмите OK. Закройте
15. Приложение давления к верхней головке предыдущее окно нажатием на Close.
15.1. Активизация глобальной 18.2 Сортировка напряжений. M_M:General
цилиндрической системы координат. Postproc ⇒ List Results ⇒ Sort Elems.
(начало координат в центре верхней Введите имя сортируемой таблицы S_EQV
головки). U_M:Work Plane ⇒ Change и нажмите OK.
Active CS to ⇒ Global Cylindrical 18.3 Присвоение переменной S_EQVMAX
15.2 Выбор узлов лежащих на дуге радиуса 25 максимального значения эквивалентных
в пределах изменения угла от 210° до 270°. напряжений. U_M:Parameters ⇒ Get
U_M:Select ⇒ Entities. В верхнем списке Scalar Data. В левом списке диалогового
выберите тип примитива Nodes , в нижнем окна выбрать строку Results data, в
способ выбора By Location. Включите правом – Other operations и нажмите OK.
кнопку From Full.и X. В поле ввода MIN, В следующем диалоговом окне ввести
MAX введите радиус размещения узлов 25 имя параметра максимального
и нажмите Apply. Включите кнопку эквивалентного напряжения S_EQVMAX,
Reselect и Y. В поле MIN, MAX введите в левом списке выберите строку From
210, 270 и нажмите OK. sort oper, в правом - Maximum value и
15.3. Задание величины давления. M_M: OK.
Оптимизация модели
Preprocessor ⇒ Loads ⇒ Apply⇒ Pressure
19. Задание геометрических параметров.
⇒ On Nodes. Нажмите Pick All и в
M_M:Design Opt ⇒ Design Variables. В
следующем окне введите в поле Value 8.90
диалоговом окне нажмите клавишу Add. В
и нажмите OK.
следующем окне последовательно выбирайте
15.4. Возврат в набор всех узлов модели..
из списка Name имена переменных, в поле
U_M:Select ⇒ Entities. В верхнем списке
MIN ввести левую границу диапазона
выберите тип примитива Nodes, кнопка
переменной, в поле MAX – правую границу.
Full должна быть включена и затем OK. В
После каждого ввода нажимайте Apply. Ниже
следующем окне нажмите Pick All.
в скобках указаны параметры для которых
Расчет модели
вводится левая и правая граница диапазона.
16. Решение модели с заданными граничными
8
условиями. M_M:Solution ⇒ Current LS 20 Apply (DS1)
Постпроцессор 8
17. Определение суммарного объема модели. 20 Apply (DS2)
17.1. Формирование таблицы объемов 15
элементов.M_M:General Postproc ⇒ 30 Apply (T3)
Element Table ⇒ Define Table. Нажмите 5
Add. В следующем диалоговом окне 30 Apply (T4)
верхнем поле введите имя таблицы VOLU, 225
ниже из левого списка выберите строку 250 Apply (AL11)
Geometry, из правого – Elem volume 2
VOLU и нажмите OK. Закройте 20 Apply (DAL1)
предыдущее окно нажатием на Close. 100
17.2 Суммирование объемов. M_M:General 120 Apply (AL21)
Postproc ⇒ Element Table ⇒ Sum of Each 2
Item. Нажмите OK. 20 OK (DAL2)
17.3 Присвоение переменной суммарного Закройте предыдущее окно нажатием
объема. U_M:Parameters ⇒ Get Scalar Close.
Data. В левом списке диалогового окна 20. Задание переменной состояния . M_M:Design
выбрать строку Results data, в правом – Opt ⇒ State Variables. В диалоговом окне
Elem table sums и нажмите OK. В нажмите клавишу Add. В следующем окне
следующем диалоговом окне ввести имя выберите параметр S_EQVMAX и введите в
параметра суммарного объема TVOL и поле MAX его максимальное значение 25.
OK. Нажмите OK. Закройте предыдущее окно
18. Определение максимального эквивалентного нажатием Close.
напряжения . 21. Задание целевой функции. M_M:Design Opt ⇒
18.1 Формирование таблицы эквивалентных Objective. Выберите параметр TVOL. Нажмите
напряжений по Мизесу. .M_M:General OK.
Postproc ⇒ Element Table ⇒ Define Table.
Нажмите Add. В следующем диалоговом
окне в верхнем поле введите имя таблицы
S_EQV, ниже из левого списка выберите
строку Stress, из правого – von Mises

Представительство CAD FEM GmbH в СНГ: 107497 Москва, Щелковское шоссе, 77, офис 1703 5
Тел.: (095) 468-8175 Тел.\факс: (095) 913-2300 e-mail: cadfem@online.ru http://www.cadfem.ru
Рехтер Александр Дантонович, ТОО “Альбион”, тел.(0852) 27-45-51 E-mail rad@ymz.yaroslavl.ru
22. Задание метода оптимизации. M_M:Design 24. Запуск процесса оптимизации. M_M:Design
Opt ⇒ Method/Tool. Включите кнопку First Opt ⇒ Run .
-Order и нажмите OK. (First-Order относится к 25. Просмотр полученных результатов. U_M:
методам оптимизации первого порядка). В Parameters ⇒ Scalar Parameters. Ansys
следующем окне в поле NITR введите число выводит информационное окно с номером
итераций 10, остальные параметры по наилучшего набора параметров. В описанном
умолчанию. и нажмите OK. примере сходимость была достигнута на 6
23. M_M:Design Opt ⇒ Assign. Назначение итерации, время расчета на машине с
рабочего файла. Проведение оптимизации в процессором Pentium 120 Mhz составило 5162
интерактивном режиме требует рабочего сек. При этом эквивалентные напряжения
файла. Им может быть протокол сеанса работы снизились до 27, 836 кг/кв.мм, объем
(файл с расширением log). Возможно увеличился до 134202 куб.мм. Остальные
потребуется его правка. При правке удаляются параметры приняли следующие значения
лишние команды (напр., команды просмотра, (DS1=9.4, DS2=11.9, T3=29.6, T4=5.0,
выдачи вспомогательной печати и т.д.). AL11=234.7, DAL1=9.8, AL21=108.3,
Выберите из списка файл с расширением log и DAL2=11.4)
нажмите OK.

Рис.2 Эквивалентные напряжения до оптимизации (максимальное значение 47,551 кг/кв.мм)

Рис.3 Эквивалентные напряжения после оптимизации (максимальное значение 27,836 кг/кв.мм)

Представительство CAD FEM GmbH в СНГ: 107497 Москва, Щелковское шоссе, 77, офис 1703 6
Тел.: (095) 468-8175 Тел.\факс: (095) 913-2300 e-mail: cadfem@online.ru http://www.cadfem.ru

Оценить