You are on page 1of 10

Uso de Excel y Access para el desarrollo de

aplicaciones administrativas empresariales

Importar, exportar y vincular datos entre Access y Excel


Ocultar todo

Access y Excel pueden compartir datos de muchas formas. Se puede copiar datos desde una hoja de
cálculo (hoja de cálculo: documento principal que se utiliza en Excel para almacenar y trabajar con datos.
Consta de celdas que se organizan en filas y columnas. Una hoja de cálculo se almacena siempre en un
libro.) abierta y pegarlos en una hoja de datos de Access, importar una hoja de cálculo en una base de
datos de Access o, simplemente, cargar en Excel una hoja de datos de Access utilizando el comando
Analizar con Excel. En este tema se explica de forma detallada cómo intercambiar datos entre Access y
Excel importando, exportando o vinculando datos.

Importar datos desde Excel

Crear vínculos a datos de Excel

Exportar datos de Access a Excel

Solución de problemas

Importar datos desde Excel


Si tiene intención de almacenar en Access algunos o todos los datos contenidos en una o varias hojas de
cálculo de Excel, debería importar el contenido de la hoja de cálculo en una base de datos de Access nueva
o existente. Cuando importa los datos, Access crea una copia de los datos en una tabla nueva o existente,
sin modificar el archivo de origen de Excel.

A continuación se indican algunos escenarios en los que puede ser necesario importar datos de Excel en
Access:

• Lleva mucho tiempo usando Excel y ahora se está planteando la posibilidad de pasarse a Access.
Podría empezar por importar sus hojas de cálculo de Excel en una o varias bases de datos nuevas
de Access.
• Es usted un director que recibe de sus empleados informes en formato de Excel y desea combinar
los informes con una base de datos existente para actualizar el contenido de la misma.
• Es usted un director al que sus empleados le envían informes semanales en forma de archivos de
Excel y desea automatizar la operación de importar para ahorrar tiempo.
• Está desarrollando una aplicación en la que es necesario escribir código para importar datos de
Excel en Access.

Si es la primera vez que va a importar datos desde Excel, debería saber lo siguiente:

• No busque maneras de guardar una hoja de cálculo de Excel como una base de datos de Access.
Microsoft Excel no proporciona la funcionalidad "guardar como" para crear una base de datos de
Access con datos de Excel.
• Para iniciar la operación de importación, la base de datos de Access debe estar abierta
previamente. Si desea importar los datos en una nueva base de datos, debe crear una base de
datos en blanco (que no contenga tablas, formularios ni informes) antes de iniciar la operación de
importación.
• Los datos importaos desde una hoja de cálculo se almacenan en una tabla nueva o existente en
la base de datos actual. Si no está familiarizado con las tablas o con la estructura de las bases de
datos, vea Información sobre las tablas (MDB) y Diseñar una base de datos.
• Cuando abra una hoja de cálculo de Excel en Access (en el cuadro de diálogo Abrir archivo,
cambie el valor del cuadro de lista Tipo de archivo a Archivos de Microsoft Office Excel y
seleccione el archivo deseado), Access crea un vínculo a la hoja de cálculo en lugar de importar
sus datos. Crear un vínculo a una hoja de cálculo es distinto a importarla en una base de datos.
Para obtener más información sobre la vinculación, vea la sección Crear vínculos a datos de Excel
más adelante en este tema.

Introducción a la operación de importación

Paso 1: Identificar los datos que se desea importar

Empiece por buscar el archivo de Excel y seleccione la hoja de cálculo que posee los datos que desea
importar en Access. Durante la operación de importación sólo se puede importar una hoja de cálculo o
rango con nombre (nombre: palabra o cadena de caracteres que representa una celda, rango de celdas,
fórmula o valor constante. Utilice nombres fáciles de entender, como Productos, para referirse a rangos
difíciles de entender, como Ventas!C20:C30.) cada vez. Si no desea importar toda la hoja de cálculo o un
rango con nombre existente completo, puede que se plantee crear un nuevo rango con nombre que sólo
incluya las celdas que desee importar. Tenga en cuenta que durante la operación de importación, puede
decidir omitir una o varias columnas de la hoja de cálculo o del rango con nombre, pero no es posible
hacerlo con las filas.

Para importar varias hojas de cálculo o rangos con nombre, repita la operación de importación para cada
hoja de cálculo o rango.

Para obtener más información sobre cómo trabajar con rangos con nombre, vea la Ayuda de Excel.

Paso 2: Identificar la base de datos y la tabla de destino

Identifique la base de datos en la que se almacenarán los datos importados. Si no desea almacenar los
datos en ninguna de las bases de datos existentes, cree una base de datos en blanco. Para obtener más
información sobre cómo crear una base de datos en blanco, vea la sección "Crear una base de datos vacía
sin usar el Asistente para bases de datos" del tema Crear una base de datos de Access.

La operación de importación se iniciará después de abrir la base de datos de destino. Durante la operación,
se le pedirá que especifique el nombre de la tabla donde se almacenarán los datos importados. Si
especifica el nombre de una tabla existente, Access anexará los datos al final de la tabla. Si elige
almacenar los datos en una nueva tabla, Access creará la tabla durante la operación de importación.

Paso 3: Preparar los datos para la operación de importación

Revise los datos que desea importar y siga este procedimiento:

• Asegúrese de que las celdas tienen formato tabular. Si el rango incluye celdas combinadas, el
contenido de la celda se colocará en el campo que corresponde a la columna situada más a la
izquierda y el resto de los campos se dejarán en blanco.
• Si la primera fila de la hoja de cálculo o rango con nombre contiene los nombres de las columnas,
puede especificar que Access trate los datos de la primera fila como nombres de campo durante
la operación de importación. Si no hay ningún nombre de columna en la hoja de cálculo o un
nombre de columna concreto infringe las reglas de nomenclatura de campos de Access, Access
asignará un nombre válido para cada campo correspondiente.
• Si va a importar los datos en una tabla existente, asegúrese de que el número de columnas de la
hoja de cálculo o del nombre con rango coincide con el número de campos existente en la tabla.
También debe coincidir el nombre, tipo de fecha y posición de cada columna con el del campo
correspondiente de la tabla.

Sugerencia Para revisar los campos de una tabla y sus propiedades, abra la tabla en la vista
Diseño.

Paso 4: Aspectos que debe conocer antes de importar determinados tipos de datos y elementos

• Elementos gráficos Los elementos gráficos, como logotipos, gráficos e imágenes no se


importan.
• Tipo de datos De forma predeterminada, Access analiza las 25 primeras filas para averiguar el
tipo de datos que contiene la columna. Si Access encuentra valores más allá de la 25ª fila que no
son compatibles con el tipo de datos elegido, simplemente omitirá esos valores y no los
importará.

NOTA Durante la operación de importación no se puede cambiar el tipo de datos del campo de
destino.
• Valores calculados Los resultados de las columnas o celdas calculados se importan y se
almacenan en un campo de un tipo de datos adecuado. No se importa la fórmula en sí.
• Hipervínculos Las columnas que contienen hipervínculos se importarán como campos de texto.

Una vez importados los datos, puede que se dé cuenta de que no se importaron todos los datos, o de que
Access no asignó el tipo de datos adecuado. Vea el paso 6 para obtener más información sobre cómo
tomar medidas correctivas.

Paso 5: Iniciar la operación de importación

1. Abra la base de datos de destino. Asegúrese de que la base de datos no es de sólo lectura y de
que dispone de permisos para realizar cambios en la base de datos.

Si no existe la base de datos, créela. Para obtener más información sobre cómo crear una base de
datos en blanco, vea la sección "Crear una base de datos vacía sin usar el Asistente para bases
de datos" del tema Crear una base de datos de Access.

2. En el menú Archivo, elija Obtener datos externos y, a continuación, haga clic en Importar.

NOTA El comando Obtener datos externos sólo está disponible cuando hay una base de datos
abierta.

3. En el cuadro de diálogo Importar, dentro del cuadro Tipo de archivo, seleccione Microsoft
Excel.

NOTA Si en el cuadro Tipo de archivo no aparece Microsoft Excel, se debe a que la ruta de
acceso al controlador necesario especificada en el Registro no es válida.

4. Haga clic en la flecha que aparece a la derecha del cuadro Buscar en, seleccione la unidad y la
carpeta en la que se encuentra el archivo de hoja de cálculo y, a continuación, haga doble clic en
su icono.

NOTA Si aparece un mensaje de error que indica que Access no puede importar el archivo
seleccionado, puede deberse a que el archivo está dañado o a que los datos no están en un
formato que pueda leer Access. Abra el archivo en Excel y asegúrese de que los datos están
intactos y de que tienen formato tabular.

5. Siga las instrucciones de los cuadros de diálogo del Asistente para importación de hojas de
cálculo.

Si no se inicia el asistente

Esto se podría deber a que Access se estuviera ejecutando en modo de recinto de seguridad, pero
no estuviera instalado en el equipo Microsoft Jet 4.0 SP8 o una versión posterior. Para que Access
esté completamente operativo, se requiere Jet 4.0 SP8 o una versión posterior cuando está
habilitado el modo de recinto de seguridad.

Para obtener más información acerca de la instalación de la actualización de Jet, consulte el


artículo de Office Online Acerca de Microsoft Jet 4.0 SP8 o posterior, en
http://office.microsoft.com/assistance/preview.aspx?AssetID=HA010489351033.

Para obtener más información acerca del modo de recinto de seguridad, vea el tema Acerca del
modo de recinto de seguridad del Servicio de expresión de Microsoft Jet.

NOTA Si elige importar los datos en una nueva tabla y se da cuenta de que no puede especificar opciones
de campo excepto para el primero, debe obtener una actualización para corregir un problema conocido.

Una vez terminada la operación de importación, aparecerá un mensaje informando del estado de la
operación. Si se produjo algún error, Access crea una tabla de registro de errores en la base de datos y
muestra el nombre de la tabla en ese mensaje.

Paso 6: Revisar los datos importados, la tabla de registro de errores y emprender las acciones
correctivas

El último paso consiste en abrir la tabla de destino en la vista Hoja de datos, después en la vista Diseño, y
por último asegurarse de que los datos se importaron sin errores.

Revisar la tabla del registro de errores Si el mensaje que apareció al final de los errores de la
operación mencionados, puede que desee abrir la tabla de registro de errores y revisar su contenido. La
tabla tiene tres campos: Error, Campo y Fila. Cada fila contiene información sobre un error específico y el
contenido del campo Error debería servir de ayuda para solucionar el problema. Para obtener una lista de
cadenas de error y sugerencias sobre cómo solucionar cada tipo de error, vea la sección "Tras importar un
archivo, Access dice que se ha creado una tabla Nombre de tabla$_ErroresDeImportación" del tema
Solucionar problemas de importación y vinculación.

Revisar la tabla de destino Aunque los mensajes de error y la tabla de registro de errores informará de
la mayoría de errores producidos, seguirá siendo conveniente revisar los datos importados. Si observa que
no se importaron todas las filas o columnas, intente identificar y corregir el problema en el archivo de
origen y pruebe a repetir la importación. Si en una columna parecen estar truncados los datos, pruebe a
aumentar el ancho de la columna en la vista Hoja de datos antes de probar otras opciones.

Cuando encuentre un problema concreto, corríjalo en el archivo de origen. Cuando crea que ha corregido
todos los problemas conocidos, repita la operación de importación.

Para obtener información detallada sobre la solución de problemas, vea Solucionar problemas de
importación y vinculación.

Verificar y cambiar el tipo de datos de los campos Access intenta asignar el tipo de datos adecuado
a los campos importados, pero debería comprobar los campos para asegurarse de que se les ha asignado
el tipo de datos deseado. Por ejemplo, en una base de datos de Access, un campo de número de teléfono o
de código postal se podría importar como campo de tipo Número, pero se debería cambiar a un campo de
tipo Texto en Access, porque no es probable que se vayan a realizar cálculos con estos tipos de archivos.
También debería comprobar y establecer propiedades de los campos, como su formato, si es necesario.

Otras maneras de incluir datos de Excel en Access

Además de importar, puede utilizar las técnicas siguientes para incluir datos de Excel en Access:

• Crear vínculos a datos de Excel. Al vincular no se crea una copia de los datos en Access, pero se
permite que Access vea y modifique datos en las hojas de cálculo de Excel. Para obtener más
información sobre cómo crear vínculos a hojas de cálculo, vea la sección Crear vínculos a datos
de Excel de este tema.
• Cortar o copiar datos desde Excel y pegarlos en una tabla de Access. Para obtener más
información sobre cómo cortar o copiar datos de una hoja de cálculo, vea la Ayuda de Excel.
• Importar datos escribiendo código. Para importar los datos mediante programación se puede
escribir una macro o un procedimiento de Visual Basic para Aplicaciones (VBA). Para obtener más
información sobre cómo hacerlo, vea Importar datos mediante programación.
• Exportar datos de Microsoft Excel a un archivo XML de Lenguaje de marcado extensible (Lenguaje
de marcado extensible (XML): forma abreviada del Lenguaje de marcado generalizado estándar
(SGML) que permite a los programadores crear etiquetas personalizadas que ofrecen flexibilidad
para organizar y presentar información.) que después se puede importar en Access. Para obtener
más información sobre cómo importar datos XML, vea la sección "Importar datos o esquemas de
XML" del tema Importar o vincular datos y objetos.

Crear vínculos a datos de Excel


Si no desea mantener una copia de los datos en la base de datos de Access, puede crear un vínculo a la
hoja de cálculo de Excel. La vinculación permite establecer conexión con los datos existentes en otros
programas sin importarlos, de manera que los datos se pueden ver y modificar tanto en el programa
original como en el archivo de Access.

Cuando cree un vínculo o una hoja de cálculo o a un rango con nombre, Access crea una nueva tabla
vinculada a las celdas de origen. Los cambios realizados en los datos de la tabla actualizarán el archivo de
origen de Excel. La vinculación resulta de utilidad cuando es necesario compartir datos de Excel entre
usuarios de Excel y de Access.

Si es la primera vez que va a crear vínculos con una hoja de cálculo de Excel, debería saber los siguientes
puntos:

• No se pueden crear vínculos a bases de datos de Access desde Excel.


• No se pueden crear vínculos de datos de Excel a una tabla existente en la base de datos. Al crear
un vínculo, Access crea una nueva tabla, normalmente conocida como tabla vinculada. La tabla
muestra los datos contenidos en la hoja de datos o el nombre con rango del origen, pero en
realidad no almacena los datos en la base de datos.
• Una base de datos puede tener varias tablas vinculadas.
• Los cambios realizados en los datos de Excel se reflejarán automáticamente en la tabla vinculada.
Cualquier cambio que efectúe en la tabla vinculada en Access se guardará automáticamente en
el archivo de origen de Excel.
• Cuando abra una hoja de cálculo de Excel en Access (en el cuadro de diálogo Abrir archivo,
cambie el valor del cuadro de lista Tipo de archivo a Archivos de Microsoft Office Excel y
seleccione el archivo deseado), Access crea una base de datos en blanco e inicia
automáticamente el Asistente para vinculación de hojas de cálculo.

Para obtener más información sobre la vinculación, vea Vincular datos y objetos de bases de datos.

Introducción a la operación de vinculación

Paso 1: Identificar los datos que se desea vincular

Empiece por buscar el archivo de Excel y la hoja de cálculo que posee los datos a los que desea establecer
un vínculo. Durante la operación de vinculación sólo se puede vincular una hoja de cálculo o rango con
nombre cada vez. Si no desea vincular toda la hoja de cálculo o un rango con nombre existente completo,
puede que se plantee crear un rango con nombre que sólo incluya las celdas que desee importar.

Para establecer un vínculo a importar varias hojas de cálculo o rangos con nombre, repita la operación de
vinculación para cada hoja de cálculo o rango.

Para obtener más información sobre cómo trabajar con rangos con nombre, vea la Ayuda de Excel.

Paso 2: Identificar la base de datos y la tabla de destino

Identifique la base de datos a la que desea crear el vínculo. Si no desea almacenar el vínculo en ninguna de
las bases de datos existentes, cree una base de datos en blanco. Para obtener más información sobre
cómo crear una base de datos en blanco, vea la sección "Crear una base de datos vacía sin usar el
Asistente para bases de datos" del tema Crear una base de datos de Access.

La operación de vinculación en Access comenzará después de abrir la base de datos de destino. Durante la
misma, Access creará una tabla vinculada. Si ya existe una tabla con el nombre especificado, Access
sobrescribirá dicha tabla.

Paso 3: Preparar los datos para la operación de vinculación

Revise los datos que desea vincular y siga este procedimiento:

• Asegúrese de que las celdas tienen formato tabular. Si el rango incluye celdas combinadas, el
contenido de la celda se colocará en el campo que corresponde a la columna situada más a la
izquierda y el resto de los campos se dejarán en blanco.
• Si la primera fila de la hoja de cálculo o rango con nombre contiene los nombres de las columnas,
puede especificar que Access trate los datos de la primera fila como nombres de campo durante
la operación de vinculación. Si no hay ningún nombre de columna en la hoja de cálculo o un
nombre de columna concreto infringe las reglas de nomenclatura de campos de Access, Access
asignará un nombre válido para cada campo correspondiente.

Paso 4: Aspectos que debe conocer antes de vincular determinados tipos de datos y elementos

• Elementos gráficos Los elementos gráficos contenidos en una hoja de cálculo de Excel, como
logotipos, gráficos e imágenes no estarán visibles en Access.
• Tipos de datos Los tipos de datos de los campos de la tabla vinculada no se pueden cambiar. Ni
tampoco cambiar el tamaño de los campos.
• Valores calculados Los resultados de una columna o celdas calculadas aparecen en la tabla,
pero no se podrán modificar los valores.
• Columna de Excel con valores de más de 255 caracteres Durante la vinculación, si Access
encuentra valores en Excel que tengan más de 255 caracteres, los almacena en un campo de tipo
Memo que incluye sólo los primeros 255 caracteres. Una solución alternativa para esta limitación
consiste en importar la hoja de cálculo o rango con nombre, en lugar de crear un vínculo a la
misma.

Una vez creada la tabla vinculada, debería abrirla en la vista Hoja de datos para ver que la tabla tiene
exactamente el mismo aspecto que el que tiene en el archivo de origen. Vea el paso 6 para ver los posibles
errores que pueden producirse y cómo corregirlos.

Paso 5: Iniciar la operación de vinculación

1. Abra la base de datos de destino. Asegúrese de que la base de datos no es de sólo lectura y de
que dispone de permisos para realizar cambios en la base de datos.

Si no existe la base de datos, créela. Para obtener más información sobre cómo crear una base de
datos en blanco, vea la sección "Crear una base de datos vacía sin usar el Asistente para bases
de datos" del tema Crear una base de datos de Access.

2. En el menú Archivo, elija Obtener datos externos y, a continuación, haga clic en Vincular
tablas.

NOTA El comando Obtener datos externos sólo está disponible cuando hay una base de datos
abierta.

3. En el cuadro de diálogo Vincular, dentro del cuadro Tipo de archivo, seleccione Microsoft
Excel.

NOTA Si en el cuadro Tipo de archivo no aparece Microsoft Excel, se debe a que la ruta de
acceso al controlador necesario especificada en el Registro no es válida.

4. Haga clic en la flecha que aparece a la derecha del cuadro Buscar en, seleccione la unidad y la
carpeta en la que se encuentra el archivo de hoja de cálculo y, a continuación, haga doble clic en
su icono.

NOTA Si aparece un mensaje de error que indica que Access no puede vincular el archivo
seleccionado, puede deberse a que el archivo está dañado o a que los datos no están en un
formato que pueda leer Access. Abra el archivo en Excel y asegúrese de que los datos están
intactos y de que tienen formato tabular.

5. Siga las instrucciones de los cuadros de diálogo del Asistente para vinculación de hojas de
cálculo.

Si no se inicia el asistente

Esto se podría deber a que Access se estuviera ejecutando en modo de recinto de seguridad, pero
no estuviera instalado en el equipo Microsoft Jet 4.0 SP8 o una versión posterior. Para que Access
esté completamente operativo, se requiere Jet 4.0 SP8 o una versión posterior cuando está
habilitado el modo de recinto de seguridad.

Para obtener más información acerca de la instalación de la actualización de Jet, consulte el


artículo de Office Online Acerca de Microsoft Jet 4.0 SP8 o posterior, en
http://office.microsoft.com/assistance/preview.aspx?AssetID=HA010489351033.

Para obtener más información acerca del modo de recinto de seguridad, vea el tema Acerca del
modo de recinto de seguridad del Servicio de expresión de Microsoft Jet.

Una vez terminada la operación de vinculación, aparecerá un mensaje informando del estado de la
operación.

Paso 6: Revisar la tabla vinculada y tomar las acciones correctivas


El último paso consiste en abrir la tabla en la vista Hoja de datos y revisar los datos mostrados.

Busque cadenas que comiencen por "#", como #Num. Por ejemplo, Access muestra #Num en los campos
numéricos cuando encuentra un valor no numérico.

Busque cadenas que parezcan estar truncadas. Aumente el ancho de la columna de la vista Hoja de datos,
pero si sigue sin verse el valor completo, podría deberse a que el valor tiene más de 255. Access sólo
muestra los primeros 255 caracteres, por lo que la alternativa es importar los datos en lugar de vincularlos.

Para obtener información detallada sobre la solución de problemas, vea Solucionar problemas de
importación y vinculación.

Exportar datos de Access a Excel


Con frecuencia, se producirán situaciones en las que los datos estén almacenados en Access, pero no es
necesario moverlos o copiarlos a Excel. Por ejemplo, podría desear distribuir el informe a un grupo de
usuarios que prefieren verlos en Excel. O bien, quizás desee analizar sus datos de Access aprovechando las
características de Excel. En esos campos, exporte el contenido de la base de datos de Access a una hoja de
cálculo de Excel.

A Excel se pueden exportar los siguientes elementos:

• Los datos contenidos en una tabla, consulta, formulario o informe.

La ilustración siguiente muestra el aspecto que tendrá el informe Catálogo de la base de datos de
ejemplo Neptuno después de exportarlo a Excel:

• Todas o algunas de las filas y columnas de una vista de hoja de datos

La ilustración siguiente muestra el aspecto que tendrá una parte de la tabla Empleados en la
vista de hoja de datos después de haberla exportado a Excel:

NOTA En una única operación de exportación no se puede exportar varios objetos. Sin embargo, se
pueden combinar los datos contenidos en distintas hojas de cálculo después de finalizar las operaciones de
importación individuales. Para obtener más información, vea Combinar libros y Mover (cortar) o copiar
celdas o datos de celdas en la Ayuda de Excel.
Introducción a la operación de exportación

Paso 1: Identificar los datos que se desea exportar

Empiece por buscar la base de datos y el objeto de la base de datos que contiene los datos que desea
exportar. Se pueden exportar tablas, consultas, formularios o informes. Por ejemplo, se puede exportar la
información de los clientes almacenada en la tabla Clientes o en todo el informe del catálogo Productos.

NOTA Las páginas de acceso a datos (página de acceso a datos: página Web diseñada para ver datos y
trabajar con ellos desde Internet o una intranet. Sus datos suelen estar almacenados en una base de datos
de Access.), macros y módulos no se pueden exportar.

Paso 2: Decidir dónde empezar la operación de exportación

Los objetos se pueden exportar desde la ventana Base de datos (ventana Base de datos: ventana que
aparece cuando se abre una base de datos o un proyecto de Access. Muestra métodos abreviados para
crear objetos de base de datos nuevos y abrir otros existentes.) o cuando la base de datos está abierta en
una vista. La tabla siguiente explica cómo influye la vista utilizada en lo que se exporta.

NOTA Los datos no se pueden exportar desde la vista Diseño ni desde la vista SQL.

Objeto Vista o ventana Lo que se exporta


Tabla,
Ventana Base de
consulta o Todos los campos o registros
datos
formulario
Tabla, Todos los campos y registros del origen de datos subyacente,
Vistas Tabla dinámica
consulta o independientemente de si los campos están realmente incluidos en la
y Gráfico dinámico
formulario vista.
Tabla, Si desea exportar sólo parte de los datos, puede seleccionarlos y
consulta o Vista Hoja de datos después elegir exportar sólo los datos seleccionados. También tiene la
formulario opción de exportar toda la hoja de datos.
Todos los campos y registros del origen de datos subyacente,
Formulario Vista Formulario independientemente de si los campos están realmente incluidos en la
vista.
Todos los datos contenidos en los cuadros de texto de las secciones
Ventana Base de
Encabezado del grupo y Detalle, y cualquier otro cuadro de texto
datos, Presentación
Informe contenido en un pie de página de grupo que contenga una expresión
preliminar y Vista
que utilice la función Suma. Access utiliza la característica de esquema
previa del diseño
de Excel para dar formato al informe en Excel.

Paso 3: Identificar el archivo de destino de la operación de exportación

Durante la operación de exportación, se le pedirá que especifique el nombre del archivo de destino. Si no
existe ningún nombre de archivo como el que especifique, se creará un nuevo archivo. Si el archivo existe,
se producirá una de las siguientes situaciones:

• Si va a exportar una tabla o consulta y no activa la casilla de verificación Con formato durante la
operación de exportación, el archivo no se sobrescribirá. Se agregará al archivo una nueva hoja
de cálculo con el mismo nombre que el del objeto que se va a exportar. Si ya existe una hoja de
cálculo con ese nombre, Access le pedirá que reemplace el contenido de la hoja de cálculo
correspondiente o que especifique otro nombre para la nueva hoja.

Al activar la casilla de verificación Con formato, la hoja de cálculo hereda los ajustes de formato
parecidos a la hoja de datos, pero sobrescribe el contenido existente de la hoja de cálculo.

• Si va a exportar un formulario o un informe, el archivo se sobrescribirá en todos los casos. Se


quitarán todas sus hojas de cálculo existentes y se creará una nueva hoja de cálculo con el
mismo nombre que el del objeto exportado.

Paso 4: Aspectos que debe conocer antes de exportar determinados tipos de datos y controles

• Imágenes y objetos Todos los elementos gráficos, como logotipos, imágenes de fondo y
contenido de campos de objeto OLE que formen parte de los datos exportados no se exportarán.
• Gráfico Al exportar un formulario o un informe que contenga un objeto de Microsoft Graph, no se
exporta el objeto gráfico.
• Valores nulos A veces, los valores nulos se reemplazan con los datos que deberían estar en la
columna adyacente en la hoja de cálculo resultante.
• Valores calculados La expresión usada para calcular los valores no se exporta a Excel, sino
sólo el resultado de las expresiones.
• Valores de fecha Los valores de fecha anteriores al 1 de enero de 1900 no se exportan: en su
lugar, la celda correspondiente de la hoja de cálculo contendrá un valor nulo.
• Casillas de verificación Si inicia la operación de exportación desde la ventana Base de
datos (ventana Base de datos: ventana que aparece cuando se abre una base de datos o un
proyecto de Access. Muestra métodos abreviados para crear objetos de base de datos nuevos y
abrir otros existentes.) o en la vista Formulario, las casillas de verificación de los formularios no
se exportarán. La columna correspondiente de la hoja de cálculo mostrará el signo "#". Para
solucionar esta situación, abra el formulario en la vista Hoja de datos antes de exportarla. La
columna correspondiente en la hoja de cálculo contendrá VERDADERO o FALSO, dependiendo del
estado de activación de la casilla de verificación del formulario.
• Subinformes y subformularios Los subinformes se exportan, pero los subformularios se
omitirán.

Paso 5: Iniciar la operación de exportación

1. Si el objeto que desea exportar no está abierto, en la ventana Base de datos (ventana Base de
datos: ventana que aparece cuando se abre una base de datos o un proyecto de Access. Muestra
métodos abreviados para crear objetos de base de datos nuevos y abrir otros existentes.), haga
clic en el nombre del objeto. Para guardar sólo una parte de la hoja de datos, ábrala y seleccione
esa parte de la hoja de datos antes de continuar.
2. En el menú Archivo, haga clic en Exportar.
3. En el cuadro Guardar como tipo, haga clic en Microsoft Excel 5-7 o en Microsoft Excel 97-
2003.

NOTA Si en el cuadro Tipo de archivo no aparece Microsoft Excel, se debe a que la ruta de
acceso al controlador necesario especificada en el Registro no es válida.

4. Haga clic en la flecha situada a la derecha del cuadro Guardar en y seleccione la unidad o la
carpeta en la que desee guardarlo.
5. En el cuadro Nombre de archivo, escriba un nombre para el archivo (o utilice el nombre
sugerido).
6. Active la casilla de verificación Con formato.
7. Siga uno de estos procedimientos:
o Si va a guardar una hoja de datos, haga clic en Exportar todo para guardar toda la
hoja de cálculo o en Guardar selección si en el paso 1 se seleccionó una parte de la
hoja de datos.
o Para todos los demás objetos de la base de datos, haga clic en Exportar.

Paso 6: Revisar la hoja de cálculo de Excel

Abra la hoja de cálculo y asegúrese de que los datos se exportaron por completo. Busque indicadores de
error (triángulos verdes ) o valores erróneos (cadenas que empiezan con "#", en lugar de los datos) en las
celdas. Para obtener más información sobre cómo solucionar indicadores de error y valores erróneos, vea
la Ayuda de Excel.

Cuando examine la hoja de cálculo en busca de errores, busque también columnas en blanco o columnas
que faltan, y celdas vacías. Si encuentra problemas graves, corríjalos en la base de datos de origen y repita
la operación de exportación.

Para obtener información detallada para la solución de problemas, vea Solucionar problemas de
exportación en Access.

Otras maneras de incluir datos de Access en Excel

Además de exportar, puede utilizar las técnicas siguientes para incluir datos de Access en Excel:

• Cortar o copiar datos desde Access y pegarlos en una hoja de cálculo de Excel. Para obtener más
información sobre cómo hacerlo, vea la sección "Copiar o mover registros o datos desde varios
campos de Microsoft Access en otra aplicación" del tema Copiar o mover datos.
• Exportar datos utilizando código. Para exportar los datos mediante programación se puede
escribir una macro o un procedimiento de Visual Basic para Aplicaciones (VBA). Para obtener más
información sobre cómo hacerlo, vea Exportar datos mediante programación.
• Cargar datos de Access en una instancia de Excel.

¿Cómo?

1. En la ventana Base de datos (ventana Base de datos: ventana que aparece cuando se
abre una base de datos o un proyecto de Access. Muestra métodos abreviados para
crear objetos de base de datos nuevos y abrir otros existentes.), haga clic en el nombre
de la hoja de datos, formulario o informe que desea guardar y cárguela en Excel. Para
cargar sólo una parte de la hoja de datos, ábrala y seleccione esa parte de la hoja de
datos antes de continuar.
2. En el menú Herramientas, elija Vínculos con Office, luego, haga clic en Analizar
con Microsoft Excel.
• Exportar datos de Microsoft Access a un archivo XML de Lenguaje de marcado
extensible (Lenguaje de marcado extensible (XML): forma abreviada del Lenguaje de marcado
generalizado estándar (SGML) que permite a los programadores crear etiquetas personalizadas
que ofrecen flexibilidad para organizar y presentar información.) que después se puede importar
en Excel. Para obtener más información sobre cómo exportar datos de Access como XML, vea
Exportar datos de Access como XML.

Solución de problemas
Si sigue teniendo problemas con alguna de estas operaciones, pruebe las sugerencias siguientes. Los
vínculos del "Paso 4" y del "Paso 6" le serán de mucha utilidad.

• Vea los temas "Solucionar problemas de exportación en Access" o "Solucionar problemas de


importación y vinculación" en la lista Vea también de este tema.
• Haga clic en los vínculos del "Paso 4" de cualquiera de las tres secciones "Introducción..." de este
tema para obtener información sobre posibles áreas problemáticas y sus soluciones.

Un problema común en la importación: datos truncados

Si detecta que durante la importación se están truncando las celdas de Excel que contienen más
de 255 caracteres, vea "Tipo de datos" en el Paso 4: Aspectos que debe conocer antes de
importar determinados tipos de datos y elementos, dentro de la sección "Introducción a la
operación de importación" de este tema. En ella se explica que el Asistente para importación de
hojas de cálculo sólo muestra una vista previa de las primeras 25 filas de los datos de Excel para
predecir el tipo de datos que asignar al campo de la nueva tabla.

Si en la 36ª fila de datos hay una celda que contiene 440 caracteres, por ejemplo, Access no verá
los datos de esa fila y, en lugar de crear un campo con el tipo de datos Memo, el asistente creará
un campo con el tipo de datos Texto. ¿Cómo se puede evitar este problema concreto? Cortando e
insertando la 36ª fila de los datos por encima de la 25ª fila de la hoja de cálculo de Excel.
También es importante asegurarse de que los datos de las columnas de la hoja de cálculo tienen
el mismo tipo de datos en todas las filas.

• Haga clic en los vínculos del "Paso 6" para obtener sugerencias sobre cómo interpretar el
contenido de la tabla de registro de errores de Access o los errores de la hoja de cálculo de Excel
en la que se importaron los datos.