Вы находитесь на странице: 1из 3

T ESTE C ONDICIONAL

uma equao que compara valores, Funes e Frmulas.


comparao, retorna na clula a string de texto Verdadeiro ou Falso.

Aps

Lembre-se de que quando voc estiver comparando texto, este deve vir entre
aspas. Para fazer um Teste Condicional (comparao) voc deve utilizar os
Operadores de Comparao (> , < , >= , <= , = , <>).
Exemplos:
=A5>A10

=D5="Senac

=B3>0 =MNIMO(A1:A3)<>6

=SOMA(A1:A5)>MDIA(B1:B5)
=MXIMO(B6:B9)>=20

F UNO SE
uma equao de comparao como um Teste Condicional, mas, ao invs
de devolver a string de texto Verdadeiro ou Falso, cria valores para Verdadeiro e
Falso e devolve esses valores na clula onde foi aplicada a funo.
Sintaxe: =SE(TesteCondicional;ValorVerdadeiro;ValorFalso)
Exemplos:
=SE(A1>=7; A P R O V A D O ; R E P R O V A D O )

=SE(B3>9;10%;20%)

=SE(B5<=500;5%;14%)

=SE(T5=T2;100;0)

=SE(SOMA(A1:A6)<0;" N E G A T I V O ";" P O S I T I V O ")

=SE(R4<>5;3;6)

G RAFOS

DE

D ECISO

Os grafos de deciso so uma representao grfica da elaborao da soluo


de funes do tipo SE. O grafo consiste em uma linha plana onde colocado o
teste lgico e duas linhas inclinadas, que so caminhos a serem tomados ao
analisar o teste lgico.
Exemplo:
=SE(C2<1000;C2*1,5%;C2*2,5%) temos:

Ao transpor o grafo para a funo SE, o teste da linha horizontal o primeiro


parmetro da funo, o valor do caminho de cima o segundo parmetro, e o
valor do caminho de baixo, o terceiro parmetro.
72

E X C E L 20 00

Neste caso ao realizar o teste lgico, tomamos o caminho para cima, se o


teste for verdadeiro, e para baixo, se o teste for falso.
Esta representao grfica muito interessante medida que vamos
aninhando funes S E .
Exemplo:
Para a soluo de um problema utilizando uma funo SE que apresenta os
conceitos C, B e A conforme as mdias obtidas por alunos, os colchetes indicam
que o valor limite est no intervalo e parnteses que o valor limite no est no
intervalo. A tabela seguinte mostra a relao ente conceito e nota:
Mdia

Conceito

[ 0;7 )

[ 7;9 )

[ 9;10 ]

O grafo que representa este problema :

Este grafo interpretado da seguinte forma:


Caso o primeiro teste seja verdadeiro a resposta C; caso seja falso, a
resposta s ser dada aps o prximo teste. No segundo teste, caso seja
verdadeiro, a resposta B; caso seja falso, a resposta A.
Decompondo o grafo para montar a funo SE:
A parte do grafo abaixo ir resultar em uma funo se da seguinte forma:
SE(A1<9;B;A")

E X C E L 20 00

73

Considerando agora, apenas a outra parte do grafo temos:


A parte do grafo ao lado ir resultar em uma funo SE da seguinte forma:
=SE(A1<7;C; o valor da parte anterior )

Utilizando o grafo, tambm mais fcil de entender porque no adequado


resolver este problema da seguinte forma:
= SE(A1<7;C;SE(E(A1>=7;A1<9);B;A"))

.......................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
.....................................................................................................................
74

E X C E L 20 00