Вы находитесь на странице: 1из 120

. .

2011

621.37:004.94:004.42
32.21-02-5-05.7
-78
. .

-78

. .

: [ ] / . . .
: . . -, 2011. 120 .
ISBN 978-5-7638-2170-3
. , ,
. , .
OrCAD PSpice.
210000
, .
.

621.37:004.94:004.42
32.21-02-5-05.7


. .
.-. . 7,5.

3220
-
-

660074 . , . , 79
./ (391) 244-82-31
E-mail: rio@sfu-kras.ru

ISBN 978-5-7638-2170-3


, 2011


........................................................................................... 6
........................ 6
, .......... 7
.................................................................................. 9
.............................................................................. 9

................................................................................... 10

1 ,
RLC ..................... 11
...................................................................................................... 11
........................................................... 11
........................................................................................ 13
..................................................................................... 13
......................................... 14
............................................................................ 14
. ,
......................................................... 15
.
, ....................................... 20
. ............................................................................. 23
. ............................................................................. 29
. ............................ 30
. .......................................................................... 31
. ........................... 36
. ......................... 38
..................................................... 40
.......................................................................................... 40
.................................................................................... 41

2
....................................................... 42
...................................................................................................... 42
........................................................... 42
. 1 ........................................................................ 46
. 1 ..................................................................... 47
. 1........................................ 47

Model Editor ............................................................................. 47
. 51
................................................................. 52

.................................................................... 58
. 2 ........................................................................ 62
. 2 ..................................................................... 62
. 2........................................ 62
............................................................................ 62
..................................................................... 65
........................................................................................ 67
.
............................................................................................................. 68
.
............................................................................................................. 69
.
............................................................................. 69
. .
............................................................................................................... 71
..................................................... 73
.......................................................................................... 74
.................................................................................... 74

3

......................................................................................... 75
...................................................................................................... 75
........................................................... 75
........................................................................................ 79
..................................................................................... 79
......................................... 80
............................................................................ 80
............................................................................................... 81
. ........................................... 84
. Temperature (Sweep)........................................ 84
. Parametric Sweep. . 86
..................................................... 89
.......................................................................................... 89
.................................................................................... 89

4
,

.................................................................................................... 90
...................................................................................................... 90
........................................................... 90
........................................................................................ 94

..................................................................................... 94
....................................................... 95
........................................................................................ 95
. 98
................................................ 99
................................................................... 100
- ................................................................................. 101
.
.................................................................... 104
PSpice Advanced Analysis............. 106
. ....................... 109
........................................................................................ 110
.................................................................................. 110
.......................................................................... 112
1 ................................................................................ 114
2 ................................................................................ 117
3 ................................................................................ 119
........................................................................................ 120


:
, ;
,
;


;

;
.

, ,
. .
- , ,
Cadence OrCAD 9.1-16.3 OS Windows. - OrCAD.
PSpice
OrCAD, -
, SPICE.
SPICE- OrCAD SPICE SPICE- , Altium, Proteus, Multisim .
,
OrCAD Capture .

,
18
. , 12 .
. 1.
1

1
2
3
4

,
RLC



: ,
, , , , , .
, .
, .
, ,
.

:
;
;
;
;
, .

, ,


, (, , , , ), ( , ).
, , , .
,
, , .
( ).
, , ,
(
, . .).
,
. ,
, .
, ,
( )
, .
.
(- . .), , (
)
- .
. ( ), .
( ) Word, Excel, Visio, Mathcad, Matlab . .

(
), , .



-

. . 2.
2


0,05

0,15

0,1

0,7

(/),
.

:
;
, .
:
;
( );
;
,
, , . .;
, .
:
, , .



, .
:
,
:
- , , ;
- ;
- , , ;
- , , .
;
;
, , ;
, ,
;
, .

: [13, 21],
[20, 23], [7], [1, 2, 3, 9, 11].
[3, 5, 6, 10, 12, 16, 18, 22], Cadence OrCAD 16.0.

10

1
,
RLC

, (
OrCAD).

. ,
. , () ( ) .
-, - - , ()
.
, , . , . ,
,

. , , , .
, , , , , . .
. .

, .
: , , . PSpice ).
,
, .
.

11

1. , RLC

, : , .
OrCAD PSpice .
Bias Point . Bias
Point . : , . , PSpice,
, .
AC Sweep . alternating current
. Sweep , . -
.
, - , , . ..

AC ACMAG,
IAC VAC,
( ).
,
, , .
Time Domain (Transient) . Time Domain , transient .
(, , . .) .
t 0 .
(Run to time)
(Maximum step size). t 0 ,
(Start saving data after), ,
t 0 . ,
(Skip the initial
transient bias point calculation). , .
. .

12

1. , RLC
.


,
, X ,
.

.
.
. [4, 8, 17].

.
1.
( ), , . , :

E1 ;

;
2
Y .
E2


, .
,
, . 3.

1. .
2. .
,
;
, , . 3.
3. . :
();

(), ,
;

13

1. , RLC

;
- ().
,
. 3 .
3

Y
1
Y

4. . :
;
(
, PSpice).
,
,
. . 3.

1. OrCAD Capture (CIS).


2. (Analog or Mixed A/D) Capture
, , .
(VDC
IDC), .
3. . (Net Alias), Place>Net
Alias, N (. 1). Name ,
( ) , , ,
.

14

1. , RLC
. ,

,
(Property Editor) Name , Place>Net Alias.

. 1.

OrCAD Capture
N00032, . , () 0.
, OrCAD, , .
. ,

4. . PSpice>New Simulation
Profile (Alt+S+N) (. 2). Name
Create.
Simulation Settings
Analysis , .

15

1. , RLC
. ,

. 2.

*.sim, \< >-PSpiceFiles\< >\.


. ,
Bias Point .
, Time Domain
. ,
(. 3), .

. 3.

(Simulation Settings) PSpice>Edit Simulation Profile,


Alt+S+E
(. 4). ,
.
, Alt, , , Alt , , , PSpice S. ,
, .

16

1. , RLC
. ,


( PSpice Resources>Simulation Profiles).

. 4.

5. Bias Point (. 5).

. 5. .

6. . PSpice>Run, F11 ,
(. 6).

. 6.

17

1. , RLC
. ,

PSpice A/D. , , , .., *.net ( ) PSpice A/D.


(Netlist file) , ,
, .
\< >-PSpiceFiles\< >\.

. 7. PSpice A/D.

PSpice A/D, , Output Window ( ) (. 7).


, ,
PSpice A/D.
7. (Netlist file). OrCAD Capture
PSpice>View Netlist. , , *.net - . Netlist .
8. OrCAD Capture , . PSpice>Bias Point> (. 8).
, ,
Delete. , ,
.

18

1. , RLC
. ,

. 8.

, (. 9).
9.
(Screenshot), .

. 9.

Alt+PrScr, .

19

1. , RLC
. ,

. ,

10. (Simulation
Settings) 1 Output File Options Calculate
small-signal DC gain (.TF). From input source name ( ,
). To Output variable
(
,
). . 10.
11. . 2
12. (Circuit file). PSpice A/D
File>Open,
\< >-PSpiceFiles\ < >\ < >\
*.cir.
.

. 10. .

OrCAD Capture ,
, ,
, (
) *.sim ( ). (Netlist file) ,
, .
PSpice A/D , *.cir.
, . .

20

1. , RLC
. ,

13. , . . 11.
1 .
7 10 , .
.LIB (library) . nom.lib
.
13 15 .
.TF
(Transfer Function) , .
.PROBE Probe,
( Bias Point, Probe
).
.INC (include)
, Netlist SCHEMATIC1.net .
1 ** Profile: "SCHEMATIC1-post" [ C:\OrCAD_Data\test-pspicefiles
** \schematic1\post.sim]
2 ** Creating circuit file "post.cir"
3 ** WARNING: THIS AUTOMATICALLY GENERATED FILE MAY BE OVERWRITTEN BY
SUBSEQUENT SIMULATIONS
4
5
6
7
**
8

*Libraries:
* Profile Libraries :
* Local Libraries :
* From [PSPICE NETLIST] section of C:\OrCAD\OrCAD_16.0\tools\
PSpice\PSpice.ini file:
.lib "nom.lib"

9 *Analysis directives:
10 .TF V(I_I1) V_V1
11 .PROBE V(alias(*)) I(alias(*)) W(alias(*)) D(alias(*))
NOISE(alias(*))
12 .INC "..\SCHEMATIC1.net"
13
14 .END

. 11. (Circuit file)

.END .
Bias Point
.
, * , . , . .

21

1. , RLC
. ,

PSpice A/D
. PSpice A/D
*.cir , *.net
*.sim ,
.
,
, ( ). , , .. . , *.net.
, *.net
, OrCAD Capture.
*.sim *.cir
OrCAD Capture, PSpise A/D.
14. (Output file). PSpice A/D View>Output File
(. 12).

. 12.

, . 12. *.out ,
.
,
, .TF.

22

1. , RLC
.

15. , .

, (. 13).
**** SMALL-SIGNAL CHARACTERISTICS
V(I_I1)/V_V1 = -2.500E-01
INPUT RESISTANCE AT V_V1 = 4.000E+01
OUTPUT RESISTANCE AT V(I_I1) = 2.750E+01

JOB CONCLUDED
**** 12/02/10 00:34:15 ******* PSpice 16.0.0 (July 2006) ****** ID# 0 *
** Profile: "SCHEMATIC1-post" [ C:\OrCAD_Data\test* pspicefiles\schematic1\post.sim ]
**** JOB STATISTICS SUMMARY
Total job time (using Solver 1) = .02

. 13. (Output file)

PSpise A/D,
*.cir *.out, [11, 17, 18].
.

16. . 3 .
VAC IAC
( ),
, . .
( ), ().
,
(
PSpice, 1010 ).
VAC IAC , .
17. . 3
18. AC Sweep . , . 14.
: Linear , Logarithmic
.
(Total Points), (Points/Decade(Octave)). Start Frequency ,
0. End Frequency .

23

1. , RLC

. 14. . AC Sweep

19. .2
20. (Output File) 4 (Analysis directives).
.AC.
21. .
, .

21.. Add Traces. PSpice A/D Trace>Add


Trace, Insert (. 15).
OrCAD 16 ,
.

. 15. Add Traces


Probe PSpice A/D.

24

1. , RLC

21.. Add Traces ( )


Trace Expression
(. 16), , ( )
( ).
Add Traces
. ,
Probe .

. 16. Add Traces

AC Sweep
, . AC Sweep
Probe .
Trace Expression Add Traces -
Probe, . , ,
. ,
V(N1)/V(N4) N1 N4,
, .
R IMG .
Probe ABS (absolute value)
M (magnitude) , : V(N1)/V(N4), M(V(N1)/V(N4)), ABS(V(N1)/V(N4))
SQRT(PWR(R(V(N1)/V(N4)),2)+PWR(IMG(V(N1)/V(N4)),2)) . SQRT , PWR , .

25

1. , RLC

21.. ,
(Simulation Settings) , ,
, , ,
.
Simulation Settings PSpice A/D, (. 17) Simulation>Edit Profile.

21.. Simulation Settings, Probe Windows


Last plot Show (. 18)
.

21.. , .
PSpice A/D,
(. 17)
Simulation>Run.

. 17. Simulation Settings ( Edit Profile)


( Run) PSpice A/D

. 18. Simulation Settings.


Probe Window

26

1. , RLC

, Trace Expression, Show Last plot .


21.. ( ) (. 19).

. 19. .
Axis Settings

21.. .
(Axis Settings). Plot>Axis Settings,
,
( Settings) (. 19).
Axis Settings X Grid Y Grid Minor
Grids None (. 20).

21.. .
(Trace Properties). ,
(. 21). Properties.
Trace Properties :
, .
.
.

27

1. , RLC
.

. , - .

. 20. Axis Settings.

. 21.

21.. . Window>Copy to Clipboard


( ), Foreground change white to black ( ),
OK (. 22). (Ctrl+V
Shift+Ins).
, , , ,
, (. 23). , .

28

1. , RLC
.

. 22.

. 23. ,

, MS Visio, Illustrator, Corel Draw, Inkscape . .


.

22. .

22.. . Trace Expression Modify Trace ,


(. 24).

29

1. , RLC
.

. 24.

Modify Trace Add Traces . Add


Traces .

: P(I(C1)), P(I(C2)), P(I(L1)).
, . ,

. ,
, /2 /2, , .
Probe
P( ), phase . ( 0) (degree).
0, , .

22.. . 5
.


,
- .

30

1. , RLC
.

Probe G( ), G group delay. G



d d , .
23. .

23.. .

Trace Expression Modify Trace ,
P G (. 25).

. 25.
Trace Expression Add Traces

23.. .5
.

- , ,
. ,
,
( )
0 , .
, X
, Y .
PSpice A/D, AC Sweep, Probe
, X , Y
, Add Traces .

X, Y.
24. PSpice A/D . Window>New Window
(. 26). PSpice ,

Window.

, , -

31

1. , RLC
.

, .. ,
.

. 26. PSpice A/D

25. ( ) . Plot>Add Plot To Window



(. 27).
PSpice A/D
, X () .
26. X.
, , Plot>Unsynchronize X Axis (. 27).
,
SEL>> (. 27).

. 27. .
X

32

1. , RLC
.

27. .

27.. , X.
27..1. (Axis Set6
tings) . Axis Settings X
Axis Axis Variable (. 28).
27..2. X Axis Variable Trace Expression Frequency ( , ), . 29.

. 28. X Axis Variable. X

Probe R( ), real
, . R
(, . .).

. 29. X Axis Variable. X

33

1. , RLC
.

X Axis Variable Add Traces, , Modify Trace,


, ..
X.
27..3. . 27..1 27..2 ,
X .
PSpice A/D, , X (. 30).

. 30. PSpice A/D

27.. Y.
27..1. ,
, Add Traces. 7
27..2. Add Traces Trace Expression ( , ) (. 31).
Probe
IMG( ), imaginary
.
27..3. . 27..1 27..2 .

. 31.
Trace Expression Add Traces

PSpice A/D,
, (. 32).

34

1. , RLC
.

. 32.

. 33.
Inkscape

, PSpice A/D
, X. , . 33.

27.. .5

35

1. , RLC
.

28. . 4 .
VPULSE
IPULSE ( ), , . 4.
4
PULSE

V1 (I1)
V2 (I2)
TD
TR
TF
PW
PER

0
1
0
1n
1n
2
3



(Time Delay)
(Time Rise)
(Time Fall)
(Pulse Width)
(Period)

VPULSE, IPULSE , , , ,
,
.
( ). , PSpice ,
, , .
, , , , . .
.
PULSE
TR+PW+TF. TR TF , PSpice 1%
.
29. .3
30. Time Domain
. , . 34.
Run to time , Start saving data after
, Maximum step size
.

36

1. , RLC
.

1000 .
2% , . .
50 ,
.

. 34. . Time Domain

31. Probe Window Simulation Settings


Last plot.
, Probe
.
, ,
, : AC_Sweep, Time_1 . .
32. .2
33. (Output File)4 (Analysis directives).
34. .

34.. Add Traces.7

34.. Add Traces Trace Expression


(. 35), , .

. 35.
Trace Expression Add Traces

34.. ,
, (Simulation Settings) 8 .
, . 9

37

1. , RLC
.

, , .
(. 36) 200 .

. 5 9 ,
106 , 100 .

34.. , , .

34.. .5

. 36.

, , ,
.
.

-
,
.
, g t h t , g t , h t , Probe .

( )
(
).

38

1. , RLC
.

,
.
Probe D( ), D derivative .
,
. - , ,
1. PSpice , .
35. .

35.. .
Delete.

35..
, : V(N1)D(V(N1)) ,
I(L1)D(I(L1)) .
- , ( 1 /, 1 1 ), . ,
(
),
.

35.. .
6 (Axis Settings). X Axis
Data Range User Defined ( ) X 2 (. 37).

. 37. X Axis Settings

39

1. , RLC
.

Probe
PSpice Capture. 106 , ,
103 , m. PSpice
.
, Y .

35.. .5


, : . . 5.
.
. .

, , ( , , ),
( (. . 5)),
OrCAD Capture,
, , , , .
5

I R1 ,
I R2 ,
I C1 ,
I C2 ,
I L1 ,
I E1 ,
I E2 ,
I Y1 ,
U A1 ,

R ,
R ,

PSpice

40

1. , RLC

1. ?
2. ?
2. , ?
3. ? .
4. ?
5. ?
6. ?
8.
(PSpice)? PSpice.
9.
(PSpice)? PSpice.
10. VPULSE IPULSE (PSpice).
11. VAC IAC (PSpice).
12. , ?
13.
.
14. ,
?
15. ?
16. , ?
17. OrCAD?
18. 52003-2003.
19. PSpice.
20. - - .
21. , PSpice , ?
22. .
23. , ,
?
24. PSpice ?
25. PSpice ?

41

2

spice : NXP
Semiconductors, ON Semiconductor Diodes Incorporated.

: *.lib spice- ,
,
; ,
, spice-.


Model Editor.
spice-
OrCAD .
- .

() , p-n- , , , .
,
, , , .
, , .
( ),
( ),
. ,
,
. , ,
. , ,
, , -

42

2.

, , , .
n-p-n ,
p-n-p-, .
. n-p-n- p-n-p- ,
.

, , . , . : (),
() ().

, P . . .2.

,
. ,
.
:
, ,
( ), ,
( ).
() ,
( ).
, ,
: , , .
. 38, , - ( ).
PSpice -, 50 . , -, . AC Sweep , - .

43

2.

. 38. -
( )

,
,
().
, .
, . ,
, . ,
. , , ,
. .
I ,
, ,
U , .
PSpice
DC Sweep . DC
direct current .
DC Sweep (, , ) ,
, , . -

44

2.

, .
. .
, I , U ,
. . 39.

. 39.

I 2 I 0 , E , ,
( ) P. I 0 U 0 .
,
, . . ,
, ( . 39 U m
I m ), P .
I m , U m .
, U 0
( 0,50,8 ). , , ,
. R ,
, . . -

45

2. . 1

. , 180o .

() , () .
. , . :
K U 22 U 32 U 42 K U 1 ,
U1 , U 2 , U 3 . . . , .
, OrCAD , Time Domain.
() , . ,
, .
( ) :

P P0 0,5 I mU m P0 ,
, P0 , P
.
. 1

.
.
. [13, 14].

.
,
, ( 2). spice-
(datasheet) . spice- .

46

2. . 1

. 1

1. spice- PSpice Model Editor


(*.olb).
2.
, . ( 2) , ( I , I 0 , U , I 0 , U 0 ),
h21 h22 .
3.
, (U 0 ), h11 h12 .
. 1

Model Editor

1. OrCAD PSpice
Model Editor.
OrCAD PSpice Model Editor ( )
spice- ,
, , . Model Editor
spice-
() , .
2. spice-
. File>Open, File>Save As. Windows , ,
spice- ( *.lib).
3.
( *.olb).

3.. Model Import Wizard ( ).


Model Editor File>Model Import Wizard [Capture] (. 40).
Spice- , spice-

( .MODEL ),
( .SUBCKT ).
.MODEL
-. , .

47

2. . 1
Model Editor

, .SUBCKT
,
, . ,

.

. 40. Model Editor

3.. Specify Library *.lib *.olb, , (. 41). .

. 41. .

48

2. . 1
Model Editor

3.. Associate/Replace Symbol Associate Symbol ( ) (. 42). .MODEL, , , . 3..

. 42. .

3.. Select Matching (. 43).


modeled.etc : \OrCAD\tools\capture\library\pspice\.

. 43. .

modeled.etc . .

49

2. . 1
Model Editor

3.. Matching Symbols (p-n-p n-p-n) (. 43). View Model Text ( )


(. 44).
.

. 44. .

3.. Define Pin Mapping


Save Symbol (. 45).
(. 43)
(. 44).

. 45. .

: Q<> < > < > < > < >.


,
(. 46)

50

2. . 1

. 46. .

3.. . (Log File), , OK


Model Editor.

4. OrCAD Capture (CIS).


5. (Analog or Mixed A/D).
6. *.lib *.olb .

6.. Simulation Settings.1

6.. Configuration Files Libraries


Filename (. 47).

6.. . Add to Design (. 47).

. 47. *.lib

OrCAD 9.2 Stimulus, Library Include


Simulation Settings.

51

2. . 1

Add as Global .
Add to Design .
Add to Profille .
Library
.LIB.
, ,
, .
PSpice : ERROR - Model < > used by Q_Q1 is undefined.
Include,

.INC.

6.. (Place Part).


Add Library (. 48) *.olb.

. 48. *.olb

Place Part
spice- .

7.
.

7.. (. 49).
.

52

2. . 1

. 49.

7.. Ib,
- Vce. .

7.. .3

7.. DC Sweep.

7.. Options Primary Sweep


.
(Primary Sweep)
Vce, (Start Value) .
(End Value) U max - ( , datasheet Maximum Ratings,
Collector-Emitter Voltage), (Increment) 10 . . 50.

. 50. Primary Sweep.

DC Sweep , , , (, ), .

53

2. . 1

7.. Options Parametric Sweep .


(Parametric Sweep) Ib, (Start Value)
. (End Value) 1 ,
(Increment) 100 . . 51.

. 51. Parametric Sweep.

- , Secondary Sweep, , , . . - .

7.. Probe Window Last plot.

7.. .2

7.. .
Add Traces.7 Trace Expression IC(Q1)
.
, , .

7.. , U max I max (


datasheet ).
4

7.. (Output File) (Analysis directives).


8. . Add Traces7 Trace Expression
Pmax/V_Vce, Pmax
datasheet .

54

2. . 1

9. . Plot>Label>Line (. 52).
V_Vce= 80%U max
(V_Vce), Y.

. 52.

Line, .


Delete.
10.
( Ib), . 53 ,
.

. 53.

11. I , I 0 , U , I 0 , U 0 .
.
, .
11.. . Trace>Cursor>Display

(. 54).

55

2. . 1

. 54.

(Probe Cursor) 1 2 (. 55).


, .
11.. .

(. 55),
1, 2.
Ctrl+ Ctrl+ ( 1)
Ctrl+Shift+ Ctrl+Shift+ ( 2).
11.. ,
( U 0 I 0 ), Plot>Label>Mark
(. 55).
, .
U 0 I 0 .
1
, 2 , Shift+ Shift+.
,
Zoom Area Zoom In, Zoom Fit, Zoom Out .
, .

56

2. . 1

. 55.

,
.5

11.. Probe Cursor


I U .
I U .

11.. I 0 .
, Information (. 56).
.

. 56.

57

2. . 1

12. Probe Cursor



h- ( h21 h22 ).
h- . 57.

. 57. h-
( h21 , h22 )

Probe Cursor X Y.

13.
.

13.. (Analog or Mixed A/D), spice- .

13.. (. 58).
.

58

2. . 1

. 58. (OrCAD)

13.. - Vbe, - Vce. .

13.. .3

13.. DC Sweep.

13.. Options Primary Sweep


.
(Primary Sweep) Vbe, (Start Value)
0,5 . (End Value) 0,8 ,
(Increment) 1 . . 59.

. 59. Primary Sweep.

13.. Options Parametric Sweep .


(Parametric Sweep) Ve, (Start Value)
10 % U 0 . (End Value) 10 %
U 0 , 10 % U 0 . . 60.

59

2. . 1

,
. , h-.
13.. Last plot.

. 60. Parametric Sweep.


( U 0 11,8 )

13.. .2

13.. . Add Traces.7 Trace Expression


IB(Q1) .
,
.
13.. (Output File)4
(Analysis directives).
14. U 0 .
( Vbe)
, (
I 0 . 11..) . 61.

14.. .10

14.. , 11 (
U 0 I 0 ). U 0 .
, .
.5
15. Probe Cursor
h ( h11 h12 ). . 62.

60

2. . 1

. 61.

. 62. h-
( h11 , h12 )

h12
, .

61

2. . 2
.

. 2
. - .
. 2
1. :
*.lib *.olb
PSpice Model Editor;
,
.
2.
. ,
.
3. , .
4. ( 1 5 )
( 500 1000 ),
1 f T 1 , U .
.
5. ,
U (t ) = U sin (2p f t ) , f ,
. 3-4 . .
6. 64
.
1 ,
10 .
. 2

1. OrCAD Capture (CIS).


2. (Analog or Mixed A/D) Capture
, .

62

2. . 2


VPULSE, VDC.
.
3. (off-page connector). Place>Off-Page Connector (. 63). Place Off-Page
Connector .
, : in (), in1 ( 1) supply ().

. 63. (off-page connector)

,
. , , , .
4. out out1. 12
5. VPULSE
.

5.. ,
Edit>Properties Ctrl+E (. 64).
(Property Editor)
,
.

5..
Pivot (. 65).

63

2. . 2

Pivot
.

. 64.

. 65. .

5.. , . 6.
(AC Sweep). spice- VAC VDC , ,
.
6
VPULSE
AC
U

V1
0

V2

TD
0

TR
1

TF
1

PW
2

PER
3

64

2. . 2

5.. VPULSE AC.



Display, Display Properties Name and Value . 66.
6.
GAIN .
GAIN OrCAD
. ( OrCAD G), GAIN , .
( OrCAD F), GAIN , h 21 .
OrCAD , . 67.

. 66.

. 67 () , - , . 68.

7. .3
8. AC Sweep .
0.1 , 10 ,
50.
9. Last plot.
10. .2
11. ,
. 13
,
.

65

2. . 2

. 67. (OrCAD) () ()

. 68. - (OrCAD)

66

2. . 2

PSpice ( )
,
-
, .
12.
.

13. .
Add Traces7 Trace Expression
, V(OUT)/V(IN) V(OUT1)/V(IN1).
14. . ,
(Simulation Settings)8 , , , . , .9
15. .
,10 Max 11
(. 69).

. 69.

16. .5
17. . Add
Traces 7 Trace Expression , I(C2)/I(C1) I(C4)/I(C3).

67

2. . 2
.

18. . 15 16.
19. .
Add Traces Trace Expression .
,
, ,
20. . 15 16. 4
21. (Output File) (Analysis directives).
.

22. .3
23. Time Domain.
24. . 4
, 500 .
25. Last plot.
26. .2
27. .
Add Traces.7 Trace Expression , V(OUT) V(OUT1).
28. . , (Simulation Settings)8 , , .9

. 70. . 1000

68

2. . 2
.

29.
.

. 70.
30. 5 .
4
31. (Output File)
(Analysis directives).
.

32. Simulation Settings8


. 4 , 5 .
33. . 26-31.

. 71.

. 71. . 1

34. . 5 .
VSIN. , . 7.
VSIN , , -

69

2. . 2
.


.
7
VSIN

VOFF
VAMPL
FREQ

U
f

( )

. , ,

35. .3
36. Time Domain. Start saving data after . 29, 3-4
, ,
25-50 .
3-4 , . 25
.
37. Last plot.
38. .2
39. .
Add Traces. Trace Expression ,
V(OUT) V(OUT1).
40. Y . Plot>Add Y
Axis Ctrl+Y (. 72).
1. ,
2, 3, 4 . .
Plot>Delete Add Y.
41. Y 2.
>> (. 72).
42. . Add
Traces. Trace Expression ,
V(IN).
43. 10
,
.
44. 5 .

70

2. . 2
. .

. 72. Y

45. PSpice A/D 14 . 39-44 .


4
46. (Output File) (Analysis directives).
.
.

47. .3
48. Time Domain. Start saving data after . 29, 64 , ,
100-200 .
PSpice A/D, .
() PSpice A/D
,
. , , .
, -

71

2. . 2
. .

, X
Axis Settings, Use Data, Restricted (analog).
1 T , .
49. Last plot.2
50. .
51. spice- . Add Traces 7 Trace Expression
, V(OUT).
52. . Trace>Fourier (. 73).6
, Fourier
Processing Options X Axis Settings.
53. Y , 100 (. 73). , X.
, , , ..
.

. 73. PSpice A/D

54. 10
( 10 .) 1 , .11 .
. 74.

72

2. . 2

PSpice A/D , .
, .FOUR.
,
, .
.FOUR OrCAD Simulation Settings, Time Domain.
Output File Options, (Transient Output File Options) Perform Fourier Analysis,
( ),
( 9) . .FOUR
1 f , f
.

. 74.

55. (Output File) 4 (Analysis directives).


.

.

73

2. . 2
.

, , (
, , ),
OrCAD Capture,
( (. . 5)),
, , .

1. - .
2. .
3. ?
4. ?
5. .
6. PSpice?
7. ?
8. PSpice , ?
9. .
10. VSIN.
11. OrCAD spice-?
12. OrCAD ?
13. ?
14. , ?
15. Probe,
h-?
16. , spice- . , .
17. OrCAD ?
18. ?
19. OrCAD spie- ?
20. , PSpice ?

74

OrCAD.
.

, , ,
. , ().

.

. .

,
. . , ,
( ), ( ).
.
. ,
,
. ,
, ,
. , , , . , , -

75

3.

, .
,
.
, .
, , .
, ,
, .
, . .
( ). .
,
( , ,
) (
, ).
.
.
, . , , ,
, ,
(, p-n-).

, . , ,
.
, . . ,
: , (, ), , .
.
, ,
, , .
.
.
, .

76

3.

( ).
.
-
. -

.
, :
, .
,
(, , . .), , .
. 1 f -, ,

f , 0,8-1,2.
106 .
, , ,
- . 1 f - ()
: ; ; -; .
, 1 f -
, ,
.
, 1 f - .
, .
1 f -
()
.
PSpice (AC Sweep).
.
, (

77

3.

). ,
,
.
.
PSpice
, :
, , , ,
.
;
.
PSpice , .
PSpice
,
. ,

( ) .
8
(PSpice)

NFIB(device_name)
NRB, NRC, NRE
NSIB, NSIC
NTOT(device_name)


-
( )
,

/.
. /
,
. ,
1, 1 , /
1000:1, 60 .
, /, . ,
75 . , , / 90 . (6065 ) . / 10 .

78

3.

.
.
. [7, 13, 14].

.
3, ( 2)
( 3),
2 2.
,
o
20 C , . 9.
9

,
, %

1, 8, 15
100
5

2, 9, 16
50
10

3, 10, 17
20
15

4, 11, 18
15
20

5, 12, 19
10
25

6, 13, 20
5
30

7, 14, 21
1
35

1. OrCAD Capture *.lib *.olb PSpice Model Editor.


2. .
, /
.
3.
, ,
,
.
4. /
. () 0,0005, () 0,009.
, , , .
5. /, .
.

79

3.

1. OrCAD Capture (CIS).


2. (Analog or Mixed-Signal Circuit Project) Capture , , .
VAC, VDC.
3. .
VCC CAPSYM.OLB. Place>Power, (. 75) F . Place Power VCC ( )
. , : in
() supply ().
out.12
, 2, , .
,
.

. 75. VCC

, .

80

3.

4. .3
5. AC Sweep, .
Noise Analysis Enabled (
). Output Voltage ( ) .
I/V Source (, )
. . 76.

. 76.

6. .2
7. . Add Traces.
Trace Expression
.
8.
.

8.. Y. 15

8.. Add Traces 7 Trace Expressions


V(ONOISE) (. 77).
V(ONOISE), out noise ,
.
ONOISE ,
NTOT(ONOISE) , 2 , V ONOISE

NTOT ONOISE ,

81

3.

8.. .
. 78.

. 77.

Simulation Output Variables


Add Traces
(. 77).

. 78.

9. / . Add Traces. Trace Expressions DB(V(OUT)/V(ONOISE)).


Probe DB( ), DB decibel .
5
10. .

82

3.

11. . . 79.

11.. PSpice .14

11.. Add Traces.7 Trace Expressions


NFIB(Q1) NRB(Q1) NRC(Q1)
NRE(Q1) NSIB(Q1) NSIC(Q1).

11.. Y .16

11.. ,
( 1030 ) .

-.

11.. .

11.. PSpice .14

11.. Add Traces.7 Trace Expressions


,
, , NTOT(Rb) NTOT(Rk) NTOT(Rn) NTOT(Rvn).
PSpice .

. 79.

83

3.

11.. Y .16
11.. .5
12. (Output File) 4 (Analysis directives).

13. R Cbreak Rbreak


BREAKOUT.
OrCAD C R . OrCAD (
16.0 ) Cbreak Rbreak,
.
14.
. 4 .

14.. , Edit>Pspice Model


Edit Ppice Model (. 80).

14.. (PSpice Model Editor),


, , TC1=0.0005
TC1=0.009 , . . 81.

14.. .

.
TC temperature coefficient, 1
.


1.
.
Temperature (Sweep)

. 80.

15.
.

15.. .3

15.. AC Sweep,
.

15.. Options Temperature

84

3.

. Temperature (Sweep)

(Sweep) . 4 ,
. . 82.

. 81. spice- Cbreak

PSpice ,
PSpice A/D 27o C .
Run the simulation at the temperature
.

. 82. (Temperature (Sweep))

15.. .2
, Probe

15.. . Add
Traces.7 Trace Expression
. .5 . 83.

15.. .5
16. PSpice A/D .14
17. / . Add Traces.7 Trace Expression
/. .5

85

3.

. Parametric Sweep.

. 83.

18. (Output File)4 (Analysis directives).


. Parametric Sweep.

19. .8
20. Options Temperature (Sweep) Parametric Sweep. , . 5. ,
. . 84.
. 84 50 150o C
10 .
21. .9

. 84. (Parametric Sweep)

22. PSpice A/D .14


23. (Performance Analysis).
Trace>Performance Analysis (. 85).

86

3.

. Parametric Sweep.

X
.
,
: , , - , ..
- . , , ,
, . .
24. .
Add Traces.7 Trace Expressions Max(V(OUT)/V(IN)) .

. 85. (Performance Analysis)

Add Traces, , Measurements


(. , ) , OrCAD 9.2
Goal Function. Functions or Macros ,
:
.
.
Max
.

87

3.

. Parametric Sweep.

Max(V(OUT)/V(IN))
, , .
25. .5

. 86. (Performance Analysis)

26. PSpice A/D .


27. (Performance Analysis).17
Trace,
(Performance
Analysis Wizard).
28.
. Add Traces.7 Trace Expressions
Bandwidth(V(OUT)/V(IN),3) 3 .
29. .5
30. PSpice A/D .14
31. (Performance Analysis).17
32. / . Add Traces.7 Trace Expressions YatX(DB(V(OUT)/V(ONOISE)),10k) ,
Y X.
YatX / 10 . 10 .
33. .5
34. (Output File)4 (Analysis directives).

88

3.

. . .

. ,
. ,
.
,
.

, , (
, ), ),
OrCAD Capture, ,
.

1. ?
2. .
3. ?
4. PSpice
?
5. , OrCAD ?
6.
PSpice?
7.
?
8. ?
9. PSpice?
10. PSpice ?
11.
BREAKOUT.OLB?
12.
(Performance Analysis)?
13. PSpice ?
14. ?
15. ?
16. PSpice ?

89

4
,


OrCAD.
, - ,
OrCAD .

.
, . ,
, , ( , , . .).
,
. .
,
.
, , , ,
. ,

.
, .

.

90

4. , ,

:
, -
,
;

;
, .
( ) y j xi :
Aji

dy j

dxi

, xi .
:
X i 0 dy j
,
S ji 0
Y j dxi

X i 0 ;

Y j 0 ;
dy j dxi .



, . j- i- Aji S ji .

. n , dxi X i 0 xi , .
S ji , . xi
dxi . ,
dxi . -

0, 25 X i0 dxi 0,25 X i0 .

91

4. , ,



.
, .
,
,
.

, , .
, . , ,
.

: (Low) (Hi), ..
.
(Low Hi) :
;
;

.
,
. , , ,
, .
-
,
-.
,

.
- :
1.

92

4. , ,

,
.
2.

( , . .).
3. 1 2. .
-
, 1000 1 %, .
4.
. , , , ,
. .
5.
.
- OrCAD
PSpice A/D AC Sweep, DC Sweep Time Domain.
, . , Bias Point.
- PSpice Advanced Analysis
PSpice A/D .


, .
,
( ) ,
. .

:
;
;
() , , -

93

4. , ,

, .
,
, .
OrCAD PSpice
Advanced Analysis.

.
.
. [1, 2, 9, 11].
.

.
, 2
2.

1. OrCAD Capture *.lib *.olb PSpice Model Editor.


2. .

. (. . 10 11).
: ,
3. , ,
. 10% .
10
,

R_R1 ()
R_R2 ()
C_C3 ()
C_C4 ()
BF_ Q

13,5
26
1
1
229,798

dxi

K 0 ,

K 0 ,

dK 0 ,

1,35
2,6
0,1
0,1
22,98

36,191

36,208

0,017

S K0 ,i
4,053-03

94

4. , ,

11

R_R1 ()

13,5

xi

1,35

f ,
987,15666

f ,
986,1674

d f ,
0,98926

Sf ,i
0,009893

2.
. ,
: 10 %, 25%.
2.1. -.

, ,
() 200.
-.
.
2.2. .

. Hi ( ) Low ( ).
.
3. , 2 PSpice Advanced Analysis
( OrCAD 9.2 PSpice Optimizer). I 0 , U 0 I 0 .

1. OrCAD Capture (CIS).


2. (Analog or Mixed A/D) Capture
, , .

95

4. , ,

VSIN, VDC.
, 12
. in, out.
3. VSIN: 0, 0,
, , AC U
(. . 5. 5. 2, 2).
5. .3
AC Sweep, .
6. .2
7. . Add Traces.7
Trace Expression
. .5
8. , 3.

8.. Evaluate Measurement ( ). Trace>Evaluate Measurement, (. 87).

8.. Trace Expression MAX(DB(V(OUT)/V(IN))).

. 87.

8.. Evaluate Measurement.18


8.. Trace Expression BANDWIDTH(V(OUT)/V(IN),3).
Evaluate Measurement (. 88) (. 87),
Add Traces, , , . OrCAD 9.2,
Trace>Eval Goal Function.
OrCAD 10.5

(. 89), , View>Measurement
Results (. 89).

96

4. , ,

. 88. Evaluate Measurement.

8..
.

. 89.

,
Tools>Options,

97

4. , ,

Probe Settings Display Evaluation. ,


, (. 90).

. 90.

9.
.

9.. - 10%. . 6, 7, 8. (. . 10 11).


Simulation Settings, Probe Windows Last plot, .

9.. . 9.
10% . . 6, 7, 8.
(. . 10 11),
.

9.. . 9. 9. ,
.
9..1. spice- BF
.
9..2. spice-
, Edit>Pspice Model
Edit Ppice Model.
9..3. (PSpice Model Editor), BF spice-. .

98

4. , ,

10. .
11.
10%.

Ctrl, ,
Edit>Properties (Ctrl+E). ,
TOLERANCE 10 % (. 91).

. 91. TOLERANCE

12. .

12.. , Edit>Pspice Model


Edit Ppice
Model.

12.. spice- , BF= DEV=25% (. 92), .

. 92. spice-

- PSpice A/D
.

99

4. , ,

, DEV, . TOLERANCE
DEV ANALOG.OLB.
BREAKOUT.OLB spice- , DEV.

13. .

13.. .3
AC Sweep, .

13.. Options Monte Carlo/Worstcase, Worst-case/Sensitivity. (Output variable


V(out)) (. 93).

. 93.

13.. Hi.

Worst-case/Sensitivity More Settings, Monte Carlo/Worstcase Output File Options Worst-Case direction Hi.

13.. .2

13.. . Add Traces.7 Trace Expression


.
.5

13..
( )

100

4. , ,

.
. . 94.

13.. .5

13.. Low
. 13., 13., 13., 13..

. 94.

13.. (Output File)4 (Analysis directives).


(Output variable),


:
0
0
dxi X i RELTOL , X i ,
RELTOL ,
Simulation Settings 0,001. .

, TOLERANCE (DEV).
-

14. -.

14.. .3
AC Sweep, .

101

4. , ,

14.. Options Monte Carlo/Worstcase, Monte Carlo.


(Output variable V(out)),
(Use distribution Uniform), ()
200 (Number of runs 200). . 95.

. 95. -

Random number seed


, 1
32767. , 17533.
- .
Output Variable ,
Use distribution
:
Uniform (1,+1);
Gauss () (1,+1) =0,25.
, , Distributions.

14.. .2
- : xi X i 0 1 , X i 0
, ,
TOLERANCE (DEV), 1, 1 ,
.

102

4. , ,

14.. . Add Traces. Trace Expression


.

14.. , . Tools>Options,
Probe Settings Use Symbols Never (. 96).

14.. .5

. 96. Probe Settings.

14.. .
14..1. PSpice A/D .14 (Performance Analysis).17
14..2. Add Traces.7 Trace Expressions MAX(DB(V(OUT)/V(IN))).
14..3. ( ).19 Add Traces.7 Trace Expressions
BANDWIDTH(V(OUT)/V(IN),3)).

14.. .5
. 97.
, -:
n samples , n divisions ; mean,

103

4. , ,

maximum, minimum, median ( ), , ; 10th%ile, 90th%ile ; sigma .

. 97. -

14.. (Output File) (Analysis directives).


.

15. , 2
I 0 (. 98) U 0 I 0 .
U 0 I 0 ,

.
16. .3
Time Domain. Run to time Start saving data after ,
. VAMPL 0.

104

4. , ,

. 98.

17. .

17.. (
).19

17.. ,
(. 99).

17.. 10
11 . ,
Y (. 99). .

17.. .

. 99.

105

4. , ,

PSpice Advanced Analysis

18. MAX , VC IC.18


OrCAD
,
, . OrCAD
Bias Point - ,
.
PSpice Advanced Analysis

19.
. 15.

19.. PSpice Advanced Analysis (Optimizer).


PSpice>Advanced Analysis>Optimizer (. 100).

. 100. PSpice Advanced Analysis

19.. ,
Parameters Click her to import a parameters (. 101).
Parameters Selection ,
, , (. 101).
Parameters (Original),
(Min) (Max) . Min Max
, , : Min 10%
Original, Max Original10. Min Max
, .

106

4. , ,

PSpice Advanced Analysis

. 101. PSpice Advanced Analysis.

19.. Specifications
Click her to import a measurements (. 102). Import measurements (. 102).

. 102.

107

4. , ,

PSpice Advanced Analysis

19.. Max Min (. 103) Specifications


, ,
, . 15.

19.. (. 103).

. 103.

. 104.
,

. 103 , p-n-p : U 0 17 , I 0 30 (. 103). ,

108

4. , ,

,
.

19..
Modified Least Squares Quadratic (LSQ) Discrete (. 104).
1% (. 104).
Modified Least Squares Quadratic . Discrete ()
, .

19.. (. 103).

19.. PSpice Advanced Analysis (Optimizer).


.

20. OrCAD Capture


. Windows
.

. 105.
( )

109

4. , ,

. .

21. VAMPL U .
, , : (
. . 105),
. ( ).

. .
. , - .
, , - .
- .

, ,
OrCAD Capture, , , , (. . 10 11),
( PSpice Advanced Analysis)
.

1. ?
2. ?
3. , .
4. , .
5. -, .
6. PSpice -.

110

4. , ,

7. ?
8. ?
8. PSpice ?
9. , ?
10. OrCAD
?
11. OrCAD
?
12. OrCAD -?
13. PSpice ?
14. PSpice
-?
15. ?

111


1. : .
/ . . , . . , . . ,
. . . .: . ., 2000. 479.
2. : / . . , . . .; . . . . .:
, 1987. 386 .
3. . . / . . , . . . .:
, 2007. 128 .
4. . . : / . . . 2-
., . .: , 2006. 424 .
5. . . OrCAD 9.. OrCAD 10.. / .. , . . . .: -, 2008. 208 .
6. . . OrCAD. . /
.. , . . . .: -, 2005. 200 .
7. . : . .
/ . . .: , 1986. 399 .
8. . .

:
.
/
. . // . . . -. : ,
2001. 205 .
9. .
: . . / . , . .: , 1988. 560 .
10. . . OrCAD 10.5 / . . . .: -, 2008. 352 .
11. . .
: . . /. . ,
. . , . . . .: , 1990. 272 .
12. . OrCAD Pspice. : . .
/ . . .: ; .: , 2008. 640 .
13. . . .
: . . . . . / . . 3-
., . . .: . ., 1990. 400 .
14. . . :
/ . . , . . ; . . . . .: , 2008. 768 .
15. . . :
/ . . , . . . .: -,
2005. 320 .

112

16. . . PSPICE- / . . . .: , 2004. 208 .


17. . . : . / . . .
4- ., . .: , 2003. 575 .
18. . . P-CAD PSpice : 4- / . . .: , 1992.
19. . . OrCAD 9.2 / . . .
.: -, 2003. 528 .
20. . . : . . . . /
. . // : -, 2005. 51 . URL:
http://window.edu.ru/window/library?p_rid=28724. 25.02.2011.
21. . 2 . . 1.
: . . / . . . .
2- . . .: . ., 1976. 544
22. .
PSPICE: . . / . . .: , 2008. 336 .
23. : . 1 /
. . [ .] // . . . . - URL:
http://dvo.sut.ru/libr/eqp/i001eqp1/. : 25.02.2011.

113

1
1

114

10

11

12

13

14

15

16

115

17

18

19

20

21

22

23

24

116

2
, 2

. 2.

:
( );

;

. 2;
= 100 ;
U , = 80%U max ;
R = a () ;
U = b () ;
a ( 0, a = 10 ),
b .

117

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25


2PB709BRL
BC847CW
MPSW06
BCP68T1
MMBT3906
PMBT4401
PMBT6428
BSP16T1
2SC4617
2DD2652
BC807-40W
BCW33
NJT4030P
NJT4031N
ZXTN25012EFH
2PB709ASW
BCX70K
PZT2907AT1
BCP69T1
ZUMT718
BCW70
PMBT3904
PMSS3904
BCW69
ZTX449

NXP Semiconductors
NXP Semiconductors
ON Semiconductor
ON Semiconductor
Diodes Incorporated
NXP Semiconductors
NXP Semiconductors
ON Semiconductor
ON Semiconductor
Diodes Incorporated
NXP Semiconductors
NXP Semiconductors
ON Semiconductor
ON Semiconductor
Diodes Incorporated
NXP Semiconductors
NXP Semiconductors
ON Semiconductor
ON Semiconductor
Diodes Incorporated
NXP Semiconductors
NXP Semiconductors
NXP Semiconductors
NXP Semiconductors
Diodes Incorporated

118

3
, 3

. 3.

R b 100 ,
b .

2.

119

Capture
PSpice>Edit Simulation Profile.
Capture , F11 PSpice>Run.
3

PSpice>New Simulation Profile.


4
PSpice A/D
View>Output File.
5
Window>Copy to Clipboard, MO Word
6
Plot>Axis Settings .
7

, Insert Trace>Add Trace.


8
PSpice A/D
Simulation>Edit Profile.
9
PSpice A/D
Simulation>Run.
10

Trace>Cursor>Display.
11

Plot>Label>Mark.
12
, N Place>Net Alias.
13
, ,
PSpice>Bias Point>.
14
PSpice A/D Window>New Window.
15
Plot>Add Y Axis Ctrl+Y .
16

Axis Settings.
17

Trace>Performance Analysis.
18

Trace>Evaluate Measurement.
19
Plot>Add Plot To Window.
2

120