You are on page 1of 4

Instalacin de ThunderCache 3.1 paralelo a Mikrotik Es la versin thundercache 3.

1, que modifique hace un tiempo y ahora comparto con la gente del foro, tambin programe algunos plugins que ya no funcionaban y agregue otros nuevos, como sabemos Thundercache es un sistema de webcache que se caracterstica por guardar archivos de pginas web dinmicas y la estticas se encarga el squid. Para instalar el Thundercache primero se tiene que tener en cuenta que nuestra infraestructura de red este en optimas condiciones (que tenga buen througput) por que sino en lugar de mejorar seria perjudicial para nuestra red, tambin se tiene que tener en cuenta que el hardware a utilizar estea en exelente condicin y que sus componentes no sean de bajo nivel, como recomendacin minima tiene que ser una P4 de 3.0 Ghz , 2 Ghz de RAM, disco duro de 500 Ghz, esto varia de acuerdo con cuantos usuarios se va a utilizar. Para medir el throughput pueden revisar en esta parte http://www.peruhardware.net/foros/sh...ght=throughput

1.- Primero tenemos que instalar Deban, se puede descargar de este link. Cdigo: http://linorg.usp.br/debian-raiz/cdimage-unofficial/non-free/cd-includingfirmware/current/multi-arch/iso-cd/firmware-6.0.2.1-amd64-i386-netinst.iso Luego instalamos Debian como se muestra en el video (se debe de poner el IP 192.168.10.2) http://www.youtube.com/watch?v=aOAqNd0-fk8 Instalacin Debian 6 squeeze 2.- Instalamos el Thundercache en Debian para eso procedemos a ingresar los siguientes comandos. (tambien pueden utilizar putty u otro cliente ssh)

Cdigo: wget http://www.joemg.host56.com/tc/thunder31.sh chmod 777 thunder31.sh ./thunder31.sh Contrasea de Mysql: thunder31 Reiniciamos Debian con el commando: reboot 3.- Redireccionamos y priorizamos el trafico de Thunder en Mikrotik con las siguientes reglas. Cdigo: /ip firewall filter add action=accept chain=forward comment="Acepta thunder 3.1" disabled=no \ src-address=192.168.10.0/30 /ip firewall nat add action=dst-nat chain=dstnat comment="Redirect Thunder 3.1" disabled=no \ dst-port=80 protocol=tcp src-address=!192.168.10.2 to-addresses=\ 192.168.10.2 to-ports=3128 /ip firewall mangle add action=mark-connection chain=postrouting comment="THUNDER CACHE FULL(TC 3.\ 1) =======================================================================\ ===============================" content="X-Cache: HIT from Thunder" \ disabled=no new-connection-mark=thunder-connection passthrough=yes \ protocol=tcp src-address=192.168.10.2 add action=mark-packet chain=postrouting connection-mark=thunder-connection \ disabled=no new-packet-mark=thunder-packs passthrough=yes add action=mark-connection chain=postrouting comment="TOS 12 (TC 3.1)=========\ ==========================================================================\ ==================================" disabled=no dscp=12 \ new-connection-mark=proxy-hits passthrough=yes protocol=tcp src-address=\

192.168.10.2 add action=mark-packet chain=postrouting connection-mark=proxy-hits disabled=\ no new-packet-mark=proxy-squid passthrough=yes /queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \ max-limit=4M name="T-cache_hits" packet-mark=proxy-squid parent=\ global-out priority=4 queue=default add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \ max-limit=4M name=ThunderCache packet-mark=thunder-packs parent=\ global-out priority=4 queue=default esta regla es para si falla el thunder no se queden los clientes sin internet cdigo: /tool netwatch add comment= Redirect Thunder 3.1 disabled=no down-script=\ "/ip firewall nat set [find comment=\" Redirect Thunder 3.1\"] disabled=yes" \ host=192.168.10.2 interval=2s timeout=2s up-script=\ "/ip firewall nat set [find comment=\" Redirect Thunder 3.1\"] disabled=no" 4.- Entramos por el navegador web para ver el relatorio. http://192.168.10.2/thunder.php