You are on page 1of 10

271 Boson NetSim for CCNP Lab Manual

CCNP ADVANCED LAB 1


Single Site Network
Advanced Labs
Lab 1: Single Site Network
Objective
This lab will allow you to develop your ability to combine multiple technologies to create a network
infrastructure that is typical of a small to medium-size enterprise with a single site. You will use
your knowledge of VLANs, Layer 2 switching, Layer 3 routing, and dynamic routing protocols to
build this infrastructure.
Simulated Network Overview
You will be creating a network with one router, one switch, and four PC hosts. Two of the PC hosts
will be connected to one VLAN, and the other two PC hosts will be connected to a different VLAN.
The router will have a subinterface for each VLAN, and 802.1q trunking will be used to connect
each subinterface to the appropriate VLAN on the switch.
You will be able to combine and use skills learned in prior labs to build out this network.
Lab Topology
For this lab, your network design will include the devices shown in the Topology diagram below.
\ct Will leir Will llar| ccrltralicrs cr all 1eices. !le 1iarar rereserls lle NelMa ir lle
Simulator. To access each of the devices from within the Simulator, select the device name from
the appropriate menu in the Simulator. For example, to access P1R1, click the eRouters button
and select P1R1 from the drop-down menu.
P1R1
P1SW1
FastEthernet0/0.1 10.100.1.1 VLAN 1
FastEthernet0/0.20 10.100.20.1 VLAN 20
FastEthernet0/0.30 10.100.30.1 VLAN 30
Fa0/0
Fa0/1
Vlan 1 10.100.1.2 VLAN 1
P1PC1
10.100.20.4
VLAN 20
Fa0/2
P1PC2
10.100.30.4
VLAN 30
Fa0/3
P1PC3
10.100.20.5
VLAN 20
Fa0/4
P1PC4
10.100.30.5
VLAN 30
Fa0/5
272 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Command Summary
Command Description
congure terminal erlers lclal ccrltralicr rc1e
hostname host_name assigns a host name to a router or switch
show run 1isla,s lle rctler's cr sWilcl's rtrrir ccrltralicr
erase startup-cong erases lle slarlt ccrltralicr slcre1 ir N\RAM
ip address ip_address subnet_mask assigns an IP address and a subnet mask to an interface
vlan vlan_id name vlan_name creates and/or names a VLAN
show vlan displays VLAN information
interface type number erlers irlerace ccrltralicr rc1e
switchport access vlan vlan_id assigns a switch port to a VLAN
speed {10 | 100 | 1000 | auto | nonegotiate} sets the interface speed
duplex {auto | full | half} sels lle irlerace 1tle\ ccrltralicr lc tll, lal, cr atlc
show ip interface brief displays information for IP interfaces
interface type number subinterface_id creates a subinterface
encapsulation dot1q vlan_id sets the encapsulation method of the interface for 802.1q VLAN trunking;
alsc seciles lle \lAN lD cr Wlicl lle rares slctl1 le lae1
reload catses lle lOS lc resel ar1 relca1 ils slarlt ccrltralicr i reserl
switchport mode trunk ccrltres a lrtr| crl
switchport mode access ccrltres ar access crl
switchport trunk encapsulation dot1q sets the encapsulation method used for a switch trunk port to 802.1q
enable password enters privileged EXEC mode
exit exits the current mode
Note: Please be aware of the following when using the Grade Lab function in the Lab Navigator. If
you choose to use an IP addressing scheme other than that shown in the lab documentation, you
ra, lr1 llal ,ctr lal Will receie ra1ir errcrs. \ctr lal ra, slill trclicr ccrrecll, ir sile c
these grading errors.
Lab Tasks
!ask J: Prepar|rg t|e 0e|oes for 0or|garat|or
l. Ma|e stre lle ccrrecl lcclc, ar1 ccrltralicr lles cr llis lal are lca1e1. !lis slctl1
occur automatically when you select this lab from the Lab Navigator.
Z. Ma|e stre all rctlers ar1 sWilcles ir lle sirtlale1 relWcr| lae erl, ccrltralicrs.
What commands should you use to accomplish this?
______________________________________________________________
3. As per the Lab Topology diagram, change the host name of the router to P1R1, and change
the host name of the switch to P1SW1. What commands should you use to do this?
______________________________________________________________
273 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Task 2
A. Assigning IP Addresses to the PC Hosts
1. Use the Lab Topology diagram to determine the correct IP addresses and default
aleWa,s cr |l|Ol, |l|OZ, |l|OJ, ar1 |l|O1. Ocrltre lle ccrrecl l| a11ress,
subnet mask, and default gateway on each PC host. Use a 24-bit subnet mask
(255.255.255.0). Remember that the gateway for each PC host is the subinterface on
the router that is assigned to the VLAN of which the PC host is a member. Write down the
commands you use to accomplish this.
_____________________________________________________________
2. From the console of P1PC1, can you ping P1PC2? Why or why not?
_____________________________________________________________
3. From the console of P1PC1, can you ping P1PC3? Why or why not?
_____________________________________________________________
B. Assigning an IP Address to the Management VLAN on P1SW1
1. Use the Lab Topology diagram to determine the correct IP address for the management VLAN
on P1SW1. Assign the correct IP address to the management VLAN on P1SW1. Remember to
use a 24-bit subnet mask (255.255.255.0). Write down the commands you use.
_____________________________________________________________
Z. Rlal is lle rare ar1 lD c lle raraererl \lAN cr |lSRl
_____________________________________________________________
Task 3
A. Creating VLANs on P1SW1
1. Examine the Lab Topology diagram. How many VLANs will you need to create, and what
are lleir \lAN lDs
_____________________________________________________________
2. Issue the commands necessary to create these VLANs. Write down the commands you use.
_____________________________________________________________
3. Verify that you have created and named the VLANs correctly. What command should you use?
_____________________________________________________________
B. Placing the PC Hosts in the Correct VLANs
1. By default, are the PC hosts already in a VLAN? If so, which one? What command should
you use to determine this?
_____________________________________________________________
2. Refer to the Lab Topology diagram, and write down which PC hosts should go in which
VLANs.
_____________________________________________________________
J. Assir lle |O lcsls lc lle ccrrecl \lANs. lr a11ilicr, sel lle sWilcl crl lc lJJ Mls/
half duplex for all PC hosts. What commands should you use?
_____________________________________________________________
1. Sel lle crl see1 ar1 1tle\ lc lJJ Mls/tll 1tle\ cr lle sWilcl crl llal ccrrecls
P1SW1 to P1R1. What commands should you use?
_____________________________________________________________
274 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Task 4
A. Creating Subinterfaces on P1R1
1. On P1R1, you will need to create a subinterface for each VLAN. Write down the names of
the subinterfaces you plan to create. What rationale did you use when deciding on names
for the subinterfaces?
_____________________________________________________________
2. Create the subinterfaces that you listed in the previous step. Remember that the router
irlerace ra, le ir a sltl1cWr slale ir lle 1eatll ccrltralicr. Be stre lc isste lle
necessary commands to activate the interface. Write down the commands you use.
______________________________________________________________
B. Assigning IP Addresses to the Subinterfaces
1. Refer to the Lab Topology diagram, and write down the IP addresses that you will assign
to each subinterface on P1R1.
______________________________________________________________
2. Per your list above, assign the appropriate IP address to each subinterface on P1R1.
Remember to use a 24-bit subnet mask (255.255.255.0). Write down the commands you
use.
______________________________________________________________
3. Be sure to verify that you have assigned the correct IP address and subnet mask to each
subinterface. Check your work, and write down the commands you use to perform this
erilcalicr.
______________________________________________________________
0. 0or|gar|rg Sab|rterfaoe Eroapsa|at|or for 89Z.J \|AN !agg|rg
1. When the Ethernet frames leaving FastEthernet0/0 arrive at FastEthernet0/1 on P1SW1,
the switch will examine the 4-byte VLAN tag in the Ethernet frame to determine which
virtual LAN should receive the frame. In order for the frames leaving Fa0/0 to be tagged
ccrrecll,, lle laJ/J stlirleraces rtsl le ccrltre1 Will lle ccrrecl ercastlalicr
command to identify the VLAN to which the subinterface belongs.
Z. Ocrltre &JZ.l \lAN lair cr eacl stlirlerace. Rrile 1cWr lle ccrrar1s ,ct tse
to accomplish this.
______________________________________________________________
0. 0or|gar|rg t|e !rark Port !|at 0orreots PJSdJ to PJRJ
1. Which port on P1SW1 is used to connect to P1R1?
______________________________________________________________
Z. Becatse llis crl Will carr, rares rcr rtllile \lANs, il slctl1 le ccrltre1 as a
lrtr| crl. SWilcl crls are ccrltre1 as access crls l, 1eatll. Ar access crl carries
only Ethernet frames of the VLAN of which the port is a member.
J. Ocrltre lle crl rare1 ir sle l as a lrtr| crl. Rererler lc sel lle lrtr| crl lc tse
the correct encapsulation! Write down the commands you use to accomplish this.
______________________________________________________________
275 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Task 5
A. Verifying Network Connectivity
1. At this point, the network should be fully operational. From the console of each PC host,
attempt to ping all other PC hosts. Are you able to do so?
_____________________________________________________________
2. From the console of P1SW1, you should be able to ping all subinterfaces on P1R1 as well
as all PC hosts. Verify that this is the case. Write down the commands you use.
_____________________________________________________________
3. From the console of P1R1, you should be able to ping all PC hosts as well as the management
VLAN on P1SW1. Verify that you can do this. Write down the commands you use.
_____________________________________________________________
B. Troubleshooting
l. Mce |O lcsl |l|Ol rcr \lAN ZJ irlc \lAN JJ. Rrile 1cWr lle ccrrar1s ,ct tse lc
do this.
_____________________________________________________________
2. From the console of P1PC1, can you ping any other PC hosts? Why or why not?
_____________________________________________________________
3. From the console of P1PC1, can you ping any of the subinterfaces on P1R1? Why or why not?
_____________________________________________________________
4. From the console of P1R1, can you ping P1PC1? Why or why not?
_____________________________________________________________
5. Based on this troubleshooting exercise, summarize in a brief paragraph the
relationships between VLANs, subinterfaces, networks, and hosts.
_____________________________________________________________
_____________________________________________________________
_____________________________________________________________
_____________________________________________________________
C. Mce |l|Ol lac| irlc \lAN ZJ. Rlicl lcsls ar1 stlirleraces car ,ct rcW ir rcr
|l|Ol Briel, e\lair llis lelaicr.
_____________________________________________________________
_____________________________________________________________
_____________________________________________________________
_____________________________________________________________
276 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Lab Solutions
!ask J: Prepar|rg t|e 0e|oes for 0or|garat|or
2. P1R1 and P1SW1:
erase startup-cong
reload
show running-cong
3. P1R1:
cong t
hostname P1R1
P1SW1:
cong t
hostname P1SW1
Task 2
A. Assigning IP Addresses to the PC Hosts
1. P1PC1:
ipcong /ip 10.100.20.4 255.255.255.0
ipcong /dg 10.100.20.1
P1PC2:
ipcong /ip 10.100.30.4 255.255.255.0
ipcong /dg 10.100.30.1
P1PC3:
ipcong /ip 10.100.20.5 255.255.255.0
ipcong /dg 10.100.20.1
P1PC4:
ipcong /ip 10.100.30.5 255.255.255.0
ipcong /dg 10.100.30.1
2. No. All PC hosts are initially in the same VLAN, which is VLAN 1; however, P1PC1 and
|l|OZ are ccrltre1 Will 1iererl relWcr| a11resses ar1 llts carrcl ir eacl cller.
3. Yes. All PC hosts are initially in the same VLAN, which is VLAN 1. P1PC1 and P1PC3 are
also in the same IP network and are able to ping each other.
B. Assigning an IP Address to the Management VLAN on P1SW1
1. P1SW1:
congure terminal
interface vlan 1
ip address 10.100.1.2 255.255.255.0
Z. !le \lAN lD c lle raraererl \lAN is \lAN l. !le rare c \lAN l is 1eatll".
277 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Task 3
A. Creating VLANs on P1SW1
l. !Wc \lANs ree1 lc le creale1: \lAN ZJ ar1 \lAN JJ. !le \lAN lDs are Z9 and J9.
2. P1SW1:
cong t
vlan 20
vlan 30
3. show vlan
B. Placing the PC Hosts in the Correct VLANs
1. You should issue the show vlan command to see that the PC hosts are already in VLAN 1.
2. P1PC1 and P1PC3 should be in VLAN 20. P1PC2 and P1PC4 should be in VLAN 30.
3. To place P1PC1 in VLAN 20 on P1SW1:
cong t
interface FastEthernet0/2
switchport access vlan 20
speed 100
duplex half
To place P1PC2 in VLAN 30 on P1SW1:
cong t
interface FastEthernet0/3
switchport access vlan 30
speed 100
duplex half
To place P1PC3 in VLAN 20 on P1SW1:
cong t
interface FastEthernet0/4
switchport access vlan 20
speed 100
duplex half
To place P1PC4 in VLAN 30 on P1SW1:
cong t
interface FastEthernet0/5
switchport access vlan 30
speed 100
duplex half
4. P1SW1:
cong t
interface FastEthernet0/1
speed 100
duplex full
Z!8 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Task 4
A. Creating Subinterfaces on P1R1
l. ll is leltl lc rare lle stlirleraces tsir lle \lAN lD lc Wlicl lle, Will le
trunked. Thus, you should create subinterfaces FastEthernet0/0.1, FastEthernet0/0.20,
and FastEthernet0/0.30 on both P1R1 and P2R1. For instance, in this case,
FastEthernet0/0.20 will be trunked to VLAN 20.
2. P1R1:
cong t
interface FastEthernet0/0
no shutdown
interface FastEthernet0/0.1
interface FastEthernet0/0.20
interface FastEthernet0/0.30
B. Assigning IP Addresses to the Subinterfaces
1. FastEthernet0/0.1 10.100.1.1
FastEthernet0/0.20 10.100.20.1
FastEthernet0/0.30 10.100.30.1
2. P1R1:
cong t
interface FastEthernet0/0.1
ip address 10.100.1.1 255.255.255.0
interface FastEthernet0/0.20
ip address 10.100.20.1 255.255.255.0
interface FastEthernet0/0.30
ip address 10.100.30.1 255.255.255.0
3. You should use the show ip interfaces brief and show running-cong commands.
0. 0or|gar|rg Sab|rterfaoe Eroapsa|at|or for 89Z.J \|AN !agg|rg
2. P1R1:
cong t
interface FastEthernet0/0.1
encapsulation dot1q 1
interface FastEthernet0/0.20
encapsulation dot1q 20
interface FastEthernet0/0.30
encapsulation dot1q 30
0. 0or|gar|rg t|e !rark Port !|at 0orreots PJSdJ to PJRJ
1. FastEthernet0/1
3. P1SW1:
conf t
interface FastEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
279 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
Task 5
A. Verifying Network Connectivity
1. Yes. From the console of each PC host, you should be able to ping all other PC hosts.
2. ping 10.100.1.1 (subinterface fa0/0.1 on P1R1)
ping 10.100.20.1 (subinterface fa0/0.20 on P1R1)
ping 10.100.30.1 (subinterface fa0/0.30 on P1R1)
ping 10.100.20.4 (P1PC1)
ping 10.100.20.5 (P1PC3)
ping 10.100.30.4 (P1PC2)
ping 10.100.30.5 (P1PC4)
3. ping 10.100.1.2 (VLAN 1 on P1SW1 management/default VLAN)
ping 10.100.20.4 (P1PC1)
ping 10.100.20.5 (P1PC3)
ping 10.100.30.4 (P1PC2)
ping 10.100.30.5 (P1PC4)
B. Troubleshooting
1. P1PC1:
cong t
interface fa0/2
switchport access vlan 30
Z. Nc. |l|Ol carrcl ir |l|OJ lecatse eer llctl lle, are ccrltre1 Will lle sare
IP network addresses, they are no longer in the same VLAN. Although P1PC1 is now in
the same VLAN as P1PC2 and P1PC4, it has a different IP network address from P1PC2
and P1PC4, so pings to those hosts also fail.
J. Nc. |l|Ol is ccrltre1 Will lle Wrcr 1eatll aleWa, ar1 l| relWcr| a11ress cr lle
VLAN of which it is now a member; thus, it has no connectivity to hosts in its own, or any
other, VLAN.
1. Nc. !ralc 1eslire1 lc |l|Ol's l| a11ress is serl ctl |lRl's laJ/J.ZJ irlerace ar1 is
lrtr|e1 lc \lAN ZJ. !lis lralc Will reer reacl |l|Ol lecatse |l|Ol is rcW ir \lAN JJ.
5. \lANs reslricl ar1 ccrlair la,er Z lralc. Rler sWilcl crls are ra1e rerlers c a
\lAN, lle, lelae as i lle, Were ccrrecle1 lc lleir cWr searale sWilcl. Ocrltrir
all hosts in a VLAN with the same IP network addresses is good network design.
!ralc is rce1 lelWeer \lANs al la,er J. !le la,er J rctlir trclicr car la|e lace
on the switch itself if the switch has Layer 3 capabilities. In this network, P1SW1 does
rcl lae la,er J rctlir caalililies, sc a searale 1eice, |lRl, rtsl rce lralc al
Layer 3 between VLANs.
If the router had enough Ethernet ports, you could connect a separate Ethernet port
rcr lle rctler lc a sWilcl crl ir eacl \lAN. !lis arcacl is rcl elcierl lecatse
il Wasles Ellerrel crls cr lle rctler ar1 lle sWilcl. lrslea1, ,ct slctl1 ccrltre
a Layer 2 trunking protocol that is supported by both P1R1 and P1SW1. You are using
802.1q trunking because the switch only supports 802.1q. By using Layer 2 trunking,
,ct car ccrrecl a irltal" rctler stlirlerace lc eacl \lAN cr lle sWilcl ar1 tse lle
rctler lc rce lralc lelWeer lle \lANs al la,er J.
Z89 Boson NetSim for CCNP Lab Manual
CCNP ADVANCED LAB 1
Single Site Network
6. After P1PC1 is moved back into VLAN 20, pings from P1PC1 to all other PC hosts and
subinterfaces are successful. Pings from P1PC1 to hosts and interfaces in VLAN 20 are all
successful because all hosts and subinterfaces in the same VLAN have the same network
address. Pings to hosts and subinterfaces in different VLANs have different network
addresses and are forwarded to the default gateway for delivery via Layer 3 routing.
Sap|e 0or|garat|or Sor|pts
P1R1 P1SW1
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname P1R1
!
ip subnet-zero
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
!
interface FastEthernet0/0.1
encapsulation dot1q 1
ip address 10.100.1.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1q 20
ip address 10.100.20.1 255.255.255.0
!
interface FastEthernet0/0.30
encapsulation dot1q 30
ip address 10.100.30.1 255.255.255.0
!
ip classless
no ip http server
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname P1SW1
!
ip subnet-zero
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
speed 100
duplex full
!
interface FastEthernet0/2
switchport access vlan 20
speed 100
duplex half
!
interface FastEthernet0/3
switchport access vlan 30
speed 100
duplex half
!
interface FastEthernet0/4
switchport access vlan 20
speed 100
duplex half
!
interface FastEthernet0/5
switchport access vlan 30
speed 100
duplex half
!
end