Вы находитесь на странице: 1из 5

TP Dploiement de rseaux IP sous IOS Cisco

Objectifs :
-

Configuration dun accs WAN (LS, FR).


Configuration dun routage statique / dynamique (RIP ou OSPF).
Familiarisation avec les commandes de configurations propres au systme IOS Cisco.

Barme : 5 par question.


Environnement logiciels et maquette
Le simulateur Packet Tracer (ou GNS).
On considre le rseau dcrit par la figure ci-dessus.

Site 0

Site 1

Pour chaque site (site 0 et site 1), est prvu un commutateur Fast Ethernet (Switch 0 et Switch 1), A chacun de ces
commutateurs est reli un PC (PC0 et PC1) et un routeur (Router0 et Router1). Choisir des routeurs avec des ports
sries ou rajouter les modules ncessaires. A travers leur interface srie (serial2/0), les deux routeurs sont relis par une
liaison null-modem ( Serial DTE )). Le plan dadressage est dcrit comme suit :
Nom de la machine/interface
PC0
PC1
Router0/FastEthernet
Router0/serial2/0
Router1/FastEthernet
Router1/serial2/0

Adresse IP
10.0.0.1/16
10.1.0.1/16
10.0.255.254/16
10.255.255.5/30
10.1.255.254/16
10.255.255.6/30

Configuration de ladressage, du protocole PPP et et dun routage statique


1) Dcrire la suite de commandes quil faut taper sur chacun des routeurs pour la configuration de ladressage dune
interface (au choix).
...................................................................................................................
...................................................................................................................
2

...................................................................................................................
...................................................................................................................
Procder la configuration de ladressage de toutes les interfaces.
Sur la liaison point point il faut prvoir un protocole de liaison. A cet effet, nous allons utiliser le protocole PPP,
sur chacun des routeurs et en passant en mode configuration de linterface serial0, taper :
Router(config-if)#encapsulation ppp
Fixer la vitesse dhorloge en tapant sur chacun des routeurs la commande suivante :
TP RL/ II2-ENSI

Page :1

Router(config-if)#clock rate 56000


Utiliser la commande show interface pour sassurer quadministrativement une interface est active, quau niveau
physique linterface fonctionne correctement et que la configuration logique (ex. encapsulation) ou protocolaire est
correcte. Quelle est le message retourn concernant ces informations lorsque tout fonctionne correctement.
1

.......................................
Quelle est le message retourn si dun cot il y a une encapsulation PPP et de lautre une encapsulation HDLC.

.......................................
Remettre lencapsulation PPP des deux cots. Et fixer le dbit 128 Kb/s.
Sur une liaison PPP, il est possible dauthentifier une extrmit par lautre ou aussi dactiver lauthentification dans
les deux sens. Pour permettre au Router0 dauthentifier Router1 (utilisateur = site1 et mot de passe psite1) suivant
le protocole PAP, il suffit de tapez sur Router 0 les commandes suivantes :
Router(config)#username site1 password 0 psite1
Router(config)#interface serial 2/0
Router(config-if)#ppp authentification pap
et sur le Router1, il faut taper les commandes suivantes :
Router(config)#interface serial 2/0
Router(config-if)# ppp pap sent-username site1 password 0 psite1

Vrifier avec le mot de passe correcte et un mot de passe in correcte le fonctionnement de la connexion.
2) Depuis PC0 il nest pas possible de joindre PC1 car certaines routes manquent ? La commande pour visualiser les
routes est :
Router#show ip route
Pour rajouter une route utiliser la commande (utiliser ? pour dterminer la suite des paramtres) :
Router(config)#ip route
Dcrire les routes rajouter sur les deux routeurs. Que faut-il aussi prvoir sur les deux PC. Vrifier que les deux
PC arrivent pinguer entre eux.
.......................................
.......................................

.......................................
.......................................
.......................................
.......................................
.......................................
.......................................
.......................................

Interconnexion de deux sites via un rseau Frame Relay


Les sites 0 et 1 ainsi quun troisime site (site 2) sont connects un rseau Frame Relay (FR). A cet effet, le
routeur Router0 (respectivement Router 1) est connect, via linterface srie serial 3/0, un rseau FR (cloud-PT). Sur
le site 2, se trouve un troisime routeur Router2 connect dune part au rseau FR et dautre part un commutateur
Fast Ethernet (Switch 2). Au commutateur est reli un PC (PC2). Pour la connexion au rseau FR choisir une liaison
Serial DCE . Le reste du plan dadressage est dcrit comme suit :

TP RL/ II2-ENSI

Page :2

Nom de la machine/Interface
Router0/serial3/0
Router1/serial3/0
Router2/serial3/0
Router2/FastEthernet
PC2

Site 0

Adresse IP
10.3.255.254/16
10.3.255.253/16
10.3.255.252/16
10.2.255.254/16
10.2.0.1/16

Site 1

Site 2

La transmission sur un rseau FR seffectue travers des circuits virtuels VCs dsigns localement par un DLCI Data
Link Connection Identifier . Dans cette manipulation nous allons utiliser des CVs permanents (PVCs). Lors de la
configuration du rseau FR il faut initialiser les diffrents PVCs (dans la ralit ceci se fait en sadressant
loprateur). Sur le simulateur cliquer sur le Cloud-PT et pour chaque interface sries (chacune correspondant un site)
dfinir deux VCs allant vers les deux autres sites. La dfinition dun VC se fait en prcisant le numro de DLCI, son
nom ainsi que le type de commutateur FR auquel on est raccord (choisir la norme Q.933a). Sur le rseau FR (cloud
FR) les interfaces sries sont numrotes de 0 2), supposons que le site <i> et connect au port srie<i> on aura :

Reste associer les DLCI de part et dautre de chaque VC. Ceci se fait, sous longlet Frame Relay , comme suit :

3) Pour configurer une interface connecte un rseau FR, commenons par taper les commandes suivantes (aprs
tre pass en mode configuration de linterface serial 3/0, dans le cas du router0) :
Router(config-if)ip address 10.3.255.254 255.255.0.0
Router(config-if)encapsulation frame-relay
Router(config-if) frame-relay interface-dlci 101
Router(config-if)frame-relay interface-dlci 102
Router(config-if)frame-relay lmi-type q933a
Router(config-if) clock rate 56000
5
Configurer de mme les routeurs Router1 et Router2.
TP RL/ II2-ENSI

Page :3

Le rseau frame relay fournit chaque routeur un mapping entre les adresses IP distantes et le DLCI local
permettant de joindre ces adresses (de la mme faon que le protocole ARP fournit la correspondance entre les
adresses IP et les adresses MACs). Visualiser ce mapping grce la commande :
Router#show frame-relay map
Des statistiques relatives aux diffrents VCs peuvent tres obtenues grce la commande
Router#show frame-relay pvc
Visualiser la table de routage et vrifier que les trois routeurs arrivent se joindre via le rseau FR.

Routage dynamique RIP


Nous pouvons remarquer ce stade que PC0 et PC1 narrivent pas joindre PC2. En gardant les routes statiques dj
saisies et en ayant sur chaque PC une route par dfaut correspondante au routeur du site o se trouve le PC, nous allons
activer le routage RIP.
4) Sur chaque routeur, taper les commandes de configuration de RIP. Par exemple sur Router0 :
Router(config)#router rip
Router(config-router)# version 2
Router(config-router)#network 10.3.0.0
Router(config-router)#network 10.255.255.4
A noter que sur ce routeur (Router0), il est inutile dactiver le RIP sur le rseau 10.0.0.0 car il n y a pas dautres
routeurs RIP, ni mme une station sur laquelle nous pouvons activer un couteur RIP pour apprendre les routes (sur
une station, nous nous limitons la route par dfaut).
Visualiser la table de routage sur Router0. Depuis ce routeur et pour joindre le PC1, est-ce lICMP-echo passe par
la liaison PPP ou par le rseau FR. Pourquoi il en est ainsi ?
...................................................................................................................
2 ...................................................................................................................
...................................................................................................................
1

Dsactiver linterface correspondante la route suivie par Router0 pour joindre 10.1.0.0. Vrifier que la table de
routage change et passe par la route alternative.
Dsactiver les routes statiques sur les diffrents routeurs. Nous allons tendre le rseau en rajoutant un quatrime
site (site 3) comportant : un commutateur Fast Ethernet (Switch3), un PC (PC3) connect au Switch3 et un routeur
Router3 ayant une interface Fast Ethernet connecte au au Switch3 et deux interfaces Gigabit Ethernet connectes
aux routeurs Router0 et Router1 (rajouter les interfaces Gigabit si ncessaire). Le reste du plan dadressage est
comme suit
Nom de la machine/Interface
Router0/Giga Ethernet 6/0
Router1/Giga Ethernet 6/0
Router3/Giga Ethernet 6/0
Router3/Giga Ethernet 7/0
Router3/Fast Ethernet 0/0
PC3

Adresse IP
10.255.255.9/30
10.255.255.14/30
10.255.255.10/30
10.255.255.13/30
10.4.255.254/16
10.4.0.1/16

Pourquoi le Router0 passe par une liaison srie 128 Kb/s (correspondant PPP ou FR) pour joindre PC1 et ne
passe pas par linterface Gigabit Ethernet. Conclusion.
...................................................................................................................
2

...................................................................................................................
...................................................................................................................
...................................................................................................................

Routage dynamique OSPF (bonus)


Dsactiver le routage RIP. Nous allons configurer le routage OSPF. Suivant Ce protocole, lAS peut tre dcoup en
aires. La dcomposition que nous retenons est la suivante :
TP RL/ II2-ENSI

Page :4

Aire
0
1
2

Rseaux
10.255.255.4 10.255.255.8 10.255.255.12
10.0.0.0 10.1.0.0 10.2.0.0 10.3.0.0
10.4.0.0

5) Sur chaque routeur, taper les commandes de configuration dOSPF, par exemple sur Router0 :
Router(config)#router ospf 1
Router(config-router)#network 10.0.0.0 ?
A.B.C.D OSPF wild card bits (valeur inverse du masque)
Router(config-router)#network 10.0.0.0 0.0.255.255 area 1
Router(config-router)#network 10.3.0.0 0.0.255.255 area 1
Router(config-router)#network 10.255.255.4 0.0.0.3 area 0
Router(config-router)#network 10.255.255.8 0.0.0.3 area 0
Remarque : avec Packet tracer 5.3 et pour les interfaces connectes des rseaux diffusion, afin que le routeur
reconnaisse ses voisins, il faut rajouter :
Router(config-if)#ip ospf network broadcast
Visualiser la table de routage sur Router0. Depuis ce routeur, par quelle interface passe le routeur pour joindre le
PC1. Pourquoi ? Que peut-on conclure en comparaison avec le RIP.
...................................................................................................................
...................................................................................................................
...................................................................................................................
...................................................................................................................
Commandes utiles pour la visualisation de certaines informations dtat (le cours rseaux informatiques , est un
pr requis pour une interprtation avance de ces informations)
Router# show ip ospf interface
Router# show ip ospf database
Router# show ip ospf neighbor
Router(config-router)#router-id

TP RL/ II2-ENSI

Page :5