Вы находитесь на странице: 1из 17

Turkish Journal of Science & Technology Volume 4, No 2, 139- 155, 2009

The Adjustment of Some Geodetic Networks Using Microsoft EXCEL SOLVER


Levent TAI
Frat University, Engineering Faculty, Civil Engineering Department, 23100, Elaz, Turkey ltasci@firat.edu.tr (Received: 20.06.2009; Accepted: 21.09.2009) Abstract The Solver is an Excel Add-in that is developed to solve mathematical equations and perform optimization solutions for modeled systems as well. In this study, Excel Solver Add-in that is developed by Frontline Systems is used to solve the adjustment problems by using least squares method. As case studies, adjustment of the closed and open traverses, leveling networks and GPS coordinates are selected Key word: Adjustment, Solver, Geodetic Networks, Leveling, GPS

Microsoft EXCEL SOLVER Kullanlarak Baz Jeodezik Alarn Dengelenmesi


zet Solver modellenmi sistemlerin optimizasyon problemlerinin zm ile matematiksel denklemleri zmek iin gelitirilmi bir Excel eklentisidir. Bu almada, Frontline Sistemleri tarafndan gelitirilmi Excel Solver eklentisi en kk kareler yntemi kullanlarak dengeleme problemlerini zmek iin kullanlmtr. alma olarak ak ve kapal poligonlar ile nivelman a ve GPS koordinatlarnn dengelenmesi seilmitir. Anahtar Szckler: Dengeleme, zc, Jeodezik Alar, Nivelman, GPS

1.Introduction According to zturk [1], data adjustment is to determine the adjusted or estimated values of the unknowns by using all redundant measurements, which are in excess of the number of measurements that are required to uniquely determine the underlying model. The main purpose of least squares method is to determine the accuracy and reliability of observations, functions of observations and estimated values. The Solver, to adjust small to medium size traverses encountered in day to day surveying practices. Furthermore, the user does not need to know how to form the condition equations how to differentiate complex equations how to solve the normal equations used in a conventional least squares approach [2].. In this study, usability of Excel Solver Add-in, developed by Frontline systems, is investigated for analysis and adjustment of

survey measurements using least squares technique. Excel Solver Add-in and Visual basic scripts are used to estimate the adjusted coordinates of closed and open traverses, levelling networks and GPS coordinates. The data adjustment examples used in this study was first solved using conventional least squares method. Then, same examples are re-solved using Excel solver and the results from the two methods are compared and discussed. 2. About the EXCEL SOLVER Microsoft Excel Solver is a Microsoft Excel add-in. Microsoft Excel Solver helps you to determine the optimum value for a formula in a particular target cell on a Microsoft Excel worksheet. Microsoft Excel Solver adjusts the values of other cells that are related to the target cell by using an equation. After you construct an equation and define a set of parameters or constraints for the variables in the equation, Microsoft Excel Solver tries various solutions to

Levent Tasci

arrive at an answer that satisfies all constraints [3]. For additional information the reader is encouraged to visit the Frontline web site at http://www.frontsys.com. The site contains links to the most current information on the Solver platforms, examples, tutorials on different optimization models, although not much on least squares application to surveying problems. 2.1 Installing Microsoft EXCELS SOLVER To install Solver, select Tools/Add-Ins. Excel displays a dialogue box with a list of all Add-Ins currently available as shown in figure 1. 1. Scroll down the list and check the box next to Solver add-in. Click OK. Excel will install the 2. add-in and place a new menu item (Solver) under the Tools menu. 3. 4.

Microsoft Excel solver uses the following elements to solve an equation. The target cell is reference for the objective function. It is the cell in the worksheet model that will be minimized, maximized, or set to a certain value. Changing cell are decision variables. These adjustable cells must be related directly or indirectly to the target cell. Constraints are restrictions on the contents of cells. For each constraint do the following: Click ADD button. This will bring up the dialog box in figure 3. In the cell reference box, enter the right hand side of the constraint. In the cell reference box, enter the left hand side of the set of Cell Reference. In the middle box should be chosen one of (<=, >=, =)

Fig. 1. The Add-Ins dialog box [6].

If Solver add-in does not appear on the list, then to install Solver add-in must use Microsoft Office CD-ROM.
Objective Function Cell Location

Constraint Cell Reference or set of Cell Reference

Formula, Cell Reference, Or Value

Constraint Type

Fig. 3. Add Constraint Dialog Box [7]

Solve Proble Min, Max or Value


Invoke Solver Option s

Decision Variable Cell Locations

Constraint Set

Clear Current Model Add a Constraint Change a Constraint Delete a Constraint

Fig. 2. Solver Parameters Dialog Box [7]

2.2 The Solver Parameters On the Tools menu, click Solver. Excel displays a solver parameters dialogue box as shown in figure 2.
140

Click options button in the Solver Parameters Dialog Box. This will bring up the Solver Options dialog box in figure 4. In the standard Excel Solver, all such options appear in one dialog box; in the Premium Solver products, where many more options and tolerances are available, each optimizer has a separate dialog box [4]. The Max Time and the Iterations edit boxes control the Solvers running time. The Show Iteration Results check box instructs the Solver to pause after each major iteration and display the current trial solution on the spreadsheet. In lieu of these options, however, the user can simply press the ESC key at any time to interrupt the Solver, inspect the current iterate, and decide whether to continue or to stop. The Assume Linear Model check box determines whether the simplex method or the GRG2 nonlinear programming algorithm will be used to solve the problem. The Use

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

Automatic Scaling check box causes the model to be rescaled internally before solution. The Assume Non-Negative check box places lower bounds of zero on any decision variables that do not have explicit bounds in the Constraints list box. The Precision edit box is used by all of the optimizers and indicates the tolerance within which constraints are considered binding and variables are considered integral in mixedinteger-programming (MIP) problems. The Tolerance edit box (a somewhat unfortunate name, but Microsofts choice) is the integer optimality or MIP gap tolerance used in the branch-and bound method. The GRG2 algorithm uses the Convergence edit box and Estimates, Derivatives, and Search option button groups [4].
Fig. 4. Solver Options Dialog Box [7].
IP Solution within this % of Optimal Use Simplex Algoritma
Assume Non-Negative Nonlinear options

3. The Essential of Adjustment by Least Square Method The adjustment is based on equations where the observations are expressed as function of unknown parameters. A Taylor series expansion is usually performed in the case of a nonlinear relationship between observations and unknowns. The resulting linear relationship can be represented in a matrix - vector notation as l=A*x (1) Where; l ... vector of observation, A ... design matrix, x ... vector of unknowns n observations and u unknown parameters lead to a design matrix A comprising n rows and u columns. We have to add a noise vector v to the observations. l+v=A*x (2)

The job of the adjustment is to find the set of unknowns which result in the smallest noise vector v. A possible criterion for the noise vector to be small is that its norm is small. vT * v = minimum. (3)

This is the principle of least squares. The solution vector x of the unknown coordinates is then computed as: x = (AT * A)-1 * AT * l (4)

Click solve button. Excel displays a Solver Results dialogue box as shown in figure 5 a message appears on the top left-hand side of the box. In this case, Excel reports that Solver found a solution. All constraints and optimally conditions are satisfied.

Fig. 5. Solver Results Box [7].

In addition, the observations are weighted according to their variance - covariance. The weighting factor of an observation is the reciprocal of its variance, which, in turn, is the square of its standard deviation (P = Q -1 ll ) .That means that observations that is considered to be very accurate (small standard deviation) gets a big weighting factor and therefore strongly affects the adjustment result. On the other hand, giving an observation a big standard deviation (relatively to the other observations) makes its impact on the adjustment result small. Then, we minimize the quantity vT * P * v = minimum.
141

(5)

Levent Tasci

(P is the weighting matrix of the observations). The solution vector x of the unknown coordinates is then computed as: x = (AT * P * A)-1 * AT * P * l (6) 4. The Regulations to Various Geodetic Networks 4.1 Leveling Networks There are two different cases for leveling networks: 4.1.1 Leveling Network Connecting Two Fixed Points
HB HA h1 HC h2 HD h3

X1T,2 = [HB HC ] r =1 h1 h2 h3 = 0

LT 1,3 = [h 1 h2 h3 ]

(10) (11) (12)

Where; HA, HB and HC are point heights. h1, h2 and h3 are height differences measured between two points Number of redundant observations= r = n-u (degrees of freedom) n= number of observation (measurements), u= number of unknowns 4.2 Traverse Networks 4.2.1 Traverse Connecting Two Fixed Points

Fixed Point

1
A Fixed Point

1
d1

2
d2
2

Fig. 6. Leveling Network Connecting Two Fixed Points [5]


T X 1, 2 = [ H C H D ] r =1 h1 + h2 + h3 + ( H A H B ) = 0 T L1,3 = [ h1 h2 h ] 3

d3

(7) (8) (9)

Fig. 8. Traverse Connecting Two Fixed Points [5].

Where; HA, HB, HC and HD are point heights. h1, h2 and h3 are height differences between two neighbor points Number of redundant observations= r = n-u (degrees of freedom) n= number of observation (measurements), u= number of unknowns 4.1.2 Closed Leveling
HA h1

x1 y x = 1 x2 y 2

1 d 1 l = 2 d 2 3 d3
xi = d i cos i y i = d i sin i

(13)

2 xi ( xb x a ) = 0 i =1 2 y i ( y b y a ) = 0 i =1 xi = x A + d i cos i y i = y A + d i sin i n=6 u=4 r = 64 = 2

(14) (15) (16) (17) (18)

h3

HB
HC

h2

Fig. 7. Closed Leveling [5].

Where; xi, yi are coordinates of points. i= azimuth ,di= distances Number of redundant observations= r = n-u (degrees of freedom) n= number of observation (measurements), u= number of unknowns

142

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

4.2.2 Closed Traverse

times are determined using Adjustment of Unknown vectors that have different accuracy and correlation approach [1].

4.3.1 Adjustment of Unknown Vectors that have Different Accuracy and Correlation

d Fig. 9. Closed traverse [5].

Functional model Condition equations are set as;

v 1 = x L1 v2 = x L2
(19) (20) (21) (22)
Q = 1 Q = 1

xi = 0 yi = 0
2 2 2 2 d i = ( yi +1 yi ) ( xi +1 xi ) ( i ) = Arc tan n=8

..... vn = x Ln

(23)
. .

( yi +1 yi ) ( xi +1 xi )

Where; v = estimated residuals (estimated error), x = estimated value, Li = observed value Stochastic Model
1 2 m 0 1 m 2 0 K1 , P1 = Q 1 1 1 2

u=6

r = 86 = 2

Where; xi and yi are coordinates of points. i= azimuth , di= distances Number of redundant observations= r = n-u (degrees of freedom) n= number of observation (measurements), u= number of unknowns 4.3 Adjustment Of Coordinates Determined From Satellite Observation Today, the geocentric coordinates of geodetic networks can be determined using satellite observations (GPS Measurements). Coordinates of the geodetic points can be determined using the measurements done in one or more surveying sessions, and these measurements are needs to be adjusted. The adjusted coordinates are calculated by determining the adjusted components of unknown vectors. The components of the unknown vectors are made up of the coordinate values of the points to be adjusted. The accuracies of the components may be different and they may have physical and/or mathematical correlation. Adjusted values of unknown vectors that were calculated more than once in different

K2

P2 = Q

(24)

Where; Qi = Cofactor matrices, Ki = VarianceCovariance matrices,

m 2 = square of mean error , Pi = Weights


0

Objective Function
T T T T v P v = v P v + v P v + + v P v ll 1 l 1 2 2 2 n n n

(25) Where

; v = estimated residuals (estimated error), Pi = Weights

Normal equations
(P1+P2 + +Pn)x -(P1L +Pn Ln)=0 1+P2 L2 +

(26)

The Adjustment Unknowns

x=(P +Pn) (P +Pn L 1 +P 2+ 1L 1+P 2L 2+ n)


-1

(27)

143

Levent Tasci

5. Mathematical Model 5.1 Determination of Data Source for the Models For leveling networks, the data used are observations, height differences and the fixed heights. The unknown heights are determined using the height differences. In leveling networks, at least height of one point must be considered as fixed height. Weights are calculated using the following formula; pi=1/Si (km) (28)

vTPllv = (L1TPlL1+ L2TP2L2+.+ LnTPnLn) vTPllv = (L1TPlL1+ L2TP2L2+.+ LnTPnLn) xT(P1L1+ P2 L2++Pn Ln) vTPllv=(L1TPlL1 ++ LnTPnLn)- (P1L1+ +PnLn)T (P1+...+Pn) -1 (P1L1+ P2 L2++Pn Ln) 5.3 Selection of Objective model

(32) (33)

(34)

In the adjustment process, (vTPv) should be minimum since the goal of the adjustment is to obtain the value that has maximum probability. 6. The Some Adjustment Samples by Using Excel Solver 6.1 Leveling Network The leveling network example provided below is taken from El-Shimmy [5].
b
h5 h6 h3

For traverses, the data used are observations (angles, lengths), known coordinates and known azimuths. In closed traverse, at least one point and in open traverse, at least two points must be selected as fixed points. Azimuths and lengths of other points are determined using the equation (37-38). Weights are determined by p=1/2 using the standard deviations of the observations. Standard deviations of the angles should be considered as RADIAN in Excel calculations. In satellite measurements, the data used are the coordinates and cofactor matrix of the points. 5.2 Selection of Constrains for the Models The constraints in Leveling adjustment; Loop Closure (Sum of the height difference) = 0 The constraints in the closed traverse adjustment; Sum of x = 0; Sum of y = 0 Sum of interior angles = (n-2)*200 (for closed traverse). Where n is the number of sides of closed traverse. Constraints in open traverses

h4

d
h2 h1

HA=0.00 m.

Fig. 10. Leveling Network


= h h ha c 1 = h h 2 d ha = h h c + hd 3 =h h ha 4 b =h h +h 5 b d h6 = hb + hc

(35)

x (x
i =1 2 i i =1 i

xa ) = 0 ya ) = 0

xi = di cosi yi = di sini

(29) (30)

y ( y

The weights of Observations are calculated from formula (28). According to this formula, six equations are written for weights of observations;

Constraints in satellite measurements (P1v1+ P2 v2++Pn vn) = 0 (31)


144

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER


Observatio ns(m.) Section Distances (km.)

h1 6.16 h2 12.57 h 6.41 l6,1 = 3 = h4 1.09 h5 11.58 5.07 h6

4km 2km 2km 4km 2km 4km

Unkonown

hb x 3,1 = hc hd

P 1 = 1 S ( km ) = 1 4 = 0 .25 P2 = 1 S ( km ) = 1 2 = 0 .50 P3 = 1 S ( km ) = 1 2 = 0 .50 P4 = 1 S ( km ) = 1 4 = 0 .25 P5 = 1 S ( km ) = 1 2 = 0 .50 P6 = 1 S ( km ) = 1 4 = 0 .25

(36)

Fig. 11. Adjustment of Leveling Networks

In figure 11; (B6:B11) contains heights difference, (C6:C11) contains leveling distances, (E6:E11) contains weights and (D5) contains fixed height. Figure 11 shows the input for Solver. The cells are contains following inputs; 1. B15 contains the height differences in cell B6. The formula in B15 (=B6) is copied through B20. 2. C15 contains the height differences in cell C6. The formula in C15 (=CB6) is copied through C20. 3. D15 contains a formula for computing. See equation (36). D15(=H17-D5); D16(=H18-D5); D17(=-H17+H18); D18(=-D5+H16); D19 (= -H16+H18); D20 (= -H16+H17) 4. E15 contains a formula for computing loop closure. See equation (12). This formula is shown as below E15(=H17-D5-B15); E16(=H18-D5-B16); E17(= -H17+H18-B17); E18(= -D5+H1B18);
145

E19(= -H16+H18-B19);E20(= -H16+H17B20) 5. F15 contains the weights in cell F6. The formula in F15 (=F6) is copied through F20. 6. G15 contains a formula for computing (VTPV). Where; v = Residuals, P = The weights of observations G15(=F15*E5^2); G16(=F16*E5^2); G17(=F17*E5^2); G18(=F18*E5^2); G19(=F19*E5^2);G20(=F20*E5^2) 7. The cells H16, H17 and H18 contain a formula for computing point heights (hb, hc and hd ). This formula is shown as below H16 (=SUM (D5:B18)) ; H17 (=SUM (D5:15)); H18 (=SUM (D5:B16)) 8. G21 contains a formula for computing (vTPv). This formula is shown as below G21 (=SUM (G15:G20)) 9. E23 contains a formula for computing loop closure. E23 (=SUM (E15:E20))

Levent Tasci

Performing of Leveling Adjustment in Excel Solver Select TOOLS/SOLVER from Excels main menu. The SOLVER PARAMETER dialog box as shown in figure 12 below will be displayed.

Performing of Leveling Adjustment in Excel The Adjustment can be performed by clicking SOLVE button in SOLVER PARAMETER dialog box. If the adjustment is successful the Solver dialog box will be displayed as shown in figure 15. Click OK button to save the solution results. Adjusted Results D15 to D20 contains corrections of height differences. E15 to E20 contains corrections of Loop closing. The cells H16, H17 and H18 contain the adjusted point heights (hb, hc and hd ). The results are given in figure 15 and 16.

Fig. 12. Solver Parameters Box

Set Target Cell: The target cell is G21. This cell contains the weighted sum of the squares of the residual to be minimized. Equal to: The Min radio button should be selected. By Changing Cells: H16 to H18 are points heights which are calculated as approximation from height differences. Subject to the Constraints: Clicking ADD button will display the ADD CONSTRAINTS dialog box in figure 13. For this example, there is a constraint which is loop closure in cell E23=0.

Fig. 15. Adjustment of Leveling Networks by the Excel SOLVER

Fig. 16. Summary Adjusted Results Fig. 13. Constraint Box

Solver Options: Clicking the options button in SOLVER PARAMETER dialog box will display the SOLVER OPTIONS dialog box as shown in figure 14. Leveling adjustment the options can be selected as shown in figure 14.

6.2 Traverse Connecting Two Fixed Points The traverse connecting two fixed points is shown in figure 17. The points A, B, C, D and the azimuths (AB), (CD) are fixed. All bearings are direction clock wise. All distances are measured from point A to point D.
N
1=139g.5761 C=185g.8790

B=344g.3640

2=225g.7189

D Y= 7909.20m X= 5104.71m C Y= 7988.10m X= 5121.87m

dB1=152.37 m.

d12= 44.26 m.

Y= 8228.84m X= 5058.48m

Fig. 14. Solver Options Box

Fig. 17. Traverse Connecting Two Fixed Points

146

d23= 70.16 m.

Y= 8123.00 m X= 5787.87m

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

di =

(y

2 2 2 2 y i ) ( xi +1 xi ) i +1

(37) (38) (39)

( i ) = Arc tan

( y i +1 y i ) ( xi +1 xi )

n = i +

Where; di = The distance is between two points, i = azimuth

The distances weights are calculated 1/(0.05)2= 400g, and the angle weights are calculated (636619,7724/15,43209877)2 = 1701806811. The cells (C5:C10) contains a formula for computing the azimuth from A to B. See equation (39). [=IF(C5+B6>600;B6+C5-600; IF(C5+B6>400;C5-200+B6; IF(C5+B6>200;B6+C5-200;B6+C5)))]. See equation (40).

Settings Traverse Connecting Two Fixed Points in Excel Figure 18 show the observations in cell (B6:B9, D6:D8) their standard deviations in cell (E6:E8, G5:G10) and weights in cell (F6:F9, H6:H10), the fixed coordinates of points in cell (L6:L9, M6:M9), the fixed azimuth in cell (I5 and J5). I6 contains fixed azimuth in grad unit. J6 contains a formula for transformation from Grad to Radian by the formula (=grd2r (I6)).

Fig. 18. Settings Traverse Connecting Two Fixed Points in Excel

147

Levent Tasci

Table 1. Specifications of Traverse Connecting Two Fixed Points in Excel Cell Number B17:B19 C17 C19 D17 D20 E16 E20 F16 F17 F20 G17 G20 H17 H20 I17 I19 J17 J20 J21 J24 K17 Formula Observed Distances =SQRT(M17^2+L17^2) =SQRT(M19^2+L19^2) =grd2r(B6) =grd2r(B9) =grd2r(C5) =grd2r(C9) =grd2r(C5) =grd2r(azmt(0;0;M17;L17)) =grd2r(C10) =ANGLE(F16;F17) =ANGLE(F19;F20) =G17-D17 =G20-D20 =C17-B17 =C19-B19 =H6*H17^2 =H9*H20^2 =SUM(J17:J20) =SUM(J21:K21) =F6*H17^2 Cell Number K19 K21 L17 L19 L21 L24 M17 M19 M21 M24 N16 N17 N18 N19 N21 O16 O17 O18 O19 O19 O21 Formula =F8*H19^2 =SUM(K17:K19) =B17*SN(E17) =B19*SN(E19) =SUM(L17:L19) =N21-L21 =B17*COS(E17) =B19*COS(E19) =SUM(M17:M19) =O21-M21 =L7 =N16+L17 =N17+L18 = N8 =N19-N16 =M7 =O16+M17 =O17+M18 =M8 =M8 =O19-O16

SOLVER Parameters

Fig. 19. Solver Parameters

Set Target Cell: Target cell is J24 and it is contain the weighted sums of the squares of the residuals in angles and distances to be minimized. Equal to: The MN radio button should be selected. By changing Cells: L17 to M19 are the Cartesian coordinates differences (X, Y) that are calculated from the observed distances and the azimuth of the lines derived from the observed angles. It also contains E20 contain calculated azimuth (CD) Subject to the Constraints: In the traverse connecting two fixed points are observed angles and distances. For this example, number of the residuals is equal to number of the constraints.
148

These constraints are sum of the coordinate differents in the direction of Y and X axis. Sum of the coordinate differents are y= -0.08 m. and x = -0.06 m. f is closing error. It is calculated by the formula f= (AB) + i (n*200). Four angles and three distances are observed in the direction of the clock wise. The unkonowns are coordinates of point 1 and point 2. The number of redundant observation (degrees of freedom) is calculated by equation (18) and it is equal to three. Clicking the ADD button will display the ADD COSTRAINT dialog box. For this example, there are three constraints. These constraints are given in below. 1. The Azimuth that is calculated in the C point is should be equal to the Azimuth that is fixed in the C point. The constraint formula is E20 = F20. 2. Sum of the closing in the direction of y axis in cell L24= 0. 3. Sum of the closing in the direction of x axis in cell M24= 0.

Performing of Traverse Adjustment in Excel The Adjustment can be performed by clicking SOLVE button the options button in

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

SOLVER PARAMETER dialog box. If the adjustment is successful the Solver dialog box

will be displayed as shown in figure 20. Click OK button to save the solution results.

Fig. 20. Performing of Traverse Adjustment in Excel

Adjusted Results The results of adjustment are given as summary in figure 21.

Fig. 21. Summary Adjusted Results

E33 to E36 contains corrections for observation angles. H17 (=rad2grd (H17)) contains a formula for transformation from radian to grad (See appendix, [(=(=grd2rad (.)]).The formula in H17 is copied through H20. E33 (=grd2rad (H17)) contains a formula for transformation from grad to radian. The formula in E33 is copied through E36. F33 to F35 contains the residuals for distances. The formula in F33 (=I17) is copied through F35. G33 to G36 contains the adjusted Azimuth. The cells from G33 to G36 are transformed from radian to grad by equation [(=rad2grd (F17))]. H33 to H36 contains the adjusted distances. The cell H33 (=C17) is copied through H35 (=C19). The cells (I34; J35) contain the adjusted coordinates. The formula I34 (= N17) is copied
149

I35 (= N18) and J34 (= O17) is copied J35 (= O18) 6.3 Closed Traverse Settings Closed Traverse in Excel SOLVER The cells (B7:B12, D7: D12) contain observations, the cells (E7:E12, G7:G12) contain standard derivation of observations and their weights. The cells (L6, M6) contain fixed point coordinates. The distances weights are calculated 1/(0.05)2= 400, and the angle weights are calculated (636619,7724/15,43209877)2 = 1701806811. The cells (C7:C12) contains a formula for computing the azimuth from A to B. [=IF(C5+B6>600;B6+C5600;IF(C5+B6>400;C5200+B6;IF(C5+B6>200;B6+C5-200;B6+C5)))].

Levent Tasci

4= 289.921 d34=59.49 m 3= 205.359


g

P4

d45= 57.43 m P5 5=305.804 d51=47.10 m P6 6=180.1854 d61= 37.91 m 1 = 303.804


g g g

P3

d23= 38.08 m

2= 315.665

P2 d12=75.73 m

N
P1

(P1P2)=339 g.791

Fig. 22. Closed Traverse

Fig. 23. Settings Closed Traverse in Excel

Table 2. Specifications of Closed Traverse in Excel Cell Number B23 B28 C23 C28 D23 D28 E22 E23 E28 F22 E23 E28 E29 F23 F28 H23 H28 G23 Formula =D7 = D12 =SQRT(L23^2+M23^2) =SQRT(L28^2+M28^2) =grd2r(B7) =grd2r(B12) =J6 =grd2r(C7) =grd2r(C12) =J6 =grd2r(azmt(0;0;M23;L23)) =grd2r(azmt(0;0;M28;L28)) =F22 =ANGLE(F22;F23) =ANGLE(F27;F28) =G23-D23 =F29-F28 =C23-B23 Cell Number G28 J23 J28 J30 K23 K28 K30 L23 L28 L30 M23 M28 M30 N23 N28 O23 O28 Formula =C28-B28 =H7*H23^2 =H12*H28^2 =SUM(J23:J28) =F7*H23^2 =F12*H28^2 =SUM(K23:K28) =B23*SN(E23) =B28*SN(E28) =SUM(L23:L28) =B23*COS(E23) =B28*COS(E28) =SUM(M23:M28) =N22+L23 =N27+L28 =O22+M23

150

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

SOLVER Parameters
f= (AB) + i (n*200). Six angles and six distances are observed in the direction of the clock wise. The unknowns are coordinates of points P3, P4, P5 and P6. The number of redundant observation (degrees of freedom) is calculated by equation (18) and it is equal to two. Clicking the ADD button will display the ADD COSTRAINT dialog box. For this example, there are three constraints. These constraints are given in below. 1. The Azimuth that is calculated in the P1 point is should be equal to the Azimuth that is fixed in the P1 point. The constraint formula is E28= F29. 2. Sum of the closing in the direction of y axis in cell L30= 0. 3. Sum of the closing in the direction of x axis in cell M30= 0.

Fig. 24. Solver parameters Dialog Box

Set Target Cell: Target cell is J30 and it is contain the weighted sums of the squares of the residuals in angles and distances to be minimized. Equal to: The MIN radio button should be selected. By changing Cells: L23 to M28 are the Cartesian coordinates (X, Y) differences that are calculated from the observed distances and the azimuth of the lines derived from the observed angles. Also, it contains the cell E28 that is calculated azimuth. Subject to the Constraints: In the closed traverse are observed angles and distances. For this example, Number of the residuals is equal to number of the constraints. These constraints are sum of the coordinate different in the direction of Y and X axis. Sum of the coordinate different are y= -0.07 m. and x = -0.05 m. f is closing error. It is calculated by the formula

Performing of Traverse Adjustment by the Excel Solver The Adjustment can be performed by clicking SOLVE button in SOLVER PARAMETER dialog box. If the adjustment is successful the Solver dialog box will be displayed as shown in figure 25. Click OK button to save the solution results.

Fig. 25. Performing of Traverse Adjustment in Excel

151

Levent Tasci

Adjusted Results
The results of adjustment are given as summary in figure 26.

Determining of Weight matrices Variance- covariance matrices (Kll) calculated using the following formula,
(Kll)=m02(Qll)

are (40)

Where; (Qll) = Cofactor matrices, m0 = a-priori variance For this problem, a-priori variance is equal to 1. Weight matrices are calculated using the following formula, Pll = Qll-1 = Kll-1 Where; Pll = Weight matrices (41)

Fig. 26. Summarized Adjustment Results

B35 to B40 contains corrections for observation angles. C35 to C40 contains corrections for observation distances. D35 to D40 contains adjusted azimuth. Also, D35 to D40 contains a formula for transformation from radian to grad by the formula (=rad2grd (H17)). E35 to E40 contains adjusted distances. C45 to C51 contains adjusted coordinates in the direction of Y axis. D45 to D51 contains adjusted coordinates in the direction of X axis. 6.4 Adjustment of Coordinates Determined from Satellite Observation Geocentric coordinate values of a point were determined using Doppler Method. The satellite observations were collected in 4 different sessions by taking advantage of different satellite constellations. A priori errors of the coordinates are 1 meter.

Determining of Approximate Coordinates The Approximation coordinates are calculated as to the smallest X, Y, and Z coordinates that the satellite observations were collected in 4 different sessions. The smallest X coordinate is at 4. period. The smallest Y and Z coordinates is at 2. period. So, approximation coordinates, X=3794214.00; Y=478192.00; Z=5172108.00 Settings for Adjustment of Coordinates Determined from Satellite Observation in Excel SOLVER The cells (D21:D32) contain the coordinates that is determined by Doppler method. The cells (F21:F32, G21:G32, H21:H32) contain cofactor matrices of the coordinates. The cells (E21, E32) contain the coordinates differences. The weights are calculated. See equation (42). Excel supports several functions of a matrix. For additional information the reader is encouraged to visit the references (8-9). The references contains to the most current information on the Matrix solution.

152

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

Fig. 27. Settings for Adjustment of Coordinates Determined from Satellite Observation in Excel Table 3. Specifications of Coordinates Determined from Satellite Observation in Excel
Cell Number D21 D32 F21 F32 G21 G32 H21 H32 E21 E22 E23 E24 E25 E26 E27 E28 E29 E30 E31 E32 I21 I32 J21 J32 K21 K32 D35 D36 D37 E35 E36 E37 F35 Formula Cell Number F36 F37 G35 G36 G37 H35 H36 H37 I35 I36 I37 J35 J36 J37 C41 C42 C43 D41 D42 D43 E41 E42 E43 F41 F42 F43 H41 H42 H43 J41 J42 J43 Formula

=D5 =D16 =E5 =E16 =F5 =F16 =G5 =G16 =D21-D35 =D22-D36 =D23-D37 =D24-D35 =D25-D36 =D26-D37 =D27-D35 =D28-D36 =D29-D37 =D30-D35 =D31-D36 =D32-D37 =INDICE(MINVERSE(F21:H23);1;1) =INDICE(MINVERSE(F30:H32);3;1) =INDICE(MINVERSE(F21:H23);1;2) =INDICE(MINVERSE(F30:H32);3;2) =INDICE(MINVERSE(F21:H23);1;3) =INDICE(MINVERSE(F30:H32);3;3) Approximation X coordinate Approximation Y coordinate Approximation Z coordinate =SUM(I21;I24;I27;I30) =SUM(I22;I25;I28;I31) =SUM(I23;I26;I29;I32) =SUM(J21;J24;J27;J30)

=SUM(J22;J25;J28;J31) =SUM(J23;J26;J29;J32) =SUM(K21;K24;K27;K30) =SUM(K22;K25;K28;K31) =SUM(K23;K26;K29;K32) =INDICE(MINVERSE (E35:G37);1;1) =INDICE(MINVERSE (E35:G37);2;1) =INDICE(MINVERSE(E35:G37);3;1) =INDICE(MINVERSE(E35:G37);1;2) =INDICE(MINVERSE(E35:G37);2;2) =INDICE(MINVERSE(E35:G37);3;2) =INDICE(MINVERSE(E35:G37);1;3) =INDICE(MINVERSE(E35:G37);2;3) =INDICE(MINVERSE(E35:G37);3;3) =INDICE(MMULT(I21:K23;E21:E23);1;1) =INDICE(MMULT(I21:K23;E21:E23);2;1) =INDICE(MMULT(I21:K23;E21:E23);3;1) =INDICE(MMULT(I24:K26;E24:E26);1;1) =INDICE(MMULT(I24:K26;E24:E26);2;1) =INDICE(MMULT(I24:K26;E24:E26);3;1) =INDICE(MMULT(I27:K29;E27:E29);1;1) =INDICE(MMULT(I27:K29;E27:E29);2;1) =INDICE(MMULT(I27:K29;E27:E29);3;1) =INDICE(MMULT(I30:K32;E30:E32);1;1) =INDICE(MMULT(I30:K32;E30:E32);2;1) =INDICE(MMULT(I30:K32;E30:E32);3;1) =SUM(C41:F41) =SUM(C42:F42) =SUM(C43:F43) =INDICE(MMULT(H35:J37;H41:H43);1;1) =INDICE(MMULT(H35:J37;H41:H43);2;1) =INDICE(MMULT(H35:J37;H41:H43);3;1)

153

Levent Tasci

Fig. 28. Solver Parameters Dialog Box

Performing of Adjustment by the Excel Solver

Solver Parameters Set Target Cell: Target cell is H44. Equal to: The MIN radio button should be selected. By changing Cells: D35 to D37 contains approximation coordinates of point. Subject to the Constraints: The Constraints are H41, H42 and H43 cell. The Adjustment can be performed by clicking SOLVE button in SOLVER PARAMETER dialog box in figure 28. If the adjustment is successful the Solver dialog box will be displayed as shown in figure 29. Click OK button to save the solution results.

Fig. 29. Adjustment of Coordinates Determined from Satellite Observation by Excel Solver

Adjusted Results
The results of adjustment are given as summary in figure 30.

Fig. 30. Summary of the adjusted results

D47 to D49 contains adjusted coordinates. E47 to E59 contains adjusted coordinates

154

The Adjustment of Some Geodetic Networks Using Microsoft Excel SOLVER

7. Results In this study, Standard Excel Solver that the software comes with Microsoft Office CDRom. is used. Standard Excel Solver supports just 200 decision variables [4]. The adjustment of medium and small geodetic networks with standard Excel Solver is done easiness. The Premium modules of Excel Solver for adjustment of bigger networks must used. Premium Excel Solver supports approximately 32000 decision variables [4]. Premium modules require additional cost. It has been proved that Excel Solver can be used to adjust 3D coordinates of the points pertaining to leveling networks, closed and open traverses using least squares method. Excel solver also can be used to adjust the 3D coordinates of the points determined by GPS observations. The results obtained from Excel Solver are exactly the same as the results obtained from conventional data adjustment tools. Excel Solver has the following advantage and disadvantages; 1. It is not necessary to have a broad knowledge about least squares technique if Excel Solver is used. It will be enough if the user has fundamental knowledge about data adjustment. 2. It is very important to select the cells to be minimized and chosen as constraints correctly. 3. The solution converges quickly. 4. Excel Solver gives flexibility and simplicity to the user in the selection of parameters and constraints. 5. Standard Excel Solver does not require additional cost, for the software comes with Microsoft Office CD-Rom. 6. It does not require complex codes to perform data adjustment. 7. Users dont need complex adjustment programs for adjustment of geodetic networks. 8. Necessary statistical knowledge for analysis of adjustment results arent obtaining from Excel Solver.

8. References
1. 2. 3. 4.

5.

6. 7.

8. 9.

ztrk E., 1991, Dengeleme Hesab Cilt 1, K.T. Mhendislik Mimarlk Fakltesi, Yayn No: 119, Trabzon. Hashimi S, R., 2004, Traverse Adjustment Using Microsoft Excel Solver, ACSM/TAPS Conference, April 19-21, Nashville,TN. http://www.microsoft.com, November 4, 2004, How to Create Visual Basic Macros by Using Excel Solver in Excel 97, Article ID: 843304 Fylstra, D., Lasdon, L., Watson, J., Waren, A., 1998, Design and Use of the Microsoft Excel Solver. Institute for Operations Research and Management Sciences. El-Sheimy, N., Lecture notes Adjustment of Observation, ENGO 362, The University of Calgary Department of Geomatics Engineering. Canada. http://hspm.sph.sc.edu/Courses/J716/SolverInstal l.html, January 13, 2004 Ziggy M., 1995, Teaching Linear Programming using Microsoft Excel Solver, Cheer (Computers in Higher Education Economics Rewiev), Volume 9, Issue 3. Veinott, A, F., 2004, Formulating and Solving Linear Programs in Excel Solver, Introduction to Optimization, MS&E 111. Roy, B, V., 2003, Excel Solver Tutorial, ENGR62/MS&E 111.

155

Оценить