Вы находитесь на странице: 1из 22

Case Study:- MVPN

Author:- Shivlu Jain (TULIP IT)


Document Type:- Informational
Multicast is an important fetaure in the service provider network.
Main Topology
Loopback 0 of PE1 is configured as RP for group 239.1.1.1 for service provider domain only, it means
RP information for the group which is 239.1.1.1 is flooded only on PE1, RR, PE2 and P routers. For RP
announcements auto-rp is used with pim sparse-dense-mode. In MVPN, we have to define the MDT
DEFAULT for particular VPN and it should be unique per vpn basics and this group address should be
reachable in the Service Provider domain. For the reachability of this group address auto-rp is used.
If we donot use any protocol for the rp announcements then by fefauly they will fallback in dense
mode which is really destructive for the service provider network. In this lab we have created only a
single VPN thats why we are using only a single group address, but in actual scenario the number of
groups we want to use should be bind in the access-list which will be binded with the rp
announcements commands. If we donot use any acl for the RP announcements then by default it
will be activated for all the groups. (Always bins your RP advertisements with the help of ACL)
Lets us see how to anounce auto-rp for service providr domain:-
Figure 1
In the figure 1, Loopback 0 is used as RP for group-list 1. In the group-list 1 group 239.1.1.1 is
defined. If you want to add more, then in the acl you can add more groups. Next command which is
send-rp-discovery is used for mapping agent, means the same router is announcing it self as rp
candidate as well as rp mapping agent. Now on the other routers your have to enable ip multicast-
routing and pim sparse-dense mode. Nothing more than that. After doing this you can check the pim
neighbors and rp mappings. In figure 2, PE1 is system rp as well as rp mapping agent for group
239.1.1.1 with RP as 10.10.10.1 which is the loopback 0 address.
Figure 2
Figure 3
Figure 4
Figure 5
From the above snap shots, it is cleared that RP information is flooded in the network correctly.
Step 2:-
Bind VRF TEST with the multicast-routing. On every PE where the VRF TEST is created should be
binded with the given command.
ip multicast-routing vrf TEST
Step 3:-
Create MDT Default for VPN TEST. Under vrf TEST we have to add the command mdt default
239.1.1.1. MDT default should be added where the vrf TEST is created and wants to receive the
multicast stream.
ip vrf TEST
rd 1:1
route-target export 1:1
route-target import 1:1
mdt default 239.1.1.1
After this check the Multicast Tunnel neighbourship on PE1 & PE2
Figure 7
Step 4:-
Check which MDT group is used for which VRF
Figure 8
Figure 9
239.1.1.1 is the MDt group for VRF TEST and Tunnel 0 is used for forwarding and receiving the
multicast traffic with source interface is loopback 0 of the PE routers. (Loopback 0 or the loopback
which is used for BGP peering should be enabled with sparse-dense mode.)
Actually we have not created tunnel 0, it is default mechanism, as soon as we enable mdt in the vrf
they made their neighborships on tunnels. You can check the tunnel status by issuing the show
interface tunnel 0 command.
On PE1 we have checked the tunnel 0 status and from the outcome it is very much cleared that this
tunnel is used for group 239.1.1.1 with source address is 10.10.10.1 and tunnel protocol is GRE/IP
MULTICAST. One cannot make the changes in the tunnel. Lets try to enter in the tunnel 0. (see figure
11). It clearly states that tunnel 0 is used for multicast and configuration is not allowed.
Figure 10
Figure 11
Step 5:-
CE1 is using its loopback 0 as RP for all the groups with the help of auto-rp. Given commands are
used on CE1.
ip pim send-rp-announce Loopback0 scope 16
ip pim send-rp-discovery scope 16
After that you can check the rp mappings on CE1
Figure 12
As defined above If donot bind the acl with the rp announcements then it will act the rp for all
groups.
RP Mappings on PE1 for VRF TEST
Figure 13
RP Mappings on PE2 for VRF TEST
Figure 14
RP Mappings on CE2
Figure 15
Now CE2 is able to discover its RP for all groups and the same is discovered with the help of auto-rp.
The main improvement of using this over static RP is that on every PE where the VRF TEST is
configured should be configured with static RP information for that VRF and if any changes occurs in
RP then the same has to be changed on all the PE routers. But with the help of auto-rp this problem
could be overcome.
Step 6:-
Loopback 0 of CE1 is originating stream for group 224.1.1.1 and Loopback 0 of CE2 is receiver. On
CE1 with the help of IP SLA command stram is generated for group 224.1.1.1 as source 10.1.1.1
which is the loopback address of CE1. On CE2 loopback 0 has joined the group 224.1.1.1 with the
help of IP IGMP JOIN-GROUP command.
Configuration on CE1
ip sla monitor 1
type udpEcho dest-ipaddr 224.1.1.1 dest-port 33333 source-ipaddr 10.1.1.1
timeout 10
frequency 3
ip sla monitor schedule 1 life forever start-time now
Showip mroute output on CE1
(10.1.1.1, 224.1.1.1), 00:43:59/00:03:05, flags: T
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:28:36/00:02:55
Show ip mroue vrf TEST 224.1.1.1 on PE1
(*, 224.1.1.1), 00:20:01/00:01:55, RP 10.1.1.1, flags: SJL
Incoming interface: FastEthernet0/0, RPF nbr 172.168.2.2
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:19:51/00:01:55
(10.1.1.1, 224.1.1.1), 00:19:58/00:03:29, flags: LT
Incoming interface: FastEthernet0/0, RPF nbr 172.168.2.2
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:19:51/00:02:01
Show ip mroute output on PE2
(*, 224.1.1.1), 00:20:25/00:02:28, RP 10.1.1.1, flags: SJCL
Incoming interface: Tunnel0, RPF nbr 10.10.10.1
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:20:25/00:02:28
(10.1.1.1, 224.1.1.1), 00:20:20/00:03:28, flags: LT
Incoming interface: Tunnel0, RPF nbr 10.10.10.1
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:20:20/00:02:31
Show ip mroute output on CE2
(*, 224.1.1.1), 00:28:33/stopped, RP 10.1.1.1, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:28:33/00:02:24
(10.1.1.1, 224.1.1.1), 00:28:33/00:02:55, flags: LJT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:28:33/00:02:24
(*,G),Outgoing of CE1 is Fa0/0 and
incoming of PE1 is Fa0/0 (which is
attached with CE1) and outgoing of
PE 1 is Tunnel0 (which is multicast
tunnel)
(S,G) entry is created, means
10.1.1.1 is the source for group
224.1.1.1, Incoming interface is
fa0/0 (which is connected with
CE1) and Outgoing interface is
Tunnel 0 (which is multicast
tunnel)
Multicast traffic is received on
tunnel 0 and forwarding on fa0/0
which is attached with CE2
Loopback 0 has joined multicast
group 224.1.1.1
Configuration of CE2
interface Loopback0
ip address 10.1.1.2 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.1.1.1
end
Configuration Of PE1
hostname SHIVLU-PE1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
ip vrf TEST
rd 1:1
route-target export 1:1
route-target import 1:1
mdt default 239.1.1.1
!
ip multicast-routing
ip multicast-routing vrf TEST
!
multilink bundle-name authenticated
mpls label protocol ldp
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding TEST
ip address 172.168.2.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.1.1.1
load-interval 30
duplex auto
speed auto
service-policy input P-TELNET
!
interface FastEthernet0/1
ip address 2.2.2.1 255.255.255.252
ip pim sparse-dense-mode
load-interval 30
duplex auto
speed auto
mpls label protocol ldp
mpls ip
service-policy output BP-TELNET
!
interface FastEthernet2/0
ip address 2.2.2.10 255.255.255.252
ip pim sparse-dense-mode
ip ospf 1 area 0
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.10.10.1
log-adjacency-changes
network 2.2.2.1 0.0.0.0 area 0
!
router bgp 1
bgp router-id 10.10.10.1
bgp log-neighbor-changes
neighbor 10.10.10.4 remote-as 1
neighbor 10.10.10.4 update-source Loopback0
!
address-family ipv4
neighbor 10.10.10.4 activate
neighbor 10.10.10.4 send-community both
neighbor 10.10.10.4 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.10.10.4 activate
neighbor 10.10.10.4 send-community both
neighbor 10.10.10.4 next-hop-self
exit-address-family
!
address-family ipv4 vrf TEST
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip route vrf TEST 10.1.1.1 255.255.255.255 172.168.2.2
no ip http server
no ip http secure-server
!
!
ip pim send-rp-announce Loopback0 scope 16 group-list 1
ip pim send-rp-discovery scope 16
!
logging alarm informational
access-list 1 permit 239.1.1.1
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
no login
!
!
webvpn cef
!
end
Configuration Of RR
hostname SHIVLU-RR
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
ip multicast-routing
!
multilink bundle-name authenticated
mpls label protocol ldp
!
archive
log config
hidekeys
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.4 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 2.2.2.13 255.255.255.252
ip pim sparse-dense-mode
ip ospf 1 area 0
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 2.2.2.5 255.255.255.252
ip pim sparse-dense-mode
ip ospf 1 area 0
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 2.2.2.9 255.255.255.252
ip pim sparse-dense-mode
ip ospf 1 area 0
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.10.10.4
log-adjacency-changes
!
router bgp 1
template peer-policy INTERNAL
route-reflector-client
send-community both
exit-peer-policy
!
template peer-session INTERNAL
remote-as 1
update-source Loopback0
exit-peer-session
!
bgp router-id 10.10.10.4
bgp log-neighbor-changes
neighbor 10.10.10.1 inherit peer-session INTERNAL
neighbor 10.10.10.2 inherit peer-session INTERNAL
neighbor 10.10.10.3 inherit peer-session INTERNAL
!
address-family ipv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 inherit peer-policy INTERNAL
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 inherit peer-policy INTERNAL
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 inherit peer-policy INTERNAL
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
neighbor 10.10.10.1 inherit peer-policy INTERNAL
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 send-community extended
neighbor 10.10.10.3 inherit peer-policy INTERNAL
exit-address-family
!
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
End
Configuration Of P
hostname SHIVLU-P
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
ip multicast-routing
!
multilink bundle-name authenticated
mpls label protocol ldp
!
archive
log config
hidekeys
!
!
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 1.1.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 2.2.2.6 255.255.255.252
ip pim sparse-dense-mode
ip ospf 1 area 0
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.10.10.2
log-adjacency-changes
network 1.1.1.2 0.0.0.0 area 0
network 2.2.2.2 0.0.0.0 area 0
!
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
no login
!
End
Configuration of PE2
hostname SHIVLU-PE2
!
ip cef
!
ip vrf TEST
rd 1:1
route-target export 1:1
route-target import 1:1
mdt default 239.1.1.1
!
ip multicast-routing
ip multicast-routing vrf TEST
!
multilink bundle-name authenticated
mpls label protocol ldp
!
archive
log config
hidekeys
!
interface Loopback0
ip address 10.10.10.3 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
description connected to ce2
ip vrf forwarding TEST
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.1.1.1
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.252
ip pim dr-priority 0
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 2.2.2.14 255.255.255.252
ip pim dr-priority 0
ip pim sparse-dense-mode
ip ospf cost 1
ip ospf 1 area 0
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.10.10.3
log-adjacency-changes
redistribute static
network 1.1.1.1 0.0.0.0 area 0
network 2.2.2.14 0.0.0.0 area 0
network 172.16.1.1 0.0.0.0 area 5
!
router bgp 1
bgp router-id 10.10.10.3
bgp log-neighbor-changes
neighbor 10.10.10.4 remote-as 1
neighbor 10.10.10.4 update-source Loopback0
!
address-family ipv4
neighbor 10.10.10.4 activate
neighbor 10.10.10.4 send-community both
neighbor 10.10.10.4 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.10.10.4 activate
neighbor 10.10.10.4 send-community both
neighbor 10.10.10.4 next-hop-self
exit-address-family
!
address-family ipv4 vrf TEST
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip route vrf TEST 10.1.1.2 255.255.255.255 172.16.1.2
no ip http server
no ip http secure-server
!
logging alarm informational
!
control-plane
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
no login
!
End
Configuration of Ce1
hostname SHIVLU-CE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
ip sla monitor 1
type udpEcho dest-ipaddr 224.1.1.1 dest-port 33333 source-ipaddr 10.1.1.1
timeout 10
frequency 3
ip sla monitor schedule 1 life forever start-time now
!
!
!
!
track 1 rtr 1 reachability
delay down 10 up 20
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
ip address 172.168.2.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
ip http server
!
ip route 0.0.0.0 0.0.0.0 172.168.2.1
!
ip pim send-rp-announce Loopback0 scope 16
ip pim send-rp-discovery scope 16
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
End
Configuration of Ce2
hostname SHIVLU-CE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
!
!
!
!
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.1.1.1
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
ip http server
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login