Вы находитесь на странице: 1из 15

INTERCONEXIN DE SERVICIOS DE TELECOMUNICACIONES

Por: Alexander P. Scola C. Curso: 10mo B



PRCTICA DE ENRUTAMIENTO RIP, ATM Y MPLS

ENRUTAMIENTO RIP

Figura 1. Escenario de la prctica del protocolo de enrutamiento RIP

Configuracin del escenario
El objetivo de esta prctica es establecer el enrutamiento RIP entre dos subredes con diferentes nmero de
hosts, para lo cual se tuvo que realizar el subneteo y no haya desperdicio de direcciones IP, se escogi la
versin 2 de RIP ya que esta soporta VLSM (mscara de subred de longitud variable).
Procedimiento:
RED_A# configure terminal // entrar al modo de configuracin global
RED_A(config)# interface serial 1/0 // ingresar a la interfaz serial 1/0 para configurarla
RED_A(config-if)# ip address 10.2.2.1 255.255.255.252 // le asignamos una direccin IP y mscara de
subred a la interfaz
RED_A(config-if)# no shutdown // activamos la interfaz
RED_A(config-if)# exit // salimos de la interfaz

RED_A(config)# interface fastethernet 0/0 // ingresamos a la interfaz fastethernet 0/0
RED_A(config-if)# ip address 192.168.10.1 255.255.255.224// le asignamos una direccin IP y mscara de
subred a la interfaz
RED_A(config-if)# no shutdown // activamos la interfaz
RED_A(config-if)# exit // salimos de la interfaz
RED_A(config)# router rip // habilita el protocolo RIP en todas las interfaces que pertenezcan a esta red
R1(config-router)# versin 2 // habilitamos la versin 2 que soporta VLSM
RED_A(config-router)# network 10.2.2.0 // ponemos todas las redes que estn directamente conectadas a
las interfaces del router para que puedan ser publicadas en las tablas de enrutamiento
RED_A(config-router)# network 192.168.10.0
RED_A(config-router)# no auto-sumary // para que no sumarice a toda la red en una sola clase
RED_A(config-if)# exit // salimos de la interfaz
RED_A(config)# end // salimos al modo de usuario privilegiado
RED_A# copy running-config startup-config // guarda la configuracin en la NVRAM

En el router RED_B son las mismas configuraciones que en RED_A, lo nico que va a cambiar son las
direcciones IP de las interfaces y la mscara de subred fastethernet ya que el nmero de hosts es 12 por
ende tambin cambiar la subred que se pondr en el protocolo RIP.
RED_B(config)# interface serial 1/0 // ingresar a la interfaz serial 1/0 para configurarla
RED_B(config-if)# ip address 10.2.2.2 255.255.255.252 // le asignamos una direccin IP y mscara de
subred

RED_B(config)# interface fastethernet 0/0 // ingresamos a la interfaz fastethernet 0/0
RED_B(config-if)# ip address 192.168.10.33 255.255.255.240// le asignamos una direccin IP y mscara de
subred

RED_B(config-router)# network 192.168.10.32
RED_A(config-router)# no auto-sumary // para que no sumarice a toda la red en una sola clase

Para comprobar si las interfaces se ha colocado correctamente y se encuentran levantadas utilizamos el
comando show ip interface brief en el modo de usuario privilegiado y como vamos a ver en la siguiente
imagen, todas las interfaces que configuramos se encuentran en estado activo (up).

Figura 2.Estado de las interfaces de los routers RED_A y RED_B.

Como ya se dijo anteriormente en RIP se tienen que colocar las subredes que estn directamente
conectadas para que estas puedan ser publicadas en sus tablas de enrutamiento y como se puede apreciar
en las dos tablas de enrutamiento de los routers RED_A y RED_B, con el comando show ip route, estn las
dos redes directamente conectadas a las interfaces serial y fastethernet que se las representa con la letra C
y la subred remota con el protocolo de enrutamiento RIP que est llegando a ese router, en el caso de
RED_A est la subred 192.168.10.32/28 que pertenece a RED_B y est saliendo por la interfaz serial s1/0, de
la misma manera RED_B tiene en su tabla de enrutamiento la subred 192.168.10.0/27 que pertenece a
RED_A y est saliendo por la interfaz serial s1/0 del mismo, para que se puedan ver las diferentes subredes
con su mscara se coloc el comando no auto-sumary en RIP para que no sumarice toda la red y la publique
como una sola clase.

Figura 3. Tablas de enrutamiento de los ruters RED_A y RED_B.

Finalmente para comprobar que las configuraciones del protocolo de enrutamiento RIP que hicimos en
RED_A y RED_B hacemos un ping entre los dos hosts de las dos subredes remotas y cmo podemos
apreciar en la siguiente imagen, este es exitoso tanto de PC1 a PC2 como de PC2 a PC1.

Figura 4. Ping exitoso entre los hosts remotos en RIP.

Con el comando trace en el simulador virtual de un PC de GNS3 podemos ver la ruta que toma el paquete
hasta llegar a su destino, en el primer caso determinamos la ruta que tomara llegar desde PC1 a PC2 y
cmo podemos ver en la imagen hay dos saltos (routers) por los cuales se atraviesa hasta llegar al destino,
el primero es la interfaz fastethernet de RED_A, el segundo es la interfaz serial de RED_B y el tercero ya es
el hosts al cual queremos llegar. El mismo nmero de saltos tenemos en el caso de ir desde RED_B hacia
RED_A.

Figura 5. Ruta que toman los paquetes hasta llegar a su destino.


ATM

Figura 6. Escenario de la prctica de ATM.

Cmo podemos ver en el escenario de la prctica de ATM tenemos dos routers en el que vamos a tener un
circuito virtual (VC), VPI (Identificador de camino virtual) y VCI (Identificador de camino virtual) con una
encapsulacin AAL5SNAP, adems de configurar el protocolo de enrutamiento RIP para que pueda haber
conexin entre los hosts remotos PC1 y PC2.
Procedimiento:
R1# configure terminal // entrar al modo de configuracin global
R1(config)# interface atm 1/0 // ingresar a la interfaz atm para configurarla
R1(config-if)# ip address 10.1.1.2 255.255.255.0 // le asignamos una direccin IP y mscara de subred a la
interfaz atm
R1(config-if)# atm ilmi-enable // activa la sealizacin ILMI en la interfaz
R1(config-if)# atm ilmi-keepalive// con este comando se mantiene activa la sealizacin ILMI
R1(config-if)# atm pvc 1 0 100 aal5snap inarp// informa de la configuracin de un PVC, siendo 1 una
etiqueta interna al propio router, 0 nmero que identifica el VPI y 100 es el VCI [2], AAL5SNAP es la
encapsulacin e INARP.
R1(config-if)# exit // salimos de la interfaz

R1(config)# map-list listaprueba //creamos una lista de conmutacin para una interfaz fsica
R1(config)# ip 10.1.1.1 atm-vc 1// asocia la lista con una direccin IP a un VC especfico

R1(config)# interface atm 1/0 // ingresar a la interfaz atm para configurarla
R1(config-if)# map-group listaprueba// asocia la lista creada a una interfaz fsica
R1(config-if)# no shutdown // activamos la interfaz
R1(config-if)# exit // salimos de la interfaz

R1(config)# router rip // habilita el protocolo RIP en todas las interfaces que pertenezcan a esta red
R1(config-router)# versin 2 // habilitamos la versin 2 que soporta VLSM
R1(config-router)# network 10.0.0.0 // ponemos todas las redes que estn directamente conectadas a las
interfaces del router para que puedan ser publicadas en las tablas de enrutamiento
R1(config-router)# network 192.168.10.0
R1(config-if)# exit // salimos de la interfaz
R1(config)# end // salimos al modo de usuario privilegiado
R1# copy running-config startup-config // guarda la configuracin en la NVRAM

Para el router R2 hacemos las mismas configuraciones que en R1, lo que va a cambiar es las direcciones IP;
en la lista de conmutacin de circuitos ponemos la direccin del router R1 para que ambos routers puedan
comunicarse y en RIP se va a poner la otra red que est directamente conectada en R2 hacia el host.
R2(config)# interface atm 1/0 // ingresar a la interfaz atm para configurarla
R2(config-if)# ip address 10.1.1.1 255.255.255.0 // le asignamos una direccin IP y mscara de subred a la
interfaz

R2(config)# map-list listaprueba // creamos una lista de conmutacin para una interfaz fsica
R2(config)# ip 10.1.1.2 atm-vc 1// asocia la lista con una direccin IP a un VC especfico

R2(config)# interface atm 1/0 // ingresar a la interfaz atm para configurarla
R2(config-if)# map-group listaprueba// asocia la lista creada a una interfaz fsica

R2(config-router)# network 192.168.11.0 // subred que est directamente conectada hacia C2

Con el comando show interfaces a1/0 se puede observar toda la configuracin que se ha hecho en la
interfaz atm y como se puede observar en la siguiente imagen de las dos interfaces atm etas estn
levantadas con la encapsulacin AAL5 y que existe slo un circuito virtual entre los dos routers.

Figura 7. Configuraciones de las interfaces ATM de los routers R1 y R2.

Para ver la tabla de conmutacin de circuitos de los routers utilizamos el comando show atm map, y como
observamos se muestra la lista de conmutacin que tiene cada uno, en R1 la lista de conmutacin se llama
listaprueba la ip a la que va a conmutar es 10.1.1.1 y tiene un solo circuito virtual, en R2 la lista de
conmutacin se llama de la misma manera listaprueba para que pueda haber la conmutacin en el mismo
circuito, la ip a la que va a conmutar es 10.1.1.2 que es la direccin de la interfaz serial de R1 y esta
tambin tiene un solo circuito virtual de la misma manera que en R1.

Figura 8. Tabla de conmutacin de circuitos ATM en los routers R1 y R2.

Como se dijo anteriormente con el comando show ip route podemos ver la tabla de enrutamiento de los
diferentes routers, en ATM tambin se puso hosts en cada router por ende estos van a estar de forma
remota y no tendrn comunicacin a menos que coloque un protocolo de enrutamiento, se le coloc RIP
igual que la prctica anterior y cmo podemos observar en la siguiente figura se estn publicando en su
tabla de enrutamiento la subred del otro router, en R1 se publica la subred 192.168.11.0/24 va la direccin
IP 10.1.1.1 que pertenece a R2, de la misma manera en R2 se publica la subred 192.168.10.0/24 va la
direccin IP 10.1.1.2 que pertenece a R1.

Figura 9. Tablas de enrutamiento de R1 y R2.

Para comprobar que las configuraciones que se hizo estn correctas procedemos a verificar haciendo un
ping entre los dos routers y como se puede apreciar en la imagen se observa que de R1 a R2 el ping es
exitoso, de la misma manera de R2 a R1. Pero cuando se hace el ping a si mismo tanto en R1 como en R2
este falla, esto se debe a que slo existe un circuito virtual y se lo est ocupando para ir hacia el otro router.

Figura 10. Ping entre R1 y R2 y as mismos.

Finalmente para ver si se llega de PC1 a PC2 mediante el protocolo de enrutamiento RIP que se configur,
se hace un ping entre los dos hosts remotos y como se observa el ping es xito tanto de PC1 a PC2 como de
PC2 a PC1.

Figura 11. Ping entre los hosts PC1 Y PC2.
MPLS

Figura 12.Escenario de la prctica de MPLS.

El objetivo de esta prctica es establecer un enlace MPLS con la topologa que observamos en la figura 12,
para ello se ha colocado tres routers que soporten MPLS, en cada uno de ellos se le habilita CEF (Cisco
Express Fordwarding), CEF es el mtodo usado por Cisco para crear las FIB (Forwarding Information Base) y,
por consiguiente, las LFIB (Label Forwarding Information Base) para MPLS. Tambin configurar un protocolo
de enrutamiento como OSPF para que los routers publiquen en sus tablas de enrutamiento las redes
remotas y pueda haber conexin entre PC1 y PC2. Una interfaz Loopback que nos va a servir para hacer
pruebas, es decir lo mismo que hace un lazo fsico pero ahora va a ser un lazo lgico.
Procedimiento.
R1# configure terminal // ingresamos al modo de configuracin global
R1(config)# ip cef // habilitamos CEF en el router
R1(config)# mpls label protocol ldp // definimos LDP como protocolo para distribucin de etiquetas MPLS
R1(config)# mpls ip // habilitamos MPLS a nivel global

R1(config)# interface loopback 0 // accedemos a la interfaz Loopback 0
R1(config-if)# ip address 192.168.1.1 255.255.255.255 // le asignamos una direccin IP y mscara de subred
R1(config-if)# no shutdown // levantamos la interfaz
R1(config-if)# exit // salimos de la intefaz Loopback 0

R1(config)# interface f1/0 // ingresamos a la interfaz fastethernet 1/0
R1(config-if)# ip address 192.168.3.1 255.255.255.0 // le asignamos una direccin IP y mscara de subred
R1(config-if)# no shutdown // levantamos la interfaz
R1(config-if)# exit // salimos de la interfaz fastethernet 1/0

R1(config)# interface f1/1 // ingresamos a la interfaz fastethernet 1/1
R1(config-if)# ip address 192.168.7.1 255.255.255.0 // le asignamos una direccin IP y mscara de subred
R1(config-if)# no shutdown // levantamos la interfaz
R1(config-if)# exit // salimos de la interfaz fastethernet 1/1

R1(config)# router ospf 1 // habilitamos el protocolo de enrutamiento OSPF con el identificador 1
R1(config-router)# mpls traffic-eng router-id loopback 0 // usaremos la interfaz Loopback 0 como
identificador de router (RID) para traffic engineering [1].
R1(config-router)# mpls traffic-eng area 0 // habilita traffic engineering en el rea 0 [1].
R1(config-router)# network 192.168.1.1 0.0.0.0 area 0// colocamos las subredes que se encuentran
directamente conectadas en el router para que puedan ser publicadas en las tablas de enrutamiento de los
otros routers, en OSPF se pone la Wilcard Mask de cada subred y con su respectiva rea que debe ser la
misma para todas las subredes
R1(config-router)# network 192.168.3.0 0.0.0.255 area 0//
R1(config-router)# network 192.168.7.0 0.0.0.255 area 0//
R1(config-router)# exit // salimos de OSPF

R1(config)# interface f1/0 // ingresamos a la interfaz fastethernet 1/0
R1(config-if)# mpls ip // habilitamos MPLS en la interfaz ya que es parte de este dominio (LER)
R1(config)# end // salimos al modo de usuario privilegiado
R1# copy running-config startup-config // guarda la configuracin en la NVRAM

La configuracin en R2 es prcticamente la misma, lo que va a cambiar son las direcciones IP y mscara de
subred de las interfaces y tambin de la Loopback 0, con ello las direcciones de subred en OSPF tambin
cambiarn, finalmente activar mpls ip en las interfaces f1/0 y f1/1 ya que son parte del dominio MPLS.
R2(config)# interface loopback 0 // accedemos a la interfaz Loopback 0
R2(config-if)# ip address 192.168.1.2 255.255.255.255 // le asignamos una direccin IP y mscara de subred

R2(config)# interface f1/0 // ingresamos a la interfaz fastethernet 1/0
R2(config-if)# ip address 192.168.3.2 255.255.255.0 // le asignamos una direccin IP y mscara de subred

R2(config)# interface f1/1 // ingresamos a la interfaz fastethernet 1/1
R2(config-if)# ip address 192.168.4.2 255.255.255.0 // le asignamos una direccin IP y mscara de subred

R2(config-router)# network 192.168.1.2 0.0.0.0 area 0// colocamos las subredes que se encuentran
directamente conectadas en el router para que puedan ser publicadas en las tablas de enrutamiento de los
otros routers, en OSPF se pone la Wilcard Mask de cada subred y con su respectiva rea que debe ser la
misma para todas las subredes
R2(config-router)# network 192.168.3.0 0.0.0.255 area 0//
R2(config-router)# network 192.168.4.0 0.0.0.255 area 0//

R2(config)# interface f1/0 // ingresamos a la interfaz fastethernet 1/0
R2(config-if)# mpls ip // habilitamos MPLS en la interfaz ya que es parte de este dominio (LSR)
R2(config)# interface f1/1// ingresamos a la interfaz fastethernet 1/1
R2(config-if)# mpls ip // habilitamos MPLS en la interfaz ya que es parte de este dominio (LSR)


En R3 la configuracin va a ser parecida que en R1 ya que ambos son LER, por ende van a cambiar las
direcciones IP y mscaras de subred de las interfaces as como en el protocolo de enrutamiento OSPF
R3(config)# interface loopback 0 // accedemos a la interfaz Loopback 0
R3(config-if)# ip address 192.168.1.3 255.255.255.255 // le asignamos una direccin IP y mscara de subred

R3(config)# interface f1/1 // ingresamos a la interfaz fastethernet 1/1
R3(config-if)# ip address 192.168.4.1 255.255.255.0 // le asignamos una direccin IP y mscara de subred

R3(config)# interface f1/0 // ingresamos a la interfaz fastethernet 1/0
R3(config-if)# ip address 192.168.5.1 255.255.255.0 // le asignamos una direccin IP y mscara de subred

R3(config-router)# network 192.168.1.3 0.0.0.0 area 0// colocamos las subredes que se encuentran
directamente conectadas en el router para que puedan ser publicadas en las tablas de enrutamiento de los
otros routers, en OSPF se pone la Wilcard Mask de cada subred y con su respectiva rea que debe ser la
misma para todas las subredes
R3(config-router)# network 192.168.4.0 0.0.0.255 area 0//
R3(config-router)# network 192.168.5.0 0.0.0.255 area 0//

R3(config)# interface f1/1// ingresamos a la interfaz fastethernet 1/1
R3(config-if)# mpls ip // habilitamos MPLS en la interfaz ya que es parte de este dominio (LER)

Ya que hemos hecho estas configuraciones en R1, R2 y R3 podemos verificar las direcciones IP que se ha
colocado a cada interfaz as como tambin ver su estado si est activo o apagado, como apreciamos en la
siguiente imagen las direcciones de cada interfaz estn activas as como el protocolo de enrutamiento que
se habilit, el comando para ver esto es show ip interface brief.

Figura 13. Estado de las diferentes interfaces de R1, R2 y R3.

Con el comando show mpls interfaces podemos apreciar el protocolo de distribucin de etiquetas (LDP) en
MPLS y cuales interfaces son parte de este dominio, en R1 la interfaz fastethernet f1/0, en R3 la interfaz
fastethernet f1/1 estos son los routers frontera (LER) y en R2 las interfaces fastethernet f1/0 y f1/1 son
parte del router conmutador de etiquetas (LSP).

Figura 14. Estado de las interfaces MPLS en R1, R2 y R3.

En esta prctica de MPLS habilitamos el protocolo de enrutamiento OSPF que posee una distancia
administrativa de 110 y es menor que RIP, en OSPF hay que poner la Wilcard Mask y su rea para que
puedan publicarse en las diferentes tablas de enrutamiento de los routers, para ver estas tablas se pone el
comando show ip route como ya se ha mencionado anteriormente.
En R1 observamos que estn tres redes directamente conectadas a las interfaces f1/0, f1/1 y Loopback 0,
cuatro redes remotas que estn llegando con el protocolo de enrutamiento OSPF a travs de la interfaz
fastethernet 1/0 y va la direccin 192.168.3.2 que pertenece a R2, dos redes tienen 2 saltos antes de llegar
a R1, las dos restantes estn ms lejos y tienen 3 saltos.
En R2 observamos que estn tres redes directamente conectadas a las interfaces f1/1, f1/0 y Loopback 0,
cuatro redes remotas que estn llegando con el protocolo de enrutamiento OSPF a travs de las dos
interfaces fastethernet 1/1 y 1/0, por f1/1 llegan dos redes va la direccin IP 192.168.4.1 que pertenece a
R3 y con dos saltos, por f1/0 llegan dos redes va la direccin IP 192.168.3.1 que pertenece a R1 y tambin
con dos saltos antes de llegar a R2.
En R3 observamos que la tabla de enrutamiento es similar a R1 ya que tiene tres redes directamente
conectadas a las interfaces f1/0, f1/1 y Loopback 0, cuatro redes remotas que estn llegando con el
protocolo de enrutamiento OSPF a travs de la interfaz fastethernet 1/1 y va la direccin 192.168.4.2 que
pertenece a R2, dos redes tienen 2 saltos antes de llegar a R3 las dos restantes estn ms lejos y tienen 3
saltos.

Figura 15.Tablas de enrutamiento de R1, R2 y R3.

Para ver la tabla de conmutacin de etiquetas utilizamos el comando show mpls forwarding table que nos
muestra las etiquetas que se colocan a las diferentes direcciones IP, se puso en este comando en R2 ya que
este es el LSR y se puede ver como los paquetes ICMP del ping van cambiando de etiqueta al momento de
realizarlo. Tambin se coloc este comando en los routers de borde LER para ver como colocan la etiqueta
de salida a la red que es parte del dominio MPLS a aquellas redes que no pertenecen al dominio, un ejemplo
en R1 donde la red 192.168.5.0/24 que sale por la interfaz f1/0 y no es parte del dominio MPLS le dan una
etiqueta local de 19, pero para que salga al dominio MPLS le dan la etiqueta 18 y esta etiqueta es la que
aparece en R2 con la red antes mencionada.
En R2 se puede observar que para la direccin de red 192.168.5.0/32 que pertenece a R1 se le da una
etiqueta de 18 como se mencion anteriormente, est saliendo por la interfaz f1/1 de R2 y su siguiente
salto es la direccin IP 192.168.4.1 que pertenece a R3.

Figura 16.Tablas de conmutacin de etiquetas de R1, R2 y R3.

Para que se pueda apreciar el cambio de los valores de conmutacin de los paquetes que se estn enviando
por el dominio MPLS es necesario que se enven de manera continua, es por eso que se hizo un ping
extendido entre los dos hosts remotos, aprecindose as el cambio de la conmutacin de los paquetes en la
imagen anterior y como se realiz el ping extendido en la siguiente figura.

Figura 17.Ping extendido entre los hosts remotos.

Como ya se dijo anteriormente el comando trace sirve para ver la ruta que toman los paquetes hasta llegar
a su destino, en este caso trazamos la ruta desde PC1 a PC2 y viceversa, dndonos como resultado que
existen tres saltos (routers) hasta llegar al otro host.

Figura 18.Ruta que toman los paquetes para llegar a su destino.

Conclusiones
El ping en ATM fue exitoso al momento de realizarlo de R1 a R2 como de R2 a R1, pero no fue
exitoso cuando se realiz el ping a s mismo, esto debido a que se coloc slo un circuito virtual
entre las interfaces ATM de R1 y R2, el ping necesita enviar paquetes ICMP tanto de ida como de
vuelta para ver cunto se demora el paquete en llegar al destino como ya est ocupado el nico
circuito virtual no es posible obtener la respuesta del ping en el mismo router.

En ATM se pudo observar como la lista de conmutacin que se cre se la asoci a una direccin IP y
esta a su vez a un VC, posteriormente este VC se asociaba a una interfaz fsica por la cual conmuta
con los dems routers que tienen interfaces ATM.

En la prctica de MPLS pude apreciar como el Router Frontera entre Capas (LER) da una etiqueta a
una red que no es parte del dominio MPLS, el LER luego pone una etiqueta de salida para que pueda
identificar a esta red en el dominio MPLS y esta etiqueta es la que llega al Router Conmutador de
Etiquetas (LSR) para que pueda enrutarla a su destino.


Referencias

[1] Univesitat Politcnica de Catalunya, Jordi Lores Jacinto, Configuracin y pruebas de funcionamiento de la
interconexin de redes heterogneas con troncal MPLS, [en lnea], disponible en:
<http://upcommons.upc.edu/pfc/bitstream/2099.1/11730/1/PFC.pdf>, [Consulta del 6-05-1014].
[2] Universidad Politcnica de Madrid, Laboratorio de Ingeniera de Redes y Servicios Telemticos, [en lnea],
disponible en: <http://www.lab.dit.upm.es/~labrst/exam/exjun05.pdf>, [Consulta del 11-05-1014].