Вы находитесь на странице: 1из 19

CCNPv6 SWITCH

Chapter 5 Lab 5-1, Hot Standby Router Protocol


Topology
Objective
Configure inter-VLAN routing ith HSRP to pro!ide redundant, fault-tolerant routing to the internal
netor"#
Background
Hot Standby Router Protocol $HSRP% i& a Ci&co-proprietary redundancy protocol for e&tabli&hing a fault-
tolerant default gateay# 't i& de&cribed in R(C ))*1# HSRP pro!ide& a tran&parent failo!er +echani&+ to the
end &tation& on the netor"# ,hi& pro!ide& u&er& at the acce&& layer ith uninterrupted &er!ice to the netor"
if the pri+ary gateay beco+e& inacce&&ible# ,he Virtual Router Redundancy Protocol $VRRP% i& a
&tandard&-ba&ed alternati!e to HSRP and i& defined in R(C -./*# ,he to technologie& are &i+ilar but not
co+patible# ,hi& lab focu&e& on HSRP#
Note: ,hi& lab u&e& Ci&co 0S-C)1/2-)3,,-L &itche& ith the Ci&co '4S i+age c)1/2-lanba&e"1-+5#1))-
3/#S6#bin, and Cataly&t -5/2-)3PS ith the Ci&co '4S i+age c-5/2-ad!ip&er!ice&"1-+5#1))-3/#S6#bin# 7ou
can u&e other &itche& $&uch a& )152 or -552% and Ci&co '4S Softare !er&ion& if they ha!e co+parable
capabilitie& and feature&# 8epending on the &itch +odel and Ci&co '4S Softare !er&ion, the co++and&
a!ailable and output produced +ight !ary fro+ hat i& &hon in thi& lab#
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1 of 11
CCNPv6 SWITCH
e!uired e"ource"
) &itche& $Ci&co )1/2 ith the Ci&co '4S Relea&e 1)#)$3/%S6 C)1/2-LAN;AS6<1-= i+age or
co+parable%
) &itche& $Ci&co -5/2 ith the Ci&co '4S Relea&e 1)#)$3/%S6 C-5/2-A8V'PS6RV'C6S<1-+5
i+age or co+parable%
6thernet and con&ole cable&
Step #: Prepare t$e "%itc$e" &or t$e lab'
6ra&e the &tartup config, delete the !lan#dat file, and reload the &itche&# Refer to Lab 1-1, >Clearing a
Sitch? and Lab 1-), >Clearing a Sitch Connected to a Larger Netor"? to prepare the &itche& for thi& lab#
Cable the e@uip+ent a& &hon#
Step (: Con&igure t$e $o"t IP "etting"'
Configure each ho&t ith the 'P addre&&, &ubnet +a&", and default gateay &hon in the topology#
Step ): Con&igure ba"ic "%itc$ para*eter"'
a# Configure +anage+ent 'P addre&&e& in VLAN 1, and the ho&tna+e, pa&&ord, and ,elnet acce&& on all
four &itche&#
Switch(config)# hostname ALS1
ALS1(config)# enable secret cisco
ALS1(config)# line vty 0 15
ALS1(config-line)# password cisco
ALS1(config-line)# login
ALS1(config-line)# exit
ALS1(config)# interface vlan 1
ALS1(config-if)# ip address 172.1.1.101 255.255.255.0
ALS1(config-if)# no sh!tdown
Switch(config)# hostname ALS2
ALS2(config)# enable secret cisco
ALS2(config)# line vty 0 15
ALS2(config-line)# password cisco
ALS2(config-line)# login
ALS2(config-line)# exit
ALS2(config)# interface vlan 1
ALS2(config-if)# ip address 172.1.1.102 255.255.255.0
ALS2(config-if)# no sh!tdown
Switch(config)# hostname "LS1
DLS1(config)# enable secret cisco
DLS1(config)# line vty 0 15
DLS1(config-line)# password cisco
DLS1(config-line)# login
DLS1(config-line)# exit
DLS1(config)# interface vlan 1
DLS1(config-if)# ip address 172.1.1.# 255.255.255.0
DLS1(config-if)# no sh!tdown
Switch(config)# hostname "LS2
DLS2(config)# enable secret cisco
DLS2(config)# line vty 0 15
DLS2(config-line)# password cisco
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page ) of 11
CCNPv6 SWITCH
DLS2(config-line)# login
DLS2(config-line)# exit
DLS2(config)# interface vlan 1
DLS2(config-if)# ip address 172.1.1.$ 255.255.255.0
DLS2(config-if)# no sh!tdown
b# Configure default gateay& on the acce&& layer &itche& ALS1 and ALS)# ,he di&tribution layer &itche&
ill not u&e a default gateay becau&e they act a& Layer - de!ice&# ,he acce&& layer &itche& act a&
Layer ) de!ice& and need a default gateay to &end +anage+ent VLAN traffic off of the local &ubnet for
the +anage+ent VLAN#
ALS1(config)# ip defa!lt%gateway 172.1.1.1
ALS2(config)# ip defa!lt%gateway 172.1.1.1
Step +: Con&igure trunk" and ,t$erC$annel" bet%een "%itc$e"'
6therChannel i& u&ed for the trun"& becau&e it allo& you to utili5e both (a&t 6thernet interface& that are
a!ailable beteen each de!ice, thereby doubling the bandidth#
NoteA 't i& good practice to &hut don the interface& on both &ide& of the lin" before a port channel i& created
and then reenable the+ after the port channel i& configured#
a# Configure trun"& and 6therChannel& fro+ 8LS1 and 8LS) to the other three &itche& according to the
diagra+# ,he "%itc$port trunk encap"ulation Bi"l C dot#!D co++and i& u&ed becau&e the&e &itche&
al&o &upport 'SL encap&ulation#
DLS1(config)# interface range fast&thernet 0'7 % (
DLS1(config-if-range)# switchport tr!n) encaps!lation dot1*
DLS1(config-if-range)# switchport mode tr!n)
DLS1(config-if-range)# channel%gro!p 1 mode desirable
Creating a port-channel interface Port-channel 1
DLS1(config-if-range)# interface range fast&thernet 0'+ % 10
DLS1(config-if-range)# switchport tr!n) encaps!lation dot1*
DLS1(config-if-range)# switchport mode tr!n)
DLS1(config-if-range)# channel%gro!p 2 mode desirable
Creating a port-channel interface Port-channel 2
DLS1(config-if-range)# interface range fast&thernet 0'11 % 12
DLS1(config-if-range)# switchport tr!n) encaps!lation dot1*
DLS1(config-if-range)# switchport mode tr!n)
DLS1(config-if-range)# channel%gro!p # mode desirable
Creating a port-channel interface Port-channel 3
DLS2(config)# interface range fast&thernet 0'7 % (
DLS2(config-if-range)# switchport tr!n) encaps!lation dot1*
DLS2(config-if-range)# switchport mode tr!n)
DLS2(config-if-range)# channel%gro!p 1 mode desirable
Creating a port-channel interface Port-channel 1
DLS2(config-if-range)# interface range fast&thernet 0'+ % 10
DLS2(config-if-range)# switchport tr!n) encaps!lation dot1*
DLS2(config-if-range)# switchport mode tr!n)
DLS2(config-if-range)# channel%gro!p 2 mode desirable
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page - of 11
CCNPv6 SWITCH
Creating a port-channel interface Port-channel 2
DLS2(config-if-range)# interface range fast&thernet 0'11 % 12
DLS2(config-if-range)# switchport tr!n) encaps!lation dot1*
DLS2(config-if-range)# switchport mode tr!n)
DLS2(config-if-range)# channel%gro!p # mode desirable
Creating a port-channel interface Port-channel 3
b# Configure the trun"& and 6therChannel fro+ ALS1 and ALS) to the other &itche&# Notice that no
encap&ulation type i& needed becau&e the )1/2 &upport& only *2)#1@ trun"&#
ALS1(config)# interface range fast&thernet 0'7 % (
ALS1(config-if-range)# switchport mode tr!n)
ALS1(config-if-range)# channel%gro!p 1 mode desirable
Creating a port-channel interface Port-channel 1
ALS1(config-if-range)# interface range fast&thernet 0'+ % 10
ALS1(config-if-range)# switchport mode tr!n)
ALS1(config-if-range)# channel%gro!p 2 mode desirable
Creating a port-channel interface Port-channel 2
ALS1(config-if-range)# interface range fast&thernet 0'11 % 12
ALS1(config-if-range)# switchport mode tr!n)
ALS1(config-if-range)# channel%gro!p # mode desirable
Creating a port-channel interface Port-channel 3
ALS2(config)# interface range fast&thernet 0'7 % (
ALS2(config-if-range)# switchport mode tr!n)
ALS2(config-if-range)# channel%gro!p 1 mode desirable
Creating a port-channel interface Port-channel 1
ALS2(config-if-range)# interface range fast&thernet 0'+ % 10
ALS2(config-if-range)# switchport mode tr!n)
ALS2(config-if-range)# channel%gro!p 2 mode desirable
Creating a port-channel interface Port-channel 2
ALS2(config-if-range)# interface range fast&thernet 0'11 % 12
ALS2(config-if-range)# switchport mode tr!n)
ALS2(config-if-range)# channel%gro!p # mode desirable
Creating a port-channel interface Port-channel 3
c# Verify trun"ing beteen 8LS1, ALS1, and ALS) u&ing the "$o% inter&ace trunk co++and on all
&itche&#
DLS1# show interface tr!n)
Port Mode Encap!lation Stat! "ati#e #lan
Po1 on $%2&1' tr!n(ing 1
Po2 on $%2&1' tr!n(ing 1
Po3 on $%2&1' tr!n(ing 1
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 3 of 11
CCNPv6 SWITCH
Port )lan allowed on tr!n(
Po1 1-*%+*
Po2 1-*%+*
Po3 1-*%+*
Port )lan allowed and acti#e in ,anage,ent do,ain
Po1 1
Po2 1
Po3 1
Port )lan in panning tree forwarding tate and not pr!ned
Po1 1
Po2 1
Po3 1
d# '&&ue the "$o% et$erc$annel "u**ary co++and on each &itch to !erify the 6therChannel&# 'n the
folloing &a+ple output fro+ ALS1, notice the three 6therChannel& on the acce&& and di&tribution layer
&itche&#
ALS1# show etherchannel s!mmary
-lag. D - down P - in port-channel
/ - tand-alone - !pended
0 - 0ot-tand12 (LACP onl2)
3 - La2er3 S - La2er2
4 - in !e f - failed to allocate aggregator
! - !n!ita1le for 1!ndling
w - waiting to 1e aggregated
d - defa!lt port
"!,1er of channel-gro!p in !e. 3
"!,1er of aggregator. 3
5ro!p Port-channel Protocol Port
------6-------------6-----------6--------------------------------------------
1 Po1(S4) PAgP -a%78(P) -a%7$(P)
2 Po2(S4) PAgP -a%7+(P) -a%71%(P)
3 Po3(S4) PAgP -a%711(P) -a%712(P)
0hich 6therChannel negotiation protocol i& in u&e hereE
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
,he 6therChannel negotiation protocol in u&e i& PAgP#
Step -: Con&igure .TP on /0S# and /0S('
a# Change the V,P +ode of ALS1 and ALS) to client#
ALS1(config)# vtp mode client
Setting de#ice to )9P CL/E"9 ,ode&
ALS2(config)# vtp mode client
Setting de#ice to )9P CL/E"9 ,ode&
b# Verify the V,P change& ith the "$o% vtp "tatu" co++and#
ALS1# show vtp stat!s
)9P )erion . r!nning )9P1 ()9P2 capa1le)
Config!ration 3e#iion . %
Ma:i,!, )LA" !pported locall2 . 2;;
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 5 of 11
CCNPv6 SWITCH
"!,1er of e:iting )LA" . ;
)9P <perating Mode . Client
)9P Do,ain "a,e .
)9P Pr!ning Mode . Dia1led
)9P )2 Mode . Dia1led
)9P 9rap 5eneration . Dia1led
MD; diget . %:C$ %:A= %:3C %:3= %:A= %:DD %:3* %:C-
Config!ration lat ,odified 12 %&%&%&% at 3-1-+3 1;.*8.3*
Ho +any VLAN& can be &upported locally on the )1/2 &itchE
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
,hi& &itch and Ci&co '4S Softare !er&ion can &upport )55 VLAN&#
Step 6: Con&igure .TP on 10S#'
a# Create the V,P do+ain on V,P &er!er 8LS1 and create VLAN& 12, )2, -2, and 32 for the do+ain#
DLS1(config)# vtp domain S,-."
DLS1(config)# vtp version 2
DLS1(config)# vlan 10
DLS1(config-#lan)# name /inance
DLS1(config-#lan)# vlan 20
DLS1(config-#lan)# name &ngineering
DLS1(config-#lan)# vlan #0
DLS1(config-#lan)# name Server%/arm1
DLS1(config-#lan)# vlan $0
DLS1(config-#lan)# name Server%/arm2
b# Verify V,P infor+ation throughout the do+ain u&ing the "$o% vlan and "$o% vtp "tatu" co++and&#
Ho +any eGi&ting VLAN& are in the V,P do+ainE
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
,here &hould be nine VLAN&A the fi!e built-in one&, plu& the four ne VLAN& that you Hu&t created#
Step 2: Con&igure acce"" port"'
a# Configure the ho&t port& of all four &itche&# ,he folloing co++and& configure the &itch port +ode a&
acce&&, place the port in the proper VLAN&, and turn on &panning-tree Port(a&t for the port&#
DLS1(config)# interface fast&thernet 0'
DLS1(config-if)# switchport mode access
DLS1(config-if)# switchport access vlan #0
DLS1(config-if)# spanning%tree portfast
DLS2(config)# interface fast&thernet 0'
DLS2(config-if)# switchport mode access
DLS2(config-if)# switchport access vlan $0
DLS2(config-if)# spanning%tree portfast
ALS1(config)# interface fast&thernet 0'
ALS1(config-if)# switchport mode access
ALS1(config-if)# switchport access vlan 10
ALS1(config-if)# spanning%tree portfast
ALS2(config)# interface fast&thernet 0'
ALS2(config-if)# switchport mode access
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page / of 11
CCNPv6 SWITCH
ALS2(config-if)# switchport access vlan 20
ALS2(config-if)# spanning%tree portfast
b# Ping fro+ the ho&t on VLAN 12 to the ho&t on VLAN 32# ,he ping &hould fail#
Are the&e re&ult& eGpected at thi& pointE 0hyE
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
7e&, it i& eGpected that the ping& ill fail becau&e no SV'& ha!e been created on 8LS1 and 8LS), eGcept
for VLAN 1# ,herefore, there i& no default gateay for the ho&t&#
NoteA ,he "%itc$port $o"t co++and can be u&ed to configure indi!idual acce&& port&# ,hi& co++and
auto+atically acti!ate& acce&& +ode, Port(a&t, and re+o!e& all a&&ociation& of the phy&ical &itch port
ith the port-channel interface& $if there are any%#
Step 3: Con&igure HSP inter&ace" and enable routing'
HSRP pro!ide& redundancy in the netor"# ,he VLAN& can be load-balanced by u&ing the "tandby group
priority priority co++and# ,he ip routing co++and i& u&ed on 8LS1 and 8LS) to acti!ate routing
capabilitie& on the&e Layer - &itche&#
6ach route proce&&or can route beteen the !ariou& SV'& configured on it& &itch# 'n addition to the real 'P
addre&& a&&igned to each di&tribution &itch SV', a&&ign a third 'P addre&& in each &ubnet to be u&ed a& a
!irtual gateay addre&&# HSRP negotiate& and deter+ine& hich &itch accept& infor+ation forarded to the
!irtual gateay 'P addre&&#
,he "tandby co++and configure& the 'P addre&& of the !irtual gateay, &et& the priority for each VLAN, and
configure& the router for pree+pt# Pree+ption allo& the router ith the higher priority to beco+e the acti!e
router after a netor" failure ha& been re&ol!ed#
'n the folloing configuration&, the priority for VLAN& 1, 12, and )2 i& 152 on 8LS1, +a"ing it the acti!e router
for tho&e VLAN&# VLAN& -2 and 32 ha!e a priority of 122 on 8LS1, +a"ing 8LS1 the &tandby router for the&e
VLAN&# 8LS) i& configured to be the acti!e router for VLAN& -2 and 32 ith a priority of 152, and the &tandby
router for VLAN& 1, 12, and )2 ith a priority of 122#
DLS1(config)# ip ro!ting
DLS1(config)# interface vlan 1
DLS1(config-if)# standby 1 ip 172.1.1.1
DLS1(config-if)# standby 1 preempt
DLS1(config-if)# standby 1 priority 150
DLS1(config-if)# exit
DLS1(config)# interface vlan 10
DLS1(config-if)# ip address 172.1.10.# 255.255.255.0
DLS1(config-if)# standby 1 ip 172.1.10.1
DLS1(config-if)# standby 1 preempt
DLS1(config-if)# standby 1 priority 150
DLS1(config-if)# exit
DLS1(config)# interface vlan 20
DLS1(config-if)# ip address 172.1.20.# 255.255.255.0
DLS1(config-if)# standby 1 ip 172.1.20.1
DLS1(config-if)# standby 1 preempt
DLS1(config-if)# standby 1 priority 150
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page . of 11
CCNPv6 SWITCH
DLS1(config-if)# exit
DLS1(config)# interface vlan #0
DLS1(config-if)# ip address 172.1.#0.# 255.255.255.0
DLS1(config-if)# standby 1 ip 172.1.#0.1
DLS1(config-if)# standby 1 preempt
DLS1(config-if)# standby 1 priority 100
DLS1(config-if)# exit
DLS1(config)# interface vlan $0
DLS1(config-if)# ip address 172.1.$0.# 255.255.255.0
DLS1(config-if)# standby 1 ip 172.1.$0.1
DLS1(config-if)# standby 1 preempt
DLS1(config-if)# standby 1 priority 100
DLS2(config)# ip ro!ting
DLS2(config)# interface vlan 1
DLS2(config-if)# standby 1 ip 172.1.1.1
DLS2(config-if)# standby 1 preempt
DLS2(config-if)# standby 1 priority 100
DLS2(config-if)# exit
DLS2(config)# interface vlan 10
DLS2(config-if)# ip address 172.1.10.$ 255.255.255.0
DLS2(config-if)# standby 1 ip 172.1.10.1
DLS2(config-if)# standby 1 preempt
DLS2(config-if)# standby 1 priority 100
DLS2(config-if)# exit
DLS2(config)# interface vlan 20
DLS2(config-if)# ip address 172.1.20.$ 255.255.255.0
DLS2(config-if)# standby 1 ip 172.1.20.1
DLS2(config-if)# standby 1 preempt
DLS2(config-if)# standby 1 priority 100
DLS2(config-if)# exit
DLS2(config)# interface vlan #0
DLS2(config-if)# ip address 172.1.#0.$ 255.255.255.0
DLS2(config-if)# standby 1 ip 172.1.#0.1
DLS2(config-if)# standby 1 preempt
DLS2(config-if)# standby 1 priority 150
DLS2(config-if)# exit
DLS2(config)# interface vlan $0
DLS2(config-if)# ip address 172.1.$0.$ 255.255.255.0
DLS2(config-if)# standby 1 ip 172.1.$0.1
DLS2(config-if)# standby 1 preempt
DLS2(config-if)# standby 1 priority 150
Step 4: .eri&y t$e HSP con&iguration'
a# '&&ue the "$o% "tandby co++and on both 8LS1 and 8LS)#
DLS1# show standby
)lan1 - 5ro!p 1
State i Acti#e
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page * of 11
CCNPv6 SWITCH
; tate change> lat tate change %%.%2.*$
)irt!al /P addre i 182&1?&1&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 2&22$ ec
Pree,ption ena1led
Acti#e ro!ter i local
Stand12 ro!ter i 182&1?&1&*> priorit2 1%% (e:pire in 8&2%8 ec)
Priorit2 1;% (config!red 1;%)
/P red!ndanc2 na,e i @hrp-)l1-1@ (defa!lt)
)lan1% - 5ro!p 1
State i Acti#e
; tate change> lat tate change %%.%2.;%
)irt!al /P addre i 182&1?&1%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 1&113 ec
Pree,ption ena1led
Acti#e ro!ter i local
Stand12 ro!ter i 182&1?&1%&*> priorit2 1%% (e:pire in +&$%8 ec)
Priorit2 1;% (config!red 1;%)
/P red!ndanc2 na,e i @hrp-)l1%-1@ (defa!lt)
)lan2% - 5ro!p 1
State i Acti#e
; tate change> lat tate change %%.%2.;;
)irt!al /P addre i 182&1?&2%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 1&$$* ec
Pree,ption ena1led
Acti#e ro!ter i local
Stand12 ro!ter i 182&1?&2%&*> priorit2 1%% (e:pire in +&22% ec)
Priorit2 1;% (config!red 1;%)
/P red!ndanc2 na,e i @hrp-)l2%-1@ (defa!lt)
)lan3% - 5ro!p 1
State i Stand12
* tate change> lat tate change %%.%2.*;
)irt!al /P addre i 182&1?&3%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 2&*13 ec
Pree,ption ena1led
Acti#e ro!ter i 182&1?&3%&*> priorit2 1;% (e:pire in $&*1; ec)
Stand12 ro!ter i local
Priorit2 1%% (defa!lt 1%%)
/P red!ndanc2 na,e i @hrp-)l3%-1@ (defa!lt)
)lan*% - 5ro!p 1
State i Stand12
* tate change> lat tate change %%.%2.;1
)irt!al /P addre i 182&1?&*%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 1&$2? ec
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1 of 11
CCNPv6 SWITCH
Pree,ption ena1led
Acti#e ro!ter i 182&1?&*%&*> priorit2 1;% (e:pire in 8&$2$ ec)
Stand12 ro!ter i local
Priorit2 1%% (defa!lt 1%%)
/P red!ndanc2 na,e i @hrp-)l*%-1@ (defa!lt)
DLS2# show standby
)lan1 - 5ro!p 1
State i Stand12
3 tate change> lat tate change %%.%2.33
)irt!al /P addre i 182&1?&1&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 2&+;% ec
Pree,ption ena1led
Acti#e ro!ter i 182&1?&1&3> priorit2 1;% (e:pire in $&+?% ec)
Stand12 ro!ter i local
Priorit2 1%% (defa!lt 1%%)
/P red!ndanc2 na,e i @hrp-)l1-1@ (defa!lt)
)lan1% - 5ro!p 1
State i Stand12
3 tate change> lat tate change %%.%2.3*
)irt!al /P addre i 182&1?&1%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 1&8;+ ec
Pree,ption ena1led
Acti#e ro!ter i 182&1?&1%&3> priorit2 1;% (e:pire in 8&$** ec)
Stand12 ro!ter i local
Priorit2 1%% (defa!lt 1%%)
/P red!ndanc2 na,e i @hrp-)l1%-1@ (defa!lt)
)lan2% - 5ro!p 1
State i Stand12
3 tate change> lat tate change %%.%2.*2
)irt!al /P addre i 182&1?&2%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 2&8+% ec
Pree,ption ena1led
Acti#e ro!ter i 182&1?&2%&3> priorit2 1;% (e:pire in $&2$+ ec)
Stand12 ro!ter i local
Priorit2 1%% (defa!lt 1%%)
/P red!ndanc2 na,e i @hrp-)l2%-1@ (defa!lt)
)lan3% - 5ro!p 1
State i Acti#e
2 tate change> lat tate change %%.%2.;2
)irt!al /P addre i 182&1?&3%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in 1&;*+ ec
Pree,ption ena1led
Acti#e ro!ter i local
Stand12 ro!ter i 182&1?&3%&3> priorit2 1%% (e:pire in +&;3$ ec)
Priorit2 1;% (config!red 1;%)
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 12 of 11
CCNPv6 SWITCH
/P red!ndanc2 na,e i @hrp-)l3%-1@ (defa!lt)
)lan*% - 5ro!p 1
State i Acti#e
2 tate change> lat tate change %%.%2.;$
)irt!al /P addre i 182&1?&*%&1
Acti#e #irt!al MAC addre i %%%%&%c%8&ac%1
Local #irt!al MAC addre i %%%%&%c%8&ac%1 (#1 defa!lt)
0ello ti,e 3 ec> hold ti,e 1% ec
"e:t hello ent in %&+?2 ec
Pree,ption ena1led
Acti#e ro!ter i local
Stand12 ro!ter i 182&1?&*%&3> priorit2 1%% (e:pire in $&+?% ec)
Priorit2 1;% (config!red 1;%)
/P red!ndanc2 na,e i @hrp-)l*%-1@ (defa!lt)
b# '&&ue the "$o% "tandby brie& co++and on both 8LS1 and 8LS)#
DLS1# show standby brief
P indicate config!red to pree,pt&
A
/nterface 5rp Pri P State Acti#e Stand12 )irt!al /P
)l1 1 1;% P Acti#e local 182&1?&1&* 182&1?&1&1
)l1% 1 1;% P Acti#e local 182&1?&1%&* 182&1?&1%&1
)l2% 1 1;% P Acti#e local 182&1?&2%&* 182&1?&2%&1
)l3% 1 1%% P Stand12 182&1?&3%&* local 182&1?&3%&1
)l*% 1 1%% P Stand12 182&1?&*%&* local 182&1?&*%&1
DLS2# show standby brief
P indicate config!red to pree,pt&
A
/nterface 5rp Pri P State Acti#e Stand12 )irt!al /P
)l1 1 1%% P Stand12 182&1?&1&3 local 182&1?&1&1
)l1% 1 1%% P Stand12 182&1?&1%&3 local 182&1?&1%&1
)l2% 1 1%% P Stand12 182&1?&2%&3 local 182&1?&2%&1
)l3% 1 1;% P Acti#e local 182&1?&3%&3 182&1?&3%&1
)l*% 1 1;% P Acti#e local 182&1?&*%&3 182&1?&*%&1
0hich router i& the acti!e router for VLAN& 1, 12, and )2E 0hich i& the acti!e router for -2 and 32E
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(or VLAN& 1, 12, and )2, the acti!e router i& 8LS1# (or VLAN& -2 and 32, the acti!e router i& 8LS)#
0hat i& the default hello ti+e for each VLANE 0hat i& the default hold ti+eE
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
,he default hello ti+e i& - &econd&# ,he default hold ti+e i& 12 &econd&#
Ho i& the acti!e HSRP router &electedE
FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
,he router ith the highe&t priority i& &elected a& the acti!e HSRP router# 'f +ore router& &hare the
highe&t priority, the HSRP router ith the highe&t 'P addre&& on the &eg+ent beco+e& the acti!e router#
c# I&e the "$o% ip route co++and to !erify routing on both 8LS1 and 8LS)#
DLS1# show ip ro!te
Code. C - connected> S - tatic> 3 - 3/P> M - ,o1ile> = - =5P
D - E/53P> EB - E/53P e:ternal> < - <SP-> /A - <SP- inter area
"1 - <SP- "SSA e:ternal t2pe 1> "2 - <SP- "SSA e:ternal t2pe 2
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 11 of 11
CCNPv6 SWITCH
E1 - <SP- e:ternal t2pe 1> E2 - <SP- e:ternal t2pe 2> E - E5P
i - /S-/S> ! - /S-/S !,,ar2> L1 - /S-/S le#el-1> L2 - /S-/S le#el-2
ia - /S-/S inter area> C - candidate defa!lt> 4 - per-!er tatic ro!te
o - <D3> P - periodic downloaded tatic ro!te
5atewa2 of lat reort i not et
182&1?&%&%72* i !1netted> ; !1net
C 182&1?&*%&% i directl2 connected> )lan*%
C 182&1?&3%&% i directl2 connected> )lan3%
C 182&1?&2%&% i directl2 connected> )lan2%
C 182&1?&1%&% i directl2 connected> )lan1%
C 182&1?&1&% i directl2 connected> )lan1
Step #5: .eri&y connectivity bet%een .0/N"'
Verify connecti!ity beteen VLAN& u&ing the ping co++and fro+ the SJL Ser!er $VLAN 32% to the other
ho&t& and &er!er& on the netor"#
,he folloing i& fro+ the SJL Ser!er $VLAN 32% to the 6ngineering ho&t $VLAN )2%A
C.DE ping 172.1.20.100
Pinging 182&1?&2%&1%% with 32 12te of data.
3epl2 fro, 182&1?&2%&1%%. 12teF32 ti,eF2, 99LF2;;
3epl2 fro, 182&1?&2%&1%%. 12teF32 ti,eF2, 99LF2;;
3epl2 fro, 182&1?&2%&1%%. 12teF32 ti,eF2, 99LF2;;
3epl2 fro, 182&1?&2%&1%%. 12teF32 ti,eF2, 99LF2;;
Ping tatitic for 182&1?&2%&1%%.
Pac(et. Sent F *> 3ecei#ed F *> Lot F % (%G lo)>
Appro:i,ate ro!nd trip ti,e in ,illi-econd.
Mini,!, F 2,> Ma:i,!, F 2,> A#erage F 2,
Step ##: .eri&y HSP &unctionally'
a# Verify HSRP by di&connecting the trun"& to 8LS)# 7ou can &i+ulate thi& u&ing the "$utdo%n co++and
on tho&e interface&#
DLS2(config)# interface range fast&thernet 0'7 % 12
DLS2(config-if-range)# sh!tdown
4utput to the con&ole &hould reflect 8LS1 beco+ing the acti!e router for VLAN& -2 and 32#
1w3d. G0S3P-?-S9A9EC0A"5E. )lan3% 5rp 1 tate Stand12 -E Acti#e
1w3d. G0S3P-?-S9A9EC0A"5E. )lan*% 5rp 1 tate Stand12 -E Acti#e
b# Verify that 8LS1 i& acting a& the bac"up default gateay for VLAN& -2 and 32 u&ing the "$o% "tandby
brie& co++and# 8LS1 i& no the acti!e HSRP router for all VLAN& and the &tandby router i& un"non#
DLS1# show standby brief
P indicate config!red to pree,pt&
A
/nterface 5rp Pri P State Acti#e Stand12 )irt!al /P
)l1 1 1;% P Acti#e local !n(nown 182&1?&1&1
)l1% 1 1;% P Acti#e local !n(nown 182&1?&1%&1
)l2% 1 1;% P Acti#e local !n(nown 182&1?&2%&1
)l3% 1 1%% P Acti#e local !n(nown 182&1?&3%&1
)l*% 1 1%% P Acti#e local !n(nown 182&1?&*%&1
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1) of 11
CCNPv6 SWITCH
c# Repeat thi& proce&& by bringing up the 8LS) trun"& and &hutting don the 8LS1 interface&# I&e the
"$o% "tandby brie& co++and to &ee the re&ult&#
NoteA 'f both 8LS1 and 8LS) ha!e lin"& to the 'nternet, failure of either &itch ill cau&e HSRP to
redirect pac"et& to the other &itch# ,he functioning &itch ill ta"e o!er a& the default gateay to
pro!ide !irtually uninterrupted connecti!ity for ho&t& at the acce&& layer#
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1- of 11
CCNPv6 SWITCH
1evice Con&iguration"
NoteA V,P and VLAN co++and& do not di&play in the running configuration, unle&& the &itch i& in
tran&parent +ode# 8LS1 and 8LS) are V,P &er!er&, and ALS1 and ALS) are V,P client&# Refer to the
appropriate &tep& in the lab for the nece&&ary V,P and VLAN configuration co++and&#
S%itc$ 10S#
hotna,e DLS1
H
ena1le ecret cico
H
ip ro!ting
H
interface Port-channel1
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
H
interface Port-channel2
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
H
interface Port-channel3
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
H
interface -atEthernet%7?
witchport acce #lan 3%
witchport ,ode acce
panning-tree portfat
H
interface -atEthernet%78
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7$
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7+
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%71%
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%711
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface -atEthernet%712
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 13 of 11
CCNPv6 SWITCH
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface )lan1
ip addre 182&1?&1&3 2;;&2;;&2;;&%
tand12 1 ip 182&1?&1&1
tand12 1 priorit2 1;%
tand12 1 pree,pt
no h!tdown
H
interface )lan1%
ip addre 182&1?&1%&3 2;;&2;;&2;;&%
tand12 1 ip 182&1?&1%&1
tand12 1 priorit2 1;%
tand12 1 pree,pt
H
interface )lan2%
ip addre 182&1?&2%&3 2;;&2;;&2;;&%
tand12 1 ip 182&1?&2%&1
tand12 1 priorit2 1;%
tand12 1 pree,pt
H
interface )lan3%
ip addre 182&1?&3%&3 2;;&2;;&2;;&%
tand12 1 ip 182&1?&3%&1
tand12 1 pree,pt
H
interface )lan*%
ip addre 182&1?&*%&3 2;;&2;;&2;;&%
tand12 1 ip 182&1?&*%&1
tand12 1 pree,pt
H
line #t2 % *
paword cico
login
line #t2 ; 1;
paword cico
login
H
end
S%itc$ 10S(
hotna,e DLS2
H
ena1le ecret cico
H
ip ro!ting
H
interface Port-channel1
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
H
interface Port-channel2
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 15 of 11
CCNPv6 SWITCH
H
interface Port-channel3
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
H
interface -atEthernet%7?
witchport acce #lan *%
witchport ,ode acce
panning-tree portfat
H
interface -atEthernet%78
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7$
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7+
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%71%
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%711
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface -atEthernet%712
witchport tr!n( encap!lation dot1'
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface )lan1
ip addre 182&1?&1&* 2;;&2;;&2;;&%
tand12 1 ip 182&1?&1&1
tand12 1 pree,pt
no h!tdown
H
interface )lan1%
ip addre 182&1?&1%&* 2;;&2;;&2;;&%
tand12 1 ip 182&1?&1%&1
tand12 1 pree,pt
H
interface )lan2%
ip addre 182&1?&2%&* 2;;&2;;&2;;&%
tand12 1 ip 182&1?&2%&1
tand12 1 pree,pt
H
interface )lan3%
ip addre 182&1?&3%&* 2;;&2;;&2;;&%
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1/ of 11
CCNPv6 SWITCH
tand12 1 ip 182&1?&3%&1
tand12 1 priorit2 1;%
tand12 1 pree,pt
H
interface )lan*%
ip addre 182&1?&*%&* 2;;&2;;&2;;&%
tand12 1 ip 182&1?&*%&1
tand12 1 priorit2 1;%
tand12 1 pree,pt
H
line #t2 % *
paword cico
login
line #t2 ; 1;
paword cico
login
H
end
S%itc$ /0S#
hotna,e ALS1
H
ena1le ecret cico
H
interface Port-channel1
witchport ,ode tr!n(
H
interface Port-channel2
witchport ,ode tr!n(
H
interface Port-channel3
witchport ,ode tr!n(
H
interface -atEthernet%7?
witchport acce #lan 1%
witchport ,ode acce
panning-tree portfat
H
interface -atEthernet%78
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7$
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7+
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%71%
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%711
witchport ,ode tr!n(
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1. of 11
CCNPv6 SWITCH
channel-gro!p 3 ,ode deira1le
H
interface -atEthernet%712
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface )lan1
ip addre 182&1?&1&1%1 2;;&2;;&2;;&%
no h!tdown
H
ip defa!lt-gatewa2 182&1?&1&1
H
line #t2 % *
paword cico
login
line #t2 ; 1;
paword cico
login
H
end
S%itc$ /0S(
hotna,e ALS2
H
ena1le ecret cico
H
interface Port-channel1
witchport ,ode tr!n(
H
interface Port-channel2
witchport ,ode tr!n(
H
interface Port-channel3
witchport ,ode tr!n(
H
interface -atEthernet%7?
witchport acce #lan 2%
witchport ,ode acce
panning-tree portfat
H
interface -atEthernet%78
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7$
witchport ,ode tr!n(
channel-gro!p 1 ,ode deira1le
H
interface -atEthernet%7+
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
interface -atEthernet%71%
witchport ,ode tr!n(
channel-gro!p 2 ,ode deira1le
H
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 1* of 11
CCNPv6 SWITCH
interface -atEthernet%711
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface -atEthernet%712
witchport ,ode tr!n(
channel-gro!p 3 ,ode deira1le
H
interface )lan1
ip addre 182&1?&1&1%2 2;;&2;;&2;;&%
no h!tdown
H
ip defa!lt-gatewa2 182&1?&1&1
H
line #t2 % *
paword cico
login
line #t2 ; 1;
paword cico
login
end
All content& are Copyright 9 111):)212 Ci&co Sy&te+&, 'nc# All right& re&er!ed# ,hi& docu+ent i& Ci&co Public 'nfor+ation# Page 11 of 11