Вы находитесь на странице: 1из 7

La funcin SI en Excel

La funcin SI en Excel es parte del grupo de funciones Lgicas y nos permite evaluar una condicin para
determinar si es falsa o verdadera. La funcin SI es de gran ayuda para tomar decisiones en base al resultado
obtenido en la prueba lgica.
Sintaxis de la funcin SI
Adems de especificar la prueba lgica para la funcin SI tambin podemos especificar valores a devolver de
acuerdo al resultado de la funcin.
Prueba_lgica (obligatorio): Expresin lgica que ser evaluada para conocer si el resultado es
E!"#"E!$ o %#LS$&
alor_si_verdadero (opcional): El valor que se devolver en caso de que el resultado de
la Prueba_lgica sea E!"#"E!$&
alor_si_falso (opcional): El valor que se devolver si el resultado de la evaluacin es %#LS$&
La Prueba_lgica puede ser una expresin que utilice cualquier operador lgico o tambin puede ser una funcin de
Excel que regrese como resultado E!"A"E!# o $ALS#.
Los argumentos Valor_si_verdadero y Valor_si_falso pueden ser cadenas de texto% n&meros% referencias a otra
celda o inclusive otra funcin de Excel que se e'ecutar de acuerdo al resultado de la Prueba_lgica.
E'e(plos de la funcin SI
(robaremos la funcin SI con el siguiente e'emplo. )engo una lista de alumnos con sus calificaciones
correspondientes en la columna *. +tili,ando la funcin SI desplegar un mensa'e de A(!#*A"# si la calificacin
del alumno es superior o igual a -. y un mensa'e de !E(!#*A"# si la calificacin es menor a -.. La funcin que
utili,ar ser la siguiente/
=SI(B2>=60,"APROBADO","REPROBADO")
#bserva el resultado al aplicar esta frmula en todas las celdas de la columna 0.
)tili*ar una funcin co(o prueba lgica
Es posible utili,ar el resultado de otra funcin como la prueba lgica que necesita la funcin SI siempre y cuando
esa otra funcin regrese como resultado E!"A"E!# o $ALS#. +n e'emplo de este tipo de funcin es la funcin
ES1+2E!# la cual eval&a el contenido de una celda y devuelve el valor E!"A"E!# en caso de que sea un
valor numrico. En este e'emplo quiero desplegar la leyenda 3SI4 en caso de que la celda de la columna A
efectivamente tenga un n&mero% de lo contrario se mostrar la leyenda 31#4.
=SI(ESNUMERO(A2), "SI", "NO")
Este es el resultado de aplicar la frmula sobre los datos de la 5o'a/
)tili*ar una funcin co(o valor de regreso
0omo &ltimo e'emplo mostrar que es posible utili,ar una funcin para especificar el valor de regreso. +tili,ando
como base el e'emplo anterior% necesito que en caso de que la celda de la columna A contenga un valor numrico se
le sume el valor que colocar en la celda "6. La funcin que me ayudar a reali,ar esta operacin es la siguiente/
=SI(ESNUMERO(A2), SUMA(A2, $D$1), "NO")
0omo puedes observar% el segundo argumento es una funcin la cual se e'ecutar en caso de que la prueba lgica
sea verdadera. #bserva el resultado de esta frmula/
Slo en los casos donde la funcin SI era verdadera se reali, la suma. "e la misma manera podr7amos colocar una
funcin para el tercer argumento en caso de que el resultado de la prueba lgica fuera falso.
La funcin +$,-#!&SI en Excel nos da la oportunidad de contar el n&mero de celdas de un rango que cumplan
con un criterio establecido. Solamente cuando el valor de dic5as celdas cumple la condicin es considerada dentro
de la cuenta.
Sintaxis de la funcin +$,-#!&SI
Solamente existen dos argumentos para la funcin +$,-#!&SI que son lo siguientes/
!ango 8obligatorio9/ El rango que contiene los valores que se desean contar.
+riterio 8obligatorio9/ La condicin que determinar las celdas que sern contadas.
El criterio puede ser un n&mero o una expresin que indicar la condicin a cumplir% por e'emplo/ ::% 3;<-4%
3E!"E4. El criterio no 5ar diferencia entre may&sculas y min&sculas. La funcin +$,-#!&SI solamente permite
especificar una sola condicin% en caso de necesitar aplicar varias condiciones se puede utili,ar la funcin
0#1)A!.SI.0#1=+1)#.
E'e(plo de la funcin +$,-#!&SI)engo una lista de art7culos y cada uno tiene
asociado su color. A5ora necesito contar el total de art7culos que son de color a,ul y para ello utili,ar la siguiente
frmula/
=CONTAR.SI(B2:B11, "azu")
Al aplicar esta frmula a los datos de la columna * obtengo la cuenta correcta/
(uedes observar que el segundo argumento de la funcin +$,-#!&SI est todo en min&sculas mientras que las
celdas de la columna * tienen la primera letra en may&sculas% sin embargo el valor 3A,ul4 es considerado dentro de
la cuenta por lo que comprobamos que la condicin no es sensible a may&sculas y min&sculas.
!ecuerda que la funcin +$,-#!&SI nos permitir contar el n&mero de celdas dentro de un rango que cumplan
con el criterio que se 5aya especificado en el segundo argumento de la funcin.
>acer referencia a celdas de otras
5o'as en Excel
0uando la informacin est organi,ada en diferentes 5o'as de Excel es indispensable saber c(o crear
referencias a celdas que se encuentran en otras .o'as. La nomenclatura es muy sencilla% solamente usamos el
nombre de la 5o'a seguido del signo de exclamacin y la direccin de la celda.
!eferencia a una celda en otra .o'a de Excel
>agamos un e'emplo muy sencillo. En una de las 5o'as de mi libro de Excel tengo el presupuesto para los gastos de
los meses de enero y febrero.
En la 5o'a !esumen deseo mostrar el gasto de telfono del mes de febrero por lo que utili,o la siguiente frmula/
=P!"#u$u"#%&'C(
#bserva que esta referencia sigue las reglas mencionadas anteriormente. En primer lugar coloco el nombre de la
5o'a que tiene la informacin% seguida del s7mbolo de exclamacin y finalmente la direccin de la celda que deseo
obtener de dic5a 5o'a. #bserva que Excel obtiene el valor adecuado en mi 5o'a !esumen/
0omo puedes observar% es muy sencillo 5acer referencia a celdas de otras 5o'as en Excel.
!eferencia a un rango en otra .o'a de Excel
"e la misma manera que 5emos creado una referencia a una sola celda en otra 5o'a% podemos crear una referencia
a un rango. +tili,ando el mismo e'emplo anterior% a5ora deseo mostrar en mi 5o'a !esumen la suma total del
presupuesto del mes de $ebrero. (ara ello utili,ar la funcin S+2A especificando como argumento un rango en
otra 5o'a/
=SUMA(P!"#u$u"#%&'C2:C))
La funcin S+2A se encargar de acceder los valores en las celdas de la otra 5o'a. #bserva que Excel devuelve el
resultado correcto/
Espero que con estos dos e'emplos tengas ya claro cmo .acer una referencia a una celda o rango en otra .o'a
de Excel.
,o(bres de .o'as con espacios en blanco
Existe un caso especial al momento de crear una referencia 5acia otras 5o'as de nuestro libro y es cuando la 5o'a
que contiene los datos tiene un nombre con espacios en blanco. En mi libro de Excel de e'emplo tengo una 5o'a
llamada 3?asto !eal4 con la informacin del gasto efectuado en cada mes/
Si deseo colocar en mi 5o'a !esumen la suma de los gastos de febrero de esta 5o'a debo utili,ar la siguiente
frmula/
=SUMA(*+a#%& R"a*'C2:C))
Lo que debes notar de manera especial en esta frmula es que el nombre de la 5o'a est rodeado por comillas
sencillas que es algo que debemos 5acer cuando el nombre de la 5o'a contenga espacios en blanco. #bserva el
resultado de utili,ar esta referencia/
)tili*ar el ratn para crear una referencia a otra .o'a
@a conoces las reglas para crear referencias a celdas en otras .o'as de Excel pero tambin puedes utili,ar el
ratn para crear dic5as referencias. Solo ser suficiente con colocar el s7mbolo A y 5acer clic en la 5o'a y celda que
contiene el dato que deseamos incluir para que Excel pueda crear la referencia correcta.
Lo mismo sucede al especificar el argumento de una funcin. 0on solo 5acer clic en la 5o'a y celda que deseamos
incluir% Excel crear la referencia adecuada. En la siguiente animacin podrs observar cmo creo las referencias de
los e'emplos anteriores utili,ando solamente el ratn/