Вы находитесь на странице: 1из 758
Catalyst 2960 Switch Command Reference Cisco IOS Release 12.2(25)SEE February 2006 Corporate Headquarters Cisco
Catalyst 2960 Switch Command Reference Cisco IOS Release 12.2(25)SEE February 2006 Corporate Headquarters Cisco

Catalyst 2960 Switch Command Reference

Cisco IOS Release 12.2(25)SEE February 2006

Corporate Headquarters Cisco Systems, Inc. 170 West Tasman Drive San Jose, CA 95134-1706 USA http://www.cisco.com

Tel:

408 526-4000

Fax:

800 553-NETS (6387) 408 526-4100

Text Part Number: OL-8604-01

USA http://www.cisco.com Tel: 408 526-4000 Fax: 800 553-NETS (6387) 408 526-4100 Text Part Number: OL-8604-01

THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS” WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IIN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

CCSP, CCVP, the Cisco Square Bridge logo, Follow Me Browsing, and StackWise are trademarks of Cisco Systems, Inc.; Changing the Way We Work, Live, Play, and Learn, and iQuick Study are service marks of Cisco Systems, Inc.; and Access Registrar, Aironet, ASIST, BPX, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Empowering the Internet Generation, Enterprise/Solver, EtherChannel, EtherFast, EtherSwitch, Fast Step, FormShare, GigaDrive, GigaStack, HomeLink, Internet Quotient, IOS, IP/TV, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, LightStream, Linksys, MeetingPlace, MGX, the Networkers logo, Networking Academy, Network Registrar, Packet, PIX, Post-Routing, Pre-Routing, ProConnect, RateMUX, ScriptShare, SlideCast, SMARTnet, StrataView Plus, TeleRouter, The Fastest Way to Increase Your Internet Quotient, and TransPath are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.

All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (0502R)

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental.

Catalyst 2960 Switch Command Reference Copyright © 2006 Cisco Systems, Inc. All rights reserved.

CONTENTS
CONTENTS

Preface

xv

Audience xv

Purpose xv

Conventions xv

Related Publications

Obtaining Documentation

xvi

xvii

Cisco.com xvii Product Documentation DVD Ordering Documentation

xviii

xvii

Documentation Feedback

Cisco Product Security Overview

xviii

xviii

Reporting Security Problems in Cisco Products

xix

Obtaining Technical Assistance

xix

Cisco Technical Support & Documentation Website Submitting a Service Request Definitions of Service Request Severity

xx

xx

Obtaining Additional Publications and Information

xxi

xix

CHAPTER

1

Using the Command-Line Interface

1-1

 
 

CLI Command Modes User EXEC Mode

1-1

1-2

Privileged EXEC Mode

1-3

 

Global Configuration Mode

1-3

Interface Configuration Mode

1-4

 

config-vlan Mode

1-4

VLAN Configuration Mode Line Configuration Mode

1-4

1-5

CHAPTER

2

Catalyst 2960 Switch Cisco IOS Commands

2-1

aaa accounting dot1x

aaa authentication dot1x

aaa authorization network

archive download-sw

2-1

2-6

2-3

2-5

Catalyst 2960 Switch Command Reference

dot1x aaa authorization network archive download-sw 2-1 2-6 2-3 2-5 Catalyst 2960 Switch Command Reference OL-8604-01

OL-8604-01

iii

Contents

archive tar

archive upload-sw

2-9

2-12

auto qos voip boot boothlpr boot config-file

auto qos voip boot boothlpr boot config-file
auto qos voip boot boothlpr boot config-file

2-14

2-18

2-19

boot enable-break

boot helper

boot helper-config-file

boot manual

boot private-config-file

boot system

channel-group 2-26

channel-protocol 2-29 class 2-30 class-map 2-32

2-20

2-21

2-23

2-25

2-22

2-24

clear dot1x

2-34

clear eap

2-35

clear ip dhcp snooping database

2-36

clear lacp

clear mac address-table

clear mac address-table move update

clear pagp

clear port-security

clear spanning-tree counters

clear spanning-tree detected-protocols

clear vmps statistics clear vtp counters

2-37

2-38

2-40

2-41

2-43

2-45

2-46

2-39

2-44

cluster commander-address

2-47

cluster discovery hop-count

2-49

cluster enable

2-50

cluster holdtime

2-52

cluster member

2-53

cluster outside-interface

cluster run

cluster standby-group

2-56

2-55

2-57

outside-interface cluster run cluster standby-group 2-56 2-55 2-57 Catalyst 2960 Switch Command Reference iv OL-8604-01

Catalyst 2960 Switch Command Reference

iv

OL-8604-01

Contents

cluster timer

define interface-range delete 2-62

deny (MAC access-list configuration) dot1x 2-66

dot1x auth-fail max-attempts

dot1x auth-fail vlan dot1x control-direction

dot1x critical (global configuration)

dot1x critical (interface configuration)

dot1x default

2-59

2-60

2-68

2-70

2-72

2-78

dot1x guest-vlan

2-79

dot1x host-mode

2-81

dot1x initialize

2-82

2-63

2-74

2-76

dot1x mac-auth-bypass dot1x max-reauth-req

dot1x mac-auth-bypass dot1x max-reauth-req

2-83

2-85

dot1x max-req

dot1x pae

2-87

2-86

dot1x port-control dot1x re-authenticate

2-88

2-90

dot1x reauthentication

2-91

dot1x timeout

2-92

duplex 2-95

errdisable detect cause errdisable recovery

2-99

2-97

exception crashinfo

2-101

2-104

flowcontrol 2-102 interface port-channel

interface range

2-106

interface vlan

2-108

ip access-group

2-109

ip address

ip dhcp snooping

ip dhcp snooping binding ip dhcp snooping database

2-111

2-113

2-114

2-116

Catalyst 2960 Switch Command Reference

snooping binding ip dhcp snooping database 2-111 2-113 2-114 2-116 Catalyst 2960 Switch Command Reference OL-8604-01

OL-8604-01

v

Contents

ip dhcp snooping information option

ip dhcp snooping information option allow-untrusted

ip dhcp snooping limit rate

ip dhcp snooping trust ip dhcp snooping verify

ip dhcp snooping vlan

ip igmp filter

ip igmp max-groups

ip igmp profile ip igmp snooping

ip igmp snooping last-member-query-interval

2-131

2-118

2-122

2-123

2-124

2-125

2-127

2-126

2-129

2-133

ip igmp snooping querier

ip igmp snooping report-suppression

ip igmp snooping tcn

ip igmp snooping tcn flood

ip igmp snooping vlan immediate-leave

ip igmp snooping vlan mrouter

ip igmp snooping vlan static

ip ssh

lacp port-priority

lacp system-priority

2-135

2-139

2-141

2-143

2-145

2-147

2-149

2-151

2-137

2-142

link state group

2-153

link state track

2-155

logging file

mac access-group

mac access-list extended

2-156

2-158

2-160

2-120

mac address-table aging-time

2-162

mac address-table move update

2-163

mac address-table notification

2-165

mac address-table static

2-167

mac address-table static drop

2-168

macro apply

macro description

macro global

macro global description

2-170

2-174

2-173

2-177

macro global macro global description 2-170 2-174 2-173 2-177 Catalyst 2960 Switch Command Reference vi OL-8604-01

Catalyst 2960 Switch Command Reference

vi

OL-8604-01

Contents

macro name

match (class-map configuration)

mdix auto

media-type 2-184

mls qos

mls qos aggregate-policer

mls qos cos

mls qos dscp-mutation

mls qos map

mls qos queue-set output buffers mls qos queue-set output threshold

mls qos rewrite ip dscp

mls qos srr-queue input bandwidth

mls qos srr-queue input buffers mls qos srr-queue input cos-map mls qos srr-queue input dscp-map

mls qos srr-queue input priority-queue

2-178

2-182

2-186

2-190

2-194

2-180

2-188

2-192

2-198

2-200

2-204

2-206

2-208

2-210

2-202

2-212

mls qos srr-queue input threshold mls qos srr-queue output cos-map mls qos srr-queue output dscp-map

mls qos srr-queue input threshold mls qos srr-queue output cos-map mls qos srr-queue output dscp-map
mls qos srr-queue input threshold mls qos srr-queue output cos-map mls qos srr-queue output dscp-map

2-214

2-216

2-218

mls qos trust monitor session

mvr (global configuration)

mvr (interface configuration)

2-220

2-222

2-227

2-230

pagp

learn-method

2-233

pagp

port-priority 2-235

permit (MAC access-list configuration) police 2-240

police aggregate

2-242

2-237

policy-map 2-244 port-channel load-balance priority-queue 2-248

2-246

queue-set 2-250

radius-server dead-criteria

2-251

radius-server host

2-253

Catalyst 2960 Switch Command Reference

radius-server dead-criteria 2-251 radius-server host 2-253 Catalyst 2960 Switch Command Reference OL-8604-01 vii

OL-8604-01

vii

Contents

rcommand 2-255 remote-span 2-257

renew ip dhcp snooping database

rmon collection stats

2-261

2-259

sdm prefer

2-262

 

service password-recovery service-policy 2-266

2-264

set

2-268

setup 2-270

 

setup express

2-273

 

show access-lists

2-275

show archive status

2-278

2-279

 

show auto qos show boot

2-283

 

show cable-diagnostics tdr

2-285

show class-map

2-287

show cluster

2-288

 

show cluster candidates show cluster members

show controllers cpu-interface

show controllers ethernet-controller

show controllers tcam show controllers utilization

2-290

2-292

2-294

2-303

2-305

show dot1x

2-307

show dtp

2-311

show eap

2-313

show env

2-316

show errdisable detect

2-317

2-296

show errdisable flap-values

2-319

show errdisable recovery

2-321

show etherchannel

2-323

show flowcontrol

2-326

show interfaces

2-328

show interfaces counters

2-335

show inventory

2-337

show interfaces counters 2-335 show inventory 2-337 Catalyst 2960 Switch Command Reference viii OL-8604-01

Catalyst 2960 Switch Command Reference

viii

OL-8604-01

Contents

show ip dhcp snooping

2-338

show ip dhcp snooping binding

2-339

show ip dhcp snooping database

2-341

show ip igmp profile show ip igmp snooping

show ip igmp snooping groups

show ip igmp snooping mrouter show ip igmp snooping querier

2-343

2-344

show lacp

2-353

2-347

2-349

2-351

show link state group

2-357

show mac access-group

2-359

show mac address-table

2-361

show mac address-table address

show mac address-table aging-time

2-363

2-365

show mac address-table count

2-367

show mac address-table dynamic

2-369

show mac address-table interface

2-371

show mac address-table move update

show mac address-table notification

show mac address-table static show mac address-table vlan

show mls qos

2-381

show mls qos aggregate-policer

show mls qos input-queue show mls qos interface

show mls qos maps

show mls qos queue-set

show mls qos vlan

show monitor

show mvr

show mvr interface show mvr members

show pagp

show parser macro show policy-map

2-373

2-375

2-377

2-379

2-382

2-383

2-385

2-392

2-389

2-394

2-395

2-397

2-399

2-401

2-405

2-408

2-403

Catalyst 2960 Switch Command Reference

2-385 2-392 2-389 2-394 2-395 2-397 2-399 2-401 2-405 2-408 2-403 Catalyst 2960 Switch Command Reference

OL-8604-01

ix

Contents

show port-security show sdm prefer show setup express

show port-security show sdm prefer show setup express
show port-security show sdm prefer show setup express

show spanning-tree show storm-control show system mtu

show spanning-tree show storm-control show system mtu
show spanning-tree show storm-control show system mtu

2-410

2-413

2-415

2-416

2-427

2-429

show udld

2-430

show version

2-433

show vlan

2-435

show vmps

2-439

show vtp

2-442

shutdown 2-447

shutdown vlan

snmp-server enable traps

2-448

2-449

snmp-server host

2-452

snmp trap mac-notification

2-456

2-458

spanning-tree backbonefast

2-459

spanning-tree bpdufilter spanning-tree bpduguard

2-461

spanning-tree cost

2-463

spanning-tree etherchannel guard misconfig

2-465

spanning-tree extend system-id

2-467

spanning-tree guard

2-468

spanning-tree link-type

2-470

spanning-tree loopguard default

2-472

spanning-tree mode

2-474

spanning-tree mst configuration

2-476

spanning-tree mst cost

2-478

 

2-480

spanning-tree mst forward-time spanning-tree mst hello-time

2-481

spanning-tree mst max-age spanning-tree mst max-hops

2-482

2-483

spanning-tree mst port-priority spanning-tree mst pre-standard

spanning-tree mst port-priority spanning-tree mst pre-standard

2-485

2-487

spanning-tree mst priority

2-488

mst pre-standard 2-485 2-487 spanning-tree mst priority 2-488 Catalyst 2960 Switch Command Reference x OL-8604-01

Catalyst 2960 Switch Command Reference

x

OL-8604-01

Contents

spanning-tree mst root spanning-tree port-priority

spanning-tree portfast (global configuration)

spanning-tree portfast (interface configuration)

spanning-tree transmit hold-count

spanning-tree uplinkfast

spanning-tree vlan

speed 2-503 srr-queue bandwidth limit srr-queue bandwidth shape srr-queue bandwidth share

storm-control 2-511 switchport access

2-514

switchport backup interface

switchport block

switchport host

switchport mode

switchport nonegotiate switchport port-security

switchport port-security aging switchport priority extend

switchport protected

switchport trunk

switchport voice vlan

system mtu

2-489

2-491

2-497

2-498

2-500

2-505

2-507

2-509

2-516

2-519

2-520

2-521

2-523

2-525

2-532

2-534

2-530

2-535

2-538

2-540

2-493

2-495

test cable-diagnostics tdr

2-542

traceroute mac

2-543

traceroute mac ip trust 2-548

2-546

udld

2-550

udld port

2-552

udld reset

2-554

vlan (global configuration)

2-555

vlan (VLAN configuration)

2-561

vlan database

2-567

Catalyst 2960 Switch Command Reference

2-555 vlan (VLAN configuration) 2-561 vlan database 2-567 Catalyst 2960 Switch Command Reference OL-8604-01 xi

OL-8604-01

xi

Contents

vmps reconfirm (privileged EXEC)

vmps reconfirm (global configuration)

2-570

2-571

vmps retry

2-572

vmps server

2-573

vtp (global configuration) vtp (VLAN configuration)

vtp (global configuration) vtp (VLAN configuration)

2-575

2-579

APPENDIX

A

Catalyst 2960 Switch Boot Loader Commands

A-1

 

boot

A-2

cat

A-4

copy

A-5

delete

A-6

dir

A-7

flash_init

A-9

 

format

A-10

fsck

A-11

help A-12

 

load_helper

A-13

memory

A-14

mkdir

A-15

more A-16

 

rename

A-17

reset

A-18

rmdir

A-19

set

A-20

type A-23

 

unset

A-24

version

A-26

 

APPENDIX

B

Catalyst 2960 Switch Debug Commands

B-1

 

debug auto qos debug backup debug cluster debug dot1x

debug auto qos debug backup debug cluster debug dot1x
debug auto qos debug backup debug cluster debug dot1x
debug auto qos debug backup debug cluster debug dot1x

B-2

B-4

B-5

B-7

debug dtp

B-8

debug eap

B-9

B-2 B-4 B-5 B-7 debug dtp B-8 debug eap B-9 Catalyst 2960 Switch Command Reference xii

Catalyst 2960 Switch Command Reference

xii

OL-8604-01

Contents

debug etherchannel

debug ip dhcp snooping

debug interface debug ip igmp filter

debug ip igmp max-groups debug ip igmp snooping

debug lacp

debug mac-notification

debug matm

debug matm move update

B-10

B-11

B-12

B-13

B-14

B-15

B-17

B-19

B-16

B-18

debug monitor

B-20

debug mvrdbg

B-21

debug nvram

B-22

debug pagp

B-23

debug platform acl

debug platform backup interface

debug platform cpu-queues

debug platform dot1x

debug platform etherchannel debug platform forw-tcam

debug platform ip dhcp

debug platform ip igmp snooping

debug platform led debug platform matm

debug platform messaging application

B-24

B-25

B-26

B-29

B-30

B-28

B-31

B-32

B-34

B-35

B-36

debug platform phy

B-37

debug platform pm

B-39

debug platform port-asic

B-41

debug platform port-security

B-42

debug platform qos-acl-tcam

B-43

debug platform resource-manager

B-44

debug platform snmp debug platform span

debug platform snmp debug platform span

B-45

B-46

debug platform supervisor-asic

debug platform sw-bridge

B-48

B-47

Catalyst 2960 Switch Command Reference

debug platform supervisor-asic debug platform sw-bridge B-48 B-47 Catalyst 2960 Switch Command Reference OL-8604-01 xiii

OL-8604-01

xiii

Contents

debug platform tcam

B-49

debug platform udld

B-51

debug platform vlan

B-52

debug pm

B-53

debug port-security

B-55

debug qos-manager

B-56

debug spanning-tree

B-57

debug spanning-tree backbonefast

debug spanning-tree bpdu debug spanning-tree bpdu-opt debug spanning-tree mstp

debug spanning-tree switch

debug spanning-tree uplinkfast

debug sw-vlan debug sw-vlan ifs

debug sw-vlan notification

B-59

B-60

B-61

B-62

B-64

B-66

B-67

B-69

B-70

debug sw-vlan vtp

B-72

debug udld

B-74

debug vqpc

B-76

APPENDIX

C

Catalyst 2960 Switch Show Platform Commands

show platform acl

show platform backup interface show platform etherchannel

show platform forward

show platform ip igmp snooping

show platform layer4op

C-2

C-4

C-5

C-9

C-3

C-7

show platform mac-address-table

C-10

show platform messaging

C-11

show platform monitor

C-12

show platform mvr table

C-13

show platform pm

C-14

show platform port-asic

C-15

show platform port-security

C-20

 

show platform qos

C-21

show platform resource-manager

C-22

C-1

platform qos C-21 show platform resource-manager C-22 C-1 Catalyst 2960 Switch Command Reference xiv OL-8604-01

Catalyst 2960 Switch Command Reference

xiv

OL-8604-01

Contents

show platform snmp counters show platform spanning-tree show platform stp-instance

show platform snmp counters show platform spanning-tree show platform stp-instance
show platform snmp counters show platform spanning-tree show platform stp-instance

C-24

C-25

C-26

I NDEX

show platform tcam show platform vlan

show platform tcam show platform vlan

C-27

C-30

Catalyst 2960 Switch Command Reference

C-26 I NDEX show platform tcam show platform vlan C-27 C-30 Catalyst 2960 Switch Command Reference

OL-8604-01

xv

Contents

Contents Catalyst 2960 Switch Command Reference xvi OL-8604-01

Catalyst 2960 Switch Command Reference

xvi

OL-8604-01

Preface Audience This guide is for the networking professional using the Cisco IOS command-l ine

Preface

Preface Audience This guide is for the networking professional using the Cisco IOS command-l ine interface

Audience

This guide is for the networking professional using the Cisco IOS command-line interface (CLI) to manage the Catalyst 2960 switch, hereafter referred to as the switch. Before using this guide, you should have experience working with the Cisco IOS commands and the switch software features. Before using this guide, you should have experience working with the concepts and terminology of Ethernet and local area networking.

Purpose

The Catalyst 2960 switch is supported by a software image that provides enterprise-class intelligent services such as access control lists (ACLs) and quality of service (QoS) features.This guide provides the information that you need about the Layer 2 commands that have been created or changed for use with the Catalyst 2960 switches. For information about the standard Cisco IOS Release 12.2 commands, see the Cisco IOS documentation set available from the Cisco.com home page by selecting Technical Support & Documentation > Cisco IOS Software.

This guide does not provide procedures for configuring your switch. For detailed configuration procedures, see the software configuration guide for this release.

This guide does not describe system messages you might encounter. For more information, see the system message guide for this release.

For documentation updates, see the release notes for this release.

Conventions

This publication uses these conventions to convey instructions and information:

Command descriptions use these conventions:

Commands and keywords are in boldface text.

Arguments for which you supply values are in italic.

Square brackets ([ ]) means optional elements.

Braces ({}) group required choices, and vertical bars ( | ) separate the alternative elements.

Braces and vertical bars within square brackets ([{ | }]) mean a required choice within an optional element.

Catalyst 2960 Command Reference

brackets ([ { | }]) mean a required choice within an optional element. Catalyst 2960 Command

OL-8604-01

xv

Related Publications

Preface

Interactive examples use these conventions:

Terminal sessions and system displays are in screen font.

Information you enter is in boldface screen font.

Nonprinting characters, such as passwords or tabs, are in angle brackets (< >).

Notes, cautions, and warnings use these conventions and symbols:

cautions, and warnings us e these conventions and symbols: Note Means reader take note . Notes

Note

Means reader take note. Notes contain helpful suggestions or references to materials not contained in this manual.

or references to materials not contained in this manual. Caution Means reader be careful . In

Caution

Means reader be careful. In this situation, you might do something that could result in equipment

damage or loss of data.

that could result in equipment damage or loss of data. Related Publications These documents provide complete

Related Publications

These documents provide complete information about the switch and are available from this Cisco.com site:

Note Before installing, configuring, or upgrading the

Note

Before installing, configuring, or upgrading the switch, see these documents:

For initial configuration information, see the “Using Express Setup” chapter in the getting started guide or the “Configuring the Switch with the CLI-Based Setup Program” appendix in the hardware installation guide.

For device manager requirements, see the “System Requirements” section in the release notes (not orderable but available on Cisco.com).

For Network Assistant requirements, see the Getting Started with Cisco Network Assistant (not orderable but available on Cisco.com).

For cluster requirements, see the Release Notes for Cisco Network Assistant (not orderable but available on Cisco.com).

For upgrade information, see the “Downloading Software” section in the release notes.

“Downloadi ng Software” section in the release notes. You can order printed copies of documents with

You can order printed copies of documents with a DOC-xxxxxx= number from the Cisco.com sites and from the telephone numbers listed in the “Obtaining Documentation” section on page xvii.

Release Notes for the Catalyst 3750, 3560, 2970, and 2960 Switches (not orderable but available on Cisco.com)

Catalyst 2960 Switch Software Configuration Guide(not orderable but available on Cisco.com)

Catalyst 2960 Switch Command Reference (not orderable but available on Cisco.com)

Device manager online help (available on the switch)

Catalyst 2960 Switch Hardware Installation Guide (not orderable but available on Cisco.com)

Catalyst 2960 Switch Getting Started Guide (order number DOC-7816879=)

Catalyst 2960 Switch Getting Started Guide (order number DOC-7816879=) Catalyst 2960 Command Reference xvi OL-8604-01

Catalyst 2960 Command Reference

xvi

OL-8604-01

Preface

Obtaining Documentation

Regulatory Compliance and Safety Information for the Catalyst 2960 Switch (order number

DOC-7816880=)

Catalyst 3750, 3560, 3550, 2970, and 2960 Switch System Message Guide (not orderable but available on Cisco.com)

Getting Started with Cisco Network Assistant (not orderable but available on Cisco.com)

Release Notes for Cisco Network Assistant (not orderable but available on Cisco.com)

Cisco Small Form-Factor Pluggable Modules Installation Notes (order number DOC-7815160=)

Cisco CWDM GBIC and CWDM SFP Modules Installation Note (not orderable but available on Cisco.com)

Cisco RPS 300 Redundant Power System Hardware Installation Guide (order number

DOC-7810372=)

Cisco RPS 675 Redundant Power System Hardware Installation Guide (order number

DOC-7815201=)

For information about the Network Admission Control (NAC) features, see the Network Admission Control Software Configuration Guide (not orderable but available on Cisco.com)

Obtaining Documentation

Cisco documentation and additional literature are available on Cisco.com. Cisco also provides several ways to obtain technical assistance and other technical resources. These sections explain how to obtain technical information from Cisco Systems.

Cisco.com

You can access the most current Cisco documentation at this URL:

You can access the Cisco website at this URL:

You can access international Cisco websites at this URL:

Product Documentation DVD

The Product Documentation DVD is a comprehensive library of technical product documentation on a portable medium. The DVD enables you to access multiple versions of installation, configuration, and command guides for Cisco hardware and software products. With the DVD, you have access to the same HTML documentation that is found on the Cisco website without being connected to the Internet. Certain products also have .PDF versions of the documentation available.

The Product Documentation DVD is available as a single unit or as a subscription. Registered Cisco.com users (Cisco direct customers) can order a Product Documentation DVD (product number DOC-DOCDVD= or DOC-DOCDVD=SUB) from Cisco Marketplace at this URL:

Catalyst 2960 Command Reference

from Cisco Marketplace at this URL: http://www.cisco.com/go/marketplace/ Catalyst 2960 Command Reference OL-8604-01 xvii

OL-8604-01

xvii

Documentation Feedback

Preface

Ordering Documentation

Registered Cisco.com users may order Cisco documentation at the Product Documentation Store in the Cisco Marketplace at this URL:

Nonregistered Cisco.com users can order technical documentation from 8:00 a.m. to 5:00 p.m. (0800 to 1700) PDT by calling 1 866 463-3487 in the United States and Canada, or elsewhere by calling 011 408 519-5055. You can also order documentation by e-mail at

tech-doc-store-mkpl@external.cisco.com or by fax at 1 408 519-5001 in the United States and Canada,

or elsewhere at 011 408 519-5001.

Documentation Feedback

You can rate and provide feedback about Cisco technical documents by completing the online feedback form that appears with the technical documents on Cisco.com.

You can submit comments about Cisco documentation by using the response card (if present) behind the front cover of your document or by writing to the following address:

Cisco Systems Attn: Customer Document Ordering 170 West Tasman Drive San Jose, CA 95134-9883

We appreciate your comments.

Cisco Product Security Overview

Cisco provides a free online Security Vulnerability Policy portal at this URL:

From this site, you will find information about how to:

Report security vulnerabilities in Cisco products.

Obtain assistance with security incidents that involve Cisco products.

Register to receive security information from Cisco.

A current list of security advisories, security notices, and security responses for Cisco products is

available at this URL:

To see security advisories, security notices, and security responses as they are updated in real time, you can subscribe to the Product Security Incident Response Team Really Simple Syndication (PSIRT RSS) feed. Information about how to subscribe to the PSIRT RSS feed is found at this URL:

URL: http://www.cisco.com/en/US/products/products_psirt_rss_feed.html Catalyst 2960 Command Reference xviii OL-8604-01

Catalyst 2960 Command Reference

xviii

OL-8604-01

Preface

Obtaining Technical Assistance

Reporting Security Problems in Cisco Products

Cisco is committed to delivering secure products. We test our products internally before we release them, and we strive to correct all vulnerabilities quickly. If you think that you have identified a vulnerability in a Cisco product, contact PSIRT:

For Emergencies only— security-alert@cisco.com

An emergency is either a condition in which a system is under active attack or a condition for which a severe and urgent security vulnerability should be reported. All other conditions are considered nonemergencies.

All other conditions are considered nonemergencies. • For Nonemergencies— psirt@cisco.com In an emergency,

For Nonemergencies— psirt@cisco.com

In an emergency, you can also reach PSIRT by telephone:

1 877 228-7302

1 408 525-6532

PSIRT by telephone: • 1 877 228-7302 • 1 408 525-6532 Tip We encourage you to

Tip We encourage you to use Pretty Good Privacy (PGP) or a compatible product (for example, GnuPG) to encrypt any sensitive information that you send to Cisco. PSIRT can work with information that has been encrypted with PGP versions 2.x through 9.x.

Never use a revoked or an expired encryption key. The correct public key to use in your correspondence with PSIRT is the one linked in the Contact Summary section of the Security Vulnerability Policy page at this URL:

The link on this page has the current PGP key ID in use.

If you do not have or use PGP, contact PSIRT at the aforementioned e-mail addresses or phone numbers

before sending any sensitive material to find other means of encrypting the data.

material to find other means of encrypting the data. Obtaining Technical Assistance Cisco Technical Support

Obtaining Technical Assistance

Cisco Technical Support provides 24-hour-a-day award-winning technical assistance. The Cisco Technical Support & Documentation website on Cisco.com features extensive online support resources. In addition, if you have a valid Cisco service contract, Cisco Technical Assistance Center (TAC) engineers provide telephone support. If you do not have a valid Cisco service contract, contact your reseller.

Cisco Technical Support & Documentation Website

Catalyst 2960 Command Reference

available 24 hours a day, at this URL: http://www.cisco.com/techsupport Catalyst 2960 Command Reference OL-8604-01 xix

OL-8604-01

xix

Obtaining Technical Assistance

Preface

Access to all tools on the Cisco Technical Support & Documentation website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register at this URL:

at this URL: http://tools.cisco.com/RPF/register/register.do Note Use the Cisco Product Identification (CPI) tool to

Note Use the Cisco Product Identification (CPI) tool to locate your product serial number before submitting a web or phone request for service. You can access the CPI tool from the Cisco Technical Support & Documentation website by clicking the Tools & Resources link under Documentation & Tools. Choose Cisco Product Identification Tool from the Alphabetical Index drop-down list, or click the Cisco Product Identification Tool link under Alerts & RMAs. The CPI tool offers three search options: by product ID or model name; by tree view; or for certain products, by copying and pasting show command output. Search results show an illustration of your product with the serial number label location highlighted. Locate the serial number label on your product and record the information before placing a service call.

and record the information before placing a service call. Submitting a Service Request Using the online

Submitting a Service Request

Using the online TAC Service Request Tool is the fastest way to open S3 and S4 service requests. (S3 and S4 service requests are those in which your network is minimally impaired or for which you require product information.) After you describe your situation, the TAC Service Request Tool provides recommended solutions. If your issue is not resolved using the recommended resources, your service request is assigned to a Cisco engineer. The TAC Service Request Tool is located at this URL:

For S1 or S2 service requests, or if you do not have Internet access, contact the Cisco TAC by telephone. (S1 or S2 service requests are those in which your production network is down or severely degraded.) Cisco engineers are assigned immediately to S1 and S2 service requests to help keep your business operations running smoothly.

To open a service request by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227) EMEA: +32 2 704 55 55 USA: 1 800 553-2447

For a complete list of Cisco TAC contacts, go to this URL:

Definitions of Service Request Severity

To ensure that all service requests are reported in a standard format, Cisco has established severity definitions.

Severity 1 (S1)—An existing network is down, or there is a critical impact to your business operations. You and Cisco will commit all necessary resources around the clock to resolve the situation.

Severity 2 (S2)—Operation of an existing network is severely degraded, or significant aspects of your business operations are negatively affected by inadequate performance of Cisco products. You and Cisco will commit full-time resources during normal business hours to resolve the situation.

full-time resources during normal business hours to resolve the situation. Catalyst 2960 Command Reference xx OL-8604-01

Catalyst 2960 Command Reference

xx

OL-8604-01

Preface

Obtaining Additional Publications and Information

Severity 3 (S3)—Operational performance of the network is impaired, while most business operations remain functional. You and Cisco will commit resources during normal business hours to restore service to satisfactory levels.

Severity 4 (S4)—You require information or assistance with Cisco product capabilities, installation, or configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information

Information about Cisco products, technologies, and network solutions is available from various online and printed sources.

The Cisco Product Quick Reference Guide is a handy, compact reference tool that includes brief product overviews, key features, sample part numbers, and abbreviated technical specifications for many Cisco products that are sold through channel partners. It is updated twice a year and includes the latest Cisco offerings. To order and find out more about the Cisco Product Quick Reference Guide, go to this URL:

Cisco Marketplace provides a variety of Cisco books, reference guides, documentation, and logo merchandise. Visit Cisco Marketplace, the company store, at this URL:

Cisco Press publishes a wide range of general networking, training and certification titles. Both new and experienced users will benefit from these publications. For current Cisco Press titles and other information, go to Cisco Press at this URL:

Packet magazine is the Cisco Systems technical user magazine for maximizing Internet and networking investments. Each quarter, Packet delivers coverage of the latest industry trends, technology breakthroughs, and Cisco products and solutions, as well as network deployment and troubleshooting tips, configuration examples, customer case studies, certification and training information, and links to scores of in-depth online resources. You can access Packet magazine at this URL:

iQ Magazine is the quarterly publication from Cisco Systems designed to help growing companies learn how they can use technology to increase revenue, streamline their business, and expand services. The publication identifies the challenges facing these companies and the technologies to help solve them, using real-world case studies and business strategies to help readers make sound technology investment decisions. You can access iQ Magazine at this URL:

or view the digital edition at this URL:

Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering professionals involved in designing, developing, and operating public and private internets and intranets. You can access the Internet Protocol Journal at this URL:

Catalyst 2960 Command Reference

access the Intern et Protocol Journal at this URL: http://www.cisco.com/ipj Catalyst 2960 Command Reference OL-8604-01 xxi

OL-8604-01

xxi

Obtaining Additional Publications and Information

Preface

Networking products offered by Cisco Systems, as well as customer support services, can be obtained at this URL:

Networking Professionals Connection is an interactive website for networking professionals to share questions, suggestions, and information about networking products and technologies with Cisco experts and other networking professionals. Join a discussion at this URL:

World-class networking training is available from Cisco. You can view current offerings at this URL:

offerings at this URL: http://www.cisco.com/en/US/learning/index.html Catalyst 2960 Command Reference xxii OL-8604-01

Catalyst 2960 Command Reference

xxii

OL-8604-01

1 CHAPTER
1
CHAPTER

Using the Command-Line Interface

1 CHAPTER Using the Command-Line Interface The Catalyst 2960 switch is supported by Cisco IOS software.

The Catalyst 2960 switch is supported by Cisco IOS software. This chapter describes how to use the switch command-line interface (CLI) to configure software features.

For a complete description of the commands that support these features, see Chapter 2, “Catalyst 2960 Switch Cisco IOS Commands.” For information on the boot loader commands, see Appendix A, “Catalyst 2960 Switch Boot Loader Commands.” For information on the debug commands, see Appendix B, “Catalyst 2960 Switch Debug Commands.” For information on the show platform commands, see Appendix C, “Catalyst 2960 Switch Show Platform Commands.” For more information on Cisco IOS Release 12.2, see the Cisco IOS Release 12.2 Command Summary.

For task-oriented configuration steps, see the software configuration guide for this release.

In this document, IP refers to IP version 4 (IPv4).

CLI Command Modes

This section describes the CLI command mode structure. Command modes support specific Cisco IOS commands. For example, the interface interface-id command only works when entered in global configuration mode.

These are the main command modes for the switch:

User EXEC

Privileged EXEC

Global configuration

Interface configuration

Config-vlan

VLAN configuration

Line configuration

Catalyst 2960 Command Reference

• Config-vlan • VLAN configuration • Line configuration Catalyst 2960 Command Reference OL-8604-01 1-1

OL-8604-01

1-1

CLI Command Modes

Chapter 1

Using the Command-Line Interface

Table 1-1 lists the main command modes, how to access each mode, the prompt you see in that mode, and how to exit that mode. The prompts listed use the default name Switch.

Table 1-1

Command Modes Summary

Command Mode

Access Method

Prompt

Exit or Access Next Mode

User EXEC

This is the first level of access.

Switch>

Enter the logout command.

(For the switch) Change terminal settings, perform basic tasks, and list system information.

To enter privileged EXEC mode, enter the enable command.

Privileged EXEC

From user EXEC mode, enter the enable command.

Switch#

To exit to user EXEC mode, enter the disable command.

To enter global configuration mode, enter the configure command.

Global

From privileged EXEC mode, enter the configure command.

Switch(config)#

To exit to privileged EXEC mode, enter the exit or end command, or press Ctrl-Z.

To enter interface configuration mode, enter the interface configuration command.

configuration

 

Interface

From global configuration mode, specify an interface by entering the interface command followed by an interface identification.

Switch(config-if)#

To exit to privileged EXEC mode, enter the end command, or press Ctrl-Z.

To exit to global configuration mode, enter the exit command.

configuration

Config-vlan

In global configuration mode, enter the vlan vlan-id command.

Switch(config-vlan)#

To exit to global configuration mode, enter the exit command.

To return to privileged EXEC mode, enter the end command, or press Ctrl-Z.

VLAN

From privileged EXEC mode, enter the vlan database command.

Switch(vlan)#

To exit to privileged EXEC mode, enter the exit command.

configuration

Line configuration

From global configuration mode, specify a line by entering the line command.

Switch(config-line)#

To exit to global configuration mode, enter the exit command.

To return to privileged EXEC mode, enter the end command, or press Ctrl-Z.

User EXEC Mode

After you access the device, you are automatically in user EXEC command mode. The EXEC commands available at the user level are a subset of those available at the privileged level. In general, use the user EXEC commands to temporarily change terminal settings, perform basic tests, and list system information.

change terminal settings, perform basic tests, and list system information. Catalyst 2960 Command Reference 1-2 OL-8604-01

Catalyst 2960 Command Reference

1-2

OL-8604-01

Chapter 1

Using the Command-Line Interface

CLI Command Modes

The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch> ?

Privileged EXEC Mode

Because many of the privileged commands configure operating parameters, privileged access should be password-protected to prevent unauthorized use. The privileged command set includes those commands contained in user EXEC mode, as well as the configure privileged EXEC command through which you access the remaining command modes.

If your system administrator has set a password, you are prompted to enter it before being granted access to privileged EXEC mode. The password does not appear on the screen and is case sensitive.

The privileged EXEC mode prompt is the device name followed by the pound sign (#).

Switch#

Enter the enable command to access privileged EXEC mode:

Switch> enable

Switch#

The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch# ?

To return to user EXEC mode, enter the disable privileged EXEC command.

Global Configuration Mode

Global configuration commands apply to features that affect the device as a whole. Use the configure privileged EXEC command to enter global configuration mode. The default is to enter commands from the management console.

When you enter the configure command, a message prompts you for the source of the configuration commands:

Switch# configure Configuring from terminal, memory, or network [terminal]?

You can specify either the terminal or NVRAM as the source of configuration commands.

This example shows you how to access global configuration mode:

Switch# configure terminal Enter configuration commands, one per line. End with CNTL/Z.

The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch(config)# ?

To exit global configuration command mode and to return to privileged EXEC mode, enter the end or exit command, or press Ctrl-Z.

Catalyst 2960 Command Reference

privileged EXEC mode, enter the end or exit command, or press Ctrl-Z . Catalyst 2960 Command

OL-8604-01

1-3

CLI Command Modes

Chapter 1

Using the Command-Line Interface

Interface Configuration Mode

Interface configuration commands modify the operation of the interface. Interface configuration commands always follow a global configuration command, which defines the interface type.

Use the interface interface-id command to access interface configuration mode. The new prompt means interface configuration mode.

Switch(config-if)#

The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch(config-if)# ?

To exit interface configuration mode and to return to global configuration mode, enter the exit command. To exit interface configuration mode and to return to privileged EXEC mode, enter the end command, or press Ctrl-Z.

config-vlan Mode

Use this mode to configure normal-range VLANs (VLAN IDs 1 to 1005) or, when VTP mode is transparent, to configure extended-range VLANs (VLAN IDs 1006 to 4094). When VTP mode is transparent, the VLAN and VTP configuration is saved in the running configuration file, and you can save it to the switch startup configuration file by using the copy running-config startup-config privileged EXEC command. The configurations of VLAN IDs 1 to 1005 are saved in the VLAN database if VTP is in transparent or server mode. The extended-range VLAN configurations are not saved in the VLAN database.

Enter the vlan vlan-id global configuration command to access config-vlan mode:

Switch(config)# vlan 2000 Switch(config-vlan)#

The supported keywords can vary but are similar to the commands available in VLAN configuration mode. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch(config-vlan)# ?

For extended-range VLANs, all characteristics except the MTU size must remain at the default setting.

To return to global configuration mode, enter exit; to return to privileged EXEC mode, enter end. All the commands except shutdown take effect when you exit config-vlan mode.

VLAN Configuration Mode

You can use the VLAN configuration commands to create or modify VLAN parameters for VLAN IDs 1 to 1005.

Enter the vlan database privileged EXEC command to access VLAN configuration mode:

Switch# vlan database Switch(vlan)#

The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch(vlan)# ?

of commands, enter a question mark ( ? ) at the prompt. Switch(vlan)# ? Catalyst 2960

Catalyst 2960 Command Reference

1-4

OL-8604-01

Chapter 1

Using the Command-Line Interface

CLI Command Modes

To return to privileged EXEC mode, enter the abort VLAN configuration command to abandon the proposed database. Otherwise, enter exit to implement the proposed new VLAN database and to return to privileged EXEC mode. When you enter exit or apply, the configuration is saved in the VLAN database; configuration from VLAN configuration mode cannot be saved in the switch configuration file.

Line Configuration Mode

Line configuration commands modify the operation of a terminal line. Line configuration commands always follow a line command, which defines a line number. Use these commands to change terminal parameter settings line-by-line or for a range of lines.

Use the line vty line_number [ending_line_number] command to enter line configuration mode. The new prompt means line configuration mode. The following example shows how to enter line configuration mode for virtual terminal line 7:

Switch(config)# line vty 0 7

The supported commands can vary depending on the version of software in use. To display a comprehensive list of commands, enter a question mark (?) at the prompt.

Switch(config-line)# ?

To exit line configuration mode and to return to global configuration mode, use the exit command. To exit line configuration mode and to return to privileged EXEC mode, enter the end command, or press Ctrl-Z.

Catalyst 2960 Command Reference

return to privileged EXEC mode, enter the end command, or press Ctrl-Z . Catalyst 2960 Command

OL-8604-01

1-5

CLI Command Modes

Chapter 1

Using the Command-Line Interface

CLI Command Modes Chapter 1 Using the Command-Line Interface Catalyst 2960 Command Reference 1-6 OL-8604-01

Catalyst 2960 Command Reference

1-6

OL-8604-01

2 CHAPTER
2
CHAPTER

Catalyst 2960 Switch Cisco IOS Commands

2 CHAPTER Catalyst 2960 Switch Cisco IOS Commands aaa accounting dot1x Use the aaa accounting dot1x

aaa accounting dot1x

Use the aaa accounting dot1x global configuration command to enable authentication, authorization, and accounting (AAA) accounting and to create method lists defining specific accounting methods on a per-line or per-interface basis for IEEE 802.1x sessions. Use the no form of this command to disable IEEE 802.1x accounting.

aaa accounting dot1x {name | default} start-stop {broadcast group {name | radius | tacacs+}

[group {name | radius | tacacs+}

| tacacs+}

]}

] | group {name | radius | tacacs+} [group {name | radius

no aaa accounting dot1x {name | default}

Syntax Description

name

Name of a server group. This is optional when you enter it after the broadcast group and group keywords.

default

Use the accounting methods that follow as the default list for accounting services.

start-stop

Send a start accounting notice at the beginning of a process and a stop accounting notice at the end of a process. The start accounting record is sent in the background. The requested-user process begins regardless of whether or not the start accounting notice was received by the accounting server.

broadcast

Enable accounting records to be sent to multiple AAA servers and send accounting records to the first server in each group. If the first server is unavailable, the switch uses the list of backup servers to identify the first server.

group

Specify the server group to be used for accounting services. These are valid server group names:

 

name—Name of a server group.

radius—List of all RADIUS hosts.

tacacs+—List of all TACACS+ hosts.

The group keyword is optional when you enter it after the broadcast group and group keywords. You can enter more than optional group keyword.

 

radius

(Optional) Enable RADIUS authorization.

tacacs+

(Optional) Enable TACACS+ accounting.

Catalyst 2960 Command Reference

RADIUS authorization. tacacs+ (Optional) Enable TACACS+ accounting. Catalyst 2960 Command Reference OL-8604-01 2-1

OL-8604-01

2-1

aaa accounting dot1x

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

Defaults

AAA accounting is disabled.

Command Modes

Global configuration

Command History

Release

Modification

12.2(25)FX

This command was introduced.

Usage Guidelines

This command requires access to a RADIUS server.

We recommend that you enter the dot1x reauthentication interface configuration command before configuring IEEE 802.1x RADIUS accounting on an interface.

Examples

This example shows how to configure IEEE 802.1x accounting:

Switch(config)# aaa new-model Switch(config)# aaa accounting dot1x default start-stop group radius

aaa accounting dot1x default start-stop group radius Note The RADIUS authentication server must be properly

Note

The RADIUS authentication server must be properly configured to accept and log update or watchdog

packets from the AAA client.

and log update or watchdog packets from the AAA client. Related Commands Command Description aaa

Related Commands

Command

Description

aaa authentication

Specifies one or more AAA methods for use on interfaces running IEEE 802.1x.

dot1x

aaa new-model

Enables the AAA access control model. For syntax information, see the Cisco IOS Security Command Reference, Release 12.2 > Authentication, Authorization, and Accounting > Authentication Commands.

dot1x reauthentication

Enables or disables periodic reauthentication.

dot1x timeout

Sets the number of seconds between re-authentication attempts.

reauth-period

the number of seconds between re-authentication attempts. reauth-period Catalyst 2960 Command Reference 2-2 OL-8604-01

Catalyst 2960 Command Reference

2-2

OL-8604-01

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

aaa authentication dot1x

aaa authentication dot1x

Use the aaa authentication dot1x global configuration command to specify the authentication, authorization, and accounting (AAA) method to use on ports complying with the IEEE 802.1x authentication. Use the no form of this command to disable authentication.

aaa authentication dot1x {default} method1

no aaa authentication dot1x {default}

Syntax Description

default

Use the listed authentication method that follows this argument as the default method when a user logs in.

method1

Enter the group radius keywords to use the list of all RADIUS servers for authentication.

to use the list of all RADIUS servers for authentication. Note Though other keywords are visible

Note

Though other keywords are visible in the command-line help strings, only the default and group radius

keywords are supported.

only the default and group radius keywords are supported. Defaults No authentication is performed. Command

Defaults

No authentication is performed.

Command Modes

Global configuration

Command History

Release

Modification

12.2(25)FX

This command was introduced.

Usage Guidelines

The method argument identifies the method that the authentication algorithm tries in the given sequence to validate the password provided by the client. The only method that is truly IEEE 802.1x-compliant is the group radius method, in which the client data is validated against a RADIUS authentication server.

If you specify group radius, you must configure the RADIUS server by entering the radius-server host global configuration command.

Use the show running-config privileged EXEC command to display the configured lists of authentication methods.

Examples

This example shows how to enable AAA and how to create an IEEE 802.1x-compliant authentication list. This authentication first tries to contact a RADIUS server. If this action returns an error, the user is not allowed access to the network.

Switch(config)# aaa new-model Switch(config)# aaa authentication dot1x default group radius

You can verify your settings by entering the show running-config privileged EXEC command.

Catalyst 2960 Command Reference

settings by entering the show running-config privileged EXEC command. Catalyst 2960 Command Reference OL-8604-01 2-3

OL-8604-01

2-3

aaa authentication dot1x

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

Related Commands

Command

Description

aaa new-model

Enables the AAA access control model. For syntax information, see the Cisco IOS Security Command Reference, Release 12.2 > Authentication, Authorization, and Accounting > Authentication Commands.

show running-config

Displays the current operating configuration. For syntax information, select Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 > File Management Commands > Configuration File Management Commands.

File Management Commands > Configuration File Management Commands . Catalyst 2960 Command Reference 2-4 OL-8604-01

Catalyst 2960 Command Reference

2-4

OL-8604-01

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

aaa authorization network

aaa authorization network

Use the aaa authorization network global configuration command to the configure the switch to use user-RADIUS authorization for all network-related service requests, such as IEEE 802.1x VLAN assignment. Use the no form of this command to disable the switch for RADIUS user authorization.

aaa authorization network default group radius

no aaa authorization network default

Syntax Description

default group

Use the list of all RADIUS hosts in the server group as the default authorization list.

radius

Defaults

Authorization is disabled.

Command Modes

Global configuration

Command History

Release

Modification

12.2(25)FX

This command was introduced.

Usage Guidelines

Use the aaa authorization network default group radius global configuration command to allow the switch to download IEEE 802.1x authorization parameters from the RADIUS servers in the default authorization list. The authorization parameters are used by features such as VLAN assignment to get parameters from the RADIUS servers.

Use the show running-config privileged EXEC command to display the configured lists of authorization methods.

Examples

This example shows how to configure the switch for user RADIUS authorization for all network-related service requests:

Switch(config)# aaa authorization network default group radius

You can verify your settings by entering the show running-config privileged EXEC command.

Related Commands

Command

Description

show running-config

Displays the current operating configuration. For syntax information, select Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 > File Management Commands > Configuration File Management Commands.

archive download-sw

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

archive download-sw

Use the archive download-sw privileged EXEC command to download a new image from a TFTP server to the switch and to overwrite or keep the existing image.

archive download-sw {/force-reload | /imageonly | /leave-old-sw | /no-set-boot | /overwrite | /reload | /safe} source-url

Syntax Description

/force-reload

Unconditionally force a system reload after successfully downloading the software image.

/imageonly

Download only the software image but not the HTML files associated with the embedded device manager. The HTML files for the existing version are deleted only if the existing version is being overwritten or removed.

/leave-old-sw

Keep the old software version after a successful download.

/no-set-boot

Do not alter the setting of the BOOT environment variable to point to the new software image after it is successfully downloaded.

/overwrite

Overwrite the software image in flash memory with the downloaded one.

/reload

Reload the system after successfully downloading the image unless the configuration has been changed and not been saved.

/safe

Keep the current software image; do not delete it to make room for the new software image before the new image is downloaded. The current image is deleted after the download.

source-url

The source URL alias for a local or network file system. These options are supported:

The syntax for the local flash file system:

flash:

The syntax for the FTP:

ftp:[[//username[:password]@location]/directory]/image-name.tar

The syntax for an HTTP server:

http://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar

The syntax for a secure HTTP server:

https://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar

The syntax for the Remote Copy Protocol (RCP):

rcp:[[//username@location]/directory]/image-name.tar

The syntax for the TFTP:

tftp:[[//location]/directory]/image-name.tar

The image-name.tar is the software image to download and install on the switch.

.tar is the software image to download and install on the switch. Catalyst 2960 Command Reference

Catalyst 2960 Command Reference

2-6

OL-8604-01

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

archive download-sw

Defaults

The current software image is not overwritten with the downloaded image.

Both the software image and HTML files are downloaded.

The new image is downloaded to the flash: file system.

The BOOT environment variable is changed to point to the new software image on the flash: file system.

Image names are case sensitive; the image file is provided in tar format.

Command Modes

Privileged EXEC

Command History

Release

Modification

12.2(25)FX

This command was introduced.

Usage Guidelines

The /imageonly option removes the HTML files for the existing image if the existing image is being removed or replaced. Only the Cisco IOS image (without the HTML files) is downloaded.

Using the /safe or /leave-old-sw option can cause the new image download to fail if there is insufficient flash memory. If leaving the software in place prevents the new image from fitting in flash memory due to space constraints, an error results.

If you used the /leave-old-sw option and did not overwrite the old image when you downloaded the new one, you can remove the old image by using the delete privileged EXEC command. For more information, see the “delete” section on page 2-62.

Use the /overwrite option to overwrite the image on the flash device with the downloaded one.

If you specify the command without the /overwrite option, the download algorithm verifies that the new image is not the same as the one on the switch flash device. If the images are the same, the download does not occur. If the images are different, the old image is deleted, and the new one is downloaded.

After downloading a new image, enter the reload privileged EXEC command to begin using the new image, or specify the /reload or /force-reload option in the archive download-sw command.

Examples

This example shows how to download a new image from a TFTP server at 172.20.129.10 and overwrite the image on the switch:

Switch# archive download-sw /overwrite tftp://172.20.129.10/test-image.tar

This example shows how to download only the software image from a TFTP server at 172.20.129.10 to the switch:

Switch# archive download-sw /imageonly tftp://172.20.129.10/test-image.tar

This example shows how to keep the old software version after a successful download:

Switch# archive download-sw /leave-old-sw tftp://172.20.129.10/test-image.tar

Catalyst 2960 Command Reference

archive download-sw /leave-old-sw tftp://172.20.129.10/test-image.tar Catalyst 2960 Command Reference OL-8604-01 2-7

OL-8604-01

2-7

archive download-sw

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

Related Commands

Command

Description

archive tar

Creates a tar file, lists the files in a tar file, or extracts the files from a tar file.

archive upload-sw

Uploads an existing image on the switch to a server.

delete

Deletes a file or directory on the flash memory device.

to a server. delete Deletes a file or directory on the flash memory device. Catalyst 2960

Catalyst 2960 Command Reference

2-8

OL-8604-01

Chapter 2

Catalyst 2960 Switch Cisco IOS Commands

archive tar

archive tar

Use the archive tar privileged EXEC command to create a tar file, list files in a tar file, or extract the files from a tar file.

archive tar {/create destination-url flash:/file-url} | {/table source-url} | {/xtract source-url

flash:/file-url [dir/file

]}

Syntax Description

/create destination-url flash:/file-url

Create a new tar file on the local or network file system.

For destination-url, specify the destination URL alias for the local or network file system and the name of the tar file to create. These options are supported:

The syntax for the local flash filesystem:

flash:

The syntax for the FTP:

ftp:[[//username[:password]@location]/directory]/tar-filename.tar

The syntax for an HTTP server:

http://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar

The syntax for a secure HTTP server:

https://[[username:password]@]{hostname | host-ip}[/directory]/image-name.tar

The syntax for the Remote Copy Protocol (RCP) is:

rcp:[[//username@location]/directory]/tar-filename.tar

The syntax for the TFTP:

tftp:[[//location]/directory]/tar-filename.tar

The tar-filename.tar is the tar file to be created.

For flash:/file-url, specify the location on the local flash file system from which the new tar file is created.

An optional list of files or directories within the source directory can be specified to write to the new tar file. If none are specified, all files and directories at this level are written to the newly created tar file.

Catalyst 2960 Command Reference