Вы находитесь на странице: 1из 11

Enrutamiento Dinmico con RIP en Routers Cisco

Ejercicio #1:
En esta entrada trataremos sobre la configuracin del enrutamiento dinmico de
routers Cisco mediante el protocolo RIP.

Como podemos ver en el diagrama, tenemos dos routers R1 y R2 que se comunican


mediante la red 1.1.1.0/30 a travs de sus interfaces seriales 1.1.1.1/30 y 1.1.1.2/30
respectivamente. Adicionalmente, tenemos dos computadoras PC1 y PC2 que se
comunican con los routers R1 y R2 mediante las redes 192.168.10.0/24 y
192.168.20.0/24 respectivamente.
En este ejemplo, vamos a configurar los equipos R1 y R2 para lograr conectividad
entre los equipos PC1 y PC2 usando enrutamiento dinmico con el protocolo RIP. El
protocolo RIP (Routing Information Protocol) es un protocolo de enrutamiento por
vector-distancia y utiliza el nmero de saltos como mtrica para la seleccin de rutas.

Contenido
1.
2.
3.

Configuracin
Probar
la
Configuracin
del

de
los
conectividad
enrutamiento

routers
entre
dinmico

R1
R1
entre

y
y
R1

R2
R2
R2

El comando para configurar el enrutamiento esttico mediante el protocolo RIP


esrouter
rip.
Para
agregar
las
redes
se
usa
el
comando network
[direccin_red]donde [direccin_red] es la direccin de la red con clase directamente
conectada al router. Por ejemplo, para la red 1.1.1.0(clase A) su direccin con clase es
1.0.0.0, para la red 172.16.26.0(clase B) su direccin con clase es 172.16.0.0 y para
la red 192.168.35.0(clase C) su direccin con clase es 192.168.35.0. Como se observa
en el diagrama, en el router R1 las redes directamente conectadas son
192.168.10.0/24 y 1.1.1.0/30 y para el router R2 las redes directamente conectadas
son 192.168.20.0/24 y 1.1.1.0/30.

Configuracin de los routers R1 y R2


Procedemos a configurar el nombre, la interfaz fastEthernet y la interfaz serial de los
routers R1 y R2 segn el diagrama de red. Para ver la configuracin visita la
entradaEnrutamiento Esttico en Routers Cisco y sigue los pasos indicados en los
puntos Configuracin del Router R1 y Configuracin del Router R2 para configurar los
equipos.

Probar la conectividad entre R1 y R2


Hasta este punto, hemos configurado R1 y R2 para que tengan conectividad entre s,
todava no hemos configurado el enrutamiento dinmico en los equipos. Antes de
continuar, podemos hacer uso del comando ping para probar la conectividad entre los
equipos. Para poder realizar enrutamiento dinmico entre R1 y R2 debe haber
conectividad entre ellos. Por ejemplo, en R1 hacemos ping a la interfaz de R2:
R1>ping 1.1.1.2

Configuracin del enrutamiento dinmico


entre R1 y R2
En R1, entramos al modo de configuracin global y configuramos el enrutamiento
dinmico ingresando las redes directamente conectadas a R1:
R1>enable
R1#configure terminal
R1(config)#router rip
R1(config-router)#network 1.0.0.0
R1(config-router)#network 192.168.10.0
De manera anloga, realizamos el procedimiento para R2:
R2>enable
R2#configure terminal
R2(config)#router rip
R2(config-router)#network 1.0.0.0
R2(config-router)#network 192.168.20.0
Y listo, tenemos los equipos configurados con enrutamiendo dinmico usando el
protocolo RIP. Para ver la configuracin del enrutamiento dinmico se usa el
comandoshow ip protocols.
R1>show ip protocols
Podemos verificar que el enrutamiento funciona haciendo ping a las interfaces
fastEthernet de R1 y R2. Por ejemplo para verificar el enrutamiento en R1:
R1>ping 192.168.20.1
Para probar el enrutamiento en R2:

R2>ping 192.168.10.1
Para probar la conectividad entre los hosts (PC1 y PC2), solo es necesario configurar la
direccin IP, la mscara de red y la direccin IP de la puerta de enlace para cada uno.
Para PC1 la puerta de enlace sera la interfaz Ethernet 0/0 de R1 cuya direccin IP es
192.168.10.1 y para PC2 la puerta de enlace sera la interfaz Ethernet 0/0 de R2 cuya
direccin IP es 192.168.20.1. Luego queda probar la conectividad con el
comandoping. Por ejemplo, para PC1 el comando es ping 192.168.20.2 y para PC2
el comando es ping 192.168.10.2.

Ejercicio #2:

La configuracin inicial es la siguiente, hemos asignado una IP a cada interfaz de


serie de cada router a excepcin de R2 que tiene dos interfaces, una contra R1 y
otra contra R2:
Router 1 (hostname R1):

R1#conf t
R1(config)#interface Serial1/0
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#no shutdown

Router 2 (hostname R2)

R2#conf t
R2(config)#interface Serial1/0
R2(config-if)#ip address 10.0.0.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface Serial1/1
R2(config-if)#ip address 10.0.1.1 255.255.255.0
R2(config-if)#no shutdown

Router 3 (hostname R3)

R3#conf t
R3(config)#interface Serial1/0
R3(config-if)#ip address 10.0.1.2 255.255.255.0
R3(config-if)#no shutdown

Con esta configuracin, y sin aplicar ningn tipo de routing slo hay comunicacin
entre las interfaces conectadas directamente (C), lo podemos verificar con el
comando

show

ip

route:

Router 1 (hostname R1):


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
...
...
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets


C

10.0.0.0 is directly connected, Serial1/0

Router 2 (hostname R2)


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
...
...
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets


C

10.0.0.0 is directly connected, Serial1/0

10.0.1.0 is directly connected, Serial1/1

Router 3 (hostname R3)


R3# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
...
...
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets


C

10.0.1.0 is directly connected, Serial1/0

Efectivamente, el router R2 tienen conectividad con los otros dos routers:


R2#ping 10.0.0.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/11/32 ms
R2#ping 10.0.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/20 ms

Ahora

llega

el

momento

de

configurar

routing

para

poder establecer

comunicacin entre el router R1 y el R3 ya que no estn conectados


directamente:
R1#ping 10.0.1.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.0.1.2, ti
.....
Success rate is 0 percent (0/5)

Los pasos para activar RIPv2 son los siguientes, ponemos como ejemplo el router
R1:

R1#conf t
Enter configuration commands, one per line.

End with CNTL/Z.

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#exit

Los pasos son acceder al modo de configuracin global, indicar que el protocolo
de routing es rip (router rip), especificar la version 2 y finalmente con el comando
network especificar a travs de que interfaces se enviarn y recibirn las
actualizaciones de routing, en este caso todas las interfaces que pertenezcan a
la red 10.0.0.0 que es la serial 1/0.
Hacemos lo mismo en R2, pero en este caso especificamos que las dos interfaces
serial enviarn y recibirn actualizaciones de routing:

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#network 10.0.1.0

En este momento, aunque no hemos terminado ya que falta configurar R3 ya


podemos ver la nueva ruta, se ha recibido que la red 10.0.1.0 se ha de enrutar a
travs de la interfaz 10.0.0.2 Serial1/0 del router R2:

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets


C 10.0.0.0 is directly connected, Serial1/0
R 10.0.1.0 [120/1] via 10.0.0.2, 00:00:25, Serial1/0

Todava no funcionar la comunicacin porque R3 no sabe como devolver los


paquetes recibidos as que lo configuramos de igual modo:

R3(config)#router rip

R3(config-router)#version 2
R3(config-router)#network 10.0.1.0

Ahora ya podemos finalmente verificar en todos los routers la tabla de


enrutamiento, deberan haber recibido las rutas para comunicarse entre los tres,
verificamos con un ping desde R1 o R3:
R1#ping 10.0.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/31/44 ms

Y desde R3 a R1:
R3#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms

Realmente nos podramos haber ahorrado la configuracin de routing en el router


R2 ya queest conectado directamente a ambas redes. Vamos a probar a
deshabilitarlo:
R2(config)#no router rip

Y verificamos que todo sigue funcionando correctamente:


R1#ping 10.0.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/20 ms

R3#ping 10.0.0.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/28 ms