Вы находитесь на странице: 1из 2

Ejercicios de introduccin a algoritmica

por Alicia Beatriz Paur


Este documento adapta ejercitacin de la Gua de Trabajos Prcticos de la asignatura Algortmica y Programacin I,
carrera: Licenciatura en Sistemas y Analista Programador Universitario-Facultad de Ingeniera (UNPSJB, sede Trelew)
con la finalidad de generar objetos de aprendizaje (OA) de menor granularidad y mayor modularidad tendientes a
aumentar su reusabilidad en diferentes contextos.
La gua de trabajos prcticos de Algortmica y Programacin I ha sido desarrollada por los docentes de esa ctedra entre
los que se incluye la autora de esta adaptacin.
El objetivo de este OA es repasar conceptos introductorios tales como notacin binaria, comprensin de expresiones
lgicas; tambin se ejercitan soluciones algortmicas de ejercicios simples.

Repaso notacin binaria


1- Representa en notacin binaria los siguientes valores decimales:
a) 2
b) 425
c) 987
2- Compara la representacin binaria del valor 987 con la representacin binaria de la secuencia de caracteres 987.
Es lo mismo? Por qu?
3- Cuntas representaciones diferentes pueden lograrse en un byte? Qu rango de valores numricos se
representan en un byte? Qu nmero representa la secuencia binaria 1111 1111? (considerado como nmero no
signado)

Usando expresiones lgicas


1- Un hombre perdido en el desierto se encuentra con cuatro botellas enterradas en la arena y un cadver al lado de
ellas. Cada botella tiene una etiqueta:
a) Ac hay agua o soda
b) Ac hay agua o soda
c) Ac hay veneno o jugo d) Ac hay veneno o agua.
Las cuatro botellas tienen lquidos con distinto aspecto, con lo cual nuestro hombre intuye, acertadamente, que
contienen cuatro lquidos distintos. Cul botella contiene veneno?
2- Para poder cursar esta materia se requiere ser alumno regular de la carrera APU y haber obtenido concepto en
Introduccin a la Computacin. Un alumno que en el ciclo lectivo anterior ha aprobado dos finales es regular. Los
alumnos ingresantes son alumnos regulares.
Para los siguientes casos, indica si el alumno que cumple esas condiciones puede cursar esta materia.
a)
b)
c)
d)

Es regular u obtuvo concepto.


Es ingresante y obtuvo concepto.
Obtuvo concepto y aprob dos finales.
Es ingresante o aprob dos finales u
obtuvo concepto.

e)
f)
g)
h)

Es ingresante y (aprob dos finales u obtuvo concepto).


Es ingresante o (aprob dos finales y obtuvo concepto).
Es ingresante y aprob dos finales y obtuvo concepto.
(Es ingresante y aprob dos finales) u obtuvo concepto.

3- Indica el resultado de las siguientes operaciones lgicas, siendo A = 3, B = 2, M = verdadero y N = falso.


( ( A + B* B) >= (A B) ) o no ( M y no N )
no ( (A = B) y (A = 3 ) ) y ( (A ~< B) o (A ~< 0))
4- Escribe expresiones lgico-matemticas para expresar los siguientes conceptos. Recuerda la diferencia entre:
5 / 2 = 2.5, 5 mod 2 = 1 y 5 div 2 = 2
N mod 2 = 0
N es un nmero par
N es un nmero impar
N es divisible por p
N es mltiplo de 7 y mltiplo de 4
no (N mod 5 = 0) y no (N mod 8 = 0)
N no es mltiplo de 5 ni mltiplo de 8
N es divisor de p
N tiene al menos dos dgitos
N es capica de dos dgitos
(N > 9 ) y (N ~< 100 ) y (N mod 10) = (N div 10)
N es un capica de tres dgitos

Primeros algoritmos
1- Cules de los siguientes algoritmos permiten generar el listado ordenado alfabticamente de los alumnos inscriptos
en AyP?. En los casos que no lo permiten, justifica el por qu.
a) Obtener la lista de nombres de los alumnos inscriptos en AyP.

Imprimir la lista.
b) Obtener la lista de nombres de los alumnos inscriptos en cada materia de la facultad (materia-nombre de
alumno).
Ordenar alfabticamente por nombre la lista.
Listar los nombres de aquellos que estn inscritos en AyP.
c) Por cada alumno de la facultad:
si est inscripto en AyP, insertar en orden alfabtico su nombre en una lista.
Imprimir la lista.
d) Obtener la lista de nombres de los alumnos inscriptos en AyP.
Ordenar alfabticamente la lista.
Imprimir la lista.
2- Modifica el algoritmo anterior para que las cartas con igual valor al de referencia:
a) le correspondan al jugador 1.
b) a ninguno de los dos.
3- Juego de cartas: Indica si el siguiente algoritmo refleja el juego. Corrige si lo consideras necesario.
Algoritmo Juego de cartas
Descripcin del juego
El juego consiste en: tomar una carta del mazo,
la cual servir de referencia.
Distribuir las restantes cartas entre dos
jugadores: el jugador 1 a quien le tocar las
cartas de menor valor que el de la carta de
referencia y el jugador 2 que tendr las
restantes. Gana el jugador que obtenga ms
cartas.

tomar una carta del mazo (carta1)


mientras queden cartas en el mazo
tomar otra carta (carta2)
si carta2 < carta1 entonces
dar carta2 a jugador 1
sumar 1 a cantidad de cartas de jugador 1
sino
dar carta2 a jugador 2
sumar 1 a cantidad de cartas de jugador 2
fin si
fin mientras
si cantidad de cartas del jugador 1 > cantidad de cartas del
jugador 2 entonces
gan el jugador 1
sino
gan el jugador 2
fin si
Fin algoritmo

4- Realiza la traza de los siguientes algoritmos e indica los resultados visualizados. Marca las asignaciones,
instrucciones de entrada o salida, variables y valores constantes, estructuras de decisin y de repeticin que
aparecen en estos algoritmos:
Algoritmo result1
Algoritmo result2
Var
x, y: entero

Var

Inicio
x 2
si x < 2 entonces
mostrar (Primero)
sino
mostrar (Segundo)
finSi

Inicio
ingresar (a, b)
si a < b entonces
c a
a b
b c
finSi

si x < 4 entonces
mostrar (Tercero)
finSi

repetir
a a b
c ab
hasta a < 0
mostrar (a, b, c)
Fin

mostrar (Cuarto)
x 5 + 3 * 6 mod 4
y x div 2
mostrar (x, y)
Fin

a, b, c: entero