Вы находитесь на странице: 1из 24

Principios de Algoritmos

Logro esperado
Comprende y analiza los problemas para
elaborar un algoritmo utilizando arreglos,
construyendo e implementando el respectivo
seudocdigo.

2
Pablo Romero

Introduccin

Pablo Romero

Agenda
Pseudocdigo
Arreglos
Tipos: Unidimensional y Bidimensional
Declaracin
Acceso
Ejemplo
Ejercicio

Arreglo (Array)
Es un conjunto finito y ordenado de
elementos homogneos.
Finito: siempre ser necesario especificar el
nmero de elementos que tiene el arreglo.
Ordenado: que sea posible identificar el
primero, segundo, , n-simo elemento del
arreglo.
Homogneo: todos los elementos son del
mismo tipo
Se almacenan normalmente en posiciones
contiguas de la memoria a partir de una
direccin inicial.
5

Tipos
Unidimensional
Bidimensional

Arreglo unidimensional
Arreglo de una dimensin (Vector)
1

ndice o Subndice: designa la posicin de un elemento en


el arreglo.
Operacin Acceso. Se realiza a travs del nombre del
arreglo y entre corchetes el valor del ndice.
Ejemplo X [1]
7

Arreglo unidimensional
La operacin de almacenamiento se realiza usando
el operador de asignacin y entregando un valor
que ser guardado en una posicin del arreglo.
Ejemplo: x[10] 524
Cuando se usan arreglos se deben tomar los
siguientes cuidados:
Dar valor inicial a los elementos del arreglo
Especificar siempre el valor del ndice
Cuidar que los ndices no tomen valores fuera de su rango.

Arreglo Bidimensional
Arreglo de dos dimensiones (Matriz)

Est conformado por filas y columnas

Arreglo bidimensional: acceso


Operacin Acceso. Se realiza a travs del nombre
del arreglo y entre corchetes el valor de los
ndices, considerando que el primero indica el
nmero de fila y el segundo el nmero de
columna del elemento, por ejemplo B[ i , j ]
La operacin de almacenamiento se realiza
asignando un valor a una determinada posicin
del arreglo.
Es necesario tener la seguridad de que los
valores usados para los ndices sean vlidos, es
decir que estn entre los valores lmites definidos
para el arreglo.
10

Declaracin y referencia (acceso)


Declaracin
Dimension IdentificadorArreglo [ tamao {, tamao} ]
Recuerde definir tipo de arreglo
Definir IdentificadorArreglo como Tipo

Referencia a Arreglos
IdentificadorArreglo [ Indice {, Indice} ]

11

Declaracin y referencia: ejemplo

Se declara:
Dimension lista [20]
Definir lista como Entero
Se usa:
Leer lista [ 3 ]
lista [ i ] 20
valor lista [ 3 ]
Escribir lista [ 3 ]

Se declara:
Dimension notas[25,4]
Definir notas como Entero
Se usa:
Escribir notas[5,3]
notas[i,j] 19
parcial notas [2,5]
Leer notas[i,j]
12

Vector: ejemplo 1
Almacenar nota obtenida por cada uno de n alumnos (mximo
20) en el vector notas. Mostrar cuantos alumnos aprobaron

13

Usando subprogramas
Proceso HallarAprob
Dimension notas[20]
Definir notas, n Como Entero
Escribir "Cantidad de alumnos "
Leer n
llenarVector(n,notas)
mostrarVector(n,notas)
Escribir "Aprobados ", cantAprob(n,notas)
FinProceso
Pablo Romero

14

SubProceso llenarVector(num,not Por Referencia)


Definir i como Entero
Para i<- 1 hasta num hacer
Leer not[i]
FinPara
FinSubProceso
SubProceso mostrarVector(num,not)
Definir i como Entero
Para i<-1 hasta num hacer
Escribir not[i]
FinPara
FinSubProceso
Pablo Romero

15

Subproceso cont<-cantAprob(num,not)
Definir i, cont Como Entero
cont<-0
Para i<- 1 hasta num hacer
Si not[i]>=12 Entonces
cont<-cont+1
FinSi
FinPara
FinSubProceso
Pablo Romero

16

Pablo Romero

17

Matriz: ejemplo 2
Almacenar 3 notas de cada uno de los n alumnos (mximo 20) en
matriz curso. Mostrar la ms alta nota y a que alumno y cual de
sus notas corresponde.

Pablo Romero

18

Pablo Romero

19

Pablo Romero

20

Ejercicio
Guardar n edades (mximo 50) de
deportistas en un vector y mostrar la menor
de las edades y a que deportista
corresponde.

Pablo Romero

21

Preguntas

Pablo Romero

22

Ejercicio
Guardar 10 nmeros en un arreglo. Mostrar
cuntos valores son negativos, positivos y
cero.

23

Recordar que
Comprende y analiza los problemas para elaborar un
algoritmo utilizando arreglos, construyendo e
implementando el respectivo seudocdigo.

En un arreglo:
Todos los datos sern del tipo (homogneo)
mismo
La cantidad de elementos es .
finita
Para designar la posicin de un elemento, se usa un valor
entero llamado .
ndice
Para referirse al arreglo, se usa un nico .
identificador
24