Вы находитесь на странице: 1из 28

Page 1 of 28

LAB 1
OBJECTIVE
Familiarization with networking Equipment, Components and PACKET Tracer

Equipment:
1 Router, 1 Switch, Computer with Packet Tracer Installed

Procedure:
Router:

Router has hot pluggable Flash Memory

Normally 2 Ethernet Ports and Free Slots available for inserting cards as required

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 2 of 28

A Console port to access


An auxiliary port for accessing router from far away location
What type of routers you have in your LAB write its product number?

What is its FLASH capacity?

How many ports and slots are available? What are their specifications? Which type of cards you have in
LAB?

Switch:
A switch has different number of ports depending on requirements and Model Number.
A Console port to access device
Sometimes we found USB console in modern switches
How many switches are in your LAB? And how many ports and their speed specified?

Is there any third layer switch available? Which one?

What is meant by POE switch?

Packet Tracer:

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 3 of 28

It is simulator for prototyping our network


Here we can use different devices like Router of Different Types and Switches of different series
In this simulator we can also use wireless devices and End Devices Like Computer and TAB etc.
Different Type of Cables available in Cable TAB.
Cables:
We have four types of cables used in this subject
a.
b.
c.
d.

Console Cable
Straight Through Cable used to connect different devices
Cross Over Cable used to connect same devices
Serial Cable

We have RJ45 connectors on both ends of straight and cross cable


In Console cable one side got RJ45 connector and other got DB-9 Connector to communicate with
computer.

Summary:

LAB 2
OBJECTIVE
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 4 of 28

Peer to Peer Communication b/w two PCs

Equipment:
2 Computers with windows OS installed
1 Crossover Cable
Some data to share

Procedure:
a.
b.
c.
d.

Power on both PCs


Enable Ethernet LAN connection from control Panel
Assign IP address to TCP/IPv4 from same network
Connect both PCs with cross cable in their LAN adapters

As we insert cable green lights will start to blink on both LAN adapters and link could be seen as UP
status. Share some data from PC1 access it from PC2.

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 5 of 28

Give ping command from one PC and write its output?

This can be accomplished from properties>Sharing >share Folder as seen in diagram.


Copy a large file from PC1 to PC2. Start task manager and see how much transfer rate you got from
network TAB?

Summary:

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 6 of 28

LAB 3
OBJECTIVE
Access a Router/Switch

Equipment:
1PC with terminal Emulator
A Router
A Console Cable

Procedure:
Launch terminal emulator select correct COM port number.
Select correct bits/s, data bits, parity, stop and flow control.
By default
Bits/s=9600
Data Bits=8
Parity= None
Stop Bits= 1
Flow Control= None
Insert DB-9 connector of console cable in PC COM port, and RJ-45 connector in Router/Switch console
port.
Power on Router/Switch and see the emulator will show the device start boot up.
To access a device from far away location we use AUX port have RJ-45 port.
We connect AUX port to modem and our emulator system with another modem.
Dial the number through emulator and device will be accessible.
How many COM ports you see? Which COM port do you select?

Summary:
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 7 of 28

LAB 4
OBJECTIVE
Basic Commands in CLI mode of Router IOS

Equipment:
Console cable
Router/Switch
PC with terminal Emulator

Procedure:
As we access the device in LAB 3 and device completed its boot startup
We see Router > its called user mode of Router.
Here we can use ping, trace route and somewhat show commands.
Type enable and enter we see Router # its called privilege mode.
Here we can use all show commands, erase flash memory.
Type configure terminal we see Router (Config) # its called configuration mode.
From here we start our any type of configuration.
Type interface type number, For example interface fast Ethernet 0/0
We see Router (Config-if) called interface mode.
From here we can configure our interface settings.
Give command show ip interface brief in privilege mode. How many physical and virtual interfaces
available?

Give command show flash, How much memory it has?

Give command show version what information you got here?


Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 8 of 28

Summary:

LAB 5
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 9 of 28

OBJECTIVE
Connecting two networks via router and routing table

Equipment:
Console cable
Router, 2-Switch, 2 Pcs
PC with terminal Emulator

Procedure:
As we access the device in LAB 3 and device completed its boot startup
Type enable to enter in privilege mode. Here type show ip interface brief command to see how many
physical and logical interfaces on router.
You will see two fast Ethernet port.
Type configure terminal to enter in global configuration mode.
Enter one of physical interface name like interface fast Ethernet 0/0
Now you are in interface mode assign ip address using command ip address address subnet mask.
Type no shutdown command to enable interface.
Repeat same process to assign ip address to the other interface.
Now connect two switches and Pcs as shown in fig. Assign ip address to the pcs from respective network.
Try to ping both pcs.
You will see it will be successful although both are in different networks.
Come to router privilege mode enter command show ip route to see routing table of router.
What does it shows?

Give command show interface fastethernet 0/0 what information you got here?
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 10 of 28

Summary:

LAB 6
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 11 of 28

OBJECTIVE
Assigning IP Address to Interface and Access via Telnet Utility

Equipment:
Console cable
Router/Switch
PC with terminal Emulator
Ethernet Straight Through cable

Procedure:
Access router as described in LAB 3.
Enter in interface mode as described in LAB 4.
Type command ip address interface IP ADDRESS SUBNET MASK it assign IP address to that
specific interface in which we are.
Type no shutdown It makes port status as UP.
Type exit to come to configuration mode
Set privilege mode password using command enable password PASSWORD
Set virtual terminal lines using command line vty 0 4
Set password to virtual line using command Password PASSWORD
Press CTRL+Z Router will be in privilege mode.
Type write or copy running-configuration startup-configuration it will save data from RAM to
NVRAM.
Connect patch cable to the interface that we have configured and insert the other end to LAN adapter of
PC.
Assign IP address to TCP/IPv4 from same network as assigned in Router/Switch.
Check connectivity of Router/Switch using ping utility.
Go to the command prompt type telnet IP ADDRESS of Router/Switch

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 12 of 28

You will be asked to type invisible password of virtual password.


After typing enable you will be demanded to give privilege mode password.
Type it and you will get access to device.
Type command show flash what type of files you got there?

Summary:

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 13 of 28

LAB 7
OBJECTIVE
Configure VLANs in a Switch, assigning ports to VLAN and PORT Security

Equipment:
Console cable
PC with terminal emulator
Switch

Procedure:
Get access to the switch and enter in privilege mode.
Type Show vlan
We see default vlans configured on switch and all ports are the member of VLAN 1.
Enter in configuration mode and type vlan 2 we will be in Switch (Config-vlan) mode
Assign a name to that vlan using command name NAME
Type vlan 3-6 in configuration mode
Type do show vlan we see configured vlans are 2-6
Enter in any interface using command interface type name
Type the following commands to make that interface member of some specific vlan
switchport mode access
switchport access vlan vlan number
Press CTRL+Z and type show vlan write down the output here

Go to interface mode of any interface that is connected and active with a PC. And write commands as
follows.
switchport port-security
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 14 of 28

switchport port-security maximum 1


switchport port-security mac-address sticky
switchport port-security violation shutdown
In privilege mode give command show port-security interface interface name write output here

Disconnect PC and connect another to that port and see what happens? What is the output of command
shoe port-security interface interface name what is the difference?

Summary:

LAB 8
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 15 of 28

OBJECTIVE
Configure DHCP Server on a Router

Equipment:
Router
Switch
3-5 PC
Some straight cables
Console cable

Procedure:
Connect all the equipment as seen in Fig.
Make PCs to obtain ip address automatically from DHCP server
Access the Router enter in configuration mode
Assign ip address to port that is connected to switch.
Type the following commands to set the DHCP server in configuration mode.
ip dhcp pool POOL NAME
network NET ID of network SUBNET MASK
default-router ip address of routers port
Press CTRL+Z and type write
Check what ip addresses PCs got?

Give command ip dhcp excluded address starting of range ending of range

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 16 of 28

Now what is the change in ip addresses of PCs?

Summary:

LAB 9
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 17 of 28

OBJECTIVE
Configuring a Trunk b/w two Switch, Assign VLAN numbers to trunk port and Configure and verify VTP

Equipment:
Two switches
Crossover and straight through cables and console cable
4 pcs

Procedure:
Connect both switches with cross cable on fast Ethernet 0/0 of both switches
Power on both switches
Create 4 vlans
Switch 1 Configuration
Config t
Interface fast Ethernet 0/0
Switchport mode trunk
Switchport trunk allowed vlan 1,2,3,4
exit
Vtp mode server
Vtp domain name CISCO

Switch 2 configuration
Config t
Interface fast Ethernet 0/0
Switchport mode trunk
Switchport trunk allowed vlan 1,2,3,4
exit
Vtp mode client
Vtp domain name CISCO

Make two ports (fa0/2 and fa0/3) of both switches the member of vlan 2 and vlan 3 respectively
Connect PCs to all 4 ports and try to communicate b/w different vlans.
What happens?

Give command show vtp status in privilege mode and write the output here.

Summary:
LAB 10
OBJECTIVE
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 18 of 28

Configure Static Route and Default Route

Equipment:
3 routers
Crossover cables
Console cable
Terminal emulator

Procedure:
Connect routers as shown
Assign ip addresses to all ports of router
Here we configure a static route on router A to reach at a network Router C and create a default route on
router B to reach at a network router C.
Router A
A (config) # ip route destination network SUBNET MASJ NEXT HOP ADDRESS
Router B
B (config) # ip route 0.0.0.0 0.0.0.0 NEXT HOP ADDRESS
Give command of show ip route on router B and C and write details.
_____________________________________________________________________________________
_____________________________________________________________________________________
_____________________________________________________________________________________
_____________________________________________________________________________________
_____________________________________________________________________________________

Summary:

LAB 11
OBJECTIVE
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 19 of 28

Configure a distance Vector Routing Protocol

Equipment:
3 Routers having minimum 3 interfaces
Crossover cables
3 Pcs
Console and terminal emulator

Procedure:
Connect the equipment as shown in diagram.
Assign IP Addresses to each interface
Try to ping from one network to any other and give details

Give command show ip route in privilege mode of each router and write here what you observe

Give the command router rip in global configuration mode.


Afterward network network of directly connected ip addresses
As RIP is class full routing protocol so no need to give subnet mask
Another flavor of RIP is version 2 which is classless routing protocol so we have to give subnet mask
information after network command
Give command show ip route in privilege mode of each router and write here what you observe

Administrative Distance of RIP is 120 by default

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 20 of 28

EIGRP is also a distance vector routing protocol and its startup implementation commands are same as
RIP V2 will be done by your instructor.
Give details of show ip route after EIGRP implementation

Summary:

LAB 12
OBJECTIVE
Configure Link State Routing Protocol
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 21 of 28

Equipment:
Two Pcs
3 Routers
Two switches

Procedure:
Connect the equipment as shown in diagram
Assign hostname and ip addresses to the respective interfaces as given in fig.
Give following commands in global configuration mode of all routers
Router(config)# router ospf autonomous system number
Same command for all directly connected networks
Router(Config-router)# network network-id wildcard-mask area area #
Give command show ip route

Show ip ospf neighbor

Show ip ospf database

Summary:

LAB 13
OBJECTIVE
Configure and verify static/dynamic NAT

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 22 of 28

Equipment:
Two ISR routers
1 Switch
5 Pcs
Straight through and Crossover cables

Procedure:
Connect the equipment as shown in fig

Assign IP Addresses according to scenario may be statically or via DHCP


Give command ip nat inside in interface fast Ethernet 0/0 mode of router A
Give command ip nat outside in interface fast Ethernet 0/1 mode of router A
Now come back to global configuration mode of router A and give command
ip nat inside source static inside local IP Address inside global IP Address
Press ctrl+Z and type write
Then give command show ip nat translation
What you see

Now send some ICMP packets from natted PC to router B.


Then give command show ip nat translation

Whats the difference?

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 23 of 28

Dynamic NAT is accomplished by your instructor and write here what is the basic difference you found in
Static and Dynamic NAT?

Summary:

LAB 14
OBJECTIVE
Configure Inter VLAN Routing

Equipment:
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 24 of 28

Two third layer switches


4 Pcs
Straight through and crossover cables

Procedure:
Configure 2 VLANs RED WHITE on a switch A
Make it vtp server and vtp domain name cisco.com
Make first 5 ports member of VLAN RED and next five ports member of VLAN WHITE
Connect 2 Pcs to RED vlan and 2 pcs to WHITE vlan
Try to communicate (ping) b/w pcs of different vlans
What is the output?

Give command ip routing on both switches now try to communicate b/w those pcs
What is output?

It is due to third layer device now router on a stick will be performed by your instructor and you will
write here the difference of both?

Summary:
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 25 of 28

LAB 15
OBJECTIVE
Install and Configure Secure Device Manager

Equipment:
Router
Straight through cable
Computer Communication and Networks
Technology Sahiwal

COMSATS Institute Of Information

Page 26 of 28

Console with terminal PC

Procedure:
Install SDM software on PC

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 27 of 28

Access the router using console cable


And give commands
Router(config)# ip http server
Router(config)# ip http authentication local
Router(config)# username NAME password PASSWORD
Router(config)# enable password PASSWORD
Assign ip address to a port of router that is connected to PC from network 10.10.10.0
Launch SDM from desktop

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information

Page 28 of 28

A window will appear as

From here we can configure router for some specific tasks.

Summary:

Computer Communication and Networks


Technology Sahiwal

COMSATS Institute Of Information