Вы находитесь на странице: 1из 51

Lab Assignment: 5

INWK 6117

Group 2
Vignesh Puli Janardhanan (B00567154)
Alagappan Vairavan (B00566817)
Kanika Poply (B00558593)

Group 3
Srinivas Yadalla (B00564873)
Vignesh Murali (B00571459)
Srinath Jayraman (B00561608)

a. Assume VPN_A and VPN_B use the same IP block/address space. How is this achieved?
RD- Route distinguisher allows different VPNs to use the same address space. RD is a 64 bit
prefix which is added in front of the IPv4 address to make potentially same IPv4 addresses
globally unique. Rd is used to identify VPN as each VPN is assigned a unique RD.
b. What is the purpose of using BGP?
When 64 bits of RD prefix is added to 32 bits of IPv4 address than it results into 96 bits of
VPNv4 addresses. VPNv4 addresses are exchanged between PE routers via BGP. To support
address families other than IPv4, another form of BGP is used known as MP-BGP.
c. For implementing the above VPNs what is the contribution of MPLS other than traffic
engineering?
Label stacking mechanism was introduced in MPLS VPN. PE ingress router attached two labels
to an unlabelled IP packet it receives. One of this is for LSP and other one for VPN. First label is
used to transfer the packet to egress router through label swapping in the MPLS network. Core
routers only perform label lookup. Second label is used by the egress router to match the VPN
route to CE. To learn BGP updates in the MPLS VPN network loopback interface on each router
is used.
d. Ping the loopback address of the peer router including the loopback addresses of VPNs
and capture the output?
ICMP echo request from 10R2 to 9R2

ICMP echo reply from 9R2 to 10R2 in response to ICMP echo request

Outputs for the following commands:


Show mpls interfaces: Shows mpls enabled interfaces as we can see in the outputs below for
routers 9R4 and 9R1

Show mpls ldp neighbor: shows the active mpls neighbors as we can see in the output below
for router 9 R4, it has 2 mpls neighbors 9R1 and 10R4.

Show mpls ldp bindings: shows the mpls label bindings i.e local label bounded and remote
label bounded.

Show mpls forwarding table: shows the local and outgoing labels along with the outgoing
interface and next hop.
10R1#sh mpls forwarding-table
Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

or Tunnel Id

interface

16

19

172.16.1.1/32

Gi0/2

192.168.41.4

17

18

172.16.2.2/32

Gi0/2

192.168.41.4

18

No Label 10.1.5.5/32[V] 1140

19

16

20

Pop Label 192.168.44.0/24 0

Gi0/2

192.168.41.4

21

No Label 10.1.3.3/32[V] 1140

Gi0/0

10.1.21.2

23

Pop Label 172.16.3.3/32

26

No Label 10.1.31.0/24[V] 0

27

No Label 10.1.21.0/24[V] 570

192.168.14.0/24 0

Gi0/1
Gi0/2

Gi0/2

10.1.31.3
192.168.41.4

192.168.41.4

aggregate/VPN_B
aggregate/VPN_A

Show ip bgp neighbors: displays active BGP neighbors in the network

9R3#sh ip bgp neighbors


BGP neighbor is 10.1.13.1, remote AS 1, external link
BGP version 4, remote router ID 172.16.1.1
BGP state = Established, up for 00:54:31
Last read 00:00:32, last write 00:00:30, hold time is 180, keepalive interval
is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received(old & new)
Address family IPv4 Unicast: advertised and received
Message statistics:
InQ depth is 0
OutQ depth is 0
Sent
Opens:

Rcvd
1

Notifications:

1
0

Updates:

Keepalives:

57

Route Refresh:
Total:

7
61

0
59

0
69

Default minimum time between advertisement runs is 30 seconds

For address family: IPv4 Unicast


BGP table version 10, neighbor version 10/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member

Sent
Prefix activity:

Rcvd
----

Prefixes Current:

---1

Prefixes Total:

3 (Consumes 156 bytes)

Implicit Withdraw:

Explicit Withdraw:

Used as bestpath:

n/a

Used as multipath:

n/a

Outbound Inbound
Local Policy Denied Prefixes:
Bestpath from this peer:
Total:

-------5

------n/a

Number of NLRIs in the update sent: max 1, min 1

Connections established 1; dropped 0


Last reset never
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled
Local host: 10.1.13.3, Local port: 179
Foreign host: 10.1.13.1, Foreign port: 17958

Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)

Event Timers (current time is 0xBB0704):


Timer

Starts Wakeups

Next

Retrans

58

0x0

TimeWait

AckHold

65

60

0x0

SendWnd

0x0

KeepAlive

0x0

GiveUp

0x0

0x0

PmtuAger

0x0

DeadWait

0x0

iss: 1354011944 snduna: 1354013126 sndnxt: 1354013126


irs: 4031290889 rcvnxt: 4031292400 rcvwnd:

sndwnd: 15203

16346 delrcvwnd:

38

SRTT: 300 ms, RTTO: 303 ms, RTV: 3 ms, KRTT: 0 ms


minRTT: 0 ms, maxRTT: 300 ms, ACK hold: 200 ms
Flags: passive open, nagle, gen tcbs
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):


Rcvd: 122 (out of order: 0), with data: 65, total data bytes: 1510
Sent: 119 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0
), with data: 57, total data bytes: 1181

Show ip vrf detail: Displays all the VRF active, their RD and import and export RT.
9R1#sh ip vrf detail
VRF VPN_A (VRF Id = 3); default RD 200:110; default VPNID <not set>
Interfaces:

Gi0/0
VRF Table ID = 3
Export VPN route-target communities
RT:200:110
Import VPN route-target communities
RT:200:110
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix

VRF VPN_B (VRF Id = 5); default RD 200:120; default VPNID <not set>
Interfaces:
Gi0/1
VRF Table ID = 5
Export VPN route-target communities
RT:200:120
Import VPN route-target communities
RT:200:120
No import route-map
No export route-map

Show ip route vrf VPN_A: Displays the routing table for VPN_A VRF
9R1#sh ip route vrf VPN_A

Routing Table: VPN_A

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks


B

10.1.2.2/32 [20/0] via 10.1.12.2, 01:30:19

10.1.3.3/32 [200/0] via 172.16.4.4, 00:25:25

10.1.12.0/24 is directly connected, GigabitEthernet0/0

10.1.12.1/32 is directly connected, GigabitEthernet0/0

10.1.21.0/24 [200/0] via 172.16.4.4, 00:25:25

Show ip route vrf*: Displays the routing table for all the VRFs active
9R1#sh ip route vrf *
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/32 is subnetted, 4 subnets


C

172.16.1.1 is directly connected, Loopback0

172.16.2.2 [110/2] via 192.168.14.4, 01:56:37, GigabitEthernet0/2

172.16.3.3 [110/3] via 192.168.14.4, 00:18:59, GigabitEthernet0/2

172.16.4.4 [110/4] via 192.168.14.4, 01:56:37, GigabitEthernet0/2


192.168.14.0/24 is variably subnetted, 2 subnets, 2 masks

192.168.14.0/24 is directly connected, GigabitEthernet0/2

192.168.14.1/32 is directly connected, GigabitEthernet0/2

192.168.41.0/24 [110/3] via 192.168.14.4, 01:56:38, GigabitEthernet0/2

192.168.44.0/24 [110/2] via 192.168.14.4, 01:56:38, GigabitEthernet0/2

Routing Table: VPN_A


Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks

10.1.2.2/32 [20/0] via 10.1.12.2, 01:32:45

10.1.3.3/32 [200/0] via 172.16.4.4, 00:27:51

10.1.12.0/24 is directly connected, GigabitEthernet0/0

10.1.12.1/32 is directly connected, GigabitEthernet0/0

10.1.21.0/24 [200/0] via 172.16.4.4, 00:27:52

Routing Table: VPN_B


Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks


B

10.1.4.4/32 [20/0] via 10.1.13.3, 01:13:11

10.1.5.5/32 [200/0] via 172.16.4.4, 00:28:13

10.1.13.0/24 is directly connected, GigabitEthernet0/1

10.1.13.1/32 is directly connected, GigabitEthernet0/1

10.1.31.0/24 [200/0] via 172.16.4.4, 00:28:14

Show ip bgp vpnv4 all:

9R1#sh ip bgp vpnv4 all


BGP table version is 33, local router ID is 172.16.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network

Next Hop

Metric LocPrf Weight Path

Route Distinguisher: 200:110 (default for vrf VPN_A)


*> 10.1.2.2/32

10.1.12.2

*>i10.1.3.3/32

172.16.4.4

0 100

*> 10.1.12.0/24

0.0.0.0

*>i10.1.21.0/24

172.16.4.4

0 100 i
0 100 i

32768 ?
0 100

0?

Route Distinguisher: 200:120 (default for vrf VPN_B)


*> 10.1.4.4/32

10.1.13.3

*>i10.1.5.5/32

172.16.4.4

0 100

*> 10.1.13.0/24

0.0.0.0

*>i10.1.31.0/24

172.16.4.4

Ping vrf VPN_A

0 200 i
0 200 i

32768 ?
0 100

0?

Show ip bgp:

Running configuration for all the routers:


Configuration on 9R1
9R1#sh run
Building configuration...
Current configuration : 2293 bytes
!
version 15.0

service timestamps debug datetime msec


service timestamps log datetime msec
no service password-encryption
!
hostname 9R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
!
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
mpls traffic-eng tunnels
no mpls ip
!
!
!
!
voice-card 0
!
!
!
!
!
!
license udi pid C3900-SPE100/K9 sn FOC15074H97
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!

!
!
!
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255
!
!
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 172.16.4.4
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 6667
tunnel mpls traffic-eng path-option 1 explicit identifier 910
tunnel mpls traffic-eng path-option 2 dynamic
!
no routing dynamic
!
interface GigabitEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
ip address 192.168.14.1 255.255.255.0
duplex auto
speed auto
mpls traffic-eng tunnels
mpls ip
!
ip rsvp bandwidth 100000
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
no clock rate 2000000
!
!

interface Serial0/0/1
no ip address
shutdown
no clock rate 2000000
!
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 172.16.1.1
log-adjacency-changes
network 172.16.1.1 0.0.0.0 area 0
network 192.168.14.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp router-id 172.16.1.1
bgp log-neighbor-changes
neighbor 10.1.12.2 remote-as 10
neighbor 172.16.4.4 remote-as 1
neighbor 172.16.4.4 update-source Loopback0
neighbor 172.16.4.4 next-hop-self
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ip explicit-path identifier 910 enable
next-address 172.16.2.2
next-address 172.16.3.3
next-address 172.16.4.4
!
!
!
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1

!
voice-port 0/2/0
!
voice-port 0/2/1
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
Configuration on 9R2
9r2#sh run
Building configuration...
Current configuration : 1520 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 9r2
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!

!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0

!
interface Serial1/2
ip address 169.1.24.2 255.255.255.0
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp router-id 10.1.2.2
bgp log-neighbor-changes
network 10.1.2.2 mask 255.255.255.255
neighbor 10.1.12.1 remote-as 1
no auto-summary
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!

!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End

Configuration on 9R3
9R3#sh run
Building configuration...

Current configuration : 1304 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 9R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!

resource policy
!
no network-clock-participate slot 1
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!
!
!
!
interface Loopback0
ip address 10.1.4.4 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface FastEthernet1/0
no ip address
shutdown

duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.1.13.3 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial1/1/0
no ip address
shutdown
clock rate 2000000
!
router bgp 200
no synchronization
bgp router-id 10.1.4.4
bgp log-neighbor-changes
network 10.1.4.4 mask 255.255.255.255
neighbor 10.1.13.1 remote-as 1
no auto-summary

!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4

login
!
scheduler allocate 20000 1000
!
End
Configuration on 9R4
9R4(config)#do sh run
Building configuration...

Current configuration : 1593 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 9R4
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
!

resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!
!
!
!
!
mpls label protocol ldp
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!

!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.44.4 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
mpls ip
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto

!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 192.168.14.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial2/0/0
bandwidth 155000
no ip address
mpls traffic-eng tunnels
ip rsvp bandwidth 155000
!
interface Serial2/1/0
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 172.16.2.2

log-adjacency-changes
network 172.16.2.2 0.0.0.0 area 0
network 192.168.14.0 0.0.0.255 area 0
network 192.168.44.0 0.0.0.255 area 0
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
!

voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End

Configuration on 10R1
10R1#sh run

Building configuration...

Current configuration : 2648 bytes


!
! Last configuration change at 21:10:08 UTC Tue May 8 2012
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
!
!
!
!
!

no ipv6 cef
ip source-route
ip cef
!
!
ip vrf VPN_A
rd 200:110
route-target export 200:110
route-target import 200:110
!
ip vrf VPN_B
rd 200:120
route-target export 200:120
route-target import 200:120
!
ip vrf VPN_X
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
mpls label protocol ldp
!
!

!
!
voice-card 0
!
!
!
!
!
!
license udi pid C3900-SPE100/K9 sn FOC15032SEG
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
interface Loopback0

ip address 172.16.4.4 255.255.255.255


!
!
interface GigabitEthernet0/0
ip vrf forwarding VPN_A
ip address 10.1.21.1 255.255.255.0
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
ip vrf forwarding VPN_B
ip address 10.1.31.1 255.255.255.0
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
ip address 192.168.41.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
!
interface Serial0/0/0
no ip address

shutdown
no clock rate 2000000
!
!
interface Serial0/0/1
bandwidth 155000
ip address 192.168.141.1 255.255.255.0
shutdown
mpls traffic-eng tunnels
no clock rate 2000000
!
ip rsvp bandwidth 155000
!
!
router ospf 1
log-adjacency-changes
network 172.16.4.4 0.0.0.0 area 0
network 192.168.41.0 0.0.0.255 area 0
!
router bgp 1
bgp router-id 172.16.4.4
bgp log-neighbor-changes
neighbor 172.16.1.1 remote-as 1
neighbor 172.16.1.1 update-source Loopback0
!
address-family ipv4

no synchronization
neighbor 172.16.1.1 activate
neighbor 172.16.1.1 next-hop-self
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 172.16.1.1 activate
neighbor 172.16.1.1 send-community both
exit-address-family
!
address-family ipv4 vrf VPN_A
no synchronization
redistribute connected
neighbor 10.1.21.2 remote-as 100
neighbor 10.1.21.2 activate
neighbor 10.1.21.2 as-override
exit-address-family
!
address-family ipv4 vrf VPN_B
no synchronization
redistribute connected
neighbor 10.1.31.3 remote-as 200
neighbor 10.1.31.3 activate
neighbor 10.1.31.3 as-override
exit-address-family

!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1

!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Configuration on 10R2
10R2#sh run
Building configuration...
Current configuration : 1448 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R2
!

boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.3.3 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.1.21.2 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto

media-type rj45
negotiation auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp router-id 10.1.3.3
bgp log-neighbor-changes
network 10.1.3.3 mask 255.255.255.255
neighbor 10.1.21.1 remote-as 1
no auto-summary
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!

!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End
Configuration on 10R3
10R3#sh run
Building configuration...
Current configuration : 1261 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
ip subnet-zero
ip cef
!

!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.5.5 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.1.31.3 255.255.255.0

duplex auto
speed auto
!
interface Serial1/0/0
no ip address
shutdown
!
interface Serial1/1/0
ip address 192.168.141.2 255.255.255.0
clock rate 2000000
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 10.1.5.5 mask 255.255.255.255
neighbor 10.1.31.1 remote-as 1
no auto-summary
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
Configuration on 10R4

10R4(config)#do sh run
Building configuration...

Current configuration : 1593 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R4
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!

!
!
!
!
mpls label protocol ldp
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.44.14 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
mpls ip
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto

!
interface FastEthernet2/1
ip address 192.168.41.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial2/0/0
bandwidth 155000
no ip address
mpls traffic-eng tunnels
ip rsvp bandwidth 155000
!
interface Serial2/1/0
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 172.16.3.3
log-adjacency-changes
network 172.16.3.3 0.0.0.0 area 0
network 192.168.41.0 0.0.0.255 area 0
network 192.168.44.0 0.0.0.255 area 0
!
ip classless

!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!

!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End

Оценить