Вы находитесь на странице: 1из 41

##################>###

#################g###########i###########b###c###d###e###f###

#q`
########################bjbjqPqP##################

##C###:###:##k#############################################################
############2#######2###2#######2#################################################-######-########\####.##T############B###~0######~0######~0######~0######~0######1;######1;###
###1;############################################$###
##h###u##<######i##########################>#######################:######1;##
####>######>#####################2#######2#######~0##############~0##
########O######O######O######>##
###2###R###~0#############~0####################O##############################
########################>####################O######O##&############"#####
####################################################################~0######r0##

### 7o###############F#######d###########R#######0######################H#######
##################################################################################
########################<###1;#####;#####O######s<##l###<################
#####################1;######1;######1;##########################################
##########tO######################################1;######1;######1;############
>######>######>######>#################################~##D#############
##########~###########################2#######2#######2#######2#######2#######
2#############

###################################################################################
###################################################################################
###################################################################################
###################################################################################
###################################################################################
###################################################################################
###################################################################################
#####ALGORITMO #1ALGORITMO: PromedioDESCRIPCIN: Calcular la media (promedio) de 3
nmerosCONSTANTES: --------------------------------VARIABLES: Entero: N1, N2, N3
Real: PromINICIOLeer N1, N2, N3
Prom= (N1+ N2+ N3)/3Escribir PromFIN
ALGORITMO #2ALGORTMO: Promedio finalDESCRIPCCION: Elaborar un algoritmo para
calcular el promedio final de la materia de algoritmos. Dicha calificacin se
compone de los siguientes porcentajes.55% -----del promedio final de sus
calificaciones parciales (3)30% ----- de la calificacin de promedio15% ----- de la
calificacin de un trabajo final
CONSTANTE: ---------------------------------VARIABLE: Real: P1, P2, P3, Prom., Examen, TrabajoF, Prom. Final INICIO
Leer
P1, P2, P3Prom=(( P1+ P2+ P3 )/3)*0.55Leer ExamenLeer TrabajoFProm. Final= (Prom +
(Examen*0.30) + (TrabajoF *0.15) )Escribir Prom. FinalFINALGORITMO #3ALGORITMO:
SueldoDESCRIPCCION: Calcular el sueldo de un empleado dados como datos de entrada:
el nombre, hrs. De trabajo y el pago en hr.CONSTANTE: Real: Pagohr=50.30VARIABLE:
Cadena: nombre
Entero: hrs.
Real: SueldoINICIOLeer nombreLeer hrs.
Sueldo= Pagohr*hrsEscribir Sueldo, nombreFINALGORITMO #4ALGORITMO: Evaluacin
DESCRIPCCION: Elaborar un algoritmo que obtenga e imprima el valor de Y a partir de
la ecuacin.Y= 3*X2 + 7X - 15CONATANTE: ------------------VARIABLE: Real: X, Y
INICIOLeer XY= (3*X*X)+(7*x) -15Escribir YFINALGORITMO #5ALGORITMO: Sistema de
ecuacion#e#s##D#E#C#R#I#P#C#C#I#O#N#:# #E#l# #s#i#s#t#e#m#a# #d#e#
#e#c#u#a#c#i#o#n#e#s# #l#i#n#e#a#l#e#s#:##a#x# #+# # #b#y#=# #C##d#x# #+# #d#y#=#
#f##S#e# #p#u#e#d#e# #r#e#s#o#l#v#e#r# #c#o#n# #l#a#s# #f#o#r#m#u#l#a#s#:##X#=#
#c#e# ## #b#f## # # # # #a#e# ## #b#d##y#=# #a#f# ## #c#d## # # # #a#e# ##
#b#d##S#i# #a#e# ## #b#d# #`" #0##E#l#a#b#o#r#e# #u#n# #a#l#g#o#r#i#t#m#o# #q#u#e#
#l#e#a# #l#o#s# #c#o#e#f#i#c#i#e#n#t#e#s# #a#,# #b#,# #c#.# #e#,# #f#,# # #y#
#c#a#l#c#u#l#e# #l#o#s# #v#a#l#o#r#e#s# de x,, y.CONSTANTE:
------------------------VARIABLE: Real: a, b, c. d, e, f, x, yINICIOLeer a, b, c,
d, e, fx=(c*e) (b*f) /(a*e) (b*d)y=(a*f) (c*d) / (a*e) (b*d)Escribir x, y
FINALGORITMO #6 ALGORITMO: Valor absolutoDESCRIPCCION: Calcular el valor absoluto de
un numero
###################################################################################
###################################################################################
#####################################################% #x# ##% # # # # # # # # # #
# #x# # #S#i# #x#>#0## # # # # # # # # # # # # # # # # # # # #-#x# #S#i# #x# #<#o#
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
# # # # # # # # # # # # # # # #### ##C#O#N#S#T#A#N#T#E#S#:# #-#-#-#-#-#-#-#-#-#-##-#-#-#-#-#-#-#-#-#-#-##V#A#R#I#A#B#L#E#S#:# #E#n#t#e#r#o#:# #x###I#N#I#C#I#O#
#L#e#e#r# #x##S#i# #(#x#<#0#)# #e#n#t#o#n#c#e#s##X#=# #x#*#(#-#1#)##F#i#n#_#s#i#
#E#s#c#r#i#b#i#r# #x##F#I#N#####A#L#G#O#R#I#T#M#O# ###7#ALGORITMO: Par o impar
DESCRIPPCION: Elabora un algoritmo para leer un numero y determinar si es par o
impar.CONSTANTE: ---------------------------VARIABLE: Entero: NINICIOLeer NSi (N
%2=0) entoncesEscribir N en parSi no Escribir N es imparFin _ sFINALGORITMO #8
ALGORITMO: NmerosDESCRIPCCION: Elaborar un algoritmo para leer 3 nmeros y
determinar s uno es la suma de los otros dos.CONSTANTES:
-----------------------------VARIABLES: entero: N1, N2, N3INICIOLeer N1, N2, N3S
(N1=N2 + N3) entoncesEscribir N1 es la suma de N2 + N3S no s (N2=N1 + N3)
entoncesEscribir N2 es la suma de N1 + N3S ni s (N3= N1 + N2) entoncesEscribir
N3 es la suma de N1 + N2) S no Escribir Ningn es la suma de los otros dosFin _
sFin _ sFin _ sFINALGORITMO #9ALGORITMO: Mltiplo de 3DESCRIPCCION: Solicitar un
entero y determinar s es mltiplo de 3 y adems
que se encuentre en el rango
(100-200).CONSTANTE: -------------------VARIABLE: Entero: NINICIOLeer NS (N>=100 y
N<=200) entoncesS (N%3=0) entoncesEscribir N es mltiplo de 3 y esta dentro del
rangoS no Escribir N no es mltiplo de 3 pero esta dentro del rangoFin _sS

no Escribir N no esta en el rangoFin _s


FINALGORITMO #10ALGORITMO: Signo
zodiacalDESCRIPCCION: Elaborar un algoritmo para leer la fecha de nacimiento de una
persona y muestre su signo zodiacal.CONTANTES: ------------------VARIABLES: Cadena:
x
Entero: wINICIO Leer x, yS (x= marzo y w>= 21) y (x= abril y w<=20)
entoncesEscribir Eres AriesFin _ sS no s (x= abril y w>= 21) y (x= mayo y
w<= 20) entoncesEscribir Eres TauroFin _ sS no s (x= mayo y w>= 21) y (x=
junio y w<= 20) entoncesEscribir Eres GminisFin _ sS no s (x= junio y w>=
21) y (x= julio y w<= 20) entoncesEscribir Eres Cncer Fin _ sS no s (x=
julio y w>= 21) y (x= agosto y w<= 20) entoncesEscribir Eres LeoFin _ sS no
s (x= agosto y w>= 21) y (x= septiembre y w<= 20) entonces Escribir Eres
VirgoFin _ sS no s (x= septiembre y w>= 21) y (x= octubre y w<= 20) entonces
Escribir Eres LibraFin _ sS no s (x= octubre y w>= 21) y (x= noviembre y
w<= 20) entoncesEscribir Eres EscorpinFin _ sS no s (x= noviembre y w>= 21)
y (x= diciembre y w<= 20) entoncesEscribir Eres SagitarioFin _ sS no s (x=
diciembre y w>= 21) y (x= enero y w<= 20) entoncesEscribir Eres Capricornio
Fin _ sS no s (x= enero y w>= 21) y (x= febrero y w<= 20) entoncesEscribir
Eres AcuarioFin _ sS no s (x= febrero y w>= 21) y (x= marzo y w<= 20)
entoncesEscribir Eres PicisFin _ sS no Escribir Fecha no reconocidaFin _sFIN
ALGORITMO #11ALGORITMO: Aumento _ sueldoDESCRIPCCION: Construir un algoritmo que
lea la categora y el sueldo de un trabajador, calcule el aumento correspondiente
teniendo en cuenta la siguiente tabla:#
Categora#Nmeros##
1#15%##2#10%##3#8%##4#7%##CONSTANTE: ---------------------------------VARIABLE:
Real: Sueldo, Aumento
Entero: catgINICIOLeer catgS (catg=1) entonces
Aumento= (sueldo*0.15)Fin _sS no s (catg==2) entoncesAumento= (sueldo*0.10)Fin
_sS no s (catg==3) entoncesAumento= (sueldo*0.08)Fin _sS no s (catg==4)
entoncesAumento= (sueldo *.007)Fin _sS no Escribir Fuera de categoraFin _sFIN
ALGORITMO #12ALGORITMO: Aumento _ sueldoDESCRIPCCION: Construir un algoritmo que
lea la categora y el sueldo de un trabajador, calcule el aumento correspondiente
teniendo en cuenta la siguiente tabla:#
Categora#Nmeros##
1#15%##2#10%##3#8%##4#7%##CONSTANTE: ---------------------------------VARIABLE:
Real: Sueldo, Aumento
Entero: catgINICIOLeer catgSegn (catg) sea1:
Aumento= sueldo*0.152 : Aumento= sueldo*0.103: Aumento= sueldo*0.084: Aumento=
sueldo*0.07S no Escribir Categora no reconocidaAumento= 0Fin _segnEscribir
AumentoFINALGORITMO #13ALGORITMO: Pago _ finalDESCRIPCCION: En una librera se
venden artculos con las siguientes condiciones:S el cliente es de tipo 1 se le
descuenta 30%S el cliente es de tipo 2 se le descuenta 20%S el cliente es de tipo
3 se le descuenta 10%Escribir un algoritmo que lea el nombre del cliente, tipo de
cliente, precio. Calcule el pago final.CONSTANTE: -----------------------------VARIABLE: Cadena: nombre
Real: precio, descuento, pagof
Entero: tipo
INICIO
Leer nombre, tipo, precioSegn (tipo) sea1: descuento= (precio*0.3)Pagof=
(precio descuento)2: descuento= (precio*0,2)Pagof= (precio descuento)3:
descuento= (precio*0.1)Pagof= (precio descuento)S no Escribir Tipo de cliente
no reconocido descuento=0Fin _sEscribir Total a pagar: pagofFINALGORITMO #14
ALGORITMO: FigurasDESCRIPCION: elaborar un algoritmo para leer un men la opcin
para dibujar las siguientes figuras geomtricas:MENU1.- Triangulo2.- Cuadrado3.Circulo4.- Rectngulo5.- SalirCONSTANTE: ------------------------------VARIANLE:
Entero: opcin INICIOLeer opcinSegn (opcin) sea1: Escribir *Escribir*
*2: Escribir *
*Escribir
*
*3: Escribir O4: Escribir * * *
Escribir * * *5: Salir ( )S no Escribir Opcin no validaFin _segnFIN
ALGORITMO #15CONSIDERE LA SIGUIENTE SENTENCIA:Segn (i) sea1: 2: 3Escribir S5: 6 :
7Escribir No10: 11Escribir Tal vezS no Escribir Algunas vecesFin _segnCul
es la salida del cdigo anterior s i=4?R= En este caso tenemos i=4, como
observamos no esta dentro del rango de las opciones y por de faul va a escribir
Algunas veces; ya que si no corresponde el valor de i a una opcin sealada
escribir lo que corresponde a la opcin S no.ALGORITMO #16 CONVIERTA EL
SIGUIENTE CODIGO A ESRUCTURA CONDICIONAL REPETITIVA.Entero: N, K, iS (i==3)
entoncesN= 1K=5S no s (i==4) entoncesN=5S no s (i==6 ) entoncesN=6 S noN==0
ESTRUCTURA CONDICIONAL REPETITIVASegn (i) sea3: N==1
K==54: N==56 : N==6 S no
N==0Fin _segnALGORITMO #17ALGORITMO: OperacinDASCRIPCCION: Solicitar la

introduccin de 2 nmeros reales y una operacin (+, -, *, /), y mostrar por


pantalla el resultado de la operacin introducida.CONSTANTE:
-------------------------------------------------VARIABLE:
Entero: opcin
Real: x, y, zINICIOLeer opcin, x, y, zSegn (opcin) sea1:
(z= x + y)2: (z= x y)3: (z= x * y)
4: (z= x / Y)S no Escribir No se
puede hacer otra operacin
z=0Fin _segnEscribir El resultado de tu operacin
es: zFINALGORITMO #18ALGORITMO: ConteoDESCRIPCCION: Desarrollar un algoritmo que
imprima los nmeros impar en orden descendiente que hay entre 1y 100.CONSTANTE:
---------------------------------VARIABLE: entero: iINICIOPara i= 100 hasta i= 1,
i= i-1S (i%2!= 0) entoncesEscribir iFin sFin paraFINALGORITMO #19.AALGORITMO:
Suma _ CuadradoDESCRIPCCION: Calcular la suma de los cuadrados de los nmeros entre
el 1 y 100.CONSTANTE: ---------------------------VARIABLE: Entero: i, suma=0INICIO
Para i=1 hasta i= 100 hacerSuma= suma + (i*i)Fin paraEscribir sumaFINALGORITMO
#19.BALGORITMO: Suma _ cuadradoDECRIPCCION:
Calcular la suma de los cuadrados
de los nmeros entre el 1 y 100.CONSTANTE: -------------------------------VARIABLE: Entero: i, suma= 0INICIOi= 1Mientras (i<= 100)Suma= suma + (i*i)i= i + 1
Fin _mientrasEscribir sumaFINALGORITMO #19.CALGORITMO: Suma _ cuadradoDECRIPCCION:
Calcular la suma de los cuadrados de los nmeros entre el 1 y 100.CONSTANTE:
--------------------------------VARIABLE: Entero: i, suma= 0INICIOi= 1Hacer Suma=
suma + (i*i)i= i + 1Mientras (i<= 100)Escribir sumaFINALGORITMO #20.AALGORITMO:
Mayor _MenorDESCRIPCCION: Algoritmo para leer 25 nmeros, obtener su promedio, el
mayor y menor de esos nmeros. CONSTANTE: ---------------------------VARIABLE:
Entero: mayor, menor, num, i
Real: promINICIOLeer numMayor= numMenor= num
Prom= numPara i=2 hasta i= 25 hacerLeer numS (num<= menor)Menor= numS (num>=
mayor)Mayor= numFin _sFin _sFin _paraEscribir El promedio :, prom/25Escribir
El numero menor es:, menorEscribir El numero mayor es, mayorFINALGORITMO #20.B
ALGORITMO: Mayor _MenorDESCRIPCCION: Algoritmo para leer 25 nmeros, obtener su
promedio, el mayor y menor de esos nmeros. CONSTANTE: --------------------------VARIABLE: Entero: mayor, menor, num, i
Real: promINICIOLeer numMayor= num
Menor= numProm= numPara i=2 hasta i= 25 hacerLeer numMientras i= 2 hasta i= 25
hacer Prom= prom + numS (num<= menor)Menor= numFin _sS (num>= mayor)Mayor= num
Fin _sFin _mientrasEscribir El promedio :, prom/25Escribir El numero menor
es:, menorEscribir El numero mayor es, mayorFINALGORITMO #20.CALGORITMO: Mayor
_MenorDESCRIPCCION: Algoritmo para leer 25 nmeros, obtener su promedio, el mayor
y menor de esos nmeros. CONSTANTE: ---------------------------VARIABLE: Entero:
mayor, menor, num, i
Real: promINICIOLeer numMayor= numMenor= numProm=
numLeer numHacer prom= prom + numS (num<= menor)Menor= numFin _sS (num>= mayor)
Mayor= numFin _si= i + 1Mientras (i<= 25)Escribir El promedio :, prom/25Escribir
El numero menor es:, menorEscribir El numero mayor es, mayorFINALGORITMO #21
ALGORITMO: Tabla de multiplicarDESCRIPCCION: Escribir un algoritmo que solicite un
numero (1-10) y muestre la tabla de dicho nmero.CONSTANTE:
-------------------------VARIABLE: Entero: i, num.INICIOS (num>= 1 y num<=10)Para
i= 1 hasta i= 10 hacerNum= num *iEscribir num, *, i, = , num*iFin _sFin
_paraFINALGORITMO #22ALGORITMO: PuntuacinDESCRIPCCION: Cuatro enteros entre 0 y
100 representan las puntuaciones de un estudiante de informtica. Escribir un
programa para encontrar la media de estas puntuaciones y visualizar una tablado
notas de acuerdo al siguiente cuadro:MEDIA#PUNTUACION##90-100#A##80-89#B##7079#C##6 0-6 9#D##0-59#E##CONSTANTE: ---------------------------VARIABLE: Entero: N1,
N2, N3, N4
Real: promINICIOLeer N1, N2, N3, N4S (N1>= 0 y N1<=100) y
(N2>= 0 y N2<=100) y (N3>= 0 y N3<=100) y (N4>= 0 y N4<=100) entonces
prom=
( N1+ N2+ N3+ N4)/4
S no Escribir Algn N esta fuera de rangoFin _sS
(prom>= 0 y prom<= 59) entoncesEscribir Tu puntuacin es EFin _sS no s (prom>=
6 0 y prom<= 6 9) entoncesEscribir Tu puntuacin es dFin _sS no s (prom>= 70 y
prom<= 79) entoncesEscribir Tu puntuacin es CFin _sS no s (prom>= 80 y prom<=
89) entoncesEscribir Tu puntuacin es BFin _sS no s (prom>= 90 y prom<= 100)
entoncesEscribir Tu puntuacin es AFin _sFINALGORITMO #24ALOGORITMO: Ao
bisiestoDASCRIPCCION: Escribir un programa que determine si un ao es bisiesto. Un
ao es bisiesto si es mltiplo de 4 (por ejemplo 1984). Sin embargo los aos
mltiplos de 100 solo son bisiestos si a la vez son mltiplos de 400 (por ejemplo

1800 no es no es bisiesto, mientras que 2000 silo ser). CONSTANTE:


--------------------------VARIABLE: Entero: aoINICIOLeer aoS /ao%100!= 0)
entoncesS (ao%4= 0) entoncesEscribir Ao BisiestoS no Escribir El ao no es
BisiestoFin sS no s (ao%400= 0) entoncesEscribir Ao BisiestoS no El ao
no es BisiestoFin sFin _sFINALGORITMO #25ALGORITMO: CalculadorDESCRIPCCION:
Escribir y ejecutar un programa que simule un calculador simple. Lee dos nmeros y
un carcter. Si el carcter es +, se imprime la suma; si el carcter es un -, se
imprime la diferencia; si el carcter es un *, se imprime el producto; si el
carcter es un /, se imprime el cociente; y si es una %, se imprime el residuo.
CONSTANTE: --------------------------------VARIABLE: Entero: Opcin, a, b
Real: rINICIOLeer opcin, a, bSegn (opcin) sea1: (r= a+b) 2: (r= a-b)3: (r= a*b)4:
(r= a/b)5: (r= a%b)Escribir rSi no Escribir No se puede hacer otra operacin r=0
Fin _segnFINALGORITMO #26 ALGORITMO: Numero _ mayorDESCRIPCCION: Elaborar un
programa que determine el mayor de tres nmeros.CONSTANTE:
-------------------------VARIABLE:
Real: a, b, cINICIOLeer a, b, cS (a<b y a>b)
entoncesEscribir El nmero mayor es: aFin _sS no s (b<a y b>c) entonces
Escribir El nmero mayor es: bFin _sSi no s (c<a y c>b) entoncesEscribir El
nmero mayor es: cFin _sS no Escribir No se puede determinar cual es el nmero
mayorFin _sFINALGORTIMO #27ALGORITMO: CalificacinDESCRIPCCION: Codificar un
programa que escriba la calificacin correspondiente a una nota, de acuerdo con el
siguiente criterio:0 a <5.0#Suspenso##5 a < 6 .5#Aprobado##6 .5 a < 8.5#Notable##8.5
a < 10#Sobresaliente##10#Matricula de h#o#n#o#r######C#O#N#S#T#A#N#T#E#:# #-#-#-##-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-##V#A#R#I#A#B#L#E#:#
#R#e#a#l#:# #C#a#l#f###I#N#I#C#I#O##L#e#e#r# #c#a#l#f##S#i# ##c#a#l#f#<# 0# #y#
#c#a#l#f#># #5#.#0#?# #e#n#t#o#n#c#e#s##E#s#c#r#i#b#i#r# ## S#u#s#p#e#n#s#o##
#S#i# ##C#a#l#f#># 5# #y# #C#a#l#f#># #6 #.#5#?# #e#n#t#o#n#c#e#s#
#E#s#c#r#i#b#i#r# ## A#p#r#o#b#a#d#o## #A#L#G#O#R#I#T#M#O# ###2#8##
#A#L#G#O#R#I#T#M#O#:# #P#o#t#e#n#c#i#a##D#E#S#R#I#P#C#C#I#O#N#:# #E#l#a#b#o#re un
algoritmo para elevar un nmero x a una potencia n.CONSTANTE:
-------------------------------------VARIABLE: Entero: x,, n, i, p=1INICIOLeer n,
x, p=1Para i= 1 hasta i= np= x*pFin _paraEscribir pFINALGORITMO #29ALGORITMO:
MuestreoDESCRIPCCION: Una persona debe realizar un muestre con 50 personas para
determinar el promedio de peso de los nios, jvenes, adultos y viejos que existen
en una zona habitacional. Se determino las categoras con base en la siguiente
tabla:CATEGORIA#EDAD##Nios#0-12##Jvenes#13-29##Adultos#30-59##Viejos#6 0 en
adelante##CONSTANTE: ------------------------------------VARIABLE: Entero: edad, i,
S= 0, PromN= 0, k= 0, PromJ= 0, T= 0, PromA= 0, w= 0, PromV= 0
Real: pesoINICIOLeer edad, pesoPara i= 0 hasta i= 50 hacerS (edad>= 0 y edad<= 12)
entoncesS= S + 1PromN= PromN + pesoS no s (edad>= 13 y edad<= 29) entoncesK= K +
1PromJ= PromJ + pesoS no s (edad>= 30 y edad<= 59) entoncesT= T + 1PromA= PromA +
pesoS no s (edad>= 6 0 y edad<= 100) entoncesW= W + 1 PromV= PromV + pesoFin _s
Fin _sFin _sFin _sFin _sFin _paraEscribir El promedio de los nios es
PromN./50Escribir El promedio de los jvenes es PromJ./50Escribir El promedio de
los adultos es PromA./50Escribir El promedio de los viejos es PromV./50FIN
ALGORITMO #30ALGORITMO: Numero_parDESCRIPCCION: Implementar un programa que sume
todos los nmeros pares entre 2 y n. El valor de n se medir al principio.
CONSTANTE: ----------------------------------VARIABLE: Entero: i, n, suma=0 INICIO
Leer nPara i= 2 hasta i= n hacerS (i%2= 0) entoncessuma = suma + 1Fin _sFin _para
Escribir La suma es sumaFINALGORITMO #31ALGORITMO: AdivinarDESCRIPCCION: Escribir
un algoritmo que juegue a adivinar un nmero del siguiente modo: la mquina piensa
un nmero entre 1 y 100 el usuario debe averiguar dicho nmero. Para elle cada vez
que el usuario sugiera un nmero el ordenador debe contestar con demasiado grande,
demasiado pequeo o correcto (g/p/c). Se debe implementar un algoritmo eficiente
que el nmero menor en el menor de intentos posibles.CONSTANTE:
---------------------------------------VARIABLE: Entero: n, x, dINICIOLeer nx=
aleatorio ( )%100 +1Mientras (x-n!= 0) hacerS (abs(x-n)>10) entoncesEscribir
Diferencia superior a 10Fin _sS no s (abs(x-n<=10) entoncesEscribir
Diferencia menor a 10Fin _sS no s (x-n= 0) entoncesEscribir Nmero adivinado
Fin _sFin _paraFINALGORITMO #32ALGORITMO: Valores de yDESCRIPCCION: Desarrollar un

algoritmo que lea como dato el valor de n y calcule los valores de la ecuacin y=
3x2-25, para x inicial x= 2.8 e incremento de 0.01. El proceso debe repetirse hasta
que y<= 0 o s no se cumple esta condicin, hasta que hallan calculado n valores de
y.CONSTANTE: ----------------------VARIABLE: Entero: i,n
Real: x= 2.8,
y INICIOLeer nMientras (y<0 o i>n) hacerY= 3(x*x) -25x= x + 0.01i= i+1Fin
_mientrasEscribir yFINALGORITMO #33ALGORITMO: Verificacin 2007DESCRIPCCION: En un
centro de verificacin de automviles se desea saber el promedio de puntos
contaminantes de los primeros 25 automviles que lleguen. As mismo se desea saber
los puntos contaminantes del carro que menos contamina y del que ms contamina.
CONSTANTE: -------------------------------------------VARIABLE: Entero: i, mayor,
menor, p, m
Real: promINICIOLeer pmayor= pmenor= pprom= pPara (i=2 hasta i=
25) hacerLeer pprom= prom+pS p<= menorMenor= pFin _sS p>= mayormayor= pFin _s
Fin _paraEscribir El promedio es prom/25
El carro que menos
contamina es menor
El carro que mas contamina es mayorFIN
ALGORITMO #34ALGORITMO: ZoolgicoDESCRIPCCION: Un zologo pretende determinar el
porcentaje de animales que hay en las siguientes categoras de edades: De 0 a 1
ao, de mas de 1 ao y menos de 3 aos, y de 3 o mas aos. El zoolgico todava no
esta seguro del animal que va a estudiar. S se decide por elefantes solo tomara
una muestra de 20 de ellos; s se decide por jirafas, tomara 15 muestras y s son
chimpancs timara 40.CONSTANTE: ----------------------------------------------VARIABLE: INICIOLeer AS (A= E) entoncesn= 20Fin_ sS no s (A=J) entoncesn=
15Fin_ sS no s (A=C)n=40Fin_ sS noEscribir Animal no reconocidoFin_ sPara
i=1 hasta i=n hacerLeer edadS (edad>=0 y edad<= 1) entoncesk= k+1Fin_ sS no s
(edad>1 y edad <3) entoncesl= l+1Fin_ sS no s (edad>=3) entoncesp= p+1Fin_ s
Escribir k*100/n
l*100/n
p*100/nFINALGORITMO #35
ALGORITMO: RelojDESCRIPCCION: Simular el comportamiento de un reloj digital,
imprimiendo la hora, minutos y segundos de un da desde las 00:00:00 horas hasta
las 23:59:59 horasCONSTANTE: -------------------------------------------VARIABLE:
Entero: h, m, sINICIOPara h= 0 hasta h= 23 hacerPara m= 0 hasta m= 6 0 hacerPara s=
0 hasta s= 6 0 hacerEscribir La hora es h, :, m, :, sFin _paraFin _paraFin
_paraFINALGORITMO #36 ALGORITMO: NeumticosDESCRIPCCION: La presin, volumen y
temperatura de una mas de aire se relaciona por la formula:masa= presin*volumen
0.37*(temperatura +46 0)CONSTANTE:
--------------------------------------------------------VARIABLE: Entero: n, i
Real: p, v, t, masa= 0INICIOLeer nPara i= 1 hasta i= n hacerLeer tipo, v, p, tS
tipo= motocicleta entonces
masa1= [masa1 + p*v/(0.37*(t +46 0))] *2
S no s (tipo= automvil) entonces
masa2= [masa2 + p*v/(0.37*(t
+46 0))] *4Fin sFin _sFin _paraEscribir El promedio de los vehculos es: masa1
+ masa2/6 FINALGORITMO #37ALGORITMO: Cmara de DiputadosDESCRIPCCION: En una Cmara
de Diputados se levanto una encuesta con todos los integrantes con el fin de
determinar con porcentaje de los n diputados estn a favor del Tratado del Libre
Comercio, que porcentaje esta en contra y que porcentaje se abstiene.CONSTANTE:
-----------------------------------------------VARIABLE: Entero: n, i, F, C, A
Cadena: respuestaINICIOLeer nPara i= 1 hasta i=n hacerLeer respuestaS (respuesta=
a favor) entoncesF= F+1S no s (respuesta= en contra) entoncesC= C+1S no A=
A+1Fin _sFin _sFin _sFin _paraEscribir A favor F*100/n
En
contra C*100/n
Se abstienen A*100/nFINALGORITMO #38ALGORITMO:
SeccionesDESCRIPCCIO: Un jefe de casilla desea determinar cuantas personas de cada
una de las secciones que componen su zona asisten al da de las votaciones. Las
secciones son: norte, sur, centro. Tambin desea determinar cual es la seccin con
mayor nmero de votantes.CONSTANTE: ------------------------VARIABLE: Cadena=
seccin, nom
Entero: i, N= 0 S= 0, A= 0, mayor
INICIOMientras (i!= 0)
hacerLeer seccinS (seccin= Norte) entoncesN= N +1
S no s (seccin=
Sur) entoncesS= S +1S (seccin= Centro) entoncesC= C +1S no Escribir Seccin
no reconocidai= i +1Fin _sFin _sFin _sS (N>S y N>C) entoncesmayor= N y nom=
NorteS no s (S>N y S>C) entoncesmayor= S y nom= Sur
S no s (C>S y
C>N) entonces
mayor= C y nom= CentroFin _sFin _sFin _sEscribir S
terminaste de contar oprime 0Leer iFin _mientrasEscribir Seccin norte NSeccin
sur SSeccin centro CSeccin con mayor numero de votos nomFINALGORITMO #39

ALGORITMO: ReprobadosDESCRICCION: Leer 50 calificaciones de un grupo de alumnos.


Calcule y escriba el porcentaje de reprobados. Tomando en cuenta que la calificaron
mnima aprobatoria es de 70CONSTANTE: --------------------------------------VARIABLE: Entero: i
Real: calf, p= 0INICIOPara i= 1 hasta i= 50 hacerLeer
calfS (calf<7.0 y cal>0) entoncesP= p +1S no s Escribir No esta reprobadoFin
_sFin _paraEscribir Porcentaje de reprobados p*100/50FINALGORITMO #40ALGORITMO:
DESCRIPCCION: Leer 250 000 votos otorgados a los 3 candidatos a gobernador e
imprimir el numero del candidato y su cantidad de votos.CONSTANTE:
----------------------------------------VARIABLE: Entero: i, k= 0, l= 0, m= 0INICIO
Leer vMientras (i= 1 hasta i<= 250000) hacerS (v=1) entoncesK= k +1S no s (v=2)
entoncesl= l +1S no s (v=3) entoncesm= m +1i= i +1Fin _sFin _sFin _sFin
_mientrasEscribir Numero de votos del 1 candidato kNumero de votos del 2
candidato lNumero de votos del 3 candidato mFINALGORITMO #41ALGORITMO: Tienda
DESCRIPCCION: Suponga que tiene un tienda y desea registrar sus ventas por medio
de una computadora. Disee un pseudocdigo y programa que lea por cada cliente:El
monto de la ventaCalcule e imprima el IVACalcule e imprima el total a pagarLea la
cantidad con que paga el clienteCalcule e imprima el cambioAl final del da deber
imprimir la cantidad de dinero que debe haber en la caja.CONSTANTE:
------------------------------------------VARIABLE:INICIOMientras (i!= 0) hacerLeer
mI= M* 0.15Escribir El IVA es: IT= M +IEscribir el total a pagar es: TLeer DC=
D-Ti Escribir Su cambio es: CK= K +1i= i +1Escribir S desea terminar oprima 0
Leer iFin _mientrasEscribir Total en la caja kFINALGORITMO #42ALGORITMO: Angulo
DESCRIPCCION: Disee un pseudocdigo y el programa que lea el valor de un ngulo
expresado en radianes y calcule e imprima el valor del seno de dicho ngulo. Se
leer tambin el nmero de trminos de la serie.SEN(X)= X-(X3/3!) + (X5/5!)
(X7/7!) +CONSTANTE: pi= 3.1416 VARIABLE: Entero: Angulo, Z=0, F=1, P= 0, H= 0
Real: yINICIOLeer AnguloY= (pi* Angulo)/180Leer NPara n=1 hasta i= N hacerZ= Z+
pow((-1), n+1) * pow((y), 2*n-1))H= H + 2*n-1Para j= 1 hasta j= H hacerF= F*jFin
_paraP= P + Z/FFin _paraEscribir El valor del seno es pFINALGORITMO # 43
ALGORITMO: Mltiplo de 6 DESCRIPCCION: Lea un vector de N elementos y luego imprima
cuantos y cuales elementos son mltiplos de 6 .CONSTANTE:
--------------------------------VARIABLE: Entero: A[100], i, N, contador= 0INICIO
Leer NPara i=0 hasta i= N-1 hacerLeer A[i]Fin _paraPara i= 0 hasta i= N-1 hacerS
(A[i]%6 ==m 0) hacerContador= contador + 1Escribir A[i]Fin _sFin _paraEscribir El
numero de mltiplos de 6 es contadorFINALGORITMO # 44ALGORITMO: Vector mayor
DESCRIPCCION: Llenar un vector de 20 elementos, que imprima la posicin y el valor
del elemento mayor almacenado en el vector. Suponga a los elementos son
diferentes.CONSTANTE: ----------------------------------------VARIABLE: Entero: i
mayor= 0, A[20]INICIOPara i= 0 hasta i= 20-1 hacerLeer A[i]S (A[i]> mayor)
entoncesmayor = A[i]posc= iFin _sFin _paraEscribir El valor del elemento mayor
es: mayor Su posicin es: poscFINALGORITMO # 45ALGORITMO: Dos vectores
DESCRIPCCION: Llenar dos vectores A y B de 45 elementos cada uno, sumar el elemento
uno del vector A con el elemento del vector B y as sucesivamente hasta 45,
almacenar el resultado en un vector C, e imprimir el vector resultante.CONSTANTE:
---------------------------------VARIABLE: Entero: A[45], B[45], C[45]INICIOPara i=
0 hasta i= 45-1 hacerLeer A[i]Leer B[i]F############################

############################### ###!###
%###2###5##############################################
###

###

###

##s~o_o_o_o_o_o_o_o_o_###h[+)##h##CJ##H*#OJ##QJ##aJ####h[+)##h##CJ
##OJ##QJ##aJ#####h#####h[+)##h##CJ$#OJ##QJ##aJ$##
%#j#####ht##ht#CJ$#OJ##QJ##U##aJ$###h[+)##hg#CJ$#OJ##QJ##aJ$####j#####hg#U#
#mH##nH##u#####hK(##hg#CJ$#OJ##QJ##aJ$####hg#CJ$#OJ##QJ##aJ$##*#j#####h4#CJ$
#OJ##QJ##U##aJ$#mH##nH##u#####j#####h4#U##mH##nH##u##%########################
###
##########################################################################
###"#########################################################################
############################################################################
#############################################################################
#############################################################################
##################################$#a$#gd######gdg######$#a$#gdg##########
################################################################################
###################################################################################
###################################################################################
###################################################################################
###################################################################################
###################################################################################
######"#######$###%###2###3###4###5###I#####################
###
##
####.
##G
##
##%
##N
##
############################################################################
#############################################################################
#############################################################################
##############################################################################
#################x-#gd#####
&##F##gd######gd######gdg######$#a$#gd##### ###
###
##
####.
##~
##
##
##
##
##
##
##
##
##
##
##
##
##
##
##
######################
###########################B###C###U###V###c###x###############

## }############################hu##h#
#5#CJ$#OJ##QJ##aJ$###hd#5#CJ$#OJ##QJ##aJ$###h#

##h##CJ##H*#OJ##QJ##aJ####h#

##h##CJ##OJ##QJ##aJ#####h##CJ##OJ##QJ##aJ#####h##CJ$#OJ##QJ##aJ$####h#X###h#
#CJ##H*#OJ##QJ##aJ####h[+)##h##CJ##H*#OJ##QJ##aJ####h[+)##h##CJ##OJ##QJ##aJ##,

##
##
##
##
##
###'###3###A###y#####################,

##J

##

##

##

##

############################################################################
#############################################################################
#############################################################################
###########################

##
&##F#####,#gd#######$####,#a$#gd#########,#gd#####
&##F##gd#########X/#gd##########)#gd######gd#########%#gd####

##

##

##

##

##

##

##

##]##o##################
############################################################################
#############################################################################
##############################################################################
##############$####,##h#^h#a$#gd######$#
&##F#####,#a$#gd#######$####,#a$#gd#########,#gd#######$#
###,#a$#gd###

#####,##h#^h#gd##

##
&##F#####,#gd####

##

##

##

##c##e##n##o####
##h################"###R###T#############&################

~se]
Q###################################hd#CJ$#OJ##QJ##aJ$####h##CJ##aJ#####j#####h
##U##mH##nH##u#####hy>##h##CJ##aJ#####h##CJ##OJ##QJ##^J##aJ#####h#+b##h##>
*#CJ##OJ##QJ##aJ####hoX##h##CJ##OJ##QJ##aJ###"#hz"##h##>*#CJ##H*#OJ##QJ##aJ##
###hz"##h##CJ##OJ##QJ##aJ#####h##CJ##H*#OJ##QJ##aJ####h##CJ##OJ##QJ##aJ#####
h##CJ$#OJ##QJ##aJ$####hu##h##CJ$#OJ##QJ##aJ$####
######h###################$###<###Z#######/###V###W###^###t###############
############################################################################
#############################################################################
#############################################################################
##################################################$####,#a$#gd######
###,#gd##

##
&##F#####,#gd###

#####,##h#^h#gd#######$####,##h#^h#a$#gd#################$###
%###&###6 ###############6 ###`###b###p###~###############################
#############################################################################
#############################################################################
############################################################################
###########################################

#####,##h#^h#gd##

##
&##F#####,#gd######gd###########gd##
#####,/##gd######
###,#gd############################p###############################
############,################################################################
############################################################################
#############################################################################
############################################################################gd#
######$#a$#gd###

#####,##h#^h#gd##

##
&##F#####,#gd#########,#gd#######$#
###,#a$#gd########################################################
##################################*###+###/###0###=###>###@###A###E###F###\###
]###m###n###r###s#############################################
###################hd#CJ$#OJ##QJ##aJ$####h>##h
##CJ##OJ##QJ##aJ#####h##CJ##H*#OJ##QJ##aJ####hu##h##CJ$#OJ##QJ##aJ$####h#
#CJ##OJ##QJ##aJ###$#ht##h##CJ##OJ##QJ##aJ##mH##sH###$#ht##h##CJ$#OJ##QJ##aJ
$#mH##sH##;######################2###Q###u###################
###
###############5###########################################################
############################################################################
#############################################################################
#############################################################################
############################gd#######$#a$#gd#######$##h#^h#a$#gd######$#
&##F##a$#gd#######$#a$#gd#####################U######################
########o##############################################################
#############################################################################
############################################################################
###############################################################################
########$#
&##F
#a$#gd#######$#a$#gd#######$#a$#gd###

########h#^h#gd#######h#^h#gd#####
&##F #gd######gd################d###e###i###{###|
########################*!##7!##8!##9!##!##!##!
###"###"###"###"###"###"###"##$"##)"##n###{###|
###}###&##&##&##&##(##(##(##(##N)##})##
x###########
%#h###h##B*#CJ##OJ##QJ##aJ##ph3f###h###h##CJ$#OJ##QJ##aJ$####h<###h##CJ
$#OJ##QJ##aJ$####h##CJ$#OJ##QJ##aJ$####hX{##h##CJ$#OJ##QJ##aJ$####h8###h##O
J##QJ###*#j#####h##CJ##OJ##QJ##U##aJ##mH##nH##u#####h##CJ##OJ##QJ##aJ#####hu#
#h##CJ$#OJ##QJ##aJ$############\###r###{################3###<###}##################F###]###f##
##############1###:###~####################################################
############################################################################
#############################################################################
#############################################################################
#######################################################################$##h#^
h#a$#gd####################H###^###g##################d###h###i###s###{
############################################################################
#############################################################################
###############################################################################
###########################################################$##$######&
#$#/#If####a$#b$#gd##
#####.#2###gd######gd#######$#a$#gd######$#
&##F
#a$#gd#######$##h#^h#a$#gd####{###|
#########w############`############`#############################################
###################################################################################
##########################$##$######&
#$#/#If####a$#b$#gd#####kd#####$##$#If#####F###############################
0##~#h#######################################
t###6
#######0###############################################6 ###########
################################4#######4###
#l#a