Вы находитесь на странице: 1из 5

Ejemplo 1:

El siguiente ejercicio calcula un descuento del 15% (0,15) para aquellos clientes que
paguen de Contado.
Prueba_lgica
Valor_si_verdadero
Valor_si_falso

1.

Pago de Contado
Descuento del 15% para quien pague al contado
Los que paguen a Crdito no obtendrn descuento:0

Activen la Hoja3 y transcriban los siguientes datos, tal y como se indica en las
columnas A, C y D, respectivamente:
A

1
2
3
4 Forma de pago:
5
6
7
8

2.
3.

Subtotal
Descuento

75000

Hagan clic en la celda A5 y escriban la etiqueta Contado


Hagan clic en la celda D2 y escriban manualmente la siguiente funcin SI:

=SI(A5=Contado;D1*0,15;0)
Argumentos de la funcin:
Prueba_lgica:
Valor_si_verdadero:
Valor_si_falso:

5.

A5=Contado
D1*0,15;
0

Opriman la tecla Enter y actualicen el libro


La frmula mirar si en la celda A5 (celda con contorno) existe la palabra Contado. En tal caso, ejecutar la frmula (15 % de descuento de 75000), en caso
contrario, colocar un cero en la celda D2, es decir, resultado Falso

A
1
2
3
4 Forma de pago:
5 Contado
6
7
8

C
Subtotal
Descuento

D
75000
11250

E-mail: hmatab@icnet.com.ve. Computacin bsica. Secciones 03 y 04. Semestre B-2000

Ejemplo 2:
En el siguiente ejercicio la funcin SI evaluar cada una de las celdas del rango A2:A8
para ver si se cumple la siguiente condicin: Si el valor de una determinada celda es
Igual o inferior a cierto nmero, 16, por ejemplo, la funcin colocar en la celda la
Sumatoria del Rango analizado; de lo contrario calcular y colocar el promedio del
rango
Prueba_lgica
Valor_si_verdadero
Valor_si_falso

1.

A2<=16
Sumatoria del rango seleccionado, es decir, A2:A8
Promedio del rango seleccionado , es decir, A2:A8

Inserten una nueva Hoja de Excel, la cuarta, y transcriban los siguientes datos,
tal y como se indica en la columnas A y B, respectivamente:
A
1
2
3
4
5
6
7
8

4.

Valores

Acciones

10
12
14
16
18
20
22

Hagan clic en la celda B2 para activarla y escriban manualmente la siguiente funcin SI:

=SI(A2<=16;SUMA($A$2:$A$8);PROMEDIO($A$2:$A$8))
Argumentos de la funcin:
Prueba_lgica:
Valor_si_verdadero:
Valor_si_falso:

6.

A2<=16
SUMA($A$2:$A$8)
PROMEDIO($A$2:$A$8))

Opriman Enter. Copien la frmula en el resto del rango y actualicen el libro


La frmula mirar si en la celda A2 est almacenado el valor 16. En ese caso,
ejecutar la frmula (SUMA($A$2:$A$8), de lo contrario, calcular y colocar el
PROMEDIO($A$2:$A$8)
A
1
2
3
4
5
6
7
8

Valores

Acciones

10
12
14
16
18
20
22

112
112
112
112
16
16
16

E-mail: hmatab@icnet.com.ve. Computacin bsica. Secciones 03 y 04. Semestre B-2000

Ejemplo 3:
En el siguiente ejercicio la funcin SI inspeccionar el contenido de la celda A2. Si el
valor encontrado es un 1, escribir la letra A; si encuentra un 2, escribir la letra B y
finalmente, si encuentra el nmero 3, escribir la letra C
De acuerdo con el enunciado del ejercicio en cada celda del rango A2:A6 se realizarn
tres anlisis: SI(A2=1 SI(A2=2 y SI(A2=3, respectivamente. Esto significa que hay que
anidar tres funciones SI en la misma expresin. Afortunadamente Excel permite anidar
hasta 7 funciones SI.
1.

Inserten una nueva Hoja de Excel, la quinta, y transcriban los siguientes datos, tal
y como se indica en la columnas A y B, respectivamente:

1
2
3
4
5
6
2.

Valores

Acciones

3
2
1
3
1

Hagan clic en la celda B2 para activarla y escriban manualmente la siguiente funcin SI.
NOTA: Se deben escribir tantos parntesis de cierre como funciones SI se aniden

=SI(A2=1;A;SI(A2=2;B;SI(A2=3;C)))
3. Opriman la tecla Enter
4. Lleven el cursor nuevamente sobre la celda B2
5. Coloquen el cursor sobre el controlador de relleno y hagan doble clic sobre l
para copiar la frmula en el resto del rango, es decir: B3:B6. Actualicen el libro.
La funcin inspeccion inteligentemente los valores almacenados en el rango A2:A6
y actu tal y como se le haba solicitado a la funcin SI que hiciera

1
2
3
4
5
6

Valores

Acciones

3
2
1
3
1

C
B
A
C
A

E-mail: hmatab@icnet.com.ve. Computacin bsica. Secciones 03 y 04. Semestre B-2000

Ejemplo 4:
En el siguiente ejemplo se utilizar la funcin SI con el fin de calificar las notas obtenidas por los estudiantes de la asignatura informatica. Para utilizaremos una escala de
notas as: Sobresaliente, 20 puntos; Distinguido, 19; Muy bueno, 17-18; Bueno,
16; Regular, 11-15; Aprobado, 10 y Reprobado, 0 - 9, respectivamente.
Tal como puede observarse existen 7 categoras de calificaciones, por lo tanto se deben anidar siete funciones SI en la misma expresin. El anidamiento debe hacerse en
el mismo orden en que aparecen las categoras, es decir desde Sobresaliente hasta
Reprobado (o viceversa).
1.

Inserten una nueva Hoja de Excel, la sexta y transcriban los siguientes datos, tal
y como se indica en la columnas A, B, C, D, E y F, respectivamente:
A
1
2
3
4
5
6
7

N. Promedio

13.38
8.00
14.50
15.79
13.55

B
Apellidos
Albornoz
Araujo
Barrios
Cabrera
Carrillo

C
Nombres
Pedro
Benito
Isabel
Antonio
Luis

D
Escuela
EC
EC
EC
EA
EC

E
F
Nota Categora
13
12
20
18
11

NOTA: ANEXAR CINCO DATOS MAS DE LOS PROPUESTOS


2.

Hagan clic en la celda F3 para activarla y escriban la siguiente funcin SI. NOTA:
Escriban tantos parntesis de cierre como funciones SI aniden:

=SI(E3=20;Sobresaliente;SI(E3>=19;Distinguido;
SI(E3>=17;Muy bueno;
SI(E3=16;Bueno;SI(E3>=11;
Regular;SI(E3=10;Aprobado; SI(E3<10;Reprobado
)))))))
3.
4.
5.

Opriman la tecla Enter


Lleven el cursor nuevamente sobre la celda F3
Coloquen el cursor sobre el controlador de relleno y hagan doble clic sobre l
para copiar la frmula en el resto del rango, es decir: F3:F24. Actualicen el libro.
La funcin inspeccion inteligentemente los valores almacenados en el rango
E3:E24 y actu tal y tal y como se especific en la funcin SI

Ejemplo 5:
En el siguiente ejemplo, si el valor en la celda A2 es 100, la prueba lgica ser Verda-dero
y se calcular la suma total del rango A2:A7. De lo contrario, si la prueba_lgica es Falso,
se devolver una cadena de texto vaca () que borrar el contenido de la celda que
contenga la funcin SI
Prueba_lgica
Valor_si_verdadero
Valor_si_falso
1.

Inserten una nueva Hoja de Excel, la sptima y transcriban los siguientes datos, tal y
como se indica en la columnas A y B, respectivamente:

1
2
3
4
5
6
7
2.

A2=100
Sumatoria del rango
Cadena de texto vaca ()

Valores

Suma

100
80
100
100
88
100

Hagan clic en la celda B2 para activarla y escriban manualmente la siguiente fun-cin


SI.

=SI(A2=100;SUMA($A$2:$A$7);)
3.
4.
5.

Opriman la tecla Enter


Lleven el cursor nuevamente sobre la celda B2
Coloquen el cursor sobre el controlador de relleno y hagan doble clic sobre l para
copiar la frmula en el resto del rango, es decir: B3:B7. Actualicen el libro.
La funcin inspeccion inteligentemente los valores almacenados en el rango A2:A7 y
actu tal y como se le haba solicitado a la funcin SI

1
2
3
4
5
6
7

Valores

Suma

100
80
100
100
88
100

568
568
568
568