Вы находитесь на странице: 1из 14

IPv6

Topology

Note: In the simulation, the module 0 was changed by the module 1 in all routers

1. Configure the network as shown in the diagrams. Configure any IGP of your choice.
R100
hostname R100
interface FastEthernet 0/0
ip address 10.1.1.1 255.255.255.252
ip router isis
no shutdown
interface FastEthernet 0/1
ip address 10.1.1.5 255.255.255.252
ip router isis
no shutdown
interface FastEthernet 1/0
ip address 192.168.1.1 255.255.255.0
ip router isis
no shutdown
router isis
net 49.0001.0100.0100.0100.00
is-type level-2-only

R101
hostname R101
interface FastEthernet 0/0
ip address 10.1.1.2 255.255.255.252
ip router isis
no shutdown
interface FastEthernet 0/1
ip address 10.1.1.9 255.255.255.252
ip router isis
no shutdown
router isis
net 49.0001.0101.0101.0101.00
is-type level-2-only

R102
hostname R102
interface FastEthernet 0/0
ip address 10.1.1.13 255.255.255.252
ip router isis
no shutdown
interface FastEthernet 0/1
ip address 10.1.1.6 255.255.255.252
ip router isis
no shutdown
router isis
net 49.0001.0102.0102.0102.00
is-type level-2-only

R103
hostname R103
interface FastEthernet 0/0
ip address 10.1.1.14 255.255.255.252
ip router isis
no shutdown
interface FastEthernet 0/1
ip address 10.1.1.10 255.255.255.252
ip router isis
no shutdown

interface FastEthernet 1/0


ip address 192.168.2.1 255.255.255.0
ip router isis
no shutdown
router isis
net 49.0001.0103.0103.0103.00
is-type level-2-only

R104
hostname R104
interface FastEthernet 0/0
ip address 192.168.1.2 255.255.255.0
ip router isis
no shutdown
router isis
net 49.0001.0104.0104.0104.00
is-type level-2-only

R105
hostname R105
interface FastEthernet 0/0
ip address 192.168.2.2 255.255.255.0
ip router isis
no shutdown
router isis
net 49.0001.0105.0105.0105.00
is-type level-2-only

Verification
R100#show isis neighbors
System Id
Type Interface
R101
L2
Fa0/0
R102
L2
Fa0/1
R104
L2
Fa1/0

IP Address
10.1.1.2
10.1.1.6
192.168.1.2

State
UP
UP
UP

Holdtime
9
9
8

Circuit Id
R101.01
R102.02
R104.01

R103#show isis neighbors


System Id
Type Interface
R101
L2
Fa0/1
R102
L2
Fa0/0
R105
L2
Fa1/0

IP Address
10.1.1.9
10.1.1.13
192.168.2.2

State
UP
UP
UP

Holdtime
7
9
8

Circuit Id
R101.02
R102.01
R105.01

2. Configure IPv6 addresses in the range of 2001:CC13:1004::/48 in the link between R100 and
R104 using EUI-64 format.
R100
interface FastEthernet1/0
ipv6 address 2001:CC13:1004::/48 eui-64
ipv6 enable
R104
interface FastEthernet0/0
ipv6 address 2001:CC13:1004::/48 eui-64
ipv6 enable

Verification
R100#show ipv6 interface FastEthernet 1/0
FastEthernet1/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::CE04:4DFF:FEAA:10
No Virtual link-local address(es):
Global unicast address(es):
2001:CC13:1004:0:CE04:4DFF:FEAA:10, subnet is 2001:CC13:1004::/48 [EUI]
Joined group address(es):
FF02::1
FF02::1:FFAA:10
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
R104#show ipv6 interface FastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::CE05:4DFF:FEAA:0
No Virtual link-local address(es):
Global unicast address(es):
2001:CC13:1004:0:CE05:4DFF:FEAA:0, subnet is 2001:CC13:1004::/48 [EUI]
Joined group address(es):
FF02::1
FF02::1:FFAA:0
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds

Comentado [AOZ1]: By default, is based on EUI-64

3. Configure IPv6 addresses in the range of 2001:CC13:1035::/48 in the link between R103 and
R105 using manual host addresses of your choice.
R103
interface FastEthernet1/0
ipv6 address 2001:CC13:1035::0103/48
ipv6 enable
R105
interface FastEthernet0/0
ipv6 address 2001:CC13:1035::0105/48
ipv6 enable

Verification
R103#show ipv6 interface fastEthernet 1/0
FastEthernet1/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::CE06:4DFF:FEB9:10
No Virtual link-local address(es):
Global unicast address(es):
2001:CC13:1035::103, subnet is 2001:CC13:1035::/48
Joined group address(es):
FF02::1
FF02::1:FF00:103
FF02::1:FFB9:10
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
R105#show ipv6 interface fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::CE0B:4DFF:FEB9:0
No Virtual link-local address(es):
Global unicast address(es):
2001:CC13:1035::105, subnet is 2001:CC13:1035::/48
Joined group address(es):
FF02::1
FF02::1:FF00:105
FF02::1:FFB9:0
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds

4. Execute a "show ipv6 interface" command and take a look at all the IPv6 addresses. Make
sure you can explain the function of each of them.
R100#show ipv6 interface
FastEthernet1/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::CE04:4DFF:FEAA:10
No Virtual link-local address(es):
Global unicast address(es):
2001:CC13:1004:0:CE04:4DFF:FEAA:10, subnet is 2001:CC13:1004::/48 [EUI]
Joined group address(es):
FF02::1
FF02::1:FFAA:10
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds

Comentado [AOZ2]: Its used to communicate two IPv6 devices.


Also, its as next hop in routing protocols operation.
Comentado [AOZ3]: Are used to specify that the virtual linklocal IPv6 address should be enabled and calculated automatically
from the virtual router virtual MAC address (VRRP or HSRP).
Comentado [AOZ4]: Are used on links that are aggregated
upward through organizations, and eventually to ISPs

5. Configure a loopback IPv6 address in the four routers: R100, R104, R103 and R105. Make
sure R104 and R100 can exchange their addresses through RIPng. Make sure R103 and
R105 can exchange their loopbacks through EIGRP.
R100
ipv6 unicast-routing

Comentado [AOZ5]: To enable IPv6 unicast routing

ipv6 router rip RIPng


interface Loopback0
ipv6 address 100::/128
ipv6 enable
ipv6 rip RIPng enable
interface FastEthernet1/0
ipv6 rip RIPng enable

Comentado [AOZ6]: In IPv6, there are not network command

Comentado [AOZ7]: To enable RIPng on the interface


connected to R104

R103
ipv6 unicast-routing
ipv6 router eigrp 1
no shutdown
interface Loopback0
ipv6 address 103::/128
ipv6 enable
ipv6 eigrp 1
interface FastEthernet1/0
ipv6 eigrp 1

Comentado [AOZ8]: Its necessary in EIGRP IPv6

R104
ipv6 unicast-routing
ipv6 router rip RIPng
interface Loopback0
ipv6 address 104::/128
ipv6 enable
ipv6 rip RIPng enable
interface FastEthernet0/0
ipv6 rip RIPng enable

R105
ipv6 unicast-routing
ipv6 router eigrp 1
no shutdown
interface Loopback0
ipv6 address 105::/128
ipv6 enable
ipv6 eigrp 1
interface FastEthernet0/0
ipv6 eigrp 1

Verification
R100#show ipv6 route rip
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
R
104::/128 [120/2]
via FE80::CE05:4DFF:FEAA:0, FastEthernet1/0
R103#show ipv6 route eigrp
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
D
105::/128 [90/156160]
via FE80::CE0B:4DFF:FEB9:0, FastEthernet1/0

Comentado [AOZ9]: R104s loopback address

Comentado [AOZ10]: R105s loopback address

R104#show ipv6 route rip


IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
R
100::/128 [120/2]
via FE80::CE04:4DFF:FEAA:10, FastEthernet0/0
R105#show ipv6 route eigrp
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
D
103::/128 [90/156160]
via FE80::CE06:4DFF:FEB9:10, FastEthernet0/0

6. Configure a manual IPv6IP tunnel between R100 and R103 to interconnect both IPv6
networks through the IPv4 network, use OSPFv3 over the tunnel and redistribution to
exchange IPv6 networks from both sides.

Comentado [AOZ11]: R100s loopback address

Comentado [AOZ12]: R103s loopback address

Comentado [AOZ13]:
http://ccietobe.blogspot.com/2008/07/ipv6-tunneling-ipv6ip.html

R100
interface Loopback1
ip address 100.100.100.100 255.255.255.255

Comentado [AOZ14]: This address will be used as source


address of the IPv6IP tunnel

ip prefix-list CONECTADAS seq 5 permit 100.100.100.100/32


route-map CONECTADAS permit 10
match ip address prefix-list CONECTADAS
router isis
redistribute connected route-map CONECTADAS

Comentado [AOZ15]: In order to announce the source address of


the tunnel

interface Tunnel 0
ipv6 enable
ipv6 address 2011::100/112
tunnel source 100.100.100.100
tunnel destination 103.103.103.103
tunnel mode ipv6ip
ipv6 prefix-list LAN seq 5 permit 2001:CC13:1004::/48
route-map LAN permit 10
match ipv6 address prefix-list LAN
ipv6 router ospf 1
redistribute connected route-map LAN

Comentado [AOZ16]: To announce its IPv6 LAN network

interface Tunnel0
ipv6 ospf 1 area 0
R103
interface Loopback1
ip address 103.103.103.103 255.255.255.255
ip prefix-list CONECTADAS seq 5 permit 103.103.103.103/32
route-map CONECTADAS permit 10
match ip address prefix-list CONECTADAS
router isis
redistribute connected route-map CONECTADAS
interface Tunnel 0
ipv6 enable
ipv6 address 2011::103/112
tunnel source 103.103.103.103
tunnel destination 100.100.100.100
tunnel mode ipv6ip
ipv6 prefix-list LAN seq 5 permit 2001:CC13:1035::/48
route-map LAN permit 10
match ipv6 address prefix-list LAN
ipv6 router ospf 1
redistribute connected route-map LAN
interface Tunnel0
ipv6 ospf 1 area 0

Verification
R100#ping 103.103.103.103 source 100.100.100.100

Comentado [AOZ17]: To check IPv4 connectivity between both


sides of the tunnel

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 103.103.103.103, timeout is 2 seconds:
Packet sent with a source address of 100.100.100.100
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
R100#show ipv6 ospf neighbor
Neighbor ID
Pri
103.103.103.103
1

State
FULL/

Dead Time
00:00:36

Interface ID
11

Interface
Tunnel0

Dead Time
00:00:39

Interface ID
11

Interface
Tunnel0

R103#show ipv6 ospf neighbor


Neighbor ID
Pri
100.100.100.100
1

State
FULL/

R100#show ipv6 route ospf


IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
OE2 2001:CC13:1035::/48 [110/20]
via FE80::6767:6767, Tunnel0
R103#show ipv6 route ospf
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
OE2 2001:CC13:1004::/48 [110/20]
via FE80::6464:6464, Tunnel0
R100#ping ipv6 2001:CC13:1035::103 source FastEthernet 1/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:CC13:1035::103, timeout is 2 seconds:
Packet sent with a source address of 2001:CC13:1004:0:CE04:4DFF:FEAA:10
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
R100#100#ping 103:: source 100::

7. Configure a manual GRE tunnel between R100 and R103 to interconnect both IPv6 networks
through the IPv4 network, use ISIS over the tunnel and redistribution to exchange IPv6
networks from both sides. Make sure this tunnel is used when you tear down the OSPF
tunnel.
R101 and R102
router isis
metric-style wide
R100
interface Loopback2
ip address 200.100.100.100 255.255.255.255
interface Tunnel 1
ipv6 enable
ipv6 address 2012::100/112
tunnel source 200.100.100.100
tunnel destination 203.103.103.103
tunnel mode gre ip
ip prefix-list CONECTADAS seq 15 permit 200.100.100.100/32
interface Tunnel1
ipv6 router isis

Comentado [AOZ18]: End to end connectivity between IPv6


networks of both sides

Comentado [AOZ19]: Ambos tneles empiezan a flapear apenas


se activa el tnel IS-IS (interface tunnel 1)

R103
interface Loopback2
ip address 203.103.103.103 255.255.255.255
interface Tunnel 1
ipv6 enable
ipv6 address 2012::103/112
tunnel source 203.103.103.103
tunnel destination 200.100.100.100
tunnel mode gre ip
ip prefix-list CONECTADAS seq 15 permit 203.103.103.103/32
interface Tunnel1
ipv6 router isis

Verification

8. Configure new IPv6 loopbacks in R104 and R105 using the prefix 3001:CC13::/16.
Exchange these loopbacks between both routers using iBGP.
R104
interface Loopback1
ipv6 address 3001:CC13::104/16
ipv6 prefix-list LOOPBACK seq 5 permit 3001::/16
route-map LOOPBACK permit 10
match ipv6 address prefix-list LOOPBACK
ipv6 router rip RIPng
redistribute connected route-map LOOPBACK

R105
interface Loopback1
ipv6 address 3001:CC13::105/16
ipv6 prefix-list LOOPBACK seq 5 permit 3001::/16
route-map LOOPBACK permit 10
match ipv6 address prefix-list LOOPBACK
ipv6 router eigrp 1
redistribute connected route-map LOOPBACK

Verification
R105#show ip igmp groups
IGMP Connected Group Membership
Group Address
Interface
225.0.0.1
FastEthernet0/0
225.0.0.102
FastEthernet0/0
225.0.0.101
FastEthernet0/0

Uptime
00:25:18
00:00:36
00:00:36

Expires
stopped
stopped
stopped

Last Reporter
192.168.2.2
192.168.2.2
192.168.2.2

Group Accounted

R100#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.0.1.40), 00:15:14/00:02:51, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

R101#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.0.1.40), 00:14:54/00:02:57, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:14:54/00:02:57
(*, 225.0.0.101), 00:13:54/00:03:22, RP 101.101.101.101, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:13:54/00:03:22
R102#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.0.1.40), 00:16:01/00:02:43, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
(*, 225.0.0.102), 00:15:13/00:03:01, RP 102.102.102.102, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:15:13/00:03:01
R103#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.0.0.1), 00:16:04/00:02:54, RP 0.0.0.0, flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse, 00:16:04/00:02:54

(*, 224.0.1.40), 00:16:50/00:02:47, RP 0.0.0.0, flags: DCL


Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:16:50/00:02:47
(*, 225.0.0.102), 00:16:09/00:02:52, RP 102.102.102.102, flags: SJC
Incoming interface: FastEthernet0/0, RPF nbr 10.1.1.13
Outgoing interface list:
FastEthernet1/0, Forward/Sparse, 00:16:09/00:02:52
(*, 225.0.0.101), 00:16:03/00:02:55, RP 101.101.101.101, flags: SJC
Incoming interface: FastEthernet0/1, RPF nbr 10.1.1.9
Outgoing interface list:
FastEthernet1/0, Forward/Sparse, 00:16:03/00:02:55

Вам также может понравиться