Вы находитесь на странице: 1из 6

red

172.10.X.0/24

10.10.10.10 green
172.9.X.0/24

BB2
Fas0/1 10.9.9.9
192.168.2.0/24 Fas0/1.1
BB1
Fas0/0.1
Fas0/0.2 112.12.46.0/24 12.12.6.6 yellow
10.2.2.2
R2 192.168.23.0/24 Fas0/0
S0/0/1 S0/1/0 S0/0/0.2 172.8.X.0/24
41.41.3.3 12.12.4.4 R6
MFR1.1:
S0/0/1 S0/0/1 S0/0/0.1
192.168.100.0/30 Fas0/1.1 141.41.34.0/30
112.12.67.0/24
Fas0/0 192.168.7.0/24 10.8.8.8
R3 R4 S0/0/0.2
MFR1.2: S0/0/1 S0/0/1
S0/1/1 S0/0/0
192.168.200.0/30 R8
AS 4100 S0/0/1 S0/1/0 141.41.13.0/24 R7 Fas0/1
41.41.1.1 S0/1/1 12.12.7.7 S0/0/0.1
R1
Fas0/0 112.12.45.0/24 112.12.56.0/24 112.12.57.0/24
141.41.111.0/24 192.168.8.0/24

Blue
Eth0/1
192.168.11.0/24 41.41.11.11
Eth0/0 Fas0/8
10.12.12.12 BB3 ATM1/0.3
S0/0/0.2 S0/0/0.3
ATM1/0.M ATM1/0.2 ATM Vlan513 CAT2
Fas0/11
CAT1 S0/0/0.1 R5 Fas0/0 10.13.13.13
12.12.5.5 192.168.5.0/24
172.13.X.0/24
AS 4100 AS 12000
172.12.X.0/24 ATM-Cell
172.24.X.0/24
ATM-Frame X: integer from 1 to 5
YY: rack number
M: 30YY-19
L: 30YY-10
Tag-switching & MPLS TE [Questions]:

- Configure Tag-switching in the 2 domains (AS 4100 and AS 12000)

- The label protocol should be TDP (2 Points)

- Loopback0 interfaces of the routers should act as the Tag-switching identifiers


(1 Point)
- Configure Frame-mode MPLS and Cell-mode MPLS between BB3 and ATM routers on
links ATM1/0.2 and ATM1/0.M respectively (2 Points)

- Configure BB3 such that it limits the number of hops permitted in an LSP established
by the downstream on demand method to 5 (1 Point)

- Configure AS 12000 routers such that they assign labels for the default route
(1 Point)
- Configure the link between R1 and R3 to accommodate MPLS MTU appropriate for the
MPLS VPN operation (1 Point)

* Configure MPLS TE inside domain AS 12000 with an RSVP requirement of 100Kbps


such that:

- Routers’ loopback0 interfaces are to be the MPLS TE identifiers (1 Point)

- Configure an MPLS TE tunnel from R4 towards R7 with the following parameters:


The Tunnel primary path should follow the dynamic low cost IGP path
The secondary path will follow the links: R4R5R6R7
The last resort option for the tunnel will follow the links: R4R5R7
(3 Points)
- Configure R5 such that:
The traffic destined to R7 should be load shared over two MPLS TE tunnels as follows:
The first tunnel will follow the dynamic low cost IGP path
The second tunnel will follow the path: R5R6R7
The fist tunnel should carry twice the traffic than the second tunnel
(3 Points)

Tag-switching & MPLS TE [Solutions]:

On all routers in the 2 domains, AS 4100 and AS 12000, configure CEF “Cisco Express
Forwarding” for the MPLS operation with “ip cef”
On all routers in the 2 domains, AS 4100 and AS 12000, configure TDP as the label
distribution protocol via “mpls label protocol tdp”

We will also configure the Loopback0 interface on all routers as their TDP identifiers by
“tag-switching tdp router-id Loopback0” which may be shown in the “sh run” output by
“mpls ldp router-id Loopback0”

We will enable the tag-switching operation under every interface facing the cloud [PE-P]
links or [P-P] links but not on interfaces facing the customers [PE-CE] links with the
command “tag-switching ip” which may be shown in the “sh run” output by “mpls ip”

For AS 12000 routers [R4, R5, R6 and R7], to assign a label for the default route, by
using “mpls ip default-route”

For the MPLS/VPN operation between R1 and R3, the label stack will include 2 labels
(each label is 4 bytes length), then a total of 8 bytes should also be added to the default
MTU of 1500 on the link between the 2 routers via “mpls mtu 1508”

On R1:

!
ip cef
mpls label protocol tdp
mpls ldp router-id Loopback0
!
interface FastEthernet0/0
mpls ip
!
interface Serial0/1/1
mpls ip
mpls mtu 1508
!

On BB3:

We will configure Frame-mode MPLS over ATM interface “ATM1/0.2” with “mpls ip”
as with all kind of interfaces

Also we will configure cell-mode MPLS over interface ATM1/0.M;


Consider we are working on Rack#1, where M=11

The Cell-mode MPLS operation is enabled on the VP-tunnel 11, for the sub-interface of
type “tag-switching” ATM1/0.11
The Control VC (carrying routing and signaling updates) will be (11/32) by default as we
have only one ATM PVP, so no need to configure it
We will limit the number of hops in the established cell-mode LSP (label switched path)
from BB3 to 5 hops via “tag-switching atm maxhops 5”

!
ip cef
mpls label protocol tdp
tag-switching tdp router-id Loopback0
tag-switching atm maxhops 5
!
interface Ethernet0/1
tag-switching ip
!
interface ATM1/0.11 tag-switching
ip address 10.1.1.1 255.255.255.252
tag-switching atm vp-tunnel 11 vci-range 33-65535
tag-switching ip
!
interface ATM1/0.2 point-to-point
ip address 10.1.1.5 255.255.255.252
tag-switching ip
pvc 20/0
!

For the MPLS TE, we are asked to configure some TE tunnels inside AS 12000; we have
the OSPF configured inside this domain

We will enable the MPLS TE globally on the domain routers with “mpls traffic-eng
tunnels”

We have also to define the OSPF area within which the TE operation will be active with
“mpls traffic-eng area 0” under the OSPF process

Also, we need to configure an identifier for the TE operation with “mpls traffic-eng
router-id Loopback0” under the OSPF process too

Under every interface; the MPLS TE tunnels will pass through, we have to configure the
RSVP protocol for the bandwidth reservation and labels allocation
We have to configure also “mpls traffic-eng tunnels”

For the first TE tunnel initiated from R4 and terminated on R7, we will use 3 path options
for this tunnel establishment
The first path-option will be the dynamic low cost IGP path, which will follow the links:
R4R6R7
The second path-option will be a static path (defined with “ip explicit-path name R7_1
enable”) following the links: R4R5R6R7
The third path-option will also be a static path (defined with “ip explicit-path name R7_2
enable”) following the links: R4R5R7

On all interfaces that the TE tunnel will pass through, or supposed to pass through, we
have to enable the RSVP operation with bandwidth 100K as given via “ip rsvp bandwidth
100”

On R4:

!
mpls traffic-eng tunnels
!
interface FastEthernet0/0
mpls traffic-eng tunnels
ip rsvp bandwidth 100
!
interface Serial0/0/0
mpls traffic-eng tunnels
ip rsvp bandwidth 100
!
router ospf 1200
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 12.12.7.7
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 dynamic
tunnel mpls traffic-eng path-option 2 explicit name R7_1
tunnel mpls traffic-eng path-option 3 explicit name R7_2
!

ip explicit-path name R7_1 enable


next-address 112.12.45.5
next-address 112.12.56.6
next-address 112.12.67.7
next-address 12.12.7.7
!
ip explicit-path name R7_2 enable
next-address 112.12.45.5
next-address 112.12.57.7
next-address 12.12.7.7
!

The TE tunnel destination is defined with “tunnel destination 12.12.7.7” to be R7 in this


case
The “tunnel mpls traffic-eng autoroute announce” is used to make the tunnel usable by
the IGP (OSPF in the domain) and to begin forwarding traffic on the tunnel
The “tunnel mpls traffic-eng path-option 1 dynamic” shows that the first option for the
tunnel establishment is dynamic through the low cost OSPF selected path between R4
and R7 (tunnel destination)
The “tunnel mpls traffic-eng path-option 2 explicit name R7_1” defines the second option
for tunnel establishment which will be static path through a sequence of defined hops
The “tunnel mpls traffic-eng path-option 3 explicit name R7_2” defines the third option
for tunnel establishment which will be static path through a sequence of defined hops