Вы находитесь на странице: 1из 6

UNIVERSIDAD DE MENDOZA

Facultad de Ingeniera

INFORMATICA I
CICLO LECTIVO 2016 2017

TRABAJO PRCTICO N 3: ALGORITMOS, DIAGRAMAS DE CHAPN Y


ESTRUCTURAS REPETITIVAS

CONTENIDO:
DIAGRAMAS DE CHAPN Y PSEUDOCDIGO: ELEMENTOS. REGLAS Y USOS. ESTRUCTURAS
REPETITIVAS.

OBJETIVOS:
Que el alumno se familiarice con la utilizacin de pseudocdigo y Diagrama de
Chapn.
Que sepa identificar las estructuras de repetitivas.

Resuelva cada uno de los ejercicios prcticos utilizando pseudocdigo y Diagrama


de Chapin.
Ejercicio 1: Calcular la suma de los cuadrados de los primeros 20 nmeros enteros y mostrar el
resultado, utilizar la estructura repetitiva Mientras hacer.
Anlisis del Problema:
Datos de entrada: no hay
Datos de salida: suma (de los cuadrados de los veinte primeros nmeros)
Proceso: calcular la suma de los cuadrados de los 20 primeros nmeros. Estructura
repetitiva: Mientras hacer
Pseudocdigo
Inicio
Variables Enteras: suma, cont
suma = 0
cont = 1
Mientras (cont <= 20) Hacer
suma = suma + cont * cont
cont = cont + 1
Fin Mientras
Mostrar La suma de los primeros veinte nmeros es:, suma
Fin
Diagrama de Chapin:

Trabajo Prctico N 4

1/6

UNIVERSIDAD DE MENDOZA
Facultad de Ingeniera

INFORMATICA I
CICLO LECTIVO 2016 2017

Ejercicio 2: Calcular la suma de los cuadrados de los primeros 20 nmeros enteros y mostrar el
resultado, utilizar la estructura repetitiva Repetir hasta que.
Anlisis del Problema:
Datos de entrada: no hay
Datos de salida: suma (de los cuadrados de los veinte primeros nmeros)
Proceso: calcular la suma de los cuadrados de los 20 primeros nmeros. Estructura
repetitiva: Repetirhasta que
Pseudocdigo
Inicio
Variables Enteras: suma, cont
suma = 0
cont = 1
Repetir
suma = suma + cont * cont
cont = cont + 1
Hasta que (cont = 21)
Mostrar La suma de los primeros veinte nmeros es:, suma
Fin
Diagrama de Chapin:
Ejercicio 3: Calcular la suma de los cuadrados de los primeros 20 nmeros enteros y mostrar el
resultado, utilizar la estructura repetitiva Para.
Anlisis del Problema:
Datos de entrada: no hay
Datos de salida: suma (de los cuadrados de los veinte primeros nmeros)
Proceso: calcular la suma de los cuadrados de los 20 primeros nmeros. Estructura
repetitiva: Para
Pseudocdigo:
Inicio
Variables Enteras: suma, cont
suma = 0
Para cont desde 1 hasta 20 con paso 1
suma = suma + cont * cont
Fin para
Mostrar La suma de los primeros veinte nmeros es:, suma
Fin

Trabajo Prctico N 4

2/6

UNIVERSIDAD DE MENDOZA
Facultad de Ingeniera

INFORMATICA I
CICLO LECTIVO 2016 2017
Diagrama de Chapin:
Ejercicio 4: Ingresar n nmeros enteros y contar cuntos de ellos son pares, cuntos impares y
cuntos nulos (iguales a cero).
Anlisis del problema:
Datos de entrada: n nmeros enteros (num)
Datos de salida: cuntos nmeros pares, cuntos impares y cuntos nulos
Pseudocdigo:
Inicio
Variables Enteras: num, cantpar, cantimpar, cantnulo
Variables Caracter: Desea
cantpar = 0
cantimpar = 0
cantnulo = 0
Repetir
Escribir Ingrese un nmero entero:
Leer num
Si num = 0 entonces
cantnulo = cantnulo + 1
sino
Si num es par entonces
cantpar = cantpar + 1
sino
cantimpar = cantimpar + 1
Finsi
Finsi
Escribir Desea ingresar otro nmero (S/N)?
Leer Desea
hasta que Desea = N
Fin
Ejercicio 5: Calcular y mostrar el promedio de edad de 10 personas menores de 18 aos. Si la
edad ingresada no cumple esta condicin, deber preguntar de nuevo la edad, ignorando el valor
ingresado que no haya cumplido esta condicin.
Anlisis del problema:
Datos de entrada: edad de 10 personas
Datos de salida: promedio de edad de 10 personas menores de 18 aos
Pseudocdigo:
Inicio
Variables Enteras: edad, cantmenores, sumaedad
Variables Reales: promedio
sumaedad = 0
cantmenores = 0
Repetir
Escribir Ingrese una edad
Leer edad
Si edad < 18 entonces

Trabajo Prctico N 4

3/6

UNIVERSIDAD DE MENDOZA
Facultad de Ingeniera

INFORMATICA I
CICLO LECTIVO 2016 2017
sumaedad = sumaedad + edad
cantmenores = cantmenores + 1
Sino
Escribir Error
Finsi
Hasta que cantmenores = 10
promedio = sumaedad / 10
Escribir El promedio de las edades es:, promedio
Fin

Ejercicio 6: Calcular el salario de n trabajadores dada la cantidad de horas trabajadas y el precio


por hora para cada uno.
Anlisis del problema
Datos de entrada: horas trabajadas, precio por hora
Datos de salida: salario
Pseudocdigo
Inicio
Variables Enteras: canthoras
Variables Reales: preciohora, salario
Variables Caracter: Desea
Repetir
Escribir Ingrese la cantidad de horas trabajadas:
Leer canthoras
Escribir Ingrese el precio por hora:
Leer preciohora
salario = canthoras * preciohora
Escribir El salario es:, salario
Escribir Desea calcular otro salario (S/N)?
Leer Desea
Hasta que Desea = N
Fin
Ejercicio 7: Calcular el factorial de un nmero entero introducido por teclado. Por ejemplo: 4! =
4*3*2*1, por lo tanto 4! = 24.
Ejercicio 8: Una compaa financiera necesita calcular cada operacin de prstamo, para ello es
necesario ingresar:
1. capital inicial (C),
2. tasa de inters mensual (T) y
3. cantidad de meses (M).
Mostrar por pantalla los siguientes valores:
1. capital inicial ingresado (C),
2. importe a abonar en cada mes hasta cancelar el prstamo, segn la cantidad de meses
(M).
Para obtener el valor de las cuotas, aplicar la siguiente frmula:
1 cuota: cuota = C/M
cuotas siguientes: valor cuota = cuota anterior + (cuota anterior*(T/100))
El programa finalizar cuando se ingrese capital inicial igual a cero (C=0).

Trabajo Prctico N 4

4/6

UNIVERSIDAD DE MENDOZA
Facultad de Ingeniera

INFORMATICA I
CICLO LECTIVO 2016 2017
Anlisis del problema:
Datos de entrada: C (capital inicial), M (meses), T (tasa de inters mensual)
Datos de salida: C, cuota
Proceso: primera cuota = C/M
otras cuotas = cuota anterior + (cuota anterior * (T/100)).
Se termina cuando C = 0
Estructuras a usar: Repetir y Para
Pseudocdigo:
Inicio
Variables Enteras: M, i
Variables Reales: C, T, cuota
Mostrar Ingrese el capital inicial
Leer C
Mientras (C <> 0) Hacer
Mostrar Ingrese cantidad de meses
Leer M
Mostrar Ingrese la tasa de inters mensual
Leer T
cuota = C/M
Mostrar La cuota 1 es igual a:, cuota
Para i desde 2 hasta M con paso 1
cuota = cuota + (cuota * (T/100))
Mostrar La cuota, i, es igual a:, cuota
FinPara
Mostrar Ingrese otro capital inicial
Leer C
Fin Mientras
Fin
Diagrama de Chapin
Ejercicio 9: Ingresar 10 notas de alumnos y mostrar cuntos tienen notas mayores o iguales a 7 y
cuntos menores a esta nota.
Anlisis del problema:
Datos de entrada: 10 notas
Datos de salida: cuantos mayores o iguales a 7, cuantos menores a 7
Pseudocdigo
Inicio
Variables Enteras: nota, cantdesaprobados, cantaprobados, i
cantdesaprobados = 0
cantaprobados = 0
Para i desde 1 hasta 11 con paso 1 hacer
Escribir Ingrese la nota:
Leer nota
Si nota >= 7 entonces
cantaprobados = cantaprobados + 1
sino
cantdesaprobados = cantdesaprobados + 1
Finsi
Finpara
Escribir La cantidad de aprobados es:, cantaprobados, y la cantidad de desaprobados
es:, cantdesaprobados
Fin

Trabajo Prctico N 4

5/6

UNIVERSIDAD DE MENDOZA
Facultad de Ingeniera

INFORMATICA I
CICLO LECTIVO 2016 2017
Ejercicio 10: Solicitar al usuario un nmero y mostrar los nmeros del 1 al nmero que introdujo el
usuario. Si el usuario ingresa un nmero menor o igual a 1, solicitar nuevamente un nmero hasta
que el nmero sea mayor a 1.
Anlisis del problema
Datos de entrada: numero
Datos de salida: numeros desde el 1 hasta el nmero que introdujo el usuario
Pseudocdigo
Inicio
Variables Enteras: num
Repetir
Escribir Ingrese un nmero:
Leer num
Ejercicio 11: Solicitar al usuario tres nmeros consecutivos (3, 4 y 5; 9, 10 y 11,
etc.), cuando se introducen tres nmeros consecutivos calcular el promedio y mostrarlos por
pantalla. Mientras no se introduzcan tres nmeros consecutivos deber seguir pidiendo los 3
nmeros.
Ejercicio 12: Solicitar al usuario un nmero y mostrar la tabla de multiplicacin (hasta el nmero
por 10) del nmero ingresado. Por ejemplo, si el usuario ingresa el nmero 2, deber mostrar:
2*1=2
2*2=4
2*3=6

2*10=20
Anlisis del problema
Datos de entrada: numero
Datos de salida: tabla de multiplicar de ese numero
Pseudocdigo
Inicio
Variables Enteras: num, x, multiplicacion
Escribir Ingresar un nmero:
Leer num
multiplicacion = 0
Para x desde 1 hasta 10 con paso 1 hacer
multiplicacion = num * x
Escribir El resultado es:, multiplicacion
Finpara
Fin

Trabajo Prctico N 4

6/6