Вы находитесь на странице: 1из 19

UNIVERSIDAD TECNOLGICA DELOS ANDES

CUSCO

Contenido
1

DEFINICIONES ACRNIMOS Y ABREVIACIONES: ................................................................... 2


1.1

ARQUETECTURA: ........................................................................................................... 4

1.2

STAKEHOLDER ............................................................................................................... 4

1.3

Escenario ....................................................................................................................... 5

1.4

Modulo y componentes ................................................................................................ 5

1.5

Atributos de calidad ...................................................................................................... 5

conceptos framework ........................................................................................................... 5


2.1

stakeholders y sus roles ................................................................................................ 5

2.2

uso de las descripciones arquitectnicas ...................................................................... 6

descripcin de arquitectura .................................................................................................. 7


3.1

documentacin arquitectnica ..................................................................................... 7

3.2

identificacin de stakeholders ...................................................................................... 8

3.3

diseo de casos de alto nivel......................................................................................... 9

3.3.1

Caso de uso registrar medicamento ..................................................................... 9

3.3.2

Caso de uso orden de venta .................................................................................. 9

3.3.3

Caso de uso Generar comprobante de venta ..................................................... 10

3.3.4

Caso de uso General ............................................................................................ 10

3.4

Vistas de Arquitectura ................................................................................................. 11

3.4.1

Vistas Escenarios: Diagramas de Casos de Uso ................................................ 11

3.4.2

Vista Lgica: Diagramas de Clases .................................................................... 13

3.4.3

Vista Desarrollo: Diagramas de Componentes ................................................. 13

3.4.4

Vista - Procesos: Diagrama de secuencia ............................................................ 14

3.4.5

Vista: Diagrama de Actividades ........................................................................... 14

3.4.6

Vista: Diagrama de Colaboracin ........................................................................ 15

descripcin de componentes .............................................................................................. 15


INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO

4.1

Descripcin .................................................................................................................. 15

4.2

Pseudocdigo .............................................................................................................. 15

4.2.1

Ingreso de medicamentos ................................................................................... 15

4.2.2

Comprobante de venta ....................................................................................... 16

4.2.3

Comprobante de venta ....................................................................................... 18

observaciones...................................................................................................................... 19
5.1

Cronograma y diagrama de Gantt ............................................................................... 19

SISTEMA DE VENTAS DE FARMACIA (Almacn y ventas)


1

DEFINICIONES ACRNIMOS Y ABREVIACIONES:


Actualizacin. - Insertar, eliminar, modificar los registros de los usuarios (Profesores).
Almacenamiento. - En relacin con ordenadores o computadoras, cualquier dispositivo capaz de
almacenar informacin procedente de un sistema informtico.
Backup.- Las copias de seguridad en un sistema informtico tienen por objetivo el mantener cierta
capacidad de recuperacin de la informacin ante posibles prdidas. Esta capacidad puede llegar a
ser algo muy importante, incluso crtico, para las empresas. Se han dado casos de empresas que
han llegado a desaparecer ante la imposibilidad de recuperar sus sistemas al estado anterior a que
se produjese un incidente de seguridad grave.
Sistema Operativo. - Software bsico que controla una computadora. El sistema operativo tiene tres
grandes funciones: coordina y manipula el hardware del ordenador o computadora, como la memoria,
las impresoras, las unidades de disco, el teclado o el mouse; organiza los archivos en diversos
dispositivos de almacenamiento, como discos flexibles, discos duros, discos compactos o cintas
magnticas, y gestiona los errores de hardware y la prdida de datos.
Sitio Web. - Se canaliza a travs del URL o identificador nico de cada pgina de contenidos. Este
sistema permite a los usuarios iniciar una solicitud de trmite y a los funcionarios del Agua Potable
atender las solicitudes e ingresar datos de las inspecciones realizadas. POSTGRESQL- Lenguaje de
consulta estructurado, en informtica, un lenguaje utilizado en bases de datos para consultar,
actualizar y manejar bases de datos relacionales.
Botn. - Es un objeto tangible que realiza un evento tras su activacin.
Conexin. - Comunicacin entre dos entes que tienen caractersticas similares de comunicacin.
Interfaz. - Medio que permite la comunicacin entre el usuario y el sistema.

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
Internet. - interconexin de redes informticas que permite a los ordenadores o computadoras
conectadas comunicarse directamente, es decir, cada ordenador de la red puede conectarse a
cualquier otro ordenador de la red. El trmino suele referirse a una interconexin en particular, de
carcter planetario y abierto al pblico, que conecta redes informticas de organismos oficiales,
educativos y empresariales.
Login.- Nombre o alias que se le da a una persona para permitirle el acceso al sistema siempre y
cuando estn registrados.
PASSWORD. - Contrasea o clave para autentificar el ingreso a un lugar o sitio.
Perifrico. - En informtica, trmino utilizado para dispositivos, como unidades de disco, impresoras,
mdem que estn conectados a un ordenador o computadora y son controlados por su
microprocesador.
Protocolo. - Seal mediante la cual se reconoce que puede tener lugar la comunicacin o la
transferencia de informacin.
Servidor. - Computadora conectada a una red que pone sus recursos a disposicin del resto de los
integrantes de la red. Suele utilizarse para mantener datos centralizados o para gestionar recursos
compartidos.
Servidor de archivos. - Dispositivo de almacenamiento de archivos en una red de rea local, o en
Internet, al que los distintos usuarios de la red pueden acceder, en funcin de los privilegios que les
hayan sido dados por parte del administrador.
Sistema Operativo. - Software bsico que controla una computadora.
El sistema operativo tiene tres grandes funciones: coordina y manipula el hardware del ordenador o
computadora, como la memoria, las impresoras, las unidades de disco, el teclado o el mouse;
organiza los archivos en diversos dispositivos de almacenamiento, como discos flexibles, discos
duros, discos compactos o cintas magnticas, y gestiona los errores de hardware y la prdida de
datos.
Sitio Web. - Se canaliza a travs del URL o identificador nico de cada pgina de contenidos. Este
sistema permite a los usuarios iniciar una solicitud de trmite y a los funcionarios del Agua Potable
atender las solicitudes e ingresar datos de las inspecciones realizadas. POSTGRESQL- Lenguaje de
consulta estructurado, en informtica, un lenguaje utilizado en bases de datos para consultar,
actualizar y manejar bases de datos relacionales.
Tabla. - Entidad que posee campos fsicos primarios secundarios
ACRNIMOS
DBA. - Es aquella persona que tiene el control central del sistema de base de datos.

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
DBMS. - Sistema de Administracin de base de datos, El software que permite la creacin,
administracin e implementacin de la base de datos.
GUI o acrnimo de Graphical User Interface. - En informtica, tipo de entorno que permite al
usuario elegir comandos, iniciar programas, ver listas de archivos y otras opciones utilizando las
representaciones visuales (iconos) y las listas de elementos del men. Las selecciones pueden
activarse bien a travs del teclado o con el ratn.
ODBC. - Herramienta que conecta la base de datos con la interfaz.
SRS.- Acrnimo de Software Requeriments Specifications (Especificacin de Requerimientos de
Software)
TCP/IP. - Acrnimo de Transmisin Control Protocol/Internet Protocol (protocolo de control de
transmisiones/protocolo de Internet), protocolos usados para el control de la transmisin en Internet.
Permite que diferentes tipos de ordenadores o computadoras se comuniquen a travs de redes
heterogneas.
URL. - Un URL es una cadena de caracteres que identifica el tipo de documento, la computadora, el
directorio y los subdirectorios en donde se encuentra el documento y su nombre.
ABREVIATURAS
HW: Hardware
SW: Software
Sr. Seor
Sra. Seora
Ing. Ingeniero(a)
Dr. Doctor(a)
1.1

ARQUETECTURA:

Conjunto de elementos estticos, propios del diseo intelectual del sistema, que
definen y dan forma tanto al cdigo fuente, como al comportamiento del software en
tiempo de ejecucin. Naturalmente ese diseo arquitectnico ha de ajustarse a las
necesidades y requisitos del proyecto.
1.2

STAKEHOLDER
Propietario: Es quien tiene algunos privilegios como el de gestionar reportes,
modificar el inventario de medicamentos.

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
Qumico farmacutico: encargado de supervisar las ventas y ingreso de los
medicamentos al stock
Tcnico farmacutico: encargado de realizar las ventas , cotizaciones de recetas cobro
de las ventas
1.3

ESCENARIO
Especifica el comportamiento y limita el inters de un rea especfica del sistema para
uno o varios stakeholders. Para el sistema de alquiler de vehculos tenemos los
siguientes escenarios: El escenario de negocio de alquiler de vehculos y el escenario
de diseo del sistema de alquiler de vehculos. Modulo y componentes

1.4

MODULO Y COMPONENTES

cualquier elemento estructural abstracto, visible, externo, de alto nivel,


analizable, que pueda constituir una funcionalidad de la solucin del sistema:

Modulo Ingreso: en este mdulo se encargar del registro de los documentos como
facturas, guas de remisin; en ingresar a los productos en unidades de venta por el
qumico farmacutico

Modulo Egreso: en este modulo se encargara del registro de las ventas, verificacin de
stock actual y cotizacin de recetas medicas

Modulo Caja: en este modulo se en carga de mostrar todas la ventas echas de


acuerdo a los comprobantes emitidos

1.5

Modulo Reporte: se mostrara los reportes requeridos


ATRIBUTOS DE CALIDAD

Un atributo de calidad, es una cualidad deseable de la solucin, que pueda


manifestarse en forma de requerimiento no funcional, que pueda ser medible,
testeable y finalmente evaluable. Para el sistema de alquiler de vehculos tenemos
los siguientes atributos de calidad: funcionabilidad y usabilidad.
2
2.1

CONCEPTOS FRAMEWORK
STAKEHOLDERS Y SUS ROLES
Propietario: Es quien tiene algunos privilegios como el de gestionar reportes,
modificar el inventario de medicamentos.
INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
Qumico farmacutico: en cargado de:

supervisar las ventas

ingreso de los medicamentos

Revisa stock

Tcnico farmacutico: en cargado de:

realizar las ventas

cotizaciones de recetas

Cajero Es la persona encargada de hacer efectivo el pago y recibir el dinero que le


proporciona el cliente.
Cliente: Es la persona que interacta con el negocio de ventas y hace los pedidos de
medicamentos segn su preferencia o receta.
2.2

USO DE LAS DESCRIPCIONES ARQUITECTNICAS


A. Modelo de tres Capas.

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
a) Capa de presentacin (parte en el cliente y parte en el servidor)
Html5
Css3
JavaScript
Tcpdf
Exjs 3.4
b) Capa de proceso (servidor web)
php
c)

Capa de datos (servidor de datos)


Mysql

3
3.1

DESCRIPCIN DE ARQUITECTURA
DOCUMENTACIN ARQUITECTNICA

El sistema Cuenta con una base de datos y relaciones como lo son casos de uso y vistas de
procesos sobre todo una arquitectura de software en los siguientes puntos se mostrarn las
vistas de caso de uso procesos.

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.2

IDENTIFICACIN DE STAKEHOLDERS
revisa stock
<<include>>

Stakeholder

descripcin

escenario

Es quien tiene algunos

genera
pedido
revisa stock

privilegios como el de
<<include>>

gestionar
Propietario

reportes,

Escenario

de negocios

Escenario

pedido de diseo
modificar el atender
inventario

vistas
CU

Administrar

Sistema.
CU Reportes
Proveedor

Qumico farmacutico

de medicamentos.

genera pedido

Es el encargado de

Escenario

ingresa medicamentos

supervisar las ventas,


Qumico

de negocios

atender
pedido
revisa
stock
ingreso <<include>>
de
los

Qumico farmacutico

farmacutico

medicamentos
<<include>>

Escenario

de diseo

CU

Administrar

Sistema.
Proveedor

CU ingresos
CU egresos
CU Reportes

revisa
pedido
Revisa
stock
ingresa medicamentos
genera pedido

en cargado
de:
<<include>>

Escenario

CU egresos

de negocios
revisa
pedido orden
revisa stock
generar
de
atender pedido
Qumico farmacutico

Tcnico
farmacutico

ventas, <<include>>
cotizaciones

EscenarioProveedor

de diseo

de recetas
ingresa medicamentos

Es

la

genera pedido

persona

<<include>>
revisahacer
stock
encargada de

efectivo
el atender
pago pedido
y
revisa
pedido<<include>>
Cajero
Qumico farmacutico

Escenario

CU egresos

de negocios

recibir el dinero que le

Escenario

Proveedor

de diseo

proporciona el cliente.
genera pedido

ingresa medicamentos
Es la persona
que

interacta

con

el

de negocios

<<include>>
negocio deatender
ventaspedido
y
Qumico farmacutico
hacepedido
los
revisa
Cliente

pedidos de

Escenario

Escenario

Proveedor

de diseo

medicamentos segn
su

ingresa medicamentos
preferencia
o

receta

<<include>>

revisa pedido

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.3

DISEO DE CASOS DE ALTO NIVEL

3.3.1

CASO DE USO REGISTRAR MEDICAMENTO


Caso de uso

Registro de medicamentos

Actores

Qumico farmacutico, propietario

Propsito

Registrar medicamentos para mantener el stock del almacn

Resumen

Se ase el pedido al proveedor de un determinado producto, luego cuando


trae el pedido se registra al sistema con la factura o la gua de remisin

Tipo

Primario

Referencia

RF01

Cruzadas
Descripcin

El qumico al momento de recepcionar la gua de remisin o factura tendr


que actualizar el stock del almacn

Valores de

Estado: propuesto () aprobado () incorporado () validado ()

planeacin

Prioridad: critica () importante () auxiliar ()


Nivel de riesgo: critico () significativo ()ordinario ()

3.3.2

CASO DE USO ORDEN DE VENTA

Caso de uso

Generar orden de venta

Actores

tcnico farmacutico, Qumico farmacutico, cliente

Propsito

Generar y revisar las ordenes de ventas para su cobro respectivo

Resumen

El cliente entrega su receta, el tcnico busca en almacn y genera orden de


venta, le qumico revisa la orden de venta

Tipo

Primario

Referencia

RF02

Cruzadas
Descripcin

Generar las ordene de venta de acuerdo a la receta del mdico y la


aprobacin del qumico farmacutico

Valores de

Estado: propuesto () aprobado () incorporado () validado ()

planeacin

Prioridad: critica () importante () auxiliar ()


Nivel de riesgo: critico () significativo () ordinario ()

INGENIERA DE SISTEMAS E INFORMTICA

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.3.3

CASO DE USO GENERAR COMPROBANTE DE VENTA

Caso de uso

Generar comprobante de venta

Actores

Tcnico, cliente

Propsito

Hacer el cobro de los rdenes de ventas y generar comprobante de venta

Resumen

El encargado revisara rdenes de venta y genera comprobante de venta

Tipo

Primario

Referencia

RF02, RF01

Cruzadas
Descripcin

El encargado tendr q revisar lar rdenes de venta y generar su respectivo


comprobante de venta

Valores de

Estado: propuesto () aprobado () incorporado () validado ()

planeacin

Prioridad: critica () importante () auxiliar ()


Nivel de riesgo: critico () significativo () ordinario ()

3.3.4

CASO DE USO GENERAL

Caso de Uso

Sistema de farmacia

Actores

Propietario, qumico farmacutico, tcnico, cajero

Propsito

Realizar la venta de medicamentos

Resumen

Cliente solicita medicamentos mediante una receta mdica, el


tcnico atiende el pedido, el qumico revisa el pedido y el cajero
genera comprobante de venta

Tipo

Primario

Referencia

RF01, RF02

cruzadas
Descripcin

El cliente solicita Cliente solicita medicamentos mediante una receta


mdica.
El tcnico revisa el stock de almacn.
El tcnico genera comprobante de venta.
El qumico revisa el pedido.
El cajero cobra y genera comprobante de venta.
INGENIERA DE SISTEMAS E INFORMTICA

1
0

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.4

VISTAS DE ARQUITECTURA

3.4.1 VISTAS ESCENARIOS: DIAGRAMAS DE CASOS DE USO


A.

CASO DE USO REGISTRAR MEDICAMENTO

revisa stock
<<include>>

genera pedido

Proveedor

atender pedido
Qumico farmacutico

ingresa medicamentos

<<include>>

revisa pedido

B.

CASO DE USO ORDEN DE VENTA

Con Receta

<<extend>>

<<extend>>

Sin Receta

Genera pedido
Genera pedido

Revisa Pedido

Revisa stock

<<include>>
Cliente

Tecnico

Quimico
<<extend>>

<<include>>

Revisa Receta
Medicamentos no Controlados
Medicamentos Controlados

INGENIERA DE SISTEMAS E INFORMTICA

1
1

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO

C.

CASO DE USO GENERAR COMPROBANTE DE VENTA

Revisa Orden de Venta

<<extend>>
Efectivo

Cobra la venta
Cliente

Cajero

<<extend>>
Tarjeta

Revisa saldo

Generar comprobante de venta

D.

CASO DE USO GENERAL

Genera pedido

tecnico

cliente
Revisa stock

Revisa pedido
quimico

Genera orden de venta

cajero
cobra pedido

genera comprobante

INGENIERA DE SISTEMAS E INFORMTICA

Qumico
1

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.4.2

VISTA LGICA: DIAGRAMAS DE CLASES

3.4.3

VISTA DESARROLLO: DIAGRAMAS DE COMPONENTES

Sistema de Farmacia
Administrador

Ingresar al
sistema

Venta de
medicamentos

Ingreso de
medicamentos

Verificar
stock

INGENIERA DE SISTEMAS E INFORMTICA

1
3

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.4.4

VISTA - PROCESOS: DIAGRAMA DE SECUENCIA

3.4.5

VISTA: DIAGRAMA DE ACTIVIDADES

INGENIERA DE SISTEMAS E INFORMTICA

1
4

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
3.4.6

VISTA: DIAGRAMA DE COLABORACIN

DESCRIPCIN DE COMPONENTES

4.1

DESCRIPCIN

4.2

PSEUDOCDIGO

4.2.1

INGRESO DE MEDICAMENTOS
SubProceso revisa_ medicamento <- cdigo ( medicamento )
Si medicamento Entonces
Escribir verdadero
Sino
Leer medicamento
Leer proveedor
Leer cantidad
Leer precio_unitario
insertar<-"ingreso Tproducto
valores(codigo,medicamento,poveedor,cantidad,precio_unitario)"
Si (insertar=verdadero) Entonces
Escribir Se ingres correctamente
INGENIERA DE SISTEMAS E INFORMTICA

1
5

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
Sino
Escribir Error al ingresar
Fin Si
Fin Si
Fin SubProceso

Proceso ingreso_de_medicamentos
Escribir ingrese datos
Leer medicamento
Leer proveedor
Leer tipo_documento
Leer cantidad
Leer precio_unitario
Si revisa_medicamento Entonces
insertar<-"ingreso tingreso
valores(codigo,medicamento,poveedor,tipo_documento,cantidad,precio_unitario)"
Si (insertar=verdadero) Entonces
Escribir Se ingres correctamente
Sino
Escribir Error al ingresar
Fin Si
Sino
Escribir Error al ingresar
Fin Si
FinProceso

4.2.2

COMPROBANTE DE VENTA
SubProceso Revisa_medicamento <- medicamento ( codigo, cantidad )
[Peticin de datos]
stock<-"mostrar todo medicamento de cdigo<-cdigo y cantidad > cantidad"
[Fin de peticin de datos]
Si stock Entonces

INGENIERA DE SISTEMAS E INFORMTICA

1
6

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
descontar<- cantidad_stosck-cantidad
Sino
Escribir no existe cantidad suficiente
Fin Si

Fin SubProceso

Proceso Comprobante _venta


Escribir Ingrese Datos
Leer medicamentos
Leer cantidad
Si Revisa_ medicamento <- (medicamentos, cantidad) Entonces
insertar<-"ingreso DVenta valores(cdigo, medicamento, cantidad, fecha,
precio_unitario)"
Si (insertar=verdadero) Entonces
Escribir Se ingres correctamente
Sino
Escribir Error al ingresar
Fin Si
Sino
Escribir Error al ingresar
Fin Si

FinProceso

INGENIERA DE SISTEMAS E INFORMTICA

1
7

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
4.2.3

COMPROBANTE DE VENTA
SubProceso Comprobante <- pedido ( codigo )
[Peticin de datos]
pedido<-"mostar todo pedidos de codigo<-codigo"
[Fin de peticin de datos]
Si pedido Entonces
Escribir existe Comprobante
Sino
Escribir no existe Comprobante
Fin Si

Fin SubProceso

Proceso Comprovante_venta
Escribir Ingrese Datos
Leer Comprobantes
Si Comprobante<-(cdigo) Entonces
insertar<-"ingreso Venta valores(codigo,fecha,precio_total)"
Si (insertar=verdadero) Entonces
Escribir Se ingres correctamente
Sino
Escribir Error al ingresar
Fin Si
Sino
Escribir Error al ingresar
Fin Si

FinProceso

INGENIERA DE SISTEMAS E INFORMTICA

1
8

UNIVERSIDAD TECNOLGICA DELOS ANDES


CUSCO
5
5.1

OBSERVACIONES
CRONOGRAMA Y DIAGRAMA DE GANTT

INGENIERA DE SISTEMAS E INFORMTICA

1
9