Вы находитесь на странице: 1из 12

ESCUELA SUPERIOR POLITCNICA

DE CHIMBORAZO
FACULTAD DE INFORMTICA Y
ELECTRNICA
INGENIERA ELECTRNICA EN
TELECOMUNICACIONES Y REDES

CONMUTACIN Y RUTEO II
OSPF MULTIAREA Y VIRTUAL
LINKS
8vo B
INTEGRANTES:
Marllory Cobos (318)
Diana Pazmio (364)
Mayra Ortiz (317)
19 de mayo de 2016
I.

OBJETIVOS:
GENERAL

Configurar una red OSPF multirea y virtual Links con equipos Juniper
y Cisco.

ESPECFICOS

Armar la red y configurar los parmetros bsicos de los dispositivos.

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

II.

Verificar que la configuracin OSPF sea correcta y que se hayan


establecido adyacencias entre los routers.
Realizar la correcta configuracin de virtual link tanto en los router
Cisco como Juniper.

MARCO TERICO:
GNS3
GNS3 es uno de los mejores simuladores grficos de redes que
podemos encontrar actualmente. La principal caracterstica de
GNS3 es que es multiplataforma, podremos usarlo tanto en
Microsoft Windows, Linux como en Mac OS X, y todo ello de
forma completamente gratuita. Al igual que otros emuladores
tales como VMWare o VirtualBox son empleados para
virtualizar sistemas operativos (Windows, Linux, etc), GNS3 es
usado para la emulacin de imgenes IOS (Internetwork
Operating System)3 de routers Cisco.
GNS3 es un front-end grafico de Dynamips4 y Dynagen5, los cuales son las
herramientas que realmente permiten la emulacin de IOS Cisco.
Dynagen ofrece una interfaz de lnea de comandos ms simple a Dynamips.
Dynamips es el responsable de la emulacin de la IOS. Usando un simple editor
de textos, un usuario podra crear su propio archivo de topologa con la red a
emular por Dynagen.
GNS3 facilita este proceso creando para ello una sencilla interfaz grfica que
abstrae al usuario de los detalles de configuracin del escenario.

Caractersticas

Diseo grfico de topologas de red a emular.


Emulacin de redes Ethernet, ATM y switches Frame Relay.

Conmutacin y Ruteo II
1

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

Emulacin de una gran variedad de IOS Cisco, JunOS, IPS y firewalls


CISCO de tipo ASA y PIX.
Conexin de la red simulada a un entorno real.
Integracin con Qemu6 y VirtualBox7 para emular hosts.
Captura de paquetes integrada usando Wireshark

OSPF Multirea
El diseo de OSPF se basa en la capacidad de dividir una red grande en redes
ms pequeas a travs de reas. (Cisco, 2015)
Ventajas De OSPF

Converge con mayor velocidad que los protocolos de vector distancia.


Sus actualizaciones son pequeas ya que no enva toda la tabla de
enrutamiento.
No es propenso a bucles de enrutamiento.
Escala muy bien en redes grandes.
Utiliza el ancho de banda de los enlaces como base de la mtrica.
Soporta VLSM y CIDR.
Brinda mltiples opciones de configuracin lo que permite adaptarlo a
requerimientos muy especficos. (Rodrgez, 2012)

VIRTUAL LINK
Un Virtual Link es un enlace que permite la interconectividad de reas
discontinuas o la conexin de un rea que no est conectada al rea 0.
(Garrett, 2006)

III.

ESCENARIO Y CONFIGURACIN

Conmutacin y Ruteo II
2

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

DIRRECIONAMIENTO EN LAS COMPUTADORAS


Conmutacin y Ruteo II
3

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

Pc-1
sudo su
ifconfig eth0 192.168.10.2 netmask 255.255.255.0 up
route add default gw 192.168.10.1
Pc-2
sudo su
ifconfig eth0 192.168.11.2 netmask 255.255.255.0 up
route add default gw 192.168.11.1
Pc-3
sudo su
ifconfig eth0 192.168.40.3 netmask 255.255.255.0 up
route add default gw 192.168.40.1
Pc-4
sudo su
ifconfig eth0 192.168.41.3 netmask 255.255.255.0 up
route add default gw 192.168.41.1

Ejemplo de Configuraciones de direccionamiento en PC Centos: PC4

DIRRECIONAMIENTO DE LOS ROUTERS:

Conmutacin y Ruteo II
4

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

Ejemplo de Configuraciones de direccionamiento en Router Cisco: R1

Ejemplo de Configuraciones de direccionamiento en Router Juniper: Juniper-1

CONFIGURACIN DE OSPF MULTIREA:

Conmutacin y Ruteo II
5

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes
ROUTERS CISCO: R1, R2, R7, R8
Router1
Router ospf 10
router-id 1.1.1.1
network 192.168.10.0 0.0.0.255 area 1
network 192.168.11.0 0.0.0.255 area 1
network 172.20.4.0 0.0.0.3 area 2
Router2
Router ospf 10
router-id 2.2.2.2
network 172.20.4.0 0.0.0.3 area 2
network 172.20.8.0 0.0.0.3 area 2
Router7
Router ospf 10
router-id 7.7.7.7
network 172.20.24.0 0.0.0.3 area 3
network 172.20.28.0 0.0.0.3 area 3
Router8
Router ospf 10
router-id 8.8.8.8
network 172.20.28.0 0.0.0.3 area 3
network 192.168.40.0 0.0.0.255 area 4
network 192.168.41.0 0.0.0.255 area 4

Conmutacin y Ruteo II
6

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

Ejemplo de Configuraciones de OSPF en Router Cisco: R2

ROUTER JUNIPER: R3, R4, R5, R6


Router3
set routing-options router-id 3.3.3.3
set protocols ospf area 0.0.0.2 interface em0
set protocols ospf area 0.0.0.0 interface em1
commit
Router4
set routing-options router-id 4.4.4.4
set protocols ospf area 0.0.0.0 interface em0
set protocols ospf area 0.0.0.0 interface em1
commit
Router5
set routing-options router-id 5.5.5.5
set protocols ospf area 0.0.0.0 interface em0
set protocols ospf area 0.0.0.0 interface em1
commit
Router6
Conmutacin y Ruteo II
7

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes
set routing-options router-id 6.6.6.6
set protocols ospf area 0.0.0.0 interface em1
set protocols ospf area 0.0.0.3 interface em0
commit

Ejemplo de Configuraciones de OSPF en Router Juniper: Juniper-1

PING ENTRE ROUTER ANTES DE REALIZAR VIRTUAL LINKS

Router Cisco 1 Router Juniper 1

Conmutacin y Ruteo II
8

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

Router Juniper 1 - Router cisco 1

CONFIGURACIN VIRTUAL LINKS


VIRTUAL-LINK 1
Router Cisco / R1
router ospf 10
area 2 virtual-link 3.3.3.3
clear ip ospf process
Juniper-1 / R3
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 1.1.1.1 transit-area
0.0.0.2
commit

a)

b)
Configuracin del Virtual Link 1: a) Router Cisco b) Router Juniper

Conmutacin y Ruteo II
9

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes

Ping R1- Juniper-1

VIRTUAL-LINK 2
Router Cisco / R2
router ospf 10
area 3 virtual-link 6.6.6.6
clear ip ospf process
Juniper-4 / R7
set protocols ospf area 0.0.0.0 virtual-link neighbor-id 8.8.8.8 transit-area
0.0.0.3
commit

a)

b)

Configuracin del Virtual Link 2: a) Router Cisco b) Router Juniper

Conmutacin y Ruteo II
10

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO


FACULTAD DE INFORMTICA Y ELECTRNICA
Escuela de Ingeniera Electrnica en Telecomunicaciones y Redes
Ping Juniper-4 a R1

PING DE EXTREMO A EXTREMO

Ping R1 a R2

IV.

BIBLIOGRAFA
Cisco. (2015). CCNA Routing & Switching Curso Mdulo 3.
Garrett, A. (2006). Junos CookBook. (M. Loukides, Ed.) Estados Unidos: OReilly
Media.
Rodrgez, G. G. (2012). Router y Switches Cisco. Argentina: DALGAS.

Conmutacin y Ruteo II
11