Вы находитесь на странице: 1из 3

hostname R1

!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial1/0
ip address 172.16.13.1 255.255.255.252
no shut
!
interface Serial1/1
ip address 172.16.12.1 255.255.255.252
no shut
!
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 172.16.12.0 0.0.0.255 area 0
network 172.16.13.0 0.0.0.255 area 0
!
router bgp 65001
network 1.1.1.1 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 65001
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 65001
neighbor 3.3.3.3 update-source Loopback0
!
line con 0
exec-timeout 0 0
logging synchronous
history size 100
!
end
==========
hostname R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial1/0
ip address 172.16.12.2 255.255.255.252
no shut
!
interface Serial1/1
ip address 192.168.0.2 255.255.255.252
no shut
!
router ospf 1
network 2.2.2.2 0.0.0.0 area 0
network 172.16.12.0 0.0.0.3 area 0
!
router bgp 65001
network 2.2.2.2 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 65001
neighbor 3.3.3.3 update-source Loopback0
neighbor 172.31.0.1 remote-as 65000
neighbor 172.31.0.1 ebgp-multihop 2
neighbor 172.31.0.1 update-source Loopback0
!

ip route 172.31.0.0 255.255.0.0 Serial1/1


!
line con 0
exec-timeout 0 0
logging synchronous
history size 100
!
end
===========
hostname R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial1/0
ip address 192.168.0.6 255.255.255.252
no shut
!
interface Serial1/1
ip address 172.16.13.2 255.255.255.252
no shut
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 172.16.13.0 0.0.0.255 area 0
!
router bgp 65001
bgp default local-preference 200
network 3.3.3.3 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 65001
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 65001
neighbor 2.2.2.2 update-source Loopback0
neighbor 172.31.0.1 remote-as 65000
neighbor 172.31.0.1 ebgp-multihop 2
neighbor 172.31.0.1 update-source Loopback0
no auto-summary
!
ip route 172.31.0.0 255.255.0.0 Serial1/0
!
line con 0
exec-timeout 0 0
logging synchronous
history size 100
!
end
=============
hostname R4
!
interface Loopback0
ip address 172.31.0.1 255.255.254.0
!
interface Loopback1
ip address 172.31.2.1 255.255.255.128
!
interface Loopback2
ip address 172.31.2.129 255.255.255.224
!

interface Loopback3
ip address 172.31.2.161 255.255.255.248
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
no shut
!
interface Serial1/0
ip address 192.168.0.5 255.255.255.252
no shut
!
interface Serial1/1
ip address 192.168.0.1 255.255.255.252
no shut
!
router bgp 65000
network 172.31.0.0
neighbor 2.2.2.2 remote-as 65001
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 65001
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 Serial1/1
ip route 3.3.3.3 255.255.255.255 Serial1/0
ip route 172.31.0.0 255.255.0.0 Null0
!
line con 0
exec-timeout 0 0
logging synchronous
history size 100
!
end

Вам также может понравиться