Вы находитесь на странице: 1из 7

[[Site1]]

enable
conf t
Configure the router host name:
hostname Site-1
Protect privileged EXEC mode from unauthorized access with the MD5 encrypted password.
enable secret cisco
Prevent device status messages from interrupting command line entries at the device console.
line con 0
logging synchronous

Secure the router console and terminal lines.

password cisco
login
exit
line vty 0 15
login
exit
Prevent all passwords from being viewed in clear text in the device configuration file.
service password-encryption
Configure a message-of-the-day banner.
banner motd
# Warning! #

Step 3: Configure the Router Physical Interfaces


int s0/0/0
bandwidth 128
ip address 192.168.10.105 255.255.255.252
description [Police and Central]
clock rate 128000
no shutdown
exit

Step 4: Configure static and default routing


ip route 0.0.0.0 0.0.0.0 s0/0/0

[[HQ]]
enable
conf t

Configure the Router Physical Interfaces


interface Serial0/0/0
bandwidth 128
ip address 192.168.10.106 255.255.255.252
no shutdown
exit
interface Serial0/0/1
bandwidth 128
ip address 192.168.10.114 255.255.255.252
clock rate 128000
no shutdown
exit
interface g0/0
ip address 192.168.18.41 255.255.255.248
no shutdown
exit
interface Serial0/1/0
ip address 198.51.100.1 255.255.255.240
no shutdown
Configure static and default routing
ip route 0.0.0.0 0.0.0.0 s0/1/0
ip route 192.168.200.0 255.255.252.0 s0/0/1
[[Site2]]
enable
conf t
Configure the Router Physical Interfaces
interface Serial0/0/1
bandwidth 128
ip address 192.168.10.113 255.255.255.252
no shutdown
Configure static and default routing
ip route 0.0.0.0 0.0.0.0 s0/0/1
ip route 192.168.200.0 255.255.252.0 s0/0/0
[[Site1]]
Step 5: Configure OSPF Routing
router ospf 10
router-id 1.1.1.1
network 192.168.10.104 0.0.0.3 area 0
network 192.168.45.0 0.0.0.255 area 0
network 192.168.47.0 0.0.0.255 area 0
network 192.168.101.0 0.0.0.255 area 0
Prevent routing updates from being sent out of any of the LAN interfaces that are routed with
OSPFv2.

passive-interface g0/0.45
passive-interface g0/0.47
passive-interface g0/0.101
exit
interface s0/0/0
bandwidth 128
ip ospf cost 7500
exit
[[HQ]]
Step 5: Configure OSPF Routing
router ospf 10
router-id 2.2.2.2
network 192.168.10.104 0.0.0.3 area 0
network 192.168.10.112 0.0.0.3 area 0
network 192.168.18.40 0.0.0.7 area 0
Prevent routing updates from being sent out of any of the LAN interfaces that are routed with
OSPFv2.
passive-interface g0/0
exit
interface s0/0/0
bandwidth 128
ip ospf cost 7500
exit
interface s0/0/1
bandwidth 128
exit
[[Site2]]
Step 5: Configure OSPF Routing
router ospf 10
router-id 3.3.3.3
network 192.168.10.112 0.0.0.3 area 0
exit
interface s0/0/1
bandwidth 128
exit
Configure VLANs and Trunking
Configure names for the VLANs
[[SW1]]
enable
conf t
vlan 45

name finance
exit
vlan 47
name sales
exit
vlan 101
name netadmin
exit
int g1/1
switchport mode trunk
no shutdown
exit
int g1/2
switchport mode trunk
no shutdown
exit
Assign the switch ports shown in the table as access ports in the VLANs
int fa0/10
switchport mode access
switchport access vlan 45
exit
int fa0/15
switchport mode access
switchport access vlan 47
exit
interface vlan 101
ip address 192.168.101.2 255.255.255.0
exit
Configure all unused switch ports as access ports, and shutdown the unused ports.
int range fa0/1-9, fa0/11-14, fa0/16-24
switchport mode access
shutdown
exit
ip default-gateway 192.168.101.1
[[SW2]]

Configure names for the VLANs


enable
conf t
vlan 45
name HR
exit
vlan 47
name records
exit
vlan 101
name comm
exit
int g1/1
switchport mode trunk
no shutdown
exit
Assign the switch ports shown in the table as access ports in the VLANs
int fa0/3
switchport mode access
switchport access vlan 45
exit
Assign the switch ports shown in the table as access ports in the VLANs
int fa0/21
switchport mode access
switchport access vlan 47
exit
interface vlan 101
ip address 192.168.101.3 255.255.255.0
exit
Configure all unused switch ports as access ports, and shutdown the unused ports.
int range fa0/1-2, fa0/4-20, fa0/22-24
switchport mode access
shutdown
exit
ip default-gateway 192.168.101.1

[[Site1]]
Configure DHCP
ip dhcp excluded-address 192.168.45.1 192.168.45.20
ip dhcp excluded-address 192.168.47.1 192.168.47.20
ip dhcp pool VLAN45
network 192.168.45.0 255.255.255.0
default-router 192.168.45.1
dns-server 192.168.18.100
exit
ip dhcp pool VLAN47
network 192.168.47.0 255.255.255.0
default-router 192.168.47.1
dns-server 192.168.18.100
exit
*****SET CLIENTS TO DHCP*****
[[HQ]]
Configure NAT
ip nat inside source static 192.168.18.46 198.51.100.14
interface g0/0
ip nat inside
exit
interface s0/1/0
ip nat outside
exit
ip nat pool INTERNET 198.51.100.3 198.51.100.13 netmask 255.255.255.240
ip nat inside source list 1 pool INTERNET
ip nat inside source static 192.168.18.46 198.51.100.14
ip access-list standard 1
Configure Access Control Lists
permit 192.168.45.0 0.0.0.255
permit 192.168.47.0 0.0.0.255
permit 192.168.200.0 0.0.3.255
exit
interface Serial0/1/0
ip access-group 101 in
exit

access-list 1 permit 192.168.45.0 0.0.0.255


access-list 1 permit 192.168.47.0 0.0.0.255
access-list 1 permit 192.168.200.0 0.0.3.255
ip access-list standard MANAGE
permit host 203.0.113.18
exit
access-list 101 permit ip host 203.0.113.18 any
access-list 101 permit tcp any host 198.51.100.14 eq www
access-list 101 permit tcp any any established
access-list 101 deny ip any any
line vty 0 15
access-class MANAGE in
password cisco
login
exit
[[Site1]]
interface g0/0
no sh
exit
Configure Router-on-a-Stick Inter-VLAN Routing
interface g0/0.45
encapsulation dot1Q 45
ip address 192.168.45.1 255.255.255.0
exit
interface g0/0.47
encapsulation dot1Q 47
ip address 192.168.47.1 255.255.255.0
exit
interface g0/0.101
encapsulation dot1Q 101
ip address 192.168.101.1 255.255.255.0
exit

Вам также может понравиться