Вы находитесь на странице: 1из 21

Taller de Condicionales

Introduccin a la programacin
Jess David Galindo

EXTRACTO
En un algoritmo puede existir una condicin que bifurque el
flujo normal del conjunto de instrucciones de acuerdo a la
decisin que se tome.

PESEINT
1. Un hombre desea saber cunto dinero se genera por concepto
de intereses sobre la cantidad que tiene en inversin en el
banco. El decidir reinvertir los intereses siempre y cuando
estos excedan a $7000, Y en ese caso desea saber cunto dinero
tendr finalmente en su cuenta.
Proceso interes
Escribir "digite el monto que hay en el banco:";
Leer m;
Escribir "digite el porcentaje de interes:"
leer pin;
i<-(m*pin)/100;
mt<-m+i;
Escribir "el interes es:",i;
si (i>7000) entonces escribir " el monto total en el banco es:",mt;
FinSi
si (i<7000) entonces Escribir "el monto total en el banco es:",m;
FinSi
FinProceso
2.Determinar si un alumno aprueba o reprueba un curso,
sabiendo que aprobara si su promedio de tres calificaciones es
mayor o igual a 70; reprueba en caso contrario.
Proceso materias
Escribir "digite la nota de la primer materia:";
Leer pm;
Escribir "digite la nota de la segunda materia:";
Leer sm;
Escribir "digite la nota de la tercer materia:";
Leer tm;
p<-(pm+sm+tm)/3;
si (p>=70) entonces escribir "APRUEBA EL CURSO";
FinSi
si (p<70) entonces escribir "REPRUEBA EL CURSO";
FinSi
FinProceso
3.En un almacn se hace un 20% de descuento a los clientes
cuya compra supere los $1000 Cul ser la cantidad que pagara
una persona por su compra?
Proceso descuento
Escribir "digite el valor de la compra:";

Leer c;
cf<-c-(c*0.2);
si (c>1000) entonces escribir "el valor a pagar es:",cf;
FinSi
si (c<1000) entonces Escribir "el valor a pagar es:",c;
FinSi
FinProceso
4.Un obrero necesita calcular su salario semanal el cual se
obtiene de la sig. Manera:
Si trabaja 40 horas o menos se le paga $16 por hora
Si trabaja ms de 40 horas se le paga $16 por cada una de las
primeras 40 horas y $20 por cada hora extra.
Proceso salariosemanal
Escribir "Digite el numero de horas de trabajo";
Leer ht;
s=16*ht;
si (ht<= 40) entonces Escribir "Su salario es:",s;
FinSi
si (ht> 40) entonces Escribir "Digite el numero de horas extras:";
leer he;
ss=s+(20*he);
Escribir "Su salario es:",ss;
FinSi
FinProceso
5. Que lea dos nmeros y los imprima en forma ascendente.
Proceso dosnumeros
Escribir "Ingrese el primer numero:";
Leer pn;
Escribir "Ingrese el segundo numero:";
Leer sn;
si(pn>sn) Entonces
Escribir " Sus numeros en orden ascendente:1)",sn;
Escribir "
2)",pn;
FinSi
si (sn>pn) Entonces
Escribir " Sus numeros en orden ascendente:1)",pn;
Escribir "
2)",sn;
FinSi
FinProceso

6.Una persona enferma, que pesa 70 kg, se encuentra en reposo


y desea saber cuntas caloras consume su cuerpo durante todo
el tiempo que realice una misma actividad. Las actividades que
tiene permitido realizar son nicamente dormir o estar sentado
en reposo. Los datos que tiene son que estando dormido
consume 1.08 caloras por minuto y estando sentado en reposo
consume 1.66 caloras por minutos
Proceso calorias
Escribir "Ingrese la actividad realizada (dormir:1 o reposo:2)";
Leer act;
Escribir "Ingrese el numero de minutos utilizados:";
Leer m;
cd=1.08*m;
cr=1.66*m;
si (act=1) Entonces
Escribir "Las calorias gastadas son:",cd;
FinSi
Si (act=2) entonces
Escribir "Las calorias gastadas son:", cr;
FinSi
FinProceso
7. Hacer un algoritmo que imprima
clave, precio original y su precio con
hace en base a la clave, si la clave es
y si la clave es 02 el descuento es
claves)

el nombre de un artculo,
descuento. El descuento lo
01 el descuento es del 10%
del 20% (solo existen dos

Proceso precio
Escribir "Ingrese el nombre del articulo:";
Leer n;
Escribir "Ingrese la clave (1 o 2):";
Leer c;
Escribir "Ingrese el precio original:";
Leer po;
si (c=1)Entonces
Escribir "El precio con descuento es:", po*0.9;
FinSi
si (c=2) Entonces
Escribir "El precio con descuento es:", po*0.8;
FinSi
FinProceso

8. Hacer un algoritmo que calcule el total a pagar por la compra


de camisas. Si se compran tres camisas o ms se aplica un
descuento del 20% sobre el total de la compra y si son menos de
tres camisas un descuento del 10%.
Proceso camisas
Escribir "Digite el numero de camisas que va a comprar:";
Leer c;
Escribir "Digite el total de la compra:";
Leer v;
si (c>=3) Entonces
Escribir "El valor total a pagar es:",v*0.8;
FinSi
si (c<3) Entonces
Escribir "El valor total a pagar es:",v*0.9;
FinSi
FinProceso
9. Una empresa quiere hacer una compra de varias piezas de la
misma clase a una fbrica de refracciones. La empresa,
dependiendo del monto total de la compra, decidir qu hacer
para pagar al fabricante.
Si el monto total de la compra excede de $500.000 la empresa
tendr la capacidad de invertir de su propio dinero un 55% del
monto de la compra, pedir prestado al banco un 30% y el resto
lo pagara solicitando un crdito al fabricante.
Si el monto total de la compra no excede de $500.000la empresa
tendr capacidad de invertir de su propio dinero un 70% y el
restante 30% lo pagara solicitando crdito al fabricante.
El fabricante cobra por concepto de inters un 20% sobre la
cantidad que se le pague a crdito.
Proceso Empresa
Escribir "Digite el valor de la compra:";
Leer vc;
dp<-vc*0.55;
pb<-vc*0.3;

f<-vc*0.15;
if<-f*0.2;
dp2<-vc*0.7;
f2<-vc*0.3;
if2<-f2*0.2;
si (vc>500000) Entonces
Escribir "Debe invertir de su propio dinero:",dp;
Escribir "Debe pedir prestado al banco:",pb;
Escribir "Debe pedir un crdito al fabricante de:",f;
Escribir "Debe pagar un interes al fabricante de:",if;
FinSi
si (vc<=500000) Entonces
Escribir "Debe invertir de su propio dinero:",dp2;
Escribir "Debe pedir un crdito al fabricante de:",f2;
Escribir "Debe pagar un interes al fabricante de:",if2;
FinSi
FinProceso

10. Calcular el total que una persona debe pagar en una


llantera, si el precio de cada llanta es de $800 si se compran
menos de 5 y de $700 si se compran 5 o mas.
Proceso llantas
Escribir "Digite el numero de llantas que desea comprar:";
Leer n;
si (n>= 5) Entonces
Escribir "El valor a pagar es:", n*700;
FinSi
si (n<5) Entonces
Escribir "El valor a pagar es:", n*800;
FinSi
FinProceso

ZINJAI COUT
1. Un hombre desea saber cunto dinero se genera por concepto
de intereses sobre la cantidad que tiene en inversin en el
banco. El decidir reinvertir los intereses siempre y cuando
estos excedan a $7000, Y en ese caso desea saber cunto dinero
tendr finalmente en su cuenta.
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system("color f9");
int c,i,pi,cf;
cout<<"ingrese la cantidad de dinero a invertir:"<<ends;
cin>>c;
cout<<"ingrese el porcentaje de interes:"<<ends;
cin>>pi;
i=(c*pi)/100;
cout<<"el interes es:"<<i<<endl;
if (i>7000)
{
cf=c+i;
cout<<"su dinero es:"<<cf<<endl;
}
else
{
cout<<"su dinero es:"<<c<<endl;
}

return 0;
}
2. Determinar si un alumno aprueba o reprueba un curso,
sabiendo que aprobara si su promedio de tres calificaciones es
mayor o igual a 70; reprueba en caso contrario.
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
int m1,m2,m3,p;
system ("color f9");
cout<<"Digite la nota de la primer materia:"<<endl;
cin>> m1;
cout<<"Digite la nota de la segunda materia:"<<endl;
cin>> m2;
cout<<"Digite la nota de la tercer materia;"<<endl;
cin>> m3;
p=(m1+m2+m3)/3;
if (p>=70)
{
cout<<"Aprueba el curso"<<ends;
}
else
{
cout<<"Reprueba el curso"<<ends;
}
return 0;
}
3.En un almacn se hace un 20% de descuento a los clientes
cuya compra supere los $1000 Cul ser la cantidad que pagara
una persona por su compra?

#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system("color f9");
float c,pc;
cout<<"Digite el total de la compra:"<<ends;
cin>>c;
pc= c - (c*0.2);
if (c>1000)
{
cout<<"el total a pagar es:"<<pc<<ends;
}
else
{
cout<<"el total a pagar es:"<<c<<ends;
}
return 0;
}
4.Un obrero necesita calcular su salario semanal el cual se
obtiene de la sig. Manera:
Si trabaja 40 horas o menos se le paga $16 por hora
Si trabaja ms de 40 horas se le paga $16 por cada una de las
primeras 40 horas y $20 por cada hora extra.
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
int ht,s,he,sd;
cout <<"horas de trabajo"<<endl;
cin>>ht;
s=(ht*16);

he=(ht-40);
sd=(40*16)+(he*20);
if (ht<=40)
{
cout<<"el salario es de:"<<s<<endl;
}
if (ht>40)
{
cout<<"el salario es de:"<<sd<<endl;
}
return 0;
}
5.Que lea dos nmeros y los imprima en forma ascendente.
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system("color f9");
int pn,sn;
cout<<"ingrese el primer numero:"<<ends;
cin>>pn;
cout<<"ingrese el segundo numero:"<<ends;
cin>>sn;
if (sn>pn)
{
cout<<"Los numeros ordenados en forma ascendente
son:1)"<<pn<<endl;
cout<<"
2)"<<sn<<endl;
}
else
{

cout<<"Los numeros ordenados en forma ascendente


son:1)"<<sn<<endl;
cout<<"
2)"<<pn<<endl;
}
return 0;
}
6.Una persona enferma, que pesa 70 kg, se encuentra en
reposo y desea saber cuntas caloras consume su cuerpo
durante todo el tiempo que realice una misma actividad. Las
actividades que tiene permitido realizar son nicamente
dormir o estar sentado en reposo. Los datos que tiene son
que estando dormido consume 1.08 caloras por minuto y
estando sentado en reposo consume 1.66 caloras por
minutos
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system("color f9");
float act, t, cd, cr;
cout<<"Digite la actividad que realizo (1 para domir, 2 para
resposo):"<<ends;
cin>> act;
cout<< "Digite los minutos que duro realizando la
actividad:"<<ends;
cin>> t;
cd=1.08*t;
cr=1.66*t;
if (act=1)
{
cout<< "Las calorias consumidas son:"<<cd<<ends;
}
if (act=2)
{
cout<< "Las calorias consumidas son:"<<cr<<ends;
}
return 0;
}
8. Hacer un algoritmo que calcule el total a pagar por la
compra de camisas. Si se compran tres camisas o ms se
aplica un descuento del 20% sobre el total de la compra y si
son menos de tres camisas un descuento del 10%.

#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
float c,v,vt,vt2;
system ("color f9");
cout<<"Digite el numero de camisas que va a comprar:"<<ends;
cin>> c;
cout<<"Digite el total de la compra:"<<ends;
cin>> v;
if (c>=3)
{
vt= (v-(v*0.2));
}
cout<<"El valor total a pagar es:"<<vt<<endl;
if (c<3)
{
vt2= (v-(v*0.1));
cout<<"El valor total a pagar es:"<<vt2<<endl;
}
return 0;
}
9.Una empresa quiere hacer una compra de varias piezas de la
misma clase a una fbrica de refracciones. La empresa,
dependiendo del monto total de la compra, decidir qu hacer
para pagar al fabricante.
Si el monto total de la compra excede de $500.000 la empresa
tendr la capacidad de invertir de su propio dinero un 55% del
monto de la compra, pedir prestado al banco un 30% y el resto
lo pagara solicitando un crdito al fabricante.
Si el monto total de la compra no excede de $500.000la empresa
tendr capacidad de invertir de su propio dinero un 70% y el
restante 30% lo pagara solicitando crdito al fabricante.
El fabricante cobra por concepto de inters un 20% sobre la
cantidad que se le pague a crdito.
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
float pc,dp,pb,f,pf,dp2,f2,if2;
cout<<"Digite el precio de la compra:"<<endl;

cin>> pc;
dp=pc*0.55;
pb=pc*0.3;
f=pc*0.15;
pf=f*0.2;
dp2=pc*0.7;
f2=pc*0.3;
if2=f2*0.2;
if (pc>500000)
{
cout<<"Debe invertir de su propio dinero:"<<dp<<endl;
cout<<"Debe pedir prestado al banco:"<<pb<<endl;
cout<<"Debe pedir un crdito al fabricante de:"<<f<<endl;
cout<<"Debe pagar un interes al fabricante de:"<<pf<<endl;
}
if (pc<500000)
{
cout<<"Debe invertir de su propio dinero:"<<dp2<<endl;
cout<<"Debe pedir un crdito al fabricante de:"<<f2<<endl;
cout<<"Debe pagar un interes al fabricante de:"<<if2<<endl;
}
return 0;
}
10.Calcular el total que una persona debe pagar en una llantera,
si el precio de cada llanta es de $800 si se compran menos de 5
y de $700 si se compran 5 o mas.
#include <iostream>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
int c,v1,v2;
system("color f9");
cout<<"Digite la cantidad de llantas a comprar:"<<ends;
cin>> c;
v1=c*700;
v2=c*800;
if (c>= 5)
{
cout<< "El valor a pagar es:"<<v1<<ends;
}
if (c<5)
{
cout<< "El valor a pagar es:"<<v2<<ends;

}
return 0;
}

ZINJAI PRINTF
1. Un hombre desea saber cunto dinero se genera por concepto
de intereses sobre la cantidad que tiene en inversin en el
banco. El decidir reinvertir los intereses siempre y cuando
estos excedan a $7000, Y en ese caso desea saber cunto dinero
tendr finalmente en su cuenta.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
int m,ip,mi,mt;
printf ("\n Digite el monto que hay en el banco:");
scanf ("%d",&m);
printf ("\n digite el porcentaje de interes:");
scanf ("%d",&ip);
mi=(m*ip)/100;
mt=m+mi;

printf ("\n EL monto del interes es:%d",mi);


if (mi>7000)
{
printf ("\n El monto total en el banco es de:%d",mt);
}
if (mi<7000)
{
printf ("\n El monto total en el banco es de:%d",m);
}
return 0;
}

2.Determinar si un alumno aprueba o reprueba un curso,


sabiendo que aprobara si su promedio de tres calificaciones es
mayor o igual a 70; reprueba en caso contrario.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
float m1,m2,m3,p;
printf ("\n digite la primer nota:");
scanf ("%f",&m1);
printf ("\n digite la segunda nota:");
scanf ("%f",&m2);
printf ("\n digite la tercer nota:");

scanf ("%f",&m3);
p=(m1+m2+m3)/3;
if (p>=70)
{
printf ("\n Aprueba el curso %.2f",p);
}
if (p<70)
{
printf ("\n Reprueba el curso %.2f",p);
}
return 0;
}
3.En un almacn se hace un 20% de descuento a los clientes
cuya compra supere los $1000 Cul ser la cantidad que pagara
una persona por su compra?
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
int vt,vc;
printf ("\n Digite el valor de la compra:");
scanf ("%d",&vc);
vt=vc*0.8;
if (vc>1000);
{
printf ("\n El valor total de la compra con descuento es:%d",vt);
}
if (vc<1000)
{
printf ("\n El valor total de la compra con descuento es:%d",vc);
}
return 0;
}
4.Un obrero necesita calcular su salario semanal el cual se
obtiene de la sig. Manera:
Si trabaja 40 horas o menos se le paga $16 por hora
Si trabaja ms de 40 horas se le paga $16 por cada una de las
primeras 40 horas y $20 por cada hora extra.
#include <iostream>

#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
int h,he,s1,s2;
printf ("\n Digite el numero de horas que trabaja:");
scanf ("%d",&h);
s1=(h*16);
s2=((s1)+(he*20));
if (h<=40)
{
printf ("\n El salario sera:%d",s1);
}
if (h>40)
{
printf ("\n Digite el numero de horas extra que trabaja:");
scanf ("%d",&he);
printf ("\n El salario sera:%d",s2);
}
return 0;
}
5. Que lea dos nmeros y los imprima en forma ascendente.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
int pn,sn;
printf ("\n Digite el primer numero:");
scanf ("%d",&pn);
printf ("\n Digite el segundo numero:");
scanf ("%d",&sn);
if (sn>pn)
{
printf ("\n Los numeros en orden ascendente son:%d",pn);
printf ("\n
%d",sn);
}
if (pn>sn)
{
printf ("\n Los numeros en orden ascendente son:%d",sn);
printf ("\n
%d",pn);

}
return 0;
}
6.Una persona enferma, que pesa 70 kg, se encuentra en reposo
y desea saber cuntas caloras consume su cuerpo durante todo
el tiempo que realice una misma actividad. Las actividades que
tiene permitido realizar son nicamente dormir o estar sentado
en reposo. Los datos que tiene son que estando dormido
consume 1.08 caloras por minuto y estando sentado en reposo
consume 1.66 caloras por minutos
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
float act,mt,cd,cr;
printf ("\n Digite la actividad realizada (1 para dormir, 2 para
reposo):");
scanf ("%f",&act);
printf ("\n Digite los minutos utilizados:");
scanf ("%f",&mt);
cd=1.08*mt;
cr=1.66*mt;
if (act=1)
{
printf ("\n Las calorias gastasdas son:%.3f",cd);
}
else
{
printf ("\n Las calorias gastadas son:%.3f",cr);
}
return 0;
}
7.Hacer un algoritmo que imprima el nombre de un artculo,
clave, precio original y su precio con descuento. El descuento lo
hace en base a la clave, si la clave es 01 el descuento es del 10%
y si la clave es 02 el descuento es del 20% (solo existen dos
claves)
#include <iostream>
#include <stdio.h>

#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
int na,c,pa,p1,p2;
system ("color f9");
printf ("\n Digite el nombre del articulo:");
scanf ("%d",&na);
printf ("\n Digite la clave (1 o 2):");
scanf ("%d",&c);
printf ("\n Digite el precio original:");
scanf ("%d",&pa);
p1=pa*0.9;
p2=pa*0.8;
if (c=1)
{
printf ("\n El precio con descuento es:%d",p1);
}
else
{
printf ("\n El precio con descuento es:%d",p2);
}
return 0;
}
8.Hacer un algoritmo que calcule el total a pagar por la compra
de camisas. Si se compran tres camisas o ms se aplica un
descuento del 20% sobre el total de la compra y si son menos de
tres camisas un descuento del 10%.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
float nc, tc, pc1, pc2;
printf ("\n Digite el numero de camisas que va a comprar:");
scanf ("%f",&nc);
printf ("\n Digite el total de la compra:");
scanf ("%f",&tc);
pc1= tc - (tc*0.2);
pc2= tc - (tc*0.1);

if (nc<3)
{
printf ("\n El valor total a pagar es:%.2f",pc2);
}
else
{
printf ("\n El valor total a pagar es:%.2f",pc1);
}
return 0;
}
9.Una empresa quiere hacer una compra de varias piezas de la
misma clase a una fbrica de refracciones. La empresa,
dependiendo del monto total de la compra, decidir qu hacer
para pagar al fabricante.
Si el monto total de la compra excede de $500.000 la empresa
tendr la capacidad de invertir de su propio dinero un 55% del
monto de la compra, pedir prestado al banco un 30% y el resto
lo pagara solicitando un crdito al fabricante.
Si el monto total de la compra no excede de $500.000la empresa
tendr capacidad de invertir de su propio dinero un 70% y el
restante 30% lo pagara solicitando crdito al fabricante.
El fabricante cobra por concepto de inters un 20% sobre la
cantidad que se le pague a crdito.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
float pc,dp,pb,f,pf,dp2,f2,if2;
printf ("\nDigite el precio de la compra:");
scanf ("%f",&pc);
dp=pc*0.55;
pb=pc*0.3;
f=pc*0.15;
pf=f*0.2;
dp2=pc*0.7;
f2=pc*0.3;
if2=f2*0.2;
if (pc>500000)
{
printf("\nDebe invertir de su propio dinero:%.2f",dp);
printf("\nDebe pedir prestado al banco:%.2f",pb);

printf("\nDebe pedir un crdito al fabricante de:%.2f",f);


printf("\nDebe pagar un interes al fabricante de:%.2f",pf);
}
if (pc<500000)
{
printf("\nDebe invertir de su propio dinero:%.2f",dp2);
printf("\nDebe pedir un crdito al fabricante de:%.2f",f2);
printf("\nDebe pagar un interes al fabricante de:%.2f",if2);
}
return 0;
}
10. Calcular el total que una persona debe pagar en una
llantera, si el precio de cada llanta es de $800 si se compran
menos de 5 y de $700 si se compran 5 o mas.
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int main(int argc, char *argv[]) {
system ("color f9");
int n,p1,p2;
printf ("\n Digite el numero de llantas que va a comprar:");
scanf ("%d",&n);
p1=(n*800);
p2=(n*700);
if (n>=5)
{
printf ("\n El precio de las llantas es:%d",p2);
}
if (n<5)
{
printf ("\n El precio de las llantas es:%d",p1);
}
return 0;
}