Вы находитесь на странице: 1из 13

FRAME RELAY NETWORK

MUHAMAD AQEEL BIN MUFTI (51213114024)


Communication Technology Section, Universiti Kuala Lumpur British Malaysian Institute (UniKL-BMI),
Batu 8, Sungai Pusu, 53100 Kuala Lumpur.
aqeelmuft@icloud.com

I.

Abstract

handles the transmission over a frequency-

Frame Relay is a packet-switched


technology, meaning that each network end
user, or end node, will share backbone
network resources, such as bandwidth. It is
standardized
wide
area
networking
technology that specifies the physical and
logical
link
layers
of
digital
telecommunications channels using a packet
switching methodology.

changing path transparent to all end-users.


Network that will connect their HQ
in Kuala Lumpur between other branch in
Johor Bharu , Kuala Terengganu and Ipoh.
In order to enable the communication
Frame Relay are used. FR is the most

INTRODUCTION

suitable because each branch will share the

Frame Relay is a packet-switched

same backbone (KL). Moreover, using hub

technology, meaning that each network end

and spoke topology is the ideal network

user, or end node, will share backbone

that is connecting network that is divided

network resources, such as bandwidth. It is

geographically. The network topology are

standardized

networking

setup as shown in Appendix 1, this design

technology that specifies the physical and

with the latest technology for the network

logical

to runs efficiently and low cost.

II.

wide

link

area

layers

telecommunications

of

channels

digital
using

packet switching methodology.

III.

Connectivity between these end

ANALYSIS

PC 1

device is accomplished with the use of


Frame Relay virtual circuits (VCs). .
Network provider commonly implement
frame relay for voice (voFR) and data as
an

encapsulation

technique,

uses

in

between local area network(LAN) over a


wide area network (WAN). Each end-user
gets a private line (or leased line) to a
frame-relay node. The frame relay network

Figure 1:TCP/IP value PC 1

Figure 2:Ping from JB router to KT and IP


router

Figure 3:Ping from PC 1 to PC 2and PC3


PC 2

Figure 4: TCP/IP value PC 2

Figure 5: Ping from KT router to JB and IP


router

Figure 6: Ping from PC 2 to PC 1and PC3


PC 3

Figure 7: TCP/IP value PC 3

possible networks are assigned with a


network address.
In a Hub-and-spoke topology, the
HQ will be the physical hub. Other
physical site in the topology known as
spokes. Each spokes are connected via
Hub. Hub and Spoke are configured with
Serial Interface that will transmit the
Figure 8: Ping from IP router to JB and KT
router

packet from the PC to the Internet (Server).


Every Serial Port are been set with the
DLCI and the network name. Frame Relay
are been use to setup to update every
possible route in the network. To make a
frame relay configuration, DLCI number is
assigned to the serial port at a frame relay.
The DLCI assigned in the WAN serial port
as shown below in Figure 11.

Figure 9: Ping from PC 3 to PC 1and PC2

IV.

DISCUSSION

Frame Relay is a Layer 2 (data link)


wide-area network (WAN) protocol that
works at both Layer 1 (physical) and Layer
2 (data link) of the OSI model. This is
commonly used to access into WAN
resources. . This is commonly used to
access into WAN resources. The TCP/IP

Figure 11:The DLCI assigned in the WAN

Suite comprises two components: the IP

DLCIs are used to identify the PVC

operating at Layer 3 (Network) and the

that is provisioned to transport data traffic.

Transmission

(TCP)

DLCIs are of local significance, unless an

operating at Layer 4. Using network

agreement has been made with the network

topology given, the network is setup. All

service provider to deploy global DLCIs.

Control

Protocol

Local significance means that DLCIs are

V.

of use only to the local Frame Relay


network device

CONCLUSION

Frame Relay network that connect


KL, JB, KT and IP are successful in

The router configuration include

making communication connectivity. The

password for console, virtual line, and

connectivity is verified by using Ping

hostname. Next, for security purposes the

command. Next the connectivity of each of

router is set with password for both

user in this network (PC1, PC2 and PC3).

console and virtual are Cisco and for secret

Using EIGRP protocol is set in every

is class. The frame configuration begins


with the setting the encapsulation type to

router in network.
The network will runs smoothly

turn on frame relay encapsulation. The sub

and it will increase the efficiency of the

interface

manually

client worker. Moreover, the HQ might

assigned with DLCI number. In order to

able to supervise the progress happened in

allow interconnection between the router

every

network, a router protocol EIGRP are

Therefore

been used. Figure 12 shows the Frame

management cost.

are

created

and

branch
it

without
will

save

going

there.

the

client

Relay Configuration, this configuration


will legislation process of a router in the
network.

VI.

REFERENCES

1) http://en.wikipedia.org/wiki/Frame

_Relay
2) http://searchenterprisewan.techtarget.c
om/definition/frame-relay
3) http://docwiki.cisco.com/wiki/Frame_
Relay
4) http://www.omnisecu.com/basicnetworking/site-to-site-wan-networktopologies-hub-and-spoketopology.php

Figure 12:Frame Relay Configuration


APPENDIX
KL Router

User Access Verification

!
!

Password:

Password:

!
ip cef

KL>en

no ipv6 cef

Password:

KL#sh run

Building configuration...

!
!

Current configuration : 1612 bytes

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime


msec

!
!

no service password-encryption
no ip domain-lookup
!
!
hostname KL
!
!
spanning-tree mode pvst
!
!
!
!
enable secret 5
$1$mERr$9cTjUIEqNGurQiFU.ZeCi1

ip address 192.168.3.1 255.255.255.0

interface FastEthernet0/0

frame-relay interface-dlci 40

ip address 192.168.30.1 255.255.255.0

clock rate 2000000

duplex auto

speed auto

interface Serial0/0/0.50 point-to-point

description link to JB roter DLCI 50

interface FastEthernet0/1

ip address 192.168.4.1 255.255.255.0

no ip address

frame-relay interface-dlci 50

duplex auto

clock rate 2000000

speed auto

shutdown

interface Serial0/0/1

no ip address

interface Serial0/0/0

clock rate 2000000

no ip address

shutdown

encapsulation frame-relay

clock rate 2000000

interface Serial0/1/0

no ip address

interface Serial0/0/0.30 point-to-point

clock rate 2000000

description link to IP router DLCI 30

shutdown

ip address 192.168.2.2 255.255.255.0

frame-relay interface-dlci 30

interface Serial0/1/1

clock rate 2000000

no ip address

clock rate 2000000

interface Serial0/0/0.40 point-to-point

shutdown

description link to KT router DLCI 40

interface Vlan1

login

no ip address

shutdown

line aux 0

router eigrp 100

line vty 0 4

network 192.168.30.0

login

network 92.0.0.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

end

auto-summary
!
ip classless

JB Router
Password:

!
ip flow-export version 9
!
!
!

JB>en
Password:
JB#sh run
Building configuration...

!
!
!
!
line con 0

Current configuration : 1193 bytes


!
version 12.4
no service timestamps log datetime msec

password cisco

no service timestamps debug datetime


msec

logging synchronous

no service password-encryption

hostname JB

spanning-tree mode pvst

enable secret 5
$1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!
!

!
!
!
!
!
interface FastEthernet0/0
!
ip address 192.168.60.1 255.255.255.0
!
duplex auto
!
speed auto
ip cef
!
no ipv6 cef
interface FastEthernet0/1
!
no ip address
!
duplex auto
!
speed auto
!
shutdown
!
!
!
interface Serial0/0/0
!
no ip address
!
encapsulation frame-relay
!
!
!
interface Serial0/0/0.51 point-to-point
no ip domain-lookup

description link to KL router DLCI 51

network 192.168.60.0

ip address 192.168.4.2 255.255.255.0

network 192.168.4.0

frame-relay interface-dlci 51

auto-summary

clock rate 2000000

ip classless

interface Serial0/0/1

no ip address

ip flow-export version 9

clock rate 2000000

shutdown

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

line con 0

interface Serial0/1/1

password cisco

no ip address

logging synchronous

clock rate 2000000

login

shutdown

line aux 0

interface Vlan1

no ip address

line vty 0 4

shutdown

login

router eigrp 100

end

!
!

KT Router
KT>en
Password:
Password:
KT#sh run
Building configuration...

!
no ip cef
no ipv6 cef
!
!
!
!

Current configuration : 1189 bytes


!
version 12.4
no service timestamps log datetime msec

!
!
!
!

no service timestamps debug datetime


msec

no service password-encryption

no ip domain-lookup

hostname KT

spanning-tree mode pvst

enable secret 5
$1$mERr$9cTjUIEqNGurQiFU.ZeCi1

!
!

!
!
!

shutdown

interface FastEthernet0/0

ip address 192.168.50.1 255.255.255.0

interface Serial0/1/0

duplex auto

no ip address

speed auto

clock rate 2000000

shutdown

interface FastEthernet0/1

no ip address

interface Serial0/1/1

duplex auto

no ip address

speed auto

clock rate 2000000

shutdown

shutdown

interface Serial0/0/0

interface Vlan1

no ip address

no ip address

encapsulation frame-relay

shutdown

interface Serial0/0/0.41 point-to-point

router eigrp 100

description link to kl router DLCI 41

network 192.168.3.0

ip address 192.168.3.2 255.255.255.0

network 192.168.50.0

frame-relay interface-dlci 41

auto-summary

clock rate 2000000

ip classless

interface Serial0/0/1

no ip address

ip flow-export version 9

clock rate 2000000

!
!
!
!
!
!
line con 0
password cisco
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
!
!
end

IP Router
User Access Verification
Password:
IP>en
Password:
IP#sh run
Building configuration...
Current configuration : 1205 bytes
!

version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname IP
!
!
!
enable secret 5
$1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.40.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!

interface Serial0/0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0/0.31 point-to-point
description link to 192.168.2.3 router dlci
31
ip address 192.168.2.3 255.255.255.0
frame-relay interface-dlci 31
clock rate 2000000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown

!
router eigrp 100
network 192.168.40.0
network 192.168.2.0
auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
password cisco
logging synchronous
login
!
line aux 0
!
line vty 0 4
login
!
!
!
end