Вы находитесь на странице: 1из 8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

Iwing's Blog @_@

Dunia itu Berputar

Belajar Mengkonfigurasi BGP

https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

1/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

Belajar Mengkonfigurasi BGP


-------------------------------------------Topology yang digunakan :
-------------------------------------------(https://iwing.files.wordpress.com/2010/07/topology2.png)
-------------------------------------------Konfigurasi Router cnc1
-------------------------------------------cnc1#
interface Loopback100
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.0.2 255.255.255.252
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.0.0.1 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 1
!
router bgp 100
no synchronization
bgp log-neighbor-changes
redistribute ospf 1 route-map lan-subnet
neighbor 10.0.0.2 remote-as 100
neighbor 172.16.0.1 remote-as 200
no auto-summary
https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

2/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map lan-subnet permit 10
match ip address 10
set metric 100
-------------------------------------------Konfigurasi Router cnc2
-------------------------------------------cnc2#
interface Loopback100
ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
ip address 172.16.0.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
ip address 172.16.0.5 255.255.255.252
serial restart-delay 0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 172.16.0.0 mask 255.255.255.252
network 172.16.0.4 mask 255.255.255.252
network 192.168.1.0
neighbor iwing peer-group
neighbor iwing remote-as 100
neighbor 172.16.0.2 peer-group iwing
neighbor 172.16.0.6 peer-group iwing
no auto-summary
!
-------------------------------------------https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

3/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

Konfigurasi Router cnc3


-------------------------------------------cnc3#
interface Loopback100
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface Serial1/1
ip address 172.16.0.6 255.255.255.252
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.0.0.2 0.0.0.0 area 0
network 192.168.3.0 0.0.0.255 area 2
!
router bgp 100
no synchronization
bgp log-neighbor-changes
redistribute ospf 1 route-map lan-subnet
neighbor 10.0.0.1 remote-as 100
neighbor 172.16.0.5 remote-as 200
no auto-summary
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map lan-subnet permit 10
match ip address 10
set metric 100
!
https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

4/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

-------------------------------------------how to check 1 (sh ip route)


-------------------------------------------cnc1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 2 subnets
B
172.16.0.4 [20/0] via 172.16.0.1, 00:22:20
C
172.16.0.0 is directly connected, Serial1/0
10.0.0.0/30 is subnetted, 1 subnets
C
10.0.0.0 is directly connected, FastEthernet0/0
B
192.168.1.0/24 [20/0] via 172.16.0.1, 00:30:28
C
192.168.2.0/24 is directly connected, Loopback100
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
O IA
192.168.3.1/32 [110/2] via 10.0.0.2, 00:41:53, FastEthernet0/0
B
192.168.3.0/24 [200/100] via 10.0.0.2, 00:31:04
cnc1#
-------------------------------------------cnc2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

5/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

Gateway of last resort is not set


172.16.0.0/30 is subnetted, 2 subnets
C
172.16.0.4 is directly connected, Serial1/1
C
172.16.0.0 is directly connected, Serial1/0
C
192.168.1.0/24 is directly connected, Loopback100
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
B
192.168.2.0/24 [20/0] via 172.16.0.6, 00:22:33
B
192.168.2.1/32 [20/0] via 172.16.0.2, 00:31:31
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
B
192.168.3.1/32 [20/0] via 172.16.0.6, 00:22:33
B
192.168.3.0/24 [20/0] via 172.16.0.2, 00:31:31
cnc2#
-------------------------------------------cnc3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 2 subnets
C
172.16.0.4 is directly connected, Serial1/1
B
172.16.0.0 [20/0] via 172.16.0.5, 00:22:20
10.0.0.0/30 is subnetted, 1 subnets
C
10.0.0.0 is directly connected, FastEthernet0/0
B
192.168.1.0/24 [20/0] via 172.16.0.5, 00:22:20
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
B
192.168.2.0/24 [200/100] via 10.0.0.1, 00:31:35
https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

6/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

O IA
192.168.2.1/32 [110/2] via 10.0.0.1, 00:42:24, FastEthernet0/0
C
192.168.3.0/24 is directly connected, Loopback100
cnc3#
-------------------------------------------how to check 2 (ping)
-------------------------------------------cnc1#ping 192.168.1.1 source 192.168.2.1 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 4/98/244 ms
cnc1#
cnc3#ping 192.168.1.1 source 192.168.3.1 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.1
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 16/102/260 ms
cnc3#
-------------------------------------------ref:
[1]. BGP part 1 and part 2, URL: http://packetlife.net ,(Juli 2010)
2 Comments leave one
1. hasan PERMALINK
24 August 2010 3:53 AM
coba dong jelasin command2 nya..fungsi nya buat apa ajj..maklum anee newbii ^_^
REPLY

https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

7/8

11/14/2016

Belajar Mengkonfigurasi BGP | Iwing's Blog @_@

REPLY
iwing PERMALINK*
24 August 2010 6:19 AM
ic, terima kasih atas masukannya, kalau ada waktu insyaAllah saya paparkan mengenai command-command yang saya pakai
he3
REPLY

Create a free website or blog at WordPress.com.

https://iwing.wordpress.com/black-box/belajar-mengkonfigurasi-bgp/

8/8

Вам также может понравиться