Вы находитесь на странице: 1из 1

Default = 50% of interface's bandwidth

(config-if)# ip bandwidth-percent eigrp 50 30

Recommendation: set the bandwidth of point-topoint links to the speed of CIR of the single PVC
on the subinterface

Bandwidth control
Recommendation: set the bandwidth of
multipoint subinterfaces to around the total CIR
for all VCs assigned to the subinterface

nonstub routers do not send Query messages to


stub routers

1- using stub routers

for multipoint subinterfaces IOS first divides the


subinterface bandwidth by the number of
configured PVCs and then determines the
EIGRP percentage

1- connected subnets of enabled interfaces


using network command

(config-router)# eigrp stub



by default it will advertise only connected and
summary routes

Limiting scope of Queries

If a router receives a Query for a (prefix/prefix


length), does not have exact matching route, but
does have a summary route that includes it, that
router sends back a Reply and does not flood
the Query

2- using route summarization


2- connected subnets of interfaces referenced
using neighbor command

before exchanging routes each router fill its


topology table from 3 sources

3- prefixes learned by redistribution into EIGRP


from other routing protocols

After 90 seconds from sending Queries it will


send SIA-Query, and if it does not receive a
SIA-Reply it will take the neighborship down

the active timer is 3 minutes by default



(config-router)# timers active-time 2
Hello
Default metric =
( (10^7 / least-bandwidth (kbps) ) + cumulativedelay (tens of microseconds) ) * 256

Prefix

Prefix Length
Feasible Distance (FD)
Contains

Metric components: bandwidth, delay, reliability,


and load

Calculates 2 metrics for each route

Update

MTU and hop count

Messages

Advertised Distance (AD)


or
Reported Distance (RD)

Topology Info Exchange


route(s) with lowest FD

Successor

used with Ack message for topology data


exchange
2 types of routes

non-successor route(s) with AD less than the


FD of the successor

Feasible Successor

Query

Reply

it's better to change the delay not the bandwidth

Ack

Building Routing Table

Serial

1544 and 20000

GigE

1000,000 and 10

modifying bandwidth and delay

1- the spokes will not form neighborship

Default bandwidth (Kbps) and delay


(microseconds)

2- the Hup will not forward updates from one


spoke to another due to Split Horizon

FastE
Multipoint subinterfaces issue
(config-router)# metric weights 0 k1 k2 k3 k4 k5
Metric Tuning

Solution: disable split horizon on the Hup



(config-subif)# no ip split-horizon eigrp 50

Modify K values
# show ip protocols

Do not have to match on EIGRP routers

Time to consider a neighbour down

Hold timer

(config)# access-list 11 permit 10.11.1.0


(config-router)# offset-list 11 in 3 Serial 0/0

add 3 to the computed FD and AD for each
prefix received on Serial 0/0 and matched by
ACL 11

Offset Lists
Types

Time between hello messages

Hello timer

default hold timer:


15 seconds on LANs
60 seconds on interfaces with a bandwidth of T1
or slower with encapsulation of Frame Relay

Show ip eigrp interfaces

EIGRP
Default

Show ip protocols
Verification commands.

Show ip eigrp topology

timers

(config-if)# ip hold-time eigrp 50 6



Tells its neighbours to wait 6 seconds before
consider it down

Show ip route
Modify

Multicast ip: 244.0.0.10


Use RTP (Reliable Transport Protocol) for
update messages

(config-if)# ip hello-interval eigrp 50 2

Hello timer:
R# show ip eigrp interface detail serial 0/0

Hold timer:
repeating: show ip eigrp neighbours

(config)# key chain carkeys


(config-keychain)# key 1
(config-keychain-key)# string cisco
(config-keychain-key)# accept-lifetime 00:00:00
1 jan 2010
(config-keychain-key)# send-lifetime 00:00:00 1
jan 2010

Show ip eigrp neighbors

using ACL

Verify

(config)# access-list 2 deny 10.17.32.0


0.0.31.255
(config)# access-list 2 permit any

(config-router)# distribute-list 2 out

1- Create a Key Chain


Route Filtering

distribute-list

using prefix list

Neighborships
Authentication

(config-if)# ip authentication mode eigrp 50 md5


(config-if)# ip authentication key-chain eigrp 50
carkeys

(config)# ip prefix-list fred seq 5 deny


10.17.35.0/24 ge 25 le 25
(config)# ip prefix-list fred seq 10 deny
10.17.36.0/24 ge 26 le 26
(config)# ip prefix-list fred seq 15 deny 0.0.0.0/0
ge 30 le 30
(config)# ip prefix-list fred seq 20 permit
0.0.0.0/0 le 32

(config-router)# distribute-list prefix fred out

2- Enable it on the interface

Key number and key string must match on the


neighbouring routers
using route map
(config-router)# neighbor 192.168.1.2 serial 0/0

(config)# route-map RM deny 8


(config-route-map)# match ip address prefix-list
ANY
(config)# route-map RM permit 20

(config-router)# distribute-list route-map RM out

static config

when configured on an interface no dynamic


neighboring will work on that interface

(config)# ip route 0.0.0.0 0.0.0.0 S 0/0


(config-router)# network 0.0.0.0
less exact than OSPF, so they don't have to
have the same masks but the neighbor IP
should be in the range of addresses for the
subnet as known to the local router

same subnet

Default Routes

Requirements

not passive

2 options

flag a route for a classful network as a route that


can be used as a default route

(config)# ip default-network 192.31.7.0
(config-router)# network 192.31.7.0

same AS number
Can be done at any router
same K values

little practical importance

Route Summarization

same rules as OSPF

(config-if)# ip summary-address eigrp 50


10.16.0.0 255.255.0.0 5

When auto-summary is enabled, EIGRP will not


support discontiguous classful networks

Router ID
matters when injecting external routes into
EIGRP, the injecting router must have unique
RID

default is 4

(config-router)# maximum-paths 6

to allow unequal load sharing

Load balancing
(config-router)# variance 2

only FS can be placed on the routing table

Sami Alsubhi

V 1.2

100,000 and 100

Вам также может понравиться