Вы находитесь на странице: 1из 6

Clculo repeticin de un

da de la semana entre
fechas en Excel

Captulo

CLCULO REPETICIN DE UN DA DE LA SEMANA ENTRE FECHAS

Descargar el Archivo
"Necesito saber cuntos domingos hay entre dos fechas determinadas,
siendo, evidentemente, dichas fechas variables".
No existe ninguna funcin especfica para resolver directamente este
problema, por lo que tendremos que realizar algunos pasos y frmulas.
Vamos a desarrollar el modelo para calcular cuntos domingos, o
cualquier otro da de la semana que queramos especificar, hay entre dos
fechas determinadas.
Lo primero que vamos a realizar es un calendario diario de tos el ao
2009. Evidentemente si las fechas que necesitemos manejar se
encuentran entre 2009 y 2010, por ejemplo, entonces deberamos
realizar dicho calendario diario. Para ello nos situamos en la celda G1 y
escribimos 1/1/2009. En G2 escribimos la frmula =G1+1 y copiamos
dicha frmula hasta que aparezca el 31/12/2009 (que terminar
lgicamente en la fila 365):

Pg. 1

Luis M. Salinas
CLMS C.A.

Captulo

Clculo repeticin de un
da de la semana entre
fechas en Excel

Como se puede apreciar en la imagen le hemos dado el formato de


fecha en el que aparece tambin el nombre del da de la semana.
Seleccionamos el rango H1:H365 y le damos el nombre tablafecha.
Preparamos ahora la entrada de datos de la forma que se muestra en la
imagen e introducimos dos fecha, por ejemplo del 7 de Febrero al 15 de
Mayo:

A continuacin nos situamos en la celda H1 y escribimos la siguiente


frmula:
=RESIDUO(G1;7)
Hacemos doble clic en la parte inferior derecha de la celda H1 (copiado
inteligente) y la frmula se copiar hasta la fila 365. Si nos fijamos en
esta nueva columna calculada la funcin RESIDUO nos devuelve el
mismo resultado para cada uno de los das de la semana. A saber:

Preparamos la siguiente tabla:


Luis M. Salinas
CLMS C.A.

Pg. 2

Clculo repeticin de un
da de la semana entre
fechas en Excel

Captulo

Seleccionamos el rango J2:K8 y le damos el nombre diaresiduo.


Nos situamos en C4 y vamos a Datos/Validacin. Seleccionamos permitir
Lista y en Origen seleccionamos el rango J2:J8. De esta manera ya
tendremos nuestra lista desplegable en la celda C6 para elegir el da de
la semana.
En la celda B6 escribimos la frmula =C4

A continuacin necesitamos realizar algunos "clculos intermedios" para


llegar a nuestra solucin. Para ello preparamos las siguientes celdas:

Pg. 3

Luis M. Salinas
CLMS C.A.

Captulo

Clculo repeticin de un
da de la semana entre
fechas en Excel

Nos situamos en K12 y vamos a calcular la fila de la tabla de fechas en


la que se encuentra la fecha inicial. Para ello escribimos la siguiente
frmula:
=COINCIDIR(C2;tablafecha)
en K13 escribimos (para calcular la fila con la que se corresponde la
fecha final):
=COINCIDIR(C3;tablafecha)
Ya tenemos la fila que se corresponde con las fechas de inicio y de fin
introducidas en C2 y C3. Ahora, en K14, concatenamos estos resultados
para generar un rango:
="H"&K11&":"&"H"&K12
Fjese que la letra de la columna la hemos introducido como dato (no la
calculamos) porque todas las fechas se encuentran en la columna H. El
resultado de la frmula indicada ser el texto: H38:H135. Tambin
podramos escribir estas tres frmulas que acabamos de realizar en una
sola:
="H"&COINCIDIR(C2;tablafecha)&":"&"H"&COINCIDIR(C3;tablafe
cha)

Luis M. Salinas
CLMS C.A.

Pg. 4

Clculo repeticin de un
da de la semana entre
fechas en Excel

Captulo

Para calcular cuntos, por ejemplo, domingos hay entre las fechas 7 de
febrero y 15 de mayo, slo nos queda contar cuntas veces se repite
entre dichas fechas el nmero de residuo
Una vez hecho esto, nos situamos en la celda C6 y escribimos la
siguiente frmula que explicamos a continuacin:
=CONTAR.SI(INDIRECTO(K16);"="&BUSCARV(C4;diaresiduo;2;FAL
SO))
La funcin CONTAR.SI nos permite realizar la cuenta en un rango de
aquellas celdas que cumplan una determinada condicin. El rango que
nos interesa (en funcin de las fechas introducidas) es el que tenemos
en la celda K16. El problema es que en K16 tenemos un texto que
representa a un rango. Para convertir dicho texto en referencia vlida
para Excel debemos utilizar la funcin INDIRECTO. De esta manera
INDIRECTO(K16) es lo mismo que si introdujramos manualmente el
rango H38:H135 .
Una vez tenemos el rango considerado nos queda establecer la
condicin que debe cumplir para que Excel proceda a contar. La manera
de hacer esto es poniendo la condicin entre comillas. Por ejemplo, si
queremos que cuente el nmero de celdas del rango H38:H135 que son
igual a 1 escribiramos =CONTAR.SI(H38:H135;"=1") . Ya hemos visto
cmo resolver la parte del rango de manera automtica (con la funcin
INDIRECTO). Si dejramos la solucin as slo podramos calcular el
nmero de domingos entre dos fechas. Como queremos tener la
posibilidad de calcular el nmero de repeticiones de cualquier da de la
semana entre dos fechas, necesitamos dejar como variable la condicin.
En realidad slo necesitamos dejar como variable el residuo de la
condicin. Como ya hemos visto, cada da de la semana se corresponde
Pg. 5

Luis M. Salinas
CLMS C.A.

Captulo

Clculo repeticin de un
da de la semana entre
fechas en Excel

con un residuo. Dicha informacin la tenemos en la tabla que hemos


llamado diaresiduo (J2:K8). Por lo tanto podemos asociar el da de la
semana seleccionado en la celda C4 con el nmero de residuo de dicho
da).
Esto
es
lo
que
hace
la
parte
de
la
frmula
BUSCARV(C4;diaresiduo;2;FALSO)
El resultado ser:

Luis M. Salinas
CLMS C.A.

Pg. 6