Вы находитесь на странице: 1из 31

Routing Protocols

Routing Basics

Example
Based on the output of the routing table which interface, a packet with a destination of
10.10.10.14 be forwarded from?

10.10.10.8/29 ip, 255.255.255.248 subnet mask


Block size 256-248 = 8
0,8,16, the address 14 falls between the two subnets 8 and 16
Therefore it is part of the 10.10.10.8 subnet
the next subnet is 16 so the broadcast address is 15,
valid host range 9 - 14

It will be forward from FE 0/1

With dynamic routes, routes communicate with each other and exchange routing information.
Examples of dynamic routing protocols are RIP, EIGRP, OSPF, and BGP.

Static routes are hard-coded on a network device. They tell the device exactly where to send
traffic, no matter what.

Example
Say that you have two locations, connected by a WAN T1 circuit. On the LAN side of each of
these locations, you have a small Ethernet network.

The only way for the devices on Ethernet LAN 10.10.1.0 to communicate with devices on
network 10.10.2.0, is to use routing. With such a simple network, static routing is a perfect
solution. You can enter one route on each router and be done with the configuration.

To configure the static routes for this network,


San Diego#conf t
San Diego(config)#ip route 10.10.2.0 255.255.255.0 20.1.1.2
Destination mask next hop
This tells the San Diego Router that any traffic destined for the Chicago LAN, should be sent
to IP address 20.1.1.2. The IP address 20.1.1.2 is the WAN serial interface of the Chicago
router. Traffic is sent to the “next hop” on the WAN, which happens to be the destination.
Chicago#conf t
Chicago(config)#ip route 10.10.1.0 255.255.255.0 20.1.1.1

On the Chicago router we are doing the reverse so the response from San Diego traffic can
find its way back to San Diego.

3 2600 routers connected via a wide area network (WAN) each router also has an Ethernet
network connected

3 Routers A, B and C Remember by default these routers only know about networks that
are directly connected to them.
Ok the idea is that each router must know about all five networks.

The first step is to configure each router with the correct IP address information
Router Network Address Interface Address
A 192.168.10.0 fa0/0 192.168.10.1
A 192.168.20.0 s0/0 192.168.20.1
B 192.168.20.0 s0/0 192.168.20.2
B 192.168.40.0 S0/1 192.168.40.1
B 192.168.30.0 Fa0/0 192.168.30.1
C 192.168.40.0 s0/0 192.168.40.2
C 192.168.50.0 Fa0/0 192.168.50.1

The first step is to configure each router with the correct IP address information; each network
in the table has a default class C 24-bit subnet mask (255.255.255.0)

Router configuration is straight forward enough, you just need to add IP addresses to your
interfaces and then perform a no shutdown on those interfaces.
Router A configuration
To configure Lab A router we just need to add an IP address to interface FastEthernet 0/0
as well as the Serial 0/0. Configuring the hostnames of each router will make identification
easier and why not set interface descriptions banner and router passwords too.

Router>en
Router#config t
Router(config)#hostname RouterA
RouterA(config)#enable secret todd
RouterA(config)#interface fa0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#description RouterA LAN Connection
RouterA(config-if)#no shut
RouterA(config-if)#interface serial 0/0
RouterA(config-if)#ip address 192.168.20.1 255.255.255.0
RouterA(config-if)#description WAN Connection to RouterB
RouterA(config-if)#no shut
RouterA(config-if)#exit
RouterA(config)#line console 0
RouterA(config-line)#password todd
RouterA(config-line)#login
RouterA(config-line)#line aux 0
RouterA(config-line)#password todd
RouterA(config-line)#login
RouterA(config-line)#line vty 0 4
RouterA(config-line)#password todd
RouterA(config-line)#login
RouterA(config-line)#exit
RouterA(config)#banner motd #
This is the RouterA
#
RouterA(config-line)#ˆZ
RouterA#copy running-config startup-config
Destination filename [startup-config]? Enter
RouterA#

To view the IP routing tables created on a Cisco router, use the privileged mode command
show ip route Note only the configured directly connected networks are shown in the
routing table. This means the router only knows how to get to networks 192.168.10.0 and
192.168.20.0

RouterA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area * - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set


C 192.168.10.0/24 is directly connected, FastEthernet0/0
C 192.168.10.0/24 is directly connected, Serial 0/0

Note: What does the no shut command do?


Enables the interface (keeps the line logically up even when physically down)
To shutdown the interfaces administratively
RouterA(config)# int fa0/0
RouterA(config-if)# shutdown
Question

Serial0/0 does not respond to a ping request from a host on the FastEthernet0/0 LAN.How
can this problem be corrected?

A. Enable the Serial 0/0 interface.


B. Correct the IP address for Serial 0/0.
C. Correct the IP address for FastEthernet 0/0.
D. Change the encapsulation type on Serial 0/0.
E. Enable autoconfiguration on the Serial 0/0 interface.

Answer A

Explanation
Need to run the command no shutdown to enable the serial 0/0 from administratively down
to up state.

Router B

To configure RouterB you have 3 interfaces to deal with FastEthernet 0/0 Serial 0/0 and
Serial 0/1. Both serial interfaces are (DCE) Data Communication Equipment. This means
adding the clock rate command to each interface.

Router>en
Router#config t
Router(config)#hostname RouterB
RouterB(config)#enable secret todd
RouterB(config)#interface fa0/0
RouterB(config-if)#ip address 192.168.30.1 255.255.255.0
RouterB(config-if)#description RouterB LAN Connection
RouterB(config-if)#no shut
RouterB(config-if)#interface serial 0/0
RouterB(config-if)#ip address 192.168.20.2 255.255.255.0
RouterB(config-if)#description WAN Connection to RouterA
RouterB(config-if)#clock rate 64000
RouterB(config-if)#no shut
RouterB(config-if)#interface serial 0/1
RouterB(config-if)#ip address 192.168.40.1 255.255.255.0
RouterB(config-if)#description WAN connection to RouterC
RouterB(config-if)#clock rate 64000
RouterB(config-if)#no shut
RouterB(config-if)#exit
RouterB(config)#line console 0
RouterB(config-line)#password todd
RouterB(config-line)#login
RouterB(config-line)#line aux 0
RouterB(config-line)#password todd
RouterB(config-line)#login
RouterB(config-line)#line vty 0 4
RouterB(config-line)#password todd
RouterB(config-line)#login
RouterB(config-line)#exit
RouterB(config)#banner motd #
This is the RouterB
#
RouterB(config-line)#ˆZ
RouterB#copy running-config startup-config
Destination filename [startup-config]? Enter
RouterB#

Theses commands configured serial 0/0 into network 192.168.20.0, Serial 0/1 into network
192.168.40.0 and FastEthernet 0/0 into network 192.168.30.0 The show ip route
command displays

RouterB#show ip route
Codes: C – connected etc…
Gateway of last resort is not set

C 192.168.20.0/24 is directly connected, Serial0/0


C 192.168.40.0/24 is directly connected, Serial0/1
C 192.168.30.0 is directly connected, FastEthernet 0/0
RouterB#

Notice that RouterB knows how to get to networks 192.168.20.0, 192.168.30.0, and
192.168.40.0 RouterA and RouterB can now communicate as they’re connected on the same
WAN.

Router C

Router>en
Router#config t
Router(config)#hostname RouterC
RouterC(config)#enable secret todd
RouterC(config)#interface fa0/0
RouterC(config-if)#ip address 192.168.50.1 255.255.255.0
RouterC(config-if)#description RouterC LAN Connection
RouterC(config-if)#no shut
RouterC(config-if)#interface serial 0/0
RouterC(config-if)#ip address 192.168.40.2 255.255.255.0
RouterC(config-if)#description WAN Connection to RouterB
RouterC(config-if)#no shut
RouterC(config-if)#exit
RouterC(config)#line console 0
RouterC(config-line)#password todd
RouterC(config-line)#login
RouterC(config-line)#line aux 0
RouterC(config-line)#password todd
RouterC(config-line)#login
RouterC(config-line)#line vty 0 4
RouterC(config-line)#password todd
RouterC(config-line)#login
RouterC(config-line)#exit
RouterC(config)#banner motd #
This is the RouterC
#
RouterC(config-line)#ˆZ
RouterC#copy running-config startup-config
Destination filename [startup-config]? Enter
RouterC#

The output of the following show ip route command displays the directly connected networks
of 192.168.50.0 and 192.168.40.0

RouterC#sh ip route
Codes: C – connected etc…
Gateway of last resort is not set

C 192.168.50.0/24 is directly connected, Serial0/0


C 192.168.40.0/24 is directly connected, Serial0/1
RouterC#
Routers A and B can communicate because there on the same WAN. RouterB and RouterC
can also communicate because they’re connected with a WAN link. But RouterA can’t
communicate with RouterC because it does not know about network 192.168.40.0 and
192.168.50.0 –at least not yet!

Configuring IP Routing in your Network


So the network has been correctly configured with IP addressing, but how does the router
send packets to remote networks?
They send packets by looking at the routing table to find out how to reach remote networks
our configured routers have info only about directly connected networks in each routing table
what happens when a router receives a packet for a network not listed in the routing table? It
doesn’t broadcast out looking for the network it just discards the packet!

The solution depends on your environment - types of routing you might need are Static,
Default and Dynamic.

Static Routing

Static routes while manually intensive to keep up are a very quick and effective way to route
data from one subnet to different subnet. A static route is a hard coded path in the router that
specifies how the router will get to a certain subnet by using a certain path.

To add a static route on a Cisco router, use the ip route command to route packets in two
ways through the next hop or exit interface the syntax is

ip route <destination network> <netmask> <next hop address > <admin distance>.
or exit interface

The syntax to utilize is: ip route <destination> <netmask> <next hop>.

This shows the creation of a static route for a single host

Cisco#conf t
Cisco(config)#ip route 193.252.19.5 255.255.255.255 193.252.19.1 110

193.252.19.5 is the destination network. 255.255.255.255 is the subnet mask for that network
and 193.252.19.1 is the next hop for the router to use. The 110 is the administrative distance

The next-hop address


router(config)#ip route 172.16.20.0 255.255.255.0 172.16.10.2

The exit interface


router(config)#ip route 172.16.20.0 255.255.255.0 s0/0

ip route The command used to create the static route.


destination network The network your placing in the routing table.
mask The subnet mask being used on the network
next-hop address The address of the next-hop router that will receive the packet and
forward it to the remote network. This is a router interface that’s on a directly connected
network. You must be able to ping the router interface before you add the route If you type in
the wrong next-hop address, or the interface to that router is down, the static route shows up
in the router’s configuration but not in the routing table.
Exit interface You can use this in place of the next-hop address if you want, but it has to be
on a point-to-point link, such as a WAN.
This command won’t work on a LAN such as Ethernet.
Administrative distance (Optional) default for static routes = 1.
We can change the default value by adding an administrative weight at the end of the cmd.
permanent If the interface is shut down or the router can’t communicate to the next-hop
router, the route is automatically discarded from the routing table. Choosing the permanent
option keeps the entry in the routing table no matter what happens.

Question

Users on the Holyoke router cannot get access to the intranet server attached to interface E0
of the Chicopee router. After investigating you discover that the routing table of the Holyoke
router shows that an entry for the Chicopee E0 network is missing.
Which of the commands will configure the Holyoke router to allow the users access to the
intranet server network?

A. Holyoke(config)#ip host Chicopee 201.73.127.2


B. Holyoke(config)#ip network 202.18.38.0
C. Holyoke(config)#ip network 202.18.18.0 255.255.255.0
D. Holyoke(config)#ip host Chicopee 201.73.127.0 255.255.255.0
E. Holyoke(config)#ip route 202.18.18.0 255.255.255.0 201.73.127.2
F. Holyoke(config)#ip route 201.73.127.0 255.255.255.0 202.18.18.0

Answer E

We use the syntax of ip route <network><mask><gateway>


Lab A Configuration

Each routing table automatically includes directly connected networks. To be able to route to
all networks in the internetwork the routing table must include information that describes
where these other networks are located and how to get there

Router A is connected to networks 192.168.10.0 and 192.168.20.0


For RouterA to be able to route to all networks, the following have to be configured in its
routing table.
192.168.30.0
192.168.40.0
192.168.50.0

The following router output shows the configuration of static routes on RouterA and the
routing table after configuration. For RouterA to find the remote networks you must place an
entry in the routing table that describes the network, the mask, and where to send the
packets.
Notice each static route sends the packets to 192.168.20.2, which is RouterA’s next hop.

RouterA(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2


RouterA(config)#ip route 192.168.40.0 255.255.255.0 192.168.20.2
RouterA(config)#ip route 192.168.50.0 255.255.255.0 192.168.20.2

After the router is configured, typing show running-config and show ip route shows
the static routes. Remember if the routes don’t appear in the routing table, its because the
router cannot communicate with the next hop address you configured. Also remember you
can use the permanent parameter to keep the route in the routing table even if you can’t
contact the next hop device.

RouterA#show ip route
Codes: C - connected, etc…

S 192.168.50.0 [1/0] via 192.168.20.2


S 192.168.40.0 [1/0] via 192.168.20.2
S 192.168.30.0 [1/0] via 192.168.20.2
C 192.168.20.0 is directly connected, Serial 0/0
C 192.168.10.0 [1/0] is directly connected, FastEthernet0/0
RouterA#

The S in the routing table entries means that the network is a static entry.
The [1/0] is the administrative distance and metric to the remote network.
Here it is 0, indicating that it’s directly connected.
RouterA now has all the info it needs to communicate with all the remote networks. However
RouterB and RouterC needs to also be configured with the same information otherwise the
packets will be discarded at RouterB and RouterC.

Router B Configuration

RouterB is connected to the networks 192.168.20.0, 192.168.30.0 and 192.168.40.0


We must configure the following static routes on RouterB
192.168.10.0
192.168.50.0

Here’s the configuration

RouterB(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1

RouterB(config)#ip route 192.168.50.0 255.255.255.0 192.168.40.2

Now looking at the routing table you can see RouterB understands how to find each network.
RouterB#show ip route
Codes: C - connected, etc…

S 192.168.50.0 [1/0] via 192.168.40.2


C 192.168.40.0 is directly connected, Serial 0/1
C 192.168.30.0 is directly connected, FastEthernet0/0
C 192.168.20.0 is directly connected, Serial 0/0
S 192.168.10.0 [1/0] via 192.168.20.1
RouterB#

The RouterB now has a complete routing table. As soon as the other routers in the
internetwork have the same routing table RouterB can communicate to all remote networks.

Router C Configuration

RouterC is directly connected to the networks 192.168.40.0, 192.168.50.0 and 192.168.40.0


We need to configure the following 3 routes on RouterC
192.168.30.0, 192.168.20.0 and 192.168.10.0
RouterC(config)#ip route 192.168.30.0 255.255.255.0 192.168.40.1

RouterC(config)#ip route 192.168.20.0 255.255.255.0 192.168.40.1

RouterC(config)#ip route 192.168.10.0 255.255.255.0 192.168.40.1

The following output shows the routing table on RouterC.

RouterC#show ip route
Codes: C - connected, etc…

C 192.168.50.0 is directly connected, FastEthernet0/0


C 192.168.40.0 is directly connected, Serial 0/0
S 192.168.30.0 [1/0] via 192.168.40.1
S 192.168.20.0 [1/0] via 192.168.40.1
S 192.168.10.0 [1/0] via 192.168.40.1
RouterC#

RouterC now shows all the networks in the internetwork and can communicate with all routers
and networks but if you add even one more network or anther router to the internetwork you’ll
have to update all routers’ routing tables by hand. Ok for a small network but problematic for
larger networks.

Verifying your Configuration (show ip route)

Router#show ip route Displays contents of routing table

Once you have configured all the routers routing tables you need to verify them. The best way
to do this besides using the show ip route command is with the ping command. By
pinging from routers A and B you can test the whole internetwork end to end.

Here is the output of a ping to network 192.168.50.0 from RouterA;


RouterA#ping 192.168.50.1
Type escape sequence to about
Sending 5, 100-byte ICMP Echos to 172.16.50.1, timeout is 2 seconds:
.!!!
Success rate is 80 percent (4/5), round-trip min/avg/max =64/66/68 ms
RouterA#

Notice that the first response is a period. This is because the first ping times out waiting for
the Address Resolution Protocol (ARP) request and response. Once the ARP has found the
hardware address of the default gateway, the IP-to-Ethernet mapping will be in the ARP
cache and will stay in the router’s cache for 4 hours. Any other IP connectivity to the next hop
router wont time out, because no ARP broadcasts have to be performed.
From RouterC, a ping to 192.168.10.0 will test for good IP connectivity. Here is the router
output.

RouterC#ping 192.168.10.1
Type escape sequence to abort
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/67/72
ms

Since you ping from end-to-end without a problem, your static route configuration was a
success!

To create static routes on a Cisco router, you use the ip route command followed by the
destination network, network mask, and either the next-hop IP address or the local exit
interface. It's vital to keep that last part in mind - you're either configuring the IP address of
the downstream router, or the interface on the local router that will serve as the exit interface.

Let's say your local router has a serial0 interface with an IP address of 200.1.1.1/30, and the
downstream router that will be the next hop will receive packets on its serial1 interface with an
IP address of 200.1.1.2/30. The static route will be for packets destined for the 172.10.1.0
network. Either of the following ip route statements would be correct.

R1(config)#ip route 172.10.1.0 255.255.255.0 200.1.1.2


(next-hop IP address)
R1(config)#ip route 172.10.1.0 255.255.255.0 serial0
(local exit interface)
You can also write a static route that matches only one destination.
This is a host route, and has 255.255.255.255 for a mask.

A Static route that matches a single destination 255.255.255.255 mask

If the above static routes should only be used to send packets to 172.10.1.1., the following
commands would do the job.

R1(config)#ip route 172.10.1.1 255.255.255.255 200.1.1.2


(next-hop IP address)
R1(config)#ip route 172.10.1.1 255.255.255.255 serial0
(local exit interface)

Static routes are ideal when using something called a stub network. This is where there is
only one way in and out of the network.

The disadvantage of using static routes is that if the connection to the next hop goes down
the router will continue to route traffic there. It will never be aware of the fact that the path is
no longer valid.
Default Static Route ip route 0.0.0.0 0.0.0.0

Finally, a default static route serves as a gateway of last resort. If there are no matches for a
destination in the routing table, the default route will be used. Default routes use all zeroes for
both the destination and mask, and again a next-hop IP address or local exit interface can be
used.

R1(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2 (next-hop IP address)


R1(config)#ip route 0.0.0.0 0.0.0.0 serial0 (local exit interface)

Default Routing

Default routes are used to direct packets addressed to networks not explicitly listed in the
routing table. Remember that when a router comes across a packet destined for an unknown
network, it automatically drops the packet. If we specify a gateway of last resort, a router will
forward traffic for networks that it doesn’t know about to the destination router address we
specify.

In the same way that you can set a default gateway on your desktops and servers, you can
also set a default gateway of sorts on your Cisco router – the gateway of last resort.

You use default routing to send packets with a remote destination network not in the routing
table to the next hop router.

You can use default routing only on a stub network


(a network with a single route) only one exit out of the network.

In the internetworking example used previously the routers A and C are considered to be on a
stub network. If you tried to put a default route on RouterB packets wouldn’t be forwarded to
the correct networks because they have more than one interface routing to other routers.
Even though RouterC has two connections, it doesn’t have a router on the 192.168.50.0
network that needs packets sent to it. RouterC will only send packets to 192.168.40.1 which is
the Serial 0/0 interface of RouterB. RouterA will send packets only to the 192.168.20.2
interface of RouterA.

To configure a default route, you use wildcards in the network address and mask locations of
a static route.

In fact a default route can be thought of as a static route that uses wildcards instead of
network and mask information.

RouterC is directly connected to networks 192.168.40.0 and 192.168.50.0.


The routing table needs to know about networks 192.168.10.0, 192.168.20.0, and
192.168.30.0.
To configure RouterC to route to the other networks, I placed three static routes in the routing
table. By using a default route you can create just one static route entry instead.

First you should delete the static routes from the router and then you should add the default
route.

RouterC(config)#no ip route 192.168.10.0 255.255.255.0 192.168.40.1


RouterC(config)#no ip route 192.168.20.0 255.255.255.0 192.168.40.1
RouterC(config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1
RouterC(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1

OK now if you look at the routing table we’ll see only the two directly connected networks plus
an S* which indicates that this entry is a candidate for a default route.

RouterC#show ip route
Codes: C - connected, etc…

Gateway of last resort is 192.168.40.1 to network 0.0.0.0

C 192.168.50.0 is directly connected, FastEthernet0/0


C 192.168.40.0 is directly connected, Serial 0/0
S* 0.0.0.0/0 [1/0] via 192.168.40.1
RouterC#

Notice in the routing table that the gateway of last resort is now set. Even so there’s one more
command you must be aware of when using default routes: the ip classless command.

All Cisco routers are classful routers, meaning they expect a default subnet mask on each
interface of the router. When a router receives a packet for a destination subnet that’s not in
the routing table, it drops the packet by default.

If your using default routing you have to use the ip classless command because no
remote subnets will be in the routing table.

Here we are using version 12.x of the (IOS) on the routers therefore the ip classless
command is on by default. If were using default routing and this command isn’t in our
configuration we need to add it if you had subnetted networks on your routers (we don’t here)
here is the command.

RouterC(config)#ip classless

Note this is a global configuration mode command

Troubleshooting With Default Static Routes

Here is a routing table

Gateway of last resort is not set


172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.17.13.0/24 is directly connected, Serial1
C 172.17.21.0/30 is directly connected, BRI0

Packets destined for 20.1.1.0 /24, or any network that doesn't have a match in that small
routing table, will be dropped by this router.

A "regular" static route to 20.1.1.0 /24 would work, but what if that routing table is so small
because a routing protocol is suddenly working incorrectly? What if you need one single route
to act as a route of last resort, a route that will handle all packets that don't have any match in
the routing table? That's where default static routes come in. If we wanted all traffic with no
more-specific match in the routing table to exit the local router via the BRI interface, the ip
route command would look like this:

R1(config)#ip route 0.0.0.0 0.0.0.0 BRI0

After adding this default static route, the routing table looks as follows:

Gateway of last resort is 0.0.0.0 to network 0.0.0.0


172.12.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.12.13.0/24 is directly connected, Serial1
C 172.12.21.0/30 is directly connected, BRI0
S* 0.0.0.0/0 is directly connected, BRI0

The S* indicates a default static route, and the exit interface is the BRI interface. Any packets
that do not have a match in the routing table will be sent out that interface. Of course, you
have to take the ISDN costs into account if you configure this, but that's a subject for another
time!

Question
The following configuration command was entered into a router

ip route 172.16.3.0 255.255.255.0 192.168.2.4 Which of the following statements are true
regarding this configuration change? (Select two)

A. The default administrative distance is used.


B. The command is used to establish a static route.
C. The command is used to configure the router interfaces.
D. The command is used to establish a stub network.
E. The subnet mask for the source address is 255.255.255.0

Answer A, B

Explanation: This command specifies a static route, and tells the router that it should forward
all traffic destined for the 172.16.3.0/24 subnet to the next hop router located at 192.168.2.4.
The default Administrative Distance for a static route is one, and since there is no AD value
specified at the end of this configuration change, the default is used.

Incorrect Answers
C. This command is done in global configuration mode, not in interface mode.
D. Stub networks are used in OSPF topologies. The example in this question is simply
applying a single static route.
E. There is not source network or subnet specified in a static route. All traffic destined to the
target of 172.16.3.0/24 is to be forwarded, regardless of the source.

Another example

Consider above, in which Router A is connected to many different networks. Router B, on the
other hand, is only connected to two networks. In order to allow Router B to get to all of the
other networks shown, we would either need to configure a routing protocol (like RIP or
IGRP), or define static routes to each network.
In this particular scenario, it might actually be easier to use default routing to allow Router B
to reach those three networks. Remember that Router B already knows about networks
10.0.40.0/24 and 10.0.50.0/24, since they are directly connected. In order to have Router B
forward all traffic destined for other networks to Router A, we should configure a gateway of
last resort on Router B. This involves a single routing table entry, with a destination network of
0.0.0.0. This address literally means “all networks”. In other words, we are saying that all
other networks can be reached via Router A. When Router B attempts to route packets, it will
first look in its routing table for the destination network. If it doesn’t find an entry, it will forward
packets to the default route specified.
To configure the gateway of last resort on Router B, use the ip route command, as below.

RouterB(config)#ip route 0.0.0.0 0.0.0.0 10.0.40.1


RouterB(config)#^Z
RouterB#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is 10.0.20.1 to network 0.0.0.0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.50.0 is directly connected, Ethernet0
C 10.0.40.0 is directly connected, Serial0
S* 0.0.0.0/0 [1/0] via 10.0.40.1

Notice that the static route entry used 0.0.0.0 for both the destination IP address and subnet
mask, followed by the address of the next hop router. In this case, all traffic not destined for
networks 10.0.50.0/24 and 10.0.40.0/24 will be forwarded to 10.0.40.1, interface S0 on Router
A. The default route also appears in our routing tables as both the gateway of last result and
as a static route. In this scenario, Router A would still need a routing table entry that defines
how to reach network 10.0.50.0/24.

Default routes are commonly used when you are routing public IP addresses to the Internet. If
you didn’t define a default route, you would literally need to define a next hop address for
every network on the Internet!

The Use of Default Static Routes

Here's our current routing table

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnet


C 1.1.1.1 is directly connected, Loopback0
172.12.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.12.13.0/24 is directly connected, Serial1
C 172.12.21.0/30 is directly connected, BRIO

If we have packets destined for the network 15.1.1.0 /24, the packets will be dropped by this
router. There's no match in that routing table for that network and the gateway of last resort is
not set.

We could configure a static route to the 15.1.1.0 /24 network, but instead we'll use a default
static route. The hardest part of configuring that route type is getting used to the odd syntax!
As with any other static route, we can use the IP address of the next-hop router or the local
router's exit interface.

Router(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.2

Send all packets destined for networks not in my routing table to 172.16.10.2

Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0

Send all packets destined for networks not in my routing table out my Serial 0/0 interface
Here, we'll send any traffic with no more-specific match in the routing table out the local
router's Serial1 interface.

R1(config)#ip route 0.0.0.0 0.0.0.0 serial1

Let's take a look at the routing table now.

Gateway of last resort is 0.0.0.0 to network 0.0.0.0


1.0.0.0/32 is subnetted, 1 subnet
C 1.1.1.1 is directly connected, Loopback0
172.12.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.12.13.0/24 is directly connected, Serial1
C 172.12.21.0/30 is directly connected, BRIO
S* 0.0.0.0/0 is directly connected, Serial1

A gateway of last resort has now been successfully configured, and the S* means that last
route in the table is a static default route. Remember, the default route is not the route that all
packets will take - it's the route packets use if there is no other possible match for their
destination in the routing table.

Configuration Example: Static Routes using the next-hop address, the exit
interface and using the default route.

Boston Router

Boston>en
Boston#config t
Boston(config)#ip route 172.16.30.0 255.255.255.0 172.16.20.2
Configures a static route using next hop address
Boston(config)#ip route 172.16.40.0 255.255.255.0 172.16.20.2
Boston(config)#ip route 172.16.50.0 255.255.255.0 172.16.20.2
Boston(config)#exit
Boston#copy run start
Buffalo Router

Buffalo>en
Buffalo#config t
Buffalo(config)#ip route 172.16.10.0 255.255.255.0 s1
Configures a static route using next exit interface
Buffalo(config)#ip route 172.16.50.0 255.255.255.0 s0
Buffalo(config)#exit
Buffalo#copy run start

Bangor Router

Bangor>en
Bangor#config t
Bangor(config)#ip route 0.0.0.0 0.0.0.0 s1
Configures a static route using the default route
Bangor(config)#exit
Bangor#copy run start

Question
Which of the following commands would you use, to configure a default route to any
destination NOT found in the routing table?

A. Router(config)# ip default-route 0.0.0.0 255.255.255.255 s0


B. Router(config)# ip route 0.0.0.0 255.255.255.255 s0
C. Router(config)# ip default-route 0.0.0.0 0.0.0.0 s0
D. Router(config)# ip route 0.0.0.0 0.0.0.0 s0
E. Router(config)# ip route any any e0

Answer D

Explanation
D is the correct syntax for configuring a gateway of last resort. Note that an alternative way is
to specify the IP address of the next hop router, for example, "ip route 0.0.0.0 0.0.0.0
10.1.1.1."

Question
You have been asked to configure a default route. Which of the IOS commands mentioned
below will accomplish this task? (Select two answer choices)

A. LTD(config)# ip route 0.0.0.0 0.0.0.0 192.168.15.36


B. LTD(config)# ip route 0.0.0.0 192.168.15.36 255.255.255.255
C. LTD# ip default-network 0.0.0.0 192.168.15.36 255.255.255.255
D. LTD(config)# ip route 0.0.0.0 0.0.0.0 E0
E. LTD(config)# ip route 0.0.0.0 255.255.255.255 S0
F. LTD(config-router)# ip route 255.255.255.255 0.0.0.0 192.168.15.36

Answer A, D

Explanation The default route is the IP address of the next hop when no other routes are
known. To configure the default route you type in 'ip route' and then two address sets of 0
followed by the address (as is the case in A) or the interface (as is the case in D).
Question
What is the purpose of the command shown below?
ip route 0.0.0.0 0.0.0.0 serial0/0

A. It configures a router to send all packets out interface serial 0/0.


B. It configures a router to block routing updates from being sent out interface serial 0/0.
C. It configures a router as a firewall, blocking all unauthorized packets from exiting serial 0/0.
D. It configures a router to send all packets for unknown destination networks out interface
serial 0/0.
E. It configures a router to drop all packets for which the destination network is unknown.

Answer D

Explanation: A default static route serves as a gateway of last resort. If there are no matches
for a destination in the routing table, the default route will be used. Default routes use all
zeroes for both the destination and mask, and again a next-hop IP address or local exit
interface can be used. TK1(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2 (next-hop IP address)
OR TK1(config)#ip route 0.0.0.0 0.0.0.0 serial0 (local exit interface)

Question

The network is displayed:

You are a network administrator and you've just finished configuring the static route 10.5.6.0 /
24 on router CertKing. Which command should you use if you want CertKing to consider this
route the most reliable?
A. CertKing(config)# ip route 10.5.6.0 0.0.0.255 fa0/0
B. CertKing(config)# ip route 10.5.6.0 0.0.0.255 10.5.4.6
C. CertKing(config)# ip route 10.5.6.0 255.255.255.0 fa0/0
D. CertKing(config)# ip route 10.5.6.0 255.255.255.0 10.5.4.6
E. CertKing(config)# ip route 10.5.4.6 0.0.0.255 10.5.6.0
F. CertKing(config)# ip route 10.5.4.6 255.255.255.0 10.5.6.0

Answer C, D

Explanation: There are two ways to specify a default static route.


One is to specify the interface to use for forwarding packets, like C.
The other way is to specify the IP address of the next hop router, such as D.

Additional Info: The following is the command you use to add a static route to a routing table:
Ip route [destination_network] [mask] [next-hop_address or exitinterface]
[administrative_distance][permanent] This list describes each command in the string: ip route
The command used to create the static route. destination network The network you're placing
in the routing table.

Mask: The subnet mask being used on the network.


next-hop address: The address of the next-hop router that will receive the packet and forward
it to the remote network. This is a router interface that's on a directory connected network.
administrative_distance By default, static routes have an administrative distance of 1. You
can change the default value by adding an administrative weight at the end of the command.

Question
A new Internet T1 is being added to the network as shown

The ISP assigned you the class C IP address 207.134.6.0/30 for this Internet connection. A
default route to the Internet should be set up. Which of the following are acceptable ways to
configure this on the Gateway router? (Select all that apply)

A. Gateway(config)# ip route 0.0.0.0 0.0.0.0 207.134.6.1

B. Gateway(config)# router rip


Gateway(config-router)# network 207.134.6.0 default

C. Gateway(config)# ip route 207.134.6.0 255.255.255.0 Serial0/0

D. Gateway(config)# router OSPF


Gateway(config-router)# network 207.134.6.0

E. Gateway(config)# ip default-network 207.134.6.0

Answer A, E

Explanation
This question only involves the configuration of the gateway router to the ISP, nothing else.
You have two choices to accomplish this: the command "ip route" or the command "ip default-
network". Both of these methods will configure a default route to the ISP as desired.

Incorrect Answers. B, D

RIP and OSPF are interior routing protocols. The T1 Internet connection that is being set up
here is between two different Autonomous Systems. The only routing protocol that could be
potentially used is BGP, but that is not an option.
C. This command will only set up a static route to the 207.134.6.0/24 network. We wish to set
up a static default route.
Question
What happens to a static route entry in a routing table when the outgoing interface is not
available?

A. The route is removed from the table.


B. The router polls neighbors for a replacement route.
C. The route remains in the table because it was defined as static.
D. The router redirects the static route to compensate for the loss of the next hop device.

Answer A

Question
Your trainee is configuring a router. In particular, he is examining a routing table that contains
static, RIP, and IGRP routes for the same destination network with each set to its default
administrative distance. He asks you which route will be used to forward data?

A. The IGRP route


B. The static route
C. The RIP route
D. All three will load balance.

Answer B

Explanation
To decide which route to use, IOS uses a concept called Administrative Distance.
Administrative distance is a number that denotes how believable an entire routing protocol is
on a single router. The lower the number, the better, or more believable the routing protocol.
(static=1, IGRP=100, RIP=120)

Question
You have just booted a Cisco router. After you open the interfaces, what routes should you
expect to see in the routing table?

A. Connected networks only


B. Connected networks and a single default static route
C. None - the routing table is empty until a routing protocol populates it
D. None of these

Answer A
Connected networks only

When you first view a routing table on a Cisco router after opening the interfaces, you'll see
only the directly connected networks.

Question
Which of the following statements will create a static route that will send packets to the
destination ip address 2.2.2.2, but no others?

A. ip route 2.2.2.2 255.255.255.255 172.12.123.1


B. ip route 2.2.2.2 0.0.0.0 172.12.123.1
C. ip route 2.2.2.2 172.12.123.1 255.255.255.255
D. ip route 2.2.2.2 172.12.123.1 0.0.0.0
E. ip route 0.0.0.0 0.0.0.0 172.12.123.1
F. ip route 0.0.0.0 172.12.123.1 0.0.0.0
Answer B

Explanation: Of the six statements presented here, only the following will send packets to
2.2.2.2 but will route no other packets
ip route 2.2.2.2 255.255.255.255 172.12.123.1

2.2.2.2 = final destination

255.255.255.255 = a 32-bit subnet mask, this means that only the specific destination
preceding it will match this statement.

172.12.123.1 = the next-hop IP address

There is a default static route presented in the choices, but it would match all possible remote
destinations, not just 2.2.2.2 as the question asked.

Question
Which of the following static routes will send only traffic destined for the 100.1.1.0/24 network
to the next-hop address 172.1.1.1?

A. ip route 100.1.1.0 255.255.255.0 172.1.1.1


B. ip route 100.1.1.0 0.0.0.255 172.1.1.1
C. ip route 100.1.1.0 172.1.1.1 255.255.255.0
D. ip route 100.1.1.0 172.1.1.1 255.255.255.0

Answer A
ip route 100.1.1.0 255.255.255.0 172.1.1.1
100.1.1.0 = remote network destination 255.255.255.0 =subnet mask 172.1.1.1 = next hop
address

Question
What letter in the routing table code indicates a static route?

Answer
A static host route is a route used to reach a single remote destination i.e. ip route 1.1.1.1
255.255.255.255 172.18.13.201 These routes are indicated with “S” “S*” indicates a default
route.

Question
You configure the static route shown here, and then attempt to ping that remote destination.
Based on the ping output shown, what is most likely the problem?

R3(config)#ip route 2.2.2.2 255.255.255.255 172.12.123.1


R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)

A. This is an illegal IP ROUTE command, so the local router has no route to 2.2.2.2.
B. The downstream router located at 172.1.1.1 does not have a route to 2.2.2.2.
C. The exit interface of 172.1.1.1 is in fact the exit interface, so routing will fail.
D. The exit interface is closed.

Answer B

This output is the result of a downstream router not having a path to 2.2.2.2. The "U" refers to
"unreachable", and this is one of those rare times that a ping returns more than one
character.

The router would not let you enter 172.1.1.1 for the IP ROUTE command if that were an
interface on that router itself.

There is no problem with that IP ROUTE command; it is a static host route.

Question
You are configuring router Lon, and want to configure a gateway of last resort to router Man.
Router Lon will be sending this traffic out its interface serial0, which has an ip address of
172.1.1.1
Router Man will be receiving this traffic on its interface serial1, and this interface has an ip
address of 189.12.12.12
Which of the following statements will successfully configure a gateway of last resort?

A. ip route 0.0.0.0 0.0.0.0 189.12.12.12


B. ip route 0.0.0.0 0.0.0.0 serial1
C. ip route 0.0.0.0 0.0.0.0 serial0
D. ip route 255.255.255.255 255.255.255.255 172.1.1.1
E. ip route 255.255.255.255 255.255.255.255 serial1
F. ip route 255.255.255.255 255.255.255.255 189.12.12.12
G. ip route 255.255.255.255 255.255.255.255 serial0
H. ip route 0.0.0.0 0.0.0.0 172.1.1.1

Answer A & C (A preferred)

Explanation
These are the only two routes that will work
A. ip route 0.0.0.0 0.0.0.0 189.12.12.12 (next hop ip)
C. ip route 0.0.0.0 0.0.0.0 serial0 (exit interface)

To configure a gateway of last resort we create a default static ip route.


The default static route begins with “ip route 0.0.0.0 0.0.0.0” so the answers with
255.255.255.255 for those 2 values can be eliminated.

A static route default or not follows this syntax

ip route < destination_network > < subnet_mask > < next_hop_IP OR exit_interface >

If you configure an ip address at the end of this command it must be the next hop if you
configure an interface type it must be the local exit interface.

In this situation the route “ip route 0.0.0.0 0.0.0.0 serial0” is not a great choice, but it would
configure the gateway of last resort. Configuring a next-hop ip address is a preferred method
and easier to troubleshoot.
Question
You have placed a static route on your router to get to Network A. You also have RIPv1 and
OSPF running on your router. The router receives updates from RIP and OSPF on how to get
to Network A. Which of the routes does the router use to get to Network A?

A. The static route


B. The RIP route
C. The OSPF route
D. None of the above, as they will cancel each other out

Answer A
A static route is the most believable route possible (except for being directly connected to a
network by a router's interface). Routers use administrative distance (AD) to decide the best
route. The lowest AD wins, and in this case, a static route has an AD of 1.
B is incorrect, as RIP's AD is 120.
C is incorrect, as OSPF's AD is 110.
D is incorrect, as a router never "cancels" out routes if it hears from more than one source;
that is the function of the AD.

Question
You need to configure a static route to reach the 10.20.0.0 network. Which of the following is
an example of the correct syntax you should use?

A. ip route 10.20.0.0 255.255.0.0 10.10.0.1


B. ip route 10.20.0.0 0.0.255.255 10.10.0.1
C. route 10.20.0.0 255.255.0.0 serial 0 100
D. route 10.20.0.0 255.255.0.0 10.10.0.1

Answer A
The ip route 10.20.0.0 255.255.0.0 10.10.0.1 command establishes a static route in the
routing table.
B is incorrect, as static routes are specified using subnet masks rather than wildcard masks.
Wildcard masks are typically used in access list and OSPF configurations.
C and D are incorrect, as you must specify the IP syntax in front of the route command.

Question
Which of the following is an example of a default static route?

A. ip route 172.16.1.0 255.255.255.0 172.16.2.1


B. ip route 0.0.0.0 0.0.0.0 172.16.2.2
C. ip route 172.16.1.0 255.255.255.0 serial 0/0
D. ip route 172.16.1.0 255.255.255.0 static

Answer B

A default route is a static route that contains a unique address and subnet mask combination
of all zeros (0.0.0.0 0.0.0.0).
A is incorrect, as it is a standard static route.
C is incorrect, as it is a standard static route using an interface instead of a next-hop IP
address.
D is incorrect, as it is not even the correct syntax for a static route.

Question
Which of the following are good candidates for static routes?
A. Stub networks
B. Large corporations
C. Laptop-based networks
D. Low-security environments

Answer A
Stub networks have only one way in and one way out. Static routes serve well in this
environment. B is incorrect, as large corporations typically have hundreds of routers, which
make static routes inappropriate. C is incorrect, as laptops versus desktops typically do not
affect routing choices. D is incorrect, as static routes are typically used in high-security
environments.

Question
You need to configure a static route to reach the 172.16.0.0 network. Which of the following is
an example of the correct syntax you should use?

A. ip route 172.16.0.0 255.255.0.0 172.31.0.1


B. ip route 172.16.0.0 255.255.0.0 static
C. route 172.16.0.0 255.255.0.0 serial 0 100
D. route 172.16.0.0 255.255.0.0 172.31.0.1

Answer A

The ip route 172.16.0.0 255.255.0.0 172.31.0.1 command establishes a static route in the
routing table. B is incorrect, as you do not have to specify that it is a static route with the word
static. Instead, there should be an interface or next-hop router address parameter. C and D
are incorrect, as you must specify the IP in front of the route command.

Question
Which of the following commands configures a static route on Router 1 to network
192.18.40.0/24 with an administrative distance of 90?

A. Router1(config)# ip route 90 192.18.30.0 255.255.255.0 192.18.20.2

B. Router1(config)# ip route 90 192.18.20.1 255.255.255.0 192.18.20.2

C. Router1(config)# ip route 192.18.40.0 255.255.255.0 192.18.30.2 90

D. Router1(config)# ip route 192.18.30.0 255.255.255.0 192.18.20.1 90

E. Router1(config)# ip route 192.18.30.0 255.255.255.0 192.18.30.2 90

Answer C

The correct syntax for a static route is ip route [destination network] [subnet mask] [interface
or next hop ip address] [administrative distance(optional)]. Increasing the AD from the default
of 1 to 90 allows the static route to be less believable than some routing protocols. This is
known as a floating static route, which is used for backup paths. In this case, you are trying to
reach the 192.18.40.0 network. You are telling the router to send packets for that network to
192.18.30.2, which is the next-hop IP address. You are also setting the AD to 90. A and B are
incorrect, as the AD parameter does not go in front of the destination network parameter. D is
incorrect, as you are trying to reach the 192.18.40.0 network, not the 192.18.30.0 network.

Question
You work as network administrator for the ABC Inc. A static route to an ABC branch office
LAN needs to be configured on the ABC router. The address of the branch office LAN is
172.16.16.0/24. The point-to-point link between the corporate router and the branch office is
configured with the first two usable IP addresses on the 172.16.14.0/24 network, with the
corporate router serial interface receiving the first address, and the branch office serial
interface receiving the second. In the box below, enter the command to configure the
corporate router with this static route. No optional parameters are required.

ABC (config)# __________

Answer –
ip route 172.16.16.0 255.255.255.0 172.16.14.2

Explanation
The syntax for ip route is ip route prefix mask { next –hop-router/ output-interface).
In Our example prefix is 172.16.16.0. Mask is 24 bits, ie 255.255.255.0. Branch office serial
interface address is second usable address in the network 172.16.14.0. That is 172.16.14.2.

Question
Which of the following can be used to determine the best path to reach a remote destination
on a Cisco router? (Choose two)

A. Static route entry.


B. Default route entry.
C. Dynamic route entry.
D. Temporary route entry.
E. Permanent route entry.

Answer A, C

Explanation
When a router must send packets that are not directly connected it must have either a static
route or a dynamic router entry.

Incorrect Answers
B. A default gateway does not always determine the appropriate path.
D and E. Routes can be temporary or permanent, but this is an attribute of the route entry
itself. This does not determine path information.

Question
A new point to point circuit is installed, connecting R1 to R2 as shown below

Users at R1 wish to utilize the existing Internet connection at R2. To do this, a gateway of last
resort needs to be set. What is the command to do this?

A. R1(config)# ip route 172.16.4.2 0.0.0.0 0.0.0.0


B. R1(config)# ip route 0.0.0.0 0.0.0.0 S1
C. R1(config)# ip route 172.16.4.1 0.0.0.0 0.0.0.0
D. R1(config)# ip route S0 0.0.0.0 0.0.0.0
E. R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.4.2
Answer E

Explanation: Setting the default gateway is done by issuing either the "ip route 0.0.0.0 0.0.0.0
serial 0" or the "ip route 0.0.0.0 0.0.0.0 172.16.4.2" command.

Incorrect Answers: A, C. The IP address of the next hop needs to go after the route, not
before. B. This would have been acceptable if the interface specified was S0, not S1. C. The
interface used to forward packets for the route should be placed after the route, not before.

Question
The following configuration command was issued on router TK1
ip route 172.16.3.0 255.255.255.0 192.168.2.1

Which of the following statements are true regarding this command? (Select two)

A. The command is used to establish a static route.


B. The default administrative distance is used.
C. The command is used to configure the default route.
D. The subnet mask for the source address is 255.255.255.0
E. The command is used to establish a stub network

Answer A, B

Explanation: The IP route command is used to establish a static route. The default
administrative distance is used because the other distance is not set at the end of the
command. Unless otherwise specified by placing a cost at the end of this command, the
default administrative distance will be 1.

Question

Which of the following will configure a static route on Router A to network 180.18.30.0/24 with
an administrative distance of 90?

A. Router(config)# ip route 90 180.18.20.1 255.255.255.0 182.18.20.2


B. Router(config)# ip route 180.18.20.1 255.255.255.0 182.18.30.0 90
C. Router(config)# ip route 180.18.30.1 255.255.255.0 182.18.20.1 90
D. Router(config)# ip route 90 180.18.30.0 255.255.255.0 182.18.20.2
E. Router(config)# ip route 180.18.30.0 255.255.255.0 182.18.20.2 90

Answer E

Explanation: Static route entries consist of the destination IP network address, the IP address
of the next hop router, and the metric (hop count) for the route. A static route that points to the
next hop IP address has an Administrative distance of 1. If the static route points to an
outgoing interface, the static route has the Administrative distance of 0. One common reason
to change the administrative distance of a route is when you use Static Routes to backup and
existing IGP route. This is normally used to bring up a backup link when the primary fails. In
this example, choice E specifies that to reach the 180.18.30.0/24 network, forward this traffic
to the router with the next hop IP address of 182.18.20.2 (Router B) using an administrative
distance of 90.

Question
The network administrator of the Oregon router adds the following command to the router
configuration: ip route 192.168.12.0 255.255.255.0 172.16.12.1. What are the results of
adding this command? (Choose two.) Exhibit:

A. Traffic for network 192.168.12.0 is forwarded to 172.16.12.1.


B. This route is automatically propagated throughout the entire network.
C. Traffic for all networks is forwarded to 172.16.12.1.
D. Traffic for network 172.16.12.0 is forwarded to the 192.168.12.0 network.
E. The command invokes a dynamic routing protocol for 192.168.12.0.
F. The command establishes a static route.

Answer A, F

Explanation: In order to configure a static route the router has to be in global configuration
mode. ip route network prefix mask {address | interface} [distance] network - the destination
network mask - is the subnet mask for that network address - IP address of the next hop
router interface - or the interface the traffic is to leave by distance - (optional) the
administrative distance of the route There are other parameters but these have been removed
as they are not relevant to the CCNA exam. Example:

ip route 10.0.0.0 255.0.0.0 131.108.3.4 110

10.0.0.0 is the destination network. 255.0.0.0 is the subnet mask for that network and
131.108.3.4 is the next hop for the router to use. The 110 is the administrative distance.

Question
A network associate has configured the internetwork that is shown in the exhibit, but has
failed to configure routing properly. Which configuration will allow the hosts on the Branch
LAN to access resources on the HQ LAN with the least impact on router processing and WAN
bandwidth?
A. HQ(config)# router rip
HQ(config-router)# network 192.168.2.0
HQ(config-router)# network 172.16.0.0
Branch(config)# router rip
Branch (config-router)# network 192.168.1.0
Branch (config-router)# network 192.168.2.0

B. HQ(config)# router eigrp 56


HQ(config-router)# network 192.168.2.4
HQ(config-router)# network 172.16.25.0
Branch(config)# router eigrp 56
Branch (config-router)# network 192.168.1.0
Branch (config-router)# network 192.168.2.4

C. HQ(config)# ip route 192.168.1.0 255.255.255.0 192.168.2.5


Branch(config)# ip route 172.16.25.0 255.255.255.0 192.168.2.6

D. HQ(config)# router ospf 1


HQ(config-router)# network 192.168.2.4 0.0.0.3 area 0
HQ(config-router)# network 172.16.25.0 0.0.0.255 area 0
Branch(config)# router ospf 1
Branch (config-router)# network 192.168.1.0 0.0.0.255 area 0
Branch (config-router)# network 192.168.2.4 0.0.0.3 area 0

Answer C

Explanation: As far as the CCNA exam goes, there are three types of routing: static, dynamic,
and default. * Static routes - are fixed routes that are manually entered by the administrator
into the router's configuration.

* Dynamic routing - is the process by which a network adapts automatically to the changes in
topology or traffic as those changes occur.

* Default routes - are very much like static route. The administrator enters the default route,
and it becomes the default path the router uses to forward packets for which it knows no other
route to use. Without a default route, packets with unknown destinations are dripped.

A static route is configured on the router with a command like this: ip route
[destination_network] [mask] [next_hop_address or exit interface] [administrative-distance]
[permanent] Example: RouterA(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.1 3
Using the previous command example the key elements of the static router configuration
command are: * ip route: This is the command used to designate a static route. *
destination address: in this example, 209.220.93.243 is the IP address of the destination
network. * subnet mask: 192.169.1.0 is a Class C IP address and is using the default subnet
mask for Class C addresses, 255.255.255.0 * next hop: Following the subnet mask is the
address of the next hop router, 192.168.1.1 * administrative distance: This is a number
between 0 and 255 that indicates how well the route can be trusted. The higher the number,
the lower the trust. * permanent: if the interface is shut down or the router cannot
communicate to the next hop router, the route is automatically discarded from the routing
table. Choosing the permanent option keeps the entry in the routing table no matter what
happens. Static routing has the following benefits: * No overhead on the router CPU * No
bandwidth usage between routers * Security (because the administrator only allows routing to
certain networks)

Question
Which of the commands below can you use to configure a default route? (Select two )

A. R1(config)# ip route 0.0.0.0 0.0.0.0 E0


B. R1(config)# ip route 0.0.0.0 255.255.255.255 S0
C. R1(config-interface)# ip route 255.255.255.255 0.0.0.0 192.168.1.21
D. R1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.21
E. R1(config)# ip route 0.0.0.0 192.168.1.21 255.255.255.255
F. R1# ip default-network 0.0.0.0 192.168.1.21 255.255.255.255

Answer A, D

Explanation

There are two ways to specify a default static route. One is to specify the interface to use for
forwarding packets, like the example in A. The other way is to specify the IP address of the
next hop router, such as the example in D. The ip route 0.0.0.0 0.0.0.0 command uses the
fact that network 0.0.0.0 is used by Cisco IOS software to represent the default network.

Incorrect Answers
B. All zero's must used for the subnet mask of a default route, not all 1's.
C. The default route is made in global configuration mode.
D, E. A subnet mask is not needed after the next hop router is specified.

Question
The following command was added to a router configuration
ip route 198.19.150.0 255.255.255.0 192.0.2.249
What two effects will this command have? (Choose two.)

A. It will create a static route to the 198.19.150.0/24 network.


B. It will create a default route using the interface with the IP address 192.0.2.249 as the next
hop.
C. All packets with an unknown destination address will be forwarded to the 198.19.150.0/24
network.
D. Information about the 198.19.150.0 network learned dynamically will be ignored as long as
this configuration command is in effect.
E. The route will be marked with an "R" in the routing table.

Answer A, D

Вам также может понравиться