Вы находитесь на странице: 1из 7

BCMSN LAB 7

Layer 3 Switching

Lab 7: Layer 3 Switching


Objective
Configure DSW switches for routing, and re-address the network for routing.

Lab Topology
For this lab, your network design will include two pods of devices. You will be responsible for configuring the
devices in both pods. The devices on the left side of the topology are in Pod 1. The devices on the right side of the
topology are in Pod 2. P1PC1 and P2PC2 are PC workstations. P1ASW1 and P2ASW2 are access-layer switches.
P1DSW1 and P2DSW2 are distribution-layer switches. The access and distribution layers are two of the three lay-
ers in the Cisco three-layer hierarchical network model, which also includes the core layer.

The Topology diagram below represents the NetMap in the Simulator. To access each of the devices from within
the Simulator, select the device name from the appropriate menu in the Simulator. For example, to access
P1ASW1, click the eSwitches button and select P1ASW1 from the drop-down menu.

Boson NetSim for CCNP Lab Manual 161


BCMSN LAB 7
Layer 3 Switching

Command Summary
Command Description
configure terminal enters global configuration mode
enable enters privileged EXEC mode
exit exits from current mode
end returns to privileged EXEC mode
interface fastethernet slot/port enters interface configuration mode for the specified
Fast Ethernet interface
interface vlan interface number enters interface configuration mode for the specified
virtual interface
ip address ip_address subnet_mask assigns an IP address to an interface
ping ip_address sends an ICMP echo request
show ip displays IP configuration
shutdown; no shutdown disables an interface; enables an interface
ip routing enables Layer 3 processing
router protocol enables a routing protocol and defines which net-
network network_address works to route for
no switchport disables Layer 2 on a port
show ip interface displays IP information for an interface
show protocols displays Layer 3 protocols enabled for a device
show ip protocols displays routing protocols enabled for a device
show ip route displays the IP routing table

Lab Tasks
PC IP Configuration
PC VLAN IP ADDRESS DEFAULT GATEWAY
P1PC1 11 172.16.11.1/24 172.16.11.100
P2PC2 12 172.16.12.1/24 172.16.12.200

ASW IP Configuration
ASW VLAN IP ADDRESS DEFAULT GATEWAY
P1ASW1 1 172.16.1.10/24 172.16.1.100
P2ASW2 1 172.16.1.20/24 172.16.1.200

DSW IP Configuration
P1DSW1 INTERFACE VLAN IP ADDRESS
VLAN1 1 172.16.1.100/24
VLAN11 11 172.16.11.100/24

162 Boson NetSim for CCNP Lab Manual


BCMSN LAB 7
Layer 3 Switching

P2DSW2 INTERFACE VLAN IP ADDRESS


VLAN1 1 172.16.1.200/24
VLAN12 12 172.16.12.200/24

1. On each PC, reconfigure the IP address as shown above.


2. On each PC, configure the default gateway as shown above.
3. On each ASW, configure the VLAN 1 interface with the appropriate IP address, and enable the interface.
Remove all VLAN interfaces except for VLAN 1.
4. On each ASW, configure the appropriate default gateway.
5. On each DSW, configure the VLAN interfaces with the appropriate IP addresses, and enable the inter-
faces.
6. Verify that each PC can successfully ping its default gateway.
7. Attempt to ping the VLAN 1 interface on the ASWs from the PCs. Were the pings successful? Why or why
not?
_________________________________________________________________
8. On each DSW, enable IP routing.
9. On each DSW, use the show protocols command to verify that IP routing is enabled.
10. From P1PC1, attempt to ping the VLAN 1 interface. The ping should now be successful.
11. On the DSWs, display the routing table to verify that all of the VLAN routes are present.
12. From P1PC1, attempt to ping P1PC2. Was the ping successful? Why or why not?
_________________________________________________________________
13. On each DSW, enable EIGRP. Use autonomous system number 100.
14. Display the routing tables on the DSWs to verify that the DSWs have learned the unknown networks.
15. From P1PC1, attempt to ping P2PC2. The ping should succeed. If it does not, try using the clear arp
command to clear P1PC1s ARP cache.

Lab Solutions
1. ipconfig /ip 172.16.11.1 255.255.255.0
2. ipconfig /dg 172.16.11.100
3. interface vlan 1
ip address 172.16.1.10 255.255.255.0
no shut
no interface vlan 11 (repeat for all VLAN interfaces except VLAN 1)
4. ip default-gateway 172.16.1.100
5. P1DSW1(config)#interface Vlan11
P1DSW1(config-if)#ip address 172.16.11.100 255.255.255.0
P1DSW1(config-if)#no shutdown

P2DSW2(config)#interface Vlan12
P2DSW2(config-if)#ip address 172.16.12.200 255.255.255.0
P2DSW2(config-if)#no shutdown

Boson NetSim for CCNP Lab Manual 163


BCMSN LAB 7
Layer 3 Switching

6. C:> 172.16.11.100

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 172.16.11.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

7. The pings fail because routing is not configured on the DSWs.


8. ip routing
9. P1DSW1#show protocols
Global values:
Internet Protocol routing is enabled

10. C:>ping 172.16.1.10

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

11. P1DSW1#show ip route


Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 5 subnets


C 172.16.11.0 is directly connected, Vlan11
C 172.16.1.0 is directly connected, Vlan1

P2DSW2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

164 Boson NetSim for CCNP Lab Manual


BCMSN LAB 7
Layer 3 Switching

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 5 subnets


C 172.16.12.0 is directly connected, Vlan12
C 172.16.1.0 is directly connected, Vlan1

12. The ping fails because the default gateway does not know a route to the destination network.
13. router eigrp 100
network 172.16.0.0

14. P1DSW1#show ip route


Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 3 subnets


D 172.16.12.0 [90/3072] via 172.16.1.200, 00:02:03, Vlan1
C 172.16.11.0 is directly connected, Vlan11
C 172.16.1.0 is directly connected, Vlan1

15. C:>ping 172.16.12.1

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

Boson NetSim for CCNP Lab Manual 165


BCMSN LAB 7
Layer 3 Switching

Sample Configuration Scripts


P1PC1 P1PC1 Router (Continued)
Version 12.1 ip classless
service timestamps debug uptime no ip http server
service timestamps log uptime !
no service password-encryption ip route 0.0.0.0 0.0.0.0 172.16.11.100
! !
hostname C: line con 0
! transport input none
ip subnet-zero line aux 0
! line vty 0 4
interface Ethernet0 !
ip address 172.16.11.1 255.255.255.0 no scheduler allocate
no ip directed-broadcast end
bandwidth 10000 exit
!
!

P1ASW1 P1ASW1 (Continued)


Version 12.1 !
service timestamps debug uptime interface FastEthernet0/6
service timestamps log uptime !
no service password-encryption interface FastEthernet0/7
! !
hostname P1ASW1 interface FastEthernet0/8
! !
ip subnet-zero interface FastEthernet0/9
spanning-tree extend system-id !
! interface FastEthernet0/10
! !
ip default-gateway 172.16.1.100 interface FastEthernet0/11
! !
interface FastEthernet0/1 interface FastEthernet0/12
description P1ASW1 to P1DSW1 !
switchport mode trunk vtp Server
switchport trunk encapsulation dot1q vtp domain bigdomain
! !
interface FastEthernet0/2 interface Vlan 1
description P1ASW1 to P1DSW1 ip address 172.16.1.10 255.255.255.0
switchport mode trunk no ip route-cache
switchport trunk encapsulation dot1q no shutdown
! !
interface FastEthernet0/3 vlan 11 name 11
description P1ASW1 to P2DSW2 !
switchport mode trunk ip default-gateway 172.16.1.100
switchport trunk encapsulation dot1q ip classless
! no ip http server
interface FastEthernet0/4 !
description P1ASW1 to P2DSW2 !
switchport mode trunk line con 0
switchport trunk encapsulation dot1q transport input none
! line aux 0
interface FastEthernet0/5 line vty 0 15
description P1PC1 to P1ASW1 !
switchport mode access no scheduler allocate
switchport access vlan 11 end

166 Boson NetSim for CCNP Lab Manual


BCMSN LAB 7
Layer 3 Switching

Sample Configuration Scripts


P1DSW1 P1DSW1 (Continued)
! interface FastEthernet0/12
Version 12.1 description P1DSW1 to P2DSW2
service timestamps debug uptime switchport mode trunk
service timestamps log uptime switchport trunk encapsulation dot1q
no service password-encryption !
! interface GigabitEthernet0/1
hostname P1DSW1 !
! interface GigabitEthernet0/2
! !
ip subnet-zero vtp Server
ip routing vtp domain bigdomain
spanning-tree extend system-id !
! interface Vlan 1
! ip address 172.16.1.100 255.255.255.0
interface FastEthernet0/1 no ip route-cache
description P1DSW1 to P1ASW1 no shutdown
switchport mode trunk !
switchport trunk encapsulation dot1q interface Vlan0011
! ip address 172.16.11.100 255.255.255.0
interface FastEthernet0/2 no ip route-cache
description P1DSW1 to P1ASW1 no shutdown
switchport mode trunk !
switchport trunk encapsulation dot1q !
! router eigrp 100
interface FastEthernet0/3 network 172.16.0.0
description P1DSW1 to P2ASW2 !
switchport mode trunk ip classless
switchport trunk encapsulation dot1q no ip http server
! !
interface FastEthernet0/4 line con 0
description P1DSW1 to P2ASW2 transport input none
switchport mode trunk line aux 0
switchport trunk encapsulation dot1q line vty 0 4
! !
interface FastEthernet0/5 no scheduler allocate
switchport mode access end
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
description P1DSW1 to P2DSW2
switchport mode trunk
switchport trunk encapsulation dot1q
!

Boson NetSim for CCNP Lab Manual 167

Вам также может понравиться